gnu Binary Utilities - Table of Contents

The GNU Binary Utilities

Version 980212

May 1993

Roland H. Pesch
Jeffrey M. Osier
Cygnus Support

  • ar
    • Controlling ar on the command line
    • Controlling ar with a script
  • ld
  • nm
  • objcopy
  • objdump
  • ranlib
  • size
  • strings
  • strip
  • c++filt
  • addr2line
  • nlmconv
  • windres
  • Selecting the target system
    • Target Selection
    • Architecture selection
    • Linker emulation selection
  • Reporting Bugs
    • Have you found a bug?
    • How to report bugs
  • Index

This document was generated on 4 March 1998 using the texi2html translator version 1.51.


The C Preprocessor - Table of Contents

The C Preprocessor

Last revised March 1997

for GCC version 2

Richard M. Stallman

  • The C Preprocessor
    • Transformations Made Globally
    • Preprocessing Directives
    • Header Files
      • Uses of Header Files
      • The `#include' Directive
      • How `#include' Works
      • Once-Only Include Files
      • Inheritance and Header Files
    • Macros
      • Simple Macros
      • Macros with Arguments
      • Predefined Macros
        • Standard Predefined Macros
        • Nonstandard Predefined Macros
      • Stringification
      • Concatenation
      • Undefining Macros
      • Redefining Macros
      • Pitfalls and Subtleties of Macros
        • Improperly Nested Constructs
        • Unintended Grouping of Arithmetic
        • Swallowing the Semicolon
        • Duplication of Side Effects
        • Self-Referential Macros
        • Separate Expansion of Macro Arguments
        • Cascaded Use of Macros
      • Newlines in Macro Arguments
    • Conditionals
      • Why Conditionals are Used
      • Syntax of Conditionals
        • The `#if' Directive
        • The `#else' Directive
        • The `#elif' Directive
      • Keeping Deleted Code for Future Reference
      • Conditionals and Macros
      • Assertions
      • The `#error' and `#warning' Directives
    • Combining Source Files
    • Miscellaneous Preprocessing Directives
    • C Preprocessor Output
    • Invoking the C Preprocessor
  • Concept Index
  • Index of Directives, Macros and Options

This document was generated on 4 March 1998 using the texi2html translator version 1.51.


Using and Porting GNU CC - Table of Contents

Using and Porting GNU CC

  • Compile C, C++, or Objective C
  • GNU CC Command Options
    • Option Summary
    • Options Controlling the Kind of Output
    • Compiling C++ Programs
    • Options Controlling C Dialect
    • Options Controlling C++ Dialect
    • Options to Request or Suppress Warnings
    • Options for Debugging Your Program or GNU CC
    • Options That Control Optimization
    • Options Controlling the Preprocessor
    • Passing Options to the Assembler
    • Options for Linking
    • Options for Directory Search
    • Specifying Target Machine and Compiler Version
    • Hardware Models and Configurations
      • M680x0 Options
      • VAX Options
      • SPARC Options
      • Convex Options
      • AMD29K Options
      • ARM Options
      • MN10300 Options
      • M32R/D Options
      • M88K Options
      • IBM RS/6000 and PowerPC Options
      • IBM RT Options
      • MIPS Options
      • Intel 386 Options
      • HPPA Options
      • Intel 960 Options
      • DEC Alpha Options
      • Clipper Options
      • H8/300 Options
      • SH Options
      • Options for System V
      • V850 Options
    • Options for Code Generation Conventions
    • Environment Variables Affecting GNU CC
    • Running Protoize
  • Installing GNU CC
    • Configurations Supported by GNU CC
    • Compilation in a Separate Directory
    • Building and Installing a Cross-Compiler
      • Steps of Cross-Compilation
      • Configuring a Cross-Compiler
      • Tools and Libraries for a Cross-Compiler
      • `libgcc.a' and Cross-Compilers
      • Cross-Compilers and Header Files
      • Actually Building the Cross-Compiler
    • Installing GNU CC on the Sun
    • Installing GNU CC on VMS
    • collect2
    • Standard Header File Directories
  • Extensions to the C Language Family
    • Statements and Declarations in Expressions
    • Locally Declared Labels
    • Labels as Values
    • Nested Functions
    • Constructing Function Calls
    • Naming an Expression's Type
    • Referring to a Type with typeof
    • Generalized Lvalues
    • Conditionals with Omitted Operands
    • Double-Word Integers
    • Complex Numbers
    • Arrays of Length Zero
    • Arrays of Variable Length
    • Macros with Variable Numbers of Arguments
    • Non-Lvalue Arrays May Have Subscripts
    • Arithmetic on void- and Function-Pointers
    • Non-Constant Initializers
    • Constructor Expressions
    • Labeled Elements in Initializers
    • Case Ranges
    • Cast to a Union Type
    • Declaring Attributes of Functions
    • Prototypes and Old-Style Function Definitions
    • C++ Style Comments
    • Dollar Signs in Identifier Names
    • The Character ESC in Constants
    • Inquiring on Alignment of Types or Variables
    • Specifying Attributes of Variables
    • Specifying Attributes of Types
    • An Inline Function is As Fast As a Macro
    • Assembler Instructions with C Expression Operands
    • Controlling Names Used in Assembler Code
    • Variables in Specified Registers
      • Defining Global Register Variables
      • Specifying Registers for Local Variables
    • Alternate Keywords
    • Incomplete enum Types
    • Function Names as Strings
    • Getting the Return or Frame Address of a Function
  • Extensions to the C++ Language
    • Named Return Values in C++
    • Minimum and Maximum Operators in C++
    • goto and Destructors in GNU C++
    • Declarations and Definitions in One Header
    • Where's the Template?
    • Type Abstraction using Signatures
  • gcov: a Test Coverage Program
    • Introduction to gcov
    • Invoking gcov
    • Using gcov with GCC Optimization
    • Brief description of gcov data files
  • Known Causes of Trouble with GNU CC
    • Actual Bugs We Haven't Fixed Yet
    • Installation Problems
    • Cross-Compiler Problems
    • Interoperation
    • Problems Compiling Certain Programs
    • Incompatibilities of GNU CC
    • Fixed Header Files
    • Standard Libraries
    • Disappointments and Misunderstandings
    • Common Misunderstandings with GNU C++
      • Declare and Define Static Members
      • Temporaries May Vanish Before You Expect
    • Caveats of using protoize
    • Certain Changes We Don't Want to Make
    • Warning Messages and Error Messages
  • Reporting Bugs
    • Have You Found a Bug?
    • Where to Report Bugs
    • How to Report Bugs
    • Sending Patches for GNU CC
  • How To Get Help with GNU CC
  • Contributing to GNU CC Development
  • Using GNU CC on VMS
    • Include Files and VMS
    • Global Declarations and VMS
    • Other VMS Issues
  • GNU CC and Portability
  • Interfacing to GNU CC Output
  • Passes and Files of the Compiler
  • RTL Representation
    • RTL Object Types
    • Access to Operands
    • Flags in an RTL Expression
    • Machine Modes
    • Constant Expression Types
    • Registers and Memory
    • RTL Expressions for Arithmetic
    • Comparison Operations
    • Bit Fields
    • Conversions
    • Declarations
    • Side Effect Expressions
    • Embedded Side-Effects on Addresses
    • Assembler Instructions as Expressions
    • Insns
    • RTL Representation of Function-Call Insns
    • Structure Sharing Assumptions
    • Reading RTL
  • Machine Descriptions
    • Everything about Instruction Patterns
    • Example of define_insn
    • RTL Template
    • Output Templates and Operand Substitution
    • C Statements for Assembler Output
    • Operand Constraints
      • Simple Constraints
      • Multiple Alternative Constraints
      • Register Class Preferences
      • Constraint Modifier Characters
      • Constraints for Particular Machines
      • Not Using Constraints
    • Standard Pattern Names For Generation
    • When the Order of Patterns Matters
    • Interdependence of Patterns
    • Defining Jump Instruction Patterns
    • Canonicalization of Instructions
    • Machine-Specific Peephole Optimizers
    • Defining RTL Sequences for Code Generation
    • Defining How to Split Instructions
    • Instruction Attributes
      • Defining Attributes and their Values
      • Attribute Expressions
      • Assigning Attribute Values to Insns
      • Example of Attribute Specifications
      • Computing the Length of an Insn
      • Constant Attributes
      • Delay Slot Scheduling
      • Specifying Function Units
  • Target Description Macros
    • Controlling the Compilation Driver, `gcc'
    • Run-time Target Specification
    • Storage Layout
    • Layout of Source Language Data Types
    • Register Usage
      • Basic Characteristics of Registers
      • Order of Allocation of Registers
      • How Values Fit in Registers
      • Handling Leaf Functions
      • Registers That Form a Stack
      • Obsolete Macros for Controlling Register Usage
    • Register Classes
    • Stack Layout and Calling Conventions
      • Basic Stack Layout
      • Specifying How Stack Checking is Done
      • Registers That Address the Stack Frame
      • Eliminating Frame Pointer and Arg Pointer
      • Passing Function Arguments on the Stack
      • Passing Arguments in Registers
      • How Scalar Function Values Are Returned
      • How Large Values Are Returned
      • Caller-Saves Register Allocation
      • Function Entry and Exit
      • Generating Code for Profiling
    • Implementing the Varargs Macros
    • Trampolines for Nested Functions
    • Implicit Calls to Library Routines
    • Addressing Modes
    • Condition Code Status
    • Describing Relative Costs of Operations
    • Dividing the Output into Sections (Texts, Data, ...)
    • Position Independent Code
    • Defining the Output Assembler Language
      • The Overall Framework of an Assembler File
      • Output of Data
      • Output of Uninitialized Variables
      • Output and Generation of Labels
      • How Initialization Functions Are Handled
      • Macros Controlling Initialization Routines
      • Output of Assembler Instructions
      • Output of Dispatch Tables
      • Assembler Commands for Exception Regions
      • Assembler Commands for Alignment
    • Controlling Debugging Information Format
      • Macros Affecting All Debugging Formats
      • Specific Options for DBX Output
      • Open-Ended Hooks for DBX Format
      • File Names in DBX Format
      • Macros for SDB and DWARF Output
    • Cross Compilation and Floating Point
    • Miscellaneous Parameters
  • The Configuration File
  • Makefile Fragments
    • The Target Makefile Fragment
    • The Host Makefile Fragment
  • Funding Free Software
  • Protect Your Freedom--Fight "Look And Feel"
  • GNU GENERAL PUBLIC LICENSE
    • Preamble
    • TERMS AND CONDITIONS FOR COPYING, DISTRIBUTION AND MODIFICATION
    • How to Apply These Terms to Your New Programs
  • Contributors to GNU CC
  • Index

This document was generated on 22 March 1998 using the texi2html translator version 1.52.


Using as - Table of Contents

Using as

The GNU Assembler

January 1994

Dean Elsner, Jay Fenlason & friends

  • Overview
    • Structure of this Manual
    • The GNU Assembler
    • Object File Formats
    • Command Line
    • Input Files
    • Output (Object) File
    • Error and Warning Messages
  • Command-Line Options
    • Enable Listings: -a[cdhlns]
    • -D
    • Work Faster: -f
    • .include search path: -I path
    • Difference Tables: -K
    • Include Local Labels: -L
    • Assemble in MRI Compatibility Mode: -M
    • Dependency tracking: --MD
    • Name the Object File: -o
    • Join Data and Text Sections: -R
    • Display Assembly Statistics: --statistics
    • Announce Version: -v
    • Suppress Warnings: -W
    • Generate Object File in Spite of Errors: -Z
  • Syntax
    • Preprocessing
    • Whitespace
    • Comments
    • Symbols
    • Statements
    • Constants
      • Character Constants
        • Strings
        • Characters
      • Number Constants
        • Integers
        • Bignums
        • Flonums
  • Sections and Relocation
    • Background
    • Linker Sections
    • Assembler Internal Sections
    • Sub-Sections
    • bss Section
  • Symbols
    • Labels
    • Giving Symbols Other Values
    • Symbol Names
    • The Special Dot Symbol
    • Symbol Attributes
      • Value
      • Type
      • Symbol Attributes: a.out
        • Descriptor
        • Other
      • Symbol Attributes for COFF
        • Primary Attributes
        • Auxiliary Attributes
      • Symbol Attributes for SOM
  • Expressions
    • Empty Expressions
    • Integer Expressions
      • Arguments
      • Operators
      • Prefix Operator
      • Infix Operators
  • Assembler Directives
    • .abort
    • .ABORT
    • .align abs-expr, abs-expr, abs-expr
    • .app-file string
    • .ascii "string"...
    • .asciz "string"...
    • .balign[wl] abs-expr, abs-expr, abs-expr
    • .byte expressions
    • .comm symbol , length
    • .data subsection
    • .def name
    • .desc symbol, abs-expression
    • .dim
    • .double flonums
    • .eject
    • .else
    • .endef
    • .endif
    • .equ symbol, expression
    • .equiv symbol, expression
    • .err
    • .extern
    • .file string
    • .fill repeat , size , value
    • .float flonums
    • .global symbol, .globl symbol
    • .hword expressions
    • .ident
    • .if absolute expression
    • .include "file"
    • .int expressions
    • .irp symbol,values...
    • .irpc symbol,values...
    • .lcomm symbol , length
    • .lflags
    • .line line-number
    • .linkonce [type]
    • .ln line-number
    • .mri val
    • .list
    • .long expressions
    • .macro
    • .nolist
    • .octa bignums
    • .org new-lc , fill
    • .p2align[wl] abs-expr, abs-expr, abs-expr
    • .psize lines , columns
    • .quad bignums
    • .rept count
    • .sbttl "subheading"
    • .scl class
    • .section name
    • .set symbol, expression
    • .short expressions
    • .single flonums
    • .size
    • .sleb128 expressions
    • .skip size , fill
    • .space size , fill
    • .stabd, .stabn, .stabs
    • .string "str"
    • .symver
    • .tag structname
    • .text subsection
    • .title "heading"
    • .type int
    • .val addr
    • .uleb128 expressions
    • .word expressions
    • Deprecated Directives
  • Machine Dependent Features
  • ARC Dependent Features
    • Options
    • Floating Point
    • ARC Machine Directives
  • AMD 29K Dependent Features
    • Options
    • Syntax
      • Macros
      • Special Characters
      • Register Names
    • Floating Point
    • AMD 29K Machine Directives
    • Opcodes
  • ARM Dependent Features
    • Options
    • Syntax
      • Special Characters
      • Register Names
    • Floating Point
    • ARM Machine Directives
    • Opcodes
  • D10V Dependent Features
    • D10V Options
    • Syntax
      • Size Modifiers
      • Sub-Instructions
      • Special Characters
      • Register Names
      • Addressing Modes
      • @WORD Modifier
    • Floating Point
    • Opcodes
  • H8/300 Dependent Features
    • Options
    • Syntax
      • Special Characters
      • Register Names
      • Addressing Modes
    • Floating Point
    • H8/300 Machine Directives
    • Opcodes
  • H8/500 Dependent Features
    • Options
    • Syntax
      • Special Characters
      • Register Names
      • Addressing Modes
    • Floating Point
    • H8/500 Machine Directives
    • Opcodes
  • HPPA Dependent Features
    • Notes
    • Options
    • Syntax
    • Floating Point
    • HPPA Assembler Directives
    • Opcodes
  • 80386 Dependent Features
    • Options
    • AT&T Syntax versus Intel Syntax
    • Opcode Naming
    • Register Naming
    • Opcode Prefixes
    • Memory References
    • Handling of Jump Instructions
    • Floating Point
    • Writing 16-bit Code
    • Notes
  • Intel 80960 Dependent Features
    • i960 Command-line Options
    • Floating Point
    • i960 Machine Directives
    • i960 Opcodes
      • callj
      • Compare-and-Branch
  • M680x0 Dependent Features
    • M680x0 Options
    • Syntax
    • Motorola Syntax
    • Floating Point
    • 680x0 Machine Directives
    • Opcodes
      • Branch Improvement
      • Special Characters
  • MIPS Dependent Features
    • Assembler options
    • MIPS ECOFF object code
    • Directives for debugging information
    • Directives to override the ISA level
    • Directives for extending MIPS 16 bit instructions
    • Directive to mark data as an instruction
    • Directives to save and restore options
  • Hitachi SH Dependent Features
    • Options
    • Syntax
      • Special Characters
      • Register Names
      • Addressing Modes
    • Floating Point
    • SH Machine Directives
    • Opcodes
  • SPARC Dependent Features
    • Options
    • Enforcing aligned data
    • Floating Point
    • Sparc Machine Directives
  • Z8000 Dependent Features
    • Options
    • Syntax
      • Special Characters
      • Register Names
      • Addressing Modes
    • Assembler Directives for the Z8000
    • Opcodes
  • VAX Dependent Features
    • VAX Command-Line Options
    • VAX Floating Point
    • Vax Machine Directives
    • VAX Opcodes
    • VAX Branch Improvement
    • VAX Operands
    • Not Supported on VAX
  • v850 Dependent Features
    • Options
    • Syntax
      • Special Characters
      • Register Names
    • Floating Point
    • V850 Machine Directives
    • Opcodes
  • Reporting Bugs
    • Have you found a bug?
    • How to report bugs
  • Acknowledgements
  • Index

This document was generated on 22 March 1998 using the texi2html translator version 1.52.


GASP - Table of Contents

GASP, an assembly preprocessor

for GASP version 1

March 1994

Roland Pesch

  • What is GASP?
  • Command Line Options
  • Preprocessor Commands
    • Conditional assembly
    • Repetitive sections of assembly
    • Preprocessor variables
    • Defining your own directives
    • Data output
      • Initialized data
      • Uninitialized data
    • Assembly listing control
    • Miscellaneous commands
    • Details of the GASP syntax
      • Special syntactic markers
      • String and numeric constants
      • Symbols
      • Arithmetic expressions in GASP
      • String primitives
    • Alternate macro syntax
  • Index

This document was generated on 4 March 1998 using the texi2html translator version 1.51.


Using LD, the GNU linker - Table of Contents

Using ld

The GNU linker

ld version 2

January 1994

Steve Chamberlain
Cygnus Support

  • Overview
  • Invocation
    • Command Line Options
    • Environment Variables
  • Command Language
    • Linker Scripts
    • Expressions
      • Integers
      • Symbol Names
      • The Location Counter
      • Operators
      • Evaluation
      • Assignment: Defining Symbols
      • Arithmetic Functions
      • Semicolons
    • Memory Layout
    • Specifying Output Sections
      • Section Definitions
      • Section Placement
      • Section Data Expressions
      • Optional Section Attributes
      • Overlays
    • ELF Program Headers
    • The Entry Point
    • Version Script
    • Option Commands
  • Machine Dependent Features
    • ld and the H8/300
    • ld and the Intel 960 family
  • BFD
    • How it works: an outline of BFD
      • Information Loss
      • The BFD canonical object-file format
  • Reporting Bugs
    • Have you found a bug?
    • How to report bugs
  • MRI Compatible Script Files
  • Index

This document was generated on 9 March 1998 using the texi2html translator version 1.51.


Cygnus C Support Library, Full - Table of Contents

The Cygnus C Support Library

Full Configuration

libc 1.4

May 1993

{Steve Chamberlain}
{Roland Pesch}
{Cygnus Support}

  • Standard Utility Functions (`stdlib.h')
    • abort---abnormal termination of a program
    • abs---integer absolute value (magnitude)
    • assert---Macro for Debugging Diagnostics
    • atexit---request execution of functions at program exit
    • atof, atoff---string to double or float
    • atoi, atol---string to integer
    • bsearch---binary search
    • calloc---allocate space for arrays
    • div---divide two integers
    • ecvt,ecvtf,fcvt,fcvtf---double or float to string
    • gvcvt, gcvtf---format double or float as string
    • ecvtbuf, fcvtbuf---double or float to string
    • exit---end program execution
    • getenv---look up environment variable
    • labs---long integer absolute value
    • ldiv---divide two long integers
    • malloc, realloc, free---manage memory
    • mbtowc---minimal multibyte to wide char converter
    • qsort---sort an array
    • rand, srand---pseudo-random numbers
    • strtod, strtodf---string to double or float
    • strtol---string to long
    • strtoul---string to unsigned long
    • system---execute command string
    • wctomb---minimal wide char to multibyte converter
  • Character Type Macros and Functions (`ctype.h')
    • isalnum---alphanumeric character predicate
    • isalpha---alphabetic character predicate
    • isascii---ASCII character predicate
    • iscntrl---control character predicate
    • isdigit---decimal digit predicate
    • islower---lower-case character predicate
    • isprint, isgraph---printable character predicates
    • ispunct---punctuation character predicate
    • isspace---whitespace character predicate
    • isupper---uppercase character predicate
    • isxdigit---hexadecimal digit predicate
    • toascii---force integers to ASCII range
    • tolower---translate characters to lower case
    • toupper---translate characters to upper case
  • Input and Output (`stdio.h')
    • clearerr---clear file or stream error indicator
    • fclose---close a file
    • feof---test for end of file
    • ferror---test whether read/write error has occurred
    • fflush---flush buffered file output
    • fgetc---get a character from a file or stream
    • fgetpos---record position in a stream or file
    • fgets---get character string from a file or stream
    • fiprintf---format output to file (integer only)
    • fopen---open a file
    • fdopen---turn open file into a stream
    • fputc---write a character on a stream or file
    • fputs---write a character string in a file or stream
    • fread---read array elements from a file
    • freopen---open a file using an existing file descriptor
    • fseek---set file position
    • fsetpos---restore position of a stream or file
    • ftell---return position in a stream or file
    • fwrite---write array elements
    • getc---read a character (macro)
    • getchar---read a character (macro)
    • gets---get character string (obsolete, use fgets instead)
    • iprintf---write formatted output (integer only)
    • mktemp, mkstemp---generate unused file name
    • perror---print an error message on standard error
    • putc---write a character (macro)
    • putchar---write a character (macro)
    • puts---write a character string
    • remove---delete a file's name
    • rename---rename a file
    • rewind---reinitialize a file or stream
    • setbuf---specify full buffering for a file or stream
    • setvbuf---specify file or stream buffering
    • siprintf---write formatted output (integer only)
    • printf, fprintf, sprintf---format output
    • scanf, fscanf, sscanf---scan and format input
    • tmpfile---create a temporary file
    • tmpnam, tempnam---name for a temporary file
    • vprintf, vfprintf, vsprintf---format argument list
  • Strings and Memory (`string.h')
    • bcmp---compare two memory areas
    • bcopy---copy memory regions
    • bzero---initialize memory to zero
    • index---search for character in string
    • memchr---find character in memory
    • memcmp---compare two memory areas
    • memcpy---copy memory regions
    • memmove---move possibly overlapping memory
    • memset---set an area of memory
    • rindex---reverse search for character in string
    • strcat---concatenate strings
    • strchr---search for character in string
    • strcmp---character string compare
    • strcoll---locale specific character string compare
    • strcpy---copy string
    • strcspn---count chars not in string
    • strerror---convert error number to string
    • strlen---character string length
    • strlwr---force string to lower case
    • strncat---concatenate strings
    • strncmp---character string compare
    • strncpy---counted copy string
    • strpbrk---find chars in string
    • strrchr---reverse search for character in string
    • strspn---find initial match
    • strstr---find string segment
    • strtok---get next token from a string
    • strupr---force string to uppercase
    • strxfrm---transform string
  • Signal Handling (`signal.h')
    • raise---send a signal
    • signal---specify handler subroutine for a signal
  • Time Functions (`time.h')
    • asctime---format time as string
    • clock---cumulative processor time
    • ctime---convert time to local and format as string
    • difftime---subtract two times
    • gmtime---convert time to UTC traditional form
    • localtime---convert time to local representation
    • mktime---convert time to arithmetic representation
    • strftime---flexible calendar time formatter
    • time---get current calendar time (as single number)
  • Locale (`locale.h')
    • setlocale, localeconv---select or query locale
  • Reentrancy
  • Miscellaneous Macros and Functions
    • unctrl---translate characters to upper case
  • System Calls
    • Definitions for OS interface
    • Reentrant covers for OS subroutines
  • Variable Argument Lists
    • ANSI-standard macros, `stdarg.h'
      • Initialize variable argument list
      • Extract a value from argument list
      • Abandon a variable argument list
    • Traditional macros, `varargs.h'
      • Declare variable arguments
      • Initialize variable argument list
      • Extract a value from argument list
      • Abandon a variable argument list
  • Index

This document was generated on 22 March 1998 using the texi2html translator version 1.52.


Cygnus C Math Library - Table of Contents

The Cygnus C Math Library

libm 1.4

December 1995

{Steve Chamberlain}
{Roland Pesch}
{Cygnus Support}

  • Mathematical Functions (`math.h')
    • Version of library
    • acos, acosf---arc cosine
    • acosh, acoshf---inverse hyperbolic cosine
    • asin, asinf---arc sine
    • asinh, asinhf---inverse hyperbolic sine
    • atan, atanf---arc tangent
    • atan2, atan2f---arc tangent of y/x
    • atanh, atanhf---inverse hyperbolic tangent
    • jN,jNf,yN,yNf---Bessel functions
    • cbrt, cbrtf---cube root
    • copysign, copysignf---sign of y, magnitude of x
    • cosh, coshf---hyperbolic cosine
    • erf, erff, erfc, erfcf---error function
    • exp, expf---exponential
    • expm1, expm1f---exponential minus 1
    • fabs, fabsf---absolute value (magnitude)
    • floor, floorf, ceil, ceilf---floor and ceiling
    • fmod, fmodf---floating-point remainder (modulo)
    • frexp, frexpf---split floating-point number
    • gamma, gammaf, lgamma, lgammaf, gamma_r,
    • hypot, hypotf---distance from origin
    • ilogb, ilogbf---get exponent of floating point number
    • infinity, infinityf---representation of infinity
    • isnan,isnanf,isinf,isinff,finite,finitef---test for exceptional numbers
    • ldexp, ldexpf---load exponent
    • log, logf---natural logarithms
    • log10, log10f---base 10 logarithms
    • log1p, log1pf---log of 1 + x
    • matherr---modifiable math error handler
    • modf, modff---split fractional and integer parts
    • nan, nanf---representation of infinity
    • nextafter, nextafterf---get next number
    • pow, powf---x to the power y
    • rint, rintf, remainder, remainderf---round and remainder
    • scalbn, scalbnf---scale by integer
    • sqrt, sqrtf---positive square root
    • sin, sinf, cos, cosf---sine or cosine
    • sinh, sinhf---hyperbolic sine
    • tan, tanf---tangent
    • tanh, tanhf---hyperbolic tangent
  • Reentrancy Properties of libm
  • Index

This document was generated on 22 March 1998 using the texi2html translator version 1.52.


Embed with GNU - Table of Contents

Embed With GNU

Porting The GNU Tools To Embedded Systems

Spring 1995

Very *Rough* Draft

Rob Savoye - Cygnus Support

  • Libgloss
      • Supported Targets
      • Sparclite Targets Supported
      • Motorola CPU32 Targets supported
      • Mips core Targets Supported
      • PA-RISC Targets Supported
      • Configuring and building libgloss.
  • Porting GCC
      • Compilation passes
  • Porting newlib
    • Crt0, the main startup file
    • Linker scripts for memory management
    • What to do when you have a binary image
    • Libraries
      • Making I/O work
      • Routines for dynamic memory allocation
      • Misc support routines
      • Useful debugging functions
  • Writing a new GDB backend
    • The standard remote protocol
    • A linked in exception handler
    • Using a ROM monitor as a backend
    • Adding support for new protocols
  • Code Listings
    • Linker script for the IDP board
    • crt0.S - The startup file
    • C based "glue" code.
    • I/O assembler code sample
    • I/O code sample
    • Led control sample

This document was generated on 4 March 1998 using the texi2html translator version 1.51.


ColdFire Development Resources

Documentation

The idea of this section is that it will contain all you need both to learn and keep up to date with the ColdFire architechture. I'll be putting GNU documentation here intitially but if you have anything from a full blown article to hints and tips or code snippets this send them to me.

GNU C documentation

Here's some basic GCC cross development documentation. All the words are OK but the layout and organisation is not quite as good as I wold hope.

  • Bintuils-2.8.1.0.18
  • cpp - C pre processor
  • gcc(EGCS-980228 or thereabouts)
  • gasp - gas pre processor
  • as - GNU assembler
  • ld - GNU linker
  • Newlib-1.8.0 - libc
  • Newlib-1.8.0 - libm
  • Porting Newlib & gcc to new boards/processors
[Home]
Copyright (c) 1997-98 David J. Fiddes.


Using as - Overview

 Go to the first, previous, next, last section, table of contents.

The Free Software Foundation Inc. thanks The Nice Computer Company of Australia for loaning Dean Elsner to write the first (Vax) version of as for Project GNU. The proprietors, management and staff of TNCCA thank FSF for distracting the boss while they got some work done.

Copyright (C) 1991, 92, 93, 94, 95, 96, 1997 Free Software Foundation, Inc.

Permission is granted to make and distribute verbatim copies of this manual provided the copyright notice and this permission notice are preserved on all copies.

Permission is granted to copy and distribute modified versions of this manual under the conditions for verbatim copying, provided that the entire resulting derived work is distributed under the terms of a permission notice identical to this one.

Permission is granted to copy and distribute translations of this manual into another language, under the above conditions for modified versions.

Overview

This manual is a user guide to the GNU assembler as.

Here is a brief summary of how to invoke as. For details, see section Command-Line Options.

as [ -a[cdhlns][=file] ] [ -D ]  [ --defsym sym=val ]
 [ -f ] [ --gstabs ] [ --help ] [ -I dir ] [ -J ] [ -K ] [ -L ]
 [ -o objfile ] [ -R ] [ --statistics ] [ -v ] [ -version ]
 [ --version ] [ -W ] [ -w ] [ -x ] [ -Z ]
 [ -mbig-endian | -mlittle-endian ]
 [ -m[arm]1 | -m[arm]2 | -m[arm]250 | -m[arm]3 | -m[arm]6 | -m[arm]7[t][[d]m[i]] ]
 [ -m[arm]v2 | -m[arm]v2a | -m[arm]v3 | -m[arm]v3m | -m[arm]v4 | -m[arm]v4t ]
 [ -mthumb | -mall ]
 [ -mfpa10 | -mfpa11 | -mfpe-old | -mno-fpu ]
 [ -EB | -EL ]
 [ -mapcs-32 | -mapcs-26 ]
 [ -O ]

 [ -Av6 | -Av7 | -Av8 | -Asparclet | -Asparclite
   -Av8plus | -Av8plusa | -Av9 | -Av9a ]
 [ -xarch=v8plus | -xarch=v8plusa ] [ -bump ] [ -32 | -64 ]
 [ -ACA | -ACA_A | -ACB | -ACC | -AKA | -AKB | -AKC | -AMC ]
 [ -b ] [ -no-relax ]
 [ -l ] [ -m68000 | -m68010 | -m68020 | ... ]
 [ -nocpp ] [ -EL ] [ -EB ] [ -G num ] [ -mcpu=CPU ]
 [ -mips1 ] [ -mips2 ] [ -mips3 ] [ -m4650 ] [ -no-m4650 ]
 [ --trap ] [ --break ]
 [ --emulation=name ]
 [ -- | files ... ]
-a[cdhlmns]
Turn on listings, in any of a variety of ways:
-ac
omit false conditionals
-ad
omit debugging directives
-ah
include high-level source
-al
include assembly
-am
include macro expansions
-an
omit forms processing
-as
include symbols
=file
set the name of the listing file
You may combine these options; for example, use `-aln' for assembly listing without forms processing. The `=file' option, if used, must be the last one. By itself, `-a' defaults to `-ahls'.
-D
Ignored. This option is accepted for script compatibility with calls to other assemblers.
--defsym sym=value
Define the symbol sym to be value before assembling the input file. value must be an integer constant. As in C, a leading `0x' indicates a hexadecimal value, and a leading `0' indicates an octal value.
-f
"fast"---skip whitespace and comment preprocessing (assume source is compiler output).
--gstabs
Generate stabs debugging information for each assembler line. This may help debugging assembler code, if the debugger can handle it.
--help
Print a summary of the command line options and exit.
-I dir
Add directory dir to the search list for .include directives.
-J
Don't warn about signed overflow.
-K
Issue warnings when difference tables altered for long displacements.
-L
Keep (in the symbol table) local symbols, starting with `L'.
-o objfile
Name the object-file output from as objfile.
-R
Fold the data section into the text section.
--statistics
Print the maximum space (in bytes) and total time (in seconds) used by assembly.
-v
-version
Print the as version.
--version
Print the as version and exit.
-W
Suppress warning messages.
-w
Ignored.
-x
Ignored.
-Z
Generate an object file even after errors.
-- | files ...
Standard input, or source files to assemble.

The following options are available when as is configured for an ARC processor.

-mbig-endian
Generate "big endian" format output.
-mlittle-endian
Generate "little endian" format output.

The following options are available when as is configured for the ARM processor family.

-m[arm]1 | -m[arm]2 | -m[arm]250 | -m[arm]3 | -m[arm]6 | -m[arm]7[t][[d]m] | -m[arm]v2 | -m[arm]v2a | -m[arm]v3 | -m[arm]v3m | -m[arm]v4 | -m[arm]v4t
Specify which variant of the ARM architecture is the target.
-mthumb | -mall
Enable or disable Thumb only instruction decoding.
-mfpa10 | -mfpa11 | -mfpe-old | -mno-fpu
Select which Floating Point architcture is the target.
-mapcs-32 | -mapcs-26
Select which procedure calling convention is in use.
-EB | -EL
Select either big-endian (-EB) or little-endian (-EL) output.

The following options are available when as is configured for a D10V processor.

-O
Optimize output by parallelizing instructions.

The following options are available when as is configured for the Intel 80960 processor.

-ACA | -ACA_A | -ACB | -ACC | -AKA | -AKB | -AKC | -AMC
Specify which variant of the 960 architecture is the target.
-b
Add code to collect statistics about branches taken.
-no-relax
Do not alter compare-and-branch instructions for long displacements; error if necessary.

The following options are available when as is configured for the Motorola 68000 series.

-l
Shorten references to undefined symbols, to one word instead of two.
-m68000 | -m68008 | -m68010 | -m68020 | -m68030 | -m68040 | -m68060
| -m68302 | -m68331 | -m68332 | -m68333 | -m68340 | -mcpu32 | -m5200
Specify what processor in the 68000 family is the target. The default is normally the 68020, but this can be changed at configuration time.
-m68881 | -m68882 | -mno-68881 | -mno-68882
The target machine does (or does not) have a floating-point coprocessor. The default is to assume a coprocessor for 68020, 68030, and cpu32. Although the basic 68000 is not compatible with the 68881, a combination of the two can be specified, since it's possible to do emulation of the coprocessor instructions with the main processor.
-m68851 | -mno-68851
The target machine does (or does not) have a memory-management unit coprocessor. The default is to assume an MMU for 68020 and up.

The following options are available when as is configured for the SPARC architecture:

-Av6 | -Av7 | -Av8 | -Asparclet | -Asparclite
-Av8plus | -Av8plusa | -Av9 | -Av9a
Explicitly select a variant of the SPARC architecture. `-Av8plus' and `-Av8plusa' select a 32 bit environment. `-Av9' and `-Av9a' select a 64 bit environment. `-Av8plusa' and `-Av9a' enable the SPARC V9 instruction set with UltraSPARC extensions.
-xarch=v8plus | -xarch=v8plusa
For compatibility with the Solaris v9 assembler. These options are equivalent to -Av8plus and -Av8plusa, respectively.
-bump
Warn when the assembler switches to another architecture.

The following options are available when as is configured for a MIPS processor.

-G num
This option sets the largest size of an object that can be referenced implicitly with the gp register. It is only accepted for targets that use ECOFF format, such as a DECstation running Ultrix. The default value is 8.
-EB
Generate "big endian" format output.
-EL
Generate "little endian" format output.
-mips1
-mips2
-mips3
Generate code for a particular MIPS Instruction Set Architecture level. `-mips1' corresponds to the R2000 and R3000 processors, `-mips2' to the R6000 processor, and `-mips3' to the R4000 processor.
-m4650
-no-m4650
Generate code for the MIPS R4650 chip. This tells the assembler to accept the `mad' and `madu' instruction, and to not schedule `nop' instructions around accesses to the `HI' and `LO' registers. `-no-m4650' turns off this option.
-mcpu=CPU
Generate code for a particular MIPS cpu. This has little effect on the assembler, but it is passed by gcc.
--emulation=name
This option causes as to emulate as configured for some other target, in all respects, including output format (choosing between ELF and ECOFF only), handling of pseudo-opcodes which may generate debugging information or store symbol table information, and default endianness. The available configuration names are: `mipsecoff', `mipself', `mipslecoff', `mipsbecoff', `mipslelf', `mipsbelf'. The first two do not alter the default endianness from that of the primary target for which the assembler was configured; the others change the default to little- or big-endian as indicated by the `b' or `l' in the name. Using `-EB' or `-EL' will override the endianness selection in any case. This option is currently supported only when the primary target as is configured for is a MIPS ELF or ECOFF target. Furthermore, the primary target or others specified with `--enable-targets=...' at configuration time must include support for the other format, if both are to be available. For example, the Irix 5 configuration includes support for both. Eventually, this option will support more configurations, with more fine-grained control over the assembler's behavior, and will be supported for more processors.
-nocpp
as ignores this option. It is accepted for compatibility with the native tools.
--trap
--no-trap
--break
--no-break
Control how to deal with multiplication overflow and division by zero. `--trap' or `--no-break' (which are synonyms) take a trap exception (and only work for Instruction Set Architecture level 2 and higher); `--break' or `--no-trap' (also synonyms, and the default) take a break exception.

Go to the first, previous, next, last section, table of contents.


Using as - Manual

Structure of this Manual

This manual is intended to describe what you need to know to use GNU as. We cover the syntax expected in source files, including notation for symbols, constants, and expressions; the directives that as understands; and of course how to invoke as.

This manual also describes some of the machine-dependent features of various flavors of the assembler.

On the other hand, this manual is not intended as an introduction to programming in assembly language--let alone programming in general! In a similar vein, we make no attempt to introduce the machine architecture; we do not describe the instruction set, standard mnemonics, registers or addressing modes that are standard to a particular architecture. You may want to consult the manufacturer's machine architecture manual for this information.


Using as - GNU Assembler

The GNU Assembler

GNU as is really a family of assemblers. If you use (or have used) the GNU assembler on one architecture, you should find a fairly similar environment when you use it on another architecture. Each version has much in common with the others, including object file formats, most assembler directives (often called pseudo-ops) and assembler syntax.

as is primarily intended to assemble the output of the GNU C compiler gcc for use by the linker ld. Nevertheless, we've tried to make as assemble correctly everything that other assemblers for the same machine would assemble. Any exceptions are documented explicitly (see section Machine Dependent Features). This doesn't mean as always uses the same syntax as another assembler for the same architecture; for example, we know of several incompatible versions of 680x0 assembly language syntax.

Unlike older assemblers, as is designed to assemble a source program in one pass of the source file. This has a subtle impact on the .org directive (see section .org new-lc , fill).


Using as - Object Formats

Object File Formats

The GNU assembler can be configured to produce several alternative object file formats. For the most part, this does not affect how you write assembly language programs; but directives for debugging symbols are typically different in different file formats. See section Symbol Attributes. On the machine specific, as can be configured to produce either a.out or COFF format object files. On the machine specific, as can be configured to produce either b.out or COFF format object files. On the machine specific, as can be configured to produce either SOM or ELF format object files.


Using as - Command Line

Command Line

After the program name as, the command line may contain options and file names. Options may appear in any order, and may be before, after, or between file names. The order of file names is significant.

`--' (two hyphens) by itself names the standard input file explicitly, as one of the files for as to assemble.

Except for `--' any command line argument that begins with a hyphen (`-') is an option. Each option changes the behavior of as. No option changes the way another option works. An option is a `-' followed by one or more letters; the case of the letter is important. All options are optional.

Some options expect exactly one file name to follow them. The file name may either immediately follow the option's letter (compatible with older assemblers) or it may be the next command argument (GNU standard). These two command lines are equivalent:

as -o my-object-file.o mumble.s
as -omy-object-file.o mumble.s


Using as - Input Files

Input Files

We use the phrase source program, abbreviated source, to describe the program input to one run of as. The program may be in one or more files; how the source is partitioned into files doesn't change the meaning of the source.

The source program is a concatenation of the text in all the files, in the order specified.

Each time you run as it assembles exactly one source program. The source program is made up of one or more files. (The standard input is also a file.)

You give as a command line that has zero or more input file names. The input files are read (from left file name to right). A command line argument (in any position) that has no special meaning is taken to be an input file name.

If you give as no file names it attempts to read one input file from the as standard input, which is normally your terminal. You may have to type ctl-D to tell as there is no more program to assemble.

Use `--' if you need to explicitly name the standard input file in your command line.

If the source is empty, as produces a small, empty object file.

Filenames and Line-numbers

There are two ways of locating a line in the input file (or files) and either may be used in reporting error messages. One way refers to a line number in a physical file; the other refers to a line number in a "logical" file. See section Error and Warning Messages.

Physical files are those files named in the command line given to as.

Logical files are simply names declared explicitly by assembler directives; they bear no relation to physical files. Logical file names help error messages reflect the original source file, when as source is itself synthesized from other files. See section .app-file string.


Using as - Object

Output (Object) File

Every time you run as it produces an output file, which is your assembly language program translated into numbers. This file is the object file. Its default name is a.out, or b.out when as is configured for the Intel 80960. You can give it another name by using the -o option. Conventionally, object file names end with `.o'. The default name is used for historical reasons: older assemblers were capable of assembling self-contained programs directly into a runnable program. (For some formats, this isn't currently possible, but it can be done for the a.out format.)

The object file is meant for input to the linker ld. It contains assembled program code, information to help ld integrate the assembled program into a runnable file, and (optionally) symbolic information for the debugger.


Using as - Errors

Error and Warning Messages

as may write warnings and error messages to the standard error file (usually your terminal). This should not happen when a compiler runs as automatically. Warnings report an assumption made so that as could keep assembling a flawed program; errors report a grave problem that stops the assembly.

Warning messages have the format

file_name:NNN:Warning Message Text

(where NNN is a line number). If a logical file name has been given (see section .app-file string) it is used for the filename, otherwise the name of the current input file is used. If a logical line number was given (see section .line line-number) (see section .ln line-number) then it is used to calculate the number printed, otherwise the actual line in the current source file is printed. The message text is intended to be self explanatory (in the grand Unix tradition).

Error messages have the format

file_name:NNN:FATAL:Error Message Text

The file name and line number are derived as for warning messages. The actual message text may be rather less explanatory because many of them aren't supposed to happen.


Using as - Invoking

Command-Line Options

This chapter describes command-line options available in all versions of the GNU assembler; see section Machine Dependent Features, for options specific to particular machine architectures.

If you are invoking as via the GNU C compiler (version 2), you can use the `-Wa' option to pass arguments through to the assembler. The assembler arguments must be separated from each other (and the `-Wa') by commas. For example:

gcc -c -g -O -Wa,-alh,-L file.c

emits a listing to standard output with high-level and assembly source.

Usually you do not need to use this `-Wa' mechanism, since many compiler command-line options are automatically passed to the assembler by the compiler. (You can call the GNU compiler driver with the `-v' option to see precisely what options it passes to each compilation pass, including the assembler.)


Using as - a

Enable Listings: -a[cdhlns]

These options enable listing output from the assembler. By itself, `-a' requests high-level, assembly, and symbols listing. You can use other letters to select specific options for the list: `-ah' requests a high-level language listing, `-al' requests an output-program assembly listing, and `-as' requests a symbol table listing. High-level listings require that a compiler debugging option like `-g' be used, and that assembly listings (`-al') be requested also.

Use the `-ac' option to omit false conditionals from a listing. Any lines which are not assembled because of a false .if (or .ifdef, or any other conditional), or a true .if followed by an .else, will be omitted from the listing.

Use the `-ad' option to omit debugging directives from the listing.

Once you have specified one of these options, you can further control listing output and its appearance using the directives .list, .nolist, .psize, .eject, .title, and .sbttl. The `-an' option turns off all forms processing. If you do not request listing output with one of the `-a' options, the listing-control directives have no effect.

The letters after `-a' may be combined into one option, e.g., `-aln'.


Using as - D

-D

This option has no effect whatsoever, but it is accepted to make it more likely that scripts written for other assemblers also work with as.


Using as - f

Work Faster: -f

`-f' should only be used when assembling programs written by a (trusted) compiler. `-f' stops the assembler from doing whitespace and comment preprocessing on the input file(s) before assembling them. See section Preprocessing.

Warning: if you use `-f' when the files actually need to be preprocessed (if they contain comments, for example), as does not work correctly.


Using as - I

.include search path: -I path

Use this option to add a path to the list of directories as searches for files specified in .include directives (see section .include "file"). You may use -I as many times as necessary to include a variety of paths. The current working directory is always searched first; after that, as searches any `-I' directories in the same order as they were specified (left to right) on the command line.


Using as - K

Difference Tables: -K

as sometimes alters the code emitted for directives of the form `.word sym1-sym2'; see section .word expressions. You can use the `-K' option if you want a warning issued when this is done.


Using as - L

Include Local Labels: -L

Labels beginning with `L' (upper case only) are called local labels. See section Symbol Names. Normally you do not see such labels when debugging, because they are intended for the use of programs (like compilers) that compose assembler programs, not for your notice. Normally both as and ld discard such labels, so you do not normally debug with them.

This option tells as to retain those `L...' symbols in the object file. Usually if you do this you also tell the linker ld to preserve symbols whose names begin with `L'.

By default, a local label is any label beginning with `L', but each target is allowed to redefine the local label prefix. On the HPPA local labels begin with `L$'. `;' for the ARM family;


Using as - M

Assemble in MRI Compatibility Mode: -M

The -M or --mri option selects MRI compatibility mode. This changes the syntax and pseudo-op handling of as to make it compatible with the ASM68K or the ASM960 (depending upon the configured target) assembler from Microtec Research. The exact nature of the MRI syntax will not be documented here; see the MRI manuals for more information. Note in particular that the handling of macros and macro arguments is somewhat different. The purpose of this option is to permit assembling existing MRI assembler code using as.

The MRI compatibility is not complete. Certain operations of the MRI assembler depend upon its object file format, and can not be supported using other object file formats. Supporting these would require enhancing each object file format individually. These are:

  • global symbols in common section The m68k MRI assembler supports common sections which are merged by the linker. Other object file formats do not support this. as handles common sections by treating them as a single common symbol. It permits local symbols to be defined within a common section, but it can not support global symbols, since it has no way to describe them.
  • complex relocations The MRI assemblers support relocations against a negated section address, and relocations which combine the start addresses of two or more sections. These are not support by other object file formats.
  • END pseudo-op specifying start address The MRI END pseudo-op permits the specification of a start address. This is not supported by other object file formats. The start address may instead be specified using the -e option to the linker, or in a linker script.
  • IDNT, .ident and NAME pseudo-ops The MRI IDNT, .ident and NAME pseudo-ops assign a module name to the output file. This is not supported by other object file formats.
  • ORG pseudo-op The m68k MRI ORG pseudo-op begins an absolute section at a given address. This differs from the usual as .org pseudo-op, which changes the location within the current section. Absolute sections are not supported by other object file formats. The address of a section may be assigned within a linker script.

There are some other features of the MRI assembler which are not supported by as, typically either because they are difficult or because they seem of little consequence. Some of these may be supported in future releases.

  • EBCDIC strings EBCDIC strings are not supported.
  • packed binary coded decimal Packed binary coded decimal is not supported. This means that the DC.P and DCB.P pseudo-ops are not supported.
  • FEQU pseudo-op The m68k FEQU pseudo-op is not supported.
  • NOOBJ pseudo-op The m68k NOOBJ pseudo-op is not supported.
  • OPT branch control options The m68k OPT branch control options---B, BRS, BRB, BRL, and BRW---are ignored. as automatically relaxes all branches, whether forward or backward, to an appropriate size, so these options serve no purpose.
  • OPT list control options The following m68k OPT list control options are ignored: C, CEX, CL, CRE, E, G, I, M, MEX, MC, MD, X.
  • other OPT options The following m68k OPT options are ignored: NEST, O, OLD, OP, P, PCO, PCR, PCS, R.
  • OPT D option is default The m68k OPT D option is the default, unlike the MRI assembler. OPT NOD may be used to turn it off.
  • XREF pseudo-op. The m68k XREF pseudo-op is ignored.
  • .debug pseudo-op The i960 .debug pseudo-op is not supported.
  • .extended pseudo-op The i960 .extended pseudo-op is not supported.
  • .list pseudo-op. The various options of the i960 .list pseudo-op are not supported.
  • .optimize pseudo-op The i960 .optimize pseudo-op is not supported.
  • .output pseudo-op The i960 .output pseudo-op is not supported.
  • .setreal pseudo-op The i960 .setreal pseudo-op is not supported.


Using as - MD

Dependency tracking: --MD

as can generate a dependency file for the file it creates. This file consists of a single rule suitable for make describing the dependencies of the main source file.

The rule is written to the file named in its argument.

This feature is used in the automatic updating of makefiles.


Using as - o

Name the Object File: -o

There is always one object file output when you run as. By default it has the name `a.out' (or `b.out', for Intel 960 targets only). You use this option (which takes exactly one filename) to give the object file a different name.

Whatever the object file is called, as overwrites any existing file of the same name.


Using as - R

Join Data and Text Sections: -R

-R tells as to write the object file as if all data-section data lives in the text section. This is only done at the very last moment: your binary data are the same, but data section parts are relocated differently. The data section part of your object file is zero bytes long because all its bytes are appended to the text section. (See section Sections and Relocation.)

When you specify -R it would be possible to generate shorter address displacements (because we do not have to cross between text and data section). We refrain from doing this simply for compatibility with older versions of as. In future, -R may work this way.

When as is configured for COFF output, this option is only useful if you use sections named `.text' and `.data'.

-R is not supported for any of the HPPA targets. Using -R generates a warning from as.


Using as - statistics

Display Assembly Statistics: --statistics

Use `--statistics' to display two statistics about the resources used by as: the maximum amount of space allocated during the assembly (in bytes), and the total execution time taken for the assembly (in CPU seconds).


Using as - v

Announce Version: -v

You can find out what version of as is running by including the option `-v' (which you can also spell as `-version') on the command line.


Using as - W

Suppress Warnings: -W

as should never give a warning or error message when assembling compiler output. But programs written by people often cause as to give a warning that a particular assumption was made. All such warnings are directed to the standard error file. If you use this option, no warnings are issued. This option only affects the warning messages: it does not change any particular of how as assembles your file. Errors, which stop the assembly, are still reported.


Using as - Z

Generate Object File in Spite of Errors: -Z

After an error message, as normally produces no output. If for some reason you are interested in object file output even after as gives an error message on your program, use the `-Z' option. If there are any errors, as continues anyways, and writes an object file after a final warning message of the form `n errors, m warnings, generating bad object file.'


Using as - Syntax

Syntax

This chapter describes the machine-independent syntax allowed in a source file. as syntax is similar to what many other assemblers use; it is inspired by the BSD 4.2 assembler, except that as does not assemble Vax bit-fields.


Using as - Preprocessing

Preprocessing

The as internal preprocessor:

  • adjusts and removes extra whitespace. It leaves one space or tab before the keywords on a line, and turns any other whitespace on the line into a single space.
  • removes all comments, replacing them with a single space, or an appropriate number of newlines.
  • converts character constants into the appropriate numeric values.

It does not do macro processing, include file handling, or anything else you may get from your C compiler's preprocessor. You can do include file processing with the .include directive (see section .include "file"). You can use the GNU C compiler driver to get other "CPP" style preprocessing, by giving the input file a `.S' suffix. See section `Options Controlling the Kind of Output' in Using GNU CC.

Excess whitespace, comments, and character constants cannot be used in the portions of the input text that are not preprocessed.

If the first line of an input file is #NO_APP or if you use the `-f' option, whitespace and comments are not removed from the input file. Within an input file, you can ask for whitespace and comment removal in specific portions of the by putting a line that says #APP before the text that may contain whitespace or comments, and putting a line that says #NO_APP after this text. This feature is mainly intend to support asm statements in compilers whose output is otherwise free of comments and whitespace.


Using as - Whitespace

Whitespace

Whitespace is one or more blanks or tabs, in any order. Whitespace is used to separate symbols, and to make programs neater for people to read. Unless within character constants (see section Character Constants), any whitespace means the same as exactly one space.


Using as - Comments

Comments

There are two ways of rendering comments to as. In both cases the comment is equivalent to one space.

Anything from `/*' through the next `*/' is a comment. This means you may not nest these comments.

/*
  The only way to include a newline ('\n') in a comment
  is to use this sort of comment.
*/

/* This sort of comment does not nest. */

Anything from the line comment character to the next newline
is considered a comment and is ignored.  The line comment character is
`;' for the AMD 29K family;
`;' on the ARC;
`;' for the H8/300 family;
`!' for the H8/500 family;
`;' for the HPPA;
`#' on the i960;
`!' for the Hitachi SH;
`!' on the SPARC;
`|' on the 680x0;
`#' on the Vax;
`!' for the Z8000;
`#' on the V850;
see section Machine Dependent Features.

On some machines there are two different line comment characters. One character only begins a comment if it is the first non-whitespace character on a line, while the other always begins a comment.

The V850 assembler also supports a double dash as starting a comment that extends to the end of the line.

`--';

To be compatible with past assemblers, lines that begin with `#' have a special interpretation. Following the `#' should be an absolute expression (see section Expressions): the logical line number of the next line. Then a string (see section Strings) is allowed: if present it is a new logical file name. The rest of the line, if any, should be whitespace.

If the first non-whitespace characters on the line are not numeric, the line is ignored. (Just like a comment.)

                          # This is an ordinary comment.
# 42-6 "new_file_name"    # New logical file name
                          # This is logical line # 36.

This feature is deprecated, and may disappear from future versions of as.


Using as - Symbol Intro

Symbols

A symbol is one or more characters chosen from the set of all letters (both upper and lower case), digits and the three characters `_.$'. On most machines, you can also use $ in symbol names; exceptions are noted in section Machine Dependent Features. No symbol may begin with a digit. Case is significant. There is no length limit: all characters are significant. Symbols are delimited by characters not in that set, or by the beginning of a file (since the source program must end with a newline, the end of a file is not a possible symbol delimiter). See section Symbols.


Using as - Statements

Statements

A statement ends at a newline character (`\n') or an "at" sign (`@'). The newline or at sign is considered part of the preceding statement. Newlines and at signs within character constants are an exception: they do not end statements. A statement ends at a newline character (`\n') or an exclamation point (`!'). The newline or exclamation point is considered part of the preceding statement. Newlines and exclamation points within character constants are an exception: they do not end statements. A statement ends at a newline character (`\n'); or (for the H8/300) a dollar sign (`$'); or (for the Hitachi-SH or the H8/500) a semicolon (`;'). The newline or separator character is considered part of the preceding statement. Newlines and separators within character constants are an exception: they do not end statements. A statement ends at a newline character (`\n') or line separator character. (The line separator is usually `;', unless this conflicts with the comment character; see section Machine Dependent Features.) The newline or separator character is considered part of the preceding statement. Newlines and separators within character constants are an exception: they do not end statements.

It is an error to end any statement with end-of-file: the last character of any input file should be a newline.

You may write a statement on more than one line if you put a backslash (\) immediately in front of any newlines within the statement. When as reads a backslashed newline both characters are ignored. You can even put backslashed newlines in the middle of symbol names without changing the meaning of your source program.

An empty statement is allowed, and may include whitespace. It is ignored.

A statement begins with zero or more labels, optionally followed by a key symbol which determines what kind of statement it is. The key symbol determines the syntax of the rest of the statement. If the symbol begins with a dot `.' then the statement is an assembler directive: typically valid for any computer. If the symbol begins with a letter the statement is an assembly language instruction: it assembles into a machine language instruction. Different versions of as for different computers recognize different instructions. In fact, the same symbol may represent a different instruction in a different computer's assembly language.

A label is a symbol immediately followed by a colon (:). Whitespace before a label or after a colon is permitted, but you may not have whitespace between a label's symbol and its colon. See section Labels.

For HPPA targets, labels need not be immediately followed by a colon, but the definition of a label must begin in column zero. This also implies that only one label may be defined on each line.

label:     .directive    followed by something
another_label:           # This is an empty statement.
           instruction   operand_1, operand_2, ...


Using as - Constants

Constants

A constant is a number, written so that its value is known by inspection, without knowing any context. Like this:

.byte  74, 0112, 092, 0x4A, 0X4a, 'J, '\J # All the same value.
.ascii "Ring the bell\7"                  # A string constant.
.octa  0x123456789abcdef0123456789ABCDEF0 # A bignum.
.float 0f-314159265358979323846264338327\
95028841971.693993751E-40                 # - pi, a flonum.


Using as - Characters

Character Constants

There are two kinds of character constants. A character stands for one character in one byte and its value may be used in numeric expressions. String constants (properly called string literals) are potentially many bytes and their values may not be used in arithmetic expressions.


Using as - Strings

Strings

A string is written between double-quotes. It may contain double-quotes or null characters. The way to get special characters into a string is to escape these characters: precede them with a backslash `\' character. For example `\\' represents one backslash: the first \ is an escape which tells as to interpret the second character literally as a backslash (which prevents as from recognizing the second \ as an escape character). The complete list of escapes follows.

\b
Mnemonic for backspace; for ASCII this is octal code 010.
\f
Mnemonic for FormFeed; for ASCII this is octal code 014.
\n
Mnemonic for newline; for ASCII this is octal code 012.
\r
Mnemonic for carriage-Return; for ASCII this is octal code 015.
\t
Mnemonic for horizontal Tab; for ASCII this is octal code 011.
\ digit digit digit
An octal character code. The numeric code is 3 octal digits. For compatibility with other Unix systems, 8 and 9 are accepted as digits: for example, \008 has the value 010, and \009 the value 011.
\x hex-digits...
A hex character code. All trailing hex digits are combined. Either upper or lower case x works.
\\
Represents one `\' character.
\"
Represents one `"' character. Needed in strings to represent this character, because an unescaped `"' would end the string.
\ anything-else
Any other character when escaped by \ gives a warning, but assembles as if the `\' was not present. The idea is that if you used an escape sequence you clearly didn't want the literal interpretation of the following character. However as has no other interpretation, so as knows it is giving you the wrong code and warns you of the fact.

Which characters are escapable, and what those escapes represent, varies widely among assemblers. The current set is what we think the BSD 4.2 assembler recognizes, and is a subset of what most C compilers recognize. If you are in doubt, do not use an escape sequence.


Using as - Chars

Characters

A single character may be written as a single quote immediately followed by that character. The same escapes apply to characters as to strings. So if you want to write the character backslash, you must write '\\ where the first \ escapes the second \. As you can see, the quote is an acute accent, not a grave accent. A newline (or at sign `@') (or dollar sign `$', for the H8/300; or semicolon `;' for the Hitachi SH or H8/500) immediately following an acute accent is taken as a literal character and does not count as the end of a statement. The value of a character constant in a numeric expression is the machine's byte-wide code for that character. as assumes your character code is ASCII: 'A means 65, 'B means 66, and so on.


Using as - Numbers

Number Constants

as distinguishes three kinds of numbers according to how they are stored in the target machine. Integers are numbers that would fit into an int in the C language. Bignums are integers, but they are stored in more than 32 bits. Flonums are floating point numbers, described below.


Using as - Integers

Integers

A binary integer is `0b' or `0B' followed by zero or more of the binary digits `01'.

An octal integer is `0' followed by zero or more of the octal digits (`01234567').

A decimal integer starts with a non-zero digit followed by zero or more digits (`0123456789').

A hexadecimal integer is `0x' or `0X' followed by one or more hexadecimal digits chosen from `0123456789abcdefABCDEF'.

Integers have the usual values. To denote a negative integer, use the prefix operator `-' discussed under expressions (see section Prefix Operator).


Using as - Bignums

Bignums

A bignum has the same syntax and semantics as an integer except that the number (or its negative) takes more than 32 bits to represent in binary. The distinction is made because in some places integers are permitted while bignums are not.


Using as - Flonums

Flonums

A flonum represents a floating point number. The translation is indirect: a decimal floating point number from the text is converted by as to a generic binary floating point number of more than sufficient precision. This generic floating point number is converted to a particular computer's floating point format (or formats) by a portion of as specialized to that computer.

A flonum is written by writing (in order)

  • The digit `0'. (`0' is optional on the HPPA.)
  • A letter, to tell as the rest of the number is a flonum. e is recommended. Case is not important. On the H8/300, H8/500, Hitachi SH, and AMD 29K architectures, the letter must be one of the letters `DFPRSX' (in upper or lower case). On the ARC, the letter must be one of the letters `DFRS' (in upper or lower case). On the Intel 960 architecture, the letter must be one of the letters `DFT' (in upper or lower case). On the HPPA architecture, the letter must be `E' (upper case only).
  • An optional sign: either `+' or `-'.
  • An optional integer part: zero or more decimal digits.
  • An optional fractional part: `.' followed by zero or more decimal digits.
  • An optional exponent, consisting of:
    • An `E' or `e'.
    • Optional sign: either `+' or `-'.
    • One or more decimal digits.

At least one of the integer part or the fractional part must be present. The floating point number has the usual base-10 value.

as does all processing using integers. Flonums are computed independently of any floating point hardware in the computer running as.


Using as - Sections

Sections and Relocation


Using as - Secs Background

Background

Roughly, a section is a range of addresses, with no gaps; all data "in" those addresses is treated the same for some particular purpose. For example there may be a "read only" section.

The linker ld reads many object files (partial programs) and combines their contents to form a runnable program. When as emits an object file, the partial program is assumed to start at address 0. ld assigns the final addresses for the partial program, so that different partial programs do not overlap. This is actually an oversimplification, but it suffices to explain how as uses sections.

ld moves blocks of bytes of your program to their run-time addresses. These blocks slide to their run-time addresses as rigid units; their length does not change and neither does the order of bytes within them. Such a rigid unit is called a section. Assigning run-time addresses to sections is called relocation. It includes the task of adjusting mentions of object-file addresses so they refer to the proper run-time addresses. For the H8/300 and H8/500, and for the Hitachi SH, as pads sections if needed to ensure they end on a word (sixteen bit) boundary.

An object file written by as has at least three sections, any of which may be empty. These are named text, data and bss sections.

When it generates COFF output, as can also generate whatever other named sections you specify using the `.section' directive (see section .section name). If you do not use any directives that place output in the `.text' or `.data' sections, these sections still exist, but are empty.

When as generates SOM or ELF output for the HPPA, as can also generate whatever other named sections you specify using the `.space' and `.subspace' directives. See HP9000 Series 800 Assembly Language Reference Manual (HP 92432-90001) for details on the `.space' and `.subspace' assembler directives.

Additionally, as uses different names for the standard text, data, and bss sections when generating SOM output. Program text is placed into the `$CODE$' section, data into `$DATA$', and BSS into `$BSS$'.

Within the object file, the text section starts at address 0, the data section follows, and the bss section follows the data section.

When generating either SOM or ELF output files on the HPPA, the text section starts at address 0, the data section at address 0x4000000, and the bss section follows the data section.

To let ld know which data changes when the sections are relocated, and how to change that data, as also writes to the object file details of the relocation needed. To perform relocation ld must know, each time an address in the object file is mentioned:

  • Where in the object file is the beginning of this reference to an address?
  • How long (in bytes) is this reference?
  • Which section does the address refer to? What is the numeric value of
    (address) - (start-address of section)?
  • Is the reference to an address "Program-Counter relative"?

In fact, every address as ever uses is expressed as

(section) + (offset into section)

Further, most expressions as computes have this section-relative nature. (For some object formats, such as SOM for the HPPA, some expressions are symbol-relative instead.)

In this manual we use the notation {secname N} to mean "offset N into section secname."

Apart from text, data and bss sections you need to know about the absolute section. When ld mixes partial programs, addresses in the absolute section remain unchanged. For example, address {absolute 0} is "relocated" to run-time address 0 by ld. Although the linker never arranges two partial programs' data sections with overlapping addresses after linking, by definition their absolute sections must overlap. Address {absolute 239} in one part of a program is always the same address when the program is running as address {absolute 239} in any other part of the program.

The idea of sections is extended to the undefined section. Any address whose section is unknown at assembly time is by definition rendered {undefined U}---where U is filled in later. Since numbers are always defined, the only way to generate an undefined address is to mention an undefined symbol. A reference to a named common block would be such a symbol: its value is unknown at assembly time so it has section undefined.

By analogy the word section is used to describe groups of sections in the linked program. ld puts all partial programs' text sections in contiguous addresses in the linked program. It is customary to refer to the text section of a program, meaning all the addresses of all partial programs' text sections. Likewise for data and bss sections.

Some sections are manipulated by ld; others are invented for use of as and have no meaning except during assembly.


Using as - Ld Sections

Linker Sections

ld deals with just four kinds of sections, summarized below.

named sections
text section
data section
These sections hold your program. as and ld treat them as separate but equal sections. Anything you can say of one section is true another. When the program is running, however, it is customary for the text section to be unalterable. The text section is often shared among processes: it contains instructions, constants and the like. The data section of a running program is usually alterable: for example, C variables would be stored in the data section.
bss section
This section contains zeroed bytes when your program begins running. It is used to hold unitialized variables or common storage. The length of each partial program's bss section is important, but because it starts out containing zeroed bytes there is no need to store explicit zero bytes in the object file. The bss section was invented to eliminate those explicit zeros from object files.
absolute section
Address 0 of this section is always "relocated" to runtime address 0. This is useful if you want to refer to an address that ld must not change when relocating. In this sense we speak of absolute addresses being "unrelocatable": they do not change during relocation.
undefined section
This "section" is a catch-all for address references to objects not in the preceding sections.

An idealized example of three relocatable sections follows. The example uses the traditional section names `.text' and `.data'. Memory addresses are on the horizontal axis.


Using as - As Sections

Assembler Internal Sections

These sections are meant only for the internal use of as. They have no meaning at run-time. You do not really need to know about these sections for most purposes; but they can be mentioned in as warning messages, so it might be helpful to have an idea of their meanings to as. These sections are used to permit the value of every expression in your assembly language program to be a section-relative address.

ASSEMBLER-INTERNAL-LOGIC-ERROR!
An internal assembler logic error has been found. This means there is a bug in the assembler.
expr section
The assembler stores complex expression internally as combinations of symbols. When it needs to represent an expression as a symbol, it puts it in the expr section.


Using as - Sub-Sections

Sub-Sections

Assembled bytes conventionally fall into two sections: text and data. You may have separate groups of data in named sections text or data that you want to end up near to each other in the object file, even though they are not contiguous in the assembler source. as allows you to use subsections for this purpose. Within each section, there can be numbered subsections with values from 0 to 8192. Objects assembled into the same subsection go into the object file together with other objects in the same subsection. For example, a compiler might want to store constants in the text section, but might not want to have them interspersed with the program being assembled. In this case, the compiler could issue a `.text 0' before each section of code being output, and a `.text 1' before each group of constants being output.

Subsections are optional. If you do not use subsections, everything goes in subsection number zero.

Each subsection is zero-padded up to a multiple of four bytes. (Subsections may be padded a different amount on different flavors of as.)

Subsections appear in your object file in numeric order, lowest numbered to highest. (All this to be compatible with other people's assemblers.) The object file contains no representation of subsections; ld and other programs that manipulate object files see no trace of them. They just see all your text subsections as a text section, and all your data subsections as a data section.

To specify which subsection you want subsequent statements assembled into, use a numeric argument to specify it, in a `.text expression' or a `.data expression' statement. When generating COFF output, you can also use an extra subsection argument with arbitrary named sections: `.section name, expression'. Expression should be an absolute expression. (See section Expressions.) If you just say `.text' then `.text 0' is assumed. Likewise `.data' means `.data 0'. Assembly begins in text 0. For instance:

.text 0     # The default subsection is text 0 anyway.
.ascii "This lives in the first text subsection. *"
.text 1
.ascii "But this lives in the second text subsection."
.data 0
.ascii "This lives in the data section,"
.ascii "in the first data subsection."
.text 0
.ascii "This lives in the first text section,"
.ascii "immediately following the asterisk (*)."

Each section has a location counter incremented by one for every byte assembled into that section. Because subsections are merely a convenience restricted to as there is no concept of a subsection location counter. There is no way to directly manipulate a location counter--but the .align directive changes it, and any label definition captures its current value. The location counter of the section where statements are being assembled is said to be the active location counter.


Using as - bss

bss Section

The bss section is used for local common variable storage. You may allocate address space in the bss section, but you may not dictate data to load into it before your program executes. When your program starts running, all the contents of the bss section are zeroed bytes.

The .lcomm pseudo-op defines a symbol in the bss section; see section .lcomm symbol , length.

The .comm pseudo-op may be used to declare a common symbol, which is another form of uninitialized symbol; see See section .comm symbol , length .

When assembling for a target which supports multiple sections, such as ELF or COFF, you may switch into the .bss section and define symbols as usual; see section .section name. You may only assemble zero values into the section. Typically the section will only contain symbol definitions and .skip directives (see section .skip size , fill).


Using as - Symbols

Symbols

Symbols are a central concept: the programmer uses symbols to name things, the linker uses symbols to link, and the debugger uses symbols to debug.

Warning: as does not place symbols in the object file in the same order they were declared. This may break some debuggers.


Using as - Labels

Labels

A label is written as a symbol immediately followed by a colon `:'. The symbol then represents the current value of the active location counter, and is, for example, a suitable instruction operand. You are warned if you use the same symbol to represent two different locations: the first definition overrides any other definitions.

On the HPPA, the usual form for a label need not be immediately followed by a colon, but instead must start in column zero. Only one label may be defined on a single line. To work around this, the HPPA version of as also provides a special directive .label for defining labels more flexibly.


Using as - Setting Symbols

Giving Symbols Other Values

A symbol can be given an arbitrary value by writing a symbol, followed by an equals sign `=', followed by an expression (see section Expressions). This is equivalent to using the .set directive. See section .set symbol, expression.


Using as - Symbol Names

Symbol Names

Symbol names begin with a letter or with one of `._'. On most machines, you can also use $ in symbol names; exceptions are noted in section Machine Dependent Features. That character may be followed by any string of digits, letters, dollar signs (unless otherwise noted in section Machine Dependent Features), and underscores. For the AMD 29K family, `?' is also allowed in the body of a symbol name, though not at its beginning.

Case of letters is significant: foo is a different symbol name than Foo.

Each symbol has exactly one name. Each name in an assembly language program refers to exactly one symbol. You may use that symbol name any number of times in a program.

Local Symbol Names

Local symbols help compilers and programmers use names temporarily. There are ten local symbol names, which are re-used throughout the program. You may refer to them using the names `0' `1' ... `9'. To define a local symbol, write a label of the form `N:' (where N represents any digit). To refer to the most recent previous definition of that symbol write `Nb', using the same digit as when you defined the label. To refer to the next definition of a local label, write `Nf'---where N gives you a choice of 10 forward references. The `b' stands for "backwards" and the `f' stands for "forwards".

Local symbols are not emitted by the current GNU C compiler.

There is no restriction on how you can use these labels, but remember that at any point in the assembly you can refer to at most 10 prior local labels and to at most 10 forward local labels.

Local symbol names are only a notation device. They are immediately transformed into more conventional symbol names before the assembler uses them. The symbol names stored in the symbol table, appearing in error messages and optionally emitted to the object file have these parts:

L
All local labels begin with `L'. Normally both as and ld forget symbols that start with `L'. These labels are used for symbols you are never intended to see. If you use the `-L' option then as retains these symbols in the object file. If you also instruct ld to retain these symbols, you may use them in debugging.
digit
If the label is written `0:' then the digit is `0'. If the label is written `1:' then the digit is `1'. And so on up through `9:'.
C-A
This unusual character is included so you do not accidentally invent a symbol of the same name. The character has ASCII value `\001'.
ordinal number
This is a serial number to keep the labels distinct. The first `0:' gets the number `1'; The 15th `0:' gets the number `15'; etc.. Likewise for the other labels `1:' through `9:'.

For instance, the first 1: is named L1C-A1, the 44th 3: is named L3C-A44.


Using as - Dot

The Special Dot Symbol

The special symbol `.' refers to the current address that as is assembling into. Thus, the expression `melvin: .long .' defines melvin to contain its own address. Assigning a value to . is treated the same as a .org directive. Thus, the expression `.=.+4' is the same as saying `.space 4'.


Using as - Symbol Attributes

Symbol Attributes

Every symbol has, as well as its name, the attributes "Value" and "Type". Depending on output format, symbols can also have auxiliary attributes.

If you use a symbol without defining it, as assumes zero for all these attributes, and probably won't warn you. This makes the symbol an externally defined symbol, which is generally what you would want.


Using as - Symbol Value

Value

The value of a symbol is (usually) 32 bits. For a symbol which labels a location in the text, data, bss or absolute sections the value is the number of addresses from the start of that section to the label. Naturally for text, data and bss sections the value of a symbol changes as ld changes section base addresses during linking. Absolute symbols' values do not change during linking: that is why they are called absolute.

The value of an undefined symbol is treated in a special way. If it is 0 then the symbol is not defined in this assembler source file, and ld tries to determine its value from other files linked into the same program. You make this kind of symbol simply by mentioning a symbol name without defining it. A non-zero value represents a .comm common declaration. The value is how much common storage to reserve, in bytes (addresses). The symbol refers to the first address of the allocated storage.


Using as - Symbol Type

Type

The type attribute of a symbol contains relocation (section) information, any flag settings indicating that a symbol is external, and (optionally), other information for linkers and debuggers. The exact format depends on the object-code output format in use.


Using as - a.out Symbols

Symbol Attributes: a.out


Using as - Symbol Desc

Descriptor

This is an arbitrary 16-bit value. You may establish a symbol's descriptor value by using a .desc statement (see section .desc symbol, abs-expression). A descriptor value means nothing to as.


Using as - Symbol Other

Other

This is an arbitrary 8-bit value. It means nothing to as.


Using as - COFF Symbols

Symbol Attributes for COFF

The COFF format supports a multitude of auxiliary symbol attributes; like the primary symbol attributes, they are set between .def and .endef directives.

Primary Attributes

The symbol name is set with .def; the value and type, respectively, with .val and .type.

Auxiliary Attributes

The as directives .dim, .line, .scl, .size, and .tag can generate auxiliary symbol table information for COFF.


Using as - SOM Symbols

Symbol Attributes for SOM

The SOM format for the HPPA supports a multitude of symbol attributes set with the .EXPORT and .IMPORT directives.

The attributes are described in HP9000 Series 800 Assembly Language Reference Manual (HP 92432-90001) under the IMPORT and EXPORT assembler directive documentation.


Using as - Expressions

Expressions

An expression specifies an address or numeric value. Whitespace may precede and/or follow an expression.

The result of an expression must be an absolute number, or else an offset into a particular section. If an expression is not absolute, and there is not enough information when as sees the expression to know its section, a second pass over the source program might be necessary to interpret the expression--but the second pass is currently not implemented. as aborts with an error message in this situation.


Using as - Empty Exprs

Empty Expressions

An empty expression has no value: it is just whitespace or null. Wherever an absolute expression is required, you may omit the expression, and as assumes a value of (absolute) 0. This is compatible with other assemblers.


Using as - Integer Exprs

Integer Expressions

An integer expression is one or more arguments delimited by operators.


Using as - Arguments

Arguments

Arguments are symbols, numbers or subexpressions. In other contexts arguments are sometimes called "arithmetic operands". In this manual, to avoid confusing them with the "instruction operands" of the machine language, we use the term "argument" to refer to parts of expressions only, reserving the word "operand" to refer only to machine instruction operands.

Symbols are evaluated to yield {section NNN} where section is one of text, data, bss, absolute, or undefined. NNN is a signed, 2's complement 32 bit integer.

Numbers are usually integers.

A number can be a flonum or bignum. In this case, you are warned that only the low order 32 bits are used, and as pretends these 32 bits are an integer. You may write integer-manipulating instructions that act on exotic constants, compatible with other assemblers.

Subexpressions are a left parenthesis `(' followed by an integer expression, followed by a right parenthesis `)'; or a prefix operator followed by an argument.


Using as - Operators

Operators

Operators are arithmetic functions, like + or %. Prefix operators are followed by an argument. Infix operators appear between their arguments. Operators may be preceded and/or followed by whitespace.


Using as - Prefix Ops

Prefix Operator

as has the following prefix operators. They each take one argument, which must be absolute.

-
Negation. Two's complement negation.
~
Complementation. Bitwise not.


Using as - Infix Ops

Infix Operators

Infix operators take two arguments, one on either side. Operators have precedence, but operations with equal precedence are performed left to right. Apart from + or -, both arguments must be absolute, and the result is absolute.

  1. Highest Precedence
    *
    Multiplication.
    /
    Division. Truncation is the same as the C operator `/'
    %
    Remainder.
    <
    <<
    Shift Left. Same as the C operator `<<'.
    >
    >>
    Shift Right. Same as the C operator `>>'.
  2. Intermediate precedence
    |
    Bitwise Inclusive Or.
    &
    Bitwise And.
    ^
    Bitwise Exclusive Or.
    !
    Bitwise Or Not.
  3. Lowest Precedence
    +
    Addition. If either argument is absolute, the result has the section of the other argument. You may not add together arguments from different sections.
    -
    Subtraction. If the right argument is absolute, the result has the section of the left argument. If both arguments are in the same section, the result is absolute. You may not subtract arguments from different sections.

In short, it's only meaningful to add or subtract the offsets in an address; you can only have a defined section in one of the two arguments.


Using as - Pseudo Ops

Assembler Directives

All assembler directives have names that begin with a period (`.'). The rest of the name is letters, usually in lower case.

This chapter discusses directives that are available regardless of the target machine configuration for the GNU assembler. Some machine configurations provide additional directives. See section Machine Dependent Features.


Using as - Abort

.abort

This directive stops the assembly immediately. It is for compatibility with other assemblers. The original idea was that the assembly language source would be piped into the assembler. If the sender of the source quit, it could use this directive tells as to quit also. One day .abort will not be supported.


Using as - ABORT

.ABORT

When producing COFF output, as accepts this directive as a synonym for `.abort'.

When producing b.out output, as accepts this directive, but ignores it.


Using as - Align

.align abs-expr, abs-expr, abs-expr

Pad the location counter (in the current subsection) to a particular storage boundary. The first expression (which must be absolute) is the alignment required, as described below.

The second expression (also absolute) gives the fill value to be stored in the padding bytes. It (and the comma) may be omitted. If it is omitted, the padding bytes are normally zero. However, on some systems, if the section is marked as containing code and the fill value is omitted, the space is filled with no-op instructions.

The third expression is also absolute, and is also optional. If it is present, it is the maximum number of bytes that should be skipped by this alignment directive. If doing the alignment would require skipping more bytes than the specified maximum, then the alignment is not done at all. You can omit the fill value (the second argument) entirely by simply using two commas after the required alignment; this can be useful if you want the alignment to be filled with no-op instructions when appropriate.

The way the required alignment is specified varies from system to system. For the a29k, hppa, m68k, m88k, w65, sparc, and Hitachi SH, and i386 using ELF format, the first expression is the alignment request in bytes. For example `.align 8' advances the location counter until it is a multiple of 8. If the location counter is already a multiple of 8, no change is needed.

For other systems, including the i386 using a.out format, it is the number of low-order zero bits the location counter must have after advancement. For example `.align 3' advances the location counter until it a multiple of 8. If the location counter is already a multiple of 8, no change is needed.

This inconsistency is due to the different behaviors of the various native assemblers for these systems which GAS must emulate. GAS also provides .balign and .p2align directives, described later, which have a consistent behavior across all architectures (but are specific to GAS).


Using as - App-File

.app-file string

.app-file (which may also be spelled `.file') tells as that we are about to start a new logical file. string is the new file name. In general, the filename is recognized whether or not it is surrounded by quotes `"'; but if you wish to specify an empty file name is permitted, you must give the quotes--"". This statement may go away in future: it is only recognized to be compatible with old as programs.


Using as - Ascii

.ascii "string"...

.ascii expects zero or more string literals (see section Strings) separated by commas. It assembles each string (with no automatic trailing zero byte) into consecutive addresses.


Using as - Asciz

.asciz "string"...

.asciz is just like .ascii, but each string is followed by a zero byte. The "z" in `.asciz' stands for "zero".


Using as - Balign

.balign[wl] abs-expr, abs-expr, abs-expr

Pad the location counter (in the current subsection) to a particular storage boundary. The first expression (which must be absolute) is the alignment request in bytes. For example `.balign 8' advances the location counter until it is a multiple of 8. If the location counter is already a multiple of 8, no change is needed.

The second expression (also absolute) gives the fill value to be stored in the padding bytes. It (and the comma) may be omitted. If it is omitted, the padding bytes are normally zero. However, on some systems, if the section is marked as containing code and the fill value is omitted, the space is filled with no-op instructions.

The third expression is also absolute, and is also optional. If it is present, it is the maximum number of bytes that should be skipped by this alignment directive. If doing the alignment would require skipping more bytes than the specified maximum, then the alignment is not done at all. You can omit the fill value (the second argument) entirely by simply using two commas after the required alignment; this can be useful if you want the alignment to be filled with no-op instructions when appropriate.

The .balignw and .balignl directives are variants of the .balign directive. The .balignw directive treats the fill pattern as a two byte word value. The .balignl directives treats the fill pattern as a four byte longword value. For example, .balignw 4,0x368d will align to a multiple of 4. If it skips two bytes, they will be filled in with the value 0x368d (the exact placement of the bytes depends upon the endianness of the processor). If it skips 1 or 3 bytes, the fill value is undefined.


Using as - Byte

.byte expressions

.byte expects zero or more expressions, separated by commas. Each expression is assembled into the next byte.


Using as - Comm

.comm symbol , length

.comm declares a common symbol named symbol. When linking, a common symbol in one object file may be merged with a defined or common symbol of the same name in another object file. If ld does not see a definition for the symbol--just one or more common symbols--then it will allocate length bytes of uninitialized memory. length must be an absolute expression. If ld sees multiple common symbols with the same name, and they do not all have the same size, it will allocate space using the largest size.

When using ELF, the .comm directive takes an optional third argument. This is the desired alignment of the symbol, specified as a byte boundary (for example, an alignment of 16 means that the least significant 4 bits of the address should be zero). The alignment must be an absolute expression, and it must be a power of two. If ld allocates uninitialized memory for the common symbol, it will use the alignment when placing the symbol. If no alignment is specified, as will set the alignment to the largest power of two less than or equal to the size of the symbol, up to a maximum of 16.

The syntax for .comm differs slightly on the HPPA. The syntax is `symbol .comm, length'; symbol is optional.


Using as - Data

.data subsection

.data tells as to assemble the following statements onto the end of the data subsection numbered subsection (which is an absolute expression). If subsection is omitted, it defaults to zero.


Using as - Def

.def name

Begin defining debugging information for a symbol name; the definition extends until the .endef directive is encountered.

This directive is only observed when as is configured for COFF format output; when producing b.out, `.def' is recognized, but ignored.


Using as - Desc

.desc symbol, abs-expression

This directive sets the descriptor of the symbol (see section Symbol Attributes) to the low 16 bits of an absolute expression.

The `.desc' directive is not available when as is configured for COFF output; it is only for a.out or b.out object format. For the sake of compatibility, as accepts it, but produces no output, when configured for COFF.


Using as - Dim

.dim

This directive is generated by compilers to include auxiliary debugging information in the symbol table. It is only permitted inside .def/.endef pairs.

`.dim' is only meaningful when generating COFF format output; when as is generating b.out, it accepts this directive but ignores it.


Using as - Double

.double flonums

.double expects zero or more flonums, separated by commas. It assembles floating point numbers. The exact kind of floating point numbers emitted depends on how as is configured. See section Machine Dependent Features.


Using as - Eject

.eject

Force a page break at this point, when generating assembly listings.


Using as - Else

.else

.else is part of the as support for conditional assembly; see section .if absolute expression. It marks the beginning of a section of code to be assembled if the condition for the preceding .if was false.


Using as - Endef

.endef

This directive flags the end of a symbol definition begun with .def.

`.endef' is only meaningful when generating COFF format output; if as is configured to generate b.out, it accepts this directive but ignores it.


Using as - Endif

.endif

.endif is part of the as support for conditional assembly; it marks the end of a block of code that is only assembled conditionally. See section .if absolute expression.


Using as - Equ

.equ symbol, expression

This directive sets the value of symbol to expression. It is synonymous with `.set'; see section .set symbol, expression.

The syntax for equ on the HPPA is `symbol .equ expression'.


Using as - Equiv

.equiv symbol, expression

The .equiv directive is like .equ and .set, except that the assembler will signal an error if symbol is already defined.

Except for the contents of the error message, this is roughly equivalent to

.ifdef SYM
.err
.endif
.equ SYM,VAL


Using as - Err

.err

If as assembles a .err directive, it will print an error message and, unless the -Z option was used, it will not generate an object file. This can be used to signal error an conditionally compiled code.


Using as - Extern

.extern

.extern is accepted in the source program--for compatibility with other assemblers--but it is ignored. as treats all undefined symbols as external.


Using as - File

.file string

.file (which may also be spelled `.app-file') tells as that we are about to start a new logical file. string is the new file name. In general, the filename is recognized whether or not it is surrounded by quotes `"'; but if you wish to specify an empty file name, you must give the quotes--"". This statement may go away in future: it is only recognized to be compatible with old as programs. In some configurations of as, .file has already been removed to avoid conflicts with other assemblers. See section Machine Dependent Features.


Using as - Fill

.fill repeat , size , value

result, size and value are absolute expressions. This emits repeat copies of size bytes. Repeat may be zero or more. Size may be zero or more, but if it is more than 8, then it is deemed to have the value 8, compatible with other people's assemblers. The contents of each repeat bytes is taken from an 8-byte number. The highest order 4 bytes are zero. The lowest order 4 bytes are value rendered in the byte-order of an integer on the computer as is assembling for. Each size bytes in a repetition is taken from the lowest order size bytes of this number. Again, this bizarre behavior is compatible with other people's assemblers.

size and value are optional. If the second comma and value are absent, value is assumed zero. If the first comma and following tokens are absent, size is assumed to be 1.


Using as - Float

.float flonums

This directive assembles zero or more flonums, separated by commas. It has the same effect as .single. The exact kind of floating point numbers emitted depends on how as is configured. See section Machine Dependent Features.


Using as - Global

.global symbol, .globl symbol

.global makes the symbol visible to ld. If you define symbol in your partial program, its value is made available to other partial programs that are linked with it. Otherwise, symbol takes its attributes from a symbol of the same name from another file linked into the same program.

Both spellings (`.globl' and `.global') are accepted, for compatibility with other assemblers.

On the HPPA, .global is not always enough to make it accessible to other partial programs. You may need the HPPA-only .EXPORT directive as well. See section HPPA Assembler Directives.


Using as - hword

.hword expressions

This expects zero or more expressions, and emits a 16 bit number for each.

This directive is a synonym for `.short'; depending on the target architecture, it may also be a synonym for `.word'.


Using as - Ident

.ident

This directive is used by some assemblers to place tags in object files. as simply accepts the directive for source-file compatibility with such assemblers, but does not actually emit anything for it.


Using as - If

.if absolute expression

.if marks the beginning of a section of code which is only considered part of the source program being assembled if the argument (which must be an absolute expression) is non-zero. The end of the conditional section of code must be marked by .endif (see section .endif); optionally, you may include code for the alternative condition, flagged by .else (see section .else).

The following variants of .if are also supported:

.ifdef symbol
Assembles the following section of code if the specified symbol has been defined.
.ifndef symbol
.ifnotdef symbol
Assembles the following section of code if the specified symbol has not been defined. Both spelling variants are equivalent.


Using as - Include

.include "file"

This directive provides a way to include supporting files at specified points in your source program. The code from file is assembled as if it followed the point of the .include; when the end of the included file is reached, assembly of the original file continues. You can control the search paths used with the `-I' command-line option (see section Command-Line Options). Quotation marks are required around file.


Using as - Int

.int expressions

Expect zero or more expressions, of any section, separated by commas. For each expression, emit a number that, at run time, is the value of that expression. The byte order and bit size of the number depends on what kind of target the assembly is for.


Using as - Irp

.irp symbol,values...

Evaluate a sequence of statements assigning different values to symbol. The sequence of statements starts at the .irp directive, and is terminated by an .endr directive. For each value, symbol is set to value, and the sequence of statements is assembled. If no value is listed, the sequence of statements is assembled once, with symbol set to the null string. To refer to symbol within the sequence of statements, use \symbol.

For example, assembling

        .irp    param,1,2,3
        move    d\param,sp@-
        .endr

is equivalent to assembling

        move    d1,sp@-
        move    d2,sp@-
        move    d3,sp@-


Using as - Irpc

.irpc symbol,values...

Evaluate a sequence of statements assigning different values to symbol. The sequence of statements starts at the .irpc directive, and is terminated by an .endr directive. For each character in value, symbol is set to the character, and the sequence of statements is assembled. If no value is listed, the sequence of statements is assembled once, with symbol set to the null string. To refer to symbol within the sequence of statements, use \symbol.

For example, assembling

        .irpc    param,123
        move    d\param,sp@-
        .endr

is equivalent to assembling

        move    d1,sp@-
        move    d2,sp@-
        move    d3,sp@-


Using as - Lcomm

.lcomm symbol , length

Reserve length (an absolute expression) bytes for a local common denoted by symbol. The section and value of symbol are those of the new local common. The addresses are allocated in the bss section, so that at run-time the bytes start off zeroed. Symbol is not declared global (see section .global symbol, .globl symbol), so is normally not visible to ld.

Some targets permit a third argument to be used with .lcomm. This argument specifies the desired alignment of the symbol in the bss section.

The syntax for .lcomm differs slightly on the HPPA. The syntax is `symbol .lcomm, length'; symbol is optional.


Using as - Lflags

.lflags

as accepts this directive, for compatibility with other assemblers, but ignores it.


Using as - Line

.line line-number

Change the logical line number. line-number must be an absolute expression. The next line has that logical line number. Therefore any other statements on the current line (after a statement separator character) are reported as on logical line number line-number - 1. One day as will no longer support this directive: it is recognized only for compatibility with existing assembler programs.

Warning: In the AMD29K configuration of as, this command is not available; use the synonym .ln in that context.

Even though this is a directive associated with the a.out or b.out object-code formats, as still recognizes it when producing COFF output, and treats `.line' as though it were the COFF `.ln' if it is found outside a .def/.endef pair.

Inside a .def, `.line' is, instead, one of the directives used by compilers to generate auxiliary symbol information for debugging.


Using as - Linkonce

.linkonce [type]

Mark the current section so that the linker only includes a single copy of it. This may be used to include the same section in several different object files, but ensure that the linker will only include it once in the final output file. The .linkonce pseudo-op must be used for each instance of the section. Duplicate sections are detected based on the section name, so it should be unique.

This directive is only supported by a few object file formats; as of this writing, the only object file format which supports it is the Portable Executable format used on Windows NT.

The type argument is optional. If specified, it must be one of the following strings. For example:

.linkonce same_size

Not all types may be supported on all object file formats.

discard
Silently discard duplicate sections. This is the default.
one_only
Warn if there are duplicate sections, but still keep only one copy.
same_size
Warn if any of the duplicates have different sizes.
same_contents
Warn if any of the duplicates do not have exactly the same contents.


Using as - Ln

.ln line-number

`.ln' is a synonym for `.line'.


Using as - MRI

.mri val

If val is non-zero, this tells as to enter MRI mode. If val is zero, this tells as to exit MRI mode. This change affects code assembled until the next .mri directive, or until the end of the file. See section Assemble in MRI Compatibility Mode: -M.


Using as - List

.list

Control (in conjunction with the .nolist directive) whether or not assembly listings are generated. These two directives maintain an internal counter (which is zero initially). .list increments the counter, and .nolist decrements it. Assembly listings are generated whenever the counter is greater than zero.

By default, listings are disabled. When you enable them (with the `-a' command line option; see section Command-Line Options), the initial value of the listing counter is one.


Using as - Long

.long expressions

.long is the same as `.int', see section .int expressions.


Using as - Macro

.macro

The commands .macro and .endm allow you to define macros that generate assembly output. For example, this definition specifies a macro sum that puts a sequence of numbers into memory:

        .macro  sum from=0, to=5
        .long   \from
        .if     \to-\from
        sum     "(\from+1)",\to
        .endif
        .endm

With that definition, `SUM 0,5' is equivalent to this assembly input:

        .long   0
        .long   1
        .long   2
        .long   3
        .long   4
        .long   5
.macro macname
.macro macname macargs ...
Begin the definition of a macro called macname. If your macro definition requires arguments, specify their names after the macro name, separated by commas or spaces. You can supply a default value for any macro argument by following the name with `=deflt'. For example, these are all valid .macro statements:
.macro comm
Begin the definition of a macro called comm, which takes no arguments.
.macro plus1 p, p1
.macro plus1 p p1
Either statement begins the definition of a macro called plus1, which takes two arguments; within the macro definition, write `\p' or `\p1' to evaluate the arguments.
.macro reserve_str p1=0 p2
Begin the definition of a macro called reserve_str, with two arguments. The first argument has a default value, but not the second. After the definition is complete, you can call the macro either as `reserve_str a,b' (with `\p1' evaluating to a and `\p2' evaluating to b), or as `reserve_str ,b' (with `\p1' evaluating as the default, in this case `0', and `\p2' evaluating to b).
When you call a macro, you can specify the argument values either by position, or by keyword. For example, `sum 9,17' is equivalent to `sum to=17, from=9'.
.endm
Mark the end of a macro definition.
.exitm
Exit early from the current macro definition.
\@
as maintains a counter of how many macros it has executed in this pseudo-variable; you can copy that number to your output with `\@', but only within a macro definition.


Using as - Nolist

.nolist

Control (in conjunction with the .list directive) whether or not assembly listings are generated. These two directives maintain an internal counter (which is zero initially). .list increments the counter, and .nolist decrements it. Assembly listings are generated whenever the counter is greater than zero.


Using as - Octa

.octa bignums

This directive expects zero or more bignums, separated by commas. For each bignum, it emits a 16-byte integer.

The term "octa" comes from contexts in which a "word" is two bytes; hence octa-word for 16 bytes.


Using as - Org

.org new-lc , fill

Advance the location counter of the current section to new-lc. new-lc is either an absolute expression or an expression with the same section as the current subsection. That is, you can't use .org to cross sections: if new-lc has the wrong section, the .org directive is ignored. To be compatible with former assemblers, if the section of new-lc is absolute, as issues a warning, then pretends the section of new-lc is the same as the current subsection.

.org may only increase the location counter, or leave it unchanged; you cannot use .org to move the location counter backwards.

Because as tries to assemble programs in one pass, new-lc may not be undefined. If you really detest this restriction we eagerly await a chance to share your improved assembler.

Beware that the origin is relative to the start of the section, not to the start of the subsection. This is compatible with other people's assemblers.

When the location counter (of the current subsection) is advanced, the intervening bytes are filled with fill which should be an absolute expression. If the comma and fill are omitted, fill defaults to zero.


Using as - P2align

.p2align[wl] abs-expr, abs-expr, abs-expr

Pad the location counter (in the current subsection) to a particular storage boundary. The first expression (which must be absolute) is the number of low-order zero bits the location counter must have after advancement. For example `.p2align 3' advances the location counter until it a multiple of 8. If the location counter is already a multiple of 8, no change is needed.

The second expression (also absolute) gives the fill value to be stored in the padding bytes. It (and the comma) may be omitted. If it is omitted, the padding bytes are normally zero. However, on some systems, if the section is marked as containing code and the fill value is omitted, the space is filled with no-op instructions.

The third expression is also absolute, and is also optional. If it is present, it is the maximum number of bytes that should be skipped by this alignment directive. If doing the alignment would require skipping more bytes than the specified maximum, then the alignment is not done at all. You can omit the fill value (the second argument) entirely by simply using two commas after the required alignment; this can be useful if you want the alignment to be filled with no-op instructions when appropriate.

The .p2alignw and .p2alignl directives are variants of the .p2align directive. The .p2alignw directive treats the fill pattern as a two byte word value. The .p2alignl directives treats the fill pattern as a four byte longword value. For example, .p2alignw 2,0x368d will align to a multiple of 4. If it skips two bytes, they will be filled in with the value 0x368d (the exact placement of the bytes depends upon the endianness of the processor). If it skips 1 or 3 bytes, the fill value is undefined.


Using as - Psize

.psize lines , columns

Use this directive to declare the number of lines--and, optionally, the number of columns--to use for each page, when generating listings.

If you do not use .psize, listings use a default line-count of 60. You may omit the comma and columns specification; the default width is 200 columns.

as generates formfeeds whenever the specified number of lines is exceeded (or whenever you explicitly request one, using .eject).

If you specify lines as 0, no formfeeds are generated save those explicitly specified with .eject.


Using as - Quad

.quad bignums

.quad expects zero or more bignums, separated by commas. For each bignum, it emits an 8-byte integer. If the bignum won't fit in 8 bytes, it prints a warning message; and just takes the lowest order 8 bytes of the bignum.

The term "quad" comes from contexts in which a "word" is two bytes; hence quad-word for 8 bytes.


Using as - Rept

.rept count

Repeat the sequence of lines between the .rept directive and the next .endr directive count times.

For example, assembling

        .rept   3
        .long   0
        .endr

is equivalent to assembling

        .long   0
        .long   0
        .long   0


Using as - Sbttl

.sbttl "subheading"

Use subheading as the title (third line, immediately after the title line) when generating assembly listings.

This directive affects subsequent pages, as well as the current page if it appears within ten lines of the top of a page.


Using as - Scl

.scl class

Set the storage-class value for a symbol. This directive may only be used inside a .def/.endef pair. Storage class may flag whether a symbol is static or external, or it may record further symbolic debugging information.

The `.scl' directive is primarily associated with COFF output; when configured to generate b.out output format, as accepts this directive but ignores it.


Using as - Section

.section name

Use the .section directive to assemble the following code into a section named name.

This directive is only supported for targets that actually support arbitrarily named sections; on a.out targets, for example, it is not accepted, even with a standard a.out section name.

For COFF targets, the .section directive is used in one of the following ways:

.section name[, "flags"]
.section name[, subsegment]

If the optional argument is quoted, it is taken as flags to use for the section. Each flag is a single character. The following flags are recognized:

b
bss section (uninitialized data)
n
section is not loaded
w
writable section
d
data section
r
read-only section
x
executable section

If no flags are specified, the default flags depend upon the section name. If the section name is not recognized, the default will be for the section to be loaded and writable.

If the optional argument to the .section directive is not quoted, it is taken as a subsegment number (see section Sub-Sections).

For ELF targets, the .section directive is used like this:

.section name[, "flags"[, @type]]

The optional flags argument is a quoted string which may contain any combintion of the following characters:

a
section is allocatable
w
section is writable
x
section is executable

The optional type argument may contain one of the following constants:

@progbits
section contains data
@nobits
section does not contain data (i.e., section only occupies space)

If no flags are specified, the default flags depend upon the section name. If the section name is not recognized, the default will be for the section to have none of the above flags: it will not be allocated in memory, nor writable, nor executable. The section will contain data.

For ELF targets, the assembler supports another type of .section directive for compatibility with the Solaris assembler:

.section "name"[, flags...]

Note that the section name is quoted. There may be a sequence of comma separated flags:

#alloc
section is allocatable
#write
section is writable
#execinstr
section is executable


Using as - Set

.set symbol, expression

Set the value of symbol to expression. This changes symbol's value and type to conform to expression. If symbol was flagged as external, it remains flagged (see section Symbol Attributes).

You may .set a symbol many times in the same assembly.

If you .set a global symbol, the value stored in the object file is the last value stored into it.

The syntax for set on the HPPA is `symbol .set expression'.


Using as - Short

.short expressions

.short is normally the same as `.word'. See section .word expressions.

In some configurations, however, .short and .word generate numbers of different lengths; see section Machine Dependent Features.


Using as - Single

.single flonums

This directive assembles zero or more flonums, separated by commas. It has the same effect as .float. The exact kind of floating point numbers emitted depends on how as is configured. See section Machine Dependent Features.


Using as - Size

.size

This directive is generated by compilers to include auxiliary debugging information in the symbol table. It is only permitted inside .def/.endef pairs.

`.size' is only meaningful when generating COFF format output; when as is generating b.out, it accepts this directive but ignores it.


Using as - Sleb128

.sleb128 expressions

sleb128 stands for "signed little endian base 128." This is a compact, variable length representation of numbers used by the DWARF symbolic debugging format. See section .uleb128 expressions.


Using as - Skip

.skip size , fill

This directive emits size bytes, each of value fill. Both size and fill are absolute expressions. If the comma and fill are omitted, fill is assumed to be zero. This is the same as `.space'.


Using as - Space

.space size , fill

This directive emits size bytes, each of value fill. Both size and fill are absolute expressions. If the comma and fill are omitted, fill is assumed to be zero. This is the same as `.skip'.

Warning: .space has a completely different meaning for HPPA targets; use .block as a substitute. See HP9000 Series 800 Assembly Language Reference Manual (HP 92432-90001) for the meaning of the .space directive. See section HPPA Assembler Directives, for a summary.

On the AMD 29K, this directive is ignored; it is accepted for compatibility with other AMD 29K assemblers.

Warning: In most versions of the GNU assembler, the directive .space has the effect of .block See section Machine Dependent Features.


Using as - Stab

.stabd, .stabn, .stabs

There are three directives that begin `.stab'. All emit symbols (see section Symbols), for use by symbolic debuggers. The symbols are not entered in the as hash table: they cannot be referenced elsewhere in the source file. Up to five fields are required:

string
This is the symbol's name. It may contain any character except `\000', so is more general than ordinary symbol names. Some debuggers used to code arbitrarily complex structures into symbol names using this field.
type
An absolute expression. The symbol's type is set to the low 8 bits of this expression. Any bit pattern is permitted, but ld and debuggers choke on silly bit patterns.
other
An absolute expression. The symbol's "other" attribute is set to the low 8 bits of this expression.
desc
An absolute expression. The symbol's descriptor is set to the low 16 bits of this expression.
value
An absolute expression which becomes the symbol's value.

If a warning is detected while reading a .stabd, .stabn, or .stabs statement, the symbol has probably already been created; you get a half-formed symbol in your object file. This is compatible with earlier assemblers!

.stabd type , other , desc
The "name" of the symbol generated is not even an empty string. It is a null pointer, for compatibility. Older assemblers used a null pointer so they didn't waste space in object files with empty strings. The symbol's value is set to the location counter, relocatably. When your program is linked, the value of this symbol is the address of the location counter when the .stabd was assembled.
.stabn type , other , desc , value
The name of the symbol is set to the empty string "".
.stabs string , type , other , desc , value
All five fields are specified.


Using as - String

.string "str"

Copy the characters in str to the object file. You may specify more than one string to copy, separated by commas. Unless otherwise specified for a particular machine, the assembler marks the end of each string with a 0 byte. You can use any of the escape sequences described in section Strings.


Using as - Symver

.symver

Use the .symver directive to bind symbols to specific version nodes within a source file. This is only supported on ELF platforms, and is typically used when assembling files to be linked into a shared library. There are cases where it may make sense to use this in objects to be bound into an application itself so as to override a versioned symbol from a shared library.

For ELF targets, the .symver directive is used like this:

.symver name, name2@nodename

In this case, the symbol name must exist and be defined within the file being assembled. The .versym directive effectively creates a symbol alias with the name name2@nodename, and in fact the main reason that we just don't try and create a regular alias is that the @ character isn't permitted in symbol names. The name2 part of the name is the actual name of the symbol by which it will be externally referenced. The name name itself is merely a name of convenience that is used so that it is possible to have definitions for multiple versions of a function within a single source file, and so that the compiler can unambiguously know which version of a function is being mentioned. The nodename portion of the alias should be the name of a node specified in the version script supplied to the linker when building a shared library. If you are attempting to override a versioned symbol from a shared library, then nodename should correspond to the nodename of the symbol you are trying to override.


Using as - Tag

.tag structname

This directive is generated by compilers to include auxiliary debugging information in the symbol table. It is only permitted inside .def/.endef pairs. Tags are used to link structure definitions in the symbol table with instances of those structures.

`.tag' is only used when generating COFF format output; when as is generating b.out, it accepts this directive but ignores it.


Using as - Text

.text subsection

Tells as to assemble the following statements onto the end of the text subsection numbered subsection, which is an absolute expression. If subsection is omitted, subsection number zero is used.


Using as - Title

.title "heading"

Use heading as the title (second line, immediately after the source file name and pagenumber) when generating assembly listings.

This directive affects subsequent pages, as well as the current page if it appears within ten lines of the top of a page.


Using as - Type

.type int

This directive, permitted only within .def/.endef pairs, records the integer int as the type attribute of a symbol table entry.

`.type' is associated only with COFF format output; when as is configured for b.out output, it accepts this directive but ignores it.


Using as - Val

.val addr

This directive, permitted only within .def/.endef pairs, records the address addr as the value attribute of a symbol table entry.

`.val' is used only for COFF output; when as is configured for b.out, it accepts this directive but ignores it.


Using as - Uleb128

.uleb128 expressions

uleb128 stands for "unsigned little endian base 128." This is a compact, variable length representation of numbers used by the DWARF symbolic debugging format. See section .sleb128 expressions.


Using as - Word

.word expressions

This directive expects zero or more expressions, of any section, separated by commas.

The size of the number emitted, and its byte order, depend on what target computer the assembly is for.

Warning: Special Treatment to support Compilers

Machines with a 32-bit address space, but that do less than 32-bit addressing, require the following special treatment. If the machine of interest to you does 32-bit addressing (or doesn't require it; see section Machine Dependent Features), you can ignore this issue.

In order to assemble compiler output into something that works, as occasionlly does strange things to `.word' directives. Directives of the form `.word sym1-sym2' are often emitted by compilers as part of jump tables. Therefore, when as assembles a directive of the form `.word sym1-sym2', and the difference between sym1 and sym2 does not fit in 16 bits, as creates a secondary jump table, immediately before the next label. This secondary jump table is preceded by a short-jump to the first byte after the secondary table. This short-jump prevents the flow of control from accidentally falling into the new table. Inside the table is a long-jump to sym2. The original `.word' contains sym1 minus the address of the long-jump to sym2.

If there were several occurrences of `.word sym1-sym2' before the secondary jump table, all of them are adjusted. If there was a `.word sym3-sym4', that also did not fit in sixteen bits, a long-jump to sym4 is included in the secondary jump table, and the .word directives are adjusted to contain sym3 minus the address of the long-jump to sym4; and so on, for as many entries in the original jump table as necessary.


Using as - Deprecated

Deprecated Directives

One day these directives won't work. They are included for compatibility with older assemblers.

.abort
.app-file
.line


Using as - Machine Dependencies

Machine Dependent Features

The machine instruction sets are (almost by definition) different on each machine where as runs. Floating point representations vary as well, and as often supports a few additional directives or command-line options for compatibility with other assemblers on a particular platform. Finally, some versions of as support special pseudo-instructions for branch optimization.

This chapter discusses most of these differences, though it does not include details on any machine's instruction set. For details on that subject, see the hardware manufacturer's manual.

@lowersections


Using as - ARC-Dependent

ARC Dependent Features


Using as - ARC-Opts

Options

The ARC chip family includes several successive levels (or other variants) of chip, using the same core instruction set, but including a few additional instructions at each level.

By default, as assumes the core instruction set (ARC base). The .cpu pseudo-op is intended to be used to select the variant.

-mbig-endian
-mlittle-endian
Any ARC configuration of as can select big-endian or little-endian output at run time (unlike most other GNU development tools, which must be configured for one or the other). Use `-mbig-endian' to select big-endian output, and `-mlittle-endian' for little-endian.


Using as - ARC-Float

Floating Point

The ARC cpu family currently does not have hardware floating point support. Software floating point support is provided by GCC and uses IEEE floating-point numbers.


Using as - ARC-Directives

ARC Machine Directives

The ARC version of as supports the following additional machine directives:

.cpu
This must be followed by the desired cpu. The ARC is intended to be customizable, .cpu is used to select the desired variant [though currently there are none].


Using as - AMD29K-Dependent

AMD 29K Dependent Features


Using as - AMD29K Options

Options

as has no additional command-line options for the AMD 29K family.


Using as - AMD29K Syntax

Syntax


Using as - AMD29K-Macros

Macros

The macro syntax used on the AMD 29K is like that described in the AMD 29K Family Macro Assembler Specification. Normal as macros should still work.


Using as - AMD29K-Chars

Special Characters

`;' is the line comment character.

The character `?' is permitted in identifiers (but may not begin an identifier).


Using as - AMD29K-Regs

Register Names

General-purpose registers are represented by predefined symbols of the form `GRnnn' (for global registers) or `LRnnn' (for local registers), where nnn represents a number between 0 and 127, written with no leading zeros. The leading letters may be in either upper or lower case; for example, `gr13' and `LR7' are both valid register names.

You may also refer to general-purpose registers by specifying the register number as the result of an expression (prefixed with `%%' to flag the expression as a register number):

%%expression

---where expression must be an absolute expression evaluating to a number between 0 and 255. The range [0, 127] refers to global registers, and the range [128, 255] to local registers.

In addition, as understands the following protected special-purpose register names for the AMD 29K family:

  vab    chd    pc0
  ops    chc    pc1
  cps    rbp    pc2
  cfg    tmc    mmu
  cha    tmr    lru

These unprotected special-purpose register names are also recognized:

  ipc    alu    fpe
  ipa    bp     inte
  ipb    fc     fps
  q      cr     exop


Using as - AMD29K Floating Point

Floating Point

The AMD 29K family uses IEEE floating-point numbers.


Using as - AMD29K Directives

AMD 29K Machine Directives

.block size , fill
This directive emits size bytes, each of value fill. Both size and fill are absolute expressions. If the comma and fill are omitted, fill is assumed to be zero. In other versions of the GNU assembler, this directive is called `.space'.
.cputype
This directive is ignored; it is accepted for compatibility with other AMD 29K assemblers.
.file
This directive is ignored; it is accepted for compatibility with other AMD 29K assemblers.

Warning: in other versions of the GNU assembler, .file is used for the directive called .app-file in the AMD 29K support.

.line
This directive is ignored; it is accepted for compatibility with other AMD 29K assemblers.
.sect
This directive is ignored; it is accepted for compatibility with other AMD 29K assemblers.
.use section name
Establishes the section and subsection for the following code; section name may be one of .text, .data, .data1, or .lit. With one of the first three section name options, `.use' is equivalent to the machine directive section name; the remaining case, `.use .lit', is the same as `.data 200'.


Using as - AMD29K Opcodes

Opcodes

as implements all the standard AMD 29K opcodes. No additional pseudo-instructions are needed on this family.

For information on the 29K machine instruction set, see Am29000 User's Manual, Advanced Micro Devices, Inc.


Using as - ARM-Dependent

ARM Dependent Features


Using as - ARM Options

Options

as has no additional command-line options for the ARM processor family.


Using as - ARM Syntax

Syntax


Using as - ARM-Chars

Special Characters

`;' is the line comment character.

*TODO* Explain about /data modifier on symbols.


Using as - ARM-Regs

Register Names

*TODO* Explain about ARM register naming, and the predefined names.


Using as - ARM Floating Point

Floating Point

The ARM family uses IEEE floating-point numbers.


Using as - ARM Directives

ARM Machine Directives

.code [16|32]
This directive selects the instruction set being generated. The value 16 selects Thumb, with the value 32 selecting ARM.
.thumb
This performs the same action as .code 16.
.arm
This performs the same action as .code 32.


Using as - ARM Opcodes

Opcodes

as implements all the standard ARM opcodes.

*TODO* Document the pseudo-ops (adr, nop)

For information on the ARM or Thumb instruction sets, see ARM Software Development Toolkit Reference Manual, Advanced RISC Machines Ltd.


Using as - D10V-Dependent

D10V Dependent Features


Using as - D10V-Opts

D10V Options

The Mitsubishi D10V version of as has a few machine dependent options.

`-O'
The D10V can often execute two sub-instructions in parallel. When this option is used, as will attempt to optimize its output by detecting when instructions can be executed in parallel.


Using as - D10V-Syntax

Syntax

The D10V syntax is based on the syntax in Mitsubishi's D10V architecture manual. The differences are detailed below.


Using as - D10V-Size

Size Modifiers

The D10V version of as uses the instruction names in the D10V Architecture Manual. However, the names in the manual are sometimes ambiguous. There are instruction names that can assemble to a short or long form opcode. How does the assembler pick the correct form? as will always pick the smallest form if it can. When dealing with a symbol that is not defined yet when a line is being assembled, it will always use the long form. If you need to force the assembler to use either the short or long form of the instruction, you can append either `.s' (short) or `.l' (long) to it. For example, if you are writing an assembly program and you want to do a branch to a symbol that is defined later in your program, you can write `bra.s foo'. Objdump and GDB will always append `.s' or `.l' to instructions which have both short and long forms.


Using as - D10V-Subs

Sub-Instructions

The D10V assembler takes as input a series of instructions, either one-per-line, or in the special two-per-line format described in the next section. Some of these instructions will be short-form or sub-instructions. These sub-instructions can be packed into a single instruction. The assembler will do this automatically. It will also detect when it should not pack instructions. For example, when a label is defined, the next instruction will never be packaged with the previous one. Whenever a branch and link instruction is called, it will not be packaged with the next instruction so the return address will be valid. Nops are automatically inserted when necessary.

If you do not want the assembler automatically making these decisions, you can control the packaging and execution type (parallel or sequential) with the special execution symbols described in the next section.


Using as - D10V-Chars

Special Characters

`;' and `#' are the line comment characters. Sub-instructions may be executed in order, in reverse-order, or in parallel. Instructions listed in the standard one-per-line format will be executed sequentially. To specify the executing order, use the following symbols:

`->'
Sequential with instruction on the left first.
`<-'
Sequential with instruction on the right first.
`||'
Parallel

The D10V syntax allows either one instruction per line, one instruction per line with the execution symbol, or two instructions per line. For example

abs a1 -> abs r0
Execute these sequentially. The instruction on the right is in the right container and is executed second.
abs r0 <- abs a1
Execute these reverse-sequentially. The instruction on the right is in the right container, and is executed first.
ld2w r2,@r8+ || mac a0,r0,r7
Execute these in parallel.
ld2w r2,@r8+ ||
mac a0,r0,r7
Two-line format. Execute these in parallel.
ld2w r2,@r8+
mac a0,r0,r7
Two-line format. Execute these sequentially. Assembler will put them in the proper containers.
ld2w r2,@r8+ ->
mac a0,r0,r7
Two-line format. Execute these sequentially. Same as above but second instruction will always go into right container.

Since `$' has no special meaning, you may use it in symbol names.


Using as - D10V-Regs

Register Names

You can use the predefined symbols `r0' through `r15' to refer to the D10V registers. You can also use `sp' as an alias for `r15'. The accumulators are `a0' and `a1'. There are special register-pair names that may optionally be used in opcodes that require even-numbered registers. Register names are not case sensitive.

Register Pairs

r0-r1
r2-r3
r4-r5
r6-r7
r8-r9
r10-r11
r12-r13
r14-r15

The D10V also has predefined symbols for these control registers and status bits:

psw
Processor Status Word
bpsw
Backup Processor Status Word
pc
Program Counter
bpc
Backup Program Counter
rpt_c
Repeat Count
rpt_s
Repeat Start address
rpt_e
Repeat End address
mod_s
Modulo Start address
mod_e
Modulo End address
iba
Instruction Break Address
f0
Flag 0
f1
Flag 1
c
Carry flag


Using as - D10V-Addressing

Addressing Modes

as understands the following addressing modes for the D10V. Rn in the following refers to any of the numbered registers, but not the control registers.

Rn
Register direct
@Rn
Register indirect
@Rn+
Register indirect with post-increment
@Rn-
Register indirect with post-decrement
@-SP
Register indirect with pre-decrement
@(disp, Rn)
Register indirect with displacement
addr
PC relative address (for branch or rep).
#imm
Immediate data (the `#' is optional and ignored)


Using as - D10V-Word

@WORD Modifier

Any symbol followed by @word will be replaced by the symbol's value shifted right by 2. This is used in situations such as loading a register with the address of a function (or any other code fragment). For example, if you want to load a register with the location of the function main then jump to that function, you could do it as follws:

ldi     r2, main@word
jmp     r2


Using as - D10V-Float

Floating Point

The D10V has no hardware floating point, but the .float and .double directives generates IEEE floating-point numbers for compatibility with other development tools.


Using as - D10V-Opcodes

Opcodes

For detailed information on the D10V machine instruction set, see D10V Architecture: A VLIW Microprocessor for Multimedia Applications (Mitsubishi Electric Corp.). as implements all the standard D10V opcodes. The only changes are those described in the section on size modifiers


Using as - H8/300-Dependent

H8/300 Dependent Features


Using as - H8/300 Options

Options

as has no additional command-line options for the Hitachi H8/300 family.


Using as - H8/300 Syntax

Syntax


Using as - H8/300-Chars

Special Characters

`;' is the line comment character.

`$' can be used instead of a newline to separate statements. Therefore you may not use `$' in symbol names on the H8/300.


Using as - H8/300-Regs

Register Names

You can use predefined symbols of the form `rnh' and `rnl' to refer to the H8/300 registers as sixteen 8-bit general-purpose registers. n is a digit from `0' to `7'); for instance, both `r0h' and `r7l' are valid register names.

You can also use the eight predefined symbols `rn' to refer to the H8/300 registers as 16-bit registers (you must use this form for addressing).

On the H8/300H, you can also use the eight predefined symbols `ern' (`er0' ... `er7') to refer to the 32-bit general purpose registers.

The two control registers are called pc (program counter; a 16-bit register, except on the H8/300H where it is 24 bits) and ccr (condition code register; an 8-bit register). r7 is used as the stack pointer, and can also be called sp.


Using as - H8/300-Addressing

Addressing Modes

as understands the following addressing modes for the H8/300:

rn
Register direct
@rn
Register indirect
@(d, rn)
@(d:16, rn)
@(d:24, rn)
Register indirect: 16-bit or 24-bit displacement d from register n. (24-bit displacements are only meaningful on the H8/300H.)
@rn+
Register indirect with post-increment
@-rn
Register indirect with pre-decrement
@aa
@aa:8
@aa:16
@aa:24
Absolute address aa. (The address size `:24' only makes sense on the H8/300H.)
#xx
#xx:8
#xx:16
#xx:32
Immediate data xx. You may specify the `:8', `:16', or `:32' for clarity, if you wish; but as neither requires this nor uses it--the data size required is taken from context.
@@aa
@@aa:8
Memory indirect. You may specify the `:8' for clarity, if you wish; but as neither requires this nor uses it.


Using as - H8/300 Floating Point

Floating Point

The H8/300 family has no hardware floating point, but the .float directive generates IEEE floating-point numbers for compatibility with other development tools.


Using as - H8/300 Directives

H8/300 Machine Directives

as has only one machine-dependent directive for the H8/300:

.h8300h
Recognize and emit additional instructions for the H8/300H variant, and also make .int emit 32-bit numbers rather than the usual (16-bit) for the H8/300 family.

On the H8/300 family (including the H8/300H) `.word' directives generate 16-bit numbers.


Using as - H8/300 Opcodes

Opcodes

For detailed information on the H8/300 machine instruction set, see H8/300 Series Programming Manual (Hitachi ADE--602--025). For information specific to the H8/300H, see H8/300H Series Programming Manual (Hitachi).

as implements all the standard H8/300 opcodes. No additional pseudo-instructions are needed on this family.

Four H8/300 instructions (add, cmp, mov, sub) are defined with variants using the suffixes `.b', `.w', and `.l' to specify the size of a memory operand. as supports these suffixes, but does not require them; since one of the operands is always a register, as can deduce the correct size.

For example, since r0 refers to a 16-bit register,

mov    r0,@foo
is equivalent to
mov.w  r0,@foo

If you use the size suffixes, as issues a warning when the suffix and the register size do not match.


Using as - H8/500-Dependent

H8/500 Dependent Features


Using as - H8/500 Options

Options

as has no additional command-line options for the Hitachi H8/500 family.


Using as - H8/500 Syntax

Syntax


Using as - H8/500-Chars

Special Characters

`!' is the line comment character.

`;' can be used instead of a newline to separate statements.

Since `$' has no special meaning, you may use it in symbol names.


Using as - H8/500-Regs

Register Names

You can use the predefined symbols `r0', `r1', `r2', `r3', `r4', `r5', `r6', and `r7' to refer to the H8/500 registers.

The H8/500 also has these control registers:

cp
code pointer
dp
data pointer
bp
base pointer
tp
stack top pointer
ep
extra pointer
sr
status register
ccr
condition code register

All registers are 16 bits long. To represent 32 bit numbers, use two adjacent registers; for distant memory addresses, use one of the segment pointers (cp for the program counter; dp for r0--r3; ep for r4 and r5; and tp for r6 and r7.


Using as - H8/500-Addressing

Addressing Modes

as understands the following addressing modes for the H8/500:

Rn
Register direct
@Rn
Register indirect
@(d:8, Rn)
Register indirect with 8 bit signed displacement
@(d:16, Rn)
Register indirect with 16 bit signed displacement
@-Rn
Register indirect with pre-decrement
@Rn+
Register indirect with post-increment
@aa:8
8 bit absolute address
@aa:16
16 bit absolute address
#xx:8
8 bit immediate
#xx:16
16 bit immediate


Using as - H8/500 Floating Point

Floating Point

The H8/500 family has no hardware floating point, but the .float directive generates IEEE floating-point numbers for compatibility with other development tools.


Using as - H8/500 Directives

H8/500 Machine Directives

as has no machine-dependent directives for the H8/500. However, on this platform the `.int' and `.word' directives generate 16-bit numbers.


Using as - H8/500 Opcodes

Opcodes

For detailed information on the H8/500 machine instruction set, see H8/500 Series Programming Manual (Hitachi M21T001).

as implements all the standard H8/500 opcodes. No additional pseudo-instructions are needed on this family.


Using as - HPPA-Dependent

HPPA Dependent Features


Using as - HPPA Notes

Notes

As a back end for GNU CC as has been throughly tested and should work extremely well. We have tested it only minimally on hand written assembly code and no one has tested it much on the assembly output from the HP compilers.

The format of the debugging sections has changed since the original as port (version 1.3X) was released; therefore, you must rebuild all HPPA objects and libraries with the new assembler so that you can debug the final executable.

The HPPA as port generates a small subset of the relocations available in the SOM and ELF object file formats. Additional relocation support will be added as it becomes necessary.


Using as - HPPA Options

Options

as has no machine-dependent command-line options for the HPPA.


Using as - HPPA Syntax

Syntax

The assembler syntax closely follows the HPPA instruction set reference manual; assembler directives and general syntax closely follow the HPPA assembly language reference manual, with a few noteworthy differences.

First, a colon may immediately follow a label definition. This is simply for compatibility with how most assembly language programmers write code.

Some obscure expression parsing problems may affect hand written code which uses the spop instructions, or code which makes significant use of the ! line separator.

as is much less forgiving about missing arguments and other similar oversights than the HP assembler. as notifies you of missing arguments as syntax errors; this is regarded as a feature, not a bug.

Finally, as allows you to use an external symbol without explicitly importing the symbol. Warning: in the future this will be an error for HPPA targets.

Special characters for HPPA targets include:

`;' is the line comment character.

`!' can be used instead of a newline to separate statements.

Since `$' has no special meaning, you may use it in symbol names.


Using as - HPPA Floating Point

Floating Point

The HPPA family uses IEEE floating-point numbers.


Using as - HPPA Directives

HPPA Assembler Directives

as for the HPPA supports many additional directives for compatibility with the native assembler. This section describes them only briefly. For detailed information on HPPA-specific assembler directives, see HP9000 Series 800 Assembly Language Reference Manual (HP 92432-90001).

as does not support the following assembler directives described in the HP manual:

.endm           .liston
.enter          .locct
.leave          .macro
.listoff

Beyond those implemented for compatibility, as supports one additional assembler directive for the HPPA: .param. It conveys register argument locations for static functions. Its syntax closely follows the .export directive.

These are the additional directives in as for the HPPA:

.block n
.blockz n
Reserve n bytes of storage, and initialize them to zero.
.call
Mark the beginning of a procedure call. Only the special case with no arguments is allowed.
.callinfo [ param=value, ... ] [ flag, ... ]
Specify a number of parameters and flags that define the environment for a procedure. param may be any of `frame' (frame size), `entry_gr' (end of general register range), `entry_fr' (end of float register range), `entry_sr' (end of space register range). The values for flag are `calls' or `caller' (proc has subroutines), `no_calls' (proc does not call subroutines), `save_rp' (preserve return pointer), `save_sp' (proc preserves stack pointer), `no_unwind' (do not unwind this proc), `hpux_int' (proc is interrupt routine).
.code
Assemble into the standard section called `$TEXT$', subsection `$CODE$'.
.copyright "string"
In the SOM object format, insert string into the object code, marked as a copyright string.
.copyright "string"
In the ELF object format, insert string into the object code, marked as a version string.
.enter
Not yet supported; the assembler rejects programs containing this directive.
.entry
Mark the beginning of a procedure.
.exit
Mark the end of a procedure.
.export name [ ,typ ] [ ,param=r ]
Make a procedure name available to callers. typ, if present, must be one of `absolute', `code' (ELF only, not SOM), `data', `entry', `data', `entry', `millicode', `plabel', `pri_prog', or `sec_prog'. param, if present, provides either relocation information for the procedure arguments and result, or a privilege level. param may be `argwn' (where n ranges from 0 to 3, and indicates one of four one-word arguments); `rtnval' (the procedure's result); or `priv_lev' (privilege level). For arguments or the result, r specifies how to relocate, and must be one of `no' (not relocatable), `gr' (argument is in general register), `fr' (in floating point register), or `fu' (upper half of float register). For `priv_lev', r is an integer.
.half n
Define a two-byte integer constant n; synonym for the portable as directive .short.
.import name [ ,typ ]
Converse of .export; make a procedure available to call. The arguments use the same conventions as the first two arguments for .export.
.label name
Define name as a label for the current assembly location.
.leave
Not yet supported; the assembler rejects programs containing this directive.
.origin lc
Advance location counter to lc. Synonym for the portable directive .org.
.param name [ ,typ ] [ ,param=r ]
Similar to .export, but used for static procedures.
.proc
Use preceding the first statement of a procedure.
.procend
Use following the last statement of a procedure.
label .reg expr
Synonym for .equ; define label with the absolute expression expr as its value.
.space secname [ ,params ]
Switch to section secname, creating a new section by that name if necessary. You may only use params when creating a new section, not when switching to an existing one. secname may identify a section by number rather than by name. If specified, the list params declares attributes of the section, identified by keywords. The keywords recognized are `spnum=exp' (identify this section by the number exp, an absolute expression), `sort=exp' (order sections according to this sort key when linking; exp is an absolute expression), `unloadable' (section contains no loadable data), `notdefined' (this section defined elsewhere), and `private' (data in this section not available to other programs).
.spnum secnam
Allocate four bytes of storage, and initialize them with the section number of the section named secnam. (You can define the section number with the HPPA .space directive.)
.string "str"
Copy the characters in the string str to the object file. See section Strings, for information on escape sequences you can use in as strings. Warning! The HPPA version of .string differs from the usual as definition: it does not write a zero byte after copying str.
.stringz "str"
Like .string, but appends a zero byte after copying str to object file.
.subspa name [ ,params ]
.nsubspa name [ ,params ]
Similar to .space, but selects a subsection name within the current section. You may only specify params when you create a subsection (in the first instance of .subspa for this name). If specified, the list params declares attributes of the subsection, identified by keywords. The keywords recognized are `quad=expr' ("quadrant" for this subsection), `align=expr' (alignment for beginning of this subsection; a power of two), `access=expr' (value for "access rights" field), `sort=expr' (sorting order for this subspace in link), `code_only' (subsection contains only code), `unloadable' (subsection cannot be loaded into memory), `common' (subsection is common block), `dup_comm' (initialized data may have duplicate names), or `zero' (subsection is all zeros, do not write in object file). .nsubspa always creates a new subspace with the given name, even if one with the same name already exists.
.version "str"
Write str as version identifier in object code.


Using as - HPPA Opcodes

Opcodes

For detailed information on the HPPA machine instruction set, see PA-RISC Architecture and Instruction Set Reference Manual (HP 09740-90039).


Using as - i386-Dependent

80386 Dependent Features


Using as - i386-Options

Options

The 80386 has no machine dependent options.


Using as - i386-Syntax

AT&T Syntax versus Intel Syntax

In order to maintain compatibility with the output of gcc, as supports AT&T System V/386 assembler syntax. This is quite different from Intel syntax. We mention these differences because almost all 80386 documents used only Intel syntax. Notable differences between the two syntaxes are:

  • AT&T immediate operands are preceded by `$'; Intel immediate operands are undelimited (Intel `push 4' is AT&T `pushl $4'). AT&T register operands are preceded by `%'; Intel register operands are undelimited. AT&T absolute (as opposed to PC relative) jump/call operands are prefixed by `*'; they are undelimited in Intel syntax.
  • AT&T and Intel syntax use the opposite order for source and destination operands. Intel `add eax, 4' is `addl $4, %eax'. The `source, dest' convention is maintained for compatibility with previous Unix assemblers.
  • In AT&T syntax the size of memory operands is determined from the last character of the opcode name. Opcode suffixes of `b', `w', and `l' specify byte (8-bit), word (16-bit), and long (32-bit) memory references. Intel syntax accomplishes this by prefixes memory operands (not the opcodes themselves) with `byte ptr', `word ptr', and `dword ptr'. Thus, Intel `mov al, byte ptr foo' is `movb foo, %al' in AT&T syntax.
  • Immediate form long jumps and calls are `lcall/ljmp $section, $offset' in AT&T syntax; the Intel syntax is `call/jmp far section:offset'. Also, the far return instruction is `lret $stack-adjust' in AT&T syntax; Intel syntax is `ret far stack-adjust'.
  • The AT&T assembler does not provide support for multiple section programs. Unix style systems expect all programs to be single sections.


Using as - i386-Opcodes

Opcode Naming

Opcode names are suffixed with one character modifiers which specify the size of operands. The letters `b', `w', and `l' specify byte, word, and long operands. If no suffix is specified by an instruction and it contains no memory operands then as tries to fill in the missing suffix based on the destination register operand (the last one by convention). Thus, `mov %ax, %bx' is equivalent to `movw %ax, %bx'; also, `mov $1, %bx' is equivalent to `movw $1, %bx'. Note that this is incompatible with the AT&T Unix assembler which assumes that a missing opcode suffix implies long operand size. (This incompatibility does not affect compiler output since compilers always explicitly specify the opcode suffix.)

Almost all opcodes have the same names in AT&T and Intel format. There are a few exceptions. The sign extend and zero extend instructions need two sizes to specify them. They need a size to sign/zero extend from and a size to zero extend to. This is accomplished by using two opcode suffixes in AT&T syntax. Base names for sign extend and zero extend are `movs...' and `movz...' in AT&T syntax (`movsx' and `movzx' in Intel syntax). The opcode suffixes are tacked on to this base name, the from suffix before the to suffix. Thus, `movsbl %al, %edx' is AT&T syntax for "move sign extend from %al to %edx." Possible suffixes, thus, are `bl' (from byte to long), `bw' (from byte to word), and `wl' (from word to long).

The Intel-syntax conversion instructions

  • `cbw' -- sign-extend byte in `%al' to word in `%ax',
  • `cwde' -- sign-extend word in `%ax' to long in `%eax',
  • `cwd' -- sign-extend word in `%ax' to long in `%dx:%ax',
  • `cdq' -- sign-extend dword in `%eax' to quad in `%edx:%eax',

are called `cbtw', `cwtl', `cwtd', and `cltd' in AT&T naming. as accepts either naming for these instructions.

Far call/jump instructions are `lcall' and `ljmp' in AT&T syntax, but are `call far' and `jump far' in Intel convention.


Using as - i386-Regs

Register Naming

Register operands are always prefixes with `%'. The 80386 registers consist of

  • the 8 32-bit registers `%eax' (the accumulator), `%ebx', `%ecx', `%edx', `%edi', `%esi', `%ebp' (the frame pointer), and `%esp' (the stack pointer).
  • the 8 16-bit low-ends of these: `%ax', `%bx', `%cx', `%dx', `%di', `%si', `%bp', and `%sp'.
  • the 8 8-bit registers: `%ah', `%al', `%bh', `%bl', `%ch', `%cl', `%dh', and `%dl' (These are the high-bytes and low-bytes of `%ax', `%bx', `%cx', and `%dx')
  • the 6 section registers `%cs' (code section), `%ds' (data section), `%ss' (stack section), `%es', `%fs', and `%gs'.
  • the 3 processor control registers `%cr0', `%cr2', and `%cr3'.
  • the 6 debug registers `%db0', `%db1', `%db2', `%db3', `%db6', and `%db7'.
  • the 2 test registers `%tr6' and `%tr7'.
  • the 8 floating point register stack `%st' or equivalently `%st(0)', `%st(1)', `%st(2)', `%st(3)', `%st(4)', `%st(5)', `%st(6)', and `%st(7)'.


Using as - i386-prefixes

Opcode Prefixes

Opcode prefixes are used to modify the following opcode. They are used to repeat string instructions, to provide section overrides, to perform bus lock operations, and to give operand and address size (16-bit operands are specified in an instruction by prefixing what would normally be 32-bit operands with a "operand size" opcode prefix). Opcode prefixes are usually given as single-line instructions with no operands, and must directly precede the instruction they act upon. For example, the `scas' (scan string) instruction is repeated with:

        repne
        scas

Here is a list of opcode prefixes:

  • Section override prefixes `cs', `ds', `ss', `es', `fs', `gs'. These are automatically added by specifying using the section:memory-operand form for memory references.
  • Operand/Address size prefixes `data16' and `addr16' change 32-bit operands/addresses into 16-bit operands/addresses. Note that 16-bit addressing modes (i.e. 8086 and 80286 addressing modes) are not supported (yet).
  • The bus lock prefix `lock' inhibits interrupts during execution of the instruction it precedes. (This is only valid with certain instructions; see a 80386 manual for details).
  • The wait for coprocessor prefix `wait' waits for the coprocessor to complete the current instruction. This should never be needed for the 80386/80387 combination.
  • The `rep', `repe', and `repne' prefixes are added to string instructions to make them repeat `%ecx' times.


Using as - i386-Memory

Memory References

An Intel syntax indirect memory reference of the form

section:[base + index*scale + disp]

is translated into the AT&T syntax

section:disp(base, index, scale)

where base and index are the optional 32-bit base and index registers, disp is the optional displacement, and scale, taking the values 1, 2, 4, and 8, multiplies index to calculate the address of the operand. If no scale is specified, scale is taken to be 1. section specifies the optional section register for the memory operand, and may override the default section register (see a 80386 manual for section register defaults). Note that section overrides in AT&T syntax must have be preceded by a `%'. If you specify a section override which coincides with the default section register, as does not output any section register override prefixes to assemble the given instruction. Thus, section overrides can be specified to emphasize which section register is used for a given memory operand.

Here are some examples of Intel and AT&T style memory references:

AT&T: `-4(%ebp)', Intel: `[ebp - 4]'
base is `%ebp'; disp is `-4'. section is missing, and the default section is used (`%ss' for addressing with `%ebp' as the base register). index, scale are both missing.
AT&T: `foo(,%eax,4)', Intel: `[foo + eax*4]'
index is `%eax' (scaled by a scale 4); disp is `foo'. All other fields are missing. The section register here defaults to `%ds'.
AT&T: `foo(,1)'; Intel `[foo]'
This uses the value pointed to by `foo' as a memory operand. Note that base and index are both missing, but there is only one `,'. This is a syntactic exception.
AT&T: `%gs:foo'; Intel `gs:foo'
This selects the contents of the variable `foo' with section register section being `%gs'.

Absolute (as opposed to PC relative) call and jump operands must be prefixed with `*'. If no `*' is specified, as always chooses PC relative addressing for jump/call labels.

Any instruction that has a memory operand must specify its size (byte, word, or long) with an opcode suffix (`b', `w', or `l', respectively).


Using as - i386-jumps

Handling of Jump Instructions

Jump instructions are always optimized to use the smallest possible displacements. This is accomplished by using byte (8-bit) displacement jumps whenever the target is sufficiently close. If a byte displacement is insufficient a long (32-bit) displacement is used. We do not support word (16-bit) displacement jumps (i.e. prefixing the jump instruction with the `addr16' opcode prefix), since the 80386 insists upon masking `%eip' to 16 bits after the word displacement is added.

Note that the `jcxz', `jecxz', `loop', `loopz', `loope', `loopnz' and `loopne' instructions only come in byte displacements, so that if you use these instructions (gcc does not use them) you may get an error message (and incorrect code). The AT&T 80386 assembler tries to get around this problem by expanding `jcxz foo' to

         jcxz cx_zero
         jmp cx_nonzero
cx_zero: jmp foo
cx_nonzero:


Using as - i386-Float

Floating Point

All 80387 floating point types except packed BCD are supported. (BCD support may be added without much difficulty). These data types are 16-, 32-, and 64- bit integers, and single (32-bit), double (64-bit), and extended (80-bit) precision floating point. Each supported type has an opcode suffix and a constructor associated with it. Opcode suffixes specify operand's data types. Constructors build these data types into memory.

  • Floating point constructors are `.float' or `.single', `.double', and `.tfloat' for 32-, 64-, and 80-bit formats. These correspond to opcode suffixes `s', `l', and `t'. `t' stands for temporary real, and that the 80387 only supports this format via the `fldt' (load temporary real to stack top) and `fstpt' (store temporary real and pop stack) instructions.
  • Integer constructors are `.word', `.long' or `.int', and `.quad' for the 16-, 32-, and 64-bit integer formats. The corresponding opcode suffixes are `s' (single), `l' (long), and `q' (quad). As with the temporary real format the 64-bit `q' format is only present in the `fildq' (load quad integer to stack top) and `fistpq' (store quad integer and pop stack) instructions.

Register to register operations do not require opcode suffixes, so that `fst %st, %st(1)' is equivalent to `fstl %st, %st(1)'.


Using as - i386-16bit

Writing 16-bit Code

While GAS normally writes only "pure" 32-bit i386 code, it has limited support for writing code to run in real mode or in 16-bit protected mode code segments. To do this, insert a `.code16' directive before the assembly language instructions to be run in 16-bit mode. You can switch GAS back to writing normal 32-bit code with the `.code32' directive.

GAS understands exactly the same assembly language syntax in 16-bit mode as in 32-bit mode. The function of any given instruction is exactly the same regardless of mode, as long as the resulting object code is executed in the mode for which GAS wrote it. So, for example, the `ret' mnemonic produces a 32-bit return instruction regardless of whether it is to be run in 16-bit or 32-bit mode. (If GAS is in 16-bit mode, it will add an operand size prefix to the instruction to force it to be a 32-bit return.)

This means, for one thing, that you can use GNU CC to write code to be run in real mode or 16-bit protected mode. Just insert the statement `asm(".code16");' at the beginning of your C source file, and while GNU CC will still be generating 32-bit code, GAS will automatically add all the necessary size prefixes to make that code run in 16-bit mode. Of course, since GNU CC only writes small-model code (it doesn't know how to attach segment selectors to pointers like native x86 compilers do), any 16-bit code you write with GNU CC will essentially be limited to a 64K address space. Also, there will be a code size and performance penalty due to all the extra address and operand size prefixes GAS has to add to the instructions.

Note that placing GAS in 16-bit mode does not mean that the resulting code will necessarily run on a 16-bit pre-80386 processor. To write code that runs on such a processor, you would have to refrain from using any 32-bit constructs which require GAS to output address or operand size prefixes. At the moment this would be rather difficult, because GAS currently supports only 32-bit addressing modes: when writing 16-bit code, it always outputs address size prefixes for any instruction that uses a non-register addressing mode. So you can write code that runs on 16-bit processors, but only if that code never references memory.


Using as - i386-Notes

Notes

There is some trickery concerning the `mul' and `imul' instructions that deserves mention. The 16-, 32-, and 64-bit expanding multiplies (base opcode `0xf6'; extension 4 for `mul' and 5 for `imul') can be output only in the one operand form. Thus, `imul %ebx, %eax' does not select the expanding multiply; the expanding multiply would clobber the `%edx' register, and this would confuse gcc output. Use `imul %ebx' to get the 64-bit product in `%edx:%eax'.

We have added a two operand form of `imul' when the first operand is an immediate mode expression and the second operand is a register. This is just a shorthand, so that, multiplying `%eax' by 69, for example, can be done with `imul $69, %eax' rather than `imul $69, %eax, %eax'.


Using as - i960-Dependent

Intel 80960 Dependent Features


Using as - Options-i960

i960 Command-line Options

-ACA | -ACA_A | -ACB | -ACC | -AKA | -AKB | -AKC | -AMC
Select the 80960 architecture. Instructions or features not supported by the selected architecture cause fatal errors. `-ACA' is equivalent to `-ACA_A'; `-AKC' is equivalent to `-AMC'. Synonyms are provided for compatibility with other tools. If you do not specify any of these options, as generates code for any instruction or feature that is supported by some version of the 960 (even if this means mixing architectures!). In principle, as attempts to deduce the minimal sufficient processor type if none is specified; depending on the object code format, the processor type may be recorded in the object file. If it is critical that the as output match a specific architecture, specify that architecture explicitly.
-b
Add code to collect information about conditional branches taken, for later optimization using branch prediction bits. (The conditional branch instructions have branch prediction bits in the CA, CB, and CC architectures.) If BR represents a conditional branch instruction, the following represents the code generated by the assembler when `-b' is specified:
        call    increment routine
        .word   0       # pre-counter
Label:  BR
        call    increment routine
        .word   0       # post-counter
The counter following a branch records the number of times that branch was not taken; the differenc between the two counters is the number of times the branch was taken. A table of every such Label is also generated, so that the external postprocessor gbr960 (supplied by Intel) can locate all the counters. This table is always labelled `__BRANCH_TABLE__'; this is a local symbol to permit collecting statistics for many separate object files. The table is word aligned, and begins with a two-word header. The first word, initialized to 0, is used in maintaining linked lists of branch tables. The second word is a count of the number of entries in the table, which follow immediately: each is a word, pointing to one of the labels illustrated above. The first word of the header is used to locate multiple branch tables, since each object file may contain one. Normally the links are maintained with a call to an initialization routine, placed at the beginning of each function in the file. The GNU C compiler generates these calls automatically when you give it a `-b' option. For further details, see the documentation of `gbr960'.
-no-relax
Normally, Compare-and-Branch instructions with targets that require displacements greater than 13 bits (or that have external targets) are replaced with the corresponding compare (or `chkbit') and branch instructions. You can use the `-no-relax' option to specify that as should generate errors instead, if the target displacement is larger than 13 bits. This option does not affect the Compare-and-Jump instructions; the code emitted for them is always adjusted when necessary (depending on displacement size), regardless of whether you use `-no-relax'.


Using as - Floating Point-i960

Floating Point

as generates IEEE floating-point numbers for the directives `.float', `.double', `.extended', and `.single'.


Using as - Directives-i960

i960 Machine Directives

.bss symbol, length, align
Reserve length bytes in the bss section for a local symbol, aligned to the power of two specified by align. length and align must be positive absolute expressions. This directive differs from `.lcomm' only in that it permits you to specify an alignment. See section .lcomm symbol , length.
.extended flonums
.extended expects zero or more flonums, separated by commas; for each flonum, `.extended' emits an IEEE extended-format (80-bit) floating-point number.
.leafproc call-lab, bal-lab
You can use the `.leafproc' directive in conjunction with the optimized callj instruction to enable faster calls of leaf procedures. If a procedure is known to call no other procedures, you may define an entry point that skips procedure prolog code (and that does not depend on system-supplied saved context), and declare it as the bal-lab using `.leafproc'. If the procedure also has an entry point that goes through the normal prolog, you can specify that entry point as call-lab. A `.leafproc' declaration is meant for use in conjunction with the optimized call instruction `callj'; the directive records the data needed later to choose between converting the `callj' into a bal or a call. call-lab is optional; if only one argument is present, or if the two arguments are identical, the single argument is assumed to be the bal entry point.
.sysproc name, index
The `.sysproc' directive defines a name for a system procedure. After you define it using `.sysproc', you can use name to refer to the system procedure identified by index when calling procedures with the optimized call instruction `callj'. Both arguments are required; index must be between 0 and 31 (inclusive).


Using as - Opcodes for i960

i960 Opcodes

All Intel 960 machine instructions are supported; see section i960 Command-line Options for a discussion of selecting the instruction subset for a particular 960 architecture.

Some opcodes are processed beyond simply emitting a single corresponding instruction: `callj', and Compare-and-Branch or Compare-and-Jump instructions with target displacements larger than 13 bits.


Using as - callj-i960

callj

You can write callj to have the assembler or the linker determine the most appropriate form of subroutine call: `call', `bal', or `calls'. If the assembly source contains enough information--a `.leafproc' or `.sysproc' directive defining the operand--then as translates the callj; if not, it simply emits the callj, leaving it for the linker to resolve.


Using as - Compare-and-branch-i960

Compare-and-Branch

The 960 architectures provide combined Compare-and-Branch instructions that permit you to store the branch target in the lower 13 bits of the instruction word itself. However, if you specify a branch target far enough away that its address won't fit in 13 bits, the assembler can either issue an error, or convert your Compare-and-Branch instruction into separate instructions to do the compare and the branch.

Whether as gives an error or expands the instruction depends on two choices you can make: whether you use the `-no-relax' option, and whether you use a "Compare and Branch" instruction or a "Compare and Jump" instruction. The "Jump" instructions are always expanded if necessary; the "Branch" instructions are expanded when necessary unless you specify -no-relax---in which case as gives an error instead.

These are the Compare-and-Branch instructions, their "Jump" variants, and the instruction pairs they may expand into:


Using as - M68K-Dependent

M680x0 Dependent Features


Using as - M68K-Opts

M680x0 Options

The Motorola 680x0 version of as has a few machine dependent options.

You can use the `-l' option to shorten the size of references to undefined symbols. If you do not use the `-l' option, references to undefined symbols are wide enough for a full long (32 bits). (Since as cannot know where these symbols end up, as can only allocate space for the linker to fill in later. Since as does not know how far away these symbols are, it allocates as much space as it can.) If you use this option, the references are only one word wide (16 bits). This may be useful if you want the object file to be as small as possible, and you know that the relevant symbols are always less than 17 bits away.

For some configurations, especially those where the compiler normally does not prepend an underscore to the names of user variables, the assembler requires a `%' before any use of a register name. This is intended to let the assembler distinguish between C variables and functions named `a0' through `a7', and so on. The `%' is always accepted, but is not required for certain configurations, notably `sun3'. The `--register-prefix-optional' option may be used to permit omitting the `%' even for configurations for which it is normally required. If this is done, it will generally be impossible to refer to C variables and functions with the same names as register names.

Normally the character `|' is treated as a comment character, which means that it can not be used in expressions. The `--bitwise-or' option turns `|' into a normal character. In this mode, you must either use C style comments, or start comments with a `#' character at the beginning of a line.

If you use an addressing mode with a base register without specifying the size, as will normally use the full 32 bit value. For example, the addressing mode `%a0@(%d0)' is equivalent to `%a0@(%d0:l)'. You may use the `--base-size-default-16' option to tell as to default to using the 16 bit value. In this case, `%a0@(%d0)' is equivalent to `%a0@(%d0:w)'. You may use the `--base-size-default-32' option to restore the default behaviour.

If you use an addressing mode with a displacement, and the value of the displacement is not known, as will normally assume that the value is 32 bits. For example, if the symbol `disp' has not been defined, as will assemble the addressing mode `%a0@(disp,%d0)' as though `disp' is a 32 bit value. You may use the `--disp-size-default-16' option to tell as to instead assume that the displacement is 16 bits. In this case, as will assemble `%a0@(disp,%d0)' as though `disp' is a 16 bit value. You may use the `--disp-size-default-32' option to restore the default behaviour.

as can assemble code for several different members of the Motorola 680x0 family. The default depends upon how as was configured when it was built; normally, the default is to assemble code for the 68020 microprocessor. The following options may be used to change the default. These options control which instructions and addressing modes are permitted. The members of the 680x0 family are very similar. For detailed information about the differences, see the Motorola manuals.

`-m68000'
`-m68ec000'
`-m68hc000'
`-m68hc001'
`-m68008'
`-m68302'
`-m68306'
`-m68307'
`-m68322'
`-m68356'
Assemble for the 68000. `-m68008', `-m68302', and so on are synonyms for `-m68000', since the chips are the same from the point of view of the assembler.
`-m68010'
Assemble for the 68010.
`-m68020'
`-m68ec020'
Assemble for the 68020. This is normally the default.
`-m68030'
`-m68ec030'
Assemble for the 68030.
`-m68040'
`-m68ec040'
Assemble for the 68040.
`-m68060'
`-m68ec060'
Assemble for the 68060.
`-mcpu32'
`-m68330'
`-m68331'
`-m68332'
`-m68333'
`-m68334'
`-m68336'
`-m68340'
`-m68341'
`-m68349'
`-m68360'
Assemble for the CPU32 family of chips.
`-m5200'
Assemble for the ColdFire family of chips.
`-m68881'
`-m68882'
Assemble 68881 floating point instructions. This is the default for the 68020, 68030, and the CPU32. The 68040 and 68060 always support floating point instructions.
`-mno-68881'
Do not assemble 68881 floating point instructions. This is the default for 68000 and the 68010. The 68040 and 68060 always support floating point instructions, even if this option is used.
`-m68851'
Assemble 68851 MMU instructions. This is the default for the 68020, 68030, and 68060. The 68040 accepts a somewhat different set of MMU instructions; `-m68851' and `-m68040' should not be used together.
`-mno-68851'
Do not assemble 68851 MMU instructions. This is the default for the 68000, 68010, and the CPU32. The 68040 accepts a somewhat different set of MMU instructions.


Using as - M68K-Syntax

Syntax

This syntax for the Motorola 680x0 was developed at MIT.

The 680x0 version of as uses instructions names and syntax compatible with the Sun assembler. Intervening periods are ignored; for example, `movl' is equivalent to `mov.l'.

In the following table apc stands for any of the address registers (`%a0' through `%a7'), the program counter (`%pc'), the zero-address relative to the program counter (`%zpc'), a suppressed address register (`%za0' through `%za7'), or it may be omitted entirely. The use of size means one of `w' or `l', and it may be omitted, along with the leading colon, unless a scale is also specified. The use of scale means one of `1', `2', `4', or `8', and it may always be omitted along with the leading colon.

The following addressing modes are understood:

Immediate
`#number'
Data Register
`%d0' through `%d7'
Address Register
`%a0' through `%a7'
`%a7' is also known as `%sp', i.e. the Stack Pointer. %a6 is also known as `%fp', the Frame Pointer.
Address Register Indirect
`%a0@' through `%a7@'
Address Register Postincrement
`%a0@+' through `%a7@+'
Address Register Predecrement
`%a0@-' through `%a7@-'
Indirect Plus Offset
`apc@(number)'
Index
`apc@(number,register:size:scale)' The number may be omitted.
Postindex
`apc@(number)@(onumber,register:size:scale)' The onumber or the register, but not both, may be omitted.
Preindex
`apc@(number,register:size:scale)@(onumber)' The number may be omitted. Omitting the register produces the Postindex addressing mode.
Absolute
`symbol', or `digits', optionally followed by `:b', `:w', or `:l'.


Using as - M68K-Moto-Syntax

Motorola Syntax

The standard Motorola syntax for this chip differs from the syntax already discussed (see section Syntax). as can accept Motorola syntax for operands, even if MIT syntax is used for other operands in the same instruction. The two kinds of syntax are fully compatible.

In the following table apc stands for any of the address registers (`%a0' through `%a7'), the program counter (`%pc'), the zero-address relative to the program counter (`%zpc'), or a suppressed address register (`%za0' through `%za7'). The use of size means one of `w' or `l', and it may always be omitted along with the leading dot. The use of scale means one of `1', `2', `4', or `8', and it may always be omitted along with the leading asterisk.

The following additional addressing modes are understood:

Address Register Indirect
`(%a0)' through `(%a7)'
`%a7' is also known as `%sp', i.e. the Stack Pointer. %a6 is also known as `%fp', the Frame Pointer.
Address Register Postincrement
`(%a0)+' through `(%a7)+'
Address Register Predecrement
`-(%a0)' through `-(%a7)'
Indirect Plus Offset
`number(%a0)' through `number(%a7)', or `number(%pc)'. The number may also appear within the parentheses, as in `(number,%a0)'. When used with the pc, the number may be omitted (with an address register, omitting the number produces Address Register Indirect mode).
Index
`number(apc,register.size*scale)' The number may be omitted, or it may appear within the parentheses. The apc may be omitted. The register and the apc may appear in either order. If both apc and register are address registers, and the size and scale are omitted, then the first register is taken as the base register, and the second as the index register.
Postindex
`([number,apc],register.size*scale,onumber)' The onumber, or the register, or both, may be omitted. Either the number or the apc may be omitted, but not both.
Preindex
`([number,apc,register.size*scale],onumber)' The number, or the apc, or the register, or any two of them, may be omitted. The onumber may be omitted. The register and the apc may appear in either order. If both apc and register are address registers, and the size and scale are omitted, then the first register is taken as the base register, and the second as the index register.


Using as - M68K-Float

Floating Point

Packed decimal (P) format floating literals are not supported. Feel free to add the code!

The floating point formats generated by directives are these.

.float
Single precision floating point constants.
.double
Double precision floating point constants.
.extend
.ldouble
Extended precision (long double) floating point constants.


Using as - M68K-Directives

680x0 Machine Directives

In order to be compatible with the Sun assembler the 680x0 assembler understands the following directives.

.data1
This directive is identical to a .data 1 directive.
.data2
This directive is identical to a .data 2 directive.
.even
This directive is a special case of the .align directive; it aligns the output to an even byte boundary.
.skip
This directive is identical to a .space directive.


Using as - M68K-opcodes

Opcodes


Using as - M68K-Branch

Branch Improvement

Certain pseudo opcodes are permitted for branch instructions. They expand to the shortest branch instruction that reach the target. Generally these mnemonics are made by substituting `j' for `b' at the start of a Motorola mnemonic.

The following table summarizes the pseudo-operations. A * flags cases that are more fully described after the table:

          Displacement
          +-------------------------------------------------
          |                68020   68000/10
Pseudo-Op |BYTE    WORD    LONG    LONG      non-PC relative
          +-------------------------------------------------
     jbsr |bsrs    bsr     bsrl    jsr       jsr
      jra |bras    bra     bral    jmp       jmp
*     jXX |bXXs    bXX     bXXl    bNXs;jmpl bNXs;jmp
*    dbXX |dbXX    dbXX        dbXX; bra; jmpl
*    fjXX |fbXXw   fbXXw   fbXXl             fbNXw;jmp

XX: condition
NX: negative of condition XX

*---see full description below

jbsr
jra
These are the simplest jump pseudo-operations; they always map to one particular machine instruction, depending on the displacement to the branch target.
jXX
Here, `jXX' stands for an entire family of pseudo-operations, where XX is a conditional branch or condition-code test. The full list of pseudo-ops in this family is:
 jhi   jls   jcc   jcs   jne   jeq   jvc
 jvs   jpl   jmi   jge   jlt   jgt   jle
For the cases of non-PC relative displacements and long displacements on the 68000 or 68010, as issues a longer code fragment in terms of NX, the opposite condition to XX. For example, for the non-PC relative case:
    jXX foo
gives
     bNXs oof
     jmp foo
 oof:
dbXX
The full family of pseudo-operations covered here is
 dbhi   dbls   dbcc   dbcs   dbne   dbeq   dbvc
 dbvs   dbpl   dbmi   dbge   dblt   dbgt   dble
 dbf    dbra   dbt
Other than for word and byte displacements, when the source reads `dbXX foo', as emits
     dbXX oo1
     bra oo2
 oo1:jmpl foo
 oo2:
fjXX
This family includes
 fjne   fjeq   fjge   fjlt   fjgt   fjle   fjf
 fjt    fjgl   fjgle  fjnge  fjngl  fjngle fjngt
 fjnle  fjnlt  fjoge  fjogl  fjogt  fjole  fjolt
 fjor   fjseq  fjsf   fjsne  fjst   fjueq  fjuge
 fjugt  fjule  fjult  fjun
For branch targets that are not PC relative, as emits
     fbNX oof
     jmp foo
 oof:
when it encounters `fjXX foo'.


Using as - M68K-Chars

Special Characters

The immediate character is `#' for Sun compatibility. The line-comment character is `|' (unless the `--bitwise-or' option is used). If a `#' appears at the beginning of a line, it is treated as a comment unless it looks like `# line file', in which case it is treated normally.


Using as - MIPS-Dependent

MIPS Dependent Features

GNU as for MIPS architectures supports several different MIPS processors, and MIPS ISA levels I through IV. For information about the MIPS instruction set, see MIPS RISC Architecture, by Kane and Heindrich (Prentice-Hall). For an overview of MIPS assembly conventions, see "Appendix D: Assembly Language Programming" in the same work.


Using as - MIPS Opts

Assembler options

The MIPS configurations of GNU as support these special options:

-G num
This option sets the largest size of an object that can be referenced implicitly with the gp register. It is only accepted for targets that use ECOFF format. The default value is 8.
-EB
-EL
Any MIPS configuration of as can select big-endian or little-endian output at run time (unlike the other GNU development tools, which must be configured for one or the other). Use `-EB' to select big-endian output, and `-EL' for little-endian.
-mips1
-mips2
-mips3
-mips4
Generate code for a particular MIPS Instruction Set Architecture level. `-mips1' corresponds to the R2000 and R3000 processors, `-mips2' to the R6000 processor, `-mips3' to the R4000 processor, and `-mips4' to the R8000 and R10000 processors. You can also switch instruction sets during the assembly; see section Directives to override the ISA level.
-mips16
-no-mips16
Generate code for the MIPS 16 processor. This is equivalent to putting `.set mips16' at the start of the assembly file. `-no-mips16' turns off this option.
-m4650
-no-m4650
Generate code for the MIPS R4650 chip. This tells the assembler to accept the `mad' and `madu' instruction, and to not schedule `nop' instructions around accesses to the `HI' and `LO' registers. `-no-m4650' turns off this option.
-m4010
-no-m4010
Generate code for the LSI R4010 chip. This tells the assembler to accept the R4010 specific instructions (`addciu', `ffc', etc.), and to not schedule `nop' instructions around accesses to the `HI' and `LO' registers. `-no-m4010' turns off this option.
-mcpu=CPU
Generate code for a particular MIPS cpu. This has little effect on the assembler, but it is passed by gcc.
-nocpp
This option is ignored. It is accepted for command-line compatibility with other assemblers, which use it to turn off C style preprocessing. With GNU as, there is no need for `-nocpp', because the GNU assembler itself never runs the C preprocessor.
--trap
--no-break
as automatically macro expands certain division and multiplication instructions to check for overflow and division by zero. This option causes as to generate code to take a trap exception rather than a break exception when an error is detected. The trap instructions are only supported at Instruction Set Architecture level 2 and higher.
--break
--no-trap
Generate code to take a break exception rather than a trap exception when an error is detected. This is the default.


Using as - MIPS Object

MIPS ECOFF object code

Assembling for a MIPS ECOFF target supports some additional sections besides the usual .text, .data and .bss. The additional sections are .rdata, used for read-only data, .sdata, used for small data, and .sbss, used for small common objects.

When assembling for ECOFF, the assembler uses the $gp ($28) register to form the address of a "small object". Any object in the .sdata or .sbss sections is considered "small" in this sense. For external objects, or for objects in the .bss section, you can use the gcc `-G' option to control the size of objects addressed via $gp; the default value is 8, meaning that a reference to any object eight bytes or smaller uses $gp. Passing `-G 0' to as prevents it from using the $gp register on the basis of object size (but the assembler uses $gp for objects in .sdata or sbss in any case). The size of an object in the .bss section is set by the .comm or .lcomm directive that defines it. The size of an external object may be set with the .extern directive. For example, `.extern sym,4' declares that the object at sym is 4 bytes in length, whie leaving sym otherwise undefined.

Using small ECOFF objects requires linker support, and assumes that the $gp register is correctly initialized (normally done automatically by the startup code). MIPS ECOFF assembly code must not modify the $gp register.


Using as - MIPS Stabs

Directives for debugging information

MIPS ECOFF as supports several directives used for generating debugging information which are not support by traditional MIPS assemblers. These are .def, .endef, .dim, .file, .scl, .size, .tag, .type, .val, .stabd, .stabn, and .stabs. The debugging information generated by the three .stab directives can only be read by GDB, not by traditional MIPS debuggers (this enhancement is required to fully support C++ debugging). These directives are primarily used by compilers, not assembly language programmers!


Using as - MIPS ISA

Directives to override the ISA level

GNU as supports an additional directive to change the MIPS Instruction Set Architecture level on the fly: .set mipsn. n should be a number from 0 to 4. A value from 1 to 4 makes the assembler accept instructions for the corresponding ISA level, from that point on in the assembly. .set mipsn affects not only which instructions are permitted, but also how certain macros are expanded. .set mips0 restores the ISA level to its original level: either the level you selected with command line options, or the default for your configuration. You can use this feature to permit specific R4000 instructions while assembling in 32 bit mode. Use this directive with care!

The directive `.set mips16' puts the assembler into MIPS 16 mode, in which it will assemble instructions for the MIPS 16 processor. Use `.set nomips16' to return to normal 32 bit mode.

Traditional MIPS assemblers do not support this directive.


Using as - MIPS autoextend

Directives for extending MIPS 16 bit instructions

By default, MIPS 16 instructions are automatically extended to 32 bits when necessary. The directive `.set noautoextend' will turn this off. When `.set noautoextend' is in effect, any 32 bit instruction must be explicitly extended with the `.e' modifier (e.g., `li.e $4,1000'). The directive `.set autoextend' may be used to once again automatically extend instructions when necessary.

This directive is only meaningful when in MIPS 16 mode. Traditional MIPS assemblers do not support this directive.


Using as - MIPS insn

Directive to mark data as an instruction

The .insn directive tells as that the following data is actually instructions. This makes a difference in MIPS 16 mode: when loading the address of a label which precedes instructions, as automatically adds 1 to the value, so that jumping to the loaded address will do the right thing.


Using as - MIPS option stack

Directives to save and restore options

The directives .set push and .set pop may be used to save and restore the current settings for all the options which are controlled by .set. The .set push directive saves the current settings on a stack. The .set pop directive pops the stack and restores the settings.

These directives can be useful inside an macro which must change an option such as the ISA level or instruction reordering but does not want to change the state of the code which invoked the macro.

Traditional MIPS assemblers do not support these directives.


Using as - SH-Dependent

Hitachi SH Dependent Features


Using as - SH Options

Options

as has no additional command-line options for the Hitachi SH family.


Using as - SH Syntax

Syntax


Using as - SH-Chars

Special Characters

`!' is the line comment character.

You can use `;' instead of a newline to separate statements.

Since `$' has no special meaning, you may use it in symbol names.


Using as - SH-Regs

Register Names

You can use the predefined symbols `r0', `r1', `r2', `r3', `r4', `r5', `r6', `r7', `r8', `r9', `r10', `r11', `r12', `r13', `r14', and `r15' to refer to the SH registers.

The SH also has these control registers:

pr
procedure register (holds return address)
pc
program counter
mach
macl
high and low multiply accumulator registers
sr
status register
gbr
global base register
vbr
vector base register (for interrupt vectors)


Using as - SH-Addressing

Addressing Modes

as understands the following addressing modes for the SH. Rn in the following refers to any of the numbered registers, but not the control registers.

Rn
Register direct
@Rn
Register indirect
@-Rn
Register indirect with pre-decrement
@Rn+
Register indirect with post-increment
@(disp, Rn)
Register indirect with displacement
@(R0, Rn)
Register indexed
@(disp, GBR)
GBR offset
@(R0, GBR)
GBR indexed
addr
@(disp, PC)
PC relative address (for branch or for addressing memory). The as implementation allows you to use the simpler form addr anywhere a PC relative address is called for; the alternate form is supported for compatibility with other assemblers.
#imm
Immediate data


Using as - SH Floating Point

Floating Point

The SH family has no hardware floating point, but the .float directive generates IEEE floating-point numbers for compatibility with other development tools.


Using as - SH Directives

SH Machine Directives

uaword
ualong
as will issue a warning when a misaligned .word or .long directive is used. You may use .uaword or .ualong to indicate that the value is intentionally misaligned.


Using as - SH Opcodes

Opcodes

For detailed information on the SH machine instruction set, see SH-Microcomputer User's Manual (Hitachi Micro Systems, Inc.).

as implements all the standard SH opcodes. No additional pseudo-instructions are needed on this family. Note, however, that because as supports a simpler form of PC-relative addressing, you may simply write (for example)

mov.l  bar,r0

where other assemblers might require an explicit displacement to bar from the program counter:

mov.l  @(disp, PC)


Using as - Sparc-Dependent

SPARC Dependent Features


Using as - Sparc-Opts

Options

The SPARC chip family includes several successive levels, using the same core instruction set, but including a few additional instructions at each level. There are exceptions to this however. For details on what instructions each variant supports, please see the chip's architecture reference manual.

By default, as assumes the core instruction set (SPARC v6), but "bumps" the architecture level as needed: it switches to successively higher architectures as it encounters instructions that only exist in the higher levels.

If not configured for SPARC v9 (sparc64-*-*) GAS will not bump passed sparclite by default, an option must be passed to enable the v9 instructions.

GAS treats sparclite as being compatible with v8, unless an architecture is explicitly requested. SPARC v9 is always incompatible with sparclite.

-Av6 | -Av7 | -Av8 | -Asparclet | -Asparclite
-Av8plus | -Av8plusa | -Av9 | -Av9a
Use one of the `-A' options to select one of the SPARC architectures explicitly. If you select an architecture explicitly, as reports a fatal error if it encounters an instruction or feature requiring an incompatible or higher level. `-Av8plus' and `-Av8plusa' select a 32 bit environment. `-Av9' and `-Av9a' select a 64 bit environment and are not available unless GAS is explicitly configured with 64 bit environment support. `-Av8plusa' and `-Av9a' enable the SPARC V9 instruction set with UltraSPARC extensions.
-xarch=v8plus | -xarch=v8plusa
For compatibility with the Solaris v9 assembler. These options are equivalent to -Av8plus and -Av8plusa, respectively.
-bump
Warn whenever it is necessary to switch to another level. If an architecture level is explicitly requested, GAS will not issue warnings until that level is reached, and will then bump the level as required (except between incompatible levels).
-32 | -64
Select the word size, either 32 bits or 64 bits. These options are only available with the ELF object file format, and require that the necessary BFD support has been included.


Using as - Sparc-Aligned-Data

Enforcing aligned data

SPARC GAS normally permits data to be misaligned. For example, it permits the .long pseudo-op to be used on a byte boundary. However, the native SunOS and Solaris assemblers issue an error when they see misaligned data.

You can use the --enforce-aligned-data option to make SPARC GAS also issue an error about misaligned data, just as the SunOS and Solaris assemblers do.

The --enforce-aligned-data option is not the default because gcc issues misaligned data pseudo-ops when it initializes certain packed data structures (structures defined using the packed attribute). You may have to assemble with GAS in order to initialize packed data structures in your own code.


Using as - Sparc-Float

Floating Point

The Sparc uses IEEE floating-point numbers.


Using as - Sparc-Directives

Sparc Machine Directives

The Sparc version of as supports the following additional machine directives:

.align
This must be followed by the desired alignment in bytes.
.common
This must be followed by a symbol name, a positive number, and "bss". This behaves somewhat like .comm, but the syntax is different.
.half
This is functionally identical to .short.
.proc
This directive is ignored. Any text following it on the same line is also ignored.
.reserve
This must be followed by a symbol name, a positive number, and "bss". This behaves somewhat like .lcomm, but the syntax is different.
.seg
This must be followed by "text", "data", or "data1". It behaves like .text, .data, or .data 1.
.skip
This is functionally identical to the .space directive.
.word
On the Sparc, the .word directive produces 32 bit values, instead of the 16 bit values it produces on many other machines.
.xword
On the Sparc V9 processor, the .xword directive produces 64 bit values.


Using as - Z8000-Dependent

Z8000 Dependent Features

The Z8000 as supports both members of the Z8000 family: the unsegmented Z8002, with 16 bit addresses, and the segmented Z8001 with 24 bit addresses.

When the assembler is in unsegmented mode (specified with the unsegm directive), an address takes up one word (16 bit) sized register. When the assembler is in segmented mode (specified with the segm directive), a 24-bit address takes up a long (32 bit) register. See section Assembler Directives for the Z8000, for a list of other Z8000 specific assembler directives.


Using as - Z8000 Options

Options

as has no additional command-line options for the Zilog Z8000 family.


Using as - Z8000 Syntax

Syntax


Using as - Z8000-Chars

Special Characters

`!' is the line comment character.

You can use `;' instead of a newline to separate statements.


Using as - Z8000-Regs

Register Names

The Z8000 has sixteen 16 bit registers, numbered 0 to 15. You can refer to different sized groups of registers by register number, with the prefix `r' for 16 bit registers, `rr' for 32 bit registers and `rq' for 64 bit registers. You can also refer to the contents of the first eight (of the sixteen 16 bit registers) by bytes. They are named `rnh' and `rnl'.

byte registers
r0l r0h r1h r1l r2h r2l r3h r3l
r4h r4l r5h r5l r6h r6l r7h r7l

word registers
r0 r1 r2 r3 r4 r5 r6 r7 r8 r9 r10 r11 r12 r13 r14 r15

long word registers
rr0 rr2 rr4 rr6 rr8 rr10 rr12 rr14

quad word registers
rq0 rq4 rq8 rq12


Using as - Z8000-Addressing

Addressing Modes

as understands the following addressing modes for the Z8000:

rn
Register direct
@rn
Indirect register
addr
Direct: the 16 bit or 24 bit address (depending on whether the assembler is in segmented or unsegmented mode) of the operand is in the instruction.
address(rn)
Indexed: the 16 or 24 bit address is added to the 16 bit register to produce the final address in memory of the operand.
rn(#imm)
Base Address: the 16 or 24 bit register is added to the 16 bit sign extended immediate displacement to produce the final address in memory of the operand.
rn(rm)
Base Index: the 16 or 24 bit register rn is added to the sign extended 16 bit index register rm to produce the final address in memory of the operand.
#xx
Immediate data xx.


Using as - Z8000 Directives

Assembler Directives for the Z8000

The Z8000 port of as includes these additional assembler directives, for compatibility with other Z8000 assemblers. As shown, these do not begin with `.' (unlike the ordinary as directives).

segm
Generates code for the segmented Z8001.
unsegm
Generates code for the unsegmented Z8002.
name
Synonym for .file
global
Synonym for .global
wval
Synonym for .word
lval
Synonym for .long
bval
Synonym for .byte
sval
Assemble a string. sval expects one string literal, delimited by single quotes. It assembles each byte of the string into consecutive addresses. You can use the escape sequence `%xx' (where xx represents a two-digit hexadecimal number) to represent the character whose ASCII value is xx. Use this feature to describe single quote and other characters that may not appear in string literals as themselves. For example, the C statement `char *a = "he said \"it's 50% off\"";' is represented in Z8000 assembly language (shown with the assembler output in hex at the left) as @begingroup @let@nonarrowing=@comment
68652073    sval    'he said %22it%27s 50%25 off%22%00'
61696420
22697427
73203530
25206F66
662200
@endgroup
rsect
synonym for .section
block
synonym for .space
even
special case of .align; aligns output to even byte boundary.


Using as - Z8000 Opcodes

Opcodes

For detailed information on the Z8000 machine instruction set, see Z8000 Technical Manual.


Using as - Vax-Dependent

VAX Dependent Features


Using as - VAX-Opts

VAX Command-Line Options

The Vax version of as accepts any of the following options, gives a warning message that the option was ignored and proceeds. These options are for compatibility with scripts designed for other people's assemblers.

-D (Debug)
-S (Symbol Table)
-T (Token Trace)
These are obsolete options used to debug old assemblers.
-d (Displacement size for JUMPs)
This option expects a number following the `-d'. Like options that expect filenames, the number may immediately follow the `-d' (old standard) or constitute the whole of the command line argument that follows `-d' (GNU standard).
-V (Virtualize Interpass Temporary File)
Some other assemblers use a temporary file. This option commanded them to keep the information in active memory rather than in a disk file. as always does this, so this option is redundant.
-J (JUMPify Longer Branches)
Many 32-bit computers permit a variety of branch instructions to do the same job. Some of these instructions are short (and fast) but have a limited range; others are long (and slow) but can branch anywhere in virtual memory. Often there are 3 flavors of branch: short, medium and long. Some other assemblers would emit short and medium branches, unless told by this option to emit short and long branches.
-t (Temporary File Directory)
Some other assemblers may use a temporary file, and this option takes a filename being the directory to site the temporary file. Since as does not use a temporary disk file, this option makes no difference. `-t' needs exactly one filename.

The Vax version of the assembler accepts two options when compiled for VMS. They are `-h', and `-+'. The `-h' option prevents as from modifying the symbol-table entries for symbols that contain lowercase characters (I think). The `-+' option causes as to print warning messages if the FILENAME part of the object file, or any symbol name is larger than 31 characters. The `-+' option also inserts some code following the `_main' symbol so that the object file is compatible with Vax-11 "C".


Using as - VAX-float

VAX Floating Point

Conversion of flonums to floating point is correct, and compatible with previous assemblers. Rounding is towards zero if the remainder is exactly half the least significant bit.

D, F, G and H floating point formats are understood.

Immediate floating literals (e.g. `S`$6.9') are rendered correctly. Again, rounding is towards zero in the boundary case.

The .float directive produces f format numbers. The .double directive produces d format numbers.


Using as - VAX-directives

Vax Machine Directives

The Vax version of the assembler supports four directives for generating Vax floating point constants. They are described in the table below.

.dfloat
This expects zero or more flonums, separated by commas, and assembles Vax d format 64-bit floating point constants.
.ffloat
This expects zero or more flonums, separated by commas, and assembles Vax f format 32-bit floating point constants.
.gfloat
This expects zero or more flonums, separated by commas, and assembles Vax g format 64-bit floating point constants.
.hfloat
This expects zero or more flonums, separated by commas, and assembles Vax h format 128-bit floating point constants.


Using as - VAX-opcodes

VAX Opcodes

All DEC mnemonics are supported. Beware that case... instructions have exactly 3 operands. The dispatch table that follows the case... instruction should be made with .word statements. This is compatible with all unix assemblers we know of.


Using as - VAX-branch

VAX Branch Improvement

Certain pseudo opcodes are permitted. They are for branch instructions. They expand to the shortest branch instruction that reaches the target. Generally these mnemonics are made by substituting `j' for `b' at the start of a DEC mnemonic. This feature is included both for compatibility and to help compilers. If you do not need this feature, avoid these opcodes. Here are the mnemonics, and the code they can expand into.

jbsb
`Jsb' is already an instruction mnemonic, so we chose `jbsb'.
(byte displacement)
bsbb ...
(word displacement)
bsbw ...
(long displacement)
jsb ...
jbr
jr
Unconditional branch.
(byte displacement)
brb ...
(word displacement)
brw ...
(long displacement)
jmp ...
jCOND
COND may be any one of the conditional branches neq, nequ, eql, eqlu, gtr, geq, lss, gtru, lequ, vc, vs, gequ, cc, lssu, cs. COND may also be one of the bit tests bs, bc, bss, bcs, bsc, bcc, bssi, bcci, lbs, lbc. NOTCOND is the opposite condition to COND.
(byte displacement)
bCOND ...
(word displacement)
bNOTCOND foo ; brw ... ; foo:
(long displacement)
bNOTCOND foo ; jmp ... ; foo:
jacbX
X may be one of b d f g h l w.
(word displacement)
OPCODE ...
(long displacement)
OPCODE ..., foo ;
brb bar ;
foo: jmp ... ;
bar:
jaobYYY
YYY may be one of lss leq.
jsobZZZ
ZZZ may be one of geq gtr.
(byte displacement)
OPCODE ...
(word displacement)
OPCODE ..., foo ;
brb bar ;
foo: brw destination ;
bar:
(long displacement)
OPCODE ..., foo ;
brb bar ;
foo: jmp destination ;
bar:
aobleq
aoblss
sobgeq
sobgtr
(byte displacement)
OPCODE ...
(word displacement)
OPCODE ..., foo ;
brb bar ;
foo: brw destination ;
bar:
(long displacement)
OPCODE ..., foo ;
brb bar ;
foo: jmp destination ;
bar:


Using as - VAX-operands

VAX Operands

The immediate character is `$' for Unix compatibility, not `#' as DEC writes it.

The indirect character is `*' for Unix compatibility, not `@' as DEC writes it.

The displacement sizing character is ``' (an accent grave) for Unix compatibility, not `^' as DEC writes it. The letter preceding ``' may have either case. `G' is not understood, but all other letters (b i l s w) are understood.

Register names understood are r0 r1 r2 ... r15 ap fp sp pc. Upper and lower case letters are equivalent.

For instance

tstb *w`$4(r5)

Any expression is permitted in an operand. Operands are comma separated.


Using as - VAX-no

Not Supported on VAX

Vax bit fields can not be assembled with as. Someone can add the required code if they really need it.


Using as - V850-Dependent

v850 Dependent Features


Using as - V850 Options

Options

as supports the following additional command-line options for the V850 processor family:

-wsigned_overflow
Causes warnings to be produced when signed immediate values overflow the space available for then within their opcodes. By default this option is disabled as it is possible to receive spurious warnings due to using exact bit patterns as immediate constants.
-wunsigned_overflow
Causes warnings to be produced when unsigned immediate values overflow the space available for then within their opcodes. By default this option is disabled as it is possible to receive spurious warnings due to using exact bit patterns as immediate constants.
-mv850
Specifies that the assembled code should be marked as being targeted at the V850 processor. This allows the linker to detect attempts to link such code with code assembled for other processors.


Using as - V850 Syntax

Syntax


Using as - V850-Chars

Special Characters

`#' is the line comment character.


Using as - V850-Regs

Register Names

as supports the following names for registers:

general register 0
r0, zero
general register 1
r1
general register 2
r2, hp
general register 3
r3, sp
general register 4
r4, gp
general register 5
r5, tp
general register 6
r6
general register 7
r7
general register 8
r8
general register 9
r9
general register 10
r10
general register 11
r11
general register 12
r12
general register 13
r13
general register 14
r14
general register 15
r15
general register 16
r16
general register 17
r17
general register 18
r18
general register 19
r19
general register 20
r20
general register 21
r21
general register 22
r22
general register 23
r23
general register 24
r24
general register 25
r25
general register 26
r26
general register 27
r27
general register 28
r28
general register 29
r29
general register 30
r30, ep
general register 31
r31, lp
system register 0
eipc
system register 1
eipsw
system register 2
fepc
system register 3
fepsw
system register 4
ecr
system register 5
psw


Using as - V850 Floating Point

Floating Point

The V850 family uses IEEE floating-point numbers.


Using as - V850 Directives

V850 Machine Directives

.offset <expression>
Moves the offset into the current section to the specified amount.
.section "name", <type>
This is an extension to the standard .section directive. It sets the current section to be <type> and creates an alias for this section called "name".
.v850
Specifies that the assembled code should be marked as being targeted at the V850 processor. This allows the linker to detect attempts to link such code with code assembled for other processors.


Using as - V850 Opcodes

Opcodes

as implements all the standard V850 opcodes.

as also implements the following pseudo ops:

hi0()
Computes the higher 16 bits of the given expression and stores it into the immediate operand field of the given instruction. For example: `mulhi hi0(here - there), r5, r6' computes the difference between the address of labels 'here' and 'there', takes the upper 16 bits of this difference, shifts it down 16 bits and then mutliplies it by the lower 16 bits in register 5, putting the result into register 6.
lo()
Computes the lower 16 bits of the given expression and stores it into the immediate operand field of the given instruction. For example: `addi lo(here - there), r5, r6' computes the difference between the address of labels 'here' and 'there', takes the lower 16 bits of this difference and adds it to register 5, putting the result into register 6.
hi()
Computes the higher 16 bits of the given expression and then adds the value of the most significant bit of the lower 16 bits of the expression and stores the result into the immediate operand field of the given instruction. For example the following code can be used to compute the address of the label 'here' and store it into register 6: `movhi hi(here), r0, r6' `movea lo(here), r6, r6' The reason for this special behaviour is that movea performs a sign extention on its immediate operand. So for example if the address of 'here' was 0xFFFFFFFF then without the special behaviour of the hi() pseudo-op the movhi instruction would put 0xFFFF0000 into r6, then the movea instruction would takes its immediate operand, 0xFFFF, sign extend it to 32 bits, 0xFFFFFFFF, and then add it into r6 giving 0xFFFEFFFF which is wrong (the fifth nibble is E). With the hi() pseudo op adding in the top bit of the lo() pseudo op, the movhi instruction actually stores 0 into r6 (0xFFFF + 1 = 0x0000), so that the movea instruction stores 0xFFFFFFFF into r6 - the right value.
sdaoff()
Computes the offset of the named variable from the start of the Small Data Area (whoes address is held in register 4, the GP register) and stores the result as a 16 bit signed value in the immediate operand field of the given instruction. For example: `ld.w sdaoff(_a_variable)[gp],r6' loads the contents of the location pointed to by the label '_a_variable' into register 6, provided that the label is located somewhere within +/- 32K of the address held in the GP register. [Note the linker assumes that the GP register contains a fixed address set to the address of the label called '__gp'. This can either be set up automatically by the linker, or specifically set by using the `--defsym __gp=<value>' command line option].
tdaoff()
Computes the offset of the named variable from the start of the Tiny Data Area (whoes address is held in register 30, the EP register) and stores the result as a 7 or 8 bit unsigned value in the immediate operand field of the given instruction. For example: `sld.w tdaoff(_a_variable)[ep],r6' loads the contents of the location pointed to by the label '_a_variable' into register 6, provided that the label is located somewhere within +256 bytes of the address held in the EP register. [Note the linker assumes that the EP register contains a fixed address set to the address of the label called '__ep'. This can either be set up automatically by the linker, or specifically set by using the `--defsym __ep=<value>' command line option].
zdaoff()
Computes the offset of the named variable from address 0 and stores the result as a 16 bit signed value in the immediate operand field of the given instruction. For example: `movea zdaoff(_a_variable),zero,r6' puts the address of the label '_a_variable' into register 6, assuming that the label is somewhere within the first 32K of memory. (Strictly speaking it also possible to access the last 32K of memory as well, as the offsets are signed).

For information on the V850 instruction set, see V850 Family 32-/16-Bit single-Chip Microcontroller Architecture Manual from NEC. Ltd.

@raisesections


Using as - Reporting Bugs

Reporting Bugs

Your bug reports play an essential role in making as reliable.

Reporting a bug may help you by bringing a solution to your problem, or it may not. But in any case the principal function of a bug report is to help the entire community by making the next version of as work better. Bug reports are your contribution to the maintenance of as.

In order for a bug report to serve its purpose, you must include the information that enables us to fix the bug.


Using as - Bug Criteria

Have you found a bug?

If you are not sure whether you have found a bug, here are some guidelines:

  • If the assembler gets a fatal signal, for any input whatever, that is a as bug. Reliable assemblers never crash.
  • If as produces an error message for valid input, that is a bug.
  • If as does not produce an error message for invalid input, that is a bug. However, you should note that your idea of "invalid input" might be our idea of "an extension" or "support for traditional practice".
  • If you are an experienced user of assemblers, your suggestions for improvement of as are welcome in any case.


Using as - Bug Reporting

How to report bugs

A number of companies and individuals offer support for GNU products. If you obtained as from a support organization, we recommend you contact that organization first.

You can find contact information for many support companies and individuals in the file `etc/SERVICE' in the GNU Emacs distribution.

In any event, we also recommend that you send bug reports for as to `bug-gnu-utils@prep.ai.mit.edu'.

The fundamental principle of reporting bugs usefully is this: report all the facts. If you are not sure whether to state a fact or leave it out, state it!

Often people omit facts because they think they know what causes the problem and assume that some details do not matter. Thus, you might assume that the name of a symbol you use in an example does not matter. Well, probably it does not, but one cannot be sure. Perhaps the bug is a stray memory reference which happens to fetch from the location where that name is stored in memory; perhaps, if the name were different, the contents of that location would fool the assembler into doing the right thing despite the bug. Play it safe and give a specific, complete example. That is the easiest thing for you to do, and the most helpful.

Keep in mind that the purpose of a bug report is to enable us to fix the bug if it is new to us. Therefore, always write your bug reports on the assumption that the bug has not been reported previously.

Sometimes people give a few sketchy facts and ask, "Does this ring a bell?" Those bug reports are useless, and we urge everyone to refuse to respond to them except to chide the sender to report bugs properly.

To enable us to fix the bug, you should include all these things:

  • The version of as. as announces it if you start it with the `--version' argument. Without this, we will not know whether there is any point in looking for the bug in the current version of as.
  • Any patches you may have applied to the as source.
  • The type of machine you are using, and the operating system name and version number.
  • What compiler (and its version) was used to compile as---e.g. "gcc-2.7".
  • The command arguments you gave the assembler to assemble your example and observe the bug. To guarantee you will not omit something important, list them all. A copy of the Makefile (or the output from make) is sufficient. If we were to try to guess the arguments, we would probably guess wrong and then we might not encounter the bug.
  • A complete input file that will reproduce the bug. If the bug is observed when the assembler is invoked via a compiler, send the assembler source, not the high level language source. Most compilers will produce the assembler source when run with the `-S' option. If you are using gcc, use the options `-v --save-temps'; this will save the assembler source in a file with an extension of `.s', and also show you exactly how as is being run.
  • A description of what behavior you observe that you believe is incorrect. For example, "It gets a fatal signal." Of course, if the bug is that as gets a fatal signal, then we will certainly notice it. But if the bug is incorrect output, we might not notice unless it is glaringly wrong. You might as well not give us a chance to make a mistake. Even if the problem you experience is a fatal signal, you should still say so explicitly. Suppose something strange is going on, such as, your copy of as is out of synch, or you have encountered a bug in the C library on your system. (This has happened!) Your copy might crash and ours would not. If you told us to expect a crash, then when ours fails to crash, we would know that the bug was not happening for us. If you had not told us to expect a crash, then we would not be able to draw any conclusion from our observations.
  • If you wish to suggest changes to the as source, send us context diffs, as generated by diff with the `-u', `-c', or `-p' option. Always send diffs from the old file to the new file. If you even discuss something in the as source, refer to it by context, not by line number. The line numbers in our development sources will not match those in your sources. Your line numbers would convey no useful information to us.

Here are some things that are not necessary:

  • A description of the envelope of the bug. Often people who encounter a bug spend a lot of time investigating which changes to the input file will make the bug go away and which changes will not affect it. This is often time consuming and not very useful, because the way we will find the bug is by running a single example under the debugger with breakpoints, not by pure deduction from a series of examples. We recommend that you save your time for something else. Of course, if you can find a simpler example to report instead of the original one, that is a convenience for us. Errors in the output will be easier to spot, running under the debugger will take less time, and so on. However, simplification is not vital; if you do not want to do this, report the bug anyway and send us the entire test case you used.
  • A patch for the bug. A patch for the bug does help us if it is a good one. But do not omit the necessary information, such as the test case, on the assumption that a patch is all we need. We might see problems with your patch and decide to fix the problem another way, or we might not understand it at all. Sometimes with a program as complicated as as it is very hard to construct an example that will make the program follow a certain path through the code. If you do not send us the example, we will not be able to construct one, so we will not be able to verify that the bug is fixed. And if we cannot understand what bug you are trying to fix, or why your patch should be an improvement, we will not install it. A test case will help us to understand.
  • A guess about what the bug is or what it depends on. Such guesses are usually wrong. Even we cannot guess right about such things without first using the debugger to find the facts.


Using as - Acknowledgements

Acknowledgements

If you have contributed to as and your name isn't listed here, it is not meant as a slight. We just don't know about it. Send mail to the maintainer, and we'll correct the situation. Currently the maintainer is Ken Raeburn (email address raeburn@cygnus.com).

Dean Elsner wrote the original GNU assembler for the VAX.(1)

Jay Fenlason maintained GAS for a while, adding support for GDB-specific debug information and the 68k series machines, most of the preprocessing pass, and extensive changes in `messages.c', `input-file.c', `write.c'.

K. Richard Pixley maintained GAS for a while, adding various enhancements and many bug fixes, including merging support for several processors, breaking GAS up to handle multiple object file format back ends (including heavy rewrite, testing, an integration of the coff and b.out back ends), adding configuration including heavy testing and verification of cross assemblers and file splits and renaming, converted GAS to strictly ANSI C including full prototypes, added support for m680[34]0 and cpu32, did considerable work on i960 including a COFF port (including considerable amounts of reverse engineering), a SPARC opcode file rewrite, DECstation, rs6000, and hp300hpux host ports, updated "know" assertions and made them work, much other reorganization, cleanup, and lint.

Ken Raeburn wrote the high-level BFD interface code to replace most of the code in format-specific I/O modules.

The original VMS support was contributed by David L. Kashtan. Eric Youngdale has done much work with it since.

The Intel 80386 machine description was written by Eliot Dresselhaus.

Minh Tran-Le at IntelliCorp contributed some AIX 386 support.

The Motorola 88k machine description was contributed by Devon Bowen of Buffalo University and Torbjorn Granlund of the Swedish Institute of Computer Science.

Keith Knowles at the Open Software Foundation wrote the original MIPS back end (`tc-mips.c', `tc-mips.h'), and contributed Rose format support (which hasn't been merged in yet). Ralph Campbell worked with the MIPS code to support a.out format.

Support for the Zilog Z8k and Hitachi H8/300 and H8/500 processors (tc-z8k, tc-h8300, tc-h8500), and IEEE 695 object file format (obj-ieee), was written by Steve Chamberlain of Cygnus Support. Steve also modified the COFF back end to use BFD for some low-level operations, for use with the H8/300 and AMD 29k targets.

John Gilmore built the AMD 29000 support, added .include support, and simplified the configuration of which versions accept which directives. He updated the 68k machine description so that Motorola's opcodes always produced fixed-size instructions (e.g. jsr), while synthetic instructions remained shrinkable (jbsr). John fixed many bugs, including true tested cross-compilation support, and one bug in relaxation that took a week and required the proverbial one-bit fix.

Ian Lance Taylor of Cygnus Support merged the Motorola and MIT syntax for the 68k, completed support for some COFF targets (68k, i386 SVR3, and SCO Unix), added support for MIPS ECOFF and ELF targets, wrote the initial RS/6000 and PowerPC assembler, and made a few other minor patches.

Steve Chamberlain made as able to generate listings.

Hewlett-Packard contributed support for the HP9000/300.

Jeff Law wrote GAS and BFD support for the native HPPA object format (SOM) along with a fairly extensive HPPA testsuite (for both SOM and ELF object formats). This work was supported by both the Center for Software Science at the University of Utah and Cygnus Support.

Support for ELF format files has been worked on by Mark Eichin of Cygnus Support (original, incomplete implementation for SPARC), Pete Hoogenboom and Jeff Law at the University of Utah (HPPA mainly), Michael Meissner of the Open Software Foundation (i386 mainly), and Ken Raeburn of Cygnus Support (sparc, and some initial 64-bit support).

Richard Henderson rewrote the Alpha assembler. Klaus Kaempf wrote GAS and BFD support for openVMS/Alpha.

Several engineers at Cygnus Support have also provided many small bug fixes and configuration enhancements.

Many others have contributed large or small bugfixes and enhancements. If you have contributed significant work and are not mentioned on this list, and want to be, let us know. Some of the history has been lost; we are not intentionally leaving anyone out.


Using as - Index

Index

Jump to: # - $ - - - . - 1 - 2 - : - @ - \ - a - b - c - d - e - f - g - h - i - j - l - m - n - o - p - q - r - s - t - u - v - w - x - z

#

  • #
  • #APP
  • #NO_APP

    • $

  • $ in symbol names, $ in symbol names, $ in symbol names

    • -

  • -+ option, VAX/VMS
  • --
  • `--base-size-default-16'
  • `--base-size-default-32'
  • `--bitwise-or' option, M680x0
  • `--disp-size-default-16'
  • `--disp-size-default-32'
  • --enforce-aligned-data
  • --MD
  • `--register-prefix-optional' option, M680x0
  • --statistics
  • -a
  • -A options, i960
  • -ac
  • -ad
  • -ah
  • -al
  • -an
  • -as
  • -Asparclet
  • -Asparclite
  • -Av6
  • -Av8
  • -Av9
  • -Av9a
  • -b option, i960
  • -D
  • -D, ignored on VAX
  • -d, VAX option
  • -EB option (MIPS)
  • -EL option (MIPS)
  • -f
  • -G option (MIPS)
  • -h option, VAX/VMS
  • -I path
  • -J, ignored on VAX
  • -K
  • -L
  • `-l' option, M680x0
  • -M
  • `-m68000' and related options
  • -mbig-endian option (ARC)
  • -mlittle-endian option (ARC)
  • -mv850 command line option, V850
  • -no-relax option, i960
  • -nocpp ignored (MIPS)
  • -o
  • -R
  • -S, ignored on VAX
  • -T, ignored on VAX
  • -t, ignored on VAX
  • -v
  • -V, redundant on VAX
  • -version
  • -W
  • -wsigned_overflow command line option, V850
  • -wunsigned_overflow command line option, V850

    • .

  • . (symbol)
  • .insn
  • .o
  • .param on HPPA
  • .set autoextend
  • .set mipsn
  • .set noautoextend
  • .set pop
  • .set push
  • .v850 directive, V850

    • 1

  • 16-bit code, i386

    • 2

  • 29K support

    • :

  • : (label)

    • @

  • @word modifier, D10V

    • \

  • \" (doublequote character)
  • \\ (`\' character)
  • \b (backspace character)
  • \ddd (octal character code)
  • \f (formfeed character)
  • \n (newline character)
  • \r (carriage return character)
  • \t (tab)
  • \xd... (hex character code)

    • a

  • a.out
  • a.out symbol attributes
  • ABORT directive
  • abort directive
  • absolute section
  • addition, permitted arguments
  • addresses
  • addresses, format of
  • addressing modes, D10V
  • addressing modes, H8/300
  • addressing modes, H8/500
  • addressing modes, M680x0
  • addressing modes, SH
  • addressing modes, Z8000
  • advancing location counter
  • align directive
  • align directive, SPARC
  • altered difference tables
  • alternate syntax for the 680x0
  • AMD 29K floating point (IEEE)
  • AMD 29K identifiers
  • AMD 29K line comment character
  • AMD 29K machine directives
  • AMD 29K macros
  • AMD 29K opcodes
  • AMD 29K options (none)
  • AMD 29K protected registers
  • AMD 29K register names
  • AMD 29K special purpose registers
  • AMD 29K support
  • app-file directive
  • ARC architectures
  • ARC big-endian output
  • ARC endianness
  • ARC floating point (IEEE)
  • ARC little-endian output
  • ARC machine directives
  • ARC options
  • ARC support
  • architecture options, i960
  • architecture options, M680x0
  • architectures, ARC
  • architectures, SPARC
  • arguments for addition
  • arguments for subtraction
  • arguments in expressions
  • arithmetic functions
  • arithmetic operands
  • arm directive, ARM
  • ARM floating point (IEEE)
  • ARM identifiers
  • ARM line comment character
  • ARM machine directives
  • ARM opcodes
  • ARM options (none)
  • ARM register names
  • ARM support
  • ascii directive
  • asciz directive
  • assembler bugs, reporting
  • assembler crash
  • assembler internal logic error
  • assembler version
  • assembler, and linker
  • assembly listings, enabling
  • assigning values to symbols, assigning values to symbols
  • attributes, symbol
  • auxiliary attributes, COFF symbols
  • auxiliary symbol information, COFF
  • Av7

    • b

  • backslash (\\)
  • backspace (\b)
  • balign directive
  • balignl directive
  • balignw directive
  • big endian output, ARC
  • big endian output, MIPS
  • big-endian output, ARC
  • big-endian output, MIPS
  • bignums
  • binary integers
  • bitfields, not supported on VAX
  • block
  • block directive, AMD 29K
  • branch improvement, M680x0
  • branch improvement, VAX
  • branch recording, i960
  • branch statistics table, i960
  • bss directive, i960
  • bss section, bss section
  • bug criteria
  • bug reports
  • bugs in assembler
  • bus lock prefixes, i386
  • bval
  • byte directive

    • c

  • call instructions, i386
  • callj, i960 pseudo-opcode
  • carriage return (\r)
  • character constants
  • character escape codes
  • character, single
  • characters used in symbols
  • code directive, ARM
  • code16 directive, i386
  • code32 directive, i386
  • COFF auxiliary symbol information
  • COFF structure debugging
  • COFF symbol attributes
  • COFF symbol descriptor
  • COFF symbol storage class
  • COFF symbol type
  • COFF symbols, debugging
  • COFF value attribute
  • COMDAT
  • comm directive
  • command line conventions
  • command line options, V850
  • command-line options ignored, VAX
  • comments
  • comments, M680x0
  • comments, removed by preprocessor
  • common directive, SPARC
  • common sections
  • common variable storage
  • compare and jump expansions, i960
  • compare/branch instructions, i960
  • conditional assembly
  • constant, single character
  • constants
  • constants, bignum
  • constants, character
  • constants, converted by preprocessor
  • constants, floating point
  • constants, integer
  • constants, number
  • constants, string
  • continuing statements
  • conversion instructions, i386
  • coprocessor wait, i386
  • cpu directive, SPARC
  • cputype directive, AMD 29K
  • crash of assembler
  • current address
  • current address, advancing

    • d

  • D10V @word modifier
  • D10V addressing modes
  • D10V floating point
  • D10V line comment character
  • D10V opcode summary
  • D10V optimization
  • D10V options
  • D10V registers
  • D10V size modifiers
  • D10V sub-instruction ordering
  • D10V sub-instructions
  • D10V support
  • D10V syntax
  • data alignment on SPARC
  • data and text sections, joining
  • data directive
  • data section
  • data1 directive, M680x0
  • data2 directive, M680x0
  • debuggers, and symbol order
  • debugging COFF symbols
  • decimal integers
  • def directive
  • dependency tracking
  • deprecated directives
  • desc directive
  • descriptor, of a.out symbol
  • dfloat directive, VAX
  • difference tables altered
  • difference tables, warning
  • dim directive
  • directives and instructions
  • directives, M680x0
  • directives, machine independent
  • directives, Z8000
  • displacement sizing character, VAX
  • dot (symbol)
  • double directive
  • double directive, i386
  • double directive, M680x0
  • double directive, VAX
  • doublequote (\")

    • e

  • ECOFF sections
  • ecr register, V850
  • eight-byte integer
  • eipc register, V850
  • eipsw register, V850
  • eject directive
  • else directive
  • empty expressions
  • emulation
  • endef directive
  • endianness, ARC
  • endianness, MIPS
  • endif directive
  • endm directive
  • EOF, newline must precede
  • ep register, V850
  • equ directive
  • equiv directive
  • err directive
  • error messsages
  • error on valid input
  • errors, continuing after
  • escape codes, character
  • even
  • even directive, M680x0
  • exitm directive
  • expr (internal section)
  • expression arguments
  • expressions
  • expressions, empty
  • expressions, integer
  • extend directive M680x0
  • extended directive, i960
  • extern directive

    • f

  • faster processing (-f)
  • fatal signal
  • fepc register, V850
  • fepsw register, V850
  • ffloat directive, VAX
  • file directive
  • file directive, AMD 29K
  • file name, logical, file name, logical
  • files, including
  • files, input
  • fill directive
  • filling memory, filling memory
  • float directive
  • float directive, i386
  • float directive, M680x0
  • float directive, VAX
  • floating point numbers
  • floating point numbers (double)
  • floating point numbers (single), floating point numbers (single)
  • floating point, AMD 29K (IEEE)
  • floating point, ARC (IEEE)
  • floating point, ARM (IEEE)
  • floating point, D10V
  • floating point, H8/300 (IEEE)
  • floating point, H8/500 (IEEE)
  • floating point, HPPA (IEEE)
  • floating point, i386
  • floating point, i960 (IEEE)
  • floating point, M680x0
  • floating point, SH (IEEE)
  • floating point, SPARC (IEEE)
  • floating point, V850 (IEEE)
  • floating point, VAX
  • flonums
  • format of error messages
  • format of warning messages
  • formfeed (\f)
  • functions, in expressions

    • g

  • gbr960, i960 postprocessor
  • gfloat directive, VAX
  • global
  • global directive
  • gp register, MIPS
  • gp register, V850
  • grouping data

    • h

  • H8/300 addressing modes
  • H8/300 floating point (IEEE)
  • H8/300 line comment character
  • H8/300 line separator
  • H8/300 machine directives (none)
  • H8/300 opcode summary
  • H8/300 options (none)
  • H8/300 registers
  • H8/300 size suffixes
  • H8/300 support
  • H8/300H, assembling for
  • H8/500 addressing modes
  • H8/500 floating point (IEEE)
  • H8/500 line comment character
  • H8/500 line separator
  • H8/500 machine directives (none)
  • H8/500 opcode summary
  • H8/500 options (none)
  • H8/500 registers
  • H8/500 support
  • half directive, SPARC
  • hex character code (\xd...)
  • hexadecimal integers
  • hfloat directive, VAX
  • hi pseudo-op, V850
  • hi0 pseudo-op, V850
  • HPPA directives not supported
  • HPPA floating point (IEEE)
  • HPPA Syntax
  • HPPA-only directives
  • hword directive

    • i

  • i386 16-bit code
  • i386 conversion instructions
  • i386 floating point
  • i386 immediate operands
  • i386 jump optimization
  • i386 jump, call, return
  • i386 jump/call operands
  • i386 memory references
  • i386 mul, imul instructions
  • i386 opcode naming
  • i386 opcode prefixes
  • i386 options (none)
  • i386 register operands
  • i386 registers
  • i386 sections
  • i386 size suffixes
  • i386 source, destination operands
  • i386 support
  • i386 syntax compatibility
  • i80306 support
  • i960 architecture options
  • i960 branch recording
  • i960 callj pseudo-opcode
  • i960 compare and jump expansions
  • i960 compare/branch instructions
  • i960 floating point (IEEE)
  • i960 machine directives
  • i960 opcodes
  • i960 options
  • i960 support
  • ident directive
  • identifiers, AMD 29K
  • identifiers, ARM
  • if directive
  • ifdef directive
  • ifndef directive
  • ifnotdef directive
  • immediate character, M680x0
  • immediate character, VAX
  • immediate operands, i386
  • imul instruction, i386
  • include directive
  • include directive search path
  • indirect character, VAX
  • infix operators
  • inhibiting interrupts, i386
  • input
  • input file linenumbers
  • instruction set, M680x0
  • instruction summary, D10V
  • instruction summary, H8/300
  • instruction summary, H8/500
  • instruction summary, SH
  • instruction summary, Z8000
  • instructions and directives
  • int directive
  • int directive, H8/300
  • int directive, H8/500
  • int directive, i386
  • integer expressions
  • integer, 16-byte
  • integer, 8-byte
  • integers
  • integers, 16-bit
  • integers, 32-bit
  • integers, binary
  • integers, decimal
  • integers, hexadecimal
  • integers, octal
  • integers, one byte
  • internal assembler sections
  • invalid input
  • invocation summary
  • irp directive
  • irpc directive

    • j

  • joining text and data sections
  • jump instructions, i386
  • jump optimization, i386
  • jump/call operands, i386

    • l

  • label (:)
  • labels
  • lcomm directive
  • ld
  • ldouble directive M680x0
  • leafproc directive, i960
  • length of symbols
  • lflags directive (ignored)
  • line comment character
  • line comment character, AMD 29K
  • line comment character, ARM
  • line comment character, D10V
  • line comment character, H8/300
  • line comment character, H8/500
  • line comment character, M680x0
  • line comment character, SH
  • line comment character, V850
  • line comment character, Z8000
  • line directive
  • line directive, AMD 29K
  • line numbers, in input files
  • line numbers, in warnings/errors
  • line separator character
  • line separator, H8/300
  • line separator, H8/500
  • line separator, SH
  • line separator, Z8000
  • lines starting with #
  • linker
  • linker, and assembler
  • linkonce directive
  • list directive
  • listing control, turning off
  • listing control, turning on
  • listing control: new page
  • listing control: paper size
  • listing control: subtitle
  • listing control: title line
  • listings, enabling
  • little endian output, ARC
  • little endian output, MIPS
  • little-endian output, ARC
  • little-endian output, MIPS
  • ln directive
  • lo pseudo-op, V850
  • local common symbols
  • local labels, retaining in output
  • local symbol names
  • location counter
  • location counter, advancing
  • logical file name, logical file name
  • logical line number
  • logical line numbers
  • long directive
  • long directive, i386
  • lp register, V850
  • lval

    • m

  • M680x0 addressing modes
  • M680x0 architecture options
  • M680x0 branch improvement
  • M680x0 directives
  • M680x0 floating point
  • M680x0 immediate character
  • M680x0 line comment character
  • M680x0 opcodes
  • M680x0 options
  • M680x0 pseudo-opcodes
  • M680x0 size modifiers
  • M680x0 support
  • M680x0 syntax
  • machine dependencies
  • machine directives, AMD 29K
  • machine directives, ARC
  • machine directives, ARM
  • machine directives, H8/300 (none)
  • machine directives, H8/500 (none)
  • machine directives, i960
  • machine directives, SH
  • machine directives, SPARC
  • machine directives, V850
  • machine directives, VAX
  • machine independent directives
  • machine instructions (not covered)
  • machine-independent syntax
  • macro directive
  • macros
  • Macros, AMD 29K
  • macros, count executed
  • make rules
  • manual, structure and purpose
  • memory references, i386
  • merging text and data sections
  • messages from assembler
  • minus, permitted arguments
  • MIPS architecture options
  • MIPS big-endian output
  • MIPS debugging directives
  • MIPS ECOFF sections
  • MIPS endianness
  • MIPS ISA
  • MIPS ISA override
  • MIPS little-endian output
  • MIPS option stack
  • MIPS processor
  • MIT
  • mnemonics for opcodes, VAX
  • mnemonics, D10V
  • mnemonics, H8/300
  • mnemonics, H8/500
  • mnemonics, SH
  • mnemonics, Z8000
  • Motorola syntax for the 680x0
  • MRI compatibility mode
  • mri directive
  • MRI mode, temporarily
  • mul instruction, i386
  • multi-line statements

    • n

  • name
  • named section
  • named sections
  • names, symbol
  • naming object file
  • new page, in listings
  • newline (\n)
  • newline, required at file end
  • nolist directive
  • null-terminated strings
  • number constants
  • number of macros executed
  • numbered subsections
  • numbers, 16-bit
  • numeric values

    • o

  • object file
  • object file format
  • object file name
  • object file, after errors
  • obsolescent directives
  • octa directive
  • octal character code (\ddd)
  • octal integers
  • offset directive, V850
  • opcode mnemonics, VAX
  • opcode naming, i386
  • opcode prefixes, i386
  • opcode suffixes, i386
  • opcode summary, D10V
  • opcode summary, H8/300
  • opcode summary, H8/500
  • opcode summary, SH
  • opcode summary, Z8000
  • opcodes for AMD 29K
  • opcodes for ARM
  • opcodes for V850
  • opcodes, i960
  • opcodes, M680x0
  • operand delimiters, i386
  • operand notation, VAX
  • operands in expressions
  • operator precedence
  • operators, in expressions
  • operators, permitted arguments
  • optimization, D10V
  • option summary
  • options for AMD29K (none)
  • options for ARC
  • options for ARM (none)
  • options for i386 (none)
  • options for SPARC
  • options for V850 (none)
  • options for VAX/VMS
  • options, all versions of assembler
  • options, command line
  • options, D10V
  • options, H8/300 (none)
  • options, H8/500 (none)
  • options, i960
  • options, M680x0
  • options, SH (none)
  • options, Z8000
  • org directive
  • other attribute, of a.out symbol
  • output file

    • p

  • p2align directive
  • p2alignl directive
  • p2alignw directive
  • padding the location counter
  • padding the location counter given a power of two
  • padding the location counter given number of bytes
  • page, in listings
  • paper size, for listings
  • paths for .include
  • patterns, writing in memory
  • plus, permitted arguments
  • precedence of operators
  • precision, floating point
  • prefix operators
  • prefixes, i386
  • preprocessing
  • preprocessing, turning on and off
  • primary attributes, COFF symbols
  • proc directive, SPARC
  • protected registers, AMD 29K
  • pseudo-opcodes, M680x0
  • pseudo-ops for branch, VAX
  • pseudo-ops, machine independent
  • psize directive
  • psw register, V850
  • purpose of GNU assembler

    • q

  • quad directive
  • quad directive, i386

    • r

  • real-mode code, i386
  • register names, AMD 29K
  • register names, ARM
  • register names, H8/300
  • register names, V850
  • register names, VAX
  • register operands, i386
  • registers, D10V
  • registers, H8/500
  • registers, i386
  • registers, SH
  • registers, Z8000
  • relocation
  • relocation example
  • repeat prefixes, i386
  • reporting bugs in assembler
  • rept directive
  • reserve directive, SPARC
  • return instructions, i386
  • rsect

    • s

  • sbttl directive
  • scl directive
  • sdaoff pseudo-op, V850
  • search path for .include
  • sect directive, AMD 29K
  • section directive
  • section directive, V850
  • section override prefixes, i386
  • section-relative addressing
  • sections
  • sections in messages, internal
  • sections, i386
  • sections, named
  • seg directive, SPARC
  • segm
  • set directive
  • SH addressing modes
  • SH floating point (IEEE)
  • SH line comment character
  • SH line separator
  • SH machine directives
  • SH opcode summary
  • SH options (none)
  • SH registers
  • SH support
  • short directive
  • single character constant
  • single directive
  • single directive, i386
  • sixteen bit integers
  • sixteen byte integer
  • size directive
  • size modifiers, D10V
  • size modifiers, M680x0
  • size prefixes, i386
  • size suffixes, H8/300
  • sizes operands, i386
  • skip directive
  • skip directive, M680x0
  • skip directive, SPARC
  • sleb128 directive
  • small objects, MIPS ECOFF
  • SOM symbol attributes
  • source program
  • source, destination operands; i386
  • sp register, V850
  • space directive
  • space used, maximum for assembly
  • SPARC architectures
  • SPARC data alignment
  • SPARC floating point (IEEE)
  • SPARC machine directives
  • SPARC options
  • SPARC support
  • special characters, M680x0
  • special purpose registers, AMD 29K
  • stabd directive
  • stabn directive
  • stabs directive
  • stabx directives
  • standard assembler sections
  • standard input, as input file
  • statement on multiple lines
  • statement separator character
  • statement separator, H8/300
  • statement separator, H8/500
  • statement separator, SH
  • statement separator, Z8000
  • statements, structure of
  • statistics, about assembly
  • stopping the assembly
  • string constants
  • string directive
  • string directive on HPPA
  • string literals
  • string, copying to object file
  • structure debugging, COFF
  • sub-instruction ordering, D10V
  • sub-instructions, D10V
  • subexpressions
  • subtitles for listings
  • subtraction, permitted arguments
  • summary of options
  • support
  • supporting files, including
  • suppressing warnings
  • sval
  • symbol attributes
  • symbol attributes, a.out
  • symbol attributes, COFF
  • symbol attributes, SOM
  • symbol descriptor, COFF
  • symbol names
  • symbol names, `$' in, symbol names, `$' in, symbol names, `$' in
  • symbol names, local
  • symbol names, temporary
  • symbol storage class (COFF)
  • symbol type
  • symbol type, COFF
  • symbol value
  • symbol value, setting
  • symbol values, assigning
  • symbol versioning
  • symbol, common
  • symbol, making visible to linker
  • symbolic debuggers, information for
  • symbols
  • symbols with lowercase, VAX/VMS
  • symbols, assigning values to
  • symbols, local common
  • symver directive
  • syntax compatibility, i386
  • syntax, D10V
  • syntax, M680x0
  • syntax, machine-independent
  • sysproc directive, i960

    • t

  • tab (\t)
  • tag directive
  • tdaoff pseudo-op, V850
  • temporary symbol names
  • text and data sections, joining
  • text directive
  • text section
  • tfloat directive, i386
  • thumb directive, ARM
  • Thumb support
  • time, total for assembly
  • title directive
  • tp register, V850
  • trusted compiler
  • turning preprocessing on and off
  • type directive
  • type of a symbol

    • u

  • ualong directive, SH
  • uaword directive, SH
  • uleb128 directive
  • undefined section
  • unsegm
  • use directive, AMD 29K

    • v

  • V850 command line options
  • V850 floating point (IEEE)
  • V850 line comment character
  • V850 machine directives
  • V850 opcodes
  • V850 options (none)
  • V850 register names
  • V850 support
  • val directive
  • value attribute, COFF
  • value of a symbol
  • VAX bitfields not supported
  • VAX branch improvement
  • VAX command-line options ignored
  • VAX displacement sizing character
  • VAX floating point
  • VAX immediate character
  • VAX indirect character
  • VAX machine directives
  • VAX opcode mnemonics
  • VAX operand notation
  • VAX register names
  • VAX support
  • Vax-11 C compatibility
  • VAX/VMS options
  • version of assembler
  • versions of symbols
  • VMS (VAX) options

    • w

  • warning for altered difference tables
  • warning messages
  • warnings, suppressing
  • whitespace
  • whitespace, removed by preprocessor
  • wide floating point directives, VAX
  • word directive
  • word directive, H8/300
  • word directive, H8/500
  • word directive, i386
  • word directive, SPARC
  • writing patterns in memory
  • wval

    • x

  • xword directive, SPARC

    • z

  • Z800 addressing modes
  • Z8000 directives
  • Z8000 line comment character
  • Z8000 line separator
  • Z8000 opcode summary
  • Z8000 options
  • Z8000 registers
  • Z8000 support
  • zdaoff pseudo-op, V850
  • zero register, V850
  • zero-terminated strings

    • Go to the first, previous, next, last section, table of contents.


Using as - Footnotes

Using as

The GNU Assembler

January 1994

Dean Elsner, Jay Fenlason & friends

(1)

Any more details?

This document was generated on 22 March 1998 using the texi2html translator version 1.52.


gnu Binary Utilities - ar

ar

ar [-]p[mod [relpos]] archive [member...]
ar -M [ <mri-script ]

The GNU ar program creates, modifies, and extracts from archives. An archive is a single file holding a collection of other files in a structure that makes it possible to retrieve the original individual files (called members of the archive).

The original files' contents, mode (permissions), timestamp, owner, and group are preserved in the archive, and can be restored on extraction.

GNU ar can maintain archives whose members have names of any length; however, depending on how ar is configured on your system, a limit on member-name length may be imposed for compatibility with archive formats maintained with other tools. If it exists, the limit is often 15 characters (typical of formats related to a.out) or 16 characters (typical of formats related to coff).

ar is considered a binary utility because archives of this sort are most often used as libraries holding commonly needed subroutines.

ar creates an index to the symbols defined in relocatable object modules in the archive when you specify the modifier `s'. Once created, this index is updated in the archive whenever ar makes a change to its contents (save for the `q' update operation). An archive with such an index speeds up linking to the library, and allows routines in the library to call each other without regard to their placement in the archive.

You may use `nm -s' or `nm --print-armap' to list this index table. If an archive lacks the table, another form of ar called ranlib can be used to add just the table.

GNU ar is designed to be compatible with two different facilities. You can control its activity using command-line options, like the different varieties of ar on Unix systems; or, if you specify the single command-line option `-M', you can control it with a script supplied via standard input, like the MRI "librarian" program.

Controlling ar on the command line

ar [-]p[mod [relpos]] archive [member...]

When you use ar in the Unix style, ar insists on at least two arguments to execute: one keyletter specifying the operation (optionally accompanied by other keyletters specifying modifiers), and the archive name to act on.

Most operations can also accept further member arguments, specifying particular files to operate on.

GNU ar allows you to mix the operation code p and modifier flags mod in any order, within the first command-line argument.

If you wish, you may begin the first command-line argument with a dash.

The p keyletter specifies what operation to execute; it may be any of the following, but you must specify only one of them:

d
Delete modules from the archive. Specify the names of modules to be deleted as member...; the archive is untouched if you specify no files to delete. If you specify the `v' modifier, ar lists each module as it is deleted.
m
Use this operation to move members in an archive. The ordering of members in an archive can make a difference in how programs are linked using the library, if a symbol is defined in more than one member. If no modifiers are used with m, any members you name in the member arguments are moved to the end of the archive; you can use the `a', `b', or `i' modifiers to move them to a specified place instead.
p
Print the specified members of the archive, to the standard output file. If the `v' modifier is specified, show the member name before copying its contents to standard output. If you specify no member arguments, all the files in the archive are printed.
q
Quick append; Historically, add the files member... to the end of archive, without checking for replacement. The modifiers `a', `b', and `i' do not affect this operation; new members are always placed at the end of the archive. The modifier `v' makes ar list each file as it is appended. Since the point of this operation is speed, the archive's symbol table index is not updated, even if it already existed; you can use `ar s' or ranlib explicitly to update the symbol table index. However, too many different system assume quick append rebuilds the index, so GNU ar treats q to same way its treats r.
r
Insert the files member... into archive (with replacement). This operation differs from `q' in that any previously existing members are deleted if their names match those being added. If one of the files named in member... does not exist, ar displays an error message, and leaves undisturbed any existing members of the archive matching that name. By default, new members are added at the end of the file; but you may use one of the modifiers `a', `b', or `i' to request placement relative to some existing member. The modifier `v' used with this operation elicits a line of output for each file inserted, along with one of the letters `a' or `r' to indicate whether the file was appended (no old member deleted) or replaced.
t
Display a table listing the contents of archive, or those of the files listed in member... that are present in the archive. Normally only the member name is shown; if you also want to see the modes (permissions), timestamp, owner, group, and size, you can request that by also specifying the `v' modifier. If you do not specify a member, all files in the archive are listed. If there is more than one file with the same name (say, `fie') in an archive (say `b.a'), `ar t b.a fie' lists only the first instance; to see them all, you must ask for a complete listing--in our example, `ar t b.a'.
x
Extract members (named member) from the archive. You can use the `v' modifier with this operation, to request that ar list each name as it extracts it. If you do not specify a member, all files in the archive are extracted.

A number of modifiers (mod) may immediately follow the p keyletter, to specify variations on an operation's behavior:

a
Add new files after an existing member of the archive. If you use the modifier `a', the name of an existing archive member must be present as the relpos argument, before the archive specification.
b
Add new files before an existing member of the archive. If you use the modifier `b', the name of an existing archive member must be present as the relpos argument, before the archive specification. (same as `i').
c
Create the archive. The specified archive is always created if it did not exist, when you request an update. But a warning is issued unless you specify in advance that you expect to create it, by using this modifier.
f
Truncate names in the archive. GNU ar will normally permit file names of any length. This will cause it to create archives which are not compatible with the native ar program on some systems. If this is a concern, the `f' modifier may be used to truncate file names when putting them in the archive.
i
Insert new files before an existing member of the archive. If you use the modifier `i', the name of an existing archive member must be present as the relpos argument, before the archive specification. (same as `b').
l
This modifier is accepted but not used.
o
Preserve the original dates of members when extracting them. If you do not specify this modifier, files extracted from the archive are stamped with the time of extraction.
s
Write an object-file index into the archive, or update an existing one, even if no other change is made to the archive. You may use this modifier flag either with any operation, or alone. Running `ar s' on an archive is equivalent to running `ranlib' on it.
u
Normally, `ar r'... inserts all files listed into the archive. If you would like to insert only those of the files you list that are newer than existing members of the same names, use this modifier. The `u' modifier is allowed only for the operation `r' (replace). In particular, the combination `qu' is not allowed, since checking the timestamps would lose any speed advantage from the operation `q'.
v
This modifier requests the verbose version of an operation. Many operations display additional information, such as filenames processed, when the modifier `v' is appended.
V
This modifier shows the version number of ar.

Controlling ar with a script

ar -M [ <script ]

If you use the single command-line option `-M' with ar, you can control its operation with a rudimentary command language. This form of ar operates interactively if standard input is coming directly from a terminal. During interactive use, ar prompts for input (the prompt is `AR >'), and continues executing even after errors. If you redirect standard input to a script file, no prompts are issued, and ar abandons execution (with a nonzero exit code) on any error.

The ar command language is not designed to be equivalent to the command-line options; in fact, it provides somewhat less control over archives. The only purpose of the command language is to ease the transition to GNU ar for developers who already have scripts written for the MRI "librarian" program.

The syntax for the ar command language is straightforward:

  • commands are recognized in upper or lower case; for example, LIST is the same as list. In the following descriptions, commands are shown in upper case for clarity.
  • a single command may appear on each line; it is the first word on the line.
  • empty lines are allowed, and have no effect.
  • comments are allowed; text after either of the characters `*' or `;' is ignored.
  • Whenever you use a list of names as part of the argument to an ar command, you can separate the individual names with either commas or blanks. Commas are shown in the explanations below, for clarity.
  • `+' is used as a line continuation character; if `+' appears at the end of a line, the text on the following line is considered part of the current command.

Here are the commands you can use in ar scripts, or when using ar interactively. Three of them have special significance:

OPEN or CREATE specify a current archive, which is a temporary file required for most of the other commands.

SAVE commits the changes so far specified by the script. Prior to SAVE, commands affect only the temporary copy of the current archive.

ADDLIB archive
ADDLIB archive (module, module, ... module)
Add all the contents of archive (or, if specified, each named module from archive) to the current archive. Requires prior use of OPEN or CREATE.
ADDMOD member, member, ... member
Add each named member as a module in the current archive. Requires prior use of OPEN or CREATE.
CLEAR
Discard the contents of the current archive, cancelling the effect of any operations since the last SAVE. May be executed (with no effect) even if no current archive is specified.
CREATE archive
Creates an archive, and makes it the current archive (required for many other commands). The new archive is created with a temporary name; it is not actually saved as archive until you use SAVE. You can overwrite existing archives; similarly, the contents of any existing file named archive will not be destroyed until SAVE.
DELETE module, module, ... module
Delete each listed module from the current archive; equivalent to `ar -d archive module ... module'. Requires prior use of OPEN or CREATE.
DIRECTORY archive (module, ... module)
DIRECTORY archive (module, ... module) outputfile
List each named module present in archive. The separate command VERBOSE specifies the form of the output: when verbose output is off, output is like that of `ar -t archive module...'. When verbose output is on, the listing is like `ar -tv archive module...'. Output normally goes to the standard output stream; however, if you specify outputfile as a final argument, ar directs the output to that file.
END
Exit from ar, with a 0 exit code to indicate successful completion. This command does not save the output file; if you have changed the current archive since the last SAVE command, those changes are lost.
EXTRACT module, module, ... module
Extract each named module from the current archive, writing them into the current directory as separate files. Equivalent to `ar -x archive module...'. Requires prior use of OPEN or CREATE.
LIST
Display full contents of the current archive, in "verbose" style regardless of the state of VERBOSE. The effect is like `ar tv archive'). (This single command is a GNU ld enhancement, rather than present for MRI compatibility.) Requires prior use of OPEN or CREATE.
OPEN archive
Opens an existing archive for use as the current archive (required for many other commands). Any changes as the result of subsequent commands will not actually affect archive until you next use SAVE.
REPLACE module, module, ... module
In the current archive, replace each existing module (named in the REPLACE arguments) from files in the current working directory. To execute this command without errors, both the file, and the module in the current archive, must exist. Requires prior use of OPEN or CREATE.
VERBOSE
Toggle an internal flag governing the output from DIRECTORY. When the flag is on, DIRECTORY output matches output from `ar -tv '....
SAVE
Commit your changes to the current archive, and actually save it as a file with the name specified in the last CREATE or OPEN command. Requires prior use of OPEN or CREATE.


gnu Binary Utilities - ld

ld

The GNU linker ld is now described in a separate manual. See section `Overview' in Using LD: the GNU linker.


gnu Binary Utilities - nm

nm

nm [ -a | --debug-syms ]  [ -g | --extern-only ]
   [ -B ]  [ -C | --demangle ] [ -D | --dynamic ]
   [ -s | --print-armap ]  [ -A | -o | --print-file-name ]
   [ -n | -v | --numeric-sort ]  [ -p | --no-sort ]
   [ -r | --reverse-sort ]  [ --size-sort ] [ -u | --undefined-only ]
   [ -t radix | --radix=radix ] [ -P | --portability ]
   [ --target=bfdname ] [ -f format | --format=format ]
   [ --defined-only ] [-l | --line-numbers ]
   [ --no-demangle ] [ -V | --version ]  [ --help ]  [ objfile... ]

GNU nm lists the symbols from object files objfile.... If no object files are listed as arguments, nm assumes `a.out'.

For each symbol, nm shows:

  • The symbol value, in the radix selected by options (see below), or hexadecimal by default.
  • The symbol type. At least the following types are used; others are, as well, depending on the object file format. If lowercase, the symbol is local; if uppercase, the symbol is global (external).
    A
    The symbol's value is absolute, and will not be changed by further linking.
    B
    The symbol is in the uninitialized data section (known as BSS).
    C
    The symbol is common. Common symbols are uninitialized data. When linking, multiple common symbols may appear with the same name. If the symbol is defined anywhere, the common symbols are treated as undefined references. For more details on common symbols, see the discussion of --warn-common in section `Linker options' in The GNU linker.
    D
    The symbol is in the initialized data section.
    G
    The symbol is in an initialized data section for small objects. Some object file formats permit more efficient access to small data objects, such as a global int variable as opposed to a large global array.
    I
    The symbol is an indirect reference to another symbol. This is a GNU extension to the a.out object file format which is rarely used.
    N
    The symbol is a debugging symbol.
    R
    The symbol is in a read only data section.
    S
    The symbol is in an uninitialized data section for small objects.
    T
    The symbol is in the text (code) section.
    U
    The symbol is undefined.
    W
    The symbol is weak. When a weak defined symbol is linked with a normal defined symbol, the normal defined symbol is used with no error. When a weak undefined symbol is linked and the symbol is not defined, the value of the weak symbol becomes zero with no error.
    -
    The symbol is a stabs symbol in an a.out object file. In this case, the next values printed are the stabs other field, the stabs desc field, and the stab type. Stabs symbols are used to hold debugging information; for more information, see section `Stabs Overview' in The "stabs" debug format.
    ?
    The symbol type is unknown, or object file format specific.
  • The symbol name.

The long and short forms of options, shown here as alternatives, are equivalent.

-A
-o
--print-file-name
Precede each symbol by the name of the input file (or archive element) in which it was found, rather than identifying the input file once only, before all of its symbols.
-a
--debug-syms
Display all symbols, even debugger-only symbols; normally these are not listed.
-B
The same as `--format=bsd' (for compatibility with the MIPS nm).
-C
--demangle
Decode (demangle) low-level symbol names into user-level names. Besides removing any initial underscore prepended by the system, this makes C++ function names readable. See section c++filt, for more information on demangling.
--no-demangle
Do not demangle low-level symbol names. This is the default.
-D
--dynamic
Display the dynamic symbols rather than the normal symbols. This is only meaningful for dynamic objects, such as certain types of shared libraries.
-f format
--format=format
Use the output format format, which can be bsd, sysv, or posix. The default is bsd. Only the first character of format is significant; it can be either upper or lower case.
-g
--extern-only
Display only external symbols.
-l
--line-numbers
For each symbol, use debugging information to try to find a filename and line number. For a defined symbol, look for the line number of the address of the symbol. For an undefined symbol, look for the line number of a relocation entry which refers to the symbol. If line number information can be found, print it after the other symbol information.
-n
-v
--numeric-sort
Sort symbols numerically by their addresses, rather than alphabetically by their names.
-p
--no-sort
Do not bother to sort the symbols in any order; print them in the order encountered.
-P
--portability
Use the POSIX.2 standard output format instead of the default format. Equivalent to `-f posix'.
-s
--print-armap
When listing symbols from archive members, include the index: a mapping (stored in the archive by ar or ranlib) of which modules contain definitions for which names.
-r
--reverse-sort
Reverse the order of the sort (whether numeric or alphabetic); let the last come first.
--size-sort
Sort symbols by size. The size is computed as the difference between the value of the symbol and the value of the symbol with the next higher value. The size of the symbol is printed, rather than the value.
-t radix
--radix=radix
Use radix as the radix for printing the symbol values. It must be `d' for decimal, `o' for octal, or `x' for hexadecimal.
--target=bfdname
Specify an object code format other than your system's default format. See section Target Selection, for more information.
-u
--undefined-only
Display only undefined symbols (those external to each object file).
--defined-only
Display only defined symbols for each object file.
-V
--version
Show the version number of nm and exit.
--help
Show a summary of the options to nm and exit.


gnu Binary Utilities - objcopy

objcopy

objcopy [ -F bfdname | --target=bfdname ]
        [ -I bfdname | --input-target=bfdname ]
        [ -O bfdname | --output-target=bfdname ]
        [ -S | --strip-all ]  [ -g | --strip-debug ]
        [ -K symbolname | --keep-symbol=symbolname ]
        [ -N symbolname | --strip-symbol=symbolname ]
        [ -L symbolname | --localize-symbol=symbolname ]
        [ -W symbolname | --weaken-symbol=symbolname ]
        [ -x | --discard-all ]  [ -X | --discard-locals ]
        [ -b byte | --byte=byte ]
        [ -i interleave | --interleave=interleave ]
        [ -R sectionname | --remove-section=sectionname ]
        [ -p | --preserve-dates ] [ --debugging ]
        [ --gap-fill=val ] [ --pad-to=address ]
        [ --set-start=val ] [ --adjust-start=incr ]
        [ --adjust-vma=incr ]
        [ --adjust-section-vma=section{=,+,-}val ]
        [ --adjust-warnings ] [ --no-adjust-warnings ]
        [ --set-section-flags=section=flags ]
        [ --add-section=sectionname=filename ]
        [ --change-leading-char ] [ --remove-leading-char ]
        [ --weaken ]
        [ -v | --verbose ] [ -V | --version ]  [ --help ]
        infile [outfile]

The GNU objcopy utility copies the contents of an object file to another. objcopy uses the GNU BFD Library to read and write the object files. It can write the destination object file in a format different from that of the source object file. The exact behavior of objcopy is controlled by command-line options.

objcopy creates temporary files to do its translations and deletes them afterward. objcopy uses BFD to do all its translation work; it has access to all the formats described in BFD and thus is able to recognize most formats without being told explicitly. See section `BFD' in Using LD.

objcopy can be used to generate S-records by using an output target of `srec' (e.g., use `-O srec').

objcopy can be used to generate a raw binary file by using an output target of `binary' (e.g., use `-O binary'). When objcopy generates a raw binary file, it will essentially produce a memory dump of the contents of the input object file. All symbols and relocation information will be discarded. The memory dump will start at the load address of the lowest section copied into the output file.

When generating an S-record or a raw binary file, it may be helpful to use `-S' to remove sections containing debugging information. In some cases `-R' will be useful to remove sections which contain information which is not needed by the binary file.

infile
outfile
The source and output files, respectively. If you do not specify outfile, objcopy creates a temporary file and destructively renames the result with the name of infile.
-I bfdname
--input-target=bfdname
Consider the source file's object format to be bfdname, rather than attempting to deduce it. See section Target Selection, for more information.
-O bfdname
--output-target=bfdname
Write the output file using the object format bfdname. See section Target Selection, for more information.
-F bfdname
--target=bfdname
Use bfdname as the object format for both the input and the output file; i.e., simply transfer data from source to destination with no translation. See section Target Selection, for more information.
-R sectionname
--remove-section=sectionname
Remove any section named sectionname from the output file. This option may be given more than once. Note that using this option inappropriately may make the output file unusable.
-S
--strip-all
Do not copy relocation and symbol information from the source file.
-g
--strip-debug
Do not copy debugging symbols from the source file.
--strip-unneeded
Strip all symbols that are not needed for relocation processing.
-K symbolname
--keep-symbol=symbolname
Copy only symbol symbolname from the source file. This option may be given more than once.
-N symbolname
--strip-symbol=symbolname
Do not copy symbol symbolname from the source file. This option may be given more than once.
-L symbolname
--localize-symbol=symbolname
Make symbol symbolname local to the file, so that it is not visible externally. This option may be given more than once.
-W symbolname
--weaken-symbol=symbolname
Make symbol symbolname weak. This option may be given more than once.
-x
--discard-all
Do not copy non-global symbols from the source file.
-X
--discard-locals
Do not copy compiler-generated local symbols. (These usually start with `L' or `.'.)
-b byte
--byte=byte
Keep only every byteth byte of the input file (header data is not affected). byte can be in the range from 0 to interleave-1, where interleave is given by the `-i' or `--interleave' option, or the default of 4. This option is useful for creating files to program ROM. It is typically used with an srec output target.
-i interleave
--interleave=interleave
Only copy one out of every interleave bytes. Select which byte to copy with the -b or `--byte' option. The default is 4. objcopy ignores this option if you do not specify either `-b' or `--byte'.
-p
--preserve-dates
Set the access and modification dates of the output file to be the same as those of the input file.
--debugging
Convert debugging information, if possible. This is not the default because only certain debugging formats are supported, and the conversion process can be time consuming.
--gap-fill val
Fill gaps between sections with val. This is done by increasing the size of the section with the lower address, and filling in the extra space created with val.
--pad-to address
Pad the output file up to the virtual address address. This is done by increasing the size of the last section. The extra space is filled in with the value specified by `--gap-fill' (default zero).
--set-start val
Set the address of the new file to val. Not all object file formats support setting the start address.
--adjust-start incr
Adjust the start address by adding incr. Not all object file formats support setting the start address.
--adjust-vma incr
Adjust the address of all sections, as well as the start address, by adding incr. Some object file formats do not permit section addresses to be changed arbitrarily. Note that this does not relocate the sections; if the program expects sections to be loaded at a certain address, and this option is used to change the sections such that they are loaded at a different address, the program may fail.
--adjust-section-vma section{=,+,-}val
Set or adjust the address of the named section. If `=' is used, the section address is set to val. Otherwise, val is added to or subtracted from the section address. See the comments under `--adjust-vma', above. If section does not exist in the input file, a warning will be issued, unless `--no-adjust-warnings' is used.
--adjust-warnings
If `--adjust-section-vma' is used, and the named section does not exist, issue a warning. This is the default.
--no-adjust-warnings
Do not issue a warning if `--adjust-section-vma' is used, even if the named section does not exist.
--set-section-flags section=flags
Set the flags for the named section. The flags argument is a comma separated string of flag names. The recognized names are `alloc', `contents', `load', `readonly', `code', `data', and `rom'. You can set the `contents' flag for a section which does not have contents, but it is not meaningful to clear the `contents' flag of a section which does have contents--just remove the section instead. Not all flags are meaningful for all object file formats.
--add-section sectionname=filename
Add a new section named sectionname while copying the file. The contents of the new section are taken from the file filename. The size of the section will be the size of the file. This option only works on file formats which can support sections with arbitrary names.
--change-leading-char
Some object file formats use special characters at the start of symbols. The most common such character is underscore, which compilers often add before every symbol. This option tells objcopy to change the leading character of every symbol when it converts between object file formats. If the object file formats use the same leading character, this option has no effect. Otherwise, it will add a character, or remove a character, or change a character, as appropriate.
--remove-leading-char
If the first character of a global symbol is a special symbol leading character used by the object file format, remove the character. The most common symbol leading character is underscore. This option will remove a leading underscore from all global symbols. This can be useful if you want to link together objects of different file formats with different conventions for symbol names. This is different from --change-leading-char because it always changes the symbol name when appropriate, regardless of the object file format of the output file.
--weaken
Change all global symbols in the file to be weak. This can be useful when building an object which will be linked against other objects using the -R option to the linker. This option is only effective when using an object file format which supports weak symbols.
-V
--version
Show the version number of objcopy.
-v
--verbose
Verbose output: list all object files modified. In the case of archives, `objcopy -V' lists all members of the archive.
--help
Show a summary of the options to objcopy.


gnu Binary Utilities - objdump

objdump

objdump [ -a | --archive-headers ]
        [ -b bfdname | --target=bfdname ] [ --debugging ]
        [ -C | --demangle ] [ -d | --disassemble ]
        [ -D | --disassemble-all ] [ --disassemble-zeroes ]
        [ -EB | -EL | --endian={big | little } ]
        [ -f | --file-headers ]
        [ -h | --section-headers | --headers ]  [ -i | --info ]
        [ -j section | --section=section ]
        [ -l | --line-numbers ] [ -S | --source ]
        [ -m machine | --architecture=machine ]
        [ -r | --reloc ] [ -R | --dynamic-reloc ]
        [ -s | --full-contents ]  [ --stabs ]
        [ -t | --syms ] [ -T | --dynamic-syms ] [ -x | --all-headers ]
        [ -w | --wide ] [ --start-address=address ]
        [ --stop-address=address ]
        [ --prefix-addresses] [ --[no-]show-raw-insn ]
        [ --adjust-vma=offset ]
        [ --version ]  [ --help ]
        objfile...

objdump displays information about one or more object files. The options control what particular information to display. This information is mostly useful to programmers who are working on the compilation tools, as opposed to programmers who just want their program to compile and work.

objfile... are the object files to be examined. When you specify archives, objdump shows information on each of the member object files.

The long and short forms of options, shown here as alternatives, are equivalent. At least one option besides `-l' must be given.

-a
--archive-header
If any of the objfile files are archives, display the archive header information (in a format similar to `ls -l'). Besides the information you could list with `ar tv', `objdump -a' shows the object file format of each archive member.
--adjust-vma=offset
When dumping information, first add offset to all the section addresses. This is useful if the section addresses do not correspond to the symbol table, which can happen when putting sections at particular addresses when using a format which can not represent section addresses, such as a.out.
-b bfdname
--target=bfdname
Specify that the object-code format for the object files is bfdname. This option may not be necessary; objdump can automatically recognize many formats. For example,
objdump -b oasys -m vax -h fu.o
displays summary information from the section headers (`-h') of `fu.o', which is explicitly identified (`-m') as a VAX object file in the format produced by Oasys compilers. You can list the formats available with the `-i' option. See section Target Selection, for more information.
-C
--demangle
Decode (demangle) low-level symbol names into user-level names. Besides removing any initial underscore prepended by the system, this makes C++ function names readable. See section c++filt, for more information on demangling.
--debugging
Display debugging information. This attempts to parse debugging information stored in the file and print it out using a C like syntax. Only certain types of debugging information have been implemented.
-d
--disassemble
Display the assembler mnemonics for the machine instructions from objfile. This option only disassembles those sections which are expected to contain instructions.
-D
--disassemble-all
Like `-d', but disassemble the contents of all sections, not just those expected to contain instructions.
--prefix-addresses
When disassembling, print the complete address on each line. This is the older disassembly format.
--disassemble-zeroes
Normally the disassembly output will skip blocks of zeroes. This option directs the disassembler to disassemble those blocks, just like any other data.
-EB
-EL
--endian={big|little}
Specify the endianness of the object files. This only affects disassembly. This can be useful when disassembling a file format which does not describe endianness information, such as S-records.
-f
--file-header
Display summary information from the overall header of each of the objfile files.
-h
--section-header
--header
Display summary information from the section headers of the object file. File segments may be relocated to nonstandard addresses, for example by using the `-Ttext', `-Tdata', or `-Tbss' options to ld. However, some object file formats, such as a.out, do not store the starting address of the file segments. In those situations, although ld relocates the sections correctly, using `objdump -h' to list the file section headers cannot show the correct addresses. Instead, it shows the usual addresses, which are implicit for the target.
--help
Print a summary of the options to objdump and exit.
-i
--info
Display a list showing all architectures and object formats available for specification with `-b' or `-m'.
-j name
--section=name
Display information only for section name.
-l
--line-numbers
Label the display (using debugging information) with the filename and source line numbers corresponding to the object code or relocs shown. Only useful with `-d', `-D', or `-r'.
-m machine
--architecture=machine
Specify the architecture to use when disassembling object files. This can be useful when disasembling object files which do not describe architecture information, such as S-records. You can list the available architectures with the `-i' option.
-r
--reloc
Print the relocation entries of the file. If used with `-d' or `-D', the relocations are printed interspersed with the disassembly.
-R
--dynamic-reloc
Print the dynamic relocation entries of the file. This is only meaningful for dynamic objects, such as certain types of shared libraries.
-s
--full-contents
Display the full contents of any sections requested.
-S
--source
Display source code intermixed with disassembly, if possible. Implies `-d'.
--show-raw-insn
When disassembling instructions, print the instruction in hex as well as in symbolic form. This is the default except when --prefix-addresses is used.
--no-show-raw-insn
When disassembling instructions, do not print the instruction bytes. This is the default when --prefix-addresses is used.
--stabs
Display the full contents of any sections requested. Display the contents of the .stab and .stab.index and .stab.excl sections from an ELF file. This is only useful on systems (such as Solaris 2.0) in which .stab debugging symbol-table entries are carried in an ELF section. In most other file formats, debugging symbol-table entries are interleaved with linkage symbols, and are visible in the `--syms' output. For more information on stabs symbols, see section `Stabs Overview' in The "stabs" debug format.
--start-address=address
Start displaying data at the specified address. This affects the output of the -d, -r and -s options.
--stop-address=address
Stop displaying data at the specified address. This affects the output of the -d, -r and -s options.
-t
--syms
Print the symbol table entries of the file. This is similar to the information provided by the `nm' program.
-T
--dynamic-syms
Print the dynamic symbol table entries of the file. This is only meaningful for dynamic objects, such as certain types of shared libraries. This is similar to the information provided by the `nm' program when given the `-D' (`--dynamic') option.
--version
Print the version number of objdump and exit.
-x
--all-header
Display all available header information, including the symbol table and relocation entries. Using `-x' is equivalent to specifying all of `-a -f -h -r -t'.
-w
--wide
Format some lines for output devices that have more than 80 columns.


gnu Binary Utilities - ranlib

ranlib

ranlib [-vV] archive

ranlib generates an index to the contents of an archive and stores it in the archive. The index lists each symbol defined by a member of an archive that is a relocatable object file.

You may use `nm -s' or `nm --print-armap' to list this index.

An archive with such an index speeds up linking to the library and allows routines in the library to call each other without regard to their placement in the archive.

The GNU ranlib program is another form of GNU ar; running ranlib is completely equivalent to executing `ar -s'. See section ar.

-v
-V
Show the version number of ranlib.


gnu Binary Utilities - size

size

size [ -A | -B | --format=compatibility ]
     [ --help ]  [ -d | -o | -x | --radix=number ]
     [ --target=bfdname ]  [ -V | --version ]
     [ objfile... ]

The GNU size utility lists the section sizes--and the total size--for each of the object or archive files objfile in its argument list. By default, one line of output is generated for each object file or each module in an archive.

objfile... are the object files to be examined. If none are specified, the file a.out will be used.

The command line options have the following meanings:

-A
-B
--format=compatibility
Using one of these options, you can choose whether the output from GNU size resembles output from System V size (using `-A', or `--format=sysv'), or Berkeley size (using `-B', or `--format=berkeley'). The default is the one-line format similar to Berkeley's. Here is an example of the Berkeley (default) format of output from size:
size --format=Berkeley ranlib size
text    data    bss     dec     hex     filename
294880  81920   11592   388392  5ed28   ranlib
294880  81920   11888   388688  5ee50   size
This is the same data, but displayed closer to System V conventions:
size --format=SysV ranlib size
ranlib  :
section         size         addr
.text         294880         8192
.data          81920       303104
.bss           11592       385024
Total         388392

size  :
section         size         addr
.text         294880         8192
.data          81920       303104
.bss           11888       385024
Total         388688
--help
Show a summary of acceptable arguments and options.
-d
-o
-x
--radix=number
Using one of these options, you can control whether the size of each section is given in decimal (`-d', or `--radix=10'); octal (`-o', or `--radix=8'); or hexadecimal (`-x', or `--radix=16'). In `--radix=number', only the three values (8, 10, 16) are supported. The total size is always given in two radices; decimal and hexadecimal for `-d' or `-x' output, or octal and hexadecimal if you're using `-o'.
--target=bfdname
Specify that the object-code format for objfile is bfdname. This option may not be necessary; size can automatically recognize many formats. See section Target Selection, for more information.
-V
--version
Display the version number of size.


gnu Binary Utilities - strings

strings

strings [-afov] [-min-len] [-n min-len] [-t radix] [-]
        [--all] [--print-file-name] [--bytes=min-len]
        [--radix=radix] [--target=bfdname]
        [--help] [--version] file...

For each file given, GNU strings prints the printable character sequences that are at least 4 characters long (or the number given with the options below) and are followed by an unprintable character. By default, it only prints the strings from the initialized and loaded sections of object files; for other types of files, it prints the strings from the whole file.

strings is mainly useful for determining the contents of non-text files.

-a
--all
-
Do not scan only the initialized and loaded sections of object files; scan the whole files.
-f
--print-file-name
Print the name of the file before each string.
--help
Print a summary of the program usage on the standard output and exit.
-min-len
-n min-len
--bytes=min-len
Print sequences of characters that are at least min-len characters long, instead of the default 4.
-o
Like `-t o'. Some other versions of strings have `-o' act like `-t d' instead. Since we can not be compatible with both ways, we simply chose one.
-t radix
--radix=radix
Print the offset within the file before each string. The single character argument specifies the radix of the offset---`o' for octal, `x' for hexadecimal, or `d' for decimal.
--target=bfdname
Specify an object code format other than your system's default format. See section Target Selection, for more information.
-v
--version
Print the program version number on the standard output and exit.


gnu Binary Utilities - strip

strip

strip [ -F bfdname | --target=bfdname ]
      [ -I bfdname | --input-target=bfdname ]
      [ -O bfdname | --output-target=bfdname ]
      [ -s | --strip-all ] [ -S | -g | --strip-debug ]
      [ -K symbolname | --keep-symbol=symbolname ]
      [ -N symbolname | --strip-symbol=symbolname ]
      [ -x | --discard-all ] [ -X | --discard-locals ]
      [ -R sectionname | --remove-section=sectionname ]
      [ -o file ] [ -p | --preserve-dates ]
      [ -v | --verbose ]  [ -V | --version ]  [ --help ]
      objfile...

GNU strip discards all symbols from object files objfile. The list of object files may include archives. At least one object file must be given.

strip modifies the files named in its argument, rather than writing modified copies under different names.

-F bfdname
--target=bfdname
Treat the original objfile as a file with the object code format bfdname, and rewrite it in the same format. See section Target Selection, for more information.
--help
Show a summary of the options to strip and exit.
-I bfdname
--input-target=bfdname
Treat the original objfile as a file with the object code format bfdname. See section Target Selection, for more information.
-O bfdname
--output-target=bfdname
Replace objfile with a file in the output format bfdname. See section Target Selection, for more information.
-R sectionname
--remove-section=sectionname
Remove any section named sectionname from the output file. This option may be given more than once. Note that using this option inappropriately may make the output file unusable.
-s
--strip-all
Remove all symbols.
-g
-S
--strip-debug
Remove debugging symbols only.
--strip-unneeded
Remove all symbols that are not needed for relocation processing.
-K symbolname
--keep-symbol=symbolname
Keep only symbol symbolname from the source file. This option may be given more than once.
-N symbolname
--strip-symbol=symbolname
Remove symbol symbolname from the source file. This option may be given more than once, and may be combined with strip options other than -K.
-o file
Put the stripped output in file, rather than replacing the existing file. When this argument is used, only one objfile argument may be specified.
-p
--preserve-dates
Preserve the access and modification dates of the file.
-x
--discard-all
Remove non-global symbols.
-X
--discard-locals
Remove compiler-generated local symbols. (These usually start with `L' or `.'.)
-V
--version
Show the version number for strip.
-v
--verbose
Verbose output: list all object files modified. In the case of archives, `strip -v' lists all members of the archive.


gnu Binary Utilities - c++filt

c++filt

c++filt [ -_ | --strip-underscores ]
    [ -n | --no-strip-underscores ]
        [ -s format | --format=format ]
        [ --help ]  [ --version ]  [ symbol... ]

The C++ language provides function overloading, which means that you can write many functions with the same name (providing each takes parameters of different types). All C++ function names are encoded into a low-level assembly label (this process is known as mangling). The c++filt program does the inverse mapping: it decodes (demangles) low-level names into user-level names so that the linker can keep these overloaded functions from clashing.

Every alphanumeric word (consisting of letters, digits, underscores, dollars, or periods) seen in the input is a potential label. If the label decodes into a C++ name, the C++ name replaces the low-level name in the output.

You can use c++filt to decipher individual symbols:

c++filt symbol

If no symbol arguments are given, c++filt reads symbol names from the standard input and writes the demangled names to the standard output. All results are printed on the standard output.

-_
--strip-underscores
On some systems, both the C and C++ compilers put an underscore in front of every name. For example, the C name foo gets the low-level name _foo. This option removes the initial underscore. Whether c++filt removes the underscore by default is target dependent.
-n
--no-strip-underscores
Do not remove the initial underscore.
-s format
--format=format
GNU nm can decode three different methods of mangling, used by different C++ compilers. The argument to this option selects which method it uses:
gnu
the one used by the GNU compiler (the default method)
lucid
the one used by the Lucid compiler
arm
the one specified by the C++ Annotated Reference Manual
--help
Print a summary of the options to c++filt and exit.
--version
Print the version number of c++filt and exit.

Warning: c++filt is a new utility, and the details of its user interface are subject to change in future releases. In particular, a command-line option may be required in the the future to decode a name passed as an argument on the command line; in other words,

c++filt symbol

may in a future release become

c++filt option symbol


gnu Binary Utilities - addr2line

addr2line

addr2line [ -b bfdname | --target=bfdname ]
          [ -C | --demangle ]
          [ -e filename | --exe=filename ]
          [ -f | --functions ] [ -s | --basename ]
          [ -H | --help ] [ -V | --version ]
          [ addr addr ... ]

addr2line translates program addresses into file names and line numbers. Given an address and an executable, it uses the debugging information in the executable to figure out which file name and line number are associated with a given address.

The executable to use is specified with the -e option. The default is `a.out'.

addr2line has two modes of operation.

In the first, hexadecimal addresses are specified on the command line, and addr2line displays the file name and line number for each address.

In the second, addr2line reads hexadecimal addresses from standard input, and prints the file name and line number for each address on standard output. In this mode, addr2line may be used in a pipe to convert dynamically chosen addresses.

The format of the output is `FILENAME:LINENO'. The file name and line number for each address is printed on a separate line. If the -f option is used, then each `FILENAME:LINENO' line is preceded by a `FUNCTIONNAME' line which is the name of the function containing the address.

If the file name or function name can not be determined, addr2line will print two question marks in their place. If the line number can not be determined, addr2line will print 0.

The long and short forms of options, shown here as alternatives, are equivalent.

-b bfdname
--target=bfdname
Specify that the object-code format for the object files is bfdname.
-C
--demangle
Decode (demangle) low-level symbol names into user-level names. Besides removing any initial underscore prepended by the system, this makes C++ function names readable. See section c++filt, for more information on demangling.
-e filename
--exe=filename
Specify the name of the executable for which addresses should be translated. The default file is `a.out'.
-f
--functions
Display function names as well as file and line number information.
-s
--basenames
Display only the base of each file name.


gnu Binary Utilities - nlmconv

nlmconv

nlmconv converts a relocatable object file into a NetWare Loadable Module.

Warning: nlmconv is not always built as part of the binary utilities, since it is only useful for NLM targets.

nlmconv [ -I bfdname | --input-target=bfdname ]
        [ -O bfdname | --output-target=bfdname ]
        [ -T headerfile | --header-file=headerfile ]
        [ -d | --debug]  [ -l linker | --linker=linker ]
        [ -h | --help ]  [ -V | --version ]
        infile outfile

nlmconv converts the relocatable `i386' object file infile into the NetWare Loadable Module outfile, optionally reading headerfile for NLM header information. For instructions on writing the NLM command file language used in header files, see the `linkers' section, `NLMLINK' in particular, of the NLM Development and Tools Overview, which is part of the NLM Software Developer's Kit ("NLM SDK"), available from Novell, Inc. nlmconv uses the GNU Binary File Descriptor library to read infile; see section `BFD' in Using LD, for more information.

nlmconv can perform a link step. In other words, you can list more than one object file for input if you list them in the definitions file (rather than simply specifying one input file on the command line). In this case, nlmconv calls the linker for you.

-I bfdname
--input-target=bfdname
Object format of the input file. nlmconv can usually determine the format of a given file (so no default is necessary). See section Target Selection, for more information.
-O bfdname
--output-target=bfdname
Object format of the output file. nlmconv infers the output format based on the input format, e.g. for a `i386' input file the output format is `nlm32-i386'. See section Target Selection, for more information.
-T headerfile
--header-file=headerfile
Reads headerfile for NLM header information. For instructions on writing the NLM command file language used in header files, see see the `linkers' section, of the NLM Development and Tools Overview, which is part of the NLM Software Developer's Kit, available from Novell, Inc.
-d
--debug
Displays (on standard error) the linker command line used by nlmconv.
-l linker
--linker=linker
Use linker for any linking. linker can be an abosolute or a relative pathname.
-h
--help
Prints a usage summary.
-V
--version
Prints the version number for nlmconv.


gnu Binary Utilities - windres

windres

windres may be used to manipulate Windows resources.

Warning: windres is not always built as part of the binary utilities, since it is only useful for Windows targets.

windres [options] [input-file] [output-file]

windres reads resources from an input file and copies them into an output file. Either file may be in one of three formats:

rc
A text format read by the Resource Compiler.
res
A binary format generated by the Resource Compiler.
coff
A COFF object or executable.

The exact description of these different formats is available in documentation from Microsoft.

When windres converts from the rc format to the res format, it is acting like the Windows Resource Compiler. When windres converts from the res format to the coff format, it is acting like the Windows CVTRES program.

When windres generates an rc file, the output is similar but not identical to the format expected for the input. When an input rc file refers to an external filename, an output rc file will instead include the file contents.

If the input or output format is not specified, windres will guess based on the file name, or, for the input file, the file contents. A file with an extension of `.rc' will be treated as an rc file, a file with an extension of `.res' will be treated as a res file, and a file with an extension of `.o' or `.exe' will be treated as a coff file.

If no output file is specified, windres will print the resources in rc format to standard output.

The normal use is for you to write an rc file, use windres to convert it to a COFF object file, and then link the COFF file into your application. This will make the resources described in the rc file available to Windows.

-i filename
--input filename
The name of the input file. If this option is not used, then windres will use the first non-option argument as the input file name. If there are no non-option arguments, then windres will read from standard input. windres can not read a COFF file from standard input.
-o filename
--output filename
The name of the output file. If this option is not used, then windres will use the first non-option argument, after any used for the input file name, as the output file name. If there is no non-option argument, then windres will write to standard output. windres can not write a COFF file to standard output.
-I format
--input-format format
The input format to read. format may be `res', `rc', or `coff'. If no input format is specified, windres will guess, as described above.
-O format
--output-format format
The output format to generate. format may be `res', `rc', or `coff'. If no output format is specified, windres will guess, as described above.
-F target
--target target
Specify the BFD format to use for a COFF file as input or output. This is a BFD target name; you can use the --help option to see a list of supported targets. Normally windres will use the default format, which is the first one listed by the --help option. section Target Selection.
--preprocessor program
When windres reads an rc file, it runs it through the C preprocessor first. This option may be used to specify the preprocessor to use, including any leading arguments. The default preprocessor argument is gcc -E -xc-header -DRC_INVOKED.
--include-dir directory
Specify an include directory to use when reading an rc file. windres will pass this to the preprocessor as an -I option. windres will also search this directory when looking for files named in the rc file.
--define sym[=val]
Specify a -D option to pass to the preprocessor when reading an rc file.
--language val
Specify the default language to use when reading an rc file. val should be a hexadecimal language code. The low eight bits are the language, and the high eight bits are the sublanguage.
--help
Prints a usage summary.
--version
Prints the version number for windres.
--yydebug
If windres is compiled with YYDEBUG defined as 1, this will turn on parser debugging.


gnu Binary Utilities - Selecting the target system

Selecting the target system

You can specify three aspects of the target system to the GNU binary file utilities, each in several ways:

  • the target
  • the architecture
  • the linker emulation (which applies to the linker only)

In the following summaries, the lists of ways to specify values are in order of decreasing precedence. The ways listed first override those listed later.

The commands to list valid values only list the values for which the programs you are running were configured. If they were configured with `--enable-targets=all', the commands list most of the available values, but a few are left out; not all targets can be configured in at once because some of them can only be configured native (on hosts with the same type as the target system).

Target Selection

A target is an object file format. A given target may be supported for multiple architectures (see section Architecture selection). A target selection may also have variations for different operating systems or architectures.

The command to list valid target values is `objdump -i' (the first column of output contains the relevant information).

Some sample values are: `a.out-hp300bsd', `ecoff-littlemips', `a.out-sunos-big'.

You can also specify a target using a configuration triplet. This is the same sort of name that is passed to configure to specify a target. When you use a configuration triplet as an argument, it must be fully canonicalized. You can see the canonical version of a triplet by running the shell script `config.sub' which is included with the sources.

Some sample configuration triplets are: `m68k-hp-bsd', `mips-dec-ultrix', `sparc-sun-sunos'.

objdump Target

Ways to specify:

  1. command line option: `-b' or `--target'
  2. environment variable GNUTARGET
  3. deduced from the input file

objcopy and strip Input Target

Ways to specify:

  1. command line options: `-I' or `--input-target', or `-F' or `--target'
  2. environment variable GNUTARGET
  3. deduced from the input file

objcopy and strip Output Target

Ways to specify:

  1. command line options: `-O' or `--output-target', or `-F' or `--target'
  2. the input target (see "objcopy and strip Input Target" above)
  3. environment variable GNUTARGET
  4. deduced from the input file

nm, size, and strings Target

Ways to specify:

  1. command line option: `--target'
  2. environment variable GNUTARGET
  3. deduced from the input file

Linker Input Target

Ways to specify:

  1. command line option: `-b' or `--format' (see section `Options' in Using LD)
  2. script command TARGET (see section `Option Commands' in Using LD)
  3. environment variable GNUTARGET (see section `Environment' in Using LD)
  4. the default target of the selected linker emulation (see section Linker emulation selection)

Linker Output Target

Ways to specify:

  1. command line option: `-oformat' (see section `Options' in Using LD)
  2. script command OUTPUT_FORMAT (see section `Option Commands' in Using LD)
  3. the linker input target (see "Linker Input Target" above)

Architecture selection

An architecture is a type of CPU on which an object file is to run. Its name may contain a colon, separating the name of the processor family from the name of the particular CPU.

The command to list valid architecture values is `objdump -i' (the second column contains the relevant information).

Sample values: `m68k:68020', `mips:3000', `sparc'.

objdump Architecture

Ways to specify:

  1. command line option: `-m' or `--architecture'
  2. deduced from the input file

objcopy, nm, size, strings Architecture

Ways to specify:

  1. deduced from the input file

Linker Input Architecture

Ways to specify:

  1. deduced from the input file

Linker Output Architecture

Ways to specify:

  1. script command OUTPUT_ARCH (see section `Option Commands' in Using LD)
  2. the default architecture from the linker output target (see section Target Selection)

Linker emulation selection

A linker emulation is a "personality" of the linker, which gives the linker default values for the other aspects of the target system. In particular, it consists of

  • the linker script
  • the target
  • several "hook" functions that are run at certain stages of the linking process to do special things that some targets require

The command to list valid linker emulation values is `ld -V'.

Sample values: `hp300bsd', `mipslit', `sun4'.

Ways to specify:

  1. command line option: `-m' (see section `Options' in Using LD)
  2. environment variable LDEMULATION
  3. compiled-in DEFAULT_EMULATION from `Makefile', which comes from EMUL in `config/target.mt'


gnu Binary Utilities - Reporting Bugs

Reporting Bugs

Your bug reports play an essential role in making the binary utilities reliable.

Reporting a bug may help you by bringing a solution to your problem, or it may not. But in any case the principal function of a bug report is to help the entire community by making the next version of the binary utilities work better. Bug reports are your contribution to their maintenance.

In order for a bug report to serve its purpose, you must include the information that enables us to fix the bug.

Have you found a bug?

If you are not sure whether you have found a bug, here are some guidelines:

  • If a binary utility gets a fatal signal, for any input whatever, that is a bug. Reliable utilities never crash.
  • If a binary utility produces an error message for valid input, that is a bug.
  • If you are an experienced user of binary utilities, your suggestions for improvement are welcome in any case.

How to report bugs

A number of companies and individuals offer support for GNU products. If you obtained the binary utilities from a support organization, we recommend you contact that organization first.

You can find contact information for many support companies and individuals in the file `etc/SERVICE' in the GNU Emacs distribution.

In any event, we also recommend that you send bug reports for the binary utilities to `bug-gnu-utils@prep.ai.mit.edu'.

The fundamental principle of reporting bugs usefully is this: report all the facts. If you are not sure whether to state a fact or leave it out, state it!

Often people omit facts because they think they know what causes the problem and assume that some details do not matter. Thus, you might assume that the name of a file you use in an example does not matter. Well, probably it does not, but one cannot be sure. Perhaps the bug is a stray memory reference which happens to fetch from the location where that pathname is stored in memory; perhaps, if the pathname were different, the contents of that location would fool the utility into doing the right thing despite the bug. Play it safe and give a specific, complete example. That is the easiest thing for you to do, and the most helpful.

Keep in mind that the purpose of a bug report is to enable us to fix the bug if it is new to us. Therefore, always write your bug reports on the assumption that the bug has not been reported previously.

Sometimes people give a few sketchy facts and ask, "Does this ring a bell?" Those bug reports are useless, and we urge everyone to refuse to respond to them except to chide the sender to report bugs properly.

To enable us to fix the bug, you should include all these things:

  • The version of the utility. Each utility announces it if you start it with the `--version' argument. Without this, we will not know whether there is any point in looking for the bug in the current version of the binary utilities.
  • Any patches you may have applied to the source, including any patches made to the BFD library.
  • The type of machine you are using, and the operating system name and version number.
  • What compiler (and its version) was used to compile the utilities--e.g. "gcc-2.7".
  • The command arguments you gave the utility to observe the bug. To guarantee you will not omit something important, list them all. A copy of the Makefile (or the output from make) is sufficient. If we were to try to guess the arguments, we would probably guess wrong and then we might not encounter the bug.
  • A complete input file, or set of input files, that will reproduce the bug. If the utility is reading an object file or files, then it is generally most helpful to send the actual object files, uuencoded if necessary to get them through the mail system. Making them available for anonymous FTP is not as good, but may be the only reasonable choice for large object files. If the source files were produced exclusively using GNU programs (e.g., gcc, gas, and/or the GNU ld), then it may be OK to send the source files rather than the object files. In this case, be sure to say exactly what version of gcc, or whatever, was used to produce the object files. Also say how gcc, or whatever, was configured.
  • A description of what behavior you observe that you believe is incorrect. For example, "It gets a fatal signal." Of course, if the bug is that the utility gets a fatal signal, then we will certainly notice it. But if the bug is incorrect output, we might not notice unless it is glaringly wrong. You might as well not give us a chance to make a mistake. Even if the problem you experience is a fatal signal, you should still say so explicitly. Suppose something strange is going on, such as, your copy of the utility is out of synch, or you have encountered a bug in the C library on your system. (This has happened!) Your copy might crash and ours would not. If you told us to expect a crash, then when ours fails to crash, we would know that the bug was not happening for us. If you had not told us to expect a crash, then we would not be able to draw any conclusion from our observations.
  • If you wish to suggest changes to the source, send us context diffs, as generated by diff with the `-u', `-c', or `-p' option. Always send diffs from the old file to the new file. If you even discuss something in the ld source, refer to it by context, not by line number. The line numbers in our development sources will not match those in your sources. Your line numbers would convey no useful information to us.

Here are some things that are not necessary:

  • A description of the envelope of the bug. Often people who encounter a bug spend a lot of time investigating which changes to the input file will make the bug go away and which changes will not affect it. This is often time consuming and not very useful, because the way we will find the bug is by running a single example under the debugger with breakpoints, not by pure deduction from a series of examples. We recommend that you save your time for something else. Of course, if you can find a simpler example to report instead of the original one, that is a convenience for us. Errors in the output will be easier to spot, running under the debugger will take less time, and so on. However, simplification is not vital; if you do not want to do this, report the bug anyway and send us the entire test case you used.
  • A patch for the bug. A patch for the bug does help us if it is a good one. But do not omit the necessary information, such as the test case, on the assumption that a patch is all we need. We might see problems with your patch and decide to fix the problem another way, or we might not understand it at all. Sometimes with programs as complicated as the binary utilities it is very hard to construct an example that will make the program follow a certain path through the code. If you do not send us the example, we will not be able to construct one, so we will not be able to verify that the bug is fixed. And if we cannot understand what bug you are trying to fix, or why your patch should be an improvement, we will not install it. A test case will help us to understand.
  • A guess about what the bug is or what it depends on. Such guesses are usually wrong. Even we cannot guess right about such things without first using the debugger to find the facts.


gnu Binary Utilities - Index

Index

.

  • .stab

    • a

  • addr2line
  • address to file name and line number
  • all header information, object file
  • ar
  • ar compatibility
  • architecture
  • architectures available
  • archive contents
  • archive headers
  • archives

    • b

  • bug criteria
  • bug reports
  • bugs
  • bugs, reporting

    • c

  • c++filt
  • collections of files
  • compatibility, ar
  • contents of archive
  • crash
  • creating archives

    • d

  • dates in archive
  • debug symbols
  • debugging symbols
  • deleting from archive
  • demangling C++ symbols
  • demangling in nm
  • demangling in objdump, demangling in objdump
  • disassembling object code
  • disassembly architecture
  • disassembly endianness
  • disassembly, with source
  • discarding symbols
  • dynamic relocation entries, in object file
  • dynamic symbol table entries, printing
  • dynamic symbols

    • e

  • ELF object file format
  • endianness
  • error on valid input
  • external symbols, external symbols, external symbols
  • extract from archive

    • f

  • fatal signal
  • file name

    • h

  • header information, all

    • i

  • input file name

    • l

  • ld
  • libraries
  • linker
  • listings strings

    • m

  • machine instructions
  • moving in archive
  • MRI compatibility, ar

    • n

  • name duplication in archive
  • name length
  • nm
  • nm compatibility, nm compatibility
  • nm format, nm format

    • o

  • objdump
  • object code format, object code format, object code format, object code format, object code format
  • object file header
  • object file information
  • object file sections
  • object formats available
  • operations on archive

    • p

  • printing from archive
  • printing strings

    • q

  • quick append to archive

    • r

  • radix for section sizes
  • ranlib
  • relative placement in archive
  • relocation entries, in object file
  • removing symbols
  • repeated names in archive
  • replacement in archive
  • reporting bugs

    • s

  • scripts, ar
  • section addresses in objdump
  • section headers
  • section information
  • section sizes
  • sections, full contents
  • size
  • size display format
  • size number format
  • sorting symbols
  • source disassembly
  • source file name
  • source filenames for object files
  • stab
  • start-address
  • stop-address
  • strings
  • strings, printing
  • strip
  • symbol index, symbol index
  • symbol index, listing
  • symbol line numbers
  • symbol table entries, printing
  • symbols
  • symbols, discarding

    • u

  • undefined symbols, undefined symbols
  • Unix compatibility, ar
  • updating an archive

    • v

  • VMA in objdump

    • w

  • wide output, printing
  • writing archive index

    • Go to the first, previous, next, last section, table of contents.


The C Preprocessor - The C Preprocessor

The C Preprocessor

The C preprocessor is a macro processor that is used automatically by the C compiler to transform your program before actual compilation. It is called a macro processor because it allows you to define macros, which are brief abbreviations for longer constructs.

The C preprocessor provides four separate facilities that you can use as you see fit:

  • Inclusion of header files. These are files of declarations that can be substituted into your program.
  • Macro expansion. You can define macros, which are abbreviations for arbitrary fragments of C code, and then the C preprocessor will replace the macros with their definitions throughout the program.
  • Conditional compilation. Using special preprocessing directives, you can include or exclude parts of the program according to various conditions.
  • Line control. If you use a program to combine or rearrange source files into an intermediate file which is then compiled, you can use line control to inform the compiler of where each source line originally came from.

C preprocessors vary in some details. This manual discusses the GNU C preprocessor, the C Compatible Compiler Preprocessor. The GNU C preprocessor provides a superset of the features of ANSI Standard C.

ANSI Standard C requires the rejection of many harmless constructs commonly used by today's C programs. Such incompatibility would be inconvenient for users, so the GNU C preprocessor is configured to accept these constructs by default. Strictly speaking, to get ANSI Standard C, you must use the options `-trigraphs', `-undef' and `-pedantic', but in practice the consequences of having strict ANSI Standard C make it undesirable to do this. See section Invoking the C Preprocessor.

The C preprocessor is designed for C-like languages; you may run into problems if you apply it to other kinds of languages, because it assumes that it is dealing with C. For example, the C preprocessor sometimes outputs extra white space to avoid inadvertent C token concatenation, and this may cause problems with other languages.

Transformations Made Globally

Most C preprocessor features are inactive unless you give specific directives to request their use. (Preprocessing directives are lines starting with `#'; see section Preprocessing Directives). But there are three transformations that the preprocessor always makes on all the input it receives, even in the absence of directives.

  • All C comments are replaced with single spaces.
  • Backslash-Newline sequences are deleted, no matter where. This feature allows you to break long lines for cosmetic purposes without changing their meaning.
  • Predefined macro names are replaced with their expansions (see section Predefined Macros).

The first two transformations are done before nearly all other parsing and before preprocessing directives are recognized. Thus, for example, you can split a line cosmetically with Backslash-Newline anywhere (except when trigraphs are in use; see below).

/*
*/ # /*
*/ defi\
ne FO\
O 10\
20

is equivalent into `#define FOO 1020'. You can split even an escape sequence with Backslash-Newline. For example, you can split "foo\bar" between the `\' and the `b' to get

"foo\\
bar"

This behavior is unclean: in all other contexts, a Backslash can be inserted in a string constant as an ordinary character by writing a double Backslash, and this creates an exception. But the ANSI C standard requires it. (Strict ANSI C does not allow Newlines in string constants, so they do not consider this a problem.)

But there are a few exceptions to all three transformations.

  • C comments and predefined macro names are not recognized inside a `#include' directive in which the file name is delimited with `<' and `>'.
  • C comments and predefined macro names are never recognized within a character or string constant. (Strictly speaking, this is the rule, not an exception, but it is worth noting here anyway.)
  • Backslash-Newline may not safely be used within an ANSI "trigraph". Trigraphs are converted before Backslash-Newline is deleted. If you write what looks like a trigraph with a Backslash-Newline inside, the Backslash-Newline is deleted as usual, but it is then too late to recognize the trigraph. This exception is relevant only if you use the `-trigraphs' option to enable trigraph processing. See section Invoking the C Preprocessor.

Preprocessing Directives

Most preprocessor features are active only if you use preprocessing directives to request their use.

Preprocessing directives are lines in your program that start with `#'. The `#' is followed by an identifier that is the directive name. For example, `#define' is the directive that defines a macro. Whitespace is also allowed before and after the `#'.

The set of valid directive names is fixed. Programs cannot define new preprocessing directives.

Some directive names require arguments; these make up the rest of the directive line and must be separated from the directive name by whitespace. For example, `#define' must be followed by a macro name and the intended expansion of the macro. See section Simple Macros.

A preprocessing directive cannot be more than one line in normal circumstances. It may be split cosmetically with Backslash-Newline, but that has no effect on its meaning. Comments containing Newlines can also divide the directive into multiple lines, but the comments are changed to Spaces before the directive is interpreted. The only way a significant Newline can occur in a preprocessing directive is within a string constant or character constant. Note that most C compilers that might be applied to the output from the preprocessor do not accept string or character constants containing Newlines.

The `#' and the directive name cannot come from a macro expansion. For example, if `foo' is defined as a macro expanding to `define', that does not make `#foo' a valid preprocessing directive.

Header Files

A header file is a file containing C declarations and macro definitions (see section Macros) to be shared between several source files. You request the use of a header file in your program with the C preprocessing directive `#include'.

Uses of Header Files

Header files serve two kinds of purposes.

  • System header files declare the interfaces to parts of the operating system. You include them in your program to supply the definitions and declarations you need to invoke system calls and libraries.
  • Your own header files contain declarations for interfaces between the source files of your program. Each time you have a group of related declarations and macro definitions all or most of which are needed in several different source files, it is a good idea to create a header file for them.

Including a header file produces the same results in C compilation as copying the header file into each source file that needs it. But such copying would be time-consuming and error-prone. With a header file, the related declarations appear in only one place. If they need to be changed, they can be changed in one place, and programs that include the header file will automatically use the new version when next recompiled. The header file eliminates the labor of finding and changing all the copies as well as the risk that a failure to find one copy will result in inconsistencies within a program.

The usual convention is to give header files names that end with `.h'. Avoid unusual characters in header file names, as they reduce portability.

The `#include' Directive

Both user and system header files are included using the preprocessing directive `#include'. It has three variants:

#include <file>
This variant is used for system header files. It searches for a file named file in a list of directories specified by you, then in a standard list of system directories. You specify directories to search for header files with the command option `-I' (see section Invoking the C Preprocessor). The option `-nostdinc' inhibits searching the standard system directories; in this case only the directories you specify are searched. The parsing of this form of `#include' is slightly special because comments are not recognized within the `<...>'. Thus, in `#include <x/*y>' the `/*' does not start a comment and the directive specifies inclusion of a system header file named `x/*y'. Of course, a header file with such a name is unlikely to exist on Unix, where shell wildcard features would make it hard to manipulate. The argument file may not contain a `>' character. It may, however, contain a `<' character.
#include "file"
This variant is used for header files of your own program. It searches for a file named file first in the current directory, then in the same directories used for system header files. The current directory is the directory of the current input file. It is tried first because it is presumed to be the location of the files that the current input file refers to. (If the `-I-' option is used, the special treatment of the current directory is inhibited.) The argument file may not contain `"' characters. If backslashes occur within file, they are considered ordinary text characters, not escape characters. None of the character escape sequences appropriate to string constants in C are processed. Thus, `#include "x\n\\y"' specifies a filename containing three backslashes. It is not clear why this behavior is ever useful, but the ANSI standard specifies it.
#include anything else
This variant is called a computed #include. Any `#include' directive whose argument does not fit the above two forms is a computed include. The text anything else is checked for macro calls, which are expanded (see section Macros). When this is done, the result must fit one of the above two variants--in particular, the expanded text must in the end be surrounded by either quotes or angle braces. This feature allows you to define a macro which controls the file name to be used at a later point in the program. One application of this is to allow a site-specific configuration file for your program to specify the names of the system include files to be used. This can help in porting the program to various operating systems in which the necessary system header files are found in different places.

How `#include' Works

The `#include' directive works by directing the C preprocessor to scan the specified file as input before continuing with the rest of the current file. The output from the preprocessor contains the output already generated, followed by the output resulting from the included file, followed by the output that comes from the text after the `#include' directive. For example, given a header file `header.h' as follows,

char *test ();

and a main program called `program.c' that uses the header file, like this,

int x;
#include "header.h"

main ()
{
  printf (test ());
}

the output generated by the C preprocessor for `program.c' as input would be

int x;
char *test ();

main ()
{
  printf (test ());
}

Included files are not limited to declarations and macro definitions; those are merely the typical uses. Any fragment of a C program can be included from another file. The include file could even contain the beginning of a statement that is concluded in the containing file, or the end of a statement that was started in the including file. However, a comment or a string or character constant may not start in the included file and finish in the including file. An unterminated comment, string constant or character constant in an included file is considered to end (with an error message) at the end of the file.

It is possible for a header file to begin or end a syntactic unit such as a function definition, but that would be very confusing, so don't do it.

The line following the `#include' directive is always treated as a separate line by the C preprocessor even if the included file lacks a final newline.

Once-Only Include Files

Very often, one header file includes another. It can easily result that a certain header file is included more than once. This may lead to errors, if the header file defines structure types or typedefs, and is certainly wasteful. Therefore, we often wish to prevent multiple inclusion of a header file.

The standard way to do this is to enclose the entire real contents of the file in a conditional, like this:

#ifndef FILE_FOO_SEEN
#define FILE_FOO_SEEN

the entire file

#endif /* FILE_FOO_SEEN */

The macro FILE_FOO_SEEN indicates that the file has been included once already. In a user header file, the macro name should not begin with `_'. In a system header file, this name should begin with `__' to avoid conflicts with user programs. In any kind of header file, the macro name should contain the name of the file and some additional text, to avoid conflicts with other header files.

The GNU C preprocessor is programmed to notice when a header file uses this particular construct and handle it efficiently. If a header file is contained entirely in a `#ifndef' conditional, then it records that fact. If a subsequent `#include' specifies the same file, and the macro in the `#ifndef' is already defined, then the file is entirely skipped, without even reading it.

There is also an explicit directive to tell the preprocessor that it need not include a file more than once. This is called `#pragma once', and was used in addition to the `#ifndef' conditional around the contents of the header file. `#pragma once' is now obsolete and should not be used at all.

In the Objective C language, there is a variant of `#include' called `#import' which includes a file, but does so at most once. If you use `#import' instead of `#include', then you don't need the conditionals inside the header file to prevent multiple execution of the contents.

`#import' is obsolete because it is not a well designed feature. It requires the users of a header file--the applications programmers--to know that a certain header file should only be included once. It is much better for the header file's implementor to write the file so that users don't need to know this. Using `#ifndef' accomplishes this goal.

Inheritance and Header Files

Inheritance is what happens when one object or file derives some of its contents by virtual copying from another object or file. In the case of C header files, inheritance means that one header file includes another header file and then replaces or adds something.

If the inheriting header file and the base header file have different names, then inheritance is straightforward: simply write `#include "base"' in the inheriting file.

Sometimes it is necessary to give the inheriting file the same name as the base file. This is less straightforward.

For example, suppose an application program uses the system header `sys/signal.h', but the version of `/usr/include/sys/signal.h' on a particular system doesn't do what the application program expects. It might be convenient to define a "local" version, perhaps under the name `/usr/local/include/sys/signal.h', to override or add to the one supplied by the system.

You can do this by compiling with the option `-I.', and writing a file `sys/signal.h' that does what the application program expects. But making this file include the standard `sys/signal.h' is not so easy--writing `#include <sys/signal.h>' in that file doesn't work, because it includes your own version of the file, not the standard system version. Used in that file itself, this leads to an infinite recursion and a fatal error in compilation.

`#include </usr/include/sys/signal.h>' would find the proper file, but that is not clean, since it makes an assumption about where the system header file is found. This is bad for maintenance, since it means that any change in where the system's header files are kept requires a change somewhere else.

The clean way to solve this problem is to use `#include_next', which means, "Include the next file with this name." This directive works like `#include' except in searching for the specified file: it starts searching the list of header file directories after the directory in which the current file was found.

Suppose you specify `-I /usr/local/include', and the list of directories to search also includes `/usr/include'; and suppose both directories contain `sys/signal.h'. Ordinary `#include <sys/signal.h>' finds the file under `/usr/local/include'. If that file contains `#include_next <sys/signal.h>', it starts searching after that directory, and finds the file in `/usr/include'.

Macros

A macro is a sort of abbreviation which you can define once and then use later. There are many complicated features associated with macros in the C preprocessor.

Simple Macros

A simple macro is a kind of abbreviation. It is a name which stands for a fragment of code. Some people refer to these as manifest constants.

Before you can use a macro, you must define it explicitly with the `#define' directive. `#define' is followed by the name of the macro and then the code it should be an abbreviation for. For example,

#define BUFFER_SIZE 1020

defines a macro named `BUFFER_SIZE' as an abbreviation for the text `1020'. If somewhere after this `#define' directive there comes a C statement of the form

foo = (char *) xmalloc (BUFFER_SIZE);

then the C preprocessor will recognize and expand the macro `BUFFER_SIZE', resulting in

foo = (char *) xmalloc (1020);

The use of all upper case for macro names is a standard convention. Programs are easier to read when it is possible to tell at a glance which names are macros.

Normally, a macro definition must be a single line, like all C preprocessing directives. (You can split a long macro definition cosmetically with Backslash-Newline.) There is one exception: Newlines can be included in the macro definition if within a string or character constant. This is because it is not possible for a macro definition to contain an unbalanced quote character; the definition automatically extends to include the matching quote character that ends the string or character constant. Comments within a macro definition may contain Newlines, which make no difference since the comments are entirely replaced with Spaces regardless of their contents.

Aside from the above, there is no restriction on what can go in a macro body. Parentheses need not balance. The body need not resemble valid C code. (But if it does not, you may get error messages from the C compiler when you use the macro.)

The C preprocessor scans your program sequentially, so macro definitions take effect at the place you write them. Therefore, the following input to the C preprocessor

foo = X;
#define X 4
bar = X;

produces as output

foo = X;

bar = 4;

After the preprocessor expands a macro name, the macro's definition body is appended to the front of the remaining input, and the check for macro calls continues. Therefore, the macro body can contain calls to other macros. For example, after

#define BUFSIZE 1020
#define TABLESIZE BUFSIZE

the name `TABLESIZE' when used in the program would go through two stages of expansion, resulting ultimately in `1020'.

This is not at all the same as defining `TABLESIZE' to be `1020'. The `#define' for `TABLESIZE' uses exactly the body you specify--in this case, `BUFSIZE'---and does not check to see whether it too is the name of a macro. It's only when you use `TABLESIZE' that the result of its expansion is checked for more macro names. See section Cascaded Use of Macros.

Macros with Arguments

A simple macro always stands for exactly the same text, each time it is used. Macros can be more flexible when they accept arguments. Arguments are fragments of code that you supply each time the macro is used. These fragments are included in the expansion of the macro according to the directions in the macro definition. A macro that accepts arguments is called a function-like macro because the syntax for using it looks like a function call.

To define a macro that uses arguments, you write a `#define' directive with a list of argument names in parentheses after the name of the macro. The argument names may be any valid C identifiers, separated by commas and optionally whitespace. The open-parenthesis must follow the macro name immediately, with no space in between.

For example, here is a macro that computes the minimum of two numeric values, as it is defined in many C programs:

#define min(X, Y)  ((X) < (Y) ? (X) : (Y))

(This is not the best way to define a "minimum" macro in GNU C. See section Duplication of Side Effects, for more information.)

To use a macro that expects arguments, you write the name of the macro followed by a list of actual arguments in parentheses, separated by commas. The number of actual arguments you give must match the number of arguments the macro expects. Examples of use of the macro `min' include `min (1, 2)' and `min (x + 28, *p)'.

The expansion text of the macro depends on the arguments you use. Each of the argument names of the macro is replaced, throughout the macro definition, with the corresponding actual argument. Using the same macro `min' defined above, `min (1, 2)' expands into

((1) < (2) ? (1) : (2))

where `1' has been substituted for `X' and `2' for `Y'.

Likewise, `min (x + 28, *p)' expands into

((x + 28) < (*p) ? (x + 28) : (*p))

Parentheses in the actual arguments must balance; a comma within parentheses does not end an argument. However, there is no requirement for brackets or braces to balance, and they do not prevent a comma from separating arguments. Thus,

macro (array[x = y, x + 1])

passes two arguments to macro: `array[x = y' and `x + 1]'. If you want to supply `array[x = y, x + 1]' as an argument, you must write it as `array[(x = y, x + 1)]', which is equivalent C code.

After the actual arguments are substituted into the macro body, the entire result is appended to the front of the remaining input, and the check for macro calls continues. Therefore, the actual arguments can contain calls to other macros, either with or without arguments, or even to the same macro. The macro body can also contain calls to other macros. For example, `min (min (a, b), c)' expands into this text:

((((a) < (b) ? (a) : (b))) < (c)
 ? (((a) < (b) ? (a) : (b)))
 : (c))

(Line breaks shown here for clarity would not actually be generated.)

If a macro foo takes one argument, and you want to supply an empty argument, you must write at least some whitespace between the parentheses, like this: `foo ( )'. Just `foo ()' is providing no arguments, which is an error if foo expects an argument. But `foo0 ()' is the correct way to call a macro defined to take zero arguments, like this:

#define foo0() ...

If you use the macro name followed by something other than an open-parenthesis (after ignoring any spaces, tabs and comments that follow), it is not a call to the macro, and the preprocessor does not change what you have written. Therefore, it is possible for the same name to be a variable or function in your program as well as a macro, and you can choose in each instance whether to refer to the macro (if an actual argument list follows) or the variable or function (if an argument list does not follow).

Such dual use of one name could be confusing and should be avoided except when the two meanings are effectively synonymous: that is, when the name is both a macro and a function and the two have similar effects. You can think of the name simply as a function; use of the name for purposes other than calling it (such as, to take the address) will refer to the function, while calls will expand the macro and generate better but equivalent code. For example, you can use a function named `min' in the same source file that defines the macro. If you write `&min' with no argument list, you refer to the function. If you write `min (x, bb)', with an argument list, the macro is expanded. If you write `(min) (a, bb)', where the name `min' is not followed by an open-parenthesis, the macro is not expanded, so you wind up with a call to the function `min'.

You may not define the same name as both a simple macro and a macro with arguments.

In the definition of a macro with arguments, the list of argument names must follow the macro name immediately with no space in between. If there is a space after the macro name, the macro is defined as taking no arguments, and all the rest of the line is taken to be the expansion. The reason for this is that it is often useful to define a macro that takes no arguments and whose definition begins with an identifier in parentheses. This rule about spaces makes it possible for you to do either this:

#define FOO(x) - 1 / (x)

(which defines `FOO' to take an argument and expand into minus the reciprocal of that argument) or this:

#define BAR (x) - 1 / (x)

(which defines `BAR' to take no argument and always expand into `(x) - 1 / (x)').

Note that the uses of a macro with arguments can have spaces before the left parenthesis; it's the definition where it matters whether there is a space.

Predefined Macros

Several simple macros are predefined. You can use them without giving definitions for them. They fall into two classes: standard macros and system-specific macros.

Standard Predefined Macros

The standard predefined macros are available with the same meanings regardless of the machine or operating system on which you are using GNU C. Their names all start and end with double underscores. Those preceding __GNUC__ in this table are standardized by ANSI C; the rest are GNU C extensions.

__FILE__
This macro expands to the name of the current input file, in the form of a C string constant. The precise name returned is the one that was specified in `#include' or as the input file name argument.
__LINE__
This macro expands to the current input line number, in the form of a decimal integer constant. While we call it a predefined macro, it's a pretty strange macro, since its "definition" changes with each new line of source code. This and `__FILE__' are useful in generating an error message to report an inconsistency detected by the program; the message can state the source line at which the inconsistency was detected. For example,
fprintf (stderr, "Internal error: "
                 "negative string length "
                 "%d at %s, line %d.",
         length, __FILE__, __LINE__);
A `#include' directive changes the expansions of `__FILE__' and `__LINE__' to correspond to the included file. At the end of that file, when processing resumes on the input file that contained the `#include' directive, the expansions of `__FILE__' and `__LINE__' revert to the values they had before the `#include' (but `__LINE__' is then incremented by one as processing moves to the line after the `#include'). The expansions of both `__FILE__' and `__LINE__' are altered if a `#line' directive is used. See section Combining Source Files.
__DATE__
This macro expands to a string constant that describes the date on which the preprocessor is being run. The string constant contains eleven characters and looks like `"Feb 1 1996"'.
__TIME__
This macro expands to a string constant that describes the time at which the preprocessor is being run. The string constant contains eight characters and looks like `"23:59:01"'.
__STDC__
This macro expands to the constant 1, to signify that this is ANSI Standard C. (Whether that is actually true depends on what C compiler will operate on the output from the preprocessor.) On some hosts, system include files use a different convention, where `__STDC__' is normally 0, but is 1 if the user specifies strict conformance to the C Standard. The preprocessor follows the host convention when processing system include files, but when processing user files it follows the usual GNU C convention. This macro is not defined if the `-traditional' option is used.
__STDC_VERSION__
This macro expands to the C Standard's version number, a long integer constant of the form `yyyymmL' where yyyy and mm are the year and month of the Standard version. This signifies which version of the C Standard the preprocessor conforms to. Like `__STDC__', whether this version number is accurate for the entire implementation depends on what C compiler will operate on the output from the preprocessor. This macro is not defined if the `-traditional' option is used.
__GNUC__
This macro is defined if and only if this is GNU C. This macro is defined only when the entire GNU C compiler is in use; if you invoke the preprocessor directly, `__GNUC__' is undefined. The value identifies the major version number of GNU CC (`1' for GNU CC version 1, which is now obsolete, and `2' for version 2).
__GNUC_MINOR__
The macro contains the minor version number of the compiler. This can be used to work around differences between different releases of the compiler (for example, if gcc 2.6.3 is known to support a feature, you can test for __GNUC__ > 2 || (__GNUC__ == 2 && __GNUC_MINOR__ >= 6)). The last number, `3' in the example above, denotes the bugfix level of the compiler; no macro contains this value.
__GNUG__
The GNU C compiler defines this when the compilation language is C++; use `__GNUG__' to distinguish between GNU C and GNU C++.
__cplusplus
The draft ANSI standard for C++ used to require predefining this variable. Though it is no longer required, GNU C++ continues to define it, as do other popular C++ compilers. You can use `__cplusplus' to test whether a header is compiled by a C compiler or a C++ compiler.
__STRICT_ANSI__
This macro is defined if and only if the `-ansi' switch was specified when GNU C was invoked. Its definition is the null string. This macro exists primarily to direct certain GNU header files not to define certain traditional Unix constructs which are incompatible with ANSI C.
__BASE_FILE__
This macro expands to the name of the main input file, in the form of a C string constant. This is the source file that was specified as an argument when the C compiler was invoked.
__INCLUDE_LEVEL__
This macro expands to a decimal integer constant that represents the depth of nesting in include files. The value of this macro is incremented on every `#include' directive and decremented at every end of file. For input files specified by command line arguments, the nesting level is zero.
__VERSION__
This macro expands to a string which describes the version number of GNU C. The string is normally a sequence of decimal numbers separated by periods, such as `"2.6.0"'. The only reasonable use of this macro is to incorporate it into a string constant.
__OPTIMIZE__
This macro is defined in optimizing compilations. It causes certain GNU header files to define alternative macro definitions for some system library functions. It is unwise to refer to or test the definition of this macro unless you make very sure that programs will execute with the same effect regardless.
__CHAR_UNSIGNED__
This macro is defined if and only if the data type char is unsigned on the target machine. It exists to cause the standard header file `limits.h' to work correctly. It is bad practice to refer to this macro yourself; instead, refer to the standard macros defined in `limits.h'. The preprocessor uses this macro to determine whether or not to sign-extend large character constants written in octal; see section The `#if' Directive.
__REGISTER_PREFIX__
This macro expands to a string describing the prefix applied to cpu registers in assembler code. It can be used to write assembler code that is usable in multiple environments. For example, in the `m68k-aout' environment it expands to the string `""', but in the `m68k-coff' environment it expands to the string `"%"'.
__USER_LABEL_PREFIX__
This macro expands to a string describing the prefix applied to user generated labels in assembler code. It can be used to write assembler code that is usable in multiple environments. For example, in the `m68k-aout' environment it expands to the string `"_"', but in the `m68k-coff' environment it expands to the string `""'. This does not work with the `-mno-underscores' option that the i386 OSF/rose and m88k targets provide nor with the `-mcall*' options of the rs6000 System V Release 4 target.

Nonstandard Predefined Macros

The C preprocessor normally has several predefined macros that vary between machines because their purpose is to indicate what type of system and machine is in use. This manual, being for all systems and machines, cannot tell you exactly what their names are; instead, we offer a list of some typical ones. You can use `cpp -dM' to see the values of predefined macros; see section Invoking the C Preprocessor.

Some nonstandard predefined macros describe the operating system in use, with more or less specificity. For example,

unix
`unix' is normally predefined on all Unix systems.
BSD
`BSD' is predefined on recent versions of Berkeley Unix (perhaps only in version 4.3).

Other nonstandard predefined macros describe the kind of CPU, with more or less specificity. For example,

vax
`vax' is predefined on Vax computers.
mc68000
`mc68000' is predefined on most computers whose CPU is a Motorola 68000, 68010 or 68020.
m68k
`m68k' is also predefined on most computers whose CPU is a 68000, 68010 or 68020; however, some makers use `mc68000' and some use `m68k'. Some predefine both names. What happens in GNU C depends on the system you are using it on.
M68020
`M68020' has been observed to be predefined on some systems that use 68020 CPUs--in addition to `mc68000' and `m68k', which are less specific.
_AM29K
_AM29000
Both `_AM29K' and `_AM29000' are predefined for the AMD 29000 CPU family.
ns32000
`ns32000' is predefined on computers which use the National Semiconductor 32000 series CPU.

Yet other nonstandard predefined macros describe the manufacturer of the system. For example,

sun
`sun' is predefined on all models of Sun computers.
pyr
`pyr' is predefined on all models of Pyramid computers.
sequent
`sequent' is predefined on all models of Sequent computers.

These predefined symbols are not only nonstandard, they are contrary to the ANSI standard because their names do not start with underscores. Therefore, the option `-ansi' inhibits the definition of these symbols.

This tends to make `-ansi' useless, since many programs depend on the customary nonstandard predefined symbols. Even system header files check them and will generate incorrect declarations if they do not find the names that are expected. You might think that the header files supplied for the Uglix computer would not need to test what machine they are running on, because they can simply assume it is the Uglix; but often they do, and they do so using the customary names. As a result, very few C programs will compile with `-ansi'. We intend to avoid such problems on the GNU system.

What, then, should you do in an ANSI C program to test the type of machine it will run on?

GNU C offers a parallel series of symbols for this purpose, whose names are made from the customary ones by adding `__' at the beginning and end. Thus, the symbol __vax__ would be available on a Vax, and so on.

The set of nonstandard predefined names in the GNU C preprocessor is controlled (when cpp is itself compiled) by the macro `CPP_PREDEFINES', which should be a string containing `-D' options, separated by spaces. For example, on the Sun 3, we use the following definition:

#define CPP_PREDEFINES "-Dmc68000 -Dsun -Dunix -Dm68k"

This macro is usually specified in `tm.h'.

Stringification

Stringification means turning a code fragment into a string constant whose contents are the text for the code fragment. For example, stringifying `foo (z)' results in `"foo (z)"'.

In the C preprocessor, stringification is an option available when macro arguments are substituted into the macro definition. In the body of the definition, when an argument name appears, the character `#' before the name specifies stringification of the corresponding actual argument when it is substituted at that point in the definition. The same argument may be substituted in other places in the definition without stringification if the argument name appears in those places with no `#'.

Here is an example of a macro definition that uses stringification:

#define WARN_IF(EXP) \
do { if (EXP) \
        fprintf (stderr, "Warning: " #EXP "\n"); } \
while (0)

Here the actual argument for `EXP' is substituted once as given, into the `if' statement, and once as stringified, into the argument to `fprintf'. The `do' and `while (0)' are a kludge to make it possible to write `WARN_IF (arg);', which the resemblance of `WARN_IF' to a function would make C programmers want to do; see section Swallowing the Semicolon.

The stringification feature is limited to transforming one macro argument into one string constant: there is no way to combine the argument with other text and then stringify it all together. But the example above shows how an equivalent result can be obtained in ANSI Standard C using the feature that adjacent string constants are concatenated as one string constant. The preprocessor stringifies the actual value of `EXP' into a separate string constant, resulting in text like

do { if (x == 0) \
        fprintf (stderr, "Warning: " "x == 0" "\n"); } \
while (0)

but the C compiler then sees three consecutive string constants and concatenates them into one, producing effectively

do { if (x == 0) \
        fprintf (stderr, "Warning: x == 0\n"); } \
while (0)

Stringification in C involves more than putting doublequote characters around the fragment; it is necessary to put backslashes in front of all doublequote characters, and all backslashes in string and character constants, in order to get a valid C string constant with the proper contents. Thus, stringifying `p = "foo\n";' results in `"p = \"foo\\n\";"'. However, backslashes that are not inside of string or character constants are not duplicated: `\n' by itself stringifies to `"\n"'.

Whitespace (including comments) in the text being stringified is handled according to precise rules. All leading and trailing whitespace is ignored. Any sequence of whitespace in the middle of the text is converted to a single space in the stringified result.

Concatenation

Concatenation means joining two strings into one. In the context of macro expansion, concatenation refers to joining two lexical units into one longer one. Specifically, an actual argument to the macro can be concatenated with another actual argument or with fixed text to produce a longer name. The longer name might be the name of a function, variable or type, or a C keyword; it might even be the name of another macro, in which case it will be expanded.

When you define a macro, you request concatenation with the special operator `##' in the macro body. When the macro is called, after actual arguments are substituted, all `##' operators are deleted, and so is any whitespace next to them (including whitespace that was part of an actual argument). The result is to concatenate the syntactic tokens on either side of the `##'.

Consider a C program that interprets named commands. There probably needs to be a table of commands, perhaps an array of structures declared as follows:

struct command
{
  char *name;
  void (*function) ();
};

struct command commands[] =
{
  { "quit", quit_command},
  { "help", help_command},
  ...
};

It would be cleaner not to have to give each command name twice, once in the string constant and once in the function name. A macro which takes the name of a command as an argument can make this unnecessary. The string constant can be created with stringification, and the function name by concatenating the argument with `_command'. Here is how it is done:

#define COMMAND(NAME)  { #NAME, NAME ## _command }

struct command commands[] =
{
  COMMAND (quit),
  COMMAND (help),
  ...
};

The usual case of concatenation is concatenating two names (or a name and a number) into a longer name. But this isn't the only valid case. It is also possible to concatenate two numbers (or a number and a name, such as `1.5' and `e3') into a number. Also, multi-character operators such as `+=' can be formed by concatenation. In some cases it is even possible to piece together a string constant. However, two pieces of text that don't together form a valid lexical unit cannot be concatenated. For example, concatenation with `x' on one side and `+' on the other is not meaningful because those two characters can't fit together in any lexical unit of C. The ANSI standard says that such attempts at concatenation are undefined, but in the GNU C preprocessor it is well defined: it puts the `x' and `+' side by side with no particular special results.

Keep in mind that the C preprocessor converts comments to whitespace before macros are even considered. Therefore, you cannot create a comment by concatenating `/' and `*': the `/*' sequence that starts a comment is not a lexical unit, but rather the beginning of a "long" space character. Also, you can freely use comments next to a `##' in a macro definition, or in actual arguments that will be concatenated, because the comments will be converted to spaces at first sight, and concatenation will later discard the spaces.

Undefining Macros

To undefine a macro means to cancel its definition. This is done with the `#undef' directive. `#undef' is followed by the macro name to be undefined.

Like definition, undefinition occurs at a specific point in the source file, and it applies starting from that point. The name ceases to be a macro name, and from that point on it is treated by the preprocessor as if it had never been a macro name.

For example,

#define FOO 4
x = FOO;
#undef FOO
x = FOO;

expands into

x = 4;

x = FOO;

In this example, `FOO' had better be a variable or function as well as (temporarily) a macro, in order for the result of the expansion to be valid C code.

The same form of `#undef' directive will cancel definitions with arguments or definitions that don't expect arguments. The `#undef' directive has no effect when used on a name not currently defined as a macro.

Redefining Macros

Redefining a macro means defining (with `#define') a name that is already defined as a macro.

A redefinition is trivial if the new definition is transparently identical to the old one. You probably wouldn't deliberately write a trivial redefinition, but they can happen automatically when a header file is included more than once (see section Header Files), so they are accepted silently and without effect.

Nontrivial redefinition is considered likely to be an error, so it provokes a warning message from the preprocessor. However, sometimes it is useful to change the definition of a macro in mid-compilation. You can inhibit the warning by undefining the macro with `#undef' before the second definition.

In order for a redefinition to be trivial, the new definition must exactly match the one already in effect, with two possible exceptions:

  • Whitespace may be added or deleted at the beginning or the end.
  • Whitespace may be changed in the middle (but not inside strings). However, it may not be eliminated entirely, and it may not be added where there was no whitespace at all.

Recall that a comment counts as whitespace.

Pitfalls and Subtleties of Macros

In this section we describe some special rules that apply to macros and macro expansion, and point out certain cases in which the rules have counterintuitive consequences that you must watch out for.

Improperly Nested Constructs

Recall that when a macro is called with arguments, the arguments are substituted into the macro body and the result is checked, together with the rest of the input file, for more macro calls.

It is possible to piece together a macro call coming partially from the macro body and partially from the actual arguments. For example,

#define double(x) (2*(x))
#define call_with_1(x) x(1)

would expand `call_with_1 (double)' into `(2*(1))'.

Macro definitions do not have to have balanced parentheses. By writing an unbalanced open parenthesis in a macro body, it is possible to create a macro call that begins inside the macro body but ends outside of it. For example,

#define strange(file) fprintf (file, "%s %d",
...
strange(stderr) p, 35)

This bizarre example expands to `fprintf (stderr, "%s %d", p, 35)'!

Unintended Grouping of Arithmetic

You may have noticed that in most of the macro definition examples shown above, each occurrence of a macro argument name had parentheses around it. In addition, another pair of parentheses usually surround the entire macro definition. Here is why it is best to write macros that way.

Suppose you define a macro as follows,

#define ceil_div(x, y) (x + y - 1) / y

whose purpose is to divide, rounding up. (One use for this operation is to compute how many `int' objects are needed to hold a certain number of `char' objects.) Then suppose it is used as follows:

a = ceil_div (b & c, sizeof (int));

This expands into

a = (b & c + sizeof (int) - 1) / sizeof (int);

which does not do what is intended. The operator-precedence rules of C make it equivalent to this:

a = (b & (c + sizeof (int) - 1)) / sizeof (int);

But what we want is this:

a = ((b & c) + sizeof (int) - 1)) / sizeof (int);

Defining the macro as

#define ceil_div(x, y) ((x) + (y) - 1) / (y)

provides the desired result.

Unintended grouping can result in another way. Consider `sizeof ceil_div(1, 2)'. That has the appearance of a C expression that would compute the size of the type of `ceil_div (1, 2)', but in fact it means something very different. Here is what it expands to:

sizeof ((1) + (2) - 1) / (2)

This would take the size of an integer and divide it by two. The precedence rules have put the division outside the `sizeof' when it was intended to be inside.

Parentheses around the entire macro definition can prevent such problems. Here, then, is the recommended way to define `ceil_div':

#define ceil_div(x, y) (((x) + (y) - 1) / (y))

Swallowing the Semicolon

Often it is desirable to define a macro that expands into a compound statement. Consider, for example, the following macro, that advances a pointer (the argument `p' says where to find it) across whitespace characters:

#define SKIP_SPACES (p, limit)  \
{ register char *lim = (limit); \
  while (p != lim) {            \
    if (*p++ != ' ') {          \
      p--; break; }}}

Here Backslash-Newline is used to split the macro definition, which must be a single line, so that it resembles the way such C code would be laid out if not part of a macro definition.

A call to this macro might be `SKIP_SPACES (p, lim)'. Strictly speaking, the call expands to a compound statement, which is a complete statement with no need for a semicolon to end it. But it looks like a function call. So it minimizes confusion if you can use it like a function call, writing a semicolon afterward, as in `SKIP_SPACES (p, lim);'

But this can cause trouble before `else' statements, because the semicolon is actually a null statement. Suppose you write

if (*p != 0)
  SKIP_SPACES (p, lim);
else ...

The presence of two statements--the compound statement and a null statement--in between the `if' condition and the `else' makes invalid C code.

The definition of the macro `SKIP_SPACES' can be altered to solve this problem, using a `do ... while' statement. Here is how:

#define SKIP_SPACES (p, limit)     \
do { register char *lim = (limit); \
     while (p != lim) {            \
       if (*p++ != ' ') {          \
         p--; break; }}}           \
while (0)

Now `SKIP_SPACES (p, lim);' expands into

do {...} while (0);

which is one statement.

Duplication of Side Effects

Many C programs define a macro `min', for "minimum", like this:

#define min(X, Y)  ((X) < (Y) ? (X) : (Y))

When you use this macro with an argument containing a side effect, as shown here,

next = min (x + y, foo (z));

it expands as follows:

next = ((x + y) < (foo (z)) ? (x + y) : (foo (z)));

where `x + y' has been substituted for `X' and `foo (z)' for `Y'.

The function `foo' is used only once in the statement as it appears in the program, but the expression `foo (z)' has been substituted twice into the macro expansion. As a result, `foo' might be called two times when the statement is executed. If it has side effects or if it takes a long time to compute, the results might not be what you intended. We say that `min' is an unsafe macro.

The best solution to this problem is to define `min' in a way that computes the value of `foo (z)' only once. The C language offers no standard way to do this, but it can be done with GNU C extensions as follows:

#define min(X, Y)                     \
({ typeof (X) __x = (X), __y = (Y);   \
   (__x < __y) ? __x : __y; })

If you do not wish to use GNU C extensions, the only solution is to be careful when using the macro `min'. For example, you can calculate the value of `foo (z)', save it in a variable, and use that variable in `min':

#define min(X, Y)  ((X) < (Y) ? (X) : (Y))
...
{
  int tem = foo (z);
  next = min (x + y, tem);
}

(where we assume that `foo' returns type `int').

Self-Referential Macros

A self-referential macro is one whose name appears in its definition. A special feature of ANSI Standard C is that the self-reference is not considered a macro call. It is passed into the preprocessor output unchanged.

Let's consider an example:

#define foo (4 + foo)

where `foo' is also a variable in your program.

Following the ordinary rules, each reference to `foo' will expand into `(4 + foo)'; then this will be rescanned and will expand into `(4 + (4 + foo))'; and so on until it causes a fatal error (memory full) in the preprocessor.

However, the special rule about self-reference cuts this process short after one step, at `(4 + foo)'. Therefore, this macro definition has the possibly useful effect of causing the program to add 4 to the value of `foo' wherever `foo' is referred to.

In most cases, it is a bad idea to take advantage of this feature. A person reading the program who sees that `foo' is a variable will not expect that it is a macro as well. The reader will come across the identifier `foo' in the program and think its value should be that of the variable `foo', whereas in fact the value is four greater.

The special rule for self-reference applies also to indirect self-reference. This is the case where a macro x expands to use a macro `y', and the expansion of `y' refers to the macro `x'. The resulting reference to `x' comes indirectly from the expansion of `x', so it is a self-reference and is not further expanded. Thus, after

#define x (4 + y)
#define y (2 * x)

`x' would expand into `(4 + (2 * x))'. Clear?

But suppose `y' is used elsewhere, not from the definition of `x'. Then the use of `x' in the expansion of `y' is not a self-reference because `x' is not "in progress". So it does expand. However, the expansion of `x' contains a reference to `y', and that is an indirect self-reference now because `y' is "in progress". The result is that `y' expands to `(2 * (4 + y))'.

It is not clear that this behavior would ever be useful, but it is specified by the ANSI C standard, so you may need to understand it.

Separate Expansion of Macro Arguments

We have explained that the expansion of a macro, including the substituted actual arguments, is scanned over again for macro calls to be expanded.

What really happens is more subtle: first each actual argument text is scanned separately for macro calls. Then the results of this are substituted into the macro body to produce the macro expansion, and the macro expansion is scanned again for macros to expand.

The result is that the actual arguments are scanned twice to expand macro calls in them.

Most of the time, this has no effect. If the actual argument contained any macro calls, they are expanded during the first scan. The result therefore contains no macro calls, so the second scan does not change it. If the actual argument were substituted as given, with no prescan, the single remaining scan would find the same macro calls and produce the same results.

You might expect the double scan to change the results when a self-referential macro is used in an actual argument of another macro (see section Self-Referential Macros): the self-referential macro would be expanded once in the first scan, and a second time in the second scan. But this is not what happens. The self-references that do not expand in the first scan are marked so that they will not expand in the second scan either.

The prescan is not done when an argument is stringified or concatenated. Thus,

#define str(s) #s
#define foo 4
str (foo)

expands to `"foo"'. Once more, prescan has been prevented from having any noticeable effect.

More precisely, stringification and concatenation use the argument as written, in un-prescanned form. The same actual argument would be used in prescanned form if it is substituted elsewhere without stringification or concatenation.

#define str(s) #s lose(s)
#define foo 4
str (foo)

expands to `"foo" lose(4)'.

You might now ask, "Why mention the prescan, if it makes no difference? And why not skip it and make the preprocessor faster?" The answer is that the prescan does make a difference in three special cases:

  • Nested calls to a macro.
  • Macros that call other macros that stringify or concatenate.
  • Macros whose expansions contain unshielded commas.

We say that nested calls to a macro occur when a macro's actual argument contains a call to that very macro. For example, if `f' is a macro that expects one argument, `f (f (1))' is a nested pair of calls to `f'. The desired expansion is made by expanding `f (1)' and substituting that into the definition of `f'. The prescan causes the expected result to happen. Without the prescan, `f (1)' itself would be substituted as an actual argument, and the inner use of `f' would appear during the main scan as an indirect self-reference and would not be expanded. Here, the prescan cancels an undesirable side effect (in the medical, not computational, sense of the term) of the special rule for self-referential macros.

But prescan causes trouble in certain other cases of nested macro calls. Here is an example:

#define foo  a,b
#define bar(x) lose(x)
#define lose(x) (1 + (x))

bar(foo)

We would like `bar(foo)' to turn into `(1 + (foo))', which would then turn into `(1 + (a,b))'. But instead, `bar(foo)' expands into `lose(a,b)', and you get an error because lose requires a single argument. In this case, the problem is easily solved by the same parentheses that ought to be used to prevent misnesting of arithmetic operations:

#define foo (a,b)
#define bar(x) lose((x))

The problem is more serious when the operands of the macro are not expressions; for example, when they are statements. Then parentheses are unacceptable because they would make for invalid C code:

#define foo { int a, b; ... }

In GNU C you can shield the commas using the `({...})' construct which turns a compound statement into an expression:

#define foo ({ int a, b; ... })

Or you can rewrite the macro definition to avoid such commas:

#define foo { int a; int b; ... }

There is also one case where prescan is useful. It is possible to use prescan to expand an argument and then stringify it--if you use two levels of macros. Let's add a new macro `xstr' to the example shown above:

#define xstr(s) str(s)
#define str(s) #s
#define foo 4
xstr (foo)

This expands into `"4"', not `"foo"'. The reason for the difference is that the argument of `xstr' is expanded at prescan (because `xstr' does not specify stringification or concatenation of the argument). The result of prescan then forms the actual argument for `str'. `str' uses its argument without prescan because it performs stringification; but it cannot prevent or undo the prescanning already done by `xstr'.

Cascaded Use of Macros

A cascade of macros is when one macro's body contains a reference to another macro. This is very common practice. For example,

#define BUFSIZE 1020
#define TABLESIZE BUFSIZE

This is not at all the same as defining `TABLESIZE' to be `1020'. The `#define' for `TABLESIZE' uses exactly the body you specify--in this case, `BUFSIZE'---and does not check to see whether it too is the name of a macro.

It's only when you use `TABLESIZE' that the result of its expansion is checked for more macro names.

This makes a difference if you change the definition of `BUFSIZE' at some point in the source file. `TABLESIZE', defined as shown, will always expand using the definition of `BUFSIZE' that is currently in effect:

#define BUFSIZE 1020
#define TABLESIZE BUFSIZE
#undef BUFSIZE
#define BUFSIZE 37

Now `TABLESIZE' expands (in two stages) to `37'. (The `#undef' is to prevent any warning about the nontrivial redefinition of BUFSIZE.)

Newlines in Macro Arguments

Traditional macro processing carries forward all newlines in macro arguments into the expansion of the macro. This means that, if some of the arguments are substituted more than once, or not at all, or out of order, newlines can be duplicated, lost, or moved around within the expansion. If the expansion consists of multiple statements, then the effect is to distort the line numbers of some of these statements. The result can be incorrect line numbers, in error messages or displayed in a debugger.

The GNU C preprocessor operating in ANSI C mode adjusts appropriately for multiple use of an argument--the first use expands all the newlines, and subsequent uses of the same argument produce no newlines. But even in this mode, it can produce incorrect line numbering if arguments are used out of order, or not used at all.

Here is an example illustrating this problem:

#define ignore_second_arg(a,b,c) a; c

ignore_second_arg (foo (),
                   ignored (),
                   syntax error);

The syntax error triggered by the tokens `syntax error' results in an error message citing line four, even though the statement text comes from line five.

Conditionals

In a macro processor, a conditional is a directive that allows a part of the program to be ignored during compilation, on some conditions. In the C preprocessor, a conditional can test either an arithmetic expression or whether a name is defined as a macro.

A conditional in the C preprocessor resembles in some ways an `if' statement in C, but it is important to understand the difference between them. The condition in an `if' statement is tested during the execution of your program. Its purpose is to allow your program to behave differently from run to run, depending on the data it is operating on. The condition in a preprocessing conditional directive is tested when your program is compiled. Its purpose is to allow different code to be included in the program depending on the situation at the time of compilation.

Why Conditionals are Used

Generally there are three kinds of reason to use a conditional.

  • A program may need to use different code depending on the machine or operating system it is to run on. In some cases the code for one operating system may be erroneous on another operating system; for example, it might refer to library routines that do not exist on the other system. When this happens, it is not enough to avoid executing the invalid code: merely having it in the program makes it impossible to link the program and run it. With a preprocessing conditional, the offending code can be effectively excised from the program when it is not valid.
  • You may want to be able to compile the same source file into two different programs. Sometimes the difference between the programs is that one makes frequent time-consuming consistency checks on its intermediate data, or prints the values of those data for debugging, while the other does not.
  • A conditional whose condition is always false is a good way to exclude code from the program but keep it as a sort of comment for future reference.

Most simple programs that are intended to run on only one machine will not need to use preprocessing conditionals.

Syntax of Conditionals

A conditional in the C preprocessor begins with a conditional directive: `#if', `#ifdef' or `#ifndef'. See section Conditionals and Macros, for information on `#ifdef' and `#ifndef'; only `#if' is explained here.

The `#if' Directive

The `#if' directive in its simplest form consists of

#if expression
controlled text
#endif /* expression */

The comment following the `#endif' is not required, but it is a good practice because it helps people match the `#endif' to the corresponding `#if'. Such comments should always be used, except in short conditionals that are not nested. In fact, you can put anything at all after the `#endif' and it will be ignored by the GNU C preprocessor, but only comments are acceptable in ANSI Standard C.

expression is a C expression of integer type, subject to stringent restrictions. It may contain

  • Integer constants, which are all regarded as long or unsigned long.
  • Character constants, which are interpreted according to the character set and conventions of the machine and operating system on which the preprocessor is running. The GNU C preprocessor uses the C data type `char' for these character constants; therefore, whether some character codes are negative is determined by the C compiler used to compile the preprocessor. If it treats `char' as signed, then character codes large enough to set the sign bit will be considered negative; otherwise, no character code is considered negative.
  • Arithmetic operators for addition, subtraction, multiplication, division, bitwise operations, shifts, comparisons, and logical operations (`&&' and `||').
  • Identifiers that are not macros, which are all treated as zero(!).
  • Macro calls. All macro calls in the expression are expanded before actual computation of the expression's value begins.

Note that `sizeof' operators and enum-type values are not allowed. enum-type values, like all other identifiers that are not taken as macro calls and expanded, are treated as zero.

The controlled text inside of a conditional can include preprocessing directives. Then the directives inside the conditional are obeyed only if that branch of the conditional succeeds. The text can also contain other conditional groups. However, the `#if' and `#endif' directives must balance.

The `#else' Directive

The `#else' directive can be added to a conditional to provide alternative text to be used if the condition is false. This is what it looks like:

#if expression
text-if-true
#else /* Not expression */
text-if-false
#endif /* Not expression */

If expression is nonzero, and thus the text-if-true is active, then `#else' acts like a failing conditional and the text-if-false is ignored. Contrariwise, if the `#if' conditional fails, the text-if-false is considered included.

The `#elif' Directive

One common case of nested conditionals is used to check for more than two possible alternatives. For example, you might have

#if X == 1
...
#else /* X != 1 */
#if X == 2
...
#else /* X != 2 */
...
#endif /* X != 2 */
#endif /* X != 1 */

Another conditional directive, `#elif', allows this to be abbreviated as follows:

#if X == 1
...
#elif X == 2
...
#else /* X != 2 and X != 1*/
...
#endif /* X != 2 and X != 1*/

`#elif' stands for "else if". Like `#else', it goes in the middle of a `#if'-`#endif' pair and subdivides it; it does not require a matching `#endif' of its own. Like `#if', the `#elif' directive includes an expression to be tested.

The text following the `#elif' is processed only if the original `#if'-condition failed and the `#elif' condition succeeds. More than one `#elif' can go in the same `#if'-`#endif' group. Then the text after each `#elif' is processed only if the `#elif' condition succeeds after the original `#if' and any previous `#elif' directives within it have failed. `#else' is equivalent to `#elif 1', and `#else' is allowed after any number of `#elif' directives, but `#elif' may not follow `#else'.

Keeping Deleted Code for Future Reference

If you replace or delete a part of the program but want to keep the old code around as a comment for future reference, the easy way to do this is to put `#if 0' before it and `#endif' after it. This is better than using comment delimiters `/*' and `*/' since those won't work if the code already contains comments (C comments do not nest).

This works even if the code being turned off contains conditionals, but they must be entire conditionals (balanced `#if' and `#endif').

Conversely, do not use `#if 0' for comments which are not C code. Use the comment delimiters `/*' and `*/' instead. The interior of `#if 0' must consist of complete tokens; in particular, singlequote characters must balance. But comments often contain unbalanced singlequote characters (known in English as apostrophes). These confuse `#if 0'. They do not confuse `/*'.

Conditionals and Macros

Conditionals are useful in connection with macros or assertions, because those are the only ways that an expression's value can vary from one compilation to another. A `#if' directive whose expression uses no macros or assertions is equivalent to `#if 1' or `#if 0'; you might as well determine which one, by computing the value of the expression yourself, and then simplify the program.

For example, here is a conditional that tests the expression `BUFSIZE == 1020', where `BUFSIZE' must be a macro.

#if BUFSIZE == 1020
  printf ("Large buffers!\n");
#endif /* BUFSIZE is large */

(Programmers often wish they could test the size of a variable or data type in `#if', but this does not work. The preprocessor does not understand sizeof, or typedef names, or even the type keywords such as int.)

The special operator `defined' is used in `#if' expressions to test whether a certain name is defined as a macro. Either `defined name' or `defined (name)' is an expression whose value is 1 if name is defined as macro at the current point in the program, and 0 otherwise. For the `defined' operator it makes no difference what the definition of the macro is; all that matters is whether there is a definition. Thus, for example,

#if defined (vax) || defined (ns16000)

would succeed if either of the names `vax' and `ns16000' is defined as a macro. You can test the same condition using assertions (see section Assertions), like this:

#if #cpu (vax) || #cpu (ns16000)

If a macro is defined and later undefined with `#undef', subsequent use of the `defined' operator returns 0, because the name is no longer defined. If the macro is defined again with another `#define', `defined' will recommence returning 1.

Conditionals that test whether just one name is defined are very common, so there are two special short conditional directives for this case.

#ifdef name
is equivalent to `#if defined (name)'.
#ifndef name
is equivalent to `#if ! defined (name)'.

Macro definitions can vary between compilations for several reasons.

  • Some macros are predefined on each kind of machine. For example, on a Vax, the name `vax' is a predefined macro. On other machines, it would not be defined.
  • Many more macros are defined by system header files. Different systems and machines define different macros, or give them different values. It is useful to test these macros with conditionals to avoid using a system feature on a machine where it is not implemented.
  • Macros are a common way of allowing users to customize a program for different machines or applications. For example, the macro `BUFSIZE' might be defined in a configuration file for your program that is included as a header file in each source file. You would use `BUFSIZE' in a preprocessing conditional in order to generate different code depending on the chosen configuration.
  • Macros can be defined or undefined with `-D' and `-U' command options when you compile the program. You can arrange to compile the same source file into two different programs by choosing a macro name to specify which program you want, writing conditionals to test whether or how this macro is defined, and then controlling the state of the macro with compiler command options. See section Invoking the C Preprocessor.

Assertions

Assertions are a more systematic alternative to macros in writing conditionals to test what sort of computer or system the compiled program will run on. Assertions are usually predefined, but you can define them with preprocessing directives or command-line options.

The macros traditionally used to describe the type of target are not classified in any way according to which question they answer; they may indicate a hardware architecture, a particular hardware model, an operating system, a particular version of an operating system, or specific configuration options. These are jumbled together in a single namespace. In contrast, each assertion consists of a named question and an answer. The question is usually called the predicate. An assertion looks like this:

#predicate (answer)

You must use a properly formed identifier for predicate. The value of answer can be any sequence of words; all characters are significant except for leading and trailing whitespace, and differences in internal whitespace sequences are ignored. Thus, `x + y' is different from `x+y' but equivalent to `x + y'. `)' is not allowed in an answer.

Here is a conditional to test whether the answer answer is asserted for the predicate predicate:

#if #predicate (answer)

There may be more than one answer asserted for a given predicate. If you omit the answer, you can test whether any answer is asserted for predicate:

#if #predicate

Most of the time, the assertions you test will be predefined assertions. GNU C provides three predefined predicates: system, cpu, and machine. system is for assertions about the type of software, cpu describes the type of computer architecture, and machine gives more information about the computer. For example, on a GNU system, the following assertions would be true:

#system (gnu)
#system (mach)
#system (mach 3)
#system (mach 3.subversion)
#system (hurd)
#system (hurd version)

and perhaps others. The alternatives with more or less version information let you ask more or less detailed questions about the type of system software.

On a Unix system, you would find #system (unix) and perhaps one of: #system (aix), #system (bsd), #system (hpux), #system (lynx), #system (mach), #system (posix), #system (svr3), #system (svr4), or #system (xpg4) with possible version numbers following.

Other values for system are #system (mvs) and #system (vms).

Portability note: Many Unix C compilers provide only one answer for the system assertion: #system (unix), if they support assertions at all. This is less than useful.

An assertion with a multi-word answer is completely different from several assertions with individual single-word answers. For example, the presence of system (mach 3.0) does not mean that system (3.0) is true. It also does not directly imply system (mach), but in GNU C, that last will normally be asserted as well.

The current list of possible assertion values for cpu is: #cpu (a29k), #cpu (alpha), #cpu (arm), #cpu (clipper), #cpu (convex), #cpu (elxsi), #cpu (tron), #cpu (h8300), #cpu (i370), #cpu (i386), #cpu (i860), #cpu (i960), #cpu (m68k), #cpu (m88k), #cpu (mips), #cpu (ns32k), #cpu (hppa), #cpu (pyr), #cpu (ibm032), #cpu (rs6000), #cpu (sh), #cpu (sparc), #cpu (spur), #cpu (tahoe), #cpu (vax), #cpu (we32000).

You can create assertions within a C program using `#assert', like this:

#assert predicate (answer)

(Note the absence of a `#' before predicate.)

Each time you do this, you assert a new true answer for predicate. Asserting one answer does not invalidate previously asserted answers; they all remain true. The only way to remove an assertion is with `#unassert'. `#unassert' has the same syntax as `#assert'. You can also remove all assertions about predicate like this:

#unassert predicate

You can also add or cancel assertions using command options when you run gcc or cpp. See section Invoking the C Preprocessor.

The `#error' and `#warning' Directives

The directive `#error' causes the preprocessor to report a fatal error. The rest of the line that follows `#error' is used as the error message. The line must consist of complete tokens.

You would use `#error' inside of a conditional that detects a combination of parameters which you know the program does not properly support. For example, if you know that the program will not run properly on a Vax, you might write

#ifdef __vax__
#error "Won't work on Vaxen.  See comments at get_last_object."
#endif

See section Nonstandard Predefined Macros, for why this works.

If you have several configuration parameters that must be set up by the installation in a consistent way, you can use conditionals to detect an inconsistency and report it with `#error'. For example,

#if HASH_TABLE_SIZE % 2 == 0 || HASH_TABLE_SIZE % 3 == 0 \
    || HASH_TABLE_SIZE % 5 == 0
#error HASH_TABLE_SIZE should not be divisible by a small prime
#endif

The directive `#warning' is like the directive `#error', but causes the preprocessor to issue a warning and continue preprocessing. The rest of the line that follows `#warning' is used as the warning message.

You might use `#warning' in obsolete header files, with a message directing the user to the header file which should be used instead.

Combining Source Files

One of the jobs of the C preprocessor is to inform the C compiler of where each line of C code came from: which source file and which line number.

C code can come from multiple source files if you use `#include'; both `#include' and the use of conditionals and macros can cause the line number of a line in the preprocessor output to be different from the line's number in the original source file. You will appreciate the value of making both the C compiler (in error messages) and symbolic debuggers such as GDB use the line numbers in your source file.

The C preprocessor builds on this feature by offering a directive by which you can control the feature explicitly. This is useful when a file for input to the C preprocessor is the output from another program such as the bison parser generator, which operates on another file that is the true source file. Parts of the output from bison are generated from scratch, other parts come from a standard parser file. The rest are copied nearly verbatim from the source file, but their line numbers in the bison output are not the same as their original line numbers. Naturally you would like compiler error messages and symbolic debuggers to know the original source file and line number of each line in the bison input.

bison arranges this by writing `#line' directives into the output file. `#line' is a directive that specifies the original line number and source file name for subsequent input in the current preprocessor input file. `#line' has three variants:

#line linenum
Here linenum is a decimal integer constant. This specifies that the line number of the following line of input, in its original source file, was linenum.
#line linenum filename
Here linenum is a decimal integer constant and filename is a string constant. This specifies that the following line of input came originally from source file filename and its line number there was linenum. Keep in mind that filename is not just a file name; it is surrounded by doublequote characters so that it looks like a string constant.
#line anything else
anything else is checked for macro calls, which are expanded. The result should be a decimal integer constant followed optionally by a string constant, as described above.

`#line' directives alter the results of the `__FILE__' and `__LINE__' predefined macros from that point on. See section Standard Predefined Macros.

The output of the preprocessor (which is the input for the rest of the compiler) contains directives that look much like `#line' directives. They start with just `#' instead of `#line', but this is followed by a line number and file name as in `#line'. See section C Preprocessor Output.

Miscellaneous Preprocessing Directives

This section describes three additional preprocessing directives. They are not very useful, but are mentioned for completeness.

The null directive consists of a `#' followed by a Newline, with only whitespace (including comments) in between. A null directive is understood as a preprocessing directive but has no effect on the preprocessor output. The primary significance of the existence of the null directive is that an input line consisting of just a `#' will produce no output, rather than a line of output containing just a `#'. Supposedly some old C programs contain such lines.

The ANSI standard specifies that the effect of the `#pragma' directive is implementation-defined. In the GNU C preprocessor, `#pragma' directives are not used, except for `#pragma once' (see section Once-Only Include Files). However, they are left in the preprocessor output, so they are available to the compilation pass.

The `#ident' directive is supported for compatibility with certain other systems. It is followed by a line of text. On some systems, the text is copied into a special place in the object file; on most systems, the text is ignored and this directive has no effect. Typically `#ident' is only used in header files supplied with those systems where it is meaningful.

C Preprocessor Output

The output from the C preprocessor looks much like the input, except that all preprocessing directive lines have been replaced with blank lines and all comments with spaces. Whitespace within a line is not altered; however, unless `-traditional' is used, spaces may be inserted into the expansions of macro calls to prevent tokens from being concatenated.

Source file name and line number information is conveyed by lines of the form

# linenum filename flags

which are inserted as needed into the middle of the input (but never within a string or character constant). Such a line means that the following line originated in file filename at line linenum.

After the file name comes zero or more flags, which are `1', `2', `3', or `4'. If there are multiple flags, spaces separate them. Here is what the flags mean:

`1'
This indicates the start of a new file.
`2'
This indicates returning to a file (after having included another file).
`3'
This indicates that the following text comes from a system header file, so certain warnings should be suppressed.
`4'
This indicates that the following text should be treated as C.

Invoking the C Preprocessor

Most often when you use the C preprocessor you will not have to invoke it explicitly: the C compiler will do so automatically. However, the preprocessor is sometimes useful on its own.

The C preprocessor expects two file names as arguments, infile and outfile. The preprocessor reads infile together with any other files it specifies with `#include'. All the output generated by the combined input files is written in outfile.

Either infile or outfile may be `-', which as infile means to read from standard input and as outfile means to write to standard output. Also, if outfile or both file names are omitted, the standard output and standard input are used for the omitted file names.

Here is a table of command options accepted by the C preprocessor. These options can also be given when compiling a C program; they are passed along automatically to the preprocessor when it is invoked by the compiler.

`-P'
Inhibit generation of `#'-lines with line-number information in the output from the preprocessor (see section C Preprocessor Output). This might be useful when running the preprocessor on something that is not C code and will be sent to a program which might be confused by the `#'-lines.
`-C'
Do not discard comments: pass them through to the output file. Comments appearing in arguments of a macro call will be copied to the output before the expansion of the macro call.
`-traditional'
Try to imitate the behavior of old-fashioned C, as opposed to ANSI C.
  • Traditional macro expansion pays no attention to singlequote or doublequote characters; macro argument symbols are replaced by the argument values even when they appear within apparent string or character constants.
  • Traditionally, it is permissible for a macro expansion to end in the middle of a string or character constant. The constant continues into the text surrounding the macro call.
  • However, traditionally the end of the line terminates a string or character constant, with no error.
  • In traditional C, a comment is equivalent to no text at all. (In ANSI C, a comment counts as whitespace.)
  • Traditional C does not have the concept of a "preprocessing number". It considers `1.0e+4' to be three tokens: `1.0e', `+', and `4'.
  • A macro is not suppressed within its own definition, in traditional C. Thus, any macro that is used recursively inevitably causes an error.
  • The character `#' has no special meaning within a macro definition in traditional C.
  • In traditional C, the text at the end of a macro expansion can run together with the text after the macro call, to produce a single token. (This is impossible in ANSI C.)
  • Traditionally, `\' inside a macro argument suppresses the syntactic significance of the following character.
`-trigraphs'
Process ANSI standard trigraph sequences. These are three-character sequences, all starting with `??', that are defined by ANSI C to stand for single characters. For example, `??/' stands for `\', so `'??/n'' is a character constant for a newline. Strictly speaking, the GNU C preprocessor does not support all programs in ANSI Standard C unless `-trigraphs' is used, but if you ever notice the difference it will be with relief. You don't want to know any more about trigraphs.
`-pedantic'
Issue warnings required by the ANSI C standard in certain cases such as when text other than a comment follows `#else' or `#endif'.
`-pedantic-errors'
Like `-pedantic', except that errors are produced rather than warnings.
`-Wtrigraphs'
Warn if any trigraphs are encountered (assuming they are enabled).
`-Wcomment'
Warn whenever a comment-start sequence `/*' appears in a `/*' comment, or whenever a Backslash-Newline appears in a `//' comment.
`-Wall'
Requests both `-Wtrigraphs' and `-Wcomment' (but not `-Wtraditional' or `-Wundef').
`-Wtraditional'
Warn about certain constructs that behave differently in traditional and ANSI C.
`-Wundef'
Warn if an undefined identifier is evaluated in an `#if' directive.
`-I directory'
Add the directory directory to the head of the list of directories to be searched for header files (see section The `#include' Directive). This can be used to override a system header file, substituting your own version, since these directories are searched before the system header file directories. If you use more than one `-I' option, the directories are scanned in left-to-right order; the standard system directories come after.
`-I-'
Any directories specified with `-I' options before the `-I-' option are searched only for the case of `#include "file"'; they are not searched for `#include <file>'. If additional directories are specified with `-I' options after the `-I-', these directories are searched for all `#include' directives. In addition, the `-I-' option inhibits the use of the current directory as the first search directory for `#include "file"'. Therefore, the current directory is searched only if it is requested explicitly with `-I.'. Specifying both `-I-' and `-I.' allows you to control precisely which directories are searched before the current one and which are searched after.
`-nostdinc'
Do not search the standard system directories for header files. Only the directories you have specified with `-I' options (and the current directory, if appropriate) are searched.
`-nostdinc++'
Do not search for header files in the C++-specific standard directories, but do still search the other standard directories. (This option is used when building libg++.)
`-remap'
When searching for a header file in a directory, remap file names if a file named `header.gcc' exists in that directory. This can be used to work around limitations of file systems with file name restrictions. The `header.gcc' file should contain a series of lines with two tokens on each line: the first token is the name to map, and the second token is the actual name to use.
`-D name'
Predefine name as a macro, with definition `1'.
`-D name=definition'
Predefine name as a macro, with definition definition. There are no restrictions on the contents of definition, but if you are invoking the preprocessor from a shell or shell-like program you may need to use the shell's quoting syntax to protect characters such as spaces that have a meaning in the shell syntax. If you use more than one `-D' for the same name, the rightmost definition takes effect.
`-U name'
Do not predefine name. If both `-U' and `-D' are specified for one name, the `-U' beats the `-D' and the name is not predefined.
`-undef'
Do not predefine any nonstandard macros.
`-A predicate(answer)'
Make an assertion with the predicate predicate and answer answer. See section Assertions. You can use `-A-' to disable all predefined assertions; it also undefines all predefined macros that identify the type of target system.
`-dM'
Instead of outputting the result of preprocessing, output a list of `#define' directives for all the macros defined during the execution of the preprocessor, including predefined macros. This gives you a way of finding out what is predefined in your version of the preprocessor; assuming you have no file `foo.h', the command
touch foo.h; cpp -dM foo.h
will show the values of any predefined macros.
`-dD'
Like `-dM' except in two respects: it does not include the predefined macros, and it outputs both the `#define' directives and the result of preprocessing. Both kinds of output go to the standard output file.
`-dI'
Output `#include' directives in addition to the result of preprocessing.
`-M [-MG]'
Instead of outputting the result of preprocessing, output a rule suitable for make describing the dependencies of the main source file. The preprocessor outputs one make rule containing the object file name for that source file, a colon, and the names of all the included files. If there are many included files then the rule is split into several lines using `\'-newline. `-MG' says to treat missing header files as generated files and assume they live in the same directory as the source file. It must be specified in addition to `-M'. This feature is used in automatic updating of makefiles.
`-MM [-MG]'
Like `-M' but mention only the files included with `#include "file"'. System header files included with `#include <file>' are omitted.
`-MD file'
Like `-M' but the dependency information is written to file. This is in addition to compiling the file as specified---`-MD' does not inhibit ordinary compilation the way `-M' does. When invoking gcc, do not specify the file argument. Gcc will create file names made by replacing ".c" with ".d" at the end of the input file names. In Mach, you can use the utility md to merge multiple dependency files into a single dependency file suitable for using with the `make' command.
`-MMD file'
Like `-MD' except mention only user header files, not system header files.
`-H'
Print the name of each header file used, in addition to other normal activities.
`-imacros file'
Process file as input, discarding the resulting output, before processing the regular input file. Because the output generated from file is discarded, the only effect of `-imacros file' is to make the macros defined in file available for use in the main input.
`-include file'
Process file as input, and include all the resulting output, before processing the regular input file.
`-idirafter dir'
Add the directory dir to the second include path. The directories on the second include path are searched when a header file is not found in any of the directories in the main include path (the one that `-I' adds to).
`-iprefix prefix'
Specify prefix as the prefix for subsequent `-iwithprefix' options.
`-iwithprefix dir'
Add a directory to the second include path. The directory's name is made by concatenating prefix and dir, where prefix was specified previously with `-iprefix'.
`-isystem dir'
Add a directory to the beginning of the second include path, marking it as a system directory, so that it gets the same special treatment as is applied to the standard system directories.
`-lang-c'
`-lang-c89'
`-lang-c++'
`-lang-objc'
`-lang-objc++'
Specify the source language. `-lang-c' is the default; it allows recognition of C++ comments (comments that begin with `//' and end at end of line) and hexadecimal floating-point constants, since these features will most likely appear in the next C standard. `-lang-c89' disables recognition of C++ comments and hexadecimal floating-point constants. `-lang-c++' handles C++ comment syntax and includes extra default include directories for C++. `-lang-objc' enables the Objective C `#import' directive. `-lang-objc++' enables both C++ and Objective C extensions. These options are generated by the compiler driver gcc, but not passed from the `gcc' command line unless you use the driver's `-Wp' option.
`-lint'
Look for commands to the program checker lint embedded in comments, and emit them preceded by `#pragma lint'. For example, the comment `/* NOTREACHED */' becomes `#pragma lint NOTREACHED'. This option is available only when you call cpp directly; gcc will not pass it from its command line.
`-$'
Forbid the use of `$' in identifiers. This was formerly required for strict conformance to the C Standard before the standard was corrected. This option is available only when you call cpp directly; gcc will not pass it from its command line.


The C Preprocessor - Concept Index

Concept Index

#

  • `##'

    • a

  • arguments in macro definitions
  • assertions
  • assertions, undoing

    • b

  • blank macro arguments

    • c

  • cascaded macros
  • commenting out code
  • computed `#include'
  • concatenation
  • conditionals

    • d

  • directives

    • e

  • expansion of arguments

    • f

  • function-like macro

    • h

  • header file

    • i

  • including just once
  • inheritance
  • invocation of the preprocessor

    • l

  • line control

    • m

  • macro argument expansion
  • macro body uses macro
  • macros with argument
  • manifest constant

    • n

  • newlines in macro arguments
  • null directive

    • o

  • options
  • output format
  • overriding a header file

    • p

  • parentheses in macro bodies
  • pitfalls of macros
  • predefined macros
  • predicates
  • preprocessing directives
  • prescan of macro arguments
  • problems with macros

    • r

  • redefining macros
  • repeated inclusion
  • retracting assertions

    • s

  • second include path
  • self-reference
  • semicolons (after macro calls)
  • side effects (in macro arguments)
  • simple macro
  • space as macro argument
  • standard predefined macros
  • stringification

    • t

  • testing predicates

    • u

  • unassert
  • undefining macros
  • unsafe macros

    • Go to the first, previous, next, last section, table of contents.


The C Preprocessor - Index of Directives, Macros and Options

Index of Directives, Macros and Options

#

  • #assert
  • #cpu
  • #define
  • #elif
  • #else
  • #error
  • #ident
  • #if
  • #ifdef
  • #ifndef
  • #import
  • #include
  • #include_next
  • #line
  • #machine
  • #pragma
  • #pragma once
  • #system
  • #unassert
  • #warning

    • -

  • -$
  • -A
  • -C
  • -D
  • -dD
  • -dI
  • -dM
  • -H
  • -I
  • -idirafter
  • -imacros
  • -include
  • -iprefix
  • -isystem
  • -iwithprefix
  • -lang-c
  • -lang-c++
  • -lang-c89
  • -lang-objc
  • -lang-objc++
  • -M
  • -MD
  • -MM
  • -MMD
  • -nostdinc
  • -nostdinc++
  • -P
  • -pedantic
  • -pedantic-errors
  • -remap
  • -traditional
  • -trigraphs
  • -U
  • -undef
  • -Wall
  • -Wcomment
  • -Wtraditional
  • -Wtrigraphs
  • -Wundef

    • _

  • __BASE_FILE__
  • __CHAR_UNSIGNED__
  • __cplusplus
  • __DATE__
  • __FILE__
  • __GNUC__
  • __GNUC_MINOR__
  • __GNUG__
  • __INCLUDE_LEVEL_
  • __LINE__
  • __OPTIMIZE__
  • __REGISTER_PREFIX__
  • __STDC__
  • __STDC_VERSION__
  • __STRICT_ANSI__
  • __TIME__
  • __USER_LABEL_PREFIX__
  • __VERSION__
  • _AM29000
  • _AM29K

    • b

  • BSD

    • d

  • defined

    • m

  • M68020
  • m68k
  • mc68000

    • n

  • ns32000

    • p

  • pyr

    • s

  • sequent
  • sun
  • system header files

    • u

  • unix

    • v

  • vax

    • Go to the first, previous, next, last section, table of contents.


GASP - What is GASP?

Copyright (C) 1994, 1995 Free Software Foundation, Inc.

Permission is granted to make and distribute verbatim copies of this manual provided the copyright notice and this permission notice are preserved on all copies.

Permission is granted to copy and distribute modified versions of this manual under the conditions for verbatim copying, provided also that the entire resulting derived work is distributed under the terms of a permission notice identical to this one.

Permission is granted to copy and distribute translations of this manual into another language, under the above conditions for modified versions.

What is GASP?

The primary purpose of the GNU assembler is to assemble the output of other programs--notably compilers. When you have to hand-code specialized routines in assembly, that means the GNU assembler is an unfriendly processor: it has no directives for macros, conditionals, or many other conveniences that you might expect.

In some cases you can simply use the C preprocessor, or a generalized preprocessor like M4; but this can be awkward, since none of these things are designed with assembly in mind.

GASP fills this need. It is expressly designed to provide the facilities you need with hand-coded assembly code. Implementing it as a preprocessor, rather than part of the assembler, allows the maximum flexibility: you can use it with hand-coded assembly, without paying a penalty of added complexity in the assembler you use for compiler output.

Here is a small example to give the flavor of GASP. This input to GASP

        .MACRO  saveregs from=8 to=14
count   .ASSIGNA \from
        ! save r\from..r\to
        .AWHILE  \&count LE \to
        mov     r\&count,@-sp
count   .ASSIGNA  \&count + 1
        .AENDW
        .ENDM

        saveregs from=12

bar:    mov     #H'dead+10,r0
foo     .SDATAC "hello"<10>
        .END

generates this assembly program:

        ! save r12..r14
        mov     r12,@-sp
        mov     r13,@-sp
        mov     r14,@-sp

bar:    mov     #57005+10,r0
foo:    .byte   6,104,101,108,108,111,10


GASP - Command Line Options

Command Line Options

The simplest way to use GASP is to run it as a filter and assemble its output. In Unix and its ilk, you can do this, for example:

$ gasp prog.asm | as -o prog.o

Naturally, there are also a few command-line options to allow you to request variations on this basic theme. Here is the full set of possibilities for the GASP command line.

gasp  [ -a | --alternate ]
      [ -c char | --commentchar char ]
      [ -d | --debug ]  [ -h | --help ] [ -M | --mri ]
      [ -o outfile | --output outfile ]
      [ -p | --print ]  [ -s | --copysource ]
      [ -u | --unreasonable ]  [ -v | --version ]
      infile ...
infile ...
The input file names. You must specify at least one input file; if you specify more, GASP preprocesses them all, concatenating the output in the order you list the infile arguments. Mark the end of each input file with the preprocessor command .END. See section Miscellaneous commands.
-a
--alternate
Use alternative macro syntax. See section Alternate macro syntax, for a discussion of how this syntax differs from the default GASP syntax.
-c 'char'
--commentchar 'char'
Use char as the comment character. The default comment character is `!'. For example, to use a semicolon as the comment character, specify `-c ';'' on the GASP command line. Since assembler command characters often have special significance to command shells, it is a good idea to quote or escape char when you specify a comment character. For the sake of simplicity, all examples in this manual use the default comment character `!'.
-d
--debug
Show debugging statistics. In this version of GASP, this option produces statistics about the string buffers that GASP allocates internally. For each defined buffersize s, GASP shows the number of strings n that it allocated, with a line like this:
strings size s : n
GASP displays these statistics on the standard error stream, when done preprocessing.
-h
--help
Display a summary of the GASP command line options.
-M
--mri
Use MRI compatibility mode. Using this option causes GASP to accept the syntax and pseudo-ops used by the Microtec Research ASM68K assembler.
-o outfile
--output outfile
Write the output in a file called outfile. If you do not use the `-o' option, GASP writes its output on the standard output stream.
-p
--print
Print line numbers. GASP obeys this option only if you also specify `-s' to copy source lines to its output. With `-s -p', GASP displays the line number of each source line copied (immediately after the comment character at the beginning of the line).
-s
--copysource
Copy the source lines to the output file. Use this option to see the effect of each preprocessor line on the GASP output. GASP places a comment character (`!' by default) at the beginning of each source line it copies, so that you can use this option and still assemble the result.
-u
--unreasonable
Bypass "unreasonable expansion" limit. Since you can define GASP macros inside other macro definitions, the preprocessor normally includes a sanity check. If your program requires more than 1,000 nested expansions, GASP normally exits with an error message. Use this option to turn off this check, allowing unlimited nested expansions.
-v
--version
Display the GASP version number.


GASP - Preprocessor Commands

Preprocessor Commands

GASP commands have a straightforward syntax that fits in well with assembly conventions. In general, a command extends for a line, and may have up to three fields: an optional label, the command itself, and optional arguments to the command. You can write commands in upper or lower case, though this manual shows them in upper case. See section Details of the GASP syntax, for more information.

Conditional assembly

The conditional-assembly directives allow you to include or exclude portions of an assembly depending on how a pair of expressions, or a pair of strings, compare.

The overall structure of conditionals is familiar from many other contexts. .AIF marks the start of a conditional, and precedes assembly for the case when the condition is true. An optional .AELSE precedes assembly for the converse case, and an .AENDI marks the end of the condition.

You may nest conditionals up to a depth of 100; GASP rejects nesting beyond that, because it may indicate a bug in your macro structure.

Conditionals are primarily useful inside macro definitions, where you often need different effects depending on argument values. See section Defining your own directives, for details about defining macros.

.AIF expra cmp exprb
.AIF "stra" cmp "strb"
The governing condition goes on the same line as the .AIF preprocessor command. You may compare either two strings, or two expressions. When you compare strings, only two conditional cmp comparison operators are available: `EQ' (true if stra and strb are identical), and `NE' (the opposite). When you compare two expressions, both expressions must be absolute (see section Arithmetic expressions in GASP). You can use these cmp comparison operators with expressions:
EQ
Are expra and exprb equal? (For strings, are stra and strb identical?)
NE
Are expra and exprb different? (For strings, are stra and strb different?
LT
Is expra less than exprb? (Not allowed for strings.)
LE
Is expra less than or equal to exprb? (Not allowed for strings.)
GT
Is expra greater than exprb? (Not allowed for strings.)
GE
Is expra greater than or equal to exprb? (Not allowed for strings.)
.AELSE
Marks the start of assembly code to be included if the condition fails. Optional, and only allowed within a conditional (between .AIF and .AENDI).
.AENDI
Marks the end of a conditional assembly.

Repetitive sections of assembly

Two preprocessor directives allow you to repeatedly issue copies of the same block of assembly code.

.AREPEAT aexp
.AENDR
If you simply need to repeat the same block of assembly over and over a fixed number of times, sandwich one instance of the repeated block between .AREPEAT and .AENDR. Specify the number of copies as aexp (which must be an absolute expression). For example, this repeats two assembly statements three times in succession:
        .AREPEAT        3
        rotcl   r2
        div1    r0,r1
        .AENDR
.AWHILE expra cmp exprb
.AENDW
.AWHILE stra cmp strb
.AENDW
To repeat a block of assembly depending on a conditional test, rather than repeating it for a specific number of times, use .AWHILE. .AENDW marks the end of the repeated block. The conditional comparison works exactly the same way as for .AIF, with the same comparison operators (see section Conditional assembly). Since the terms of the comparison must be absolute expression, .AWHILE is primarily useful within macros. See section Defining your own directives.

You can use the .EXITM preprocessor directive to break out of loops early (as well as to break out of macros). See section Defining your own directives.

Preprocessor variables

You can use variables in GASP to represent strings, registers, or the results of expressions.

You must distinguish two kinds of variables:

  1. Variables defined with .EQU or .ASSIGN. To evaluate this kind of variable in your assembly output, simply mention its name. For example, these two lines define and use a variable `eg':
    eg     .EQU   FLIP-64
       ...
       mov.l  eg,r0
    Do not use this kind of variable in conditional expressions or while loops; GASP only evaluates these variables when writing assembly output.
  2. Variables for use during preprocessing. You can define these with .ASSIGNC or .ASSIGNA. To evaluate this kind of variable, write `\&' before the variable name; for example,
    opcit  .ASSIGNA  47
       ...
       .AWHILE  \&opcit GT 0
       ...
       .AENDW
    GASP treats macro arguments almost the same way, but to evaluate them you use the prefix `\' rather than `\&'. See section Defining your own directives.
pvar .EQU expr
Assign preprocessor variable pvar the value of the expression expr. There are no restrictions on redefinition; use `.EQU' with the same pvar as often as you find it convenient.
pvar .ASSIGN expr
Almost the same as .EQU, save that you may not redefine pvar using .ASSIGN once it has a value.
pvar .ASSIGNA aexpr
Define a variable with a numeric value, for use during preprocessing. aexpr must be an absolute expression. You can redefine variables with .ASSIGNA at any time.
pvar .ASSIGNC "str"
Define a variable with a string value, for use during preprocessing. You can redefine variables with .ASSIGNC at any time.
pvar .REG (register)
Use .REG to define a variable that represents a register. In particular, register is not evaluated as an expression. You may use .REG at will to redefine register variables.

All these directives accept the variable name in the "label" position, that is at the left margin. You may specify a colon after the variable name if you wish; the first example above could have started `eg:' with the same effect.

Defining your own directives

The commands .MACRO and .ENDM allow you to define macros that generate assembly output. You can use these macros with a syntax similar to built-in GASP or assembler directives. For example, this definition specifies a macro SUM that adds together a range of consecutive registers:

        .MACRO  SUM FROM=0, TO=9
        ! \FROM \TO
        mov     r\FROM,r10
COUNT   .ASSIGNA        \FROM+1
        .AWHILE \&COUNT LE \TO
        add     r\&COUNT,r10
COUNT   .ASSIGNA        \&COUNT+1
        .AENDW
        .ENDM

With that definition, `SUM 0,5' generates this assembly output:

        ! 0 5
        mov     r0,r10
        add     r1,r10
        add     r2,r10
        add     r3,r10
        add     r4,r10
        add     r5,r10
.MACRO macname
.MACRO macname macargs ...
Begin the definition of a macro called macname. If your macro definition requires arguments, specify their names after the macro name, separated by commas or spaces. You can supply a default value for any macro argument by following the name with `=deflt'. For example, these are all valid .MACRO statements:
.MACRO COMM
Begin the definition of a macro called COMM, which takes no arguments.
.MACRO PLUS1 P, P1
.MACRO PLUS1 P P1
Either statement begins the definition of a macro called PLUS1, which takes two arguments; within the macro definition, write `\P' or `\P1' to evaluate the arguments.
.MACRO RESERVE_STR P1=0 P2
Begin the definition of a macro called RESERVE_STR, with two arguments. The first argument has a default value, but not the second. After the definition is complete, you can call the macro either as `RESERVE_STR a,b' (with `\P1' evaluating to a and `\P2' evaluating to b), or as `RESERVE_STR ,b' (with `\P1' evaluating as the default, in this case `0', and `\P2' evaluating to b).
When you call a macro, you can specify the argument values either by position, or by keyword. For example, `SUM 9,17' is equivalent to `SUM TO=17, FROM=9'. Macro arguments are preprocessor variables similar to the variables you define with `.ASSIGNA' or `.ASSIGNC'; in particular, you can use them in conditionals or for loop control. (The only difference is the prefix you write to evaluate the variable: for a macro argument, write `\argname', but for a preprocessor variable, write `\&varname'.)
name .MACRO
name .MACRO ( macargs ... )
An alternative form of introducing a macro definition: specify the macro name in the label position, and the arguments (if any) between parentheses after the name. Defaulting rules and usage work the same way as for the other macro definition syntax.
.ENDM
Mark the end of a macro definition.
.EXITM
Exit early from the current macro definition, .AREPEAT loop, or .AWHILE loop.
\@
GASP maintains a counter of how many macros it has executed in this pseudo-variable; you can copy that number to your output with `\@', but only within a macro definition.
LOCAL name [ , ... ]
Warning: LOCAL is only available if you select "alternate macro syntax" with `-a' or `--alternate'. See section Alternate macro syntax. Generate a string replacement for each of the name arguments, and replace any instances of name in each macro expansion. The replacement string is unique in the assembly, and different for each separate macro expansion. LOCAL allows you to write macros that define symbols, without fear of conflict between separate macro expansions.

Data output

In assembly code, you often need to specify working areas of memory; depending on the application, you may want to initialize such memory or not. GASP provides preprocessor directives to help you avoid repetitive coding for both purposes.

You can use labels as usual to mark the data areas.

Initialized data

These are the GASP directives for initialized data, and the standard GNU assembler directives they expand to:

.DATA expr, expr, ...
.DATA.B expr, expr, ...
.DATA.W expr, expr, ...
.DATA.L expr, expr, ...
Evaluate arithmetic expressions expr, and emit the corresponding as directive (labelled with lab). The unqualified .DATA emits `.long'; .DATA.B emits `.byte'; .DATA.W emits `.short'; and .DATA.L emits `.long'. For example, `foo .DATA 1,2,3' emits `foo: .long 1,2,3'.
.DATAB repeat, expr
.DATAB.B repeat, expr
.DATAB.W repeat, expr
.DATAB.L repeat, expr
Make as emit repeat copies of the value of the expression expr (using the as directive .fill). `.DATAB.B' repeats one-byte values; `.DATAB.W' repeats two-byte values; and `.DATAB.L' repeats four-byte values. `.DATAB' without a suffix repeats four-byte values, just like `.DATAB.L'. repeat must be an absolute expression with a positive value.
.SDATA "str" ...
String data. Emits a concatenation of bytes, precisely as you specify them (in particular, nothing is added to mark the end of the string). See section String and numeric constants, for details about how to write strings. .SDATA concatenates multiple arguments, making it easy to switch between string representations. You can use commas to separate the individual arguments for clarity, if you choose.
.SDATAB repeat, "str" ...
Repeated string data. The first argument specifies how many copies of the string to emit; the remaining arguments specify the string, in the same way as the arguments to .SDATA.
.SDATAZ "str" ...
Zero-terminated string data. Just like .SDATA, except that .SDATAZ writes a zero byte at the end of the string.
.SDATAC "str" ...
Count-prefixed string data. Just like .SDATA, except that GASP precedes the string with a leading one-byte count. For example, `.SDATAC "HI"' generates `.byte 2,72,73'. Since the count field is only one byte, you can only use .SDATAC for strings less than 256 bytes in length.

Uninitialized data

Use the .RES, .SRES, .SRESC, and .SRESZ directives to reserve memory and leave it uninitialized. GASP resolves these directives to appropriate calls of the GNU as .space directive.

.RES count
.RES.B count
.RES.W count
.RES.L count
Reserve room for count uninitialized elements of data. The suffix specifies the size of each element: .RES.B reserves count bytes, .RES.W reserves count pairs of bytes, and .RES.L reserves count quartets. .RES without a suffix is equivalent to .RES.L.
.SRES count
.SRES.B count
.SRES.W count
.SRES.L count
.SRES is a synonym for `.RES'.
.SRESC count
.SRESC.B count
.SRESC.W count
.SRESC.L count
Like .SRES, but reserves space for count+1 elements.
.SRESZ count
.SRESZ.B count
.SRESZ.W count
.SRESZ.L count
Like .SRES, but reserves space for count+1 elements.

Assembly listing control

The GASP listing-control directives correspond to related GNU as directives.

.PRINT LIST
.PRINT NOLIST
Print control. This directive emits the GNU as directive .list or .nolist, according to its argument. See section `.list' in Using as, for details on how these directives interact.
.FORM LIN=ln
.FORM COL=cols
.FORM LIN=ln COL=cols
Specify the page size for assembly listings: ln represents the number of lines, and cols the number of columns. You may specify either page dimension independently, or both together. If you do not specify the number of lines, GASP assumes 60 lines; if you do not specify the number of columns, GASP assumes 132 columns. (Any values you may have specified in previous instances of .FORM do not carry over as defaults.) Emits the .psize assembler directive.
.HEADING string
Specify string as the title of your assembly listings. Emits `.title "string"'.
.PAGE
Force a new page in assembly listings. Emits `.eject'.

Miscellaneous commands

.ALTERNATE
Use the alternate macro syntax henceforth in the assembly. See section Alternate macro syntax.
.ORG
This command is recognized, but not yet implemented. GASP generates an error message for programs that use .ORG.
.RADIX s
GASP understands numbers in any of base two, eight, ten, or sixteen. You can encode the base explicitly in any numeric constant (see section String and numeric constants). If you write numbers without an explicit indication of the base, the most recent `.RADIX s' command determines how they are interpreted. s is a single letter, one of the following:
.RADIX B
Base 2.
.RADIX Q
Base 8.
.RADIX D
Base 10. This is the original default radix.
.RADIX H
Base 16.
You may specify the argument s in lower case (any of `bqdh') with the same effects.
.EXPORT name
.GLOBAL name
Declare name global (emits `.global name'). The two directives are synonymous.
.PROGRAM
No effect: GASP accepts this directive, and silently ignores it.
.END
Mark end of each preprocessor file. GASP issues a warning if it reaches end of file without seeing this command.
.INCLUDE "str"
Preprocess the file named by str, as if its contents appeared where the .INCLUDE directive does. GASP imposes a maximum limit of 30 stacked include files, as a sanity check.
.ALIGN size
Evaluate the absolute expression size, and emit the assembly instruction `.align size' using the result.

Details of the GASP syntax

Since GASP is meant to work with assembly code, its statement syntax has no surprises for the assembly programmer.

Whitespace (blanks or tabs; not newline) is partially significant, in that it delimits up to three fields in a line. The amount of whitespace does not matter; you may line up fields in separate lines if you wish, but GASP does not require that.

The first field, an optional label, must be flush left in a line (with no leading whitespace) if it appears at all. You may use a colon after the label if you wish; GASP neither requires the colon nor objects to it (but will not include it as part of the label name).

The second field, which must appear after some whitespace, contains a GASP or assembly directive.

Any further fields on a line are arguments to the directive; you can separate them from one another using either commas or whitespace.

Special syntactic markers

GASP recognizes a few special markers: to delimit comments, to continue a statement on the next line, to separate symbols from other characters, and to copy text to the output literally. (One other special marker, `\@', works only within macro definitions; see section Defining your own directives.)

The trailing part of any GASP source line may be a comment. A comment begins with the first unquoted comment character (`!' by default), or an escaped or doubled comment character (`\!' or `!!' by default), and extends to the end of a line. You can specify what comment character to use with the `-c' option (see section Command Line Options). The two kinds of comment markers lead to slightly different treatment:

!
A single, un-escaped comment character generates an assembly comment in the GASP output. GASP evaluates any preprocessor variables (macro arguments, or variables defined with .ASSIGNA or .ASSIGNC) present. For example, a macro that begins like this
        .MACRO  SUM FROM=0, TO=9
        ! \FROM \TO
issues as the first line of output a comment that records the values you used to call the macro.
\!
!!
Either an escaped comment character, or a double comment character, marks a GASP source comment. GASP does not copy such comments to the assembly output.

To continue a statement on the next line of the file, begin the second line with the character `+'.

Occasionally you may want to prevent GASP from preprocessing some particular bit of text. To copy literally from the GASP source to its output, place `\(' before the string to copy, and `)' at the end. For example, write `\(\!)' if you need the characters `\!' in your assembly output.

To separate a preprocessor variable from text to appear immediately after its value, write a single quote ('). For example, `.SDATA "\P'1"' writes a string built by concatenating the value of P and the digit `1'. (You cannot achieve this by writing just `\P1', since `P1' is itself a valid name for a preprocessor variable.)

String and numeric constants

There are two ways of writing string constants in GASP: as literal text, and by numeric byte value. Specify a string literal between double quotes ("str"). Specify an individual numeric byte value as an absolute expression between angle brackets (<expr>. Directives that output strings allow you to specify any number of either kind of value, in whatever order is convenient, and concatenate the result. (Alternate syntax mode introduces a number of alternative string notations; see section Alternate macro syntax.)

You can write numeric constants either in a specific base, or in whatever base is currently selected (either 10, or selected by the most recent .RADIX).

To write a number in a specific base, use the pattern s'ddd: a base specifier character s, followed by a single quote followed by digits ddd. The base specifier character matches those you can specify with .RADIX: `B' for base 2, `Q' for base 8, `D' for base 10, and `H' for base 16. (You can write this character in lower case if you prefer.)

Symbols

GASP recognizes symbol names that start with any alphabetic character, `_', or `$', and continue with any of the same characters or with digits. Label names follow the same rules.

Arithmetic expressions in GASP

There are two kinds of expressions, depending on their result: absolute expressions, which resolve to a constant (that is, they do not involve any values unknown to GASP), and relocatable expressions, which must reduce to the form

addsym+const-subsym

where addsym and subsym are assembly symbols of unknown value, and const is a constant.

Arithmetic for GASP expressions follows very similar rules to C. You can use parentheses to change precedence; otherwise, arithmetic primitives have decreasing precedence in the order of the following list.

  1. Single-argument + (identity), - (arithmetic opposite), or ~ (bitwise negation). The argument must be an absolute expression.
  2. * (multiplication) and / (division). Both arguments must be absolute expressions.
  3. + (addition) and - (subtraction). At least one argument must be absolute.
  4. & (bitwise and). Both arguments must be absolute.
  5. | (bitwise or) and ~ (bitwise exclusive or; ^ in C). Both arguments must be absolute.

String primitives

You can use these primitives to manipulate strings (in the argument field of GASP statements):

.LEN("str")
Calculate the length of string "str", as an absolute expression. For example, `.RES.B .LEN("sample")' reserves six bytes of memory.
.INSTR("string", "seg", ix)
Search for the first occurrence of seg after position ix of string. For example, `.INSTR("ABCDEFG", "CDE", 0)' evaluates to the absolute result 2. The result is -1 if seg does not occur in string after position ix.
.SUBSTR("string",start,len)
The substring of string beginning at byte number start and extending for len bytes.

Alternate macro syntax

If you specify `-a' or `--alternate' on the GASP command line, the preprocessor uses somewhat different syntax. This syntax is reminiscent of the syntax of Phar Lap macro assembler, but it is not meant to be a full emulation of Phar Lap or similar assemblers. In particular, GASP does not support directives such as DB and IRP, even in alternate syntax mode.

In particular, `-a' (or `--alternate') elicits these differences:

Preprocessor directives
You can use GASP preprocessor directives without a leading `.' dot. For example, you can write `SDATA' with the same effect as `.SDATA'.
LOCAL
One additional directive, LOCAL, is available. See section Defining your own directives, for an explanation of how to use LOCAL.
String delimiters
You can write strings delimited in these other ways besides "string":
'string'
You can delimit strings with single-quote charaters.
<string>
You can delimit strings with matching angle brackets.
single-character string escape
To include any single character literally in a string (even if the character would otherwise have some special meaning), you can prefix the character with `!' (an exclamation mark). For example, you can write `<4.3 !> 5.4!!>' to get the literal text `4.3 > 5.4!'.
Expression results as strings
You can write `%expr' to evaluate the expression expr and use the result as a string.


GASP - Index

Index

!

  • ! default comment char

    • +

  • +

    • -

  • --alternate
  • --commentchar 'char'
  • --copysource
  • --debug
  • --help
  • --mri
  • --output outfile
  • --print
  • --unreasonable
  • --version
  • -a
  • -c 'char'
  • -d
  • -h
  • -M
  • -o outfile
  • -p
  • -s
  • -u
  • -v

    • .

  • .AELSE
  • .AENDI
  • .AENDR
  • .AENDW, .AENDW
  • .AIF "stra" cmp "strb"
  • .AIF expra cmp exprb
  • .ALIGN size
  • .ALTERNATE
  • .AREPEAT aexp
  • .AWHILE expra cmp exprb
  • .AWHILE stra cmp strb
  • .DATA expr, expr, ...
  • .DATA.B expr, expr, ...
  • .DATA.L expr, expr, ...
  • .DATA.W expr, expr, ...
  • .DATAB repeat, expr
  • .DATAB.B repeat, expr
  • .DATAB.L repeat, expr
  • .DATAB.W repeat, expr
  • .END
  • .ENDM
  • .EXITM
  • .EXPORT name
  • .FORM COL=cols
  • .FORM LIN=ln
  • .FORM LIN=ln COL=cols
  • .GLOBAL name
  • .HEADING string
  • .INCLUDE "str"
  • .INSTR("string", "seg", ix)
  • .LEN("str")
  • .MACRO macname
  • .MACRO macname macargs ...
  • .ORG
  • .PAGE
  • .PRINT LIST
  • .PRINT NOLIST
  • .PROGRAM
  • .RADIX s
  • .RES count
  • .RES.B count
  • .RES.L count
  • .RES.W count
  • .SDATA "str" ...
  • .SDATAB repeat, "str" ...
  • .SDATAC "str" ...
  • .SDATAZ "str" ...
  • .SRES count
  • .SRES.B count
  • .SRES.L count
  • .SRES.W count
  • .SRESC count
  • .SRESC.B count
  • .SRESC.L count
  • .SRESC.W count
  • .SRESZ count
  • .SRESZ.B count
  • .SRESZ.L count
  • .SRESZ.W count
  • .SUBSTR("string",start,len)

    • ;

  • ; as comment char

    • \

  • \@

    • a

  • absolute expressions
  • argument fields
  • avoiding preprocessing

    • b

  • bang, as comment
  • breaking out of loops

    • c

  • comment character, changing
  • comments
  • continuation character
  • copying literally to output

    • d

  • directive field

    • e

  • EQ
  • exclamation mark, as comment

    • f

  • fields of GASP source line

    • g

  • GE
  • GT

    • i

  • infile ...

    • l

  • label field
  • LE
  • literal copy to output
  • LOCAL name [ , ... ]
  • loops, breaking out of
  • LT

    • m

  • macros, count executed

    • n

  • name .MACRO
  • name .MACRO ( macargs ... )
  • NE
  • number of macros executed

    • p

  • preprocessing, avoiding
  • pvar .ASSIGN expr
  • pvar .ASSIGNA aexpr
  • pvar .ASSIGNC "str"
  • pvar .EQU expr
  • pvar .REG (register)

    • r

  • relocatable expressions

    • s

  • semicolon, as comment
  • shriek, as comment
  • symbol separator
  • symbols, separating from text

    • t

  • text, separating from symbols

    • w

  • whitespace

    • Go to the first, previous, next, last section, table of contents.


Using and Porting GNU CC - G++ and GCC

>\input texinfo

Using and Porting GNU CC

Richard M. Stallman

Last updated 26 November 1995

for egcs-1.0.2 Copyright (C) 1988, 89, 92, 93, 94, 95, 96 Free Software Foundation, Inc.

For EGCS Version 1.0

Published by the Free Software Foundation
59 Temple Place - Suite 330
Boston, MA 02111-1307, USA
Last printed November, 1995.
Printed copies are available for $50 each.
ISBN 1-882114-36-1

Permission is granted to make and distribute verbatim copies of this manual provided the copyright notice and this permission notice are preserved on all copies.

Permission is granted to copy and distribute modified versions of this manual under the conditions for verbatim copying, provided also that the sections entitled "GNU General Public License," "Funding for Free Software," and "Protect Your Freedom--Fight `Look And Feel'" are included exactly as in the original, and provided that the entire resulting derived work is distributed under the terms of a permission notice identical to this one.

Permission is granted to copy and distribute translations of this manual into another language, under the above conditions for modified versions, except that the sections entitled "GNU General Public License," "Funding for Free Software," and "Protect Your Freedom--Fight `Look And Feel'", and this permission notice, may be included in translations approved by the Free Software Foundation instead of in the original English.

Compile C, C++, or Objective C

The C, C++, and Objective C versions of the compiler are integrated; the GNU C compiler can compile programs written in C, C++, or Objective C.

"GCC" is a common shorthand term for the GNU C compiler. This is both the most general name for the compiler, and the name used when the emphasis is on compiling C programs.

When referring to C++ compilation, it is usual to call the compiler "G++". Since there is only one compiler, it is also accurate to call it "GCC" no matter what the language context; however, the term "G++" is more useful when the emphasis is on compiling C++ programs.

We use the name "GNU CC" to refer to the compilation system as a whole, and more specifically to the language-independent part of the compiler. For example, we refer to the optimization options as affecting the behavior of "GNU CC" or sometimes just "the compiler".

Front ends for other languages, such as Ada 9X, Fortran, Modula-3, and Pascal, are under development. These front-ends, like that for C++, are built in subdirectories of GNU CC and link to it. The result is an integrated compiler that can compile programs written in C, C++, Objective C, or any of the languages for which you have installed front ends.

In this manual, we only discuss the options for the C, Objective-C, and C++ compilers and those of the GNU CC core. Consult the documentation of the other front ends for the options to use when compiling programs written in other languages.

G++ is a compiler, not merely a preprocessor. G++ builds object code directly from your C++ program source. There is no intermediate C version of the program. (By contrast, for example, some other implementations use a program that generates a C program from your C++ source.) Avoiding an intermediate C representation of the program means that you get better object code, and better debugging information. The GNU debugger, GDB, works with this information in the object code to give you comprehensive C++ source-level editing capabilities (see section `C and C++' in Debugging with GDB).


Using and Porting GNU CC - Invoking GCC

GNU CC Command Options

When you invoke GNU CC, it normally does preprocessing, compilation, assembly and linking. The "overall options" allow you to stop this process at an intermediate stage. For example, the `-c' option says not to run the linker. Then the output consists of object files output by the assembler.

Other options are passed on to one stage of processing. Some options control the preprocessor and others the compiler itself. Yet other options control the assembler and linker; most of these are not documented here, since you rarely need to use any of them.

Most of the command line options that you can use with GNU CC are useful for C programs; when an option is only useful with another language (usually C++), the explanation says so explicitly. If the description for a particular option does not mention a source language, you can use that option with all supported languages.

See section Compiling C++ Programs, for a summary of special options for compiling C++ programs.

The gcc program accepts options and file names as operands. Many options have multiletter names; therefore multiple single-letter options may not be grouped: `-dr' is very different from `-d -r'.

You can mix options and other arguments. For the most part, the order you use doesn't matter. Order does matter when you use several options of the same kind; for example, if you specify `-L' more than once, the directories are searched in the order specified.

Many options have long names starting with `-f' or with `-W'---for example, `-fforce-mem', `-fstrength-reduce', `-Wformat' and so on. Most of these have both positive and negative forms; the negative form of `-ffoo' would be `-fno-foo'. This manual documents only one of these two forms, whichever one is not the default.


Using and Porting GNU CC - Option Summary

Option Summary

Here is a summary of all the options, grouped by type. Explanations are in the following sections.

Overall Options
See section Options Controlling the Kind of Output.
-c  -S  -E  -o file  -pipe  -v  -x language
C Language Options
See section Options Controlling C Dialect.
-ansi  -fallow-single-precision  -fcond-mismatch  -fno-asm
-fno-builtin  -ffreestanding  -fhosted  -fsigned-bitfields  -fsigned-char
-funsigned-bitfields  -funsigned-char  -fwritable-strings
-traditional  -traditional-cpp  -trigraphs
C++ Language Options
See section Options Controlling C++ Dialect.
-fall-virtual  -fdollars-in-identifiers  -felide-constructors
-fenum-int-equiv  -fexternal-templates  -ffor-scope  -fno-for-scope
-fhandle-signatures  -fmemoize-lookups  -fname-mangling-version-n
-fno-default-inline  -fno-gnu-keywords -fnonnull-objects -fguiding-decls
-foperator-names  -fstrict-prototype  -fthis-is-variable
-ftemplate-depth-n  -nostdinc++  -traditional  +en
Warning Options
See section Options to Request or Suppress Warnings.
-fsyntax-only  -pedantic  -pedantic-errors
-w  -W  -Wall  -Waggregate-return  -Wbad-function-cast
-Wcast-align  -Wcast-qual  -Wchar-subscript  -Wcomment
-Wconversion  -Werror  -Wformat
-Wid-clash-len  -Wimplicit  -Wimport  -Winline
-Wlarger-than-len  -Wmain  -Wmissing-declarations
-Wmissing-prototypes  -Wnested-externs
-Wno-import  -Wold-style-cast  -Woverloaded-virtual  -Wparentheses
-Wpointer-arith  -Wredundant-decls  -Wreorder  -Wreturn-type  -Wshadow
-Wsign-compare  -Wstrict-prototypes  -Wswitch  -Wsynth
-Wtemplate-debugging  -Wtraditional  -Wtrigraphs
-Wundef  -Wuninitialized  -Wunused  -Wwrite-strings
Debugging Options
See section Options for Debugging Your Program or GNU CC.
-a  -ax  -dletters  -fpretend-float
-fprofile-arcs  -ftest-coverage
-g  -glevel  -gcoff  -gdwarf  -gdwarf-1  -gdwarf-1+  -gdwarf-2
-ggdb  -gstabs  -gstabs+  -gxcoff  -gxcoff+
-p  -pg  -print-file-name=library  -print-libgcc-file-name
-print-prog-name=program  -print-search-dirs  -save-temps
Optimization Options
See section Options That Control Optimization.
-fbranch-probabilities
-fcaller-saves  -fcse-follow-jumps  -fcse-skip-blocks
-fdelayed-branch   -fexpensive-optimizations
-ffast-math  -ffloat-store  -fforce-addr  -fforce-mem
-ffunction-sections  -finline-functions
-fkeep-inline-functions  -fno-default-inline
-fno-defer-pop  -fno-function-cse
-fno-inline  -fno-peephole  -fomit-frame-pointer -fregmove
-frerun-cse-after-loop  -frerun-loop-opt -fschedule-insns
-fschedule-insns2  -fstrength-reduce  -fthread-jumps
-funroll-all-loops  -funroll-loops
-fmove-all-movables  -freduce-all-givs
-O  -O0  -O1  -O2  -O3
Preprocessor Options
See section Options Controlling the Preprocessor.
-Aquestion(answer)  -C  -dD  -dM  -dN
-Dmacro[=defn]  -E  -H
-idirafter dir
-include file  -imacros file
-iprefix file  -iwithprefix dir
-iwithprefixbefore dir  -isystem dir
-M  -MD  -MM  -MMD  -MG  -nostdinc  -P  -trigraphs
-undef  -Umacro  -Wp,option
Assembler Option
See section Passing Options to the Assembler.
-Wa,option
Linker Options
See section Options for Linking.
object-file-name  -llibrary
-nostartfiles  -nodefaultlibs  -nostdlib
-s  -static  -shared  -symbolic
-Wl,option  -Xlinker option
-u symbol
Directory Options
See section Options for Directory Search.
-Bprefix  -Idir  -I-  -Ldir  -specs=file
Target Options
See section Specifying Target Machine and Compiler Version.
-b machine  -V version
Machine Dependent Options
See section Hardware Models and Configurations.
M680x0 Options
-m68000  -m68020  -m68020-40  -m68020-60  -m68030  -m68040
-m68060  -m5200  -m68881  -mbitfield  -mc68000  -mc68020  -mfpa
-mnobitfield  -mrtd  -mshort  -msoft-float  -malign-int

VAX Options
-mg  -mgnu  -munix

SPARC Options
-mcpu=cpu type
-mtune=cpu type
-mcmodel=code model
-malign-jumps=num  -malign-loops=num
-malign-functions=num
-m32  -m64
-mapp-regs  -mbroken-saverestore  -mcypress  -mepilogue
-mflat  -mfpu  -mhard-float  -mhard-quad-float
-mimpure-text  -mlive-g0  -mno-app-regs  -mno-epilogue
-mno-flat  -mno-fpu  -mno-impure-text
-mno-stack-bias  -mno-unaligned-doubles
-msoft-float  -msoft-quad-float  -msparclite  -mstack-bias
-msupersparc  -munaligned-doubles  -mv8

Convex Options
-mc1  -mc2  -mc32  -mc34  -mc38
-margcount  -mnoargcount
-mlong32  -mlong64
-mvolatile-cache  -mvolatile-nocache

AMD29K Options
-m29000  -m29050  -mbw  -mnbw  -mdw  -mndw
-mlarge  -mnormal  -msmall
-mkernel-registers  -mno-reuse-arg-regs
-mno-stack-check  -mno-storem-bug
-mreuse-arg-regs  -msoft-float  -mstack-check
-mstorem-bug  -muser-registers

ARM Options
-mapcs-frame  -mapcs-26  -mapcs-32
-mlittle-endian  -mbig-endian  -mwords-little-endian
-mshort-load-bytes  -mno-short-load-bytes
-msoft-float  -mhard-float
-mbsd  -mxopen  -mno-symrename

MN10300 Options
-mmult-bug
-mno-mult-bug

M32R/D Options
-mcode-model=model type  -msdata=sdata type
-G num

M88K Options
-m88000  -m88100  -m88110  -mbig-pic
-mcheck-zero-division  -mhandle-large-shift
-midentify-revision  -mno-check-zero-division
-mno-ocs-debug-info  -mno-ocs-frame-position
-mno-optimize-arg-area  -mno-serialize-volatile
-mno-underscores  -mocs-debug-info
-mocs-frame-position  -moptimize-arg-area
-mserialize-volatile  -mshort-data-num  -msvr3
-msvr4  -mtrap-large-shift  -muse-div-instruction
-mversion-03.00  -mwarn-passed-structs

RS/6000 and PowerPC Options
-mcpu=cpu type
-mtune=cpu type
-mpower  -mno-power  -mpower2  -mno-power2
-mpowerpc  -mno-powerpc
-mpowerpc-gpopt  -mno-powerpc-gpopt
-mpowerpc-gfxopt  -mno-powerpc-gfxopt
-mnew-mnemonics  -mno-new-mnemonics
-mfull-toc   -mminimal-toc  -mno-fop-in-toc  -mno-sum-in-toc
-mxl-call  -mno-xl-call  -mthreads  -mpe
-msoft-float  -mhard-float  -mmultiple  -mno-multiple
-mstring  -mno-string  -mupdate  -mno-update
-mfused-madd  -mno-fused-madd  -mbit-align  -mno-bit-align
-mstrict-align  -mno-strict-align  -mrelocatable
-mno-relocatable  -mrelocatable-lib  -mno-relocatable-lib
-mtoc  -mno-toc  -mtraceback  -mno-traceback
-mlittle  -mlittle-endian  -mbig  -mbig-endian
-mcall-aix  -mcall-sysv  -mprototype  -mno-prototype
-msim  -mmvme  -memb  -msdata  -msdata=opt  -G num

RT Options
-mcall-lib-mul  -mfp-arg-in-fpregs  -mfp-arg-in-gregs
-mfull-fp-blocks  -mhc-struct-return  -min-line-mul
-mminimum-fp-blocks  -mnohc-struct-return

MIPS Options
-mabicalls  -mcpu=cpu type  -membedded-data
-membedded-pic  -mfp32  -mfp64  -mgas  -mgp32  -mgp64
-mgpopt  -mhalf-pic  -mhard-float  -mint64  -mips1
-mips2  -mips3  -mlong64  -mlong-calls  -mmemcpy
-mmips-as  -mmips-tfile  -mno-abicalls
-mno-embedded-data  -mno-embedded-pic
-mno-gpopt  -mno-long-calls
-mno-memcpy  -mno-mips-tfile  -mno-rnames  -mno-stats
-mrnames  -msoft-float
-m4650  -msingle-float  -mmad
-mstats  -EL  -EB  -G num  -nocpp

i386 Options
-mcpu=cpu type
-march=cpu type
-mieee-fp  -mno-fancy-math-387
-mno-fp-ret-in-387  -msoft-float  -msvr3-shlib
-mno-wide-multiply  -mrtd  -malign-double
-mreg-alloc=list  -mregparm=num
-malign-jumps=num  -malign-loops=num
-malign-functions=num

HPPA Options
-mbig-switch  -mdisable-fpregs  -mdisable-indexing  -mfast-indirect-calls
-mgas  -mjump-in-delay  -mlong-load-store  -mno-big-switch  -mno-disable-fpregs
-mno-disable-indexing  -mno-fast-indirect-calls  -mno-gas
-mno-jump-in-delay
-mno-long-load-store
-mno-portable-runtime -mno-soft-float -mno-space -mno-space-regs -msoft-float
-mpa-risc-1-0  -mpa-risc-1-1  -mportable-runtime
-mschedule=list  -mspace  -mspace-regs

Intel 960 Options
-mcpu type  -masm-compat  -mclean-linkage
-mcode-align  -mcomplex-addr  -mleaf-procedures
-mic-compat  -mic2.0-compat  -mic3.0-compat
-mintel-asm  -mno-clean-linkage  -mno-code-align
-mno-complex-addr  -mno-leaf-procedures
-mno-old-align  -mno-strict-align  -mno-tail-call
-mnumerics  -mold-align  -msoft-float  -mstrict-align
-mtail-call

DEC Alpha Options
-mfp-regs  -mno-fp-regs
-mno-soft-float  -msoft-float
-mieee  -mieee-with-inexact  -mieee-conformant
-mfp-trap-mode  -mfp-rounding-mode  -mtrap-precision
-mbuild-constants

Clipper Options
-mc300  -mc400

H8/300 Options
-mrelax  -mh -ms -mint32  -malign-300

SH Options
-m1  -m2  -m3  -m3e  -mb  -ml  -mrelax

System V Options
-Qy  -Qn  -YP,paths  -Ym,dir

V850 Options
-mlong-calls -mno-long-calls -mep -mno-ep
-mprolog-function -mno-prolog-function -mspace
-mtda=n -msda=n -mzda=n
-mv850
Code Generation Options
See section Options for Code Generation Conventions.
-fcall-saved-reg  -fcall-used-reg
-fexceptions -ffixed-reg  -finhibit-size-directive
-fcheck-memory-usage  -fprefix-function-name
-fno-common  -fno-ident  -fno-gnu-linker
-fpcc-struct-return  -fpic  -fPIC
-freg-struct-return  -fshared-data  -fshort-enums
-fshort-double  -fvolatile  -fvolatile-global
-fverbose-asm -fpack-struct  -fstack-check  +e0  +e1
-fargument-alias  -fargument-noalias
-fargument-noalias-global


Using and Porting GNU CC - Overall Options

Options Controlling the Kind of Output

Compilation can involve up to four stages: preprocessing, compilation proper, assembly and linking, always in that order. The first three stages apply to an individual source file, and end by producing an object file; linking combines all the object files (those newly compiled, and those specified as input) into an executable file.

For any given input file, the file name suffix determines what kind of compilation is done:

file.c
C source code which must be preprocessed.
file.i
C source code which should not be preprocessed.
file.ii
C++ source code which should not be preprocessed.
file.m
Objective-C source code. Note that you must link with the library `libobjc.a' to make an Objective-C program work.
file.h
C header file (not to be compiled or linked).
file.cc
file.cxx
file.cpp
file.C
C++ source code which must be preprocessed. Note that in `.cxx', the last two letters must both be literally `x'. Likewise, `.C' refers to a literal capital C.
file.s
Assembler code.
file.S
Assembler code which must be preprocessed.
other
An object file to be fed straight into linking. Any file name with no recognized suffix is treated this way.

You can specify the input language explicitly with the `-x' option:

-x language
Specify explicitly the language for the following input files (rather than letting the compiler choose a default based on the file name suffix). This option applies to all following input files until the next `-x' option. Possible values for language are:
c  objective-c  c++
c-header  cpp-output  c++-cpp-output
assembler  assembler-with-cpp
-x none
Turn off any specification of a language, so that subsequent files are handled according to their file name suffixes (as they are if `-x' has not been used at all).

If you only want some of the stages of compilation, you can use `-x' (or filename suffixes) to tell gcc where to start, and one of the options `-c', `-S', or `-E' to say where gcc is to stop. Note that some combinations (for example, `-x cpp-output -E' instruct gcc to do nothing at all.

-c
Compile or assemble the source files, but do not link. The linking stage simply is not done. The ultimate output is in the form of an object file for each source file. By default, the object file name for a source file is made by replacing the suffix `.c', `.i', `.s', etc., with `.o'. Unrecognized input files, not requiring compilation or assembly, are ignored.
-S
Stop after the stage of compilation proper; do not assemble. The output is in the form of an assembler code file for each non-assembler input file specified. By default, the assembler file name for a source file is made by replacing the suffix `.c', `.i', etc., with `.s'. Input files that don't require compilation are ignored.
-E
Stop after the preprocessing stage; do not run the compiler proper. The output is in the form of preprocessed source code, which is sent to the standard output. Input files which don't require preprocessing are ignored.
-o file
Place output in file file. This applies regardless to whatever sort of output is being produced, whether it be an executable file, an object file, an assembler file or preprocessed C code. Since only one output file can be specified, it does not make sense to use `-o' when compiling more than one input file, unless you are producing an executable file as output. If `-o' is not specified, the default is to put an executable file in `a.out', the object file for `source.suffix' in `source.o', its assembler file in `source.s', and all preprocessed C source on standard output.
-v
Print (on standard error output) the commands executed to run the stages of compilation. Also print the version number of the compiler driver program and of the preprocessor and the compiler proper.
-pipe
Use pipes rather than temporary files for communication between the various stages of compilation. This fails to work on some systems where the assembler is unable to read from a pipe; but the GNU assembler has no trouble.


Using and Porting GNU CC - Invoking G++

Compiling C++ Programs

C++ source files conventionally use one of the suffixes `.C', `.cc', `cpp', or `.cxx'; preprocessed C++ files use the suffix `.ii'. GNU CC recognizes files with these names and compiles them as C++ programs even if you call the compiler the same way as for compiling C programs (usually with the name gcc).

However, C++ programs often require class libraries as well as a compiler that understands the C++ language--and under some circumstances, you might want to compile programs from standard input, or otherwise without a suffix that flags them as C++ programs. g++ is a program that calls GNU CC with the default language set to C++, and automatically specifies linking against the GNU class library libg++. (1) On many systems, the script g++ is also installed with the name c++.

When you compile C++ programs, you may specify many of the same command-line options that you use for compiling programs in any language; or command-line options meaningful for C and related languages; or options that are meaningful only for C++ programs. See section Options Controlling C Dialect, for explanations of options for languages related to C. See section Options Controlling C++ Dialect, for explanations of options that are meaningful only for C++ programs.


Using and Porting GNU CC - C Dialect Options

Options Controlling C Dialect

The following options control the dialect of C (or languages derived from C, such as C++ and Objective C) that the compiler accepts:

-ansi
Support all ANSI standard C programs. This turns off certain features of GNU C that are incompatible with ANSI C, such as the asm, inline and typeof keywords, and predefined macros such as unix and vax that identify the type of system you are using. It also enables the undesirable and rarely used ANSI trigraph feature, and it disables recognition of C++ style `//' comments. The alternate keywords __asm__, __extension__, __inline__ and __typeof__ continue to work despite `-ansi'. You would not want to use them in an ANSI C program, of course, but it is useful to put them in header files that might be included in compilations done with `-ansi'. Alternate predefined macros such as __unix__ and __vax__ are also available, with or without `-ansi'. The `-ansi' option does not cause non-ANSI programs to be rejected gratuitously. For that, `-pedantic' is required in addition to `-ansi'. See section Options to Request or Suppress Warnings. The macro __STRICT_ANSI__ is predefined when the `-ansi' option is used. Some header files may notice this macro and refrain from declaring certain functions or defining certain macros that the ANSI standard doesn't call for; this is to avoid interfering with any programs that might use these names for other things. The functions alloca, abort, exit, and _exit are not builtin functions when `-ansi' is used.
-fno-asm
Do not recognize asm, inline or typeof as a keyword, so that code can use these words as identifiers. You can use the keywords __asm__, __inline__ and __typeof__ instead. `-ansi' implies `-fno-asm'. In C++, this switch only affects the typeof keyword, since asm and inline are standard keywords. You may want to use the `-fno-gnu-keywords' flag instead, as it also disables the other, C++-specific, extension keywords such as headof.
-fno-builtin
Don't recognize builtin functions that do not begin with two leading underscores. Currently, the functions affected include abort, abs, alloca, cos, exit, fabs, ffs, labs, memcmp, memcpy, sin, sqrt, strcmp, strcpy, and strlen. GCC normally generates special code to handle certain builtin functions more efficiently; for instance, calls to alloca may become single instructions that adjust the stack directly, and calls to memcpy may become inline copy loops. The resulting code is often both smaller and faster, but since the function calls no longer appear as such, you cannot set a breakpoint on those calls, nor can you change the behavior of the functions by linking with a different library. The `-ansi' option prevents alloca and ffs from being builtin functions, since these functions do not have an ANSI standard meaning.
-fhosted
Assert that compilation takes place in a hosted environment. This implies `-fbuiltin'. A hosted environment is one in which the entire standard library is available, and in which main has a return type of int. Examples are nearly everything except a kernel. This is equivalent to `-fno-freestanding'.
-ffreestanding
Assert that compilation takes place in a freestanding environment. This implies `-fno-builtin'. A freestanding environment is one in which the standard library may not exist, and program startup may not necessarily be at main. The most obvious example is an OS kernel. This is equivalent to `-fno-hosted'.
-trigraphs
Support ANSI C trigraphs. You don't want to know about this brain-damage. The `-ansi' option implies `-trigraphs'.
-traditional
Attempt to support some aspects of traditional C compilers. Specifically:
  • All extern declarations take effect globally even if they are written inside of a function definition. This includes implicit declarations of functions.
  • The newer keywords typeof, inline, signed, const and volatile are not recognized. (You can still use the alternative keywords such as __typeof__, __inline__, and so on.)
  • Comparisons between pointers and integers are always allowed.
  • Integer types unsigned short and unsigned char promote to unsigned int.
  • Out-of-range floating point literals are not an error.
  • Certain constructs which ANSI regards as a single invalid preprocessing number, such as `0xe-0xd', are treated as expressions instead.
  • String "constants" are not necessarily constant; they are stored in writable space, and identical looking constants are allocated separately. (This is the same as the effect of `-fwritable-strings'.)
  • All automatic variables not declared register are preserved by longjmp. Ordinarily, GNU C follows ANSI C: automatic variables not declared volatile may be clobbered.
  • The character escape sequences `\x' and `\a' evaluate as the literal characters `x' and `a' respectively. Without `-traditional', `\x' is a prefix for the hexadecimal representation of a character, and `\a' produces a bell.
  • In C++ programs, assignment to this is permitted with `-traditional'. (The option `-fthis-is-variable' also has this effect.)
You may wish to use `-fno-builtin' as well as `-traditional' if your program uses names that are normally GNU C builtin functions for other purposes of its own. You cannot use `-traditional' if you include any header files that rely on ANSI C features. Some vendors are starting to ship systems with ANSI C header files and you cannot use `-traditional' on such systems to compile files that include any system headers. The `-traditional' option also enables the `-traditional-cpp' option, which is described next.
-traditional-cpp
Attempt to support some aspects of traditional C preprocessors. Specifically:
  • Comments convert to nothing at all, rather than to a space. This allows traditional token concatenation.
  • In a preprocessing directive, the `#' symbol must appear as the first character of a line.
  • Macro arguments are recognized within string constants in a macro definition (and their values are stringified, though without additional quote marks, when they appear in such a context). The preprocessor always considers a string constant to end at a newline.
  • The predefined macro __STDC__ is not defined when you use `-traditional', but __GNUC__ is (since the GNU extensions which __GNUC__ indicates are not affected by `-traditional'). If you need to write header files that work differently depending on whether `-traditional' is in use, by testing both of these predefined macros you can distinguish four situations: GNU C, traditional GNU C, other ANSI C compilers, and other old C compilers. The predefined macro __STDC_VERSION__ is also not defined when you use `-traditional'. See section `Standard Predefined Macros' in The C Preprocessor, for more discussion of these and other predefined macros.
  • The preprocessor considers a string constant to end at a newline (unless the newline is escaped with `\'). (Without `-traditional', string constants can contain the newline character as typed.)
-fcond-mismatch
Allow conditional expressions with mismatched types in the second and third arguments. The value of such an expression is void.
-funsigned-char
Let the type char be unsigned, like unsigned char. Each kind of machine has a default for what char should be. It is either like unsigned char by default or like signed char by default. Ideally, a portable program should always use signed char or unsigned char when it depends on the signedness of an object. But many programs have been written to use plain char and expect it to be signed, or expect it to be unsigned, depending on the machines they were written for. This option, and its inverse, let you make such a program work with the opposite default. The type char is always a distinct type from each of signed char or unsigned char, even though its behavior is always just like one of those two.
-fsigned-char
Let the type char be signed, like signed char. Note that this is equivalent to `-fno-unsigned-char', which is the negative form of `-funsigned-char'. Likewise, the option `-fno-signed-char' is equivalent to `-funsigned-char'. You may wish to use `-fno-builtin' as well as `-traditional' if your program uses names that are normally GNU C builtin functions for other purposes of its own. You cannot use `-traditional' if you include any header files that rely on ANSI C features. Some vendors are starting to ship systems with ANSI C header files and you cannot use `-traditional' on such systems to compile files that include any system headers.
-fsigned-bitfields
-funsigned-bitfields
-fno-signed-bitfields
-fno-unsigned-bitfields
These options control whether a bitfield is signed or unsigned, when the declaration does not use either signed or unsigned. By default, such a bitfield is signed, because this is consistent: the basic integer types such as int are signed types. However, when `-traditional' is used, bitfields are all unsigned no matter what.
-fwritable-strings
Store string constants in the writable data segment and don't uniquize them. This is for compatibility with old programs which assume they can write into string constants. The option `-traditional' also has this effect. Writing into string constants is a very bad idea; "constants" should be constant.
-fallow-single-precision
Do not promote single precision math operations to double precision, even when compiling with `-traditional'. Traditional K&R C promotes all floating point operations to double precision, regardless of the sizes of the operands. On the architecture for which you are compiling, single precision may be faster than double precision. If you must use `-traditional', but want to use single precision operations when the operands are single precision, use this option. This option has no effect when compiling with ANSI or GNU C conventions (the default).


Using and Porting GNU CC - C++ Dialect Options

Options Controlling C++ Dialect

This section describes the command-line options that are only meaningful for C++ programs; but you can also use most of the GNU compiler options regardless of what language your program is in. For example, you might compile a file firstClass.C like this:

g++ -g -felide-constructors -O -c firstClass.C

In this example, only `-felide-constructors' is an option meant only for C++ programs; you can use the other options with any language supported by GNU CC.

Here is a list of options that are only for compiling C++ programs:

-fno-access-control
Turn off all access checking. This switch is mainly useful for working around bugs in the access control code.
-fall-virtual
Treat all possible member functions as virtual, implicitly. All member functions (except for constructor functions and new or delete member operators) are treated as virtual functions of the class where they appear. This does not mean that all calls to these member functions will be made through the internal table of virtual functions. Under some circumstances, the compiler can determine that a call to a given virtual function can be made directly; in these cases the calls are direct in any case.
-fcheck-new
Check that the pointer returned by operator new is non-null before attempting to modify the storage allocated. The current Working Paper requires that operator new never return a null pointer, so this check is normally unnecessary.
-fconserve-space
Put uninitialized or runtime-initialized global variables into the common segment, as C does. This saves space in the executable at the cost of not diagnosing duplicate definitions. If you compile with this flag and your program mysteriously crashes after main() has completed, you may have an object that is being destroyed twice because two definitions were merged.
-fdollars-in-identifiers
Accept `$' in identifiers. You can also explicitly prohibit use of `$' with the option `-fno-dollars-in-identifiers'. (GNU C allows `$' by default on most target systems, but there are a few exceptions.) Traditional C allowed the character `$' to form part of identifiers. However, ANSI C and C++ forbid `$' in identifiers.
-fenum-int-equiv
Anachronistically permit implicit conversion of int to enumeration types. Current C++ allows conversion of enum to int, but not the other way around.
-fexternal-templates
Cause template instantiations to obey `#pragma interface' and `implementation'; template instances are emitted or not according to the location of the template definition. See section Where's the Template?, for more information. This option is deprecated.
-falt-external-templates
Similar to -fexternal-templates, but template instances are emitted or not according to the place where they are first instantiated. See section Where's the Template?, for more information. This option is deprecated.
-ffor-scope
-fno-for-scope
If -ffor-scope is specified, the scope of variables declared in a for-init-statement is limited to the `for' loop itself, as specified by the draft C++ standard. If -fno-for-scope is specified, the scope of variables declared in a for-init-statement extends to the end of the enclosing scope, as was the case in old versions of gcc, and other (traditional) implementations of C++. The default if neither flag is given to follow the standard, but to allow and give a warning for old-style code that would otherwise be invalid, or have different behavior.
-fno-gnu-keywords
Do not recognize classof, headof, signature, sigof or typeof as a keyword, so that code can use these words as identifiers. You can use the keywords __classof__, __headof__, __signature__, __sigof__, and __typeof__ instead. `-ansi' implies `-fno-gnu-keywords'.
-fguiding-decls
Treat a function declaration with the same type as a potential function template instantiation as though it declares that instantiation, not a normal function. If a definition is given for the function later in the translation unit (or another translation unit if the target supports weak symbols), that definition will be used; otherwise the template will be instantiated. This behavior reflects the C++ language prior to September 1996, when guiding declarations were removed. This option implies `-fname-mangling-version-0', and will not work with other name mangling versions.
-fno-implicit-templates
Never emit code for templates which are instantiated implicitly (i.e. by use); only emit code for explicit instantiations. See section Where's the Template?, for more information.
-fhandle-signatures
Recognize the signature and sigof keywords for specifying abstract types. The default (`-fno-handle-signatures') is not to recognize them. See section Type Abstraction using Signatures.
-fhuge-objects
Support virtual function calls for objects that exceed the size representable by a `short int'. Users should not use this flag by default; if you need to use it, the compiler will tell you so. If you compile any of your code with this flag, you must compile all of your code with this flag (including libg++, if you use it). This flag is not useful when compiling with -fvtable-thunks.
-fno-implement-inlines
To save space, do not emit out-of-line copies of inline functions controlled by `#pragma implementation'. This will cause linker errors if these functions are not inlined everywhere they are called.
-fmemoize-lookups
-fsave-memoized
Use heuristics to compile faster. These heuristics are not enabled by default, since they are only effective for certain input files. Other input files compile more slowly. The first time the compiler must build a call to a member function (or reference to a data member), it must (1) determine whether the class implements member functions of that name; (2) resolve which member function to call (which involves figuring out what sorts of type conversions need to be made); and (3) check the visibility of the member function to the caller. All of this adds up to slower compilation. Normally, the second time a call is made to that member function (or reference to that data member), it must go through the same lengthy process again. This means that code like this:
cout << "This " << p << " has " << n << " legs.\n";
makes six passes through all three steps. By using a software cache, a "hit" significantly reduces this cost. Unfortunately, using the cache introduces another layer of mechanisms which must be implemented, and so incurs its own overhead. `-fmemoize-lookups' enables the software cache. Because access privileges (visibility) to members and member functions may differ from one function context to the next, G++ may need to flush the cache. With the `-fmemoize-lookups' flag, the cache is flushed after every function that is compiled. The `-fsave-memoized' flag enables the same software cache, but when the compiler determines that the context of the last function compiled would yield the same access privileges of the next function to compile, it preserves the cache. This is most helpful when defining many member functions for the same class: with the exception of member functions which are friends of other classes, each member function has exactly the same access privileges as every other, and the cache need not be flushed. The code that implements these flags has rotted; you should probably avoid using them.
-fstrict-prototype
Within an `extern "C"' linkage specification, treat a function declaration with no arguments, such as `int foo ();', as declaring the function to take no arguments. Normally, such a declaration means that the function foo can take any combination of arguments, as in C. `-pedantic' implies `-fstrict-prototype' unless overridden with `-fno-strict-prototype'. This flag no longer affects declarations with C++ linkage.
-fname-mangling-version-n
Control the way in which names are mangled. Version 0 is compatible with versions of g++ before 2.8. Version 1 is the default. Version 1 will allow correct mangling of function templates. For example, version 0 mangling does not mangle foo<int, double> and foo<int, char> given this declaration:
template <class T, class U> void foo(T t);
-fno-nonnull-objects
Don't assume that a reference is initialized to refer to a valid object. Although the current C++ Working Paper prohibits null references, some old code may rely on them, and you can use `-fno-nonnull-objects' to turn on checking. At the moment, the compiler only does this checking for conversions to virtual base classes.
-foperator-names
Recognize the operator name keywords and, bitand, bitor, compl, not, or and xor as synonyms for the symbols they refer to. `-ansi' implies `-foperator-names'.
-frepo
Enable automatic template instantiation. This option also implies `-fno-implicit-templates'. See section Where's the Template?, for more information.
-fthis-is-variable
Permit assignment to this. The incorporation of user-defined free store management into C++ has made assignment to `this' an anachronism. Therefore, by default it is invalid to assign to this within a class member function; that is, GNU C++ treats `this' in a member function of class X as a non-lvalue of type `X *'. However, for backwards compatibility, you can make it valid with `-fthis-is-variable'.
-fvtable-thunks
Use `thunks' to implement the virtual function dispatch table (`vtable'). The traditional (cfront-style) approach to implementing vtables was to store a pointer to the function and two offsets for adjusting the `this' pointer at the call site. Newer implementations store a single pointer to a `thunk' function which does any necessary adjustment and then calls the target function. This option also enables a heuristic for controlling emission of vtables; if a class has any non-inline virtual functions, the vtable will be emitted in the translation unit containing the first one of those.
-ftemplate-depth-n
Set the maximum instantiation depth for template classes to n. A limit on the template instantiation depth is needed to detect endless recursions during template class instantiation. ANSI/ISO C++ conforming programs must not rely on a maximum depth greater than 17.
-nostdinc++
Do not search for header files in the standard directories specific to C++, but do still search the other standard directories. (This option is used when building libg++.)
-traditional
For C++ programs (in addition to the effects that apply to both C and C++), this has the same effect as `-fthis-is-variable'. See section Options Controlling C Dialect.

In addition, these optimization, warning, and code generation options have meanings only for C++ programs:

-fno-default-inline
Do not assume `inline' for functions defined inside a class scope. See section Options That Control Optimization.
-Wold-style-cast
-Woverloaded-virtual
-Wtemplate-debugging
Warnings that apply only to C++ programs. See section Options to Request or Suppress Warnings.
-Weffc++
Warn about violation of some style rules from Effective C++ by Scott Myers.
+en
Control how virtual function definitions are used, in a fashion compatible with cfront 1.x. See section Options for Code Generation Conventions.


Using and Porting GNU CC - Warning Options

Options to Request or Suppress Warnings

Warnings are diagnostic messages that report constructions which are not inherently erroneous but which are risky or suggest there may have been an error.

You can request many specific warnings with options beginning `-W', for example `-Wimplicit' to request warnings on implicit declarations. Each of these specific warning options also has a negative form beginning `-Wno-' to turn off warnings; for example, `-Wno-implicit'. This manual lists only one of the two forms, whichever is not the default.

These options control the amount and kinds of warnings produced by GNU CC:

-fsyntax-only
Check the code for syntax errors, but don't do anything beyond that.
-pedantic
Issue all the warnings demanded by strict ANSI standard C; reject all programs that use forbidden extensions. Valid ANSI standard C programs should compile properly with or without this option (though a rare few will require `-ansi'). However, without this option, certain GNU extensions and traditional C features are supported as well. With this option, they are rejected. `-pedantic' does not cause warning messages for use of the alternate keywords whose names begin and end with `__'. Pedantic warnings are also disabled in the expression that follows __extension__. However, only system header files should use these escape routes; application programs should avoid them. See section Alternate Keywords. This option is not intended to be useful; it exists only to satisfy pedants who would otherwise claim that GNU CC fails to support the ANSI standard. Some users try to use `-pedantic' to check programs for strict ANSI C conformance. They soon find that it does not do quite what they want: it finds some non-ANSI practices, but not all--only those for which ANSI C requires a diagnostic. A feature to report any failure to conform to ANSI C might be useful in some instances, but would require considerable additional work and would be quite different from `-pedantic'. We recommend, rather, that users take advantage of the extensions of GNU C and disregard the limitations of other compilers. Aside from certain supercomputers and obsolete small machines, there is less and less reason ever to use any other C compiler other than for bootstrapping GNU CC.
-pedantic-errors
Like `-pedantic', except that errors are produced rather than warnings.
-w
Inhibit all warning messages.
-Wno-import
Inhibit warning messages about the use of `#import'.
-Wchar-subscripts
Warn if an array subscript has type char. This is a common cause of error, as programmers often forget that this type is signed on some machines.
-Wcomment
Warn whenever a comment-start sequence `/*' appears in a `/*' comment, or whenever a Backslash-Newline appears in a `//' comment.
-Wformat
Check calls to printf and scanf, etc., to make sure that the arguments supplied have types appropriate to the format string specified.
-Wimplicit
Warn whenever a function or parameter is implicitly declared, or when a type implicitly defaults to int.
-Wmain
Warn if the type of `main' is suspicious. `main' should be a function with external linkage, returning int, taking either zero arguments, two, or three arguments of appropriate types.
-Wparentheses
Warn if parentheses are omitted in certain contexts, such as when there is an assignment in a context where a truth value is expected, or when operators are nested whose precedence people often get confused about.
-Wreturn-type
Warn whenever a function is defined with a return-type that defaults to int. Also warn about any return statement with no return-value in a function whose return-type is not void.
-Wswitch
Warn whenever a switch statement has an index of enumeral type and lacks a case for one or more of the named codes of that enumeration. (The presence of a default label prevents this warning.) case labels outside the enumeration range also provoke warnings when this option is used.
-Wtrigraphs
Warn if any trigraphs are encountered (assuming they are enabled).
-Wunused
Warn whenever a variable is unused aside from its declaration, whenever a function is declared static but never defined, whenever a label is declared but not used, and whenever a statement computes a result that is explicitly not used. To suppress this warning for an expression, simply cast it to void. For unused variables and parameters, use the `unused' attribute (see section Specifying Attributes of Variables).
-Wuninitialized
An automatic variable is used without first being initialized. These warnings are possible only in optimizing compilation, because they require data flow information that is computed only when optimizing. If you don't specify `-O', you simply won't get these warnings. These warnings occur only for variables that are candidates for register allocation. Therefore, they do not occur for a variable that is declared volatile, or whose address is taken, or whose size is other than 1, 2, 4 or 8 bytes. Also, they do not occur for structures, unions or arrays, even when they are in registers. Note that there may be no warning about a variable that is used only to compute a value that itself is never used, because such computations may be deleted by data flow analysis before the warnings are printed. These warnings are made optional because GNU CC is not smart enough to see all the reasons why the code might be correct despite appearing to have an error. Here is one example of how this can happen:
{
  int x;
  switch (y)
    {
    case 1: x = 1;
      break;
    case 2: x = 4;
      break;
    case 3: x = 5;
    }
  foo (x);
}
If the value of y is always 1, 2 or 3, then x is always initialized, but GNU CC doesn't know this. Here is another common case:
{
  int save_y;
  if (change_y) save_y = y, y = new_y;
  ...
  if (change_y) y = save_y;
}
This has no bug because save_y is used only if it is set. Some spurious warnings can be avoided if you declare all the functions you use that never return as noreturn. See section Declaring Attributes of Functions.
-Wreorder (C++ only)
Warn when the order of member initializers given in the code does not match the order in which they must be executed. For instance:
struct A {
  int i;
  int j;
  A(): j (0), i (1) { }
};
Here the compiler will warn that the member initializers for `i' and `j' will be rearranged to match the declaration order of the members.
-Wsign-compare
Warn when a comparison between signed and unsigned values could produce an incorrect result when the signed value is converted to unsigned.
-Wtemplate-debugging
When using templates in a C++ program, warn if debugging is not yet fully available (C++ only).
-Wall
All of the above `-W' options combined. This enables all the warnings about constructions that some users consider questionable, and that are easy to avoid (or modify to prevent the warning), even in conjunction with macros.

The following `-W...' options are not implied by `-Wall'. Some of them warn about constructions that users generally do not consider questionable, but which occasionally you might wish to check for; others warn about constructions that are necessary or hard to avoid in some cases, and there is no simple way to modify the code to suppress the warning.

-W
Print extra warning messages for these events:
  • A nonvolatile automatic variable might be changed by a call to longjmp. These warnings as well are possible only in optimizing compilation. The compiler sees only the calls to setjmp. It cannot know where longjmp will be called; in fact, a signal handler could call it at any point in the code. As a result, you may get a warning even when there is in fact no problem because longjmp cannot in fact be called at the place which would cause a problem.
  • A function can return either with or without a value. (Falling off the end of the function body is considered returning without a value.) For example, this function would evoke such a warning:
    foo (a)
{
  if (a > 0)
    return a;
}
  • An expression-statement or the left-hand side of a comma expression contains no side effects. To suppress the warning, cast the unused expression to void. For example, an expression such as `x[i,j]' will cause a warning, but `x[(void)i,j]' will not.
  • An unsigned value is compared against zero with `<' or `<='.
  • A comparison like `x<=y<=z' appears; this is equivalent to `(x<=y ? 1 : 0) <= z', which is a different interpretation from that of ordinary mathematical notation.
  • Storage-class specifiers like static are not the first things in a declaration. According to the C Standard, this usage is obsolescent.
  • If `-Wall' or `-Wunused' is also specified, warn about unused arguments.
  • An aggregate has a partly bracketed initializer. For example, the following code would evoke such a warning, because braces are missing around the initializer for x.h:
    struct s { int f, g; };
struct t { struct s h; int i; };
struct t x = { 1, 2, 3 };
-Wtraditional
Warn about certain constructs that behave differently in traditional and ANSI C.
  • Macro arguments occurring within string constants in the macro body. These would substitute the argument in traditional C, but are part of the constant in ANSI C.
  • A function declared external in one block and then used after the end of the block.
  • A switch statement has an operand of type long.
-Wundef
Warn if an undefined identifier is evaluated in an `#if' directive.
-Wshadow
Warn whenever a local variable shadows another local variable.
-Wid-clash-len
Warn whenever two distinct identifiers match in the first len characters. This may help you prepare a program that will compile with certain obsolete, brain-damaged compilers.
-Wlarger-than-len
Warn whenever an object of larger than len bytes is defined.
-Wpointer-arith
Warn about anything that depends on the "size of" a function type or of void. GNU C assigns these types a size of 1, for convenience in calculations with void * pointers and pointers to functions.
-Wbad-function-cast
Warn whenever a function call is cast to a non-matching type. For example, warn if int malloc() is cast to anything *.
-Wcast-qual
Warn whenever a pointer is cast so as to remove a type qualifier from the target type. For example, warn if a const char * is cast to an ordinary char *.
-Wcast-align
Warn whenever a pointer is cast such that the required alignment of the target is increased. For example, warn if a char * is cast to an int * on machines where integers can only be accessed at two- or four-byte boundaries.
-Wwrite-strings
Give string constants the type const char[length] so that copying the address of one into a non-const char * pointer will get a warning. These warnings will help you find at compile time code that can try to write into a string constant, but only if you have been very careful about using const in declarations and prototypes. Otherwise, it will just be a nuisance; this is why we did not make `-Wall' request these warnings.
-Wconversion
Warn if a prototype causes a type conversion that is different from what would happen to the same argument in the absence of a prototype. This includes conversions of fixed point to floating and vice versa, and conversions changing the width or signedness of a fixed point argument except when the same as the default promotion. Also, warn if a negative integer constant expression is implicitly converted to an unsigned type. For example, warn about the assignment x = -1 if x is unsigned. But do not warn about explicit casts like (unsigned) -1.
-Waggregate-return
Warn if any functions that return structures or unions are defined or called. (In languages where you can return an array, this also elicits a warning.)
-Wstrict-prototypes
Warn if a function is declared or defined without specifying the argument types. (An old-style function definition is permitted without a warning if preceded by a declaration which specifies the argument types.)
-Wmissing-prototypes
Warn if a global function is defined without a previous prototype declaration. This warning is issued even if the definition itself provides a prototype. The aim is to detect global functions that fail to be declared in header files.
-Wmissing-declarations
Warn if a global function is defined without a previous declaration. Do so even if the definition itself provides a prototype. Use this option to detect global functions that are not declared in header files.
-Wredundant-decls
Warn if anything is declared more than once in the same scope, even in cases where multiple declaration is valid and changes nothing.
-Wnested-externs
Warn if an extern declaration is encountered within an function.
-Winline
Warn if a function can not be inlined, and either it was declared as inline, or else the `-finline-functions' option was given.
-Wold-style-cast
Warn if an old-style (C-style) cast is used within a program.
-Woverloaded-virtual
Warn when a derived class function declaration may be an error in defining a virtual function (C++ only). In a derived class, the definitions of virtual functions must match the type signature of a virtual function declared in the base class. With this option, the compiler warns when you define a function with the same name as a virtual function, but with a type signature that does not match any declarations from the base class.
-Wsynth (C++ only)
Warn when g++'s synthesis behavior does not match that of cfront. For instance:
struct A {
  operator int ();
  A& operator = (int);
};

main ()
{
  A a,b;
  a = b;
}
In this example, g++ will synthesize a default `A& operator = (const A&);', while cfront will use the user-defined `operator ='.
-Werror
Make all warnings into errors.


Using and Porting GNU CC - Debugging Options

Options for Debugging Your Program or GNU CC

GNU CC has various special options that are used for debugging either your program or GCC:

-g
Produce debugging information in the operating system's native format (stabs, COFF, XCOFF, or DWARF). GDB can work with this debugging information. On most systems that use stabs format, `-g' enables use of extra debugging information that only GDB can use; this extra information makes debugging work better in GDB but will probably make other debuggers crash or refuse to read the program. If you want to control for certain whether to generate the extra information, use `-gstabs+', `-gstabs', `-gxcoff+', `-gxcoff', `-gdwarf-1+', or `-gdwarf-1' (see below). Unlike most other C compilers, GNU CC allows you to use `-g' with `-O'. The shortcuts taken by optimized code may occasionally produce surprising results: some variables you declared may not exist at all; flow of control may briefly move where you did not expect it; some statements may not be executed because they compute constant results or their values were already at hand; some statements may execute in different places because they were moved out of loops. Nevertheless it proves possible to debug optimized output. This makes it reasonable to use the optimizer for programs that might have bugs. The following options are useful when GNU CC is generated with the capability for more than one debugging format.
-ggdb
Produce debugging information for use by GDB. This means to use the most expressive format available (DWARF 2, stabs, or the native format if neither of those are supported), including GDB extensions if at all possible.
-gstabs
Produce debugging information in stabs format (if that is supported), without GDB extensions. This is the format used by DBX on most BSD systems. On MIPS, Alpha and System V Release 4 systems this option produces stabs debugging output which is not understood by DBX or SDB. On System V Release 4 systems this option requires the GNU assembler.
-gstabs+
Produce debugging information in stabs format (if that is supported), using GNU extensions understood only by the GNU debugger (GDB). The use of these extensions is likely to make other debuggers crash or refuse to read the program.
-gcoff
Produce debugging information in COFF format (if that is supported). This is the format used by SDB on most System V systems prior to System V Release 4.
-gxcoff
Produce debugging information in XCOFF format (if that is supported). This is the format used by the DBX debugger on IBM RS/6000 systems.
-gxcoff+
Produce debugging information in XCOFF format (if that is supported), using GNU extensions understood only by the GNU debugger (GDB). The use of these extensions is likely to make other debuggers crash or refuse to read the program, and may cause assemblers other than the GNU assembler (GAS) to fail with an error.
-gdwarf
Produce debugging information in DWARF version 1 format (if that is supported). This is the format used by SDB on most System V Release 4 systems.
-gdwarf+
Produce debugging information in DWARF version 1 format (if that is supported), using GNU extensions understood only by the GNU debugger (GDB). The use of these extensions is likely to make other debuggers crash or refuse to read the program.
-gdwarf-2
Produce debugging information in DWARF version 2 format (if that is supported). This is the format used by DBX on IRIX 6.
-glevel
-ggdblevel
-gstabslevel
-gcofflevel
-gxcofflevel
-gdwarflevel
-gdwarf-2level
Request debugging information and also use level to specify how much information. The default level is 2. Level 1 produces minimal information, enough for making backtraces in parts of the program that you don't plan to debug. This includes descriptions of functions and external variables, but no information about local variables and no line numbers. Level 3 includes extra information, such as all the macro definitions present in the program. Some debuggers support macro expansion when you use `-g3'.
-p
Generate extra code to write profile information suitable for the analysis program prof. You must use this option when compiling the source files you want data about, and you must also use it when linking.
-pg
Generate extra code to write profile information suitable for the analysis program gprof. You must use this option when compiling the source files you want data about, and you must also use it when linking.
-a
Generate extra code to write profile information for basic blocks, which will record the number of times each basic block is executed, the basic block start address, and the function name containing the basic block. If `-g' is used, the line number and filename of the start of the basic block will also be recorded. If not overridden by the machine description, the default action is to append to the text file `bb.out'. This data could be analyzed by a program like tcov. Note, however, that the format of the data is not what tcov expects. Eventually GNU gprof should be extended to process this data.
-Q
Makes the compiler print out each function name as it is compiled, and print some statistics about each pass when it finishes.
-ax
Generate extra code to profile basic blocks. Your executable will produce output that is a superset of that produced when `-a' is used. Additional output is the source and target address of the basic blocks where a jump takes place, the number of times a jump is executed, and (optionally) the complete sequence of basic blocks being executed. The output is appended to file `bb.out'. You can examine different profiling aspects without recompilation. Your execuable will read a list of function names from file `bb.in'. Profiling starts when a function on the list is entered and stops when that invocation is exited. To exclude a function from profiling, prefix its name with `-'. If a function name is not unique, you can disambiguate it by writing it in the form `/path/filename.d:functionname'. Your executable will write the available paths and filenames in file `bb.out'. Several function names have a special meaning:
__bb_jumps__
Write source, target and frequency of jumps to file `bb.out'.
__bb_hidecall__
Exclude function calls from frequency count.
__bb_showret__
Include function returns in frequency count.
__bb_trace__
Write the sequence of basic blocks executed to file `bbtrace.gz'. The file will be compressed using the program `gzip', which must exist in your PATH. On systems without the `popen' function, the file will be named `bbtrace' and will not be compressed. Profiling for even a few seconds on these systems will produce a very large file. Note: __bb_hidecall__ and __bb_showret__ will not affect the sequence written to `bbtrace.gz'.
Here's a short example using different profiling parameters in file `bb.in'. Assume function foo consists of basic blocks 1 and 2 and is called twice from block 3 of function main. After the calls, block 3 transfers control to block 4 of main. With __bb_trace__ and main contained in file `bb.in', the following sequence of blocks is written to file `bbtrace.gz': 0 3 1 2 1 2 4. The return from block 2 to block 3 is not shown, because the return is to a point inside the block and not to the top. The block address 0 always indicates, that control is transferred to the trace from somewhere outside the observed functions. With `-foo' added to `bb.in', the blocks of function foo are removed from the trace, so only 0 3 4 remains. With __bb_jumps__ and main contained in file `bb.in', jump frequencies will be written to file `bb.out'. The frequencies are obtained by constructing a trace of blocks and incrementing a counter for every neighbouring pair of blocks in the trace. The trace 0 3 1 2 1 2 4 displays the following frequencies:
Jump from block 0x0 to block 0x3 executed 1 time(s)
Jump from block 0x3 to block 0x1 executed 1 time(s)
Jump from block 0x1 to block 0x2 executed 2 time(s)
Jump from block 0x2 to block 0x1 executed 1 time(s)
Jump from block 0x2 to block 0x4 executed 1 time(s)
With __bb_hidecall__, control transfer due to call instructions is removed from the trace, that is the trace is cut into three parts: 0 3 4, 0 1 2 and 0 1 2. With __bb_showret__, control transfer due to return instructions is added to the trace. The trace becomes: 0 3 1 2 3 1 2 3 4. Note, that this trace is not the same, as the sequence written to `bbtrace.gz'. It is solely used for counting jump frequencies.
-fprofile-arcs
Instrument arcs during compilation. For each function of your program, GNU CC creates a program flow graph, then finds a spanning tree for the graph. Only arcs that are not on the spanning tree have to be instrumented: the compiler adds code to count the number of times that these arcs are executed. When an arc is the only exit or only entrance to a block, the instrumentation code can be added to the block; otherwise, a new basic block must be created to hold the instrumentation code. Since not every arc in the program must be instrumented, programs compiled with this option run faster than programs compiled with `-a', which adds instrumentation code to every basic block in the program. The tradeoff: since gcov does not have execution counts for all branches, it must start with the execution counts for the instrumented branches, and then iterate over the program flow graph until the entire graph has been solved. Hence, gcov runs a little more slowly than a program which uses information from `-a'. `-fprofile-arcs' also makes it possible to estimate branch probabilities, and to calculate basic block execution counts. In general, basic block execution counts do not give enough information to estimate all branch probabilities. When the compiled program exits, it saves the arc execution counts to a file called `sourcename.da'. Use the compiler option `-fbranch-probabilities' (see section Options That Control Optimization) when recompiling, to optimize using estimated branch probabilities.
-ftest-coverage
Create data files for the gcov code-coverage utility (see section gcov: a Test Coverage Program). The data file names begin with the name of your source file:
sourcename.bb
A mapping from basic blocks to line numbers, which gcov uses to associate basic block execution counts with line numbers.
sourcename.bbg
A list of all arcs in the program flow graph. This allows gcov to reconstruct the program flow graph, so that it can compute all basic block and arc execution counts from the information in the sourcename.da file (this last file is the output from `-fprofile-arcs').
-dletters
Says to make debugging dumps during compilation at times specified by letters. This is used for debugging the compiler. The file names for most of the dumps are made by appending a word to the source file name (e.g. `foo.c.rtl' or `foo.c.jump'). Here are the possible letters for use in letters, and their meanings:
`M'
Dump all macro definitions, at the end of preprocessing, and write no output.
`N'
Dump all macro names, at the end of preprocessing.
`D'
Dump all macro definitions, at the end of preprocessing, in addition to normal output.
`y'
Dump debugging information during parsing, to standard error.
`r'
Dump after RTL generation, to `file.rtl'.
`x'
Just generate RTL for a function instead of compiling it. Usually used with `r'.
`j'
Dump after first jump optimization, to `file.jump'.
`s'
Dump after CSE (including the jump optimization that sometimes follows CSE), to `file.cse'.
`L'
Dump after loop optimization, to `file.loop'.
`t'
Dump after the second CSE pass (including the jump optimization that sometimes follows CSE), to `file.cse2'.
`f'
Dump after flow analysis, to `file.flow'.
`c'
Dump after instruction combination, to the file `file.combine'.
`S'
Dump after the first instruction scheduling pass, to `file.sched'.
`l'
Dump after local register allocation, to `file.lreg'.
`g'
Dump after global register allocation, to `file.greg'.
`R'
Dump after the second instruction scheduling pass, to `file.sched2'.
`J'
Dump after last jump optimization, to `file.jump2'.
`d'
Dump after delayed branch scheduling, to `file.dbr'.
`k'
Dump after conversion from registers to stack, to `file.stack'.
`a'
Produce all the dumps listed above.
`m'
Print statistics on memory usage, at the end of the run, to standard error.
`p'
Annotate the assembler output with a comment indicating which pattern and alternative was used.
`A'
Annotate the assembler output with miscellaneous debugging information.
-fpretend-float
When running a cross-compiler, pretend that the target machine uses the same floating point format as the host machine. This causes incorrect output of the actual floating constants, but the actual instruction sequence will probably be the same as GNU CC would make when running on the target machine.
-save-temps
Store the usual "temporary" intermediate files permanently; place them in the current directory and name them based on the source file. Thus, compiling `foo.c' with `-c -save-temps' would produce files `foo.i' and `foo.s', as well as `foo.o'.
-print-file-name=library
Print the full absolute name of the library file library that would be used when linking--and don't do anything else. With this option, GNU CC does not compile or link anything; it just prints the file name.
-print-prog-name=program
Like `-print-file-name', but searches for a program such as `cpp'.
-print-libgcc-file-name
Same as `-print-file-name=libgcc.a'. This is useful when you use `-nostdlib' or `-nodefaultlibs' but you do want to link with `libgcc.a'. You can do
gcc -nostdlib files... `gcc -print-libgcc-file-name`
-print-search-dirs
Print the name of the configured installation directory and a list of program and library directories gcc will search--and don't do anything else. This is useful when gcc prints the error message `installation problem, cannot exec cpp: No such file or directory'. To resolve this you either need to put `cpp' and the other compiler components where gcc expects to find them, or you can set the environment variable GCC_EXEC_PREFIX to the directory where you installed them. Don't forget the trailing '/'. See section Environment Variables Affecting GNU CC.


Using and Porting GNU CC - Optimize Options

Options That Control Optimization

These options control various sorts of optimizations:

-O
-O1
Optimize. Optimizing compilation takes somewhat more time, and a lot more memory for a large function. Without `-O', the compiler's goal is to reduce the cost of compilation and to make debugging produce the expected results. Statements are independent: if you stop the program with a breakpoint between statements, you can then assign a new value to any variable or change the program counter to any other statement in the function and get exactly the results you would expect from the source code. Without `-O', the compiler only allocates variables declared register in registers. The resulting compiled code is a little worse than produced by PCC without `-O'. With `-O', the compiler tries to reduce code size and execution time. When you specify `-O', the compiler turns on `-fthread-jumps' and `-fdefer-pop' on all machines. The compiler turns on `-fdelayed-branch' on machines that have delay slots, and `-fomit-frame-pointer' on machines that can support debugging even without a frame pointer. On some machines the compiler also turns on other flags.
-O2
Optimize even more. GNU CC performs nearly all supported optimizations that do not involve a space-speed tradeoff. The compiler does not perform loop unrolling or function inlining when you specify `-O2'. As compared to `-O', this option increases both compilation time and the performance of the generated code. `-O2' turns on all optional optimizations except for loop unrolling and function inlining. It also turns on the `-fforce-mem' option on all machines and frame pointer elimination on machines where doing so does not interfere with debugging.
-O3
Optimize yet more. `-O3' turns on all optimizations specified by `-O2' and also turns on the `inline-functions' option.
-O0
Do not optimize. If you use multiple `-O' options, with or without level numbers, the last such option is the one that is effective.

Options of the form `-fflag' specify machine-independent flags. Most flags have both positive and negative forms; the negative form of `-ffoo' would be `-fno-foo'. In the table below, only one of the forms is listed--the one which is not the default. You can figure out the other form by either removing `no-' or adding it.

-ffloat-store
Do not store floating point variables in registers, and inhibit other options that might change whether a floating point value is taken from a register or memory. This option prevents undesirable excess precision on machines such as the 68000 where the floating registers (of the 68881) keep more precision than a double is supposed to have. Similarly for the x86 architecture. For most programs, the excess precision does only good, but a few programs rely on the precise definition of IEEE floating point. Use `-ffloat-store' for such programs.
-fno-default-inline
Do not make member functions inline by default merely because they are defined inside the class scope (C++ only). Otherwise, when you specify `-O', member functions defined inside class scope are compiled inline by default; i.e., you don't need to add `inline' in front of the member function name.
-fno-defer-pop
Always pop the arguments to each function call as soon as that function returns. For machines which must pop arguments after a function call, the compiler normally lets arguments accumulate on the stack for several function calls and pops them all at once.
-fforce-mem
Force memory operands to be copied into registers before doing arithmetic on them. This produces better code by making all memory references potential common subexpressions. When they are not common subexpressions, instruction combination should eliminate the separate register-load. The `-O2' option turns on this option.
-fforce-addr
Force memory address constants to be copied into registers before doing arithmetic on them. This may produce better code just as `-fforce-mem' may.
-fomit-frame-pointer
Don't keep the frame pointer in a register for functions that don't need one. This avoids the instructions to save, set up and restore frame pointers; it also makes an extra register available in many functions. It also makes debugging impossible on some machines. On some machines, such as the Vax, this flag has no effect, because the standard calling sequence automatically handles the frame pointer and nothing is saved by pretending it doesn't exist. The machine-description macro FRAME_POINTER_REQUIRED controls whether a target machine supports this flag. See section Register Usage.
-fno-inline
Don't pay attention to the inline keyword. Normally this option is used to keep the compiler from expanding any functions inline. Note that if you are not optimizing, no functions can be expanded inline.
-finline-functions
Integrate all simple functions into their callers. The compiler heuristically decides which functions are simple enough to be worth integrating in this way. If all calls to a given function are integrated, and the function is declared static, then the function is normally not output as assembler code in its own right.
-fkeep-inline-functions
Even if all calls to a given function are integrated, and the function is declared static, nevertheless output a separate run-time callable version of the function. This switch does not affect extern inline functions.
-fkeep-static-consts
Emit variables declared static const when optimization isn't turned on, even if the variables aren't referenced. GNU CC enables this option by default. If you want to force the compiler to check if the variable was referenced, regardless of whether or not optimization is turned on, use the `-fno-keep-static-consts' option.
-fno-function-cse
Do not put function addresses in registers; make each instruction that calls a constant function contain the function's address explicitly. This option results in less efficient code, but some strange hacks that alter the assembler output may be confused by the optimizations performed when this option is not used.
-ffast-math
This option allows GCC to violate some ANSI or IEEE rules and/or specifications in the interest of optimizing code for speed. For example, it allows the compiler to assume arguments to the sqrt function are non-negative numbers and that no floating-point values are NaNs. This option should never be turned on by any `-O' option since it can result in incorrect output for programs which depend on an exact implementation of IEEE or ANSI rules/specifications for math functions.

The following options control specific optimizations. The `-O2' option turns on all of these optimizations except `-funroll-loops' and `-funroll-all-loops'. On most machines, the `-O' option turns on the `-fthread-jumps' and `-fdelayed-branch' options, but specific machines may handle it differently.

You can use the following flags in the rare cases when "fine-tuning" of optimizations to be performed is desired.

-fstrength-reduce
Perform the optimizations of loop strength reduction and elimination of iteration variables.
-fthread-jumps
Perform optimizations where we check to see if a jump branches to a location where another comparison subsumed by the first is found. If so, the first branch is redirected to either the destination of the second branch or a point immediately following it, depending on whether the condition is known to be true or false.
-fcse-follow-jumps
In common subexpression elimination, scan through jump instructions when the target of the jump is not reached by any other path. For example, when CSE encounters an if statement with an else clause, CSE will follow the jump when the condition tested is false.
-fcse-skip-blocks
This is similar to `-fcse-follow-jumps', but causes CSE to follow jumps which conditionally skip over blocks. When CSE encounters a simple if statement with no else clause, `-fcse-skip-blocks' causes CSE to follow the jump around the body of the if.
-frerun-cse-after-loop
Re-run common subexpression elimination after loop optimizations has been performed.
-frerun-loop-opt
Run the loop optimizer twice.
-fexpensive-optimizations
Perform a number of minor optimizations that are relatively expensive.
-fdelayed-branch
If supported for the target machine, attempt to reorder instructions to exploit instruction slots available after delayed branch instructions.
-fschedule-insns
If supported for the target machine, attempt to reorder instructions to eliminate execution stalls due to required data being unavailable. This helps machines that have slow floating point or memory load instructions by allowing other instructions to be issued until the result of the load or floating point instruction is required.
-fschedule-insns2
Similar to `-fschedule-insns', but requests an additional pass of instruction scheduling after register allocation has been done. This is especially useful on machines with a relatively small number of registers and where memory load instructions take more than one cycle.
-ffunction-sections
Place each function into its own section in the output file if the target supports arbitrary sections. The function's name determines the section's name in the output file. Use this option on systems where the linker can perform optimizations to improve locality of reference in the instruction space. HPPA processors running HP-UX and Sparc processors running Solaris 2 have linkers with such optimizations. Other systems using the ELF object format as well as AIX may have these optimizations in the future. Only use this option when there are significant benefits from doing so. When you specify this option, the assembler and linker will create larger object and executable files and will also be slower. You will not be able to use gprof on all systems if you specify this option and you may have problems with debugging if you specify both this option and `-g'.
-fcaller-saves
Enable values to be allocated in registers that will be clobbered by function calls, by emitting extra instructions to save and restore the registers around such calls. Such allocation is done only when it seems to result in better code than would otherwise be produced. This option is enabled by default on certain machines, usually those which have no call-preserved registers to use instead.
-funroll-loops
Perform the optimization of loop unrolling. This is only done for loops whose number of iterations can be determined at compile time or run time. `-funroll-loop' implies both `-fstrength-reduce' and `-frerun-cse-after-loop'.
-funroll-all-loops
Perform the optimization of loop unrolling. This is done for all loops and usually makes programs run more slowly. `-funroll-all-loops' implies `-fstrength-reduce' as well as `-frerun-cse-after-loop'.
-fmove-all-movables
Forces all invariant computations in loops to be moved outside the loop.
-freduce-all-givs
Forces all general-induction variables in loops to be strength-reduced. Note: When compiling programs written in Fortran, `-fmove-all-moveables' and `-freduce-all-givs' are enabled by default when you use the optimizer. These options may generate better or worse code; results are highly dependent on the structure of loops within the source code. These two options are intended to be removed someday, once they have helped determine the efficacy of various approaches to improving loop optimizations. Please let us (egcs@cygnus.com and fortran@gnu.org) know how use of these options affects the performance of your production code. We're very interested in code that runs slower when these options are enabled.
-fno-peephole
Disable any machine-specific peephole optimizations.
-fbranch-probabilities
After running a program compiled with `-fprofile-arcs' (see section Options for Debugging Your Program or GNU CC), you can compile it a second time using `-fbranch-probabilities', to improve optimizations based on guessing the path a branch might take. With `-fbranch-probabilities', GNU CC puts a `REG_EXEC_COUNT' note on the first instruction of each basic block, and a `REG_BR_PROB' note on each `JUMP_INSN' and `CALL_INSN'. These can be used to improve optimization. Currently, they are only used in one place: in `reorg.c', instead of guessing which path a branch is mostly to take, the `REG_BR_PROB' values are used to exactly determine which path is taken more often.
-fregmove
Some machines only support 2 operands per instruction. On such machines, GNU CC might have to do extra copies. The `-fregmove' option overrides the default for the machine to do the copy before register allocation.


Using and Porting GNU CC - Preprocessor Options

Options Controlling the Preprocessor

These options control the C preprocessor, which is run on each C source file before actual compilation.

If you use the `-E' option, nothing is done except preprocessing. Some of these options make sense only together with `-E' because they cause the preprocessor output to be unsuitable for actual compilation.

-include file
Process file as input before processing the regular input file. In effect, the contents of file are compiled first. Any `-D' and `-U' options on the command line are always processed before `-include file', regardless of the order in which they are written. All the `-include' and `-imacros' options are processed in the order in which they are written.
-imacros file
Process file as input, discarding the resulting output, before processing the regular input file. Because the output generated from file is discarded, the only effect of `-imacros file' is to make the macros defined in file available for use in the main input. Any `-D' and `-U' options on the command line are always processed before `-imacros file', regardless of the order in which they are written. All the `-include' and `-imacros' options are processed in the order in which they are written.
-idirafter dir
Add the directory dir to the second include path. The directories on the second include path are searched when a header file is not found in any of the directories in the main include path (the one that `-I' adds to).
-iprefix prefix
Specify prefix as the prefix for subsequent `-iwithprefix' options.
-iwithprefix dir
Add a directory to the second include path. The directory's name is made by concatenating prefix and dir, where prefix was specified previously with `-iprefix'. If you have not specified a prefix yet, the directory containing the installed passes of the compiler is used as the default.
-iwithprefixbefore dir
Add a directory to the main include path. The directory's name is made by concatenating prefix and dir, as in the case of `-iwithprefix'.
-isystem dir
Add a directory to the beginning of the second include path, marking it as a system directory, so that it gets the same special treatment as is applied to the standard system directories.
-nostdinc
Do not search the standard system directories for header files. Only the directories you have specified with `-I' options (and the current directory, if appropriate) are searched. See section Options for Directory Search, for information on `-I'. By using both `-nostdinc' and `-I-', you can limit the include-file search path to only those directories you specify explicitly.
-undef
Do not predefine any nonstandard macros. (Including architecture flags).
-E
Run only the C preprocessor. Preprocess all the C source files specified and output the results to standard output or to the specified output file.
-C
Tell the preprocessor not to discard comments. Used with the `-E' option.
-P
Tell the preprocessor not to generate `#line' directives. Used with the `-E' option.
-M
Tell the preprocessor to output a rule suitable for make describing the dependencies of each object file. For each source file, the preprocessor outputs one make-rule whose target is the object file name for that source file and whose dependencies are all the #include header files it uses. This rule may be a single line or may be continued with `\'-newline if it is long. The list of rules is printed on standard output instead of the preprocessed C program. `-M' implies `-E'. Another way to specify output of a make rule is by setting the environment variable DEPENDENCIES_OUTPUT (see section Environment Variables Affecting GNU CC).
-MM
Like `-M' but the output mentions only the user header files included with `#include "file"'. System header files included with `#include <file>' are omitted.
-MD
Like `-M' but the dependency information is written to a file made by replacing ".c" with ".d" at the end of the input file names. This is in addition to compiling the file as specified---`-MD' does not inhibit ordinary compilation the way `-M' does. In Mach, you can use the utility md to merge multiple dependency files into a single dependency file suitable for using with the `make' command.
-MMD
Like `-MD' except mention only user header files, not system header files.
-MG
Treat missing header files as generated files and assume they live in the same directory as the source file. If you specify `-MG', you must also specify either `-M' or `-MM'. `-MG' is not supported with `-MD' or `-MMD'.
-H
Print the name of each header file used, in addition to other normal activities.
-Aquestion(answer)
Assert the answer answer for question, in case it is tested with a preprocessing conditional such as `#if #question(answer)'. `-A-' disables the standard assertions that normally describe the target machine.
-Dmacro
Define macro macro with the string `1' as its definition.
-Dmacro=defn
Define macro macro as defn. All instances of `-D' on the command line are processed before any `-U' options.
-Umacro
Undefine macro macro. `-U' options are evaluated after all `-D' options, but before any `-include' and `-imacros' options.
-dM
Tell the preprocessor to output only a list of the macro definitions that are in effect at the end of preprocessing. Used with the `-E' option.
-dD
Tell the preprocessing to pass all macro definitions into the output, in their proper sequence in the rest of the output.
-dN
Like `-dD' except that the macro arguments and contents are omitted. Only `#define name' is included in the output.
-trigraphs
Support ANSI C trigraphs. The `-ansi' option also has this effect.
-Wp,option
Pass option as an option to the preprocessor. If option contains commas, it is split into multiple options at the commas.


Using and Porting GNU CC - Assembler Options

Passing Options to the Assembler

You can pass options to the assembler.

-Wa,option
Pass option as an option to the assembler. If option contains commas, it is split into multiple options at the commas.


Using and Porting GNU CC - Link Options

Options for Linking

These options come into play when the compiler links object files into an executable output file. They are meaningless if the compiler is not doing a link step.

object-file-name
A file name that does not end in a special recognized suffix is considered to name an object file or library. (Object files are distinguished from libraries by the linker according to the file contents.) If linking is done, these object files are used as input to the linker.
-c
-S
-E
If any of these options is used, then the linker is not run, and object file names should not be used as arguments. See section Options Controlling the Kind of Output.
-llibrary
Search the library named library when linking. It makes a difference where in the command you write this option; the linker searches processes libraries and object files in the order they are specified. Thus, `foo.o -lz bar.o' searches library `z' after file `foo.o' but before `bar.o'. If `bar.o' refers to functions in `z', those functions may not be loaded. The linker searches a standard list of directories for the library, which is actually a file named `liblibrary.a'. The linker then uses this file as if it had been specified precisely by name. The directories searched include several standard system directories plus any that you specify with `-L'. Normally the files found this way are library files--archive files whose members are object files. The linker handles an archive file by scanning through it for members which define symbols that have so far been referenced but not defined. But if the file that is found is an ordinary object file, it is linked in the usual fashion. The only difference between using an `-l' option and specifying a file name is that `-l' surrounds library with `lib' and `.a' and searches several directories.
-lobjc
You need this special case of the `-l' option in order to link an Objective C program.
-nostartfiles
Do not use the standard system startup files when linking. The standard system libraries are used normally, unless -nostdlib or -nodefaultlibs is used.
-nodefaultlibs
Do not use the standard system libraries when linking. Only the libraries you specify will be passed to the linker. The standard startup files are used normally, unless -nostartfiles is used.
-nostdlib
Do not use the standard system startup files or libraries when linking. No startup files and only the libraries you specify will be passed to the linker. One of the standard libraries bypassed by `-nostdlib' and `-nodefaultlibs' is `libgcc.a', a library of internal subroutines that GNU CC uses to overcome shortcomings of particular machines, or special needs for some languages. (See section Interfacing to GNU CC Output, for more discussion of `libgcc.a'.) In most cases, you need `libgcc.a' even when you want to avoid other standard libraries. In other words, when you specify `-nostdlib' or `-nodefaultlibs' you should usually specify `-lgcc' as well. This ensures that you have no unresolved references to internal GNU CC library subroutines. (For example, `__main', used to ensure C++ constructors will be called; see section collect2.)
-s
Remove all symbol table and relocation information from the executable.
-static
On systems that support dynamic linking, this prevents linking with the shared libraries. On other systems, this option has no effect.
-shared
Produce a shared object which can then be linked with other objects to form an executable. Not all systems support this option. You must also specify `-fpic' or `-fPIC' on some systems when you specify this option.
-symbolic
Bind references to global symbols when building a shared object. Warn about any unresolved references (unless overridden by the link editor option `-Xlinker -z -Xlinker defs'). Only a few systems support this option.
-Xlinker option
Pass option as an option to the linker. You can use this to supply system-specific linker options which GNU CC does not know how to recognize. If you want to pass an option that takes an argument, you must use `-Xlinker' twice, once for the option and once for the argument. For example, to pass `-assert definitions', you must write `-Xlinker -assert -Xlinker definitions'. It does not work to write `-Xlinker "-assert definitions"', because this passes the entire string as a single argument, which is not what the linker expects.
-Wl,option
Pass option as an option to the linker. If option contains commas, it is split into multiple options at the commas.
-u symbol
Pretend the symbol symbol is undefined, to force linking of library modules to define it. You can use `-u' multiple times with different symbols to force loading of additional library modules.


Using and Porting GNU CC - Directory Options

Options for Directory Search

These options specify directories to search for header files, for libraries and for parts of the compiler:

-Idir
Add the directory dir to the head of the list of directories to be searched for header files. This can be used to override a system header file, substituting your own version, since these directories are searched before the system header file directories. If you use more than one `-I' option, the directories are scanned in left-to-right order; the standard system directories come after.
-I-
Any directories you specify with `-I' options before the `-I-' option are searched only for the case of `#include "file"'; they are not searched for `#include <file>'. If additional directories are specified with `-I' options after the `-I-', these directories are searched for all `#include' directives. (Ordinarily all `-I' directories are used this way.) In addition, the `-I-' option inhibits the use of the current directory (where the current input file came from) as the first search directory for `#include "file"'. There is no way to override this effect of `-I-'. With `-I.' you can specify searching the directory which was current when the compiler was invoked. That is not exactly the same as what the preprocessor does by default, but it is often satisfactory. `-I-' does not inhibit the use of the standard system directories for header files. Thus, `-I-' and `-nostdinc' are independent.
-Ldir
Add directory dir to the list of directories to be searched for `-l'.
-Bprefix
This option specifies where to find the executables, libraries, include files, and data files of the compiler itself. The compiler driver program runs one or more of the subprograms `cpp', `cc1', `as' and `ld'. It tries prefix as a prefix for each program it tries to run, both with and without `machine/version/' (see section Specifying Target Machine and Compiler Version). For each subprogram to be run, the compiler driver first tries the `-B' prefix, if any. If that name is not found, or if `-B' was not specified, the driver tries two standard prefixes, which are `/usr/lib/gcc/' and `/usr/local/lib/gcc-lib/'. If neither of those results in a file name that is found, the unmodified program name is searched for using the directories specified in your `PATH' environment variable. `-B' prefixes that effectively specify directory names also apply to libraries in the linker, because the compiler translates these options into `-L' options for the linker. They also apply to includes files in the preprocessor, because the compiler translates these options into `-isystem' options for the preprocessor. In this case, the compiler appends `include' to the prefix. The run-time support file `libgcc.a' can also be searched for using the `-B' prefix, if needed. If it is not found there, the two standard prefixes above are tried, and that is all. The file is left out of the link if it is not found by those means. Another way to specify a prefix much like the `-B' prefix is to use the environment variable GCC_EXEC_PREFIX. See section Environment Variables Affecting GNU CC.
-specs=file
Process file after the compiler reads in the standard `specs' file, in order to override the defaults that the `gcc' driver program uses when determining what switches to pass to `cc1', `cc1plus', `as', `ld', etc. More than one `-specs='file can be specified on the command line, and they are processed in order, from left to right.


Using and Porting GNU CC - Target Options

Specifying Target Machine and Compiler Version

By default, GNU CC compiles code for the same type of machine that you are using. However, it can also be installed as a cross-compiler, to compile for some other type of machine. In fact, several different configurations of GNU CC, for different target machines, can be installed side by side. Then you specify which one to use with the `-b' option.

In addition, older and newer versions of GNU CC can be installed side by side. One of them (probably the newest) will be the default, but you may sometimes wish to use another.

-b machine
The argument machine specifies the target machine for compilation. This is useful when you have installed GNU CC as a cross-compiler. The value to use for machine is the same as was specified as the machine type when configuring GNU CC as a cross-compiler. For example, if a cross-compiler was configured with `configure i386v', meaning to compile for an 80386 running System V, then you would specify `-b i386v' to run that cross compiler. When you do not specify `-b', it normally means to compile for the same type of machine that you are using.
-V version
The argument version specifies which version of GNU CC to run. This is useful when multiple versions are installed. For example, version might be `2.0', meaning to run GNU CC version 2.0. The default version, when you do not specify `-V', is the last version of GNU CC that you installed.

The `-b' and `-V' options actually work by controlling part of the file name used for the executable files and libraries used for compilation. A given version of GNU CC, for a given target machine, is normally kept in the directory `/usr/local/lib/gcc-lib/machine/version'.

Thus, sites can customize the effect of `-b' or `-V' either by changing the names of these directories or adding alternate names (or symbolic links). If in directory `/usr/local/lib/gcc-lib/' the file `80386' is a link to the file `i386v', then `-b 80386' becomes an alias for `-b i386v'.

In one respect, the `-b' or `-V' do not completely change to a different compiler: the top-level driver program gcc that you originally invoked continues to run and invoke the other executables (preprocessor, compiler per se, assembler and linker) that do the real work. However, since no real work is done in the driver program, it usually does not matter that the driver program in use is not the one for the specified target and version.

The only way that the driver program depends on the target machine is in the parsing and handling of special machine-specific options. However, this is controlled by a file which is found, along with the other executables, in the directory for the specified version and target machine. As a result, a single installed driver program adapts to any specified target machine and compiler version.

The driver program executable does control one significant thing, however: the default version and target machine. Therefore, you can install different instances of the driver program, compiled for different targets or versions, under different names.

For example, if the driver for version 2.0 is installed as ogcc and that for version 2.1 is installed as gcc, then the command gcc will use version 2.1 by default, while ogcc will use 2.0 by default. However, you can choose either version with either command with the `-V' option.


Using and Porting GNU CC - Submodel Options

Hardware Models and Configurations

Earlier we discussed the standard option `-b' which chooses among different installed compilers for completely different target machines, such as Vax vs. 68000 vs. 80386.

In addition, each of these target machine types can have its own special options, starting with `-m', to choose among various hardware models or configurations--for example, 68010 vs 68020, floating coprocessor or none. A single installed version of the compiler can compile for any model or configuration, according to the options specified.

Some configurations of the compiler also support additional special options, usually for compatibility with other compilers on the same platform.

These options are defined by the macro TARGET_SWITCHES in the machine description. The default for the options is also defined by that macro, which enables you to change the defaults.


Using and Porting GNU CC - M680x0 Options

M680x0 Options

These are the `-m' options defined for the 68000 series. The default values for these options depends on which style of 68000 was selected when the compiler was configured; the defaults for the most common choices are given below.

-m68000
-mc68000
Generate output for a 68000. This is the default when the compiler is configured for 68000-based systems.
-m68020
-mc68020
Generate output for a 68020. This is the default when the compiler is configured for 68020-based systems.
-m68881
Generate output containing 68881 instructions for floating point. This is the default for most 68020 systems unless `-nfp' was specified when the compiler was configured.
-m68030
Generate output for a 68030. This is the default when the compiler is configured for 68030-based systems.
-m68040
Generate output for a 68040. This is the default when the compiler is configured for 68040-based systems. This option inhibits the use of 68881/68882 instructions that have to be emulated by software on the 68040. If your 68040 does not have code to emulate those instructions, use `-m68040'.
-m68060
Generate output for a 68060. This is the default when the compiler is configured for 68060-based systems. This option inhibits the use of 68020 and 68881/68882 instructions that have to be emulated by software on the 68060. If your 68060 does not have code to emulate those instructions, use `-m68060'.
-m5200
Generate output for a 520X "coldfire" family cpu. This is the default when the compiler is configured for 520X-based systems.
-m68020-40
Generate output for a 68040, without using any of the new instructions. This results in code which can run relatively efficiently on either a 68020/68881 or a 68030 or a 68040. The generated code does use the 68881 instructions that are emulated on the 68040.
-m68020-60
Generate output for a 68060, without using any of the new instructions. This results in code which can run relatively efficiently on either a 68020/68881 or a 68030 or a 68040. The generated code does use the 68881 instructions that are emulated on the 68060.
-mfpa
Generate output containing Sun FPA instructions for floating point.
-msoft-float
Generate output containing library calls for floating point. Warning: the requisite libraries are not available for all m68k targets. Normally the facilities of the machine's usual C compiler are used, but this can't be done directly in cross-compilation. You must make your own arrangements to provide suitable library functions for cross-compilation. The embedded targets `m68k-*-aout' and `m68k-*-coff' do provide software floating point support.
-mshort
Consider type int to be 16 bits wide, like short int.
-mnobitfield
Do not use the bit-field instructions. The `-m68000' option implies `-mnobitfield'.
-mbitfield
Do use the bit-field instructions. The `-m68020' option implies `-mbitfield'. This is the default if you use a configuration designed for a 68020.
-mrtd
Use a different function-calling convention, in which functions that take a fixed number of arguments return with the rtd instruction, which pops their arguments while returning. This saves one instruction in the caller since there is no need to pop the arguments there. This calling convention is incompatible with the one normally used on Unix, so you cannot use it if you need to call libraries compiled with the Unix compiler. Also, you must provide function prototypes for all functions that take variable numbers of arguments (including printf); otherwise incorrect code will be generated for calls to those functions. In addition, seriously incorrect code will result if you call a function with too many arguments. (Normally, extra arguments are harmlessly ignored.) The rtd instruction is supported by the 68010, 68020, 68030, 68040, and 68060 processors, but not by the 68000 or 5200.
-malign-int
-mno-align-int
Control whether GNU CC aligns int, long, long long, float, double, and long double variables on a 32-bit boundary (`-malign-int') or a 16-bit boundary (`-mno-align-int'). Aligning variables on 32-bit boundaries produces code that runs somewhat faster on processors with 32-bit busses at the expense of more memory. Warning: if you use the `-malign-int' switch, GNU CC will align structures containing the above types differently than most published application binary interface specifications for the m68k.


Using and Porting GNU CC - VAX Options

VAX Options

These `-m' options are defined for the Vax:

-munix
Do not output certain jump instructions (aobleq and so on) that the Unix assembler for the Vax cannot handle across long ranges.
-mgnu
Do output those jump instructions, on the assumption that you will assemble with the GNU assembler.
-mg
Output code for g-format floating point numbers instead of d-format.


Using and Porting GNU CC - SPARC Options

SPARC Options

These `-m' switches are supported on the SPARC:

-mno-app-regs
-mapp-regs
Specify `-mapp-regs' to generate output using the global registers 2 through 4, which the SPARC SVR4 ABI reserves for applications. This is the default. To be fully SVR4 ABI compliant at the cost of some performance loss, specify `-mno-app-regs'. You should compile libraries and system software with this option.
-mfpu
-mhard-float
Generate output containing floating point instructions. This is the default.
-mno-fpu
-msoft-float
Generate output containing library calls for floating point. Warning: the requisite libraries are not available for all SPARC targets. Normally the facilities of the machine's usual C compiler are used, but this cannot be done directly in cross-compilation. You must make your own arrangements to provide suitable library functions for cross-compilation. The embedded targets `sparc-*-aout' and `sparclite-*-*' do provide software floating point support. `-msoft-float' changes the calling convention in the output file; therefore, it is only useful if you compile all of a program with this option. In particular, you need to compile `libgcc.a', the library that comes with GNU CC, with `-msoft-float' in order for this to work.
-mhard-quad-float
Generate output containing quad-word (long double) floating point instructions.
-msoft-quad-float
Generate output containing library calls for quad-word (long double) floating point instructions. The functions called are those specified in the SPARC ABI. This is the default. As of this writing, there are no sparc implementations that have hardware support for the quad-word floating point instructions. They all invoke a trap handler for one of these instructions, and then the trap handler emulates the effect of the instruction. Because of the trap handler overhead, this is much slower than calling the ABI library routines. Thus the `-msoft-quad-float' option is the default.
-mno-epilogue
-mepilogue
With `-mepilogue' (the default), the compiler always emits code for function exit at the end of each function. Any function exit in the middle of the function (such as a return statement in C) will generate a jump to the exit code at the end of the function. With `-mno-epilogue', the compiler tries to emit exit code inline at every function exit.
-mno-flat
-mflat
With `-mflat', the compiler does not generate save/restore instructions and will use a "flat" or single register window calling convention. This model uses %i7 as the frame pointer and is compatible with the normal register window model. Code from either may be intermixed. The local registers and the input registers (0-5) are still treated as "call saved" registers and will be saved on the stack as necessary. With `-mno-flat' (the default), the compiler emits save/restore instructions (except for leaf functions) and is the normal mode of operation.
-mno-unaligned-doubles
-munaligned-doubles
Assume that doubles have 8 byte alignment. This is the default. With `-munaligned-doubles', GNU CC assumes that doubles have 8 byte alignment only if they are contained in another type, or if they have an absolute address. Otherwise, it assumes they have 4 byte alignment. Specifying this option avoids some rare compatibility problems with code generated by other compilers. It is not the default because it results in a performance loss, especially for floating point code.
-mv8
-msparclite
These two options select variations on the SPARC architecture. By default (unless specifically configured for the Fujitsu SPARClite), GCC generates code for the v7 variant of the SPARC architecture. `-mv8' will give you SPARC v8 code. The only difference from v7 code is that the compiler emits the integer multiply and integer divide instructions which exist in SPARC v8 but not in SPARC v7. `-msparclite' will give you SPARClite code. This adds the integer multiply, integer divide step and scan (ffs) instructions which exist in SPARClite but not in SPARC v7. These options are deprecated and will be deleted in GNU CC 2.9. They have been replaced with `-mcpu=xxx'.
-mcypress
-msupersparc
These two options select the processor for which the code is optimised. With `-mcypress' (the default), the compiler optimizes code for the Cypress CY7C602 chip, as used in the SparcStation/SparcServer 3xx series. This is also appropriate for the older SparcStation 1, 2, IPX etc. With `-msupersparc' the compiler optimizes code for the SuperSparc cpu, as used in the SparcStation 10, 1000 and 2000 series. This flag also enables use of the full SPARC v8 instruction set. These options are deprecated and will be deleted in GNU CC 2.9. They have been replaced with `-mcpu=xxx'.
-mcpu=cpu_type
Set the instruction set, register set, and instruction scheduling parameters for machine type cpu_type. Supported values for cpu_type are `v7', `cypress', `v8', `supersparc', `sparclite', `f930', `f934', `sparclet', `tsc701', `v9', and `ultrasparc'. Default instruction scheduling parameters are used for values that select an architecture and not an implementation. These are `v7', `v8', `sparclite', `sparclet', `v9'. Here is a list of each supported architecture and their supported implementations.
    v7:             cypress
    v8:             supersparc
    sparclite:      f930, f934
    sparclet:       tsc701
    v9:             ultrasparc
-mtune=cpu_type
Set the instruction scheduling parameters for machine type cpu_type, but do not set the instruction set or register set that the option `-mcpu='cpu_type would. The same values for `-mcpu='cpu_type are used for `-mtune='cpu_type, though the only useful values are those that select a particular cpu implementation: `cypress', `supersparc', `f930', `f934', `tsc701', `ultrasparc'.
-malign-loops=num
Align loops to a 2 raised to a num byte boundary. If `-malign-loops' is not specified, the default is 2.
-malign-jumps=num
Align instructions that are only jumped to to a 2 raised to a num byte boundary. If `-malign-jumps' is not specified, the default is 2.
-malign-functions=num
Align the start of functions to a 2 raised to num byte boundary. If `-malign-functions' is not specified, the default is 2 if compiling for 32 bit sparc, and 5 if compiling for 64 bit sparc.

These `-m' switches are supported in addition to the above on the SPARCLET processor.

-mlittle-endian
Generate code for a processor running in little-endian mode.
-mlive-g0
Treat register %g0 as a normal register. GCC will continue to clobber it as necessary but will not assume it always reads as 0.
-mbroken-saverestore
Generate code that does not use non-trivial forms of the save and restore instructions. Early versions of the SPARCLET processor do not correctly handle save and restore instructions used with arguments. They correctly handle them used without arguments. A save instruction used without arguments increments the current window pointer but does not allocate a new stack frame. It is assumed that the window overflow trap handler will properly handle this case as will interrupt handlers.

These `-m' switches are supported in addition to the above on SPARC V9 processors in 64 bit environments.

-mlittle-endian
Generate code for a processor running in little-endian mode.
-m32
-m64
Generate code for a 32 bit or 64 bit environment. The 32 bit environment sets int, long and pointer to 32 bits. The 64 bit environment sets int to 32 bits and long and pointer to 64 bits.
-mcmodel=medlow
Generate code for the Medium/Low code model: the program must be linked in the low 32 bits of the address space. Pointers are 64 bits. Programs can be statically or dynamically linked.
-mcmodel=medmid
Generate code for the Medium/Middle code model: the program must be linked in the low 44 bits of the address space, the text segment must be less than 2G bytes, and data segment must be within 2G of the text segment. Pointers are 64 bits.
-mcmodel=medany
Generate code for the Medium/Anywhere code model: the program may be linked anywhere in the address space, the text segment must be less than 2G bytes, and data segment must be within 2G of the text segment. Pointers are 64 bits.
-mcmodel=embmedany
Generate code for the Medium/Anywhere code model for embedded systems: assume a 32 bit text and a 32 bit data segment, both starting anywhere (determined at link time). Register %g4 points to the base of the data segment. Pointers still 64 bits. Programs are statically linked, PIC is not supported.
-mstack-bias
-mno-stack-bias
With `-mstack-bias', GNU CC assumes that the stack pointer, and frame pointer if present, are offset by -2047 which must be added back when making stack frame references. Otherwise, assume no such offset is present.


Using and Porting GNU CC - Convex Options

Convex Options

These `-m' options are defined for Convex:

-mc1
Generate output for C1. The code will run on any Convex machine. The preprocessor symbol __convex__c1__ is defined.
-mc2
Generate output for C2. Uses instructions not available on C1. Scheduling and other optimizations are chosen for max performance on C2. The preprocessor symbol __convex_c2__ is defined.
-mc32
Generate output for C32xx. Uses instructions not available on C1. Scheduling and other optimizations are chosen for max performance on C32. The preprocessor symbol __convex_c32__ is defined.
-mc34
Generate output for C34xx. Uses instructions not available on C1. Scheduling and other optimizations are chosen for max performance on C34. The preprocessor symbol __convex_c34__ is defined.
-mc38
Generate output for C38xx. Uses instructions not available on C1. Scheduling and other optimizations are chosen for max performance on C38. The preprocessor symbol __convex_c38__ is defined.
-margcount
Generate code which puts an argument count in the word preceding each argument list. This is compatible with regular CC, and a few programs may need the argument count word. GDB and other source-level debuggers do not need it; this info is in the symbol table.
-mnoargcount
Omit the argument count word. This is the default.
-mvolatile-cache
Allow volatile references to be cached. This is the default.
-mvolatile-nocache
Volatile references bypass the data cache, going all the way to memory. This is only needed for multi-processor code that does not use standard synchronization instructions. Making non-volatile references to volatile locations will not necessarily work.
-mlong32
Type long is 32 bits, the same as type int. This is the default.
-mlong64
Type long is 64 bits, the same as type long long. This option is useless, because no library support exists for it.


Using and Porting GNU CC - AMD29K Options

AMD29K Options

These `-m' options are defined for the AMD Am29000:

-mdw
Generate code that assumes the DW bit is set, i.e., that byte and halfword operations are directly supported by the hardware. This is the default.
-mndw
Generate code that assumes the DW bit is not set.
-mbw
Generate code that assumes the system supports byte and halfword write operations. This is the default.
-mnbw
Generate code that assumes the systems does not support byte and halfword write operations. `-mnbw' implies `-mndw'.
-msmall
Use a small memory model that assumes that all function addresses are either within a single 256 KB segment or at an absolute address of less than 256k. This allows the call instruction to be used instead of a const, consth, calli sequence.
-mnormal
Use the normal memory model: Generate call instructions only when calling functions in the same file and calli instructions otherwise. This works if each file occupies less than 256 KB but allows the entire executable to be larger than 256 KB. This is the default.
-mlarge
Always use calli instructions. Specify this option if you expect a single file to compile into more than 256 KB of code.
-m29050
Generate code for the Am29050.
-m29000
Generate code for the Am29000. This is the default.
-mkernel-registers
Generate references to registers gr64-gr95 instead of to registers gr96-gr127. This option can be used when compiling kernel code that wants a set of global registers disjoint from that used by user-mode code. Note that when this option is used, register names in `-f' flags must use the normal, user-mode, names.
-muser-registers
Use the normal set of global registers, gr96-gr127. This is the default.
-mstack-check
-mno-stack-check
Insert (or do not insert) a call to __msp_check after each stack adjustment. This is often used for kernel code.
-mstorem-bug
-mno-storem-bug
`-mstorem-bug' handles 29k processors which cannot handle the separation of a mtsrim insn and a storem instruction (most 29000 chips to date, but not the 29050).
-mno-reuse-arg-regs
-mreuse-arg-regs
`-mno-reuse-arg-regs' tells the compiler to only use incoming argument registers for copying out arguments. This helps detect calling a function with fewer arguments than it was declared with.
-mno-impure-text
-mimpure-text
`-mimpure-text', used in addition to `-shared', tells the compiler to not pass `-assert pure-text' to the linker when linking a shared object.
-msoft-float
Generate output containing library calls for floating point. Warning: the requisite libraries are not part of GNU CC. Normally the facilities of the machine's usual C compiler are used, but this can't be done directly in cross-compilation. You must make your own arrangements to provide suitable library functions for cross-compilation.


Using and Porting GNU CC - ARM Options

ARM Options

These `-m' options are defined for Advanced RISC Machines (ARM) architectures:

-mapcs-frame
Generate a stack frame that is compliant with the ARM Procedure Call Standard for all functions, even if this is not strictly necessary for correct execution of the code.
-mapcs-26
Generate code for a processor running with a 26-bit program counter, and conforming to the function calling standards for the APCS 26-bit option. This option replaces the `-m2' and `-m3' options of previous releases of the compiler.
-mapcs-32
Generate code for a processor running with a 32-bit program counter, and conforming to the function calling standards for the APCS 32-bit option. This option replaces the `-m6' option of previous releases of the compiler.
-mhard-float
Generate output containing floating point instructions. This is the default.
-msoft-float
Generate output containing library calls for floating point. Warning: the requisite libraries are not available for all ARM targets. Normally the facilities of the machine's usual C compiler are used, but this cannot be done directly in cross-compilation. You must make your own arrangements to provide suitable library functions for cross-compilation. `-msoft-float' changes the calling convention in the output file; therefore, it is only useful if you compile all of a program with this option. In particular, you need to compile `libgcc.a', the library that comes with GNU CC, with `-msoft-float' in order for this to work.
-mlittle-endian
Generate code for a processor running in little-endian mode. This is the default for all standard configurations.
-mbig-endian
Generate code for a processor running in big-endian mode; the default is to compile code for a little-endian processor.
-mwords-little-endian
This option only applies when generating code for big-endian processors. Generate code for a little-endian word order but a big-endian byte order. That is, a byte order of the form `32107654'. Note: this option should only be used if you require compatibility with code for big-endian ARM processors generated by versions of the compiler prior to 2.8.
-mshort-load-bytes
Do not try to load half-words (eg `short's) by loading a word from an unaligned address. For some targets the MMU is configured to trap unaligned loads; use this option to generate code that is safe in these environments.
-mno-short-load-bytes
Use unaligned word loads to load half-words (eg `short's). This option produces more efficient code, but the MMU is sometimes configured to trap these instructions.
-mbsd
This option only applies to RISC iX. Emulate the native BSD-mode compiler. This is the default if `-ansi' is not specified.
-mxopen
This option only applies to RISC iX. Emulate the native X/Open-mode compiler.
-mno-symrename
This option only applies to RISC iX. Do not run the assembler post-processor, `symrename', after code has been assembled. Normally it is necessary to modify some of the standard symbols in preparation for linking with the RISC iX C library; this option suppresses this pass. The post-processor is never run when the compiler is built for cross-compilation.


Using and Porting GNU CC - MN10300 Options

MN10300 Options

These `-m' options are defined for Matsushita MN10300 architectures:

-mmult-bug
Generate code to avoid bugs in the multiply instructions for the MN10300 processors. This is the default.
-mno-mult-bug
Do not generate code to avoid bugs in the multiply instructions for the MN10300 processors.


Using and Porting GNU CC - M32R/D Options

M32R/D Options

These `-m' options are defined for Mitsubishi M32R/D architectures:

-mcode-model=small
Assume all objects live in the lower 16MB of memory (so that their addresses can be loaded with the ld24 instruction), and assume all subroutines are reachable with the bl instruction. This is the default. The addressability of a particular object can be set with the model attribute.
-mcode-model=medium
Assume objects may be anywhere in the 32 bit address space (the compiler will generate seth/add3 instructions to load their addresses), and assume all subroutines are reachable with the bl instruction.
-mcode-model=large
Assume objects may be anywhere in the 32 bit address space (the compiler will generate seth/add3 instructions to load their addresses), and assume subroutines may not be reachable with the bl instruction (the compiler will generate the much slower seth/add3/jl instruction sequence).
-msdata=none
Disable use of the small data area. Variables will be put into one of `.data', `bss', or `.rodata' (unless the section attribute has been specified). This is the default. The small data area consists of sections `.sdata' and `.sbss'. Objects may be explicitly put in the small data area with the section attribute using one of these sections.
-msdata=sdata
Put small global and static data in the small data area, but do not generate special code to reference them.
-msdata=use
Put small global and static data in the small data area, and generate special instructions to reference them.
-G num
Put global and static objects less than or equal to num bytes into the small data or bss sections instead of the normal data or bss sections. The default value of num is 8. The `-msdata' option must be set to one of `sdata' or `use' for this option to have any effect. All modules should be compiled with the same `-G num' value. Compiling with different values of num may or may not work; if it doesn't the linker will give an error message - incorrect code will not be generated.


Using and Porting GNU CC - M88K Options

M88K Options

These `-m' options are defined for Motorola 88k architectures:

-m88000
Generate code that works well on both the m88100 and the m88110.
-m88100
Generate code that works best for the m88100, but that also runs on the m88110.
-m88110
Generate code that works best for the m88110, and may not run on the m88100.
-mbig-pic
Obsolete option to be removed from the next revision. Use `-fPIC'.
-midentify-revision
Include an ident directive in the assembler output recording the source file name, compiler name and version, timestamp, and compilation flags used.
-mno-underscores
In assembler output, emit symbol names without adding an underscore character at the beginning of each name. The default is to use an underscore as prefix on each name.
-mocs-debug-info
-mno-ocs-debug-info
Include (or omit) additional debugging information (about registers used in each stack frame) as specified in the 88open Object Compatibility Standard, "OCS". This extra information allows debugging of code that has had the frame pointer eliminated. The default for DG/UX, SVr4, and Delta 88 SVr3.2 is to include this information; other 88k configurations omit this information by default.
-mocs-frame-position
When emitting COFF debugging information for automatic variables and parameters stored on the stack, use the offset from the canonical frame address, which is the stack pointer (register 31) on entry to the function. The DG/UX, SVr4, Delta88 SVr3.2, and BCS configurations use `-mocs-frame-position'; other 88k configurations have the default `-mno-ocs-frame-position'.
-mno-ocs-frame-position
When emitting COFF debugging information for automatic variables and parameters stored on the stack, use the offset from the frame pointer register (register 30). When this option is in effect, the frame pointer is not eliminated when debugging information is selected by the -g switch.
-moptimize-arg-area
-mno-optimize-arg-area
Control how function arguments are stored in stack frames. `-moptimize-arg-area' saves space by optimizing them, but this conflicts with the 88open specifications. The opposite alternative, `-mno-optimize-arg-area', agrees with 88open standards. By default GNU CC does not optimize the argument area.
-mshort-data-num
Generate smaller data references by making them relative to r0, which allows loading a value using a single instruction (rather than the usual two). You control which data references are affected by specifying num with this option. For example, if you specify `-mshort-data-512', then the data references affected are those involving displacements of less than 512 bytes. `-mshort-data-num' is not effective for num greater than 64k.
-mserialize-volatile
-mno-serialize-volatile
Do, or don't, generate code to guarantee sequential consistency of volatile memory references. By default, consistency is guaranteed. The order of memory references made by the MC88110 processor does not always match the order of the instructions requesting those references. In particular, a load instruction may execute before a preceding store instruction. Such reordering violates sequential consistency of volatile memory references, when there are multiple processors. When consistency must be guaranteed, GNU C generates special instructions, as needed, to force execution in the proper order. The MC88100 processor does not reorder memory references and so always provides sequential consistency. However, by default, GNU C generates the special instructions to guarantee consistency even when you use `-m88100', so that the code may be run on an MC88110 processor. If you intend to run your code only on the MC88100 processor, you may use `-mno-serialize-volatile'. The extra code generated to guarantee consistency may affect the performance of your application. If you know that you can safely forgo this guarantee, you may use `-mno-serialize-volatile'.
-msvr4
-msvr3
Turn on (`-msvr4') or off (`-msvr3') compiler extensions related to System V release 4 (SVr4). This controls the following:
  1. Which variant of the assembler syntax to emit.
  2. `-msvr4' makes the C preprocessor recognize `#pragma weak' that is used on System V release 4.
  3. `-msvr4' makes GNU CC issue additional declaration directives used in SVr4.
`-msvr4' is the default for the m88k-motorola-sysv4 and m88k-dg-dgux m88k configurations. `-msvr3' is the default for all other m88k configurations.
-mversion-03.00
This option is obsolete, and is ignored.
-mno-check-zero-division
-mcheck-zero-division
Do, or don't, generate code to guarantee that integer division by zero will be detected. By default, detection is guaranteed. Some models of the MC88100 processor fail to trap upon integer division by zero under certain conditions. By default, when compiling code that might be run on such a processor, GNU C generates code that explicitly checks for zero-valued divisors and traps with exception number 503 when one is detected. Use of mno-check-zero-division suppresses such checking for code generated to run on an MC88100 processor. GNU C assumes that the MC88110 processor correctly detects all instances of integer division by zero. When `-m88110' is specified, both `-mcheck-zero-division' and `-mno-check-zero-division' are ignored, and no explicit checks for zero-valued divisors are generated.
-muse-div-instruction
Use the div instruction for signed integer division on the MC88100 processor. By default, the div instruction is not used. On the MC88100 processor the signed integer division instruction div) traps to the operating system on a negative operand. The operating system transparently completes the operation, but at a large cost in execution time. By default, when compiling code that might be run on an MC88100 processor, GNU C emulates signed integer division using the unsigned integer division instruction divu), thereby avoiding the large penalty of a trap to the operating system. Such emulation has its own, smaller, execution cost in both time and space. To the extent that your code's important signed integer division operations are performed on two nonnegative operands, it may be desirable to use the div instruction directly. On the MC88110 processor the div instruction (also known as the divs instruction) processes negative operands without trapping to the operating system. When `-m88110' is specified, `-muse-div-instruction' is ignored, and the div instruction is used for signed integer division. Note that the result of dividing INT_MIN by -1 is undefined. In particular, the behavior of such a division with and without `-muse-div-instruction' may differ.
-mtrap-large-shift
-mhandle-large-shift
Include code to detect bit-shifts of more than 31 bits; respectively, trap such shifts or emit code to handle them properly. By default GNU CC makes no special provision for large bit shifts.
-mwarn-passed-structs
Warn when a function passes a struct as an argument or result. Structure-passing conventions have changed during the evolution of the C language, and are often the source of portability problems. By default, GNU CC issues no such warning.


Using and Porting GNU CC - RS/6000 and PowerPC Options

IBM RS/6000 and PowerPC Options

These `-m' options are defined for the IBM RS/6000 and PowerPC:

-mpower
-mno-power
-mpower2
-mno-power2
-mpowerpc
-mno-powerpc
-mpowerpc-gpopt
-mno-powerpc-gpopt
-mpowerpc-gfxopt
-mno-powerpc-gfxopt
GNU CC supports two related instruction set architectures for the RS/6000 and PowerPC. The POWER instruction set are those instructions supported by the `rios' chip set used in the original RS/6000 systems and the PowerPC instruction set is the architecture of the Motorola MPC5xx, MPC6xx, MPC8xx microprocessors, and the IBM 4xx microprocessors. Neither architecture is a subset of the other. However there is a large common subset of instructions supported by both. An MQ register is included in processors supporting the POWER architecture. You use these options to specify which instructions are available on the processor you are using. The default value of these options is determined when configuring GNU CC. Specifying the `-mcpu=cpu_type' overrides the specification of these options. We recommend you use the `-mcpu=cpu_type' option rather than the options listed above. The `-mpower' option allows GNU CC to generate instructions that are found only in the POWER architecture and to use the MQ register. Specifying `-mpower2' implies `-power' and also allows GNU CC to generate instructions that are present in the POWER2 architecture but not the original POWER architecture. The `-mpowerpc' option allows GNU CC to generate instructions that are found only in the 32-bit subset of the PowerPC architecture. Specifying `-mpowerpc-gpopt' implies `-mpowerpc' and also allows GNU CC to use the optional PowerPC architecture instructions in the General Purpose group, including floating-point square root. Specifying `-mpowerpc-gfxopt' implies `-mpowerpc' and also allows GNU CC to use the optional PowerPC architecture instructions in the Graphics group, including floating-point select. If you specify both `-mno-power' and `-mno-powerpc', GNU CC will use only the instructions in the common subset of both architectures plus some special AIX common-mode calls, and will not use the MQ register. Specifying both `-mpower' and `-mpowerpc' permits GNU CC to use any instruction from either architecture and to allow use of the MQ register; specify this for the Motorola MPC601.
-mnew-mnemonics
-mold-mnemonics
Select which mnemonics to use in the generated assembler code. `-mnew-mnemonics' requests output that uses the assembler mnemonics defined for the PowerPC architecture, while `-mold-mnemonics' requests the assembler mnemonics defined for the POWER architecture. Instructions defined in only one architecture have only one mnemonic; GNU CC uses that mnemonic irrespective of which of these options is specified. PowerPC assemblers support both the old and new mnemonics, as will later POWER assemblers. Current POWER assemblers only support the old mnemonics. Specify `-mnew-mnemonics' if you have an assembler that supports them, otherwise specify `-mold-mnemonics'. The default value of these options depends on how GNU CC was configured. Specifying `-mcpu=cpu_type' sometimes overrides the value of these option. Unless you are building a cross-compiler, you should normally not specify either `-mnew-mnemonics' or `-mold-mnemonics', but should instead accept the default.
-mcpu=cpu_type
Set architecture type, register usage, choice of mnemonics, and instruction scheduling parameters for machine type cpu_type. Supported values for cpu_type are `rs6000', `rios1', `rios2', `rsc', `601', `602', `603', `603e', `604', `604e', `620', `power', `power2', `powerpc', `403', `505', `801', `821', `823', and `860' and `common'. `-mcpu=power', `-mcpu=power2', and `-mcpu=powerpc' specify generic POWER, POWER2 and pure PowerPC (i.e., not MPC601) architecture machine types, with an appropriate, generic processor model assumed for scheduling purposes. Specifying any of the following options: `-mcpu=rios1', `-mcpu=rios2', `-mcpu=rsc', `-mcpu=power', or `-mcpu=power2' enables the `-mpower' option and disables the `-mpowerpc' option; `-mcpu=601' enables both the `-mpower' and `-mpowerpc' options. All of `-mcpu=602', `-mcpu=603', `-mcpu=603e', `-mcpu=604', `-mcpu=620', enable the `-mpowerpc' option and disable the `-mpower' option. Exactly similarly, all of `-mcpu=403', `-mcpu=505', `-mcpu=821', `-mcpu=860' and `-mcpu=powerpc' enable the `-mpowerpc' option and disable the `-mpower' option. `-mcpu=common' disables both the `-mpower' and `-mpowerpc' options. AIX versions 4 or greater selects `-mcpu=common' by default, so that code will operate on all members of the RS/6000 and PowerPC families. In that case, GNU CC will use only the instructions in the common subset of both architectures plus some special AIX common-mode calls, and will not use the MQ register. GNU CC assumes a generic processor model for scheduling purposes. Specifying any of the options `-mcpu=rios1', `-mcpu=rios2', `-mcpu=rsc', `-mcpu=power', or `-mcpu=power2' also disables the `new-mnemonics' option. Specifying `-mcpu=601', `-mcpu=602', `-mcpu=603', `-mcpu=603e', `-mcpu=604', `620', `403', or `-mcpu=powerpc' also enables the `new-mnemonics' option. Specifying `-mcpu=403', `-mcpu=821', or `-mcpu=860' also enables the `-msoft-float' option.
-mtune=cpu_type
Set the instruction scheduling parameters for machine type cpu_type, but do not set the architecture type, register usage, choice of mnemonics like `-mcpu='cpu_type would. The same values for cpu_type are used for `-mtune='cpu_type as for `-mcpu='cpu_type. The `-mtune='cpu_type option overrides the `-mcpu='cpu_type option in terms of instruction scheduling parameters.
-mfull-toc
-mno-fp-in-toc
-mno-sum-in-toc
-mminimal-toc
Modify generation of the TOC (Table Of Contents), which is created for every executable file. The `-mfull-toc' option is selected by default. In that case, GNU CC will allocate at least one TOC entry for each unique non-automatic variable reference in your program. GNU CC will also place floating-point constants in the TOC. However, only 16,384 entries are available in the TOC. If you receive a linker error message that saying you have overflowed the available TOC space, you can reduce the amount of TOC space used with the `-mno-fp-in-toc' and `-mno-sum-in-toc' options. `-mno-fp-in-toc' prevents GNU CC from putting floating-point constants in the TOC and `-mno-sum-in-toc' forces GNU CC to generate code to calculate the sum of an address and a constant at run-time instead of putting that sum into the TOC. You may specify one or both of these options. Each causes GNU CC to produce very slightly slower and larger code at the expense of conserving TOC space. If you still run out of space in the TOC even when you specify both of these options, specify `-mminimal-toc' instead. This option causes GNU CC to make only one TOC entry for every file. When you specify this option, GNU CC will produce code that is slower and larger but which uses extremely little TOC space. You may wish to use this option only on files that contain less frequently executed code.
-mxl-call
-mno-xl-call
On AIX, pass floating-point arguments to prototyped functions beyond the register save area (RSA) on the stack in addition to argument FPRs. The AIX calling convention was extended but not initially documented to handle an obscure K&R C case of calling a function that takes the address of its arguments with fewer arguments than declared. AIX XL compilers assume that floating point arguments which do not fit in the RSA are on the stack when they compile a subroutine without optimization. Because always storing floating-point arguments on the stack is inefficient and rarely needed, this option is not enabled by default and only is necessary when calling subroutines compiled by AIX XL compilers without optimization.
-mthreads
Support AIX Threads. Link an application written to use pthreads with special libraries and startup code to enable the application to run.
-mpe
Support IBM RS/6000 SP Parallel Environment (PE). Link an application written to use message passing with special startup code to enable the application to run. The system must have PE installed in the standard location (`/usr/lpp/ppe.poe/'), or the `specs' file must be overridden with the `-specs=' option to specify the appropriate directory location. The Parallel Environment does not support threads, so the `-mpe' option and the `-mthreads' option are incompatible.
-msoft-float
-mhard-float
Generate code that does not use (uses) the floating-point register set. Software floating point emulation is provided if you use the `-msoft-float' option, and pass the option to GNU CC when linking.
-mmultiple
-mno-multiple
Generate code that uses (does not use) the load multiple word instructions and the store multiple word instructions. These instructions are generated by default on POWER systems, and not generated on PowerPC systems. Do not use `-mmultiple' on little endian PowerPC systems, since those instructions do not work when the processor is in little endian mode.
-mstring
-mno-string
Generate code that uses (does not use) the load string instructions and the store string word instructions to save multiple registers and do small block moves. These instructions are generated by default on POWER systems, and not generated on PowerPC systems. Do not use `-mstring' on little endian PowerPC systems, since those instructions do not work when the processor is in little endian mode.
-mupdate
-mno-update
Generate code that uses (does not use) the load or store instructions that update the base register to the address of the calculated memory location. These instructions are generated by default. If you use `-mno-update', there is a small window between the time that the stack pointer is updated and the address of the previous frame is stored, which means code that walks the stack frame across interrupts or signals may get corrupted data.
-mfused-madd
-mno-fused-madd
Generate code that uses (does not use) the floating point multiply and accumulate instructions. These instructions are generated by default if hardware floating is used.
-mno-bit-align
-mbit-align
On System V.4 and embedded PowerPC systems do not (do) force structures and unions that contain bit fields to be aligned to the base type of the bit field. For example, by default a structure containing nothing but 8 unsigned bitfields of length 1 would be aligned to a 4 byte boundary and have a size of 4 bytes. By using `-mno-bit-align', the structure would be aligned to a 1 byte boundary and be one byte in size.
-mno-strict-align
-mstrict-align
On System V.4 and embedded PowerPC systems do not (do) assume that unaligned memory references will be handled by the system.
-mrelocatable
-mno-relocatable
On embedded PowerPC systems generate code that allows (does not allow) the program to be relocated to a different address at runtime. If you use `-mrelocatable' on any module, all objects linked together must be compiled with `-mrelocatable' or `-mrelocatable-lib'.
-mrelocatable-lib
-mno-relocatable-lib
On embedded PowerPC systems generate code that allows (does not allow) the program to be relocated to a different address at runtime. Modules compiled with `-mreloctable-lib' can be linked with either modules compiled without `-mrelocatable' and `-mrelocatable-lib' or with modules compiled with the `-mrelocatable' options.
-mno-toc
-mtoc
On System V.4 and embedded PowerPC systems do not (do) assume that register 2 contains a pointer to a global area pointing to the addresses used in the program.
-mno-traceback
-mtraceback
On embedded PowerPC systems do not (do) generate a traceback tag before the start of the function. This tag can be used by the debugger to identify where the start of a function is.
-mlittle
-mlittle-endian
On System V.4 and embedded PowerPC systems compile code for the processor in little endian mode. The `-mlittle-endian' option is the same as `-mlittle'.
-mbig
-mbig-endian
On System V.4 and embedded PowerPC systems compile code for the processor in big endian mode. The `-mbig-endian' option is the same as `-mbig'.
-mcall-sysv
On System V.4 and embedded PowerPC systems compile code using calling conventions that adheres to the March 1995 draft of the System V Application Binary Interface, PowerPC processor supplement. This is the default unless you configured GCC using `powerpc-*-eabiaix'.
-mcall-sysv-eabi
Specify both `-mcall-sysv' and `-meabi' options.
-mcall-sysv-noeabi
Specify both `-mcall-sysv' and `-mno-eabi' options.
-mcall-aix
On System V.4 and embedded PowerPC systems compile code using calling conventions that are similar to those used on AIX. This is the default if you configured GCC using `powerpc-*-eabiaix'.
-mcall-solaris
On System V.4 and embedded PowerPC systems compile code for the Solaris operating system.
-mcall-linux
On System V.4 and embedded PowerPC systems compile code for the Linux-based GNU system.
-mprototype
-mno-prototype
On System V.4 and embedded PowerPC systems assume that all calls to variable argument functions are properly prototyped. Otherwise, the compiler must insert an instruction before every non prototyped call to set or clear bit 6 of the condition code register (CR) to indicate whether floating point values were passed in the floating point registers in case the function takes a variable arguments. With `-mprototype', only calls to prototyped variable argument functions will set or clear the bit.
-msim
On embedded PowerPC systems, assume that the startup module is called `sim-crt0.o' and that the standard C libraries are `libsim.a' and `libc.a'. This is the default for `powerpc-*-eabisim'. configurations.
-mmvme
On embedded PowerPC systems, assume that the startup module is called `mvme-crt0.o' and the standard C libraries are `libmvme.a' and `libc.a'.
-memb
On embedded PowerPC systems, set the PPC_EMB bit in the ELF flags header to indicate that `eabi' extended relocations are used.
-meabi
-mno-eabi
On System V.4 and embedded PowerPC systems do (do not) adhere to the Embedded Applications Binary Interface (eabi) which is a set of modifications to the System V.4 specifications. Selecting -meabi means that the stack is aligned to an 8 byte boundary, a function __eabi is called to from main to set up the eabi environment, and the `-msdata' option can use both r2 and r13 to point to two separate small data areas. Selecting -mno-eabi means that the stack is aligned to a 16 byte boundary, do not call an initialization function from main, and the `-msdata' option will only use r13 to point to a single small data area. The `-meabi' option is on by default if you configured GCC using one of the `powerpc*-*-eabi*' options.
-msdata=eabi
On System V.4 and embedded PowerPC systems, put small initialized const global and static data in the `.sdata2' section, which is pointed to by register r2. Put small initialized non-const global and static data in the `.sdata' section, which is pointed to by register r13. Put small uninitialized global and static data in the `.sbss' section, which is adjacent to the `.sdata' section. The `-msdata=eabi' option is incompatible with the `-mrelocatable' option. The `-msdata=eabi' option also sets the `-memb' option.
-msdata=sysv
On System V.4 and embedded PowerPC systems, put small global and static data in the `.sdata' section, which is pointed to by register r13. Put small uninitialized global and static data in the `.sbss' section, which is adjacent to the `.sdata' section. The `-msdata=sysv' option is incompatible with the `-mrelocatable' option.
-msdata=default
-msdata
On System V.4 and embedded PowerPC systems, if `-meabi' is used, compile code the same as `-msdata=eabi', otherwise compile code the same as `-msdata=sysv'.
-msdata-data
On System V.4 and embedded PowerPC systems, put small global and static data in the `.sdata' section. Put small uninitialized global and static data in the `.sbss' section. Do not use register r13 to address small data however. This is the default behavior unless other `-msdata' options are used.
-msdata=none
-mno-sdata
On embedded PowerPC systems, put all initialized global and static data in the `.data' section, and all uninitialized data in the `.bss' section.
-G num
On embbeded PowerPC systems, put global and static items less than or equal to num bytes into the small data or bss sections instead of the normal data or bss section. By default, num is 8. The `-G num' switch is also passed to the linker. All modules should be compiled with the same `-G num' value.
-mregnames
-mno-regnames
On System V.4 and embedded PowerPC systems do (do not) emit register names in the assembly language output using symbolic forms.


Using and Porting GNU CC - RT Options

IBM RT Options

These `-m' options are defined for the IBM RT PC:

-min-line-mul
Use an in-line code sequence for integer multiplies. This is the default.
-mcall-lib-mul
Call lmul$$ for integer multiples.
-mfull-fp-blocks
Generate full-size floating point data blocks, including the minimum amount of scratch space recommended by IBM. This is the default.
-mminimum-fp-blocks
Do not include extra scratch space in floating point data blocks. This results in smaller code, but slower execution, since scratch space must be allocated dynamically.
-mfp-arg-in-fpregs
Use a calling sequence incompatible with the IBM calling convention in which floating point arguments are passed in floating point registers. Note that varargs.h and stdargs.h will not work with floating point operands if this option is specified.
-mfp-arg-in-gregs
Use the normal calling convention for floating point arguments. This is the default.
-mhc-struct-return
Return structures of more than one word in memory, rather than in a register. This provides compatibility with the MetaWare HighC (hc) compiler. Use the option `-fpcc-struct-return' for compatibility with the Portable C Compiler (pcc).
-mnohc-struct-return
Return some structures of more than one word in registers, when convenient. This is the default. For compatibility with the IBM-supplied compilers, use the option `-fpcc-struct-return' or the option `-mhc-struct-return'.


Using and Porting GNU CC - MIPS Options

MIPS Options

These `-m' options are defined for the MIPS family of computers:

-mcpu=cpu type
Assume the defaults for the machine type cpu type when scheduling instructions. The choices for cpu type are `r2000', `r3000', `r4000', `r4400', `r4600', and `r6000'. While picking a specific cpu type will schedule things appropriately for that particular chip, the compiler will not generate any code that does not meet level 1 of the MIPS ISA (instruction set architecture) without the `-mips2' or `-mips3' switches being used.
-mips1
Issue instructions from level 1 of the MIPS ISA. This is the default. `r3000' is the default cpu type at this ISA level.
-mips2
Issue instructions from level 2 of the MIPS ISA (branch likely, square root instructions). `r6000' is the default cpu type at this ISA level.
-mips3
Issue instructions from level 3 of the MIPS ISA (64 bit instructions). `r4000' is the default cpu type at this ISA level. This option does not change the sizes of any of the C data types.
-mfp32
Assume that 32 32-bit floating point registers are available. This is the default.
-mfp64
Assume that 32 64-bit floating point registers are available. This is the default when the `-mips3' option is used.
-mgp32
Assume that 32 32-bit general purpose registers are available. This is the default.
-mgp64
Assume that 32 64-bit general purpose registers are available. This is the default when the `-mips3' option is used.
-mint64
Types long, int, and pointer are 64 bits. This works only if `-mips3' is also specified.
-mlong64
Types long and pointer are 64 bits, and type int is 32 bits. This works only if `-mips3' is also specified.
-mmips-as
Generate code for the MIPS assembler, and invoke `mips-tfile' to add normal debug information. This is the default for all platforms except for the OSF/1 reference platform, using the OSF/rose object format. If the either of the `-gstabs' or `-gstabs+' switches are used, the `mips-tfile' program will encapsulate the stabs within MIPS ECOFF.
-mgas
Generate code for the GNU assembler. This is the default on the OSF/1 reference platform, using the OSF/rose object format. Also, this is the default if the configure option `--with-gnu-as' is used.
-msplit-addresses
-mno-split-addresses
Generate code to load the high and low parts of address constants separately. This allows gcc to optimize away redundant loads of the high order bits of addresses. This optimization requires GNU as and GNU ld. This optimization is enabled by default for some embedded targets where GNU as and GNU ld are standard.
-mrnames
-mno-rnames
The `-mrnames' switch says to output code using the MIPS software names for the registers, instead of the hardware names (ie, a0 instead of $4). The only known assembler that supports this option is the Algorithmics assembler.
-mgpopt
-mno-gpopt
The `-mgpopt' switch says to write all of the data declarations before the instructions in the text section, this allows the MIPS assembler to generate one word memory references instead of using two words for short global or static data items. This is on by default if optimization is selected.
-mstats
-mno-stats
For each non-inline function processed, the `-mstats' switch causes the compiler to emit one line to the standard error file to print statistics about the program (number of registers saved, stack size, etc.).
-mmemcpy
-mno-memcpy
The `-mmemcpy' switch makes all block moves call the appropriate string function (`memcpy' or `bcopy') instead of possibly generating inline code.
-mmips-tfile
-mno-mips-tfile
The `-mno-mips-tfile' switch causes the compiler not postprocess the object file with the `mips-tfile' program, after the MIPS assembler has generated it to add debug support. If `mips-tfile' is not run, then no local variables will be available to the debugger. In addition, `stage2' and `stage3' objects will have the temporary file names passed to the assembler embedded in the object file, which means the objects will not compare the same. The `-mno-mips-tfile' switch should only be used when there are bugs in the `mips-tfile' program that prevents compilation.
-msoft-float
Generate output containing library calls for floating point. Warning: the requisite libraries are not part of GNU CC. Normally the facilities of the machine's usual C compiler are used, but this can't be done directly in cross-compilation. You must make your own arrangements to provide suitable library functions for cross-compilation.
-mhard-float
Generate output containing floating point instructions. This is the default if you use the unmodified sources.
-mabicalls
-mno-abicalls
Emit (or do not emit) the pseudo operations `.abicalls', `.cpload', and `.cprestore' that some System V.4 ports use for position independent code.
-mlong-calls
-mno-long-calls
Do all calls with the `JALR' instruction, which requires loading up a function's address into a register before the call. You need to use this switch, if you call outside of the current 512 megabyte segment to functions that are not through pointers.
-mhalf-pic
-mno-half-pic
Put pointers to extern references into the data section and load them up, rather than put the references in the text section.
-membedded-pic
-mno-embedded-pic
Generate PIC code suitable for some embedded systems. All calls are made using PC relative address, and all data is addressed using the $gp register. This requires GNU as and GNU ld which do most of the work.
-membedded-data
-mno-embedded-data
Allocate variables to the read-only data section first if possible, then next in the small data section if possible, otherwise in data. This gives slightly slower code than the default, but reduces the amount of RAM required when executing, and thus may be preferred for some embedded systems.
-msingle-float
-mdouble-float
The `-msingle-float' switch tells gcc to assume that the floating point coprocessor only supports single precision operations, as on the `r4650' chip. The `-mdouble-float' switch permits gcc to use double precision operations. This is the default.
-mmad
-mno-mad
Permit use of the `mad', `madu' and `mul' instructions, as on the `r4650' chip.
-m4650
Turns on `-msingle-float', `-mmad', and, at least for now, `-mcpu=r4650'.
-EL
Compile code for the processor in little endian mode. The requisite libraries are assumed to exist.
-EB
Compile code for the processor in big endian mode. The requisite libraries are assumed to exist.
-G num
Put global and static items less than or equal to num bytes into the small data or bss sections instead of the normal data or bss section. This allows the assembler to emit one word memory reference instructions based on the global pointer (gp or $28), instead of the normal two words used. By default, num is 8 when the MIPS assembler is used, and 0 when the GNU assembler is used. The `-G num' switch is also passed to the assembler and linker. All modules should be compiled with the same `-G num' value.
-nocpp
Tell the MIPS assembler to not run it's preprocessor over user assembler files (with a `.s' suffix) when assembling them.

These options are defined by the macro TARGET_SWITCHES in the machine description. The default for the options is also defined by that macro, which enables you to change the defaults.


Using and Porting GNU CC - i386 Options

Intel 386 Options

These `-m' options are defined for the i386 family of computers:

-mcpu=cpu type
Assume the defaults for the machine type cpu type when scheduling instructions. The choices for cpu type are: `i386', `i486', `i586' (`pentium'), `pentium', `i686' (`pentiumpro') and `pentiumpro'. While picking a specific cpu type will schedule things appropriately for that particular chip, the compiler will not generate any code that does not run on the i386 without the `-march=cpu type' option being used.
-march=cpu type
Generate instructions for the machine type cpu type. The choices for cpu type are: `i386', `i486', `pentium', and `pentiumpro'. Specifying `-march=cpu type' implies `-mcpu=cpu type'.
-m386
-m486
-mpentium
-mpentiumpro
Synonyms for -mcpu=i386, -mcpu=i486, -mcpu=pentium, and -mcpu=pentiumpro respectively.
-mieee-fp
-mno-ieee-fp
Control whether or not the compiler uses IEEE floating point comparisons. These handle correctly the case where the result of a comparison is unordered.
-msoft-float
Generate output containing library calls for floating point. Warning: the requisite libraries are not part of GNU CC. Normally the facilities of the machine's usual C compiler are used, but this can't be done directly in cross-compilation. You must make your own arrangements to provide suitable library functions for cross-compilation. On machines where a function returns floating point results in the 80387 register stack, some floating point opcodes may be emitted even if `-msoft-float' is used.
-mno-fp-ret-in-387
Do not use the FPU registers for return values of functions. The usual calling convention has functions return values of types float and double in an FPU register, even if there is no FPU. The idea is that the operating system should emulate an FPU. The option `-mno-fp-ret-in-387' causes such values to be returned in ordinary CPU registers instead.
-mno-fancy-math-387
Some 387 emulators do not support the sin, cos and sqrt instructions for the 387. Specify this option to avoid generating those instructions. This option is the default on FreeBSD. As of revision 2.6.1, these instructions are not generated unless you also use the `-ffast-math' switch.
-malign-double
-mno-align-double
Control whether GNU CC aligns double, long double, and long long variables on a two word boundary or a one word boundary. Aligning double variables on a two word boundary will produce code that runs somewhat faster on a `Pentium' at the expense of more memory. Warning: if you use the `-malign-double' switch, structures containing the above types will be aligned differently than the published application binary interface specifications for the 386.
-msvr3-shlib
-mno-svr3-shlib
Control whether GNU CC places uninitialized locals into bss or data. `-msvr3-shlib' places these locals into bss. These options are meaningful only on System V Release 3.
-mno-wide-multiply
-mwide-multiply
Control whether GNU CC uses the mul and imul that produce 64 bit results in eax:edx from 32 bit operands to do long long multiplies and 32-bit division by constants.
-mrtd
Use a different function-calling convention, in which functions that take a fixed number of arguments return with the ret num instruction, which pops their arguments while returning. This saves one instruction in the caller since there is no need to pop the arguments there. You can specify that an individual function is called with this calling sequence with the function attribute `stdcall'. You can also override the `-mrtd' option by using the function attribute `cdecl'. See section Declaring Attributes of Functions Warning: this calling convention is incompatible with the one normally used on Unix, so you cannot use it if you need to call libraries compiled with the Unix compiler. Also, you must provide function prototypes for all functions that take variable numbers of arguments (including printf); otherwise incorrect code will be generated for calls to those functions. In addition, seriously incorrect code will result if you call a function with too many arguments. (Normally, extra arguments are harmlessly ignored.)
-mreg-alloc=regs
Control the default allocation order of integer registers. The string regs is a series of letters specifying a register. The supported letters are: a allocate EAX; b allocate EBX; c allocate ECX; d allocate EDX; S allocate ESI; D allocate EDI; B allocate EBP.
-mregparm=num
Control how many registers are used to pass integer arguments. By default, no registers are used to pass arguments, and at most 3 registers can be used. You can control this behavior for a specific function by using the function attribute `regparm'. See section Declaring Attributes of Functions Warning: if you use this switch, and num is nonzero, then you must build all modules with the same value, including any libraries. This includes the system libraries and startup modules.
-malign-loops=num
Align loops to a 2 raised to a num byte boundary. If `-malign-loops' is not specified, the default is 2.
-malign-jumps=num
Align instructions that are only jumped to to a 2 raised to a num byte boundary. If `-malign-jumps' is not specified, the default is 2 if optimizing for a 386, and 4 if optimizing for a 486.
-malign-functions=num
Align the start of functions to a 2 raised to num byte boundary. If `-malign-functions' is not specified, the default is 2 if optimizing for a 386, and 4 if optimizing for a 486.


Using and Porting GNU CC - HPPA Options

HPPA Options

These `-m' options are defined for the HPPA family of computers:

-mpa-risc-1-0
Generate code for a PA 1.0 processor.
-mpa-risc-1-1
Generate code for a PA 1.1 processor.
-mbig-switch
Generate code suitable for big switch tables. Use this option only if the assembler/linker complain about out of range branches within a switch table.
-mjump-in-delay
Fill delay slots of function calls with unconditional jump instructions by modifying the return pointer for the function call to be the target of the conditional jump.
-mdisable-fpregs
Prevent floating point registers from being used in any manner. This is necessary for compiling kernels which perform lazy context switching of floating point registers. If you use this option and attempt to perform floating point operations, the compiler will abort.
-mdisable-indexing
Prevent the compiler from using indexing address modes. This avoids some rather obscure problems when compiling MIG generated code under MACH.
-mno-space-regs
Generate code that assumes the target has no space registers. This allows GCC to generate faster indirect calls and use unscaled index address modes. Such code is suitable for level 0 PA systems and kernels.
-mfast-indirect-calls
Generate code that assumes calls never cross space boundaries. This allows GCC to emit code which performs faster indirect calls. This option will not work in the presense of shared libraries or nested functions.
-mspace
Optimize for space rather than execution time. Currently this only enables out of line function prologues and epilogues. This option is incompatable with PIC code generation and profiling.
-mlong-load-store
Generate 3-instruction load and store sequences as sometimes required by the HP-UX 10 linker. This is equivalent to the `+k' option to the HP compilers.
-mportable-runtime
Use the portable calling conventions proposed by HP for ELF systems.
-mgas
Enable the use of assembler directives only GAS understands.
-mschedule=cpu type
Schedule code according to the constraints for the machine type cpu type. The choices for cpu type are `700' for 7n0 machines, `7100' for 7n5 machines, and `7100' for 7n2 machines. `7100' is the default for cpu type. Note the `7100LC' scheduling information is incomplete and using `7100LC' often leads to bad schedules. For now it's probably best to use `7100' instead of `7100LC' for the 7n2 machines.
-mlinker-opt
Enable the optimization pass in the HPUX linker. Note this makes symbolic debugging impossible. It also triggers a bug in the HPUX 8 and HPUX 9 linkers in which they give bogus error messages when linking some programs.
-msoft-float
Generate output containing library calls for floating point. Warning: the requisite libraries are not available for all HPPA targets. Normally the facilities of the machine's usual C compiler are used, but this cannot be done directly in cross-compilation. You must make your own arrangements to provide suitable library functions for cross-compilation. The embedded target `hppa1.1-*-pro' does provide software floating point support. `-msoft-float' changes the calling convention in the output file; therefore, it is only useful if you compile all of a program with this option. In particular, you need to compile `libgcc.a', the library that comes with GNU CC, with `-msoft-float' in order for this to work.


Using and Porting GNU CC - Intel 960 Options

Intel 960 Options

These `-m' options are defined for the Intel 960 implementations:

-mcpu type
Assume the defaults for the machine type cpu type for some of the other options, including instruction scheduling, floating point support, and addressing modes. The choices for cpu type are `ka', `kb', `mc', `ca', `cf', `sa', and `sb'. The default is `kb'.
-mnumerics
-msoft-float
The `-mnumerics' option indicates that the processor does support floating-point instructions. The `-msoft-float' option indicates that floating-point support should not be assumed.
-mleaf-procedures
-mno-leaf-procedures
Do (or do not) attempt to alter leaf procedures to be callable with the bal instruction as well as call. This will result in more efficient code for explicit calls when the bal instruction can be substituted by the assembler or linker, but less efficient code in other cases, such as calls via function pointers, or using a linker that doesn't support this optimization.
-mtail-call
-mno-tail-call
Do (or do not) make additional attempts (beyond those of the machine-independent portions of the compiler) to optimize tail-recursive calls into branches. You may not want to do this because the detection of cases where this is not valid is not totally complete. The default is `-mno-tail-call'.
-mcomplex-addr
-mno-complex-addr
Assume (or do not assume) that the use of a complex addressing mode is a win on this implementation of the i960. Complex addressing modes may not be worthwhile on the K-series, but they definitely are on the C-series. The default is currently `-mcomplex-addr' for all processors except the CB and CC.
-mcode-align
-mno-code-align
Align code to 8-byte boundaries for faster fetching (or don't bother). Currently turned on by default for C-series implementations only.
-mic-compat
-mic2.0-compat
-mic3.0-compat
Enable compatibility with iC960 v2.0 or v3.0.
-masm-compat
-mintel-asm
Enable compatibility with the iC960 assembler.
-mstrict-align
-mno-strict-align
Do not permit (do permit) unaligned accesses.
-mold-align
Enable structure-alignment compatibility with Intel's gcc release version 1.3 (based on gcc 1.37). This option implies `-mstrict-align'.


Using and Porting GNU CC - DEC Alpha Options

DEC Alpha Options

These `-m' options are defined for the DEC Alpha implementations:

-mno-soft-float
-msoft-float
Use (do not use) the hardware floating-point instructions for floating-point operations. When -msoft-float is specified, functions in `libgcc1.c' will be used to perform floating-point operations. Unless they are replaced by routines that emulate the floating-point operations, or compiled in such a way as to call such emulations routines, these routines will issue floating-point operations. If you are compiling for an Alpha without floating-point operations, you must ensure that the library is built so as not to call them. Note that Alpha implementations without floating-point operations are required to have floating-point registers.
-mfp-reg
-mno-fp-regs
Generate code that uses (does not use) the floating-point register set. -mno-fp-regs implies -msoft-float. If the floating-point register set is not used, floating point operands are passed in integer registers as if they were integers and floating-point results are passed in $0 instead of $f0. This is a non-standard calling sequence, so any function with a floating-point argument or return value called by code compiled with -mno-fp-regs must also be compiled with that option. A typical use of this option is building a kernel that does not use, and hence need not save and restore, any floating-point registers.
-mieee
The Alpha architecture implements floating-point hardware optimized for maximum performance. It is mostly compliant with the IEEE floating point standard. However, for full compliance, software assistance is required. This option generates code fully IEEE compliant code except that the inexact flag is not maintained (see below). If this option is turned on, the CPP macro _IEEE_FP is defined during compilation. The option is a shorthand for: `-D_IEEE_FP -mfp-trap-mode=su -mtrap-precision=i -mieee-conformant'. The resulting code is less efficient but is able to correctly support denormalized numbers and exceptional IEEE values such as not-a-number and plus/minus infinity. Other Alpha compilers call this option -ieee_with_no_inexact.
-mieee-with-inexact
This is like `-mieee' except the generated code also maintains the IEEE inexact flag. Turning on this option causes the generated code to implement fully-compliant IEEE math. The option is a shorthand for `-D_IEEE_FP -D_IEEE_FP_INEXACT' plus the three following: `-mieee-conformant', `-mfp-trap-mode=sui', and `-mtrap-precision=i'. On some Alpha implementations the resulting code may execute significantly slower than the code generated by default. Since there is very little code that depends on the inexact flag, you should normally not specify this option. Other Alpha compilers call this option `-ieee_with_inexact'.
-mfp-trap-mode=trap mode
This option controls what floating-point related traps are enabled. Other Alpha compilers call this option `-fptm 'trap mode. The trap mode can be set to one of four values:
`n'
This is the default (normal) setting. The only traps that are enabled are the ones that cannot be disabled in software (e.g., division by zero trap).
`u'
In addition to the traps enabled by `n', underflow traps are enabled as well.
`su'
Like `su', but the instructions are marked to be safe for software completion (see Alpha architecture manual for details).
`sui'
Like `su', but inexact traps are enabled as well.
-mfp-rounding-mode=rounding mode
Selects the IEEE rounding mode. Other Alpha compilers call this option `-fprm 'rounding mode. The rounding mode can be one of:
`n'
Normal IEEE rounding mode. Floating point numbers are rounded towards the nearest machine number or towards the even machine number in case of a tie.
`m'
Round towards minus infinity.
`c'
Chopped rounding mode. Floating point numbers are rounded towards zero.
`d'
Dynamic rounding mode. A field in the floating point control register (fpcr, see Alpha architecture reference manual) controls the rounding mode in effect. The C library initializes this register for rounding towards plus infinity. Thus, unless your program modifies the fpcr, `d' corresponds to round towards plus infinity.@end table
`-mtrap-precision=trap precision'
In the Alpha architecture, floating point traps are imprecise. This means without software assistance it is impossible to recover from a floating trap and program execution normally needs to be terminated. GNU CC can generate code that can assist operating system trap handlers in determining the exact location that caused a floating point trap. Depending on the requirements of an application, different levels of precisions can be selected:
`p'
Program precision. This option is the default and means a trap handler can only identify which program caused a floating point exception.
`f'
Function precision. The trap handler can determine the function that caused a floating point exception.
`i'
Instruction precision. The trap handler can determine the exact instruction that caused a floating point exception.
Other Alpha compilers provide the equivalent options called `-scope_safe' and `-resumption_safe'.
`-mieee-conformant'
This option marks the generated code as IEEE conformant. You must not use this option unless you also specify `-mtrap-precision=i' and either `-mfp-trap-mode=su' or `-mfp-trap-mode=sui'. Its only effect is to emit the line `.eflag 48' in the function prologue of the generated assembly file. Under DEC Unix, this has the effect that IEEE-conformant math library routines will be linked in.
`-mbuild-constants'
Normally GNU CC examines a 32- or 64-bit integer constant to see if it can construct it from smaller constants in two or three instructions. If it cannot, it will output the constant as a literal and generate code to load it from the data segement at runtime. Use this option to require GNU CC to construct all integer constants using code, even if it takes more instructions (the maximum is six). You would typically use this option to build a shared library dynamic loader. Itself a shared library, it must relocate itself in memory before it can find the variables and constants in its own data segment.


Using and Porting GNU CC - Clipper Options

Clipper Options

These `-m' options are defined for the Clipper implementations:

-mc300
Produce code for a C300 Clipper processor. This is the default.
-mc400
Produce code for a C400 Clipper processor i.e. use floating point registers f8..f15.


Using and Porting GNU CC - H8/300 Options

H8/300 Options

These `-m' options are defined for the H8/300 implementations:

-mrelax
Shorten some address references at link time, when possible; uses the linker option `-relax'. See section `ld and the H8/300' in Using ld, for a fuller description.
-mh
Generate code for the H8/300H.
-ms
Generate code for the H8/S.
-mint32
Make int data 32 bits by default.
-malign-300
On the h8/300h, use the same alignment rules as for the h8/300. The default for the h8/300h is to align longs and floats on 4 byte boundaries. `-malign-300' causes them to be aligned on 2 byte boundaries. This option has no effect on the h8/300.


Using and Porting GNU CC - SH Options

SH Options

These `-m' options are defined for the SH implementations:

-m1
Generate code for the SH1.
-m2
Generate code for the SH2.
-m3
Generate code for the SH3.
-m3e
Generate code for the SH3e.
-mb
Compile code for the processor in big endian mode.
-ml
Compile code for the processor in little endian mode.
-mrelax
Shorten some address references at link time, when possible; uses the linker option `-relax'.


Using and Porting GNU CC - System V Options

Options for System V

These additional options are available on System V Release 4 for compatibility with other compilers on those systems:

-G
Create a shared object. It is recommended that `-symbolic' or `-shared' be used instead.
-Qy
Identify the versions of each tool used by the compiler, in a .ident assembler directive in the output.
-Qn
Refrain from adding .ident directives to the output file (this is the default).
-YP,dirs
Search the directories dirs, and no others, for libraries specified with `-l'.
-Ym,dir
Look in the directory dir to find the M4 preprocessor. The assembler uses this option.


Using and Porting GNU CC - V850 Options

V850 Options

These `-m' options are defined for V850 implementations:

-mlong-calls
-mno-long-calls
Treat all calls as being far away (near). If calls are assumed to be far away, the compiler will always load the functions address up into a register, and call indirect through the pointer.
-mno-ep
-mep
Do not optimize (do optimize) basic blocks that use the same index pointer 4 or more times to copy pointer into the ep register, and use the shorter sld and sst instructions. The `-mep' option is on by default if you optimize.
-mno-prolog-function
-mprolog-function
Do not use (do use) external functions to save and restore registers at the prolog and epilog of a function. The external functions are slower, but use less code space if more than one function saves the same number of registers. The `-mprolog-function' option is on by default if you optimize.
-mspace
Try to make the code as small as possible. At present, this just turns on the `-mep' and `-mprolog-function' options.
-mtda=n
Put static or global variables whose size is n bytes or less into the tiny data area that register ep points to. The tiny data area can hold up to 256 bytes in total (128 bytes for byte references).
-msda=n
Put static or global variables whose size is n bytes or less into the small data area that register gp points to. The small data area can hold up to 64 kilobytes.
-mzda=n
Put static or global variables whose size is n bytes or less into the first 32 kilobytes of memory.
-mv850
Specify that the target processor is the V850.


Using and Porting GNU CC - Code Gen Options

Options for Code Generation Conventions

These machine-independent options control the interface conventions used in code generation.

Most of them have both positive and negative forms; the negative form of `-ffoo' would be `-fno-foo'. In the table below, only one of the forms is listed--the one which is not the default. You can figure out the other form by either removing `no-' or adding it.

-fpcc-struct-return
Return "short" struct and union values in memory like longer ones, rather than in registers. This convention is less efficient, but it has the advantage of allowing intercallability between GNU CC-compiled files and files compiled with other compilers. The precise convention for returning structures in memory depends on the target configuration macros. Short structures and unions are those whose size and alignment match that of some integer type.
-freg-struct-return
Use the convention that struct and union values are returned in registers when possible. This is more efficient for small structures than `-fpcc-struct-return'. If you specify neither `-fpcc-struct-return' nor its contrary `-freg-struct-return', GNU CC defaults to whichever convention is standard for the target. If there is no standard convention, GNU CC defaults to `-fpcc-struct-return', except on targets where GNU CC is the principal compiler. In those cases, we can choose the standard, and we chose the more efficient register return alternative.
-fshort-enums
Allocate to an enum type only as many bytes as it needs for the declared range of possible values. Specifically, the enum type will be equivalent to the smallest integer type which has enough room.
-fshort-double
Use the same size for double as for float.
-fshared-data
Requests that the data and non-const variables of this compilation be shared data rather than private data. The distinction makes sense only on certain operating systems, where shared data is shared between processes running the same program, while private data exists in one copy per process.
-fno-common
Allocate even uninitialized global variables in the bss section of the object file, rather than generating them as common blocks. This has the effect that if the same variable is declared (without extern) in two different compilations, you will get an error when you link them. The only reason this might be useful is if you wish to verify that the program will work on other systems which always work this way.
-fno-ident
Ignore the `#ident' directive.
-fno-gnu-linker
Do not output global initializations (such as C++ constructors and destructors) in the form used by the GNU linker (on systems where the GNU linker is the standard method of handling them). Use this option when you want to use a non-GNU linker, which also requires using the collect2 program to make sure the system linker includes constructors and destructors. (collect2 is included in the GNU CC distribution.) For systems which must use collect2, the compiler driver gcc is configured to do this automatically.
-finhibit-size-directive
Don't output a .size assembler directive, or anything else that would cause trouble if the function is split in the middle, and the two halves are placed at locations far apart in memory. This option is used when compiling `crtstuff.c'; you should not need to use it for anything else.
-fverbose-asm
Put extra commentary information in the generated assembly code to make it more readable. This option is generally only of use to those who actually need to read the generated assembly code (perhaps while debugging the compiler itself). `-fverbose-asm' is the default. `-fno-verbose-asm' causes the extra information to be omitted and is useful when comparing two assembler files.
-fvolatile
Consider all memory references through pointers to be volatile.
-fvolatile-global
Consider all memory references to extern and global data items to be volatile.
-fpic
Generate position-independent code (PIC) suitable for use in a shared library, if supported for the target machine. Such code accesses all constant addresses through a global offset table (GOT). The dynamic loader resolves the GOT entries when the program starts (the dynamic loader is not part of GNU CC; it is part of the operating system). If the GOT size for the linked executable exceeds a machine-specific maximum size, you get an error message from the linker indicating that `-fpic' does not work; in that case, recompile with `-fPIC' instead. (These maximums are 16k on the m88k, 8k on the Sparc, and 32k on the m68k and RS/6000. The 386 has no such limit.) Position-independent code requires special support, and therefore works only on certain machines. For the 386, GNU CC supports PIC for System V but not for the Sun 386i. Code generated for the IBM RS/6000 is always position-independent.
-fPIC
If supported for the target machine, emit position-independent code, suitable for dynamic linking and avoiding any limit on the size of the global offset table. This option makes a difference on the m68k, m88k, and the Sparc. Position-independent code requires special support, and therefore works only on certain machines.
-ffixed-reg
Treat the register named reg as a fixed register; generated code should never refer to it (except perhaps as a stack pointer, frame pointer or in some other fixed role). reg must be the name of a register. The register names accepted are machine-specific and are defined in the REGISTER_NAMES macro in the machine description macro file. This flag does not have a negative form, because it specifies a three-way choice.
-fcall-used-reg
Treat the register named reg as an allocatable register that is clobbered by function calls. It may be allocated for temporaries or variables that do not live across a call. Functions compiled this way will not save and restore the register reg. Use of this flag for a register that has a fixed pervasive role in the machine's execution model, such as the stack pointer or frame pointer, will produce disastrous results. This flag does not have a negative form, because it specifies a three-way choice.
-fcall-saved-reg
Treat the register named reg as an allocatable register saved by functions. It may be allocated even for temporaries or variables that live across a call. Functions compiled this way will save and restore the register reg if they use it. Use of this flag for a register that has a fixed pervasive role in the machine's execution model, such as the stack pointer or frame pointer, will produce disastrous results. A different sort of disaster will result from the use of this flag for a register in which function values may be returned. This flag does not have a negative form, because it specifies a three-way choice.
-fpack-struct
Pack all structure members together without holes. Usually you would not want to use this option, since it makes the code suboptimal, and the offsets of structure members won't agree with system libraries.
-fcheck-memory-usage
Generate extra code to check each memory access. GNU CC will generate code that is suitable for a detector of bad memory accesses such as `Checker'. If you specify this option, you can not use the asm or __asm__ keywords. You must also specify this option when you compile functions you call that have side effects. If you do not, you may get erronous messages from the detector. Normally, you should compile all your code with this option. If you use functions from a library that have side-effects (such as read), you may not be able to recompile the library and specify this option. In that case, you can enable the `-fprefix-function-name' option, which requests GNU CC to encapsulate your code and make other functions look as if they were compiled with `-fcheck-memory-usage'. This is done by calling "stubs", which are provided by the detector. If you cannot find or build stubs for every function you call, you may have to specify `-fcheck-memory-usage' without `-fprefix-function-name'.
-fprefix-function-name
Request GNU CC to add a prefix to the symbols generated for function names. GNU CC adds a prefix to the names of functions defined as well as functions called. Code compiled with this option and code compiled without the option can't be linked together, unless or stubs are used. If you compile the following code with `-fprefix-function-name'
extern void bar (int);
void
foo (int a)
{
  return bar (a + 5);

}
GNU CC will compile the code as if it was written:
extern void prefix_bar (int);
void
prefix_foo (int a)
{
  return prefix_bar (a + 5);
}
This option is designed to be used with `-fcheck-memory-usage'.
-fstack-check
Generate code to verify that you do not go beyond the boundary of the stack. You should specify this flag if you are running in an environment with multiple threads, but only rarely need to specify it in a single-threaded environment since stack overflow is automatically detected on nearly all systems if there is only one stack.
-fexceptions
Enable exception handling. For some targets, this implies generation of frame unwind information for all functions, which can produce significant data size overhead, though it does not affect execution. This option is on by default for languages that support exception handling (such as C++), and off for those that don't (such as C).
+e0
+e1
Control whether virtual function definitions in classes are used to generate code, or only to define interfaces for their callers. (C++ only). These options are provided for compatibility with cfront 1.x usage; the recommended alternative GNU C++ usage is in flux. See section Declarations and Definitions in One Header. With `+e0', virtual function definitions in classes are declared extern; the declaration is used only as an interface specification, not to generate code for the virtual functions (in this compilation). With `+e1', G++ actually generates the code implementing virtual functions defined in the code, and makes them publicly visible.
-fargument-alias
-fargument-noalias
-fargument-noalias-global
Specify the possible relationships among parameters and between parameters and global data. `-fargument-alias' specifies that arguments (parameters) may alias each other and may alias global storage. `-fargument-noalias' specifies that arguments do not alias each other, but may alias global storage. `-fargument-noalias-global' specifies that arguments do not alias each other and do not alias global storage. Each language will automatically use whatever option is required by the language standard. You should not need to use these options yourself.


Using and Porting GNU CC - Environment Variables

Environment Variables Affecting GNU CC

This section describes several environment variables that affect how GNU CC operates. They work by specifying directories or prefixes to use when searching for various kinds of files.

Note that you can also specify places to search using options such as `-B', `-I' and `-L' (see section Options for Directory Search). These take precedence over places specified using environment variables, which in turn take precedence over those specified by the configuration of GNU CC. See section Controlling the Compilation Driver, `gcc'.

TMPDIR
If TMPDIR is set, it specifies the directory to use for temporary files. GNU CC uses temporary files to hold the output of one stage of compilation which is to be used as input to the next stage: for example, the output of the preprocessor, which is the input to the compiler proper.
GCC_EXEC_PREFIX
If GCC_EXEC_PREFIX is set, it specifies a prefix to use in the names of the subprograms executed by the compiler. No slash is added when this prefix is combined with the name of a subprogram, but you can specify a prefix that ends with a slash if you wish. If GNU CC cannot find the subprogram using the specified prefix, it tries looking in the usual places for the subprogram. The default value of GCC_EXEC_PREFIX is `prefix/lib/gcc-lib/' where prefix is the value of prefix when you ran the `configure' script. Other prefixes specified with `-B' take precedence over this prefix. This prefix is also used for finding files such as `crt0.o' that are used for linking. In addition, the prefix is used in an unusual way in finding the directories to search for header files. For each of the standard directories whose name normally begins with `/usr/local/lib/gcc-lib' (more precisely, with the value of GCC_INCLUDE_DIR), GNU CC tries replacing that beginning with the specified prefix to produce an alternate directory name. Thus, with `-Bfoo/', GNU CC will search `foo/bar' where it would normally search `/usr/local/lib/bar'. These alternate directories are searched first; the standard directories come next.
COMPILER_PATH
The value of COMPILER_PATH is a colon-separated list of directories, much like PATH. GNU CC tries the directories thus specified when searching for subprograms, if it can't find the subprograms using GCC_EXEC_PREFIX.
LIBRARY_PATH
The value of LIBRARY_PATH is a colon-separated list of directories, much like PATH. When configured as a native compiler, GNU CC tries the directories thus specified when searching for special linker files, if it can't find them using GCC_EXEC_PREFIX. Linking using GNU CC also uses these directories when searching for ordinary libraries for the `-l' option (but directories specified with `-L' come first).
C_INCLUDE_PATH
CPLUS_INCLUDE_PATH
OBJC_INCLUDE_PATH
These environment variables pertain to particular languages. Each variable's value is a colon-separated list of directories, much like PATH. When GNU CC searches for header files, it tries the directories listed in the variable for the language you are using, after the directories specified with `-I' but before the standard header file directories.
DEPENDENCIES_OUTPUT
If this variable is set, its value specifies how to output dependencies for Make based on the header files processed by the compiler. This output looks much like the output from the `-M' option (see section Options Controlling the Preprocessor), but it goes to a separate file, and is in addition to the usual results of compilation. The value of DEPENDENCIES_OUTPUT can be just a file name, in which case the Make rules are written to that file, guessing the target name from the source file name. Or the value can have the form `file target', in which case the rules are written to file file using target as the target name.


Using and Porting GNU CC - Running Protoize

Running Protoize

The program protoize is an optional part of GNU C. You can use it to add prototypes to a program, thus converting the program to ANSI C in one respect. The companion program unprotoize does the reverse: it removes argument types from any prototypes that are found.

When you run these programs, you must specify a set of source files as command line arguments. The conversion programs start out by compiling these files to see what functions they define. The information gathered about a file foo is saved in a file named `foo.X'.

After scanning comes actual conversion. The specified files are all eligible to be converted; any files they include (whether sources or just headers) are eligible as well.

But not all the eligible files are converted. By default, protoize and unprotoize convert only source and header files in the current directory. You can specify additional directories whose files should be converted with the `-d directory' option. You can also specify particular files to exclude with the `-x file' option. A file is converted if it is eligible, its directory name matches one of the specified directory names, and its name within the directory has not been excluded.

Basic conversion with protoize consists of rewriting most function definitions and function declarations to specify the types of the arguments. The only ones not rewritten are those for varargs functions.

protoize optionally inserts prototype declarations at the beginning of the source file, to make them available for any calls that precede the function's definition. Or it can insert prototype declarations with block scope in the blocks where undeclared functions are called.

Basic conversion with unprotoize consists of rewriting most function declarations to remove any argument types, and rewriting function definitions to the old-style pre-ANSI form.

Both conversion programs print a warning for any function declaration or definition that they can't convert. You can suppress these warnings with `-q'.

The output from protoize or unprotoize replaces the original source file. The original file is renamed to a name ending with `.save'. If the `.save' file already exists, then the source file is simply discarded.

protoize and unprotoize both depend on GNU CC itself to scan the program and collect information about the functions it uses. So neither of these programs will work until GNU CC is installed.

Here is a table of the options you can use with protoize and unprotoize. Each option works with both programs unless otherwise stated.

-B directory
Look for the file `SYSCALLS.c.X' in directory, instead of the usual directory (normally `/usr/local/lib'). This file contains prototype information about standard system functions. This option applies only to protoize.
-c compilation-options
Use compilation-options as the options when running gcc to produce the `.X' files. The special option `-aux-info' is always passed in addition, to tell gcc to write a `.X' file. Note that the compilation options must be given as a single argument to protoize or unprotoize. If you want to specify several gcc options, you must quote the entire set of compilation options to make them a single word in the shell. There are certain gcc arguments that you cannot use, because they would produce the wrong kind of output. These include `-g', `-O', `-c', `-S', and `-o' If you include these in the compilation-options, they are ignored.
-C
Rename files to end in `.C' instead of `.c'. This is convenient if you are converting a C program to C++. This option applies only to protoize.
-g
Add explicit global declarations. This means inserting explicit declarations at the beginning of each source file for each function that is called in the file and was not declared. These declarations precede the first function definition that contains a call to an undeclared function. This option applies only to protoize.
-i string
Indent old-style parameter declarations with the string string. This option applies only to protoize. unprotoize converts prototyped function definitions to old-style function definitions, where the arguments are declared between the argument list and the initial `{'. By default, unprotoize uses five spaces as the indentation. If you want to indent with just one space instead, use `-i " "'.
-k
Keep the `.X' files. Normally, they are deleted after conversion is finished.
-l
Add explicit local declarations. protoize with `-l' inserts a prototype declaration for each function in each block which calls the function without any declaration. This option applies only to protoize.
-n
Make no real changes. This mode just prints information about the conversions that would have been done without `-n'.
-N
Make no `.save' files. The original files are simply deleted. Use this option with caution.
-p program
Use the program program as the compiler. Normally, the name `gcc' is used.
-q
Work quietly. Most warnings are suppressed.
-v
Print the version number, just like `-v' for gcc.

If you need special compiler options to compile one of your program's source files, then you should generate that file's `.X' file specially, by running gcc on that source file with the appropriate options and the option `-aux-info'. Then run protoize on the entire set of files. protoize will use the existing `.X' file because it is newer than the source file. For example:

gcc -Dfoo=bar file1.c -aux-info
protoize *.c

You need to include the special files along with the rest in the protoize command, even though their `.X' files already exist, because otherwise they won't get converted.

See section Caveats of using protoize, for more information on how to use protoize successfully.

Note most of this information is out of date and superceded by the EGCS install procedures. It is provided for historical reference only.


Using and Porting GNU CC - Installation

Installing GNU CC

Here is the procedure for installing GNU CC on a Unix system. See section Installing GNU CC on VMS, for VMS systems. In this section we assume you compile in the same directory that contains the source files; see section Compilation in a Separate Directory, to find out how to compile in a separate directory on Unix systems.

You cannot install GNU C by itself on MSDOS; it will not compile under any MSDOS compiler except itself. You need to get the complete compilation package DJGPP, which includes binaries as well as sources, and includes all the necessary compilation tools and libraries.

  1. If you have built GNU CC previously in the same directory for a different target machine, do `make distclean' to delete all files that might be invalid. One of the files this deletes is `Makefile'; if `make distclean' complains that `Makefile' does not exist, it probably means that the directory is already suitably clean.
  2. On a System V release 4 system, make sure `/usr/bin' precedes `/usr/ucb' in PATH. The cc command in `/usr/ucb' uses libraries which have bugs.
  3. Specify the host, build and target machine configurations. You do this by running the file `configure'. The build machine is the system which you are using, the host machine is the system where you want to run the resulting compiler (normally the build machine), and the target machine is the system for which you want the compiler to generate code. If you are building a compiler to produce code for the machine it runs on (a native compiler), you normally do not need to specify any operands to `configure'; it will try to guess the type of machine you are on and use that as the build, host and target machines. So you don't need to specify a configuration when building a native compiler unless `configure' cannot figure out what your configuration is or guesses wrong. In those cases, specify the build machine's configuration name with the `--build' option; the host and target will default to be the same as the build machine. (If you are building a cross-compiler, see section Building and Installing a Cross-Compiler.) Here is an example:
    ./configure --build=sparc-sun-sunos4.1
    A configuration name may be canonical or it may be more or less abbreviated. A canonical configuration name has three parts, separated by dashes. It looks like this: `cpu-company-system'. (The three parts may themselves contain dashes; `configure' can figure out which dashes serve which purpose.) For example, `m68k-sun-sunos4.1' specifies a Sun 3. You can also replace parts of the configuration by nicknames or aliases. For example, `sun3' stands for `m68k-sun', so `sun3-sunos4.1' is another way to specify a Sun 3. You can also use simply `sun3-sunos', since the version of SunOS is assumed by default to be version 4. You can specify a version number after any of the system types, and some of the CPU types. In most cases, the version is irrelevant, and will be ignored. So you might as well specify the version if you know it. See section Configurations Supported by GNU CC, for a list of supported configuration names and notes on many of the configurations. You should check the notes in that section before proceeding any further with the installation of GNU CC. There are four additional options you can specify independently to describe variant hardware and software configurations. These are `--with-gnu-as', `--with-gnu-ld', `--with-stabs' and `--nfp'.
    `--with-gnu-as'
    If you will use GNU CC with the GNU assembler (GAS), you should declare this by using the `--with-gnu-as' option when you run `configure'. Using this option does not install GAS. It only modifies the output of GNU CC to work with GAS. Building and installing GAS is up to you. Conversely, if you do not wish to use GAS and do not specify `--with-gnu-as' when building GNU CC, it is up to you to make sure that GAS is not installed. GNU CC searches for a program named as in various directories; if the program it finds is GAS, then it runs GAS. If you are not sure where GNU CC finds the assembler it is using, try specifying `-v' when you run it. The systems where it makes a difference whether you use GAS are
    `hppa1.0-any-any', `hppa1.1-any-any', `i386-any-sysv', `i386-any-isc',
    `i860-any-bsd', `m68k-bull-sysv',
    `m68k-hp-hpux', `m68k-sony-bsd',
    `m68k-altos-sysv', `m68000-hp-hpux',
    `m68000-att-sysv', `any-lynx-lynxos', and `mips-any'). On any other system, `--with-gnu-as' has no effect. On the systems listed above (except for the HP-PA, for ISC on the 386, and for `mips-sgi-irix5.*'), if you use GAS, you should also use the GNU linker (and specify `--with-gnu-ld').
    `--with-gnu-ld'
    Specify the option `--with-gnu-ld' if you plan to use the GNU linker with GNU CC. This option does not cause the GNU linker to be installed; it just modifies the behavior of GNU CC to work with the GNU linker. Specifically, it inhibits the installation of collect2, a program which otherwise serves as a front-end for the system's linker on most configurations.
    `--with-stabs'
    On MIPS based systems and on Alphas, you must specify whether you want GNU CC to create the normal ECOFF debugging format, or to use BSD-style stabs passed through the ECOFF symbol table. The normal ECOFF debug format cannot fully handle languages other than C. BSD stabs format can handle other languages, but it only works with the GNU debugger GDB. Normally, GNU CC uses the ECOFF debugging format by default; if you prefer BSD stabs, specify `--with-stabs' when you configure GNU CC. No matter which default you choose when you configure GNU CC, the user can use the `-gcoff' and `-gstabs+' options to specify explicitly the debug format for a particular compilation. `--with-stabs' is meaningful on the ISC system on the 386, also, if `--with-gas' is used. It selects use of stabs debugging information embedded in COFF output. This kind of debugging information supports C++ well; ordinary COFF debugging information does not. `--with-stabs' is also meaningful on 386 systems running SVR4. It selects use of stabs debugging information embedded in ELF output. The C++ compiler currently (2.6.0) does not support the DWARF debugging information normally used on 386 SVR4 platforms; stabs provide a workable alternative. This requires gas and gdb, as the normal SVR4 tools can not generate or interpret stabs.
    `--nfp'
    On certain systems, you must specify whether the machine has a floating point unit. These systems include `m68k-sun-sunosn' and `m68k-isi-bsd'. On any other system, `--nfp' currently has no effect, though perhaps there are other systems where it could usefully make a difference.
    `--enable-haifa'
    `--disable-haifa'
    Use `--enable-haifa' to enable use of an experimental instruction scheduler (from IBM Haifa). This may or may not produce better code. Some targets on which it is known to be a win enable it by default; use `--disable-haifa' to disable it in these cases. configure will print out whether the Haifa scheduler is enabled when it is run.
    `--enable-objcthreads=type'
    Certain systems, notably Linux-based GNU systems, can't be relied on to supply a threads facility for the Objective C runtime and so will default to single-threaded runtime. They may, however, have a library threads implementation available, in which case threads can be enabled with this option by supplying a suitable type, probably `posix'. The possibilities for type are `single', `posix', `win32', `solaris', `irix' and `mach'.
    The `configure' script searches subdirectories of the source directory for other compilers that are to be integrated into GNU CC. The GNU compiler for C++, called G++ is in a subdirectory named `cp'. `configure' inserts rules into `Makefile' to build all of those compilers. Here we spell out what files will be set up by configure. Normally you need not be concerned with these files.
    • A file named `config.h' is created that contains a `#include' of the top-level config file for the machine you will run the compiler on (see section The Configuration File). This file is responsible for defining information about the host machine. It includes `tm.h'. The top-level config file is located in the subdirectory `config'. Its name is always `xm-something.h'; usually `xm-machine.h', but there are some exceptions. If your system does not support symbolic links, you might want to set up `config.h' to contain a `#include' command which refers to the appropriate file.
    • A file named `tconfig.h' is created which includes the top-level config file for your target machine. This is used for compiling certain programs to run on that machine.
    • A file named `tm.h' is created which includes the machine-description macro file for your target machine. It should be in the subdirectory `config' and its name is often `machine.h'.
    • The command file `configure' also constructs the file `Makefile' by adding some text to the template file `Makefile.in'. The additional text comes from files in the `config' directory, named `t-target' and `x-host'. If these files do not exist, it means nothing needs to be added for a given target or host.
  4. The standard directory for installing GNU CC is `/usr/local/lib'. If you want to install its files somewhere else, specify `--prefix=dir' when you run `configure'. Here dir is a directory name to use instead of `/usr/local' for all purposes with one exception: the directory `/usr/local/include' is searched for header files no matter where you install the compiler. To override this name, use the --local-prefix option below.
  5. Specify `--local-prefix=dir' if you want the compiler to search directory `dir/include' for locally installed header files instead of `/usr/local/include'. You should specify `--local-prefix' only if your site has a different convention (not `/usr/local') for where to put site-specific files. The default value for `--local-prefix' is `/usr/local' regardless of the value of `--prefix'. Specifying `--prefix' has no effect on which directory GNU CC searches for local header files. This may seem counterintuitive, but actually it is logical. The purpose of `--prefix' is to specify where to install GNU CC. The local header files in `/usr/local/include'---if you put any in that directory--are not part of GNU CC. They are part of other programs--perhaps many others. (GNU CC installs its own header files in another directory which is based on the `--prefix' value.) Do not specify `/usr' as the `--local-prefix'! The directory you use for `--local-prefix' must not contain any of the system's standard header files. If it did contain them, certain programs would be miscompiled (including GNU Emacs, on certain targets), because this would override and nullify the header file corrections made by the fixincludes script. Indications are that people who use this option use it based on mistaken ideas of what it is for. People use it as if it specified where to install part of GNU CC. Perhaps they make this assumption because installing GNU CC creates the directory.
  6. Make sure the Bison parser generator is installed. (This is unnecessary if the Bison output files `c-parse.c' and `cexp.c' are more recent than `c-parse.y' and `cexp.y' and you do not plan to change the `.y' files.) Bison versions older than Sept 8, 1988 will produce incorrect output for `c-parse.c'.
  7. If you have chosen a configuration for GNU CC which requires other GNU tools (such as GAS or the GNU linker) instead of the standard system tools, install the required tools in the build directory under the names `as', `ld' or whatever is appropriate. This will enable the compiler to find the proper tools for compilation of the program `enquire'. Alternatively, you can do subsequent compilation using a value of the PATH environment variable such that the necessary GNU tools come before the standard system tools.
  8. Build the compiler. Just type `make LANGUAGES=c' in the compiler directory. `LANGUAGES=c' specifies that only the C compiler should be compiled. The makefile normally builds compilers for all the supported languages; currently, C, C++ and Objective C. However, C is the only language that is sure to work when you build with other non-GNU C compilers. In addition, building anything but C at this stage is a waste of time. In general, you can specify the languages to build by typing the argument `LANGUAGES="list"', where list is one or more words from the list `c', `c++', and `objective-c'. If you have any additional GNU compilers as subdirectories of the GNU CC source directory, you may also specify their names in this list. Ignore any warnings you may see about "statement not reached" in `insn-emit.c'; they are normal. Also, warnings about "unknown escape sequence" are normal in `genopinit.c' and perhaps some other files. Likewise, you should ignore warnings about "constant is so large that it is unsigned" in `insn-emit.c' and `insn-recog.c' and a warning about a comparison always being zero in `enquire.o'. Any other compilation errors may represent bugs in the port to your machine or operating system, and should be investigated and reported (see section Reporting Bugs). Some commercial compilers fail to compile GNU CC because they have bugs or limitations. For example, the Microsoft compiler is said to run out of macro space. Some Ultrix compilers run out of expression space; then you need to break up the statement where the problem happens.
  9. If you are building a cross-compiler, stop here. See section Building and Installing a Cross-Compiler.
  10. Move the first-stage object files and executables into a subdirectory with this command:
    make stage1
    The files are moved into a subdirectory named `stage1'. Once installation is complete, you may wish to delete these files with rm -r stage1.
  11. If you have chosen a configuration for GNU CC which requires other GNU tools (such as GAS or the GNU linker) instead of the standard system tools, install the required tools in the `stage1' subdirectory under the names `as', `ld' or whatever is appropriate. This will enable the stage 1 compiler to find the proper tools in the following stage. Alternatively, you can do subsequent compilation using a value of the PATH environment variable such that the necessary GNU tools come before the standard system tools.
  12. Recompile the compiler with itself, with this command:
    make CC="stage1/xgcc -Bstage1/" CFLAGS="-g -O2"
    This is called making the stage 2 compiler. The command shown above builds compilers for all the supported languages. If you don't want them all, you can specify the languages to build by typing the argument `LANGUAGES="list"'. list should contain one or more words from the list `c', `c++', `objective-c', and `proto'. Separate the words with spaces. `proto' stands for the programs protoize and unprotoize; they are not a separate language, but you use LANGUAGES to enable or disable their installation. If you are going to build the stage 3 compiler, then you might want to build only the C language in stage 2. Once you have built the stage 2 compiler, if you are short of disk space, you can delete the subdirectory `stage1'. On a 68000 or 68020 system lacking floating point hardware, unless you have selected a `tm.h' file that expects by default that there is no such hardware, do this instead:
    make CC="stage1/xgcc -Bstage1/" CFLAGS="-g -O2 -msoft-float"
  13. If you wish to test the compiler by compiling it with itself one more time, install any other necessary GNU tools (such as GAS or the GNU linker) in the `stage2' subdirectory as you did in the `stage1' subdirectory, then do this:
    make stage2
make CC="stage2/xgcc -Bstage2/" CFLAGS="-g -O2"
    This is called making the stage 3 compiler. Aside from the `-B' option, the compiler options should be the same as when you made the stage 2 compiler. But the LANGUAGES option need not be the same. The command shown above builds compilers for all the supported languages; if you don't want them all, you can specify the languages to build by typing the argument `LANGUAGES="list"', as described above. If you do not have to install any additional GNU tools, you may use the command
    make bootstrap LANGUAGES=language-list BOOT_CFLAGS=option-list
    instead of making `stage1', `stage2', and performing the two compiler builds.
  14. Then compare the latest object files with the stage 2 object files--they ought to be identical, aside from time stamps (if any). On some systems, meaningful comparison of object files is impossible; they always appear "different." This is currently true on Solaris and some systems that use ELF object file format. On some versions of Irix on SGI machines and DEC Unix (OSF/1) on Alpha systems, you will not be able to compare the files without specifying `-save-temps'; see the description of individual systems above to see if you get comparison failures. You may have similar problems on other systems. Use this command to compare the files:
    make compare
    This will mention any object files that differ between stage 2 and stage 3. Any difference, no matter how innocuous, indicates that the stage 2 compiler has compiled GNU CC incorrectly, and is therefore a potentially serious bug which you should investigate and report (see section Reporting Bugs). If your system does not put time stamps in the object files, then this is a faster way to compare them (using the Bourne shell):
    for file in *.o; do
cmp $file stage2/$file
done
    If you have built the compiler with the `-mno-mips-tfile' option on MIPS machines, you will not be able to compare the files.
  15. Install the compiler driver, the compiler's passes and run-time support with `make install'. Use the same value for CC, CFLAGS and LANGUAGES that you used when compiling the files that are being installed. One reason this is necessary is that some versions of Make have bugs and recompile files gratuitously when you do this step. If you use the same variable values, those files will be recompiled properly. For example, if you have built the stage 2 compiler, you can use the following command:
    make install CC="stage2/xgcc -Bstage2/" CFLAGS="-g -O" LANGUAGES="list"
    This copies the files `cc1', `cpp' and `libgcc.a' to files `cc1', `cpp' and `libgcc.a' in the directory `/usr/local/lib/gcc-lib/target/version', which is where the compiler driver program looks for them. Here target is the target machine type specified when you ran `configure', and version is the version number of GNU CC. This naming scheme permits various versions and/or cross-compilers to coexist. It also copies the executables for compilers for other languages (e.g., `cc1plus' for C++) to the same directory. This also copies the driver program `xgcc' into `/usr/local/bin/gcc', so that it appears in typical execution search paths. It also copies `gcc.1' into `/usr/local/man/man1' and info pages into `/usr/local/info'. On some systems, this command causes recompilation of some files. This is usually due to bugs in make. You should either ignore this problem, or use GNU Make. Warning: there is a bug in alloca in the Sun library. To avoid this bug, be sure to install the executables of GNU CC that were compiled by GNU CC. (That is, the executables from stage 2 or 3, not stage 1.) They use alloca as a built-in function and never the one in the library. (It is usually better to install GNU CC executables from stage 2 or 3, since they usually run faster than the ones compiled with some other compiler.)
  16. If you're going to use C++, it's likely that you need to also install the libg++ distribution. It should be available from the same place where you got the GNU C distribution. Just as GNU C does not distribute a C runtime library, it also does not include a C++ run-time library. All I/O functionality, special class libraries, etc., are available in the libg++ distribution.
  17. GNU CC includes a runtime library for Objective-C because it is an integral part of the language. You can find the files associated with the library in the subdirectory `objc'. The GNU Objective-C Runtime Library requires header files for the target's C library in order to be compiled,and also requires the header files for the target's thread library if you want thread support. See section Cross-Compilers and Header Files, for discussion about header files issues for cross-compilation. When you run `configure', it picks the appropriate Objective-C thread implementation file for the target platform. In some situations, you may wish to choose a different back-end as some platforms support multiple thread implementations or you may wish to disable thread support completely. You do this by specifying a value for the OBJC_THREAD_FILE makefile variable on the command line when you run make, for example:
    make CC="stage2/xgcc -Bstage2/" CFLAGS="-g -O2" OBJC_THREAD_FILE=thr-single
    Below is a list of the currently available back-ends.
    • thr-single Disable thread support, should work for all platforms.
    • thr-decosf1 DEC OSF/1 thread support.
    • thr-irix SGI IRIX thread support.
    • thr-mach Generic MACH thread support, known to work on NEXTSTEP.
    • thr-os2 IBM OS/2 thread support.
    • thr-posix Generix POSIX thread support.
    • thr-pthreads PCThreads on Linux-based GNU systems.
    • thr-solaris SUN Solaris thread support.
    • thr-win32 Microsoft Win32 API thread support.


Using and Porting GNU CC - Configurations

Configurations Supported by GNU CC

Here are the possible CPU types:

1750a, a29k, alpha, arm, cn, clipper, dsp16xx, elxsi, h8300, hppa1.0, hppa1.1, i370, i386, i486, i586, i860, i960, m32r, m68000, m68k, m88k, mips, mipsel, mips64, mips64el, ns32k, powerpc, powerpcle, pyramid, romp, rs6000, sh, sparc, sparclite, sparc64, vax, we32k.

Here are the recognized company names. As you can see, customary abbreviations are used rather than the longer official names.

acorn, alliant, altos, apollo, apple, att, bull, cbm, convergent, convex, crds, dec, dg, dolphin, elxsi, encore, harris, hitachi, hp, ibm, intergraph, isi, mips, motorola, ncr, next, ns, omron, plexus, sequent, sgi, sony, sun, tti, unicom, wrs.

The company name is meaningful only to disambiguate when the rest of the information supplied is insufficient. You can omit it, writing just `cpu-system', if it is not needed. For example, `vax-ultrix4.2' is equivalent to `vax-dec-ultrix4.2'.

Here is a list of system types:

386bsd, aix, acis, amigaos, aos, aout, aux, bosx, bsd, clix, coff, ctix, cxux, dgux, dynix, ebmon, ecoff, elf, esix, freebsd, hms, genix, gnu, linux-gnu, hiux, hpux, iris, irix, isc, luna, lynxos, mach, minix, msdos, mvs, netbsd, newsos, nindy, ns, osf, osfrose, ptx, riscix, riscos, rtu, sco, sim, solaris, sunos, sym, sysv, udi, ultrix, unicos, uniplus, unos, vms, vsta, vxworks, winnt, xenix.

You can omit the system type; then `configure' guesses the operating system from the CPU and company.

You can add a version number to the system type; this may or may not make a difference. For example, you can write `bsd4.3' or `bsd4.4' to distinguish versions of BSD. In practice, the version number is most needed for `sysv3' and `sysv4', which are often treated differently.

If you specify an impossible combination such as `i860-dg-vms', then you may get an error message from `configure', or it may ignore part of the information and do the best it can with the rest. `configure' always prints the canonical name for the alternative that it used. GNU CC does not support all possible alternatives.

Often a particular model of machine has a name. Many machine names are recognized as aliases for CPU/company combinations. Thus, the machine name `sun3', mentioned above, is an alias for `m68k-sun'. Sometimes we accept a company name as a machine name, when the name is popularly used for a particular machine. Here is a table of the known machine names:

3300, 3b1, 3bn, 7300, altos3068, altos, apollo68, att-7300, balance, convex-cn, crds, decstation-3100, decstation, delta, encore, fx2800, gmicro, hp7nn, hp8nn, hp9k2nn, hp9k3nn, hp9k7nn, hp9k8nn, iris4d, iris, isi68, m3230, magnum, merlin, miniframe, mmax, news-3600, news800, news, next, pbd, pc532, pmax, powerpc, powerpcle, ps2, risc-news, rtpc, sun2, sun386i, sun386, sun3, sun4, symmetry, tower-32, tower.

Remember that a machine name specifies both the cpu type and the company name. If you want to install your own homemade configuration files, you can use `local' as the company name to access them. If you use configuration `cpu-local', the configuration name without the cpu prefix is used to form the configuration file names.

Thus, if you specify `m68k-local', configuration uses files `m68k.md', `local.h', `m68k.c', `xm-local.h', `t-local', and `x-local', all in the directory `config/m68k'.

Here is a list of configurations that have special treatment or special things you must know:

`1750a-*-*'
MIL-STD-1750A processors. The MIL-STD-1750A cross configuration produces output for as1750, an assembler/linker available under the GNU Public License for the 1750A. as1750 can be obtained at ftp://ftp.fta-berlin.de/pub/crossgcc/1750gals/. A similarly licensed simulator for the 1750A is available from same address. You should ignore a fatal error during the building of libgcc (libgcc is not yet implemented for the 1750A.) The as1750 assembler requires the file `ms1750.inc', which is found in the directory `config/1750a'. GNU CC produced the same sections as the Fairchild F9450 C Compiler, namely:
Normal
The program code section.
Static
The read/write (RAM) data section.
Konst
The read-only (ROM) constants section.
Init
Initialization section (code to copy KREL to SREL).
The smallest addressable unit is 16 bits (BITS_PER_UNIT is 16). This means that type `char' is represented with a 16-bit word per character. The 1750A's "Load/Store Upper/Lower Byte" instructions are not used by GNU CC.
`alpha-*-osf1'
Systems using processors that implement the DEC Alpha architecture and are running the DEC Unix (OSF/1) operating system, for example the DEC Alpha AXP systems. (VMS on the Alpha is not currently supported by GNU CC.) GNU CC writes a `.verstamp' directive to the assembler output file unless it is built as a cross-compiler. It gets the version to use from the system header file `/usr/include/stamp.h'. If you install a new version of DEC Unix, you should rebuild GCC to pick up the new version stamp. Note that since the Alpha is a 64-bit architecture, cross-compilers from 32-bit machines will not generate code as efficient as that generated when the compiler is running on a 64-bit machine because many optimizations that depend on being able to represent a word on the target in an integral value on the host cannot be performed. Building cross-compilers on the Alpha for 32-bit machines has only been tested in a few cases and may not work properly. make compare may fail on old versions of DEC Unix unless you add `-save-temps' to CFLAGS. On these systems, the name of the assembler input file is stored in the object file, and that makes comparison fail if it differs between the stage1 and stage2 compilations. The option `-save-temps' forces a fixed name to be used for the assembler input file, instead of a randomly chosen name in `/tmp'. Do not add `-save-temps' unless the comparisons fail without that option. If you add `-save-temps', you will have to manually delete the `.i' and `.s' files after each series of compilations. GNU CC now supports both the native (ECOFF) debugging format used by DBX and GDB and an encapsulated STABS format for use only with GDB. See the discussion of the `--with-stabs' option of `configure' above for more information on these formats and how to select them. There is a bug in DEC's assembler that produces incorrect line numbers for ECOFF format when the `.align' directive is used. To work around this problem, GNU CC will not emit such alignment directives while writing ECOFF format debugging information even if optimization is being performed. Unfortunately, this has the very undesirable side-effect that code addresses when `-O' is specified are different depending on whether or not `-g' is also specified. To avoid this behavior, specify `-gstabs+' and use GDB instead of DBX. DEC is now aware of this problem with the assembler and hopes to provide a fix shortly.
`arm-*-aout'
Advanced RISC Machines ARM-family processors. These are often used in embedded applications. There are no standard Unix configurations. This configuration corresponds to the basic instruction sequences and will produce `a.out' format object modules. You may need to make a variant of the file `arm.h' for your particular configuration.
`arm-*-linuxaout'
Any of the ARM family processors running the Linux-based GNU system with the `a.out' binary format (ELF is not yet supported). You must use version 2.8.1.0.7 or later of the Linux binutils, which you can download from `sunsite.unc.edu:/pub/Linux/GCC' and other mirror sites for Linux-based GNU systems.
`arm-*-riscix'
The ARM2 or ARM3 processor running RISC iX, Acorn's port of BSD Unix. If you are running a version of RISC iX prior to 1.2 then you must specify the version number during configuration. Note that the assembler shipped with RISC iX does not support stabs debugging information; a new version of the assembler, with stabs support included, is now available from Acorn.
`a29k'
AMD Am29k-family processors. These are normally used in embedded applications. There are no standard Unix configurations. This configuration corresponds to AMD's standard calling sequence and binary interface and is compatible with other 29k tools. You may need to make a variant of the file `a29k.h' for your particular configuration.
`a29k-*-bsd'
AMD Am29050 used in a system running a variant of BSD Unix.
`decstation-*'
DECstations can support three different personalities: Ultrix, DEC OSF/1, and OSF/rose. To configure GCC for these platforms use the following configurations:
`decstation-ultrix'
Ultrix configuration.
`decstation-osf1'
Dec's version of OSF/1.
`decstation-osfrose'
Open Software Foundation reference port of OSF/1 which uses the OSF/rose object file format instead of ECOFF. Normally, you would not select this configuration.
The MIPS C compiler needs to be told to increase its table size for switch statements with the `-Wf,-XNg1500' option in order to compile `cp/parse.c'. If you use the `-O2' optimization option, you also need to use `-Olimit 3000'. Both of these options are automatically generated in the `Makefile' that the shell script `configure' builds. If you override the CC make variable and use the MIPS compilers, you may need to add `-Wf,-XNg1500 -Olimit 3000'.
`elxsi-elxsi-bsd'
The Elxsi's C compiler has known limitations that prevent it from compiling GNU C. Please contact mrs@cygnus.com for more details.
`dsp16xx'
A port to the AT&T DSP1610 family of processors.
`h8300-*-*'
The calling convention and structure layout has changed in release 2.6. All code must be recompiled. The calling convention now passes the first three arguments in function calls in registers. Structures are no longer a multiple of 2 bytes.
`hppa*-*-*'
There are several variants of the HP-PA processor which run a variety of operating systems. GNU CC must be configured to use the correct processor type and operating system, or GNU CC will not function correctly. The easiest way to handle this problem is to not specify a target when configuring GNU CC, the `configure' script will try to automatically determine the right processor type and operating system. `-g' does not work on HP-UX, since that system uses a peculiar debugging format which GNU CC does not know about. However, `-g' will work if you also use GAS and GDB in conjunction with GCC. We highly recommend using GAS for all HP-PA configurations. You should be using GAS-2.6 (or later) along with GDB-4.16 (or later). These can be retrieved from all the traditional GNU ftp archive sites. GAS will need to be installed into a directory before /bin, /usr/bin, and /usr/ccs/bin in your search path. You should install GAS before you build GNU CC. To enable debugging, you must configure GNU CC with the `--with-gnu-as' option before building.
`i370-*-*'
This port is very preliminary and has many known bugs. We hope to have a higher-quality port for this machine soon.
`i386-*-linux-gnuoldld'
Use this configuration to generate `a.out' binaries on Linux-based GNU systems if you do not have gas/binutils version 2.5.2 or later installed. This is an obsolete configuration.
`i386-*-linux-gnuaout'
Use this configuration to generate `a.out' binaries on Linux-based GNU systems. This configuration is being superseded. You must use gas/binutils version 2.5.2 or later.
`i386-*-linux-gnu'
Use this configuration to generate ELF binaries on Linux-based GNU systems. You must use gas/binutils version 2.5.2 or later.
`i386-*-sco'
Compilation with RCC is recommended. Also, it may be a good idea to link with GNU malloc instead of the malloc that comes with the system.
`i386-*-sco3.2v4'
Use this configuration for SCO release 3.2 version 4.
`i386-*-sco3.2v5*'
Use this for SCO Open Server Release 5.0. GNU CC can generate ELF binaries (if you specify `-melf') or COFF binaries (the default). If you are going to build your compiler in ELF mode (once you have bootstrapped the first stage compiler) you must specify `-melf' as part of CC, not CFLAGS. You should use some variant of: `CC="stage1/xgcc -melf" CFLAGS="-Bstage1/"' etc. If you do not do this, the boostrap will generate completely bogus versions of libgcc.a generated. You must have TLS597 (from ftp.sco.com/TLS) installed for ELF binaries to work correctly. Note that Open Server 5.0.2 does need TLS597 installed.
`i386-*-isc'
It may be a good idea to link with GNU malloc instead of the malloc that comes with the system. In ISC version 4.1, `sed' core dumps when building `deduced.h'. Use the version of `sed' from version 4.0.
`i386-*-esix'
It may be good idea to link with GNU malloc instead of the malloc that comes with the system.
`i386-ibm-aix'
You need to use GAS version 2.1 or later, and LD from GNU binutils version 2.2 or later.
`i386-sequent-bsd'
Go to the Berkeley universe before compiling. In addition, you probably need to create a file named `string.h' containing just one line: `#include <strings.h>'.
`i386-sequent-ptx1*'
Sequent DYNIX/ptx 1.x.
`i386-sequent-ptx2*'
Sequent DYNIX/ptx 2.x.
`i386-sun-sunos4'
You may find that you need another version of GNU CC to begin bootstrapping with, since the current version when built with the system's own compiler seems to get an infinite loop compiling part of `libgcc2.c'. GNU CC version 2 compiled with GNU CC (any version) seems not to have this problem. See section Installing GNU CC on the Sun, for information on installing GNU CC on Sun systems.
`i[345]86-*-winnt3.5'
This version requires a GAS that has not let been released. Until it is, you can get a prebuilt binary version via anonymous ftp from `cs.washington.edu:pub/gnat' or `cs.nyu.edu:pub/gnat'. You must also use the Microsoft header files from the Windows NT 3.5 SDK. Find these on the CDROM in the `/mstools/h' directory dated 9/4/94. You must use a fixed version of Microsoft linker made especially for NT 3.5, which is also is available on the NT 3.5 SDK CDROM. If you do not have this linker, can you also use the linker from Visual C/C++ 1.0 or 2.0. Installing GNU CC for NT builds a wrapper linker, called `ld.exe', which mimics the behaviour of Unix `ld' in the specification of libraries (`-L' and `-l'). `ld.exe' looks for both Unix and Microsoft named libraries. For example, if you specify `-lfoo', `ld.exe' will look first for `libfoo.a' and then for `foo.lib'. You may install GNU CC for Windows NT in one of two ways, depending on whether or not you have a Unix-like shell and various Unix-like utilities.
  1. If you do not have a Unix-like shell and few Unix-like utilities, you will use a DOS style batch script called `configure.bat'. Invoke it as configure winnt from an MSDOS console window or from the program manager dialog box. `configure.bat' assumes you have already installed and have in your path a Unix-like `sed' program which is used to create a working `Makefile' from `Makefile.in'. `Makefile' uses the Microsoft Nmake program maintenance utility and the Visual C/C++ V8.00 compiler to build GNU CC. You need only have the utilities `sed' and `touch' to use this installation method, which only automatically builds the compiler itself. You must then examine what `fixinc.winnt' does, edit the header files by hand and build `libgcc.a' manually.
  2. The second type of installation assumes you are running a Unix-like shell, have a complete suite of Unix-like utilities in your path, and have a previous version of GNU CC already installed, either through building it via the above installation method or acquiring a pre-built binary. In this case, use the `configure' script in the normal fashion.
`i860-intel-osf1'
This is the Paragon. If you have version 1.0 of the operating system, see section Installation Problems, for special things you need to do to compensate for peculiarities in the system.
`*-lynx-lynxos'
LynxOS 2.2 and earlier comes with GNU CC 1.x already installed as `/bin/gcc'. You should compile with this instead of `/bin/cc'. You can tell GNU CC to use the GNU assembler and linker, by specifying `--with-gnu-as --with-gnu-ld' when configuring. These will produce COFF format object files and executables; otherwise GNU CC will use the installed tools, which produce `a.out' format executables.
`m32r-*-elf'
Embedded M32R system.
`m68000-hp-bsd'
HP 9000 series 200 running BSD. Note that the C compiler that comes with this system cannot compile GNU CC; contact law@cs.utah.edu to get binaries of GNU CC for bootstrapping.
`m68k-altos'
Altos 3068. You must use the GNU assembler, linker and debugger. Also, you must fix a kernel bug. Details in the file `README.ALTOS'.
`m68k-apple-aux'
Apple Macintosh running A/UX. You may configure GCC to use either the system assembler and linker or the GNU assembler and linker. You should use the GNU configuration if you can, especially if you also want to use GNU C++. You enabled that configuration with + the `--with-gnu-as' and `--with-gnu-ld' options to configure. Note the C compiler that comes with this system cannot compile GNU CC. You can fine binaries of GNU CC for bootstrapping on jagubox.gsfc.nasa.gov. You will also a patched version of `/bin/ld' there that raises some of the arbitrary limits found in the original.
`m68k-att-sysv'
AT&T 3b1, a.k.a. 7300 PC. Special procedures are needed to compile GNU CC with this machine's standard C compiler, due to bugs in that compiler. You can bootstrap it more easily with previous versions of GNU CC if you have them. Installing GNU CC on the 3b1 is difficult if you do not already have GNU CC running, due to bugs in the installed C compiler. However, the following procedure might work. We are unable to test it.
  1. Comment out the `#include "config.h"' line on line 37 of `cccp.c' and do `make cpp'. This makes a preliminary version of GNU cpp.
  2. Save the old `/lib/cpp' and copy the preliminary GNU cpp to that file name.
  3. Undo your change in `cccp.c', or reinstall the original version, and do `make cpp' again.
  4. Copy this final version of GNU cpp into `/lib/cpp'.
  5. Replace every occurrence of obstack_free in the file `tree.c' with _obstack_free.
  6. Run make to get the first-stage GNU CC.
  7. Reinstall the original version of `/lib/cpp'.
  8. Now you can compile GNU CC with itself and install it in the normal fashion.
`m68k-bull-sysv'
Bull DPX/2 series 200 and 300 with BOS-2.00.45 up to BOS-2.01. GNU CC works either with native assembler or GNU assembler. You can use GNU assembler with native coff generation by providing `--with-gnu-as' to the configure script or use GNU assembler with dbx-in-coff encapsulation by providing `--with-gnu-as --stabs'. For any problem with native assembler or for availability of the DPX/2 port of GAS, contact F.Pierresteguy@frcl.bull.fr.
`m68k-crds-unox'
Use `configure unos' for building on Unos. The Unos assembler is named casm instead of as. For some strange reason linking `/bin/as' to `/bin/casm' changes the behavior, and does not work. So, when installing GNU CC, you should install the following script as `as' in the subdirectory where the passes of GCC are installed:
#!/bin/sh
casm $*
The default Unos library is named `libunos.a' instead of `libc.a'. To allow GNU CC to function, either change all references to `-lc' in `gcc.c' to `-lunos' or link `/lib/libc.a' to `/lib/libunos.a'. When compiling GNU CC with the standard compiler, to overcome bugs in the support of alloca, do not use `-O' when making stage 2. Then use the stage 2 compiler with `-O' to make the stage 3 compiler. This compiler will have the same characteristics as the usual stage 2 compiler on other systems. Use it to make a stage 4 compiler and compare that with stage 3 to verify proper compilation. (Perhaps simply defining ALLOCA in `x-crds' as described in the comments there will make the above paragraph superfluous. Please inform us of whether this works.) Unos uses memory segmentation instead of demand paging, so you will need a lot of memory. 5 Mb is barely enough if no other tasks are running. If linking `cc1' fails, try putting the object files into a library and linking from that library.
`m68k-hp-hpux'
HP 9000 series 300 or 400 running HP-UX. HP-UX version 8.0 has a bug in the assembler that prevents compilation of GNU CC. To fix it, get patch PHCO_4484 from HP. In addition, if you wish to use gas `--with-gnu-as' you must use gas version 2.1 or later, and you must use the GNU linker version 2.1 or later. Earlier versions of gas relied upon a program which converted the gas output into the native HP/UX format, but that program has not been kept up to date. gdb does not understand that native HP/UX format, so you must use gas if you wish to use gdb.
`m68k-sun'
Sun 3. We do not provide a configuration file to use the Sun FPA by default, because programs that establish signal handlers for floating point traps inherently cannot work with the FPA. See section Installing GNU CC on the Sun, for information on installing GNU CC on Sun systems.
`m88k-*-svr3'
Motorola m88k running the AT&T/Unisoft/Motorola V.3 reference port. These systems tend to use the Green Hills C, revision 1.8.5, as the standard C compiler. There are apparently bugs in this compiler that result in object files differences between stage 2 and stage 3. If this happens, make the stage 4 compiler and compare it to the stage 3 compiler. If the stage 3 and stage 4 object files are identical, this suggests you encountered a problem with the standard C compiler; the stage 3 and 4 compilers may be usable. It is best, however, to use an older version of GNU CC for bootstrapping if you have one.
`m88k-*-dgux'
Motorola m88k running DG/UX. To build 88open BCS native or cross compilers on DG/UX, specify the configuration name as `m88k-*-dguxbcs' and build in the 88open BCS software development environment. To build ELF native or cross compilers on DG/UX, specify `m88k-*-dgux' and build in the DG/UX ELF development environment. You set the software development environment by issuing `sde-target' command and specifying either `m88kbcs' or `m88kdguxelf' as the operand. If you do not specify a configuration name, `configure' guesses the configuration based on the current software development environment.
`m88k-tektronix-sysv3'
Tektronix XD88 running UTekV 3.2e. Do not turn on optimization while building stage1 if you bootstrap with the buggy Green Hills compiler. Also, The bundled LAI System V NFS is buggy so if you build in an NFS mounted directory, start from a fresh reboot, or avoid NFS all together. Otherwise you may have trouble getting clean comparisons between stages.
`mips-mips-bsd'
MIPS machines running the MIPS operating system in BSD mode. It's possible that some old versions of the system lack the functions memcpy, memcmp, and memset. If your system lacks these, you must remove or undo the definition of TARGET_MEM_FUNCTIONS in `mips-bsd.h'. The MIPS C compiler needs to be told to increase its table size for switch statements with the `-Wf,-XNg1500' option in order to compile `cp/parse.c'. If you use the `-O2' optimization option, you also need to use `-Olimit 3000'. Both of these options are automatically generated in the `Makefile' that the shell script `configure' builds. If you override the CC make variable and use the MIPS compilers, you may need to add `-Wf,-XNg1500 -Olimit 3000'.
`mips-mips-riscos*'
The MIPS C compiler needs to be told to increase its table size for switch statements with the `-Wf,-XNg1500' option in order to compile `cp/parse.c'. If you use the `-O2' optimization option, you also need to use `-Olimit 3000'. Both of these options are automatically generated in the `Makefile' that the shell script `configure' builds. If you override the CC make variable and use the MIPS compilers, you may need to add `-Wf,-XNg1500 -Olimit 3000'. MIPS computers running RISC-OS can support four different personalities: default, BSD 4.3, System V.3, and System V.4 (older versions of RISC-OS don't support V.4). To configure GCC for these platforms use the following configurations:
`mips-mips-riscosrev'
Default configuration for RISC-OS, revision rev.
`mips-mips-riscosrevbsd'
BSD 4.3 configuration for RISC-OS, revision rev.
`mips-mips-riscosrevsysv4'
System V.4 configuration for RISC-OS, revision rev.
`mips-mips-riscosrevsysv'
System V.3 configuration for RISC-OS, revision rev.
The revision rev mentioned above is the revision of RISC-OS to use. You must reconfigure GCC when going from a RISC-OS revision 4 to RISC-OS revision 5. This has the effect of avoiding a linker bug (see section Installation Problems, for more details).
`mips-sgi-*'
In order to compile GCC on an SGI running IRIX 4, the "c.hdr.lib" option must be installed from the CD-ROM supplied from Silicon Graphics. This is found on the 2nd CD in release 4.0.1. In order to compile GCC on an SGI running IRIX 5, the "compiler_dev.hdr" subsystem must be installed from the IDO CD-ROM supplied by Silicon Graphics. make compare may fail on version 5 of IRIX unless you add `-save-temps' to CFLAGS. On these systems, the name of the assembler input file is stored in the object file, and that makes comparison fail if it differs between the stage1 and stage2 compilations. The option `-save-temps' forces a fixed name to be used for the assembler input file, instead of a randomly chosen name in `/tmp'. Do not add `-save-temps' unless the comparisons fail without that option. If you do you `-save-temps', you will have to manually delete the `.i' and `.s' files after each series of compilations. The MIPS C compiler needs to be told to increase its table size for switch statements with the `-Wf,-XNg1500' option in order to compile `cp/parse.c'. If you use the `-O2' optimization option, you also need to use `-Olimit 3000'. Both of these options are automatically generated in the `Makefile' that the shell script `configure' builds. If you override the CC make variable and use the MIPS compilers, you may need to add `-Wf,-XNg1500 -Olimit 3000'. On Irix version 4.0.5F, and perhaps on some other versions as well, there is an assembler bug that reorders instructions incorrectly. To work around it, specify the target configuration `mips-sgi-irix4loser'. This configuration inhibits assembler optimization. In a compiler configured with target `mips-sgi-irix4', you can turn off assembler optimization by using the `-noasmopt' option. This compiler option passes the option `-O0' to the assembler, to inhibit reordering. The `-noasmopt' option can be useful for testing whether a problem is due to erroneous assembler reordering. Even if a problem does not go away with `-noasmopt', it may still be due to assembler reordering--perhaps GNU CC itself was miscompiled as a result. To enable debugging under Irix 5, you must use GNU as 2.5 or later, and use the `--with-gnu-as' configure option when configuring gcc. GNU as is distributed as part of the binutils package.
`mips-sony-sysv'
Sony MIPS NEWS. This works in NEWSOS 5.0.1, but not in 5.0.2 (which uses ELF instead of COFF). Support for 5.0.2 will probably be provided soon by volunteers. In particular, the linker does not like the code generated by GCC when shared libraries are linked in.
`ns32k-encore'
Encore ns32000 system. Encore systems are supported only under BSD.
`ns32k-*-genix'
National Semiconductor ns32000 system. Genix has bugs in alloca and malloc; you must get the compiled versions of these from GNU Emacs.
`ns32k-sequent'
Go to the Berkeley universe before compiling. In addition, you probably need to create a file named `string.h' containing just one line: `#include <strings.h>'.
`ns32k-utek'
UTEK ns32000 system ("merlin"). The C compiler that comes with this system cannot compile GNU CC; contact `tektronix!reed!mason' to get binaries of GNU CC for bootstrapping.
`romp-*-aos'
`romp-*-mach'
The only operating systems supported for the IBM RT PC are AOS and MACH. GNU CC does not support AIX running on the RT. We recommend you compile GNU CC with an earlier version of itself; if you compile GNU CC with hc, the Metaware compiler, it will work, but you will get mismatches between the stage 2 and stage 3 compilers in various files. These errors are minor differences in some floating-point constants and can be safely ignored; the stage 3 compiler is correct.
`rs6000-*-aix'
`powerpc-*-aix'
Various early versions of each release of the IBM XLC compiler will not bootstrap GNU CC. Symptoms include differences between the stage2 and stage3 object files, and errors when compiling `libgcc.a' or `enquire'. Known problematic releases include: xlc-1.2.1.8, xlc-1.3.0.0 (distributed with AIX 3.2.5), and xlc-1.3.0.19. Both xlc-1.2.1.28 and xlc-1.3.0.24 (PTF 432238) are known to produce working versions of GNU CC, but most other recent releases correctly bootstrap GNU CC. Release 4.3.0 of AIX and ones prior to AIX 3.2.4 include a version of the IBM assembler which does not accept debugging directives: assembler updates are available as PTFs. Also, if you are using AIX 3.2.5 or greater and the GNU assembler, you must have a version modified after October 16th, 1995 in order for the GNU C compiler to build. See the file `README.RS6000' for more details on any of these problems. GNU CC does not yet support the 64-bit PowerPC instructions. Objective C does not work on this architecture because it makes assumptions that are incompatible with the calling conventions. AIX on the RS/6000 provides support (NLS) for environments outside of the United States. Compilers and assemblers use NLS to support locale-specific representations of various objects including floating-point numbers ("." vs "," for separating decimal fractions). There have been problems reported where the library linked with GNU CC does not produce the same floating-point formats that the assembler accepts. If you have this problem, set the LANG environment variable to "C" or "En_US". Due to changes in the way that GNU CC invokes the binder (linker) for AIX 4.1, you may now receive warnings of duplicate symbols from the link step that were not reported before. The assembly files generated by GNU CC for AIX have always included multiple symbol definitions for certain global variable and function declarations in the original program. The warnings should not prevent the linker from producing a correct library or runnable executable. By default, AIX 4.1 produces code that can be used on either Power or PowerPC processors. You can specify a default version for the `-mcpu='cpu_type switch by using the configure option `--with-cpu-'cpu_type.
`powerpc-*-elf'
`powerpc-*-sysv4'
PowerPC system in big endian mode, running System V.4. You can specify a default version for the `-mcpu='cpu_type switch by using the configure option `--with-cpu-'cpu_type.
`powerpc-*-linux-gnu'
PowerPC system in big endian mode, running the Linux-based GNU system. You can specify a default version for the `-mcpu='cpu_type switch by using the configure option `--with-cpu-'cpu_type.
`powerpc-*-eabiaix'
Embedded PowerPC system in big endian mode with -mcall-aix selected as the default. You can specify a default version for the `-mcpu='cpu_type switch by using the configure option `--with-cpu-'cpu_type.
`powerpc-*-eabisim'
Embedded PowerPC system in big endian mode for use in running under the PSIM simulator. You can specify a default version for the `-mcpu='cpu_type switch by using the configure option `--with-cpu-'cpu_type.
`powerpc-*-eabi'
Embedded PowerPC system in big endian mode. You can specify a default version for the `-mcpu='cpu_type switch by using the configure option `--with-cpu-'cpu_type.
`powerpcle-*-elf'
`powerpcle-*-sysv4'
PowerPC system in little endian mode, running System V.4. You can specify a default version for the `-mcpu='cpu_type switch by using the configure option `--with-cpu-'cpu_type.
`powerpcle-*-solaris2*'
PowerPC system in little endian mode, running Solaris 2.5.1 or higher. You can specify a default version for the `-mcpu='cpu_type switch by using the configure option `--with-cpu-'cpu_type. Beta versions of the Sun 4.0 compiler do not seem to be able to build GNU CC correctly. There are also problems with the host assembler and linker that are fixed by using the GNU versions of these tools.
`powerpcle-*-eabisim'
Embedded PowerPC system in little endian mode for use in running under the PSIM simulator.
`powerpcle-*-eabi'
Embedded PowerPC system in little endian mode. You can specify a default version for the `-mcpu='cpu_type switch by using the configure option `--with-cpu-'cpu_type.
`powerpcle-*-winnt'
`powerpcle-*-pe'
PowerPC system in little endian mode running Windows NT. You can specify a default version for the `-mcpu='cpu_type switch by using the configure option `--with-cpu-'cpu_type.
`vax-dec-ultrix'
Don't try compiling with Vax C (vcc). It produces incorrect code in some cases (for example, when alloca is used). Meanwhile, compiling `cp/parse.c' with pcc does not work because of an internal table size limitation in that compiler. To avoid this problem, compile just the GNU C compiler first, and use it to recompile building all the languages that you want to run.
`sparc-sun-*'
See section Installing GNU CC on the Sun, for information on installing GNU CC on Sun systems.
`vax-dec-vms'
See section Installing GNU CC on VMS, for details on how to install GNU CC on VMS.
`we32k-*-*'
These computers are also known as the 3b2, 3b5, 3b20 and other similar names. (However, the 3b1 is actually a 68000; see section Configurations Supported by GNU CC.) Don't use `-g' when compiling with the system's compiler. The system's linker seems to be unable to handle such a large program with debugging information. The system's compiler runs out of capacity when compiling `stmt.c' in GNU CC. You can work around this by building `cpp' in GNU CC first, then use that instead of the system's preprocessor with the system's C compiler to compile `stmt.c'. Here is how:
mv /lib/cpp /lib/cpp.att
cp cpp /lib/cpp.gnu
echo '/lib/cpp.gnu -traditional ${1+"$@"}' > /lib/cpp
chmod +x /lib/cpp
The system's compiler produces bad code for some of the GNU CC optimization files. So you must build the stage 2 compiler without optimization. Then build a stage 3 compiler with optimization. That executable should work. Here are the necessary commands:
make LANGUAGES=c CC=stage1/xgcc CFLAGS="-Bstage1/ -g"
make stage2
make CC=stage2/xgcc CFLAGS="-Bstage2/ -g -O"
You may need to raise the ULIMIT setting to build a C++ compiler, as the file `cc1plus' is larger than one megabyte.


Using and Porting GNU CC - Other Dir

Compilation in a Separate Directory

If you wish to build the object files and executables in a directory other than the one containing the source files, here is what you must do differently:

  1. Make sure you have a version of Make that supports the VPATH feature. (GNU Make supports it, as do Make versions on most BSD systems.)
  2. If you have ever run `configure' in the source directory, you must undo the configuration. Do this by running:
    make distclean
  3. Go to the directory in which you want to build the compiler before running `configure':
    mkdir gcc-sun3
cd gcc-sun3
    On systems that do not support symbolic links, this directory must be on the same file system as the source code directory.
  4. Specify where to find `configure' when you run it:
    ../gcc/configure ...
    This also tells configure where to find the compiler sources; configure takes the directory from the file name that was used to invoke it. But if you want to be sure, you can specify the source directory with the `--srcdir' option, like this:
    ../gcc/configure --srcdir=../gcc other options
    The directory you specify with `--srcdir' need not be the same as the one that configure is found in.

Now, you can run make in that directory. You need not repeat the configuration steps shown above, when ordinary source files change. You must, however, run configure again when the configuration files change, if your system does not support symbolic links.


Using and Porting GNU CC - Cross-Compiler

Building and Installing a Cross-Compiler

GNU CC can function as a cross-compiler for many machines, but not all.

  • Cross-compilers for the Mips as target using the Mips assembler currently do not work, because the auxiliary programs `mips-tdump.c' and `mips-tfile.c' can't be compiled on anything but a Mips. It does work to cross compile for a Mips if you use the GNU assembler and linker.
  • Cross-compilers between machines with different floating point formats have not all been made to work. GNU CC now has a floating point emulator with which these can work, but each target machine description needs to be updated to take advantage of it.
  • Cross-compilation between machines of different word sizes is somewhat problematic and sometimes does not work.

Since GNU CC generates assembler code, you probably need a cross-assembler that GNU CC can run, in order to produce object files. If you want to link on other than the target machine, you need a cross-linker as well. You also need header files and libraries suitable for the target machine that you can install on the host machine.


Using and Porting GNU CC - Steps of Cross

Steps of Cross-Compilation

To compile and run a program using a cross-compiler involves several steps:

  • Run the cross-compiler on the host machine to produce assembler files for the target machine. This requires header files for the target machine.
  • Assemble the files produced by the cross-compiler. You can do this either with an assembler on the target machine, or with a cross-assembler on the host machine.
  • Link those files to make an executable. You can do this either with a linker on the target machine, or with a cross-linker on the host machine. Whichever machine you use, you need libraries and certain startup files (typically `crt....o') for the target machine.

It is most convenient to do all of these steps on the same host machine, since then you can do it all with a single invocation of GNU CC. This requires a suitable cross-assembler and cross-linker. For some targets, the GNU assembler and linker are available.


Using and Porting GNU CC - Configure Cross

Configuring a Cross-Compiler

To build GNU CC as a cross-compiler, you start out by running `configure'. Use the `--target=target' to specify the target type. If `configure' was unable to correctly identify the system you are running on, also specify the `--build=build' option. For example, here is how to configure for a cross-compiler that produces code for an HP 68030 system running BSD on a system that `configure' can correctly identify:

./configure --target=m68k-hp-bsd4.3


Using and Porting GNU CC - Tools and Libraries

Tools and Libraries for a Cross-Compiler

If you have a cross-assembler and cross-linker available, you should install them now. Put them in the directory `/usr/local/target/bin'. Here is a table of the tools you should put in this directory:

`as'
This should be the cross-assembler.
`ld'
This should be the cross-linker.
`ar'
This should be the cross-archiver: a program which can manipulate archive files (linker libraries) in the target machine's format.
`ranlib'
This should be a program to construct a symbol table in an archive file.

The installation of GNU CC will find these programs in that directory, and copy or link them to the proper place to for the cross-compiler to find them when run later.

The easiest way to provide these files is to build the Binutils package and GAS. Configure them with the same `--host' and `--target' options that you use for configuring GNU CC, then build and install them. They install their executables automatically into the proper directory. Alas, they do not support all the targets that GNU CC supports.

If you want to install libraries to use with the cross-compiler, such as a standard C library, put them in the directory `/usr/local/target/lib'; installation of GNU CC copies all the files in that subdirectory into the proper place for GNU CC to find them and link with them. Here's an example of copying some libraries from a target machine:

ftp target-machine
lcd /usr/local/target/lib
cd /lib
get libc.a
cd /usr/lib
get libg.a
get libm.a
quit

The precise set of libraries you'll need, and their locations on the target machine, vary depending on its operating system.

Many targets require "start files" such as `crt0.o' and `crtn.o' which are linked into each executable; these too should be placed in `/usr/local/target/lib'. There may be several alternatives for `crt0.o', for use with profiling or other compilation options. Check your target's definition of STARTFILE_SPEC to find out what start files it uses. Here's an example of copying these files from a target machine:

ftp target-machine
lcd /usr/local/target/lib
prompt
cd /lib
mget *crt*.o
cd /usr/lib
mget *crt*.o
quit


Using and Porting GNU CC - Cross Runtime

`libgcc.a' and Cross-Compilers

Code compiled by GNU CC uses certain runtime support functions implicitly. Some of these functions can be compiled successfully with GNU CC itself, but a few cannot be. These problem functions are in the source file `libgcc1.c'; the library made from them is called `libgcc1.a'.

When you build a native compiler, these functions are compiled with some other compiler--the one that you use for bootstrapping GNU CC. Presumably it knows how to open code these operations, or else knows how to call the run-time emulation facilities that the machine comes with. But this approach doesn't work for building a cross-compiler. The compiler that you use for building knows about the host system, not the target system.

So, when you build a cross-compiler you have to supply a suitable library `libgcc1.a' that does the job it is expected to do.

To compile `libgcc1.c' with the cross-compiler itself does not work. The functions in this file are supposed to implement arithmetic operations that GNU CC does not know how to open code for your target machine. If these functions are compiled with GNU CC itself, they will compile into infinite recursion.

On any given target, most of these functions are not needed. If GNU CC can open code an arithmetic operation, it will not call these functions to perform the operation. It is possible that on your target machine, none of these functions is needed. If so, you can supply an empty library as `libgcc1.a'.

Many targets need library support only for multiplication and division. If you are linking with a library that contains functions for multiplication and division, you can tell GNU CC to call them directly by defining the macros MULSI3_LIBCALL, and the like. These macros need to be defined in the target description macro file. For some targets, they are defined already. This may be sufficient to avoid the need for libgcc1.a; if so, you can supply an empty library.

Some targets do not have floating point instructions; they need other functions in `libgcc1.a', which do floating arithmetic. Recent versions of GNU CC have a file which emulates floating point. With a certain amount of work, you should be able to construct a floating point emulator that can be used as `libgcc1.a'. Perhaps future versions will contain code to do this automatically and conveniently. That depends on whether someone wants to implement it.

Some embedded targets come with all the necessary `libgcc1.a' routines written in C or assembler. These targets build `libgcc1.a' automatically and you do not need to do anything special for them. Other embedded targets do not need any `libgcc1.a' routines since all the necessary operations are supported by the hardware.

If your target system has another C compiler, you can configure GNU CC as a native compiler on that machine, build just `libgcc1.a' with `make libgcc1.a' on that machine, and use the resulting file with the cross-compiler. To do this, execute the following on the target machine:

cd target-build-dir
./configure --host=sparc --target=sun3
make libgcc1.a

And then this on the host machine:

ftp target-machine
binary
cd target-build-dir
get libgcc1.a
quit

Another way to provide the functions you need in `libgcc1.a' is to define the appropriate perform_... macros for those functions. If these definitions do not use the C arithmetic operators that they are meant to implement, you should be able to compile them with the cross-compiler you are building. (If these definitions already exist for your target file, then you are all set.)

To build `libgcc1.a' using the perform macros, use `LIBGCC1=libgcc1.a OLDCC=./xgcc' when building the compiler. Otherwise, you should place your replacement library under the name `libgcc1.a' in the directory in which you will build the cross-compiler, before you run make.


Using and Porting GNU CC - Cross Headers

Cross-Compilers and Header Files

If you are cross-compiling a standalone program or a program for an embedded system, then you may not need any header files except the few that are part of GNU CC (and those of your program). However, if you intend to link your program with a standard C library such as `libc.a', then you probably need to compile with the header files that go with the library you use.

The GNU C compiler does not come with these files, because (1) they are system-specific, and (2) they belong in a C library, not in a compiler.

If the GNU C library supports your target machine, then you can get the header files from there (assuming you actually use the GNU library when you link your program).

If your target machine comes with a C compiler, it probably comes with suitable header files also. If you make these files accessible from the host machine, the cross-compiler can use them also.

Otherwise, you're on your own in finding header files to use when cross-compiling.

When you have found suitable header files, put them in the directory `/usr/local/target/include', before building the cross compiler. Then installation will run fixincludes properly and install the corrected versions of the header files where the compiler will use them.

Provide the header files before you build the cross-compiler, because the build stage actually runs the cross-compiler to produce parts of `libgcc.a'. (These are the parts that can be compiled with GNU CC.) Some of them need suitable header files.

Here's an example showing how to copy the header files from a target machine. On the target machine, do this:

(cd /usr/include; tar cf - .) > tarfile

Then, on the host machine, do this:

ftp target-machine
lcd /usr/local/target/include
get tarfile
quit
tar xf tarfile


Using and Porting GNU CC - Build Cross

Actually Building the Cross-Compiler

Now you can proceed just as for compiling a single-machine compiler through the step of building stage 1. If you have not provided some sort of `libgcc1.a', then compilation will give up at the point where it needs that file, printing a suitable error message. If you do provide `libgcc1.a', then building the compiler will automatically compile and link a test program called `libgcc1-test'; if you get errors in the linking, it means that not all of the necessary routines in `libgcc1.a' are available.

You must provide the header file `float.h'. One way to do this is to compile `enquire' and run it on your target machine. The job of `enquire' is to run on the target machine and figure out by experiment the nature of its floating point representation. `enquire' records its findings in the header file `float.h'. If you can't produce this file by running `enquire' on the target machine, then you will need to come up with a suitable `float.h' in some other way (or else, avoid using it in your programs).

Do not try to build stage 2 for a cross-compiler. It doesn't work to rebuild GNU CC as a cross-compiler using the cross-compiler, because that would produce a program that runs on the target machine, not on the host. For example, if you compile a 386-to-68030 cross-compiler with itself, the result will not be right either for the 386 (because it was compiled into 68030 code) or for the 68030 (because it was configured for a 386 as the host). If you want to compile GNU CC into 68030 code, whether you compile it on a 68030 or with a cross-compiler on a 386, you must specify a 68030 as the host when you configure it.

To install the cross-compiler, use `make install', as usual.


Using and Porting GNU CC - Sun Install

Installing GNU CC on the Sun

On Solaris (version 2.1), do not use the linker or other tools in `/usr/ucb' to build GNU CC. Use /usr/ccs/bin.

Make sure the environment variable FLOAT_OPTION is not set when you compile `libgcc.a'. If this option were set to f68881 when `libgcc.a' is compiled, the resulting code would demand to be linked with a special startup file and would not link properly without special pains.

There is a bug in alloca in certain versions of the Sun library. To avoid this bug, install the binaries of GNU CC that were compiled by GNU CC. They use alloca as a built-in function and never the one in the library.

Some versions of the Sun compiler crash when compiling GNU CC. The problem is a segmentation fault in cpp. This problem seems to be due to the bulk of data in the environment variables. You may be able to avoid it by using the following command to compile GNU CC with Sun CC:

make CC="TERMCAP=x OBJS=x LIBFUNCS=x STAGESTUFF=x cc"

SunOS 4.1.3 and 4.1.3_U1 have bugs that can cause intermittent core dumps when compiling GNU CC. A common symptom is an internal compiler error which does not recur if you run it again. To fix the problem, install Sun recommended patch 100726 (for SunOS 4.1.3) or 101508 (for SunOS 4.1.3_U1), or upgrade to a later SunOS release.


Using and Porting GNU CC - VMS Install

Installing GNU CC on VMS

The VMS version of GNU CC is distributed in a backup saveset containing both source code and precompiled binaries.

To install the `gcc' command so you can use the compiler easily, in the same manner as you use the VMS C compiler, you must install the VMS CLD file for GNU CC as follows:

  1. Define the VMS logical names `GNU_CC' and `GNU_CC_INCLUDE' to point to the directories where the GNU CC executables (`gcc-cpp.exe', `gcc-cc1.exe', etc.) and the C include files are kept respectively. This should be done with the commands:
    $ assign /system /translation=concealed -
  disk:[gcc.] gnu_cc
$ assign /system /translation=concealed -
  disk:[gcc.include.] gnu_cc_include
    with the appropriate disk and directory names. These commands can be placed in your system startup file so they will be executed whenever the machine is rebooted. You may, if you choose, do this via the `GCC_INSTALL.COM' script in the `[GCC]' directory.
  2. Install the `GCC' command with the command line:
    $ set command /table=sys$common:[syslib]dcltables -
  /output=sys$common:[syslib]dcltables gnu_cc:[000000]gcc
$ install replace sys$common:[syslib]dcltables
  3. To install the help file, do the following:
    $ library/help sys$library:helplib.hlb gcc.hlp
    Now you can invoke the compiler with a command like `gcc /verbose file.c', which is equivalent to the command `gcc -v -c file.c' in Unix.

If you wish to use GNU C++ you must first install GNU CC, and then perform the following steps:

  1. Define the VMS logical name `GNU_GXX_INCLUDE' to point to the directory where the preprocessor will search for the C++ header files. This can be done with the command:
    $ assign /system /translation=concealed -
  disk:[gcc.gxx_include.] gnu_gxx_include
    with the appropriate disk and directory name. If you are going to be using libg++, this is where the libg++ install procedure will install the libg++ header files.
  2. Obtain the file `gcc-cc1plus.exe', and place this in the same directory that `gcc-cc1.exe' is kept. The GNU C++ compiler can be invoked with a command like `gcc /plus /verbose file.cc', which is equivalent to the command `g++ -v -c file.cc' in Unix.

We try to put corresponding binaries and sources on the VMS distribution tape. But sometimes the binaries will be from an older version than the sources, because we don't always have time to update them. (Use the `/version' option to determine the version number of the binaries and compare it with the source file `version.c' to tell whether this is so.) In this case, you should use the binaries you get to recompile the sources. If you must recompile, here is how:

  1. Execute the command procedure `vmsconfig.com' to set up the files `tm.h', `config.h', `aux-output.c', and `md.', and to create files `tconfig.h' and `hconfig.h'. This procedure also creates several linker option files used by `make-cc1.com' and a data file used by `make-l2.com'.
    $ @vmsconfig.com
  2. Setup the logical names and command tables as defined above. In addition, define the VMS logical name `GNU_BISON' to point at the to the directories where the Bison executable is kept. This should be done with the command:
    $ assign /system /translation=concealed -
  disk:[bison.] gnu_bison
    You may, if you choose, use the `INSTALL_BISON.COM' script in the `[BISON]' directory.
  3. Install the `BISON' command with the command line:
    $ set command /table=sys$common:[syslib]dcltables -
  /output=sys$common:[syslib]dcltables -
  gnu_bison:[000000]bison
$ install replace sys$common:[syslib]dcltables
  4. Type `@make-gcc' to recompile everything (alternatively, submit the file `make-gcc.com' to a batch queue). If you wish to build the GNU C++ compiler as well as the GNU CC compiler, you must first edit `make-gcc.com' and follow the instructions that appear in the comments.
  5. In order to use GCC, you need a library of functions which GCC compiled code will call to perform certain tasks, and these functions are defined in the file `libgcc2.c'. To compile this you should use the command procedure `make-l2.com', which will generate the library `libgcc2.olb'. `libgcc2.olb' should be built using the compiler built from the same distribution that `libgcc2.c' came from, and `make-gcc.com' will automatically do all of this for you. To install the library, use the following commands:
    $ library gnu_cc:[000000]gcclib/delete=(new,eprintf)
$ library gnu_cc:[000000]gcclib/delete=L_*
$ library libgcc2/extract=*/output=libgcc2.obj
$ library gnu_cc:[000000]gcclib libgcc2.obj
    The first command simply removes old modules that will be replaced with modules from `libgcc2' under different module names. The modules new and eprintf may not actually be present in your `gcclib.olb'---if the VMS librarian complains about those modules not being present, simply ignore the message and continue on with the next command. The second command removes the modules that came from the previous version of the library `libgcc2.c'. Whenever you update the compiler on your system, you should also update the library with the above procedure.
  6. You may wish to build GCC in such a way that no files are written to the directory where the source files reside. An example would be the when the source files are on a read-only disk. In these cases, execute the following DCL commands (substituting your actual path names):
    $ assign dua0:[gcc.build_dir.]/translation=concealed, -
         dua1:[gcc.source_dir.]/translation=concealed  gcc_build
$ set default gcc_build:[000000]
    where the directory `dua1:[gcc.source_dir]' contains the source code, and the directory `dua0:[gcc.build_dir]' is meant to contain all of the generated object files and executables. Once you have done this, you can proceed building GCC as described above. (Keep in mind that `gcc_build' is a rooted logical name, and thus the device names in each element of the search list must be an actual physical device name rather than another rooted logical name).
  7. If you are building GNU CC with a previous version of GNU CC, you also should check to see that you have the newest version of the assembler. In particular, GNU CC version 2 treats global constant variables slightly differently from GNU CC version 1, and GAS version 1.38.1 does not have the patches required to work with GCC version 2. If you use GAS 1.38.1, then extern const variables will not have the read-only bit set, and the linker will generate warning messages about mismatched psect attributes for these variables. These warning messages are merely a nuisance, and can safely be ignored. If you are compiling with a version of GNU CC older than 1.33, specify `/DEFINE=("inline=")' as an option in all the compilations. This requires editing all the gcc commands in `make-cc1.com'. (The older versions had problems supporting inline.) Once you have a working 1.33 or newer GNU CC, you can change this file back.
  8. If you want to build GNU CC with the VAX C compiler, you will need to make minor changes in `make-cccp.com' and `make-cc1.com' to choose alternate definitions of CC, CFLAGS, and LIBS. See comments in those files. However, you must also have a working version of the GNU assembler (GNU as, aka GAS) as it is used as the back-end for GNU CC to produce binary object modules and is not included in the GNU CC sources. GAS is also needed to compile `libgcc2' in order to build `gcclib' (see above); `make-l2.com' expects to be able to find it operational in `gnu_cc:[000000]gnu-as.exe'. To use GNU CC on VMS, you need the VMS driver programs `gcc.exe', `gcc.com', and `gcc.cld'. They are distributed with the VMS binaries (`gcc-vms') rather than the GNU CC sources. GAS is also included in `gcc-vms', as is Bison. Once you have successfully built GNU CC with VAX C, you should use the resulting compiler to rebuild itself. Before doing this, be sure to restore the CC, CFLAGS, and LIBS definitions in `make-cccp.com' and `make-cc1.com'. The second generation compiler will be able to take advantage of many optimizations that must be suppressed when building with other compilers.

Under previous versions of GNU CC, the generated code would occasionally give strange results when linked with the sharable `VAXCRTL' library. Now this should work.

Even with this version, however, GNU CC itself should not be linked with the sharable `VAXCRTL'. The version of qsort in `VAXCRTL' has a bug (known to be present in VMS versions V4.6 through V5.5) which causes the compiler to fail.

The executables are generated by `make-cc1.com' and `make-cccp.com' use the object library version of `VAXCRTL' in order to make use of the qsort routine in `gcclib.olb'. If you wish to link the compiler executables with the shareable image version of `VAXCRTL', you should edit the file `tm.h' (created by `vmsconfig.com') to define the macro QSORT_WORKAROUND.

QSORT_WORKAROUND is always defined when GNU CC is compiled with VAX C, to avoid a problem in case `gcclib.olb' is not yet available.


Using and Porting GNU CC - Collect2

collect2

Many target systems do not have support in the assembler and linker for "constructors"---initialization functions to be called before the official "start" of main. On such systems, GNU CC uses a utility called collect2 to arrange to call these functions at start time.

The program collect2 works by linking the program once and looking through the linker output file for symbols with particular names indicating they are constructor functions. If it finds any, it creates a new temporary `.c' file containing a table of them, compiles it, and links the program a second time including that file.

The actual calls to the constructors are carried out by a subroutine called __main, which is called (automatically) at the beginning of the body of main (provided main was compiled with GNU CC). Calling __main is necessary, even when compiling C code, to allow linking C and C++ object code together. (If you use `-nostdlib', you get an unresolved reference to __main, since it's defined in the standard GCC library. Include `-lgcc' at the end of your compiler command line to resolve this reference.)

The program collect2 is installed as ld in the directory where the passes of the compiler are installed. When collect2 needs to find the real ld, it tries the following file names:

  • `real-ld' in the directories listed in the compiler's search directories.
  • `real-ld' in the directories listed in the environment variable PATH.
  • The file specified in the REAL_LD_FILE_NAME configuration macro, if specified.
  • `ld' in the compiler's search directories, except that collect2 will not execute itself recursively.
  • `ld' in PATH.

"The compiler's search directories" means all the directories where gcc searches for passes of the compiler. This includes directories that you specify with `-B'.

Cross-compilers search a little differently:

  • `real-ld' in the compiler's search directories.
  • `target-real-ld' in PATH.
  • The file specified in the REAL_LD_FILE_NAME configuration macro, if specified.
  • `ld' in the compiler's search directories.
  • `target-ld' in PATH.

collect2 explicitly avoids running ld using the file name under which collect2 itself was invoked. In fact, it remembers up a list of such names--in case one copy of collect2 finds another copy (or version) of collect2 installed as ld in a second place in the search path.

collect2 searches for the utilities nm and strip using the same algorithm as above for ld.


Using and Porting GNU CC - Header Dirs

Standard Header File Directories

GCC_INCLUDE_DIR means the same thing for native and cross. It is where GNU CC stores its private include files, and also where GNU CC stores the fixed include files. A cross compiled GNU CC runs fixincludes on the header files in `$(tooldir)/include'. (If the cross compilation header files need to be fixed, they must be installed before GNU CC is built. If the cross compilation header files are already suitable for ANSI C and GNU CC, nothing special need be done).

GPLUS_INCLUDE_DIR means the same thing for native and cross. It is where g++ looks first for header files. libg++ installs only target independent header files in that directory.

LOCAL_INCLUDE_DIR is used only for a native compiler. It is normally `/usr/local/include'. GNU CC searches this directory so that users can install header files in `/usr/local/include'.

CROSS_INCLUDE_DIR is used only for a cross compiler. GNU CC doesn't install anything there.

TOOL_INCLUDE_DIR is used for both native and cross compilers. It is the place for other packages to install header files that GNU CC will use. For a cross-compiler, this is the equivalent of `/usr/include'. When you build a cross-compiler, fixincludes processes any header files in this directory.


Using and Porting GNU CC - C Extensions

Extensions to the C Language Family

GNU C provides several language features not found in ANSI standard C. (The `-pedantic' option directs GNU CC to print a warning message if any of these features is used.) To test for the availability of these features in conditional compilation, check for a predefined macro __GNUC__, which is always defined under GNU CC.

These extensions are available in C and Objective C. Most of them are also available in C++. See section Extensions to the C++ Language, for extensions that apply only to C++.


Using and Porting GNU CC - Statement Exprs

Statements and Declarations in Expressions

A compound statement enclosed in parentheses may appear as an expression in GNU C. This allows you to use loops, switches, and local variables within an expression.

Recall that a compound statement is a sequence of statements surrounded by braces; in this construct, parentheses go around the braces. For example:

({ int y = foo (); int z;
   if (y > 0) z = y;
   else z = - y;
   z; })

is a valid (though slightly more complex than necessary) expression for the absolute value of foo ().

The last thing in the compound statement should be an expression followed by a semicolon; the value of this subexpression serves as the value of the entire construct. (If you use some other kind of statement last within the braces, the construct has type void, and thus effectively no value.)

This feature is especially useful in making macro definitions "safe" (so that they evaluate each operand exactly once). For example, the "maximum" function is commonly defined as a macro in standard C as follows:

#define max(a,b) ((a) > (b) ? (a) : (b))

But this definition computes either a or b twice, with bad results if the operand has side effects. In GNU C, if you know the type of the operands (here let's assume int), you can define the macro safely as follows:

#define maxint(a,b) \
  ({int _a = (a), _b = (b); _a > _b ? _a : _b; })

Embedded statements are not allowed in constant expressions, such as the value of an enumeration constant, the width of a bit field, or the initial value of a static variable.

If you don't know the type of the operand, you can still do this, but you must use typeof (see section Referring to a Type with typeof) or type naming (see section Naming an Expression's Type).


Using and Porting GNU CC - Local Labels

Locally Declared Labels

Each statement expression is a scope in which local labels can be declared. A local label is simply an identifier; you can jump to it with an ordinary goto statement, but only from within the statement expression it belongs to.

A local label declaration looks like this:

__label__ label;

or

__label__ label1, label2, ...;

Local label declarations must come at the beginning of the statement expression, right after the `({', before any ordinary declarations.

The label declaration defines the label name, but does not define the label itself. You must do this in the usual way, with label:, within the statements of the statement expression.

The local label feature is useful because statement expressions are often used in macros. If the macro contains nested loops, a goto can be useful for breaking out of them. However, an ordinary label whose scope is the whole function cannot be used: if the macro can be expanded several times in one function, the label will be multiply defined in that function. A local label avoids this problem. For example:

#define SEARCH(array, target)                     \
({                                               \
  __label__ found;                                \
  typeof (target) _SEARCH_target = (target);      \
  typeof (*(array)) *_SEARCH_array = (array);     \
  int i, j;                                       \
  int value;                                      \
  for (i = 0; i < max; i++)                       \
    for (j = 0; j < max; j++)                     \
      if (_SEARCH_array[i][j] == _SEARCH_target)  \
        { value = i; goto found; }              \
  value = -1;                                     \
 found:                                           \
  value;                                          \
})


Using and Porting GNU CC - Labels as Values

Labels as Values

You can get the address of a label defined in the current function (or a containing function) with the unary operator `&&'. The value has type void *. This value is a constant and can be used wherever a constant of that type is valid. For example:

void *ptr;
...
ptr = &&foo;

To use these values, you need to be able to jump to one. This is done with the computed goto statement(2), goto *exp;. For example,

goto *ptr;

Any expression of type void * is allowed.

One way of using these constants is in initializing a static array that will serve as a jump table:

static void *array[] = { &&foo, &&bar, &&hack };

Then you can select a label with indexing, like this:

goto *array[i];

Note that this does not check whether the subscript is in bounds--array indexing in C never does that.

Such an array of label values serves a purpose much like that of the switch statement. The switch statement is cleaner, so use that rather than an array unless the problem does not fit a switch statement very well.

Another use of label values is in an interpreter for threaded code. The labels within the interpreter function can be stored in the threaded code for super-fast dispatching.

You can use this mechanism to jump to code in a different function. If you do that, totally unpredictable things will happen. The best way to avoid this is to store the label address only in automatic variables and never pass it as an argument.


Using and Porting GNU CC - Nested Functions

Nested Functions

A nested function is a function defined inside another function. (Nested functions are not supported for GNU C++.) The nested function's name is local to the block where it is defined. For example, here we define a nested function named square, and call it twice:

foo (double a, double b)
{
  double square (double z) { return z * z; }

  return square (a) + square (b);
}

The nested function can access all the variables of the containing function that are visible at the point of its definition. This is called lexical scoping. For example, here we show a nested function which uses an inherited variable named offset:

bar (int *array, int offset, int size)
{
  int access (int *array, int index)
    { return array[index + offset]; }
  int i;
  ...
  for (i = 0; i < size; i++)
    ... access (array, i) ...
}

Nested function definitions are permitted within functions in the places where variable definitions are allowed; that is, in any block, before the first statement in the block.

It is possible to call the nested function from outside the scope of its name by storing its address or passing the address to another function:

hack (int *array, int size)
{
  void store (int index, int value)
    { array[index] = value; }

  intermediate (store, size);
}

Here, the function intermediate receives the address of store as an argument. If intermediate calls store, the arguments given to store are used to store into array. But this technique works only so long as the containing function (hack, in this example) does not exit.

If you try to call the nested function through its address after the containing function has exited, all hell will break loose. If you try to call it after a containing scope level has exited, and if it refers to some of the variables that are no longer in scope, you may be lucky, but it's not wise to take the risk. If, however, the nested function does not refer to anything that has gone out of scope, you should be safe.

GNU CC implements taking the address of a nested function using a technique called trampolines. A paper describing them is available from `maya.idiap.ch' in directory `pub/tmb', file `usenix88-lexic.ps.Z'.

A nested function can jump to a label inherited from a containing function, provided the label was explicitly declared in the containing function (see section Locally Declared Labels). Such a jump returns instantly to the containing function, exiting the nested function which did the goto and any intermediate functions as well. Here is an example:

bar (int *array, int offset, int size)
{
  __label__ failure;
  int access (int *array, int index)
    {
      if (index > size)
        goto failure;
      return array[index + offset];
    }
  int i;
  ...
  for (i = 0; i < size; i++)
    ... access (array, i) ...
  ...
  return 0;

 /* Control comes here from access
    if it detects an error.  */
 failure:
  return -1;
}

A nested function always has internal linkage. Declaring one with extern is erroneous. If you need to declare the nested function before its definition, use auto (which is otherwise meaningless for function declarations).

bar (int *array, int offset, int size)
{
  __label__ failure;
  auto int access (int *, int);
  ...
  int access (int *array, int index)
    {
      if (index > size)
        goto failure;
      return array[index + offset];
    }
  ...
}


Using and Porting GNU CC - Constructing Calls

Constructing Function Calls

Using the built-in functions described below, you can record the arguments a function received, and call another function with the same arguments, without knowing the number or types of the arguments.

You can also record the return value of that function call, and later return that value, without knowing what data type the function tried to return (as long as your caller expects that data type).

__builtin_apply_args ()
This built-in function returns a pointer of type void * to data describing how to perform a call with the same arguments as were passed to the current function. The function saves the arg pointer register, structure value address, and all registers that might be used to pass arguments to a function into a block of memory allocated on the stack. Then it returns the address of that block.
__builtin_apply (function, arguments, size)
This built-in function invokes function (type void (*)()) with a copy of the parameters described by arguments (type void *) and size (type int). The value of arguments should be the value returned by __builtin_apply_args. The argument size specifies the size of the stack argument data, in bytes. This function returns a pointer of type void * to data describing how to return whatever value was returned by function. The data is saved in a block of memory allocated on the stack. It is not always simple to compute the proper value for size. The value is used by __builtin_apply to compute the amount of data that should be pushed on the stack and copied from the incoming argument area.
__builtin_return (result)
This built-in function returns the value described by result from the containing function. You should specify, for result, a value returned by __builtin_apply.


Using and Porting GNU CC - Naming Types

Naming an Expression's Type

You can give a name to the type of an expression using a typedef declaration with an initializer. Here is how to define name as a type name for the type of exp:

typedef name = exp;

This is useful in conjunction with the statements-within-expressions feature. Here is how the two together can be used to define a safe "maximum" macro that operates on any arithmetic type:

#define max(a,b) \
  ({typedef _ta = (a), _tb = (b);  \
    _ta _a = (a); _tb _b = (b);     \
    _a > _b ? _a : _b; })

The reason for using names that start with underscores for the local variables is to avoid conflicts with variable names that occur within the expressions that are substituted for a and b. Eventually we hope to design a new form of declaration syntax that allows you to declare variables whose scopes start only after their initializers; this will be a more reliable way to prevent such conflicts.


Using and Porting GNU CC - Typeof

Referring to a Type with typeof

Another way to refer to the type of an expression is with typeof. The syntax of using of this keyword looks like sizeof, but the construct acts semantically like a type name defined with typedef.

There are two ways of writing the argument to typeof: with an expression or with a type. Here is an example with an expression:

typeof (x[0](1))

This assumes that x is an array of functions; the type described is that of the values of the functions.

Here is an example with a typename as the argument:

typeof (int *)

Here the type described is that of pointers to int.

If you are writing a header file that must work when included in ANSI C programs, write __typeof__ instead of typeof. See section Alternate Keywords.

A typeof-construct can be used anywhere a typedef name could be used. For example, you can use it in a declaration, in a cast, or inside of sizeof or typeof.

  • This declares y with the type of what x points to.
    typeof (*x) y;
  • This declares y as an array of such values.
    typeof (*x) y[4];
  • This declares y as an array of pointers to characters:
    typeof (typeof (char *)[4]) y;
    It is equivalent to the following traditional C declaration:
    char *y[4];
    To see the meaning of the declaration using typeof, and why it might be a useful way to write, let's rewrite it with these macros:
    #define pointer(T)  typeof(T *)
#define array(T, N) typeof(T [N])
    Now the declaration can be rewritten this way:
    array (pointer (char), 4) y;
    Thus, array (pointer (char), 4) is the type of arrays of 4 pointers to char.


Using and Porting GNU CC - Lvalues

Generalized Lvalues

Compound expressions, conditional expressions and casts are allowed as lvalues provided their operands are lvalues. This means that you can take their addresses or store values into them.

Standard C++ allows compound expressions and conditional expressions as lvalues, and permits casts to reference type, so use of this extension is deprecated for C++ code.

For example, a compound expression can be assigned, provided the last expression in the sequence is an lvalue. These two expressions are equivalent:

(a, b) += 5
a, (b += 5)

Similarly, the address of the compound expression can be taken. These two expressions are equivalent:

&(a, b)
a, &b

A conditional expression is a valid lvalue if its type is not void and the true and false branches are both valid lvalues. For example, these two expressions are equivalent:

(a ? b : c) = 5
(a ? b = 5 : (c = 5))

A cast is a valid lvalue if its operand is an lvalue. A simple assignment whose left-hand side is a cast works by converting the right-hand side first to the specified type, then to the type of the inner left-hand side expression. After this is stored, the value is converted back to the specified type to become the value of the assignment. Thus, if a has type char *, the following two expressions are equivalent:

(int)a = 5
(int)(a = (char *)(int)5)

An assignment-with-arithmetic operation such as `+=' applied to a cast performs the arithmetic using the type resulting from the cast, and then continues as in the previous case. Therefore, these two expressions are equivalent:

(int)a += 5
(int)(a = (char *)(int) ((int)a + 5))

You cannot take the address of an lvalue cast, because the use of its address would not work out coherently. Suppose that &(int)f were permitted, where f has type float. Then the following statement would try to store an integer bit-pattern where a floating point number belongs:

*&(int)f = 1;

This is quite different from what (int)f = 1 would do--that would convert 1 to floating point and store it. Rather than cause this inconsistency, we think it is better to prohibit use of `&' on a cast.

If you really do want an int * pointer with the address of f, you can simply write (int *)&f.


Using and Porting GNU CC - Conditionals

Conditionals with Omitted Operands

The middle operand in a conditional expression may be omitted. Then if the first operand is nonzero, its value is the value of the conditional expression.

Therefore, the expression

x ? : y

has the value of x if that is nonzero; otherwise, the value of y.

This example is perfectly equivalent to

x ? x : y

In this simple case, the ability to omit the middle operand is not especially useful. When it becomes useful is when the first operand does, or may (if it is a macro argument), contain a side effect. Then repeating the operand in the middle would perform the side effect twice. Omitting the middle operand uses the value already computed without the undesirable effects of recomputing it.


Using and Porting GNU CC - Long Long

Double-Word Integers

GNU C supports data types for integers that are twice as long as int. Simply write long long int for a signed integer, or unsigned long long int for an unsigned integer. To make an integer constant of type long long int, add the suffix LL to the integer. To make an integer constant of type unsigned long long int, add the suffix ULL to the integer.

You can use these types in arithmetic like any other integer types. Addition, subtraction, and bitwise boolean operations on these types are open-coded on all types of machines. Multiplication is open-coded if the machine supports fullword-to-doubleword a widening multiply instruction. Division and shifts are open-coded only on machines that provide special support. The operations that are not open-coded use special library routines that come with GNU CC.

There may be pitfalls when you use long long types for function arguments, unless you declare function prototypes. If a function expects type int for its argument, and you pass a value of type long long int, confusion will result because the caller and the subroutine will disagree about the number of bytes for the argument. Likewise, if the function expects long long int and you pass int. The best way to avoid such problems is to use prototypes.


Using and Porting GNU CC - Complex

Complex Numbers

GNU C supports complex data types. You can declare both complex integer types and complex floating types, using the keyword __complex__.

For example, `__complex__ double x;' declares x as a variable whose real part and imaginary part are both of type double. `__complex__ short int y;' declares y to have real and imaginary parts of type short int; this is not likely to be useful, but it shows that the set of complex types is complete.

To write a constant with a complex data type, use the suffix `i' or `j' (either one; they are equivalent). For example, 2.5fi has type __complex__ float and 3i has type __complex__ int. Such a constant always has a pure imaginary value, but you can form any complex value you like by adding one to a real constant.

To extract the real part of a complex-valued expression exp, write __real__ exp. Likewise, use __imag__ to extract the imaginary part.

The operator `~' performs complex conjugation when used on a value with a complex type.

GNU CC can allocate complex automatic variables in a noncontiguous fashion; it's even possible for the real part to be in a register while the imaginary part is on the stack (or vice-versa). None of the supported debugging info formats has a way to represent noncontiguous allocation like this, so GNU CC describes a noncontiguous complex variable as if it were two separate variables of noncomplex type. If the variable's actual name is foo, the two fictitious variables are named foo$real and foo$imag. You can examine and set these two fictitious variables with your debugger.

A future version of GDB will know how to recognize such pairs and treat them as a single variable with a complex type.


Using and Porting GNU CC - Zero Length

Arrays of Length Zero

Zero-length arrays are allowed in GNU C. They are very useful as the last element of a structure which is really a header for a variable-length object:

struct line {
  int length;
  char contents[0];
};

{
  struct line *thisline = (struct line *)
    malloc (sizeof (struct line) + this_length);
  thisline->length = this_length;
}

In standard C, you would have to give contents a length of 1, which means either you waste space or complicate the argument to malloc.


Using and Porting GNU CC - Variable Length

Arrays of Variable Length

Variable-length automatic arrays are allowed in GNU C. These arrays are declared like any other automatic arrays, but with a length that is not a constant expression. The storage is allocated at the point of declaration and deallocated when the brace-level is exited. For example:

FILE *
concat_fopen (char *s1, char *s2, char *mode)
{
  char str[strlen (s1) + strlen (s2) + 1];
  strcpy (str, s1);
  strcat (str, s2);
  return fopen (str, mode);
}

Jumping or breaking out of the scope of the array name deallocates the storage. Jumping into the scope is not allowed; you get an error message for it.

You can use the function alloca to get an effect much like variable-length arrays. The function alloca is available in many other C implementations (but not in all). On the other hand, variable-length arrays are more elegant.

There are other differences between these two methods. Space allocated with alloca exists until the containing function returns. The space for a variable-length array is deallocated as soon as the array name's scope ends. (If you use both variable-length arrays and alloca in the same function, deallocation of a variable-length array will also deallocate anything more recently allocated with alloca.)

You can also use variable-length arrays as arguments to functions:

struct entry
tester (int len, char data[len][len])
{
  ...
}

The length of an array is computed once when the storage is allocated and is remembered for the scope of the array in case you access it with sizeof.

If you want to pass the array first and the length afterward, you can use a forward declaration in the parameter list--another GNU extension.

struct entry
tester (int len; char data[len][len], int len)
{
  ...
}

The `int len' before the semicolon is a parameter forward declaration, and it serves the purpose of making the name len known when the declaration of data is parsed.

You can write any number of such parameter forward declarations in the parameter list. They can be separated by commas or semicolons, but the last one must end with a semicolon, which is followed by the "real" parameter declarations. Each forward declaration must match a "real" declaration in parameter name and data type.


Using and Porting GNU CC - Macro Varargs

Macros with Variable Numbers of Arguments

In GNU C, a macro can accept a variable number of arguments, much as a function can. The syntax for defining the macro looks much like that used for a function. Here is an example:

#define eprintf(format, args...)  \
 fprintf (stderr, format , ## args)

Here args is a rest argument: it takes in zero or more arguments, as many as the call contains. All of them plus the commas between them form the value of args, which is substituted into the macro body where args is used. Thus, we have this expansion:

eprintf ("%s:%d: ", input_file_name, line_number)
==>
fprintf (stderr, "%s:%d: " , input_file_name, line_number)

Note that the comma after the string constant comes from the definition of eprintf, whereas the last comma comes from the value of args.

The reason for using `##' is to handle the case when args matches no arguments at all. In this case, args has an empty value. In this case, the second comma in the definition becomes an embarrassment: if it got through to the expansion of the macro, we would get something like this:

fprintf (stderr, "success!\n" , )

which is invalid C syntax. `##' gets rid of the comma, so we get the following instead:

fprintf (stderr, "success!\n")

This is a special feature of the GNU C preprocessor: `##' before a rest argument that is empty discards the preceding sequence of non-whitespace characters from the macro definition. (If another macro argument precedes, none of it is discarded.)

It might be better to discard the last preprocessor token instead of the last preceding sequence of non-whitespace characters; in fact, we may someday change this feature to do so. We advise you to write the macro definition so that the preceding sequence of non-whitespace characters is just a single token, so that the meaning will not change if we change the definition of this feature.


Using and Porting GNU CC - Subscripting

Non-Lvalue Arrays May Have Subscripts

Subscripting is allowed on arrays that are not lvalues, even though the unary `&' operator is not. For example, this is valid in GNU C though not valid in other C dialects:

struct foo {int a[4];};

struct foo f();

bar (int index)
{
  return f().a[index];
}


Using and Porting GNU CC - Pointer Arith

Arithmetic on void- and Function-Pointers

In GNU C, addition and subtraction operations are supported on pointers to void and on pointers to functions. This is done by treating the size of a void or of a function as 1.

A consequence of this is that sizeof is also allowed on void and on function types, and returns 1.

The option `-Wpointer-arith' requests a warning if these extensions are used.


Using and Porting GNU CC - Initializers

Non-Constant Initializers

As in standard C++, the elements of an aggregate initializer for an automatic variable are not required to be constant expressions in GNU C. Here is an example of an initializer with run-time varying elements:

foo (float f, float g)
{
  float beat_freqs[2] = { f-g, f+g };
  ...
}


Using and Porting GNU CC - Constructors

Constructor Expressions

GNU C supports constructor expressions. A constructor looks like a cast containing an initializer. Its value is an object of the type specified in the cast, containing the elements specified in the initializer.

Usually, the specified type is a structure. Assume that struct foo and structure are declared as shown:

struct foo {int a; char b[2];} structure;

Here is an example of constructing a struct foo with a constructor:

structure = ((struct foo) {x + y, 'a', 0});

This is equivalent to writing the following:

{
  struct foo temp = {x + y, 'a', 0};
  structure = temp;
}

You can also construct an array. If all the elements of the constructor are (made up of) simple constant expressions, suitable for use in initializers, then the constructor is an lvalue and can be coerced to a pointer to its first element, as shown here:

char **foo = (char *[]) { "x", "y", "z" };

Array constructors whose elements are not simple constants are not very useful, because the constructor is not an lvalue. There are only two valid ways to use it: to subscript it, or initialize an array variable with it. The former is probably slower than a switch statement, while the latter does the same thing an ordinary C initializer would do. Here is an example of subscripting an array constructor:

output = ((int[]) { 2, x, 28 }) [input];

Constructor expressions for scalar types and union types are is also allowed, but then the constructor expression is equivalent to a cast.


Using and Porting GNU CC - Labeled Elements

Labeled Elements in Initializers

Standard C requires the elements of an initializer to appear in a fixed order, the same as the order of the elements in the array or structure being initialized.

In GNU C you can give the elements in any order, specifying the array indices or structure field names they apply to. This extension is not implemented in GNU C++.

To specify an array index, write `[index]' or `[index] =' before the element value. For example,

int a[6] = { [4] 29, [2] = 15 };

is equivalent to

int a[6] = { 0, 0, 15, 0, 29, 0 };

The index values must be constant expressions, even if the array being initialized is automatic.

To initialize a range of elements to the same value, write `[first ... last] = value'. For example,

int widths[] = { [0 ... 9] = 1, [10 ... 99] = 2, [100] = 3 };

Note that the length of the array is the highest value specified plus one.

In a structure initializer, specify the name of a field to initialize with `fieldname:' before the element value. For example, given the following structure,

struct point { int x, y; };

the following initialization

struct point p = { y: yvalue, x: xvalue };

is equivalent to

struct point p = { xvalue, yvalue };

Another syntax which has the same meaning is `.fieldname ='., as shown here:

struct point p = { .y = yvalue, .x = xvalue };

You can also use an element label (with either the colon syntax or the period-equal syntax) when initializing a union, to specify which element of the union should be used. For example,

union foo { int i; double d; };

union foo f = { d: 4 };

will convert 4 to a double to store it in the union using the second element. By contrast, casting 4 to type union foo would store it into the union as the integer i, since it is an integer. (See section Cast to a Union Type.)

You can combine this technique of naming elements with ordinary C initialization of successive elements. Each initializer element that does not have a label applies to the next consecutive element of the array or structure. For example,

int a[6] = { [1] = v1, v2, [4] = v4 };

is equivalent to

int a[6] = { 0, v1, v2, 0, v4, 0 };

Labeling the elements of an array initializer is especially useful when the indices are characters or belong to an enum type. For example:

int whitespace[256]
  = { [' '] = 1, ['\t'] = 1, ['\h'] = 1,
      ['\f'] = 1, ['\n'] = 1, ['\r'] = 1 };


Using and Porting GNU CC - Case Ranges

Case Ranges

You can specify a range of consecutive values in a single case label, like this:

case low ... high:

This has the same effect as the proper number of individual case labels, one for each integer value from low to high, inclusive.

This feature is especially useful for ranges of ASCII character codes:

case 'A' ... 'Z':

Be careful: Write spaces around the ..., for otherwise it may be parsed wrong when you use it with integer values. For example, write this:

case 1 ... 5:

rather than this:

case 1...5:


Using and Porting GNU CC - Cast to Union

Cast to a Union Type

A cast to union type is similar to other casts, except that the type specified is a union type. You can specify the type either with union tag or with a typedef name. A cast to union is actually a constructor though, not a cast, and hence does not yield an lvalue like normal casts. (See section Constructor Expressions.)

The types that may be cast to the union type are those of the members of the union. Thus, given the following union and variables:

union foo { int i; double d; };
int x;
double y;

both x and y can be cast to type union foo.

Using the cast as the right-hand side of an assignment to a variable of union type is equivalent to storing in a member of the union:

union foo u;
...
u = (union foo) x  ==  u.i = x
u = (union foo) y  ==  u.d = y

You can also use the union cast as a function argument:

void hack (union foo);
...
hack ((union foo) x);


Using and Porting GNU CC - Function Attributes

Declaring Attributes of Functions

In GNU C, you declare certain things about functions called in your program which help the compiler optimize function calls and check your code more carefully.

The keyword __attribute__ allows you to specify special attributes when making a declaration. This keyword is followed by an attribute specification inside double parentheses. Eight attributes, noreturn, const, format, section, constructor, destructor, unused and weak are currently defined for functions. Other attributes, including section are supported for variables declarations (see section Specifying Attributes of Variables) and for types (see section Specifying Attributes of Types).

You may also specify attributes with `__' preceding and following each keyword. This allows you to use them in header files without being concerned about a possible macro of the same name. For example, you may use __noreturn__ instead of noreturn.

noreturn
A few standard library functions, such as abort and exit, cannot return. GNU CC knows this automatically. Some programs define their own functions that never return. You can declare them noreturn to tell the compiler this fact. For example,
void fatal () __attribute__ ((noreturn));

void
fatal (...)
{
  ... /* Print error message. */ ...
  exit (1);
}
The noreturn keyword tells the compiler to assume that fatal cannot return. It can then optimize without regard to what would happen if fatal ever did return. This makes slightly better code. More importantly, it helps avoid spurious warnings of uninitialized variables. Do not assume that registers saved by the calling function are restored before calling the noreturn function. It does not make sense for a noreturn function to have a return type other than void. The attribute noreturn is not implemented in GNU C versions earlier than 2.5. An alternative way to declare that a function does not return, which works in the current version and in some older versions, is as follows:
typedef void voidfn ();

volatile voidfn fatal;
const
Many functions do not examine any values except their arguments, and have no effects except the return value. Such a function can be subject to common subexpression elimination and loop optimization just as an arithmetic operator would be. These functions should be declared with the attribute const. For example,
int square (int) __attribute__ ((const));
says that the hypothetical function square is safe to call fewer times than the program says. The attribute const is not implemented in GNU C versions earlier than 2.5. An alternative way to declare that a function has no side effects, which works in the current version and in some older versions, is as follows:
typedef int intfn ();

extern const intfn square;
This approach does not work in GNU C++ from 2.6.0 on, since the language specifies that the `const' must be attached to the return value. Note that a function that has pointer arguments and examines the data pointed to must not be declared const. Likewise, a function that calls a non-const function usually must not be const. It does not make sense for a const function to return void.
format (archetype, string-index, first-to-check)
The format attribute specifies that a function takes printf or scanf style arguments which should be type-checked against a format string. For example, the declaration:
extern int
my_printf (void *my_object, const char *my_format, ...)
      __attribute__ ((format (printf, 2, 3)));
causes the compiler to check the arguments in calls to my_printf for consistency with the printf style format string argument my_format. The parameter archetype determines how the format string is interpreted, and should be either printf or scanf. The parameter string-index specifies which argument is the format string argument (starting from 1), while first-to-check is the number of the first argument to check against the format string. For functions where the arguments are not available to be checked (such as vprintf), specify the third parameter as zero. In this case the compiler only checks the format string for consistency. In the example above, the format string (my_format) is the second argument of the function my_print, and the arguments to check start with the third argument, so the correct parameters for the format attribute are 2 and 3. The format attribute allows you to identify your own functions which take format strings as arguments, so that GNU CC can check the calls to these functions for errors. The compiler always checks formats for the ANSI library functions printf, fprintf, sprintf, scanf, fscanf, sscanf, vprintf, vfprintf and vsprintf whenever such warnings are requested (using `-Wformat'), so there is no need to modify the header file `stdio.h'.
format_arg (string-index)
The format_arg attribute specifies that a function takes printf or scanf style arguments, modifies it (for example, to translate it into another language), and passes it to a printf or scanf style function. For example, the declaration:
extern char *
my_dgettext (char *my_domain, const char *my_format)
      __attribute__ ((format_arg (2)));
causes the compiler to check the arguments in calls to my_dgettext whose result is passed to a printf or scanf type function for consistency with the printf style format string argument my_format. The parameter string-index specifies which argument is the format string argument (starting from 1). The format-arg attribute allows you to identify your own functions which modify format strings, so that GNU CC can check the calls to printf and scanf function whose operands are a call to one of your own function. The compiler always treats gettext, dgettext, and dcgettext in this manner.
section ("section-name")
Normally, the compiler places the code it generates in the text section. Sometimes, however, you need additional sections, or you need certain particular functions to appear in special sections. The section attribute specifies that a function lives in a particular section. For example, the declaration:
extern void foobar (void) __attribute__ ((section ("bar")));
puts the function foobar in the bar section. Some file formats do not support arbitrary sections so the section attribute is not available on all platforms. If you need to map the entire contents of a module to a particular section, consider using the facilities of the linker instead.
constructor
destructor
The constructor attribute causes the function to be called automatically before execution enters main (). Similarly, the destructor attribute causes the function to be called automatically after main () has completed or exit () has been called. Functions with these attributes are useful for initializing data that will be used implicitly during the execution of the program. These attributes are not currently implemented for Objective C.
unused
This attribute, attached to a function, means that the function is meant to be possibly unused. GNU CC will not produce a warning for this function. GNU C++ does not currently support this attribute as definitions without parameters are valid in C++.
weak
The weak attribute causes the declaration to be emitted as a weak symbol rather than a global. This is primarily useful in defining library functions which can be overridden in user code, though it can also be used with non-function declarations. Weak symbols are supported for ELF targets, and also for a.out targets when using the GNU assembler and linker.
alias ("target")
The alias attribute causes the declaration to be emitted as an alias for another symbol, which must be specified. For instance,
void __f () { /* do something */; }
void f () __attribute__ ((weak, alias ("__f")));
declares `f' to be a weak alias for `__f'. In C++, the mangled name for the target must be used. Not all target machines support this attribute.
regparm (number)
On the Intel 386, the regparm attribute causes the compiler to pass up to number integer arguments in registers EAX, EDX, and ECX instead of on the stack. Functions that take a variable number of arguments will continue to be passed all of their arguments on the stack.
stdcall
On the Intel 386, the stdcall attribute causes the compiler to assume that the called function will pop off the stack space used to pass arguments, unless it takes a variable number of arguments. The PowerPC compiler for Windows NT currently ignores the stdcall attribute.
cdecl
On the Intel 386, the cdecl attribute causes the compiler to assume that the calling function will pop off the stack space used to pass arguments. This is useful to override the effects of the `-mrtd' switch. The PowerPC compiler for Windows NT currently ignores the cdecl attribute.
longcall
On the RS/6000 and PowerPC, the longcall attribute causes the compiler to always call the function via a pointer, so that functions which reside further than 64 megabytes (67,108,864 bytes) from the current location can be called.
dllimport
On the PowerPC running Windows NT, the dllimport attribute causes the compiler to call the function via a global pointer to the function pointer that is set up by the Windows NT dll library. The pointer name is formed by combining __imp_ and the function name.
dllexport
On the PowerPC running Windows NT, the dllexport attribute causes the compiler to provide a global pointer to the function pointer, so that it can be called with the dllimport attribute. The pointer name is formed by combining __imp_ and the function name.
exception (except-func [, except-arg])
On the PowerPC running Windows NT, the exception attribute causes the compiler to modify the structured exception table entry it emits for the declared function. The string or identifier except-func is placed in the third entry of the structured exception table. It represents a function, which is called by the exception handling mechanism if an exception occurs. If it was specified, the string or identifier except-arg is placed in the fourth entry of the structured exception table.
function_vector
Use this option on the H8/300 and H8/300H to indicate that the specified function should be called through the function vector. Calling a function through the function vector will reduce code size, however; the function vector has a limited size (maximum 128 entries on the H8/300 and 64 entries on the H8/300H) and shares space with the interrupt vector. You must use GAS and GLD from GNU binutils version 2.7 or later for this option to work correctly.
interrupt_handler
Use this option on the H8/300 and H8/300H to indicate that the specified function is an interrupt handler. The compiler will generate function entry and exit sequences suitable for use in an interrupt handler when this attribute is present.
eightbit_data
Use this option on the H8/300 and H8/300H to indicate that the specified variable should be placed into the eight bit data section. The compiler will generate more efficient code for certain operations on data in the eight bit data area. Note the eight bit data area is limited to 256 bytes of data. You must use GAS and GLD from GNU binutils version 2.7 or later for this option to work correctly.
tiny_data
Use this option on the H8/300H to indicate that the specified variable should be placed into the tiny data section. The compiler will generate more efficient code for loads and stores on data in the tiny data section. Note the tiny data area is limited to slightly under 32kbytes of data.
interrupt
Use this option on the M32R/D to indicate that the specified function is an interrupt handler. The compiler will generate function entry and exit sequences suitable for use in an interrupt handler when this attribute is present.
model (model-name)
Use this attribute on the M32R/D to set the addressability of an object, and the code generated for a function. The identifier model-name is one of small, medium, or large, representing each of the code models. Small model objects live in the lower 16MB of memory (so that their addresses can be loaded with the ld24 instruction), and are callable with the bl instruction. Medium model objects may live anywhere in the 32 bit address space (the compiler will generate seth/add3 instructions to load their addresses), and are callable with the bl instruction. Large model objects may live anywhere in the 32 bit address space (the compiler will generate seth/add3 instructions to load their addresses), and may not be reachable with the bl instruction (the compiler will generate the much slower seth/add3/jl instruction sequence).

You can specify multiple attributes in a declaration by separating them by commas within the double parentheses or by immediately following an attribute declaration with another attribute declaration.

Some people object to the __attribute__ feature, suggesting that ANSI C's #pragma should be used instead. There are two reasons for not doing this.

  1. It is impossible to generate #pragma commands from a macro.
  2. There is no telling what the same #pragma might mean in another compiler.

These two reasons apply to almost any application that might be proposed for #pragma. It is basically a mistake to use #pragma for anything.


Using and Porting GNU CC - Function Prototypes

Prototypes and Old-Style Function Definitions

GNU C extends ANSI C to allow a function prototype to override a later old-style non-prototype definition. Consider the following example:

/* Use prototypes unless the compiler is old-fashioned.  */
#if __STDC__
#define P(x) x
#else
#define P(x) ()
#endif

/* Prototype function declaration.  */
int isroot P((uid_t));

/* Old-style function definition.  */
int
isroot (x)   /* ??? lossage here ??? */
     uid_t x;
{
  return x == 0;
}

Suppose the type uid_t happens to be short. ANSI C does not allow this example, because subword arguments in old-style non-prototype definitions are promoted. Therefore in this example the function definition's argument is really an int, which does not match the prototype argument type of short.

This restriction of ANSI C makes it hard to write code that is portable to traditional C compilers, because the programmer does not know whether the uid_t type is short, int, or long. Therefore, in cases like these GNU C allows a prototype to override a later old-style definition. More precisely, in GNU C, a function prototype argument type overrides the argument type specified by a later old-style definition if the former type is the same as the latter type before promotion. Thus in GNU C the above example is equivalent to the following:

int isroot (uid_t);

int
isroot (uid_t x)
{
  return x == 0;
}

GNU C++ does not support old-style function definitions, so this extension is irrelevant.


Using and Porting GNU CC - C++ Comments

C++ Style Comments

In GNU C, you may use C++ style comments, which start with `//' and continue until the end of the line. Many other C implementations allow such comments, and they are likely to be in a future C standard. However, C++ style comments are not recognized if you specify `-ansi' or `-traditional', since they are incompatible with traditional constructs like dividend//*comment*/divisor.


Using and Porting GNU CC - Dollar Signs

Dollar Signs in Identifier Names

In GNU C, you may normally use dollar signs in identifier names. This is because many traditional C implementations allow such identifiers. However, dollar signs in identifiers are not supported on a few target machines, typically because the target assembler does not allow them.


Using and Porting GNU CC - Character Escapes

The Character ESC in Constants

You can use the sequence `\e' in a string or character constant to stand for the ASCII character ESC.


Using and Porting GNU CC - Alignment

Inquiring on Alignment of Types or Variables

The keyword __alignof__ allows you to inquire about how an object is aligned, or the minimum alignment usually required by a type. Its syntax is just like sizeof.

For example, if the target machine requires a double value to be aligned on an 8-byte boundary, then __alignof__ (double) is 8. This is true on many RISC machines. On more traditional machine designs, __alignof__ (double) is 4 or even 2.

Some machines never actually require alignment; they allow reference to any data type even at an odd addresses. For these machines, __alignof__ reports the recommended alignment of a type.

When the operand of __alignof__ is an lvalue rather than a type, the value is the largest alignment that the lvalue is known to have. It may have this alignment as a result of its data type, or because it is part of a structure and inherits alignment from that structure. For example, after this declaration:

struct foo { int x; char y; } foo1;

the value of __alignof__ (foo1.y) is probably 2 or 4, the same as __alignof__ (int), even though the data type of foo1.y does not itself demand any alignment.

A related feature which lets you specify the alignment of an object is __attribute__ ((aligned (alignment))); see the following section.


Using and Porting GNU CC - Variable Attributes

Specifying Attributes of Variables

The keyword __attribute__ allows you to specify special attributes of variables or structure fields. This keyword is followed by an attribute specification inside double parentheses. Eight attributes are currently defined for variables: aligned, mode, nocommon, packed, section, transparent_union, unused, and weak. Other attributes are available for functions (see section Declaring Attributes of Functions) and for types (see section Specifying Attributes of Types).

You may also specify attributes with `__' preceding and following each keyword. This allows you to use them in header files without being concerned about a possible macro of the same name. For example, you may use __aligned__ instead of aligned.

aligned (alignment)
This attribute specifies a minimum alignment for the variable or structure field, measured in bytes. For example, the declaration:
int x __attribute__ ((aligned (16))) = 0;
causes the compiler to allocate the global variable x on a 16-byte boundary. On a 68040, this could be used in conjunction with an asm expression to access the move16 instruction which requires 16-byte aligned operands. You can also specify the alignment of structure fields. For example, to create a double-word aligned int pair, you could write:
struct foo { int x[2] __attribute__ ((aligned (8))); };
This is an alternative to creating a union with a double member that forces the union to be double-word aligned. It is not possible to specify the alignment of functions; the alignment of functions is determined by the machine's requirements and cannot be changed. You cannot specify alignment for a typedef name because such a name is just an alias, not a distinct type. As in the preceding examples, you can explicitly specify the alignment (in bytes) that you wish the compiler to use for a given variable or structure field. Alternatively, you can leave out the alignment factor and just ask the compiler to align a variable or field to the maximum useful alignment for the target machine you are compiling for. For example, you could write:
short array[3] __attribute__ ((aligned));
Whenever you leave out the alignment factor in an aligned attribute specification, the compiler automatically sets the alignment for the declared variable or field to the largest alignment which is ever used for any data type on the target machine you are compiling for. Doing this can often make copy operations more efficient, because the compiler can use whatever instructions copy the biggest chunks of memory when performing copies to or from the variables or fields that you have aligned this way. The aligned attribute can only increase the alignment; but you can decrease it by specifying packed as well. See below. Note that the effectiveness of aligned attributes may be limited by inherent limitations in your linker. On many systems, the linker is only able to arrange for variables to be aligned up to a certain maximum alignment. (For some linkers, the maximum supported alignment may be very very small.) If your linker is only able to align variables up to a maximum of 8 byte alignment, then specifying aligned(16) in an __attribute__ will still only provide you with 8 byte alignment. See your linker documentation for further information.
mode (mode)
This attribute specifies the data type for the declaration--whichever type corresponds to the mode mode. This in effect lets you request an integer or floating point type according to its width. You may also specify a mode of `byte' or `__byte__' to indicate the mode corresponding to a one-byte integer, `word' or `__word__' for the mode of a one-word integer, and `pointer' or `__pointer__' for the mode used to represent pointers.
nocommon
This attribute specifies requests GNU CC not to place a variable "common" but instead to allocate space for it directly. If you specify the `-fno-common' flag, GNU CC will do this for all variables. Specifying the nocommon attribute for a variable provides an initialization of zeros. A variable may only be initialized in one source file.
packed
The packed attribute specifies that a variable or structure field should have the smallest possible alignment--one byte for a variable, and one bit for a field, unless you specify a larger value with the aligned attribute. Here is a structure in which the field x is packed, so that it immediately follows a:
struct foo
{
  char a;
  int x[2] __attribute__ ((packed));
};
section ("section-name")
Normally, the compiler places the objects it generates in sections like data and bss. Sometimes, however, you need additional sections, or you need certain particular variables to appear in special sections, for example to map to special hardware. The section attribute specifies that a variable (or function) lives in a particular section. For example, this small program uses several specific section names:
struct duart a __attribute__ ((section ("DUART_A"))) = { 0 };
struct duart b __attribute__ ((section ("DUART_B"))) = { 0 };
char stack[10000] __attribute__ ((section ("STACK"))) = { 0 };
int init_data __attribute__ ((section ("INITDATA"))) = 0;

main()
{
  /* Initialize stack pointer */
  init_sp (stack + sizeof (stack));

  /* Initialize initialized data */
  memcpy (&init_data, &data, &edata - &data);

  /* Turn on the serial ports */
  init_duart (&a);
  init_duart (&b);
}
Use the section attribute with an initialized definition of a global variable, as shown in the example. GNU CC issues a warning and otherwise ignores the section attribute in uninitialized variable declarations. You may only use the section attribute with a fully initialized global definition because of the way linkers work. The linker requires each object be defined once, with the exception that uninitialized variables tentatively go in the common (or bss) section and can be multiply "defined". You can force a variable to be initialized with the `-fno-common' flag or the nocommon attribute. Some file formats do not support arbitrary sections so the section attribute is not available on all platforms. If you need to map the entire contents of a module to a particular section, consider using the facilities of the linker instead.
transparent_union
This attribute, attached to a function parameter which is a union, means that the corresponding argument may have the type of any union member, but the argument is passed as if its type were that of the first union member. For more details see See section Specifying Attributes of Types. You can also use this attribute on a typedef for a union data type; then it applies to all function parameters with that type.
unused
This attribute, attached to a variable, means that the variable is meant to be possibly unused. GNU CC will not produce a warning for this variable.
weak
The weak attribute is described in See section Declaring Attributes of Functions.
model (model-name)
Use this attribute on the M32R/D to set the addressability of an object. The identifier model-name is one of small, medium, or large, representing each of the code models. Small model objects live in the lower 16MB of memory (so that their addresses can be loaded with the ld24 instruction). Medium and large model objects may live anywhere in the 32 bit address space (the compiler will generate seth/add3 instructions to load their addresses).

To specify multiple attributes, separate them by commas within the double parentheses: for example, `__attribute__ ((aligned (16), packed))'.


Using and Porting GNU CC - Type Attributes

Specifying Attributes of Types

The keyword __attribute__ allows you to specify special attributes of struct and union types when you define such types. This keyword is followed by an attribute specification inside double parentheses. Three attributes are currently defined for types: aligned, packed, and transparent_union. Other attributes are defined for functions (see section Declaring Attributes of Functions) and for variables (see section Specifying Attributes of Variables).

You may also specify any one of these attributes with `__' preceding and following its keyword. This allows you to use these attributes in header files without being concerned about a possible macro of the same name. For example, you may use __aligned__ instead of aligned.

You may specify the aligned and transparent_union attributes either in a typedef declaration or just past the closing curly brace of a complete enum, struct or union type definition and the packed attribute only past the closing brace of a definition.

aligned (alignment)
This attribute specifies a minimum alignment (in bytes) for variables of the specified type. For example, the declarations:
struct S { short f[3]; } __attribute__ ((aligned (8));
typedef int more_aligned_int __attribute__ ((aligned (8));
force the compiler to insure (as fas as it can) that each variable whose type is struct S or more_aligned_int will be allocated and aligned at least on a 8-byte boundary. On a Sparc, having all variables of type struct S aligned to 8-byte boundaries allows the compiler to use the ldd and std (doubleword load and store) instructions when copying one variable of type struct S to another, thus improving run-time efficiency. Note that the alignment of any given struct or union type is required by the ANSI C standard to be at least a perfect multiple of the lowest common multiple of the alignments of all of the members of the struct or union in question. This means that you can effectively adjust the alignment of a struct or union type by attaching an aligned attribute to any one of the members of such a type, but the notation illustrated in the example above is a more obvious, intuitive, and readable way to request the compiler to adjust the alignment of an entire struct or union type. As in the preceding example, you can explicitly specify the alignment (in bytes) that you wish the compiler to use for a given struct or union type. Alternatively, you can leave out the alignment factor and just ask the compiler to align a type to the maximum useful alignment for the target machine you are compiling for. For example, you could write:
struct S { short f[3]; } __attribute__ ((aligned));
Whenever you leave out the alignment factor in an aligned attribute specification, the compiler automatically sets the alignment for the type to the largest alignment which is ever used for any data type on the target machine you are compiling for. Doing this can often make copy operations more efficient, because the compiler can use whatever instructions copy the biggest chunks of memory when performing copies to or from the variables which have types that you have aligned this way. In the example above, if the size of each short is 2 bytes, then the size of the entire struct S type is 6 bytes. The smallest power of two which is greater than or equal to that is 8, so the compiler sets the alignment for the entire struct S type to 8 bytes. Note that although you can ask the compiler to select a time-efficient alignment for a given type and then declare only individual stand-alone objects of that type, the compiler's ability to select a time-efficient alignment is primarily useful only when you plan to create arrays of variables having the relevant (efficiently aligned) type. If you declare or use arrays of variables of an efficiently-aligned type, then it is likely that your program will also be doing pointer arithmetic (or subscripting, which amounts to the same thing) on pointers to the relevant type, and the code that the compiler generates for these pointer arithmetic operations will often be more efficient for efficiently-aligned types than for other types. The aligned attribute can only increase the alignment; but you can decrease it by specifying packed as well. See below. Note that the effectiveness of aligned attributes may be limited by inherent limitations in your linker. On many systems, the linker is only able to arrange for variables to be aligned up to a certain maximum alignment. (For some linkers, the maximum supported alignment may be very very small.) If your linker is only able to align variables up to a maximum of 8 byte alignment, then specifying aligned(16) in an __attribute__ will still only provide you with 8 byte alignment. See your linker documentation for further information.
packed
This attribute, attached to an enum, struct, or union type definition, specified that the minimum required memory be used to represent the type. Specifying this attribute for struct and union types is equivalent to specifying the packed attribute on each of the structure or union members. Specifying the `-fshort-enums' flag on the line is equivalent to specifying the packed attribute on all enum definitions. You may only specify this attribute after a closing curly brace on an enum definition, not in a typedef declaration, unless that declaration also contains the definition of the enum.
transparent_union
This attribute, attached to a union type definition, indicates that any function parameter having that union type causes calls to that function to be treated in a special way. First, the argument corresponding to a transparent union type can be of any type in the union; no cast is required. Also, if the union contains a pointer type, the corresponding argument can be a null pointer constant or a void pointer expression; and if the union contains a void pointer type, the corresponding argument can be any pointer expression. If the union member type is a pointer, qualifiers like const on the referenced type must be respected, just as with normal pointer conversions. Second, the argument is passed to the function using the calling conventions of first member of the transparent union, not the calling conventions of the union itself. All members of the union must have the same machine representation; this is necessary for this argument passing to work properly. Transparent unions are designed for library functions that have multiple interfaces for compatibility reasons. For example, suppose the wait function must accept either a value of type int * to comply with Posix, or a value of type union wait * to comply with the 4.1BSD interface. If wait's parameter were void *, wait would accept both kinds of arguments, but it would also accept any other pointer type and this would make argument type checking less useful. Instead, <sys/wait.h> might define the interface as follows:
typedef union
  {
    int *__ip;
    union wait *__up;
  } wait_status_ptr_t __attribute__ ((__transparent_union__));

pid_t wait (wait_status_ptr_t);
This interface allows either int * or union wait * arguments to be passed, using the int * calling convention. The program can call wait with arguments of either type:
int w1 () { int w; return wait (&w); }
int w2 () { union wait w; return wait (&w); }
With this interface, wait's implementation might look like this:
pid_t wait (wait_status_ptr_t p)
{
  return waitpid (-1, p.__ip, 0);
}

To specify multiple attributes, separate them by commas within the double parentheses: for example, `__attribute__ ((aligned (16), packed))'.


Using and Porting GNU CC - Inline

An Inline Function is As Fast As a Macro

By declaring a function inline, you can direct GNU CC to integrate that function's code into the code for its callers. This makes execution faster by eliminating the function-call overhead; in addition, if any of the actual argument values are constant, their known values may permit simplifications at compile time so that not all of the inline function's code needs to be included. The effect on code size is less predictable; object code may be larger or smaller with function inlining, depending on the particular case. Inlining of functions is an optimization and it really "works" only in optimizing compilation. If you don't use `-O', no function is really inline.

To declare a function inline, use the inline keyword in its declaration, like this:

inline int
inc (int *a)
{
  (*a)++;
}

(If you are writing a header file to be included in ANSI C programs, write __inline__ instead of inline. See section Alternate Keywords.)

You can also make all "simple enough" functions inline with the option `-finline-functions'. Note that certain usages in a function definition can make it unsuitable for inline substitution.

Note that in C and Objective C, unlike C++, the inline keyword does not affect the linkage of the function.

GNU CC automatically inlines member functions defined within the class body of C++ programs even if they are not explicitly declared inline. (You can override this with `-fno-default-inline'; see section Options Controlling C++ Dialect.)

When a function is both inline and static, if all calls to the function are integrated into the caller, and the function's address is never used, then the function's own assembler code is never referenced. In this case, GNU CC does not actually output assembler code for the function, unless you specify the option `-fkeep-inline-functions'. Some calls cannot be integrated for various reasons (in particular, calls that precede the function's definition cannot be integrated, and neither can recursive calls within the definition). If there is a nonintegrated call, then the function is compiled to assembler code as usual. The function must also be compiled as usual if the program refers to its address, because that can't be inlined.

When an inline function is not static, then the compiler must assume that there may be calls from other source files; since a global symbol can be defined only once in any program, the function must not be defined in the other source files, so the calls therein cannot be integrated. Therefore, a non-static inline function is always compiled on its own in the usual fashion.

If you specify both inline and extern in the function definition, then the definition is used only for inlining. In no case is the function compiled on its own, not even if you refer to its address explicitly. Such an address becomes an external reference, as if you had only declared the function, and had not defined it.

This combination of inline and extern has almost the effect of a macro. The way to use it is to put a function definition in a header file with these keywords, and put another copy of the definition (lacking inline and extern) in a library file. The definition in the header file will cause most calls to the function to be inlined. If any uses of the function remain, they will refer to the single copy in the library.

GNU C does not inline any functions when not optimizing. It is not clear whether it is better to inline or not, in this case, but we found that a correct implementation when not optimizing was difficult. So we did the easy thing, and turned it off.


Using and Porting GNU CC - Extended Asm

Assembler Instructions with C Expression Operands

In an assembler instruction using asm, you can now specify the operands of the instruction using C expressions. This means no more guessing which registers or memory locations will contain the data you want to use.

You must specify an assembler instruction template much like what appears in a machine description, plus an operand constraint string for each operand.

For example, here is how to use the 68881's fsinx instruction:

asm ("fsinx %1,%0" : "=f" (result) : "f" (angle));

Here angle is the C expression for the input operand while result is that of the output operand. Each has `"f"' as its operand constraint, saying that a floating point register is required. The `=' in `=f' indicates that the operand is an output; all output operands' constraints must use `='. The constraints use the same language used in the machine description (see section Operand Constraints).

Each operand is described by an operand-constraint string followed by the C expression in parentheses. A colon separates the assembler template from the first output operand, and another separates the last output operand from the first input, if any. Commas separate output operands and separate inputs. The total number of operands is limited to ten or to the maximum number of operands in any instruction pattern in the machine description, whichever is greater.

If there are no output operands, and there are input operands, then there must be two consecutive colons surrounding the place where the output operands would go.

Output operand expressions must be lvalues; the compiler can check this. The input operands need not be lvalues. The compiler cannot check whether the operands have data types that are reasonable for the instruction being executed. It does not parse the assembler instruction template and does not know what it means, or whether it is valid assembler input. The extended asm feature is most often used for machine instructions that the compiler itself does not know exist. If the output expression cannot be directly addressed (for example, it is a bit field), your constraint must allow a register. In that case, GNU CC will use the register as the output of the asm, and then store that register into the output.

The ordinary output operands must be write-only; GNU CC will assume that the values in these operands before the instruction are dead and need not be generated. Extended asm supports input-output or read-write operands. Use the constraint character `+' to indicate such an operand and list it with the output operands.

When the constraints for the read-write operand (or the operand in which only some of the bits are to be changed) allows a register, you may, as an alternative, logically split its function into two separate operands, one input operand and one write-only output operand. The connection between them is expressed by constraints which say they need to be in the same location when the instruction executes. You can use the same C expression for both operands, or different expressions. For example, here we write the (fictitious) `combine' instruction with bar as its read-only source operand and foo as its read-write destination:

asm ("combine %2,%0" : "=r" (foo) : "0" (foo), "g" (bar));

The constraint `"0"' for operand 1 says that it must occupy the same location as operand 0. A digit in constraint is allowed only in an input operand, and it must refer to an output operand.

Only a digit in the constraint can guarantee that one operand will be in the same place as another. The mere fact that foo is the value of both operands is not enough to guarantee that they will be in the same place in the generated assembler code. The following would not work:

asm ("combine %2,%0" : "=r" (foo) : "r" (foo), "g" (bar));

Various optimizations or reloading could cause operands 0 and 1 to be in different registers; GNU CC knows no reason not to do so. For example, the compiler might find a copy of the value of foo in one register and use it for operand 1, but generate the output operand 0 in a different register (copying it afterward to foo's own address). Of course, since the register for operand 1 is not even mentioned in the assembler code, the result will not work, but GNU CC can't tell that.

Some instructions clobber specific hard registers. To describe this, write a third colon after the input operands, followed by the names of the clobbered hard registers (given as strings). Here is a realistic example for the Vax:

asm volatile ("movc3 %0,%1,%2"
              : /* no outputs */
              : "g" (from), "g" (to), "g" (count)
              : "r0", "r1", "r2", "r3", "r4", "r5");

If you refer to a particular hardware register from the assembler code, then you will probably have to list the register after the third colon to tell the compiler that the register's value is modified. In many assemblers, the register names begin with `%'; to produce one `%' in the assembler code, you must write `%%' in the input.

If your assembler instruction can alter the condition code register, add `cc' to the list of clobbered registers. GNU CC on some machines represents the condition codes as a specific hardware register; `cc' serves to name this register. On other machines, the condition code is handled differently, and specifying `cc' has no effect. But it is valid no matter what the machine.

If your assembler instruction modifies memory in an unpredictable fashion, add `memory' to the list of clobbered registers. This will cause GNU CC to not keep memory values cached in registers across the assembler instruction.

You can put multiple assembler instructions together in a single asm template, separated either with newlines (written as `\n') or with semicolons if the assembler allows such semicolons. The GNU assembler allows semicolons and all Unix assemblers seem to do so. The input operands are guaranteed not to use any of the clobbered registers, and neither will the output operands' addresses, so you can read and write the clobbered registers as many times as you like. Here is an example of multiple instructions in a template; it assumes that the subroutine _foo accepts arguments in registers 9 and 10:

asm ("movl %0,r9;movl %1,r10;call _foo"
     : /* no outputs */
     : "g" (from), "g" (to)
     : "r9", "r10");

Unless an output operand has the `&' constraint modifier, GNU CC may allocate it in the same register as an unrelated input operand, on the assumption that the inputs are consumed before the outputs are produced. This assumption may be false if the assembler code actually consists of more than one instruction. In such a case, use `&' for each output operand that may not overlap an input. See section Constraint Modifier Characters.

If you want to test the condition code produced by an assembler instruction, you must include a branch and a label in the asm construct, as follows:

asm ("clr %0;frob %1;beq 0f;mov #1,%0;0:"
     : "g" (result)
     : "g" (input));

This assumes your assembler supports local labels, as the GNU assembler and most Unix assemblers do.

Speaking of labels, jumps from one asm to another are not supported. The compiler's optimizers do not know about these jumps, and therefore they cannot take account of them when deciding how to optimize.

Usually the most convenient way to use these asm instructions is to encapsulate them in macros that look like functions. For example,

#define sin(x)       \
({ double __value, __arg = (x);   \
   asm ("fsinx %1,%0": "=f" (__value): "f" (__arg));  \
   __value; })

Here the variable __arg is used to make sure that the instruction operates on a proper double value, and to accept only those arguments x which can convert automatically to a double.

Another way to make sure the instruction operates on the correct data type is to use a cast in the asm. This is different from using a variable __arg in that it converts more different types. For example, if the desired type were int, casting the argument to int would accept a pointer with no complaint, while assigning the argument to an int variable named __arg would warn about using a pointer unless the caller explicitly casts it.

If an asm has output operands, GNU CC assumes for optimization purposes that the instruction has no side effects except to change the output operands. This does not mean that instructions with a side effect cannot be used, but you must be careful, because the compiler may eliminate them if the output operands aren't used, or move them out of loops, or replace two with one if they constitute a common subexpression. Also, if your instruction does have a side effect on a variable that otherwise appears not to change, the old value of the variable may be reused later if it happens to be found in a register.

You can prevent an asm instruction from being deleted, moved significantly, or combined, by writing the keyword volatile after the asm. For example:

#define set_priority(x)  \
asm volatile ("set_priority %0": /* no outputs */ : "g" (x))

An instruction without output operands will not be deleted or moved significantly, regardless, unless it is unreachable.

Note that even a volatile asm instruction can be moved in ways that appear insignificant to the compiler, such as across jump instructions. You can't expect a sequence of volatile asm instructions to remain perfectly consecutive. If you want consecutive output, use a single asm.

It is a natural idea to look for a way to give access to the condition code left by the assembler instruction. However, when we attempted to implement this, we found no way to make it work reliably. The problem is that output operands might need reloading, which would result in additional following "store" instructions. On most machines, these instructions would alter the condition code before there was time to test it. This problem doesn't arise for ordinary "test" and "compare" instructions because they don't have any output operands.

If you are writing a header file that should be includable in ANSI C programs, write __asm__ instead of asm. See section Alternate Keywords.


Using and Porting GNU CC - Asm Labels

Controlling Names Used in Assembler Code

You can specify the name to be used in the assembler code for a C function or variable by writing the asm (or __asm__) keyword after the declarator as follows:

int foo asm ("myfoo") = 2;

This specifies that the name to be used for the variable foo in the assembler code should be `myfoo' rather than the usual `_foo'.

On systems where an underscore is normally prepended to the name of a C function or variable, this feature allows you to define names for the linker that do not start with an underscore.

You cannot use asm in this way in a function definition; but you can get the same effect by writing a declaration for the function before its definition and putting asm there, like this:

extern func () asm ("FUNC");

func (x, y)
     int x, y;
...

It is up to you to make sure that the assembler names you choose do not conflict with any other assembler symbols. Also, you must not use a register name; that would produce completely invalid assembler code. GNU CC does not as yet have the ability to store static variables in registers. Perhaps that will be added.


Using and Porting GNU CC - Explicit Reg Vars

Variables in Specified Registers

GNU C allows you to put a few global variables into specified hardware registers. You can also specify the register in which an ordinary register variable should be allocated.

  • Global register variables reserve registers throughout the program. This may be useful in programs such as programming language interpreters which have a couple of global variables that are accessed very often.
  • Local register variables in specific registers do not reserve the registers. The compiler's data flow analysis is capable of determining where the specified registers contain live values, and where they are available for other uses. These local variables are sometimes convenient for use with the extended asm feature (see section Assembler Instructions with C Expression Operands), if you want to write one output of the assembler instruction directly into a particular register. (This will work provided the register you specify fits the constraints specified for that operand in the asm.)


Using and Porting GNU CC - Global Reg Vars

Defining Global Register Variables

You can define a global register variable in GNU C like this:

register int *foo asm ("a5");

Here a5 is the name of the register which should be used. Choose a register which is normally saved and restored by function calls on your machine, so that library routines will not clobber it.

Naturally the register name is cpu-dependent, so you would need to conditionalize your program according to cpu type. The register a5 would be a good choice on a 68000 for a variable of pointer type. On machines with register windows, be sure to choose a "global" register that is not affected magically by the function call mechanism.

In addition, operating systems on one type of cpu may differ in how they name the registers; then you would need additional conditionals. For example, some 68000 operating systems call this register %a5.

Eventually there may be a way of asking the compiler to choose a register automatically, but first we need to figure out how it should choose and how to enable you to guide the choice. No solution is evident.

Defining a global register variable in a certain register reserves that register entirely for this use, at least within the current compilation. The register will not be allocated for any other purpose in the functions in the current compilation. The register will not be saved and restored by these functions. Stores into this register are never deleted even if they would appear to be dead, but references may be deleted or moved or simplified.

It is not safe to access the global register variables from signal handlers, or from more than one thread of control, because the system library routines may temporarily use the register for other things (unless you recompile them specially for the task at hand).

It is not safe for one function that uses a global register variable to call another such function foo by way of a third function lose that was compiled without knowledge of this variable (i.e. in a different source file in which the variable wasn't declared). This is because lose might save the register and put some other value there. For example, you can't expect a global register variable to be available in the comparison-function that you pass to qsort, since qsort might have put something else in that register. (If you are prepared to recompile qsort with the same global register variable, you can solve this problem.)

If you want to recompile qsort or other source files which do not actually use your global register variable, so that they will not use that register for any other purpose, then it suffices to specify the compiler option `-ffixed-reg'. You need not actually add a global register declaration to their source code.

A function which can alter the value of a global register variable cannot safely be called from a function compiled without this variable, because it could clobber the value the caller expects to find there on return. Therefore, the function which is the entry point into the part of the program that uses the global register variable must explicitly save and restore the value which belongs to its caller.

On most machines, longjmp will restore to each global register variable the value it had at the time of the setjmp. On some machines, however, longjmp will not change the value of global register variables. To be portable, the function that called setjmp should make other arrangements to save the values of the global register variables, and to restore them in a longjmp. This way, the same thing will happen regardless of what longjmp does.

All global register variable declarations must precede all function definitions. If such a declaration could appear after function definitions, the declaration would be too late to prevent the register from being used for other purposes in the preceding functions.

Global register variables may not have initial values, because an executable file has no means to supply initial contents for a register.

On the Sparc, there are reports that g3 ... g7 are suitable registers, but certain library functions, such as getwd, as well as the subroutines for division and remainder, modify g3 and g4. g1 and g2 are local temporaries.

On the 68000, a2 ... a5 should be suitable, as should d2 ... d7. Of course, it will not do to use more than a few of those.


Using and Porting GNU CC - Local Reg Vars

Specifying Registers for Local Variables

You can define a local register variable with a specified register like this:

register int *foo asm ("a5");

Here a5 is the name of the register which should be used. Note that this is the same syntax used for defining global register variables, but for a local variable it would appear within a function.

Naturally the register name is cpu-dependent, but this is not a problem, since specific registers are most often useful with explicit assembler instructions (see section Assembler Instructions with C Expression Operands). Both of these things generally require that you conditionalize your program according to cpu type.

In addition, operating systems on one type of cpu may differ in how they name the registers; then you would need additional conditionals. For example, some 68000 operating systems call this register %a5.

Eventually there may be a way of asking the compiler to choose a register automatically, but first we need to figure out how it should choose and how to enable you to guide the choice. No solution is evident.

Defining such a register variable does not reserve the register; it remains available for other uses in places where flow control determines the variable's value is not live. However, these registers are made unavailable for use in the reload pass. I would not be surprised if excessive use of this feature leaves the compiler too few available registers to compile certain functions.


Using and Porting GNU CC - Alternate Keywords

Alternate Keywords

The option `-traditional' disables certain keywords; `-ansi' disables certain others. This causes trouble when you want to use GNU C extensions, or ANSI C features, in a general-purpose header file that should be usable by all programs, including ANSI C programs and traditional ones. The keywords asm, typeof and inline cannot be used since they won't work in a program compiled with `-ansi', while the keywords const, volatile, signed, typeof and inline won't work in a program compiled with `-traditional'.

The way to solve these problems is to put `__' at the beginning and end of each problematical keyword. For example, use __asm__ instead of asm, __const__ instead of const, and __inline__ instead of inline.

Other C compilers won't accept these alternative keywords; if you want to compile with another compiler, you can define the alternate keywords as macros to replace them with the customary keywords. It looks like this:

#ifndef __GNUC__
#define __asm__ asm
#endif

`-pedantic' causes warnings for many GNU C extensions. You can prevent such warnings within one expression by writing __extension__ before the expression. __extension__ has no effect aside from this.


Using and Porting GNU CC - Incomplete Enums

Incomplete enum Types

You can define an enum tag without specifying its possible values. This results in an incomplete type, much like what you get if you write struct foo without describing the elements. A later declaration which does specify the possible values completes the type.

You can't allocate variables or storage using the type while it is incomplete. However, you can work with pointers to that type.

This extension may not be very useful, but it makes the handling of enum more consistent with the way struct and union are handled.

This extension is not supported by GNU C++.


Using and Porting GNU CC - Function Names

Function Names as Strings

GNU CC predefines two string variables to be the name of the current function. The variable __FUNCTION__ is the name of the function as it appears in the source. The variable __PRETTY_FUNCTION__ is the name of the function pretty printed in a language specific fashion.

These names are always the same in a C function, but in a C++ function they may be different. For example, this program:

extern "C" {
extern int printf (char *, ...);
}

class a {
 public:
  sub (int i)
    {
      printf ("__FUNCTION__ = %s\n", __FUNCTION__);
      printf ("__PRETTY_FUNCTION__ = %s\n", __PRETTY_FUNCTION__);
    }
};

int
main (void)
{
  a ax;
  ax.sub (0);
  return 0;
}

gives this output:

__FUNCTION__ = sub
__PRETTY_FUNCTION__ = int  a::sub (int)

These names are not macros: they are predefined string variables. For example, `#ifdef __FUNCTION__' does not have any special meaning inside a function, since the preprocessor does not do anything special with the identifier __FUNCTION__.


Using and Porting GNU CC - Return Address

Getting the Return or Frame Address of a Function

These functions may be used to get information about the callers of a function.

__builtin_return_address (level)
This function returns the return address of the current function, or of one of its callers. The level argument is number of frames to scan up the call stack. A value of 0 yields the return address of the current function, a value of 1 yields the return address of the caller of the current function, and so forth. The level argument must be a constant integer. On some machines it may be impossible to determine the return address of any function other than the current one; in such cases, or when the top of the stack has been reached, this function will return 0. This function should only be used with a non-zero argument for debugging purposes.
__builtin_frame_address (level)
This function is similar to __builtin_return_address, but it returns the address of the function frame rather than the return address of the function. Calling __builtin_frame_address with a value of 0 yields the frame address of the current function, a value of 1 yields the frame address of the caller of the current function, and so forth. The frame is the area on the stack which holds local variables and saved registers. The frame address is normally the address of the first word pushed on to the stack by the function. However, the exact definition depends upon the processor and the calling convention. If the processor has a dedicated frame pointer register, and the function has a frame, then __builtin_frame_address will return the value of the frame pointer register. The caveats that apply to __builtin_return_address apply to this function as well.


Using and Porting GNU CC - C++ Extensions

Extensions to the C++ Language

The GNU compiler provides these extensions to the C++ language (and you can also use most of the C language extensions in your C++ programs). If you want to write code that checks whether these features are available, you can test for the GNU compiler the same way as for C programs: check for a predefined macro __GNUC__. You can also use __GNUG__ to test specifically for GNU C++ (see section `Standard Predefined Macros' in The C Preprocessor).


Using and Porting GNU CC - Naming Results

Named Return Values in C++

GNU C++ extends the function-definition syntax to allow you to specify a name for the result of a function outside the body of the definition, in C++ programs:

type
functionname (args) return resultname;
{
  ...
  body
  ...
}

You can use this feature to avoid an extra constructor call when a function result has a class type. For example, consider a function m, declared as `X v = m ();', whose result is of class X:

X
m ()
{
  X b;
  b.a = 23;
  return b;
}

Although m appears to have no arguments, in fact it has one implicit argument: the address of the return value. At invocation, the address of enough space to hold v is sent in as the implicit argument. Then b is constructed and its a field is set to the value 23. Finally, a copy constructor (a constructor of the form `X(X&)') is applied to b, with the (implicit) return value location as the target, so that v is now bound to the return value.

But this is wasteful. The local b is declared just to hold something that will be copied right out. While a compiler that combined an "elision" algorithm with interprocedural data flow analysis could conceivably eliminate all of this, it is much more practical to allow you to assist the compiler in generating efficient code by manipulating the return value explicitly, thus avoiding the local variable and copy constructor altogether.

Using the extended GNU C++ function-definition syntax, you can avoid the temporary allocation and copying by naming r as your return value at the outset, and assigning to its a field directly:

X
m () return r;
{
  r.a = 23;
}

The declaration of r is a standard, proper declaration, whose effects are executed before any of the body of m.

Functions of this type impose no additional restrictions; in particular, you can execute return statements, or return implicitly by reaching the end of the function body ("falling off the edge"). Cases like

X
m () return r (23);
{
  return;
}

(or even `X m () return r (23); { }') are unambiguous, since the return value r has been initialized in either case. The following code may be hard to read, but also works predictably:

X
m () return r;
{
  X b;
  return b;
}

The return value slot denoted by r is initialized at the outset, but the statement `return b;' overrides this value. The compiler deals with this by destroying r (calling the destructor if there is one, or doing nothing if there is not), and then reinitializing r with b.

This extension is provided primarily to help people who use overloaded operators, where there is a great need to control not just the arguments, but the return values of functions. For classes where the copy constructor incurs a heavy performance penalty (especially in the common case where there is a quick default constructor), this is a major savings. The disadvantage of this extension is that you do not control when the default constructor for the return value is called: it is always called at the beginning.


Using and Porting GNU CC - Min and Max

Minimum and Maximum Operators in C++

It is very convenient to have operators which return the "minimum" or the "maximum" of two arguments. In GNU C++ (but not in GNU C),

a <? b
is the minimum, returning the smaller of the numeric values a and b;
a >? b
is the maximum, returning the larger of the numeric values a and b.

These operations are not primitive in ordinary C++, since you can use a macro to return the minimum of two things in C++, as in the following example.

#define MIN(X,Y) ((X) < (Y) ? : (X) : (Y))

You might then use `int min = MIN (i, j);' to set min to the minimum value of variables i and j.

However, side effects in X or Y may cause unintended behavior. For example, MIN (i++, j++) will fail, incrementing the smaller counter twice. A GNU C extension allows you to write safe macros that avoid this kind of problem (see section Naming an Expression's Type). However, writing MIN and MAX as macros also forces you to use function-call notation for a fundamental arithmetic operation. Using GNU C++ extensions, you can write `int min = i <? j;' instead.

Since <? and >? are built into the compiler, they properly handle expressions with side-effects; `int min = i++ <? j++;' works correctly.


Using and Porting GNU CC - Destructors and Goto

goto and Destructors in GNU C++

In C++ programs, you can safely use the goto statement. When you use it to exit a block which contains aggregates requiring destructors, the destructors will run before the goto transfers control.

The compiler still forbids using goto to enter a scope that requires constructors.


Using and Porting GNU CC - C++ Interface

Declarations and Definitions in One Header

C++ object definitions can be quite complex. In principle, your source code will need two kinds of things for each object that you use across more than one source file. First, you need an interface specification, describing its structure with type declarations and function prototypes. Second, you need the implementation itself. It can be tedious to maintain a separate interface description in a header file, in parallel to the actual implementation. It is also dangerous, since separate interface and implementation definitions may not remain parallel.

With GNU C++, you can use a single header file for both purposes.

Warning: The mechanism to specify this is in transition. For the nonce, you must use one of two #pragma commands; in a future release of GNU C++, an alternative mechanism will make these #pragma commands unnecessary.

The header file contains the full definitions, but is marked with `#pragma interface' in the source code. This allows the compiler to use the header file only as an interface specification when ordinary source files incorporate it with #include. In the single source file where the full implementation belongs, you can use either a naming convention or `#pragma implementation' to indicate this alternate use of the header file.

#pragma interface
#pragma interface "subdir/objects.h"
Use this directive in header files that define object classes, to save space in most of the object files that use those classes. Normally, local copies of certain information (backup copies of inline member functions, debugging information, and the internal tables that implement virtual functions) must be kept in each object file that includes class definitions. You can use this pragma to avoid such duplication. When a header file containing `#pragma interface' is included in a compilation, this auxiliary information will not be generated (unless the main input source file itself uses `#pragma implementation'). Instead, the object files will contain references to be resolved at link time. The second form of this directive is useful for the case where you have multiple headers with the same name in different directories. If you use this form, you must specify the same string to `#pragma implementation'.
#pragma implementation
#pragma implementation "objects.h"
Use this pragma in a main input file, when you want full output from included header files to be generated (and made globally visible). The included header file, in turn, should use `#pragma interface'. Backup copies of inline member functions, debugging information, and the internal tables used to implement virtual functions are all generated in implementation files. If you use `#pragma implementation' with no argument, it applies to an include file with the same basename(3) as your source file. For example, in `allclass.cc', giving just `#pragma implementation' by itself is equivalent to `#pragma implementation "allclass.h"'. In versions of GNU C++ prior to 2.6.0 `allclass.h' was treated as an implementation file whenever you would include it from `allclass.cc' even if you never specified `#pragma implementation'. This was deemed to be more trouble than it was worth, however, and disabled. If you use an explicit `#pragma implementation', it must appear in your source file before you include the affected header files. Use the string argument if you want a single implementation file to include code from multiple header files. (You must also use `#include' to include the header file; `#pragma implementation' only specifies how to use the file--it doesn't actually include it.) There is no way to split up the contents of a single header file into multiple implementation files.

`#pragma implementation' and `#pragma interface' also have an effect on function inlining.

If you define a class in a header file marked with `#pragma interface', the effect on a function defined in that class is similar to an explicit extern declaration--the compiler emits no code at all to define an independent version of the function. Its definition is used only for inlining with its callers.

Conversely, when you include the same header file in a main source file that declares it as `#pragma implementation', the compiler emits code for the function itself; this defines a version of the function that can be found via pointers (or by callers compiled without inlining). If all calls to the function can be inlined, you can avoid emitting the function by compiling with `-fno-implement-inlines'. If any calls were not inlined, you will get linker errors.


Using and Porting GNU CC - Template Instantiation

Where's the Template?

C++ templates are the first language feature to require more intelligence from the environment than one usually finds on a UNIX system. Somehow the compiler and linker have to make sure that each template instance occurs exactly once in the executable if it is needed, and not at all otherwise. There are two basic approaches to this problem, which I will refer to as the Borland model and the Cfront model.

Borland model
Borland C++ solved the template instantiation problem by adding the code equivalent of common blocks to their linker; the compiler emits template instances in each translation unit that uses them, and the linker collapses them together. The advantage of this model is that the linker only has to consider the object files themselves; there is no external complexity to worry about. This disadvantage is that compilation time is increased because the template code is being compiled repeatedly. Code written for this model tends to include definitions of all templates in the header file, since they must be seen to be instantiated.
Cfront model
The AT&T C++ translator, Cfront, solved the template instantiation problem by creating the notion of a template repository, an automatically maintained place where template instances are stored. A more modern version of the repository works as follows: As individual object files are built, the compiler places any template definitions and instantiations encountered in the repository. At link time, the link wrapper adds in the objects in the repository and compiles any needed instances that were not previously emitted. The advantages of this model are more optimal compilation speed and the ability to use the system linker; to implement the Borland model a compiler vendor also needs to replace the linker. The disadvantages are vastly increased complexity, and thus potential for error; for some code this can be just as transparent, but in practice it can been very difficult to build multiple programs in one directory and one program in multiple directories. Code written for this model tends to separate definitions of non-inline member templates into a separate file, which should be compiled separately.

When used with GNU ld version 2.8 or later on an ELF system such as Linux/GNU or Solaris 2, or on Microsoft Windows, g++ supports the Borland model. On other systems, g++ implements neither automatic model.

A future version of g++ will support a hybrid model whereby the compiler will emit any instantiations for which the template definition is included in the compile, and store template definitions and instantiation context information into the object file for the rest. The link wrapper will extract that information as necessary and invoke the compiler to produce the remaining instantiations. The linker will then combine duplicate instantiations.

In the mean time, you have the following options for dealing with template instantiations:

  1. Compile your template-using code with `-frepo'. The compiler will generate files with the extension `.rpo' listing all of the template instantiations used in the corresponding object files which could be instantiated there; the link wrapper, `collect2', will then update the `.rpo' files to tell the compiler where to place those instantiations and rebuild any affected object files. The link-time overhead is negligible after the first pass, as the compiler will continue to place the instantiations in the same files. This is your best option for application code written for the Borland model, as it will just work. Code written for the Cfront model will need to be modified so that the template definitions are available at one or more points of instantiation; usually this is as simple as adding #include <tmethods.cc> to the end of each template header. For library code, if you want the library to provide all of the template instantiations it needs, just try to link all of its object files together; the link will fail, but cause the instantiations to be generated as a side effect. Be warned, however, that this may cause conflicts if multiple libraries try to provide the same instantiations. For greater control, use explicit instantiation as described in the next option.
  2. Compile your code with `-fno-implicit-templates' to disable the implicit generation of template instances, and explicitly instantiate all the ones you use. This approach requires more knowledge of exactly which instances you need than do the others, but it's less mysterious and allows greater control. You can scatter the explicit instantiations throughout your program, perhaps putting them in the translation units where the instances are used or the translation units that define the templates themselves; you can put all of the explicit instantiations you need into one big file; or you can create small files like
    #include "Foo.h"
#include "Foo.cc"

template class Foo<int>;
template ostream& operator <<
                (ostream&, const Foo<int>&);
    for each of the instances you need, and create a template instantiation library from those. If you are using Cfront-model code, you can probably get away with not using `-fno-implicit-templates' when compiling files that don't `#include' the member template definitions. If you use one big file to do the instantiations, you may want to compile it without `-fno-implicit-templates' so you get all of the instances required by your explicit instantiations (but not by any other files) without having to specify them as well. g++ has extended the template instantiation syntax outlined in the Working Paper to allow forward declaration of explicit instantiations, explicit instantiation of members of template classes and instantiation of the compiler support data for a template class (i.e. the vtable) without instantiating any of its members:
    extern template int max (int, int);
template void Foo<int>::f ();
inline template class Foo<int>;
  3. Do nothing. Pretend g++ does implement automatic instantiation management. Code written for the Borland model will work fine, but each translation unit will contain instances of each of the templates it uses. In a large program, this can lead to an unacceptable amount of code duplication.
  4. Add `#pragma interface' to all files containing template definitions. For each of these files, add `#pragma implementation "filename"' to the top of some `.C' file which `#include's it. Then compile everything with `-fexternal-templates'. The templates will then only be expanded in the translation unit which implements them (i.e. has a `#pragma implementation' line for the file where they live); all other files will use external references. If you're lucky, everything should work properly. If you get undefined symbol errors, you need to make sure that each template instance which is used in the program is used in the file which implements that template. If you don't have any use for a particular instance in that file, you can just instantiate it explicitly, using the syntax from the latest C++ working paper:
    template class A<int>;
template ostream& operator << (ostream&, const A<int>&);
    This strategy will work with code written for either model. If you are using code written for the Cfront model, the file containing a class template and the file containing its member templates should be implemented in the same translation unit. A slight variation on this approach is to instead use the flag `-falt-external-templates'; this flag causes template instances to be emitted in the translation unit that implements the header where they are first instantiated, rather than the one which implements the file where the templates are defined. This header must be the same in all translation units, or things are likely to break. See section Declarations and Definitions in One Header, for more discussion of these pragmas.


Using and Porting GNU CC - C++ Signatures

Type Abstraction using Signatures

In GNU C++, you can use the keyword signature to define a completely abstract class interface as a datatype. You can connect this abstraction with actual classes using signature pointers. If you want to use signatures, run the GNU compiler with the `-fhandle-signatures' command-line option. (With this option, the compiler reserves a second keyword sigof as well, for a future extension.)

Roughly, signatures are type abstractions or interfaces of classes. Some other languages have similar facilities. C++ signatures are related to ML's signatures, Haskell's type classes, definition modules in Modula-2, interface modules in Modula-3, abstract types in Emerald, type modules in Trellis/Owl, categories in Scratchpad II, and types in POOL-I. For a more detailed discussion of signatures, see Signatures: A Language Extension for Improving Type Abstraction and Subtype Polymorphism in C++ by Gerald Baumgartner and Vincent F. Russo (Tech report CSD--TR--95--051, Dept. of Computer Sciences, Purdue University, August 1995, a slightly improved version appeared in Software--Practice & Experience, 25(8), pp. 863--889, August 1995). You can get the tech report by anonymous FTP from ftp.cs.purdue.edu in `pub/gb/Signature-design.ps.gz'.

Syntactically, a signature declaration is a collection of member function declarations and nested type declarations. For example, this signature declaration defines a new abstract type S with member functions `int foo ()' and `int bar (int)':

signature S
{
  int foo ();
  int bar (int);
};

Since signature types do not include implementation definitions, you cannot write an instance of a signature directly. Instead, you can define a pointer to any class that contains the required interfaces as a signature pointer. Such a class implements the signature type.

To use a class as an implementation of S, you must ensure that the class has public member functions `int foo ()' and `int bar (int)'. The class can have other member functions as well, public or not; as long as it offers what's declared in the signature, it is suitable as an implementation of that signature type.

For example, suppose that C is a class that meets the requirements of signature S (C conforms to S). Then

C obj;
S * p = &obj;

defines a signature pointer p and initializes it to point to an object of type C. The member function call `int i = p->foo ();' executes `obj.foo ()'.

Abstract virtual classes provide somewhat similar facilities in standard C++. There are two main advantages to using signatures instead:

  1. Subtyping becomes independent from inheritance. A class or signature type T is a subtype of a signature type S independent of any inheritance hierarchy as long as all the member functions declared in S are also found in T. So you can define a subtype hierarchy that is completely independent from any inheritance (implementation) hierarchy, instead of being forced to use types that mirror the class inheritance hierarchy.
  2. Signatures allow you to work with existing class hierarchies as implementations of a signature type. If those class hierarchies are only available in compiled form, you're out of luck with abstract virtual classes, since an abstract virtual class cannot be retrofitted on top of existing class hierarchies. So you would be required to write interface classes as subtypes of the abstract virtual class.

There is one more detail about signatures. A signature declaration can contain member function definitions as well as member function declarations. A signature member function with a full definition is called a default implementation; classes need not contain that particular interface in order to conform. For example, a class C can conform to the signature

signature T
{
  int f (int);
  int f0 () { return f (0); };
};

whether or not C implements the member function `int f0 ()'. If you define C::f0, that definition takes precedence; otherwise, the default implementation S::f0 applies.


Using and Porting GNU CC - Gcov

gcov: a Test Coverage Program

gcov is a tool you can use in conjunction with GNU CC to test code coverage in your programs.

This chapter describes version 1.5 of gcov.


Using and Porting GNU CC - Gcov Intro

Introduction to gcov

gcov is a test coverage program. Use it in concert with GNU CC to analyze your programs to help create more efficient, faster running code. You can use gcov as a profiling tool to help discover where your optimization efforts will best affect your code. You can also use gcov along with the other profiling tool, gprof, to assess which parts of your code use the greatest amount of computing time.

Profiling tools help you analyze your code's performance. Using a profiler such as gcov or gprof, you can find out some basic performance statistics, such as:

  • how often each line of code executes
  • what lines of code are actually executed
  • how much computing time each section of code uses

Once you know these things about how your code works when compiled, you can look at each module to see which modules should be optimized. gcov helps you determine where to work on optimization.

Software developers also use coverage testing in concert with testsuites, to make sure software is actually good enough for a release. Testsuites can verify that a program works as expected; a coverage program tests to see how much of the program is exercised by the testsuite. Developers can then determine what kinds of test cases need to be added to the testsuites to create both better testing and a better final product.

You should compile your code without optimization if you plan to use gcov because the optimization, by combining some lines of code into one function, may not give you as much information as you need to look for `hot spots' where the code is using a great deal of computer time. Likewise, because gcov accumulates statistics by line (at the lowest resolution), it works best with a programming style that places only one statement on each line. If you use complicated macros that expand to loops or to other control structures, the statistics are less helpful--they only report on the line where the macro call appears. If your complex macros behave like functions, you can replace them with inline functions to solve this problem.

gcov creates a logfile called `sourcefile.gcov' which indicates how many times each line of a source file `sourcefile.c' has executed. You can use these logfiles along with gprof to aid in fine-tuning the performance of your programs. gprof gives timing information you can use along with the information you get from gcov.

gcov works only on code compiled with GNU CC. It is not compatible with any other profiling or test coverage mechanism.


Using and Porting GNU CC - Invoking Gcov

Invoking gcov

gcov [-b] [-v] [-n] [-l] [-f] [-o directory] sourcefile
-b
Write branch frequencies to the output file, and write branch summary info to the standard output. This option allows you to see how often each branch in your program was taken.
-v
Display the gcov version number (on the standard error stream).
-n
Do not create the gcov output file.
-l
Create long file names for included source files. For example, if the header file `x.h' contains code, and was included in the file `a.c', then running gcov on the file `a.c' will produce an output file called `a.c.x.h.gcov' instead of `x.h.gcov'. This can be useful if `x.h' is included in multiple source files.
-f
Output summaries for each function in addition to the file level summary.
-o
The directory where the object files live. Gcov will search for .bb, .bbg, and .da files in this directory.

When using gcov, you must first compile your program with two special GNU CC options: `-fprofile-arcs -ftest-coverage'. This tells the compiler to generate additional information needed by gcov (basically a flow graph of the program) and also includes additional code in the object files for generating the extra profiling information needed by gcov. These additional files are placed in the directory where the source code is located.

Running the program will cause profile output to be generated. For each source file compiled with -fprofile-arcs, an accompanying .da file will be placed in the source directory.

Running gcov with your program's source file names as arguments will now produce a listing of the code along with frequency of execution for each line. For example, if your program is called `tmp.c', this is what you see when you use the basic gcov facility:

$ gcc -fprofile-arcs -ftest-coverage tmp.c
$ a.out
$ gcov tmp.c
 87.50% of 8 source lines executed in file tmp.c
Creating tmp.c.gcov.

The file `tmp.c.gcov' contains output from gcov. Here is a sample:

                main()
                {
           1      int i, total;

           1      total = 0;

          11      for (i = 0; i < 10; i++)
          10        total += i;

           1      if (total != 45)
      ######        printf ("Failure\n");
                  else
           1        printf ("Success\n");
           1    }

When you use the `-b' option, your output looks like this:

$ gcov -b tmp.c
 87.50% of 8 source lines executed in file tmp.c
 80.00% of 5 branches executed in file tmp.c
 80.00% of 5 branches taken at least once in file tmp.c
 50.00% of 2 calls executed in file tmp.c
Creating tmp.c.gcov.

Here is a sample of a resulting `tmp.c.gcov' file:

                main()
                {
           1      int i, total;

           1      total = 0;

          11      for (i = 0; i < 10; i++)
branch 0 taken = 91%
branch 1 taken = 100%
branch 2 taken = 100%
          10        total += i;

           1      if (total != 45)
branch 0 taken = 100%
      ######        printf ("Failure\n");
call 0 never executed
branch 1 never executed
                  else
           1        printf ("Success\n");
call 0 returns = 100%
           1    }

For each basic block, a line is printed after the last line of the basic block describing the branch or call that ends the basic block. There can be multiple branches and calls listed for a single source line if there are multiple basic blocks that end on that line. In this case, the branches and calls are each given a number. There is no simple way to map these branches and calls back to source constructs. In general, though, the lowest numbered branch or call will correspond to the leftmost construct on the source line.

For a branch, if it was executed at least once, then a percentage indicating the number of times the branch was taken divided by the number of times the branch was executed will be printed. Otherwise, the message "never executed" is printed.

For a call, if it was executed at least once, then a percentage indicating the number of times the call returned divided by the number of times the call was executed will be printed. This will usually be 100%, but may be less for functions call exit or longjmp, and thus may not return everytime they are called.

The execution counts are cumulative. If the example program were executed again without removing the .da file, the count for the number of times each line in the source was executed would be added to the results of the previous run(s). This is potentially useful in several ways. For example, it could be used to accumulate data over a number of program runs as part of a test verification suite, or to provide more accurate long-term information over a large number of program runs.

The data in the .da files is saved immediately before the program exits. For each source file compiled with -fprofile-arcs, the profiling code first attempts to read in an existing .da file; if the file doesn't match the executable (differing number of basic block counts) it will ignore the contents of the file. It then adds in the new execution counts and finally writes the data to the file.


Using and Porting GNU CC - Gcov and Optimization

Using gcov with GCC Optimization

If you plan to use gcov to help optimize your code, you must first compile your program with two special GNU CC options: `-fprofile-arcs -ftest-coverage'. Aside from that, you can use any other GNU CC options; but if you want to prove that every single line in your program was executed, you should not compile with optimization at the same time. On some machines the optimizer can eliminate some simple code lines by combining them with other lines. For example, code like this:

if (a != b)
  c = 1;
else
  c = 0;

can be compiled into one instruction on some machines. In this case, there is no way for gcov to calculate separate execution counts for each line because there isn't separate code for each line. Hence the gcov output looks like this if you compiled the program with optimization:

      100  if (a != b)
      100    c = 1;
      100  else
      100    c = 0;

The output shows that this block of code, combined by optimization, executed 100 times. In one sense this result is correct, because there was only one instruction representing all four of these lines. However, the output does not indicate how many times the result was 0 and how many times the result was 1.


Using and Porting GNU CC - Gcov Data Files

Brief description of gcov data files

gcov uses three files for doing profiling. The names of these files are derived from the original source file by substituting the file suffix with either .bb, .bbg, or .da. All of these files are placed in the same directory as the source file, and contain data stored in a platform-independent method.

The .bb and .bbg files are generated when the source file is compiled with the GNU CC `-ftest-coverage' option. The .bb file contains a list of source files (including headers), functions within those files, and line numbers corresponding to each basic block in the source file.

The .bb file format consists of several lists of 4-byte integers which correspond to the line numbers of each basic block in the file. Each list is terminated by a line number of 0. A line number of -1 is used to designate that the source file name (padded to a 4-byte boundary and followed by another -1) follows. In addition, a line number of -2 is used to designate that the name of a function (also padded to a 4-byte boundary and followed by a -2) follows.

The .bbg file is used to reconstruct the program flow graph for the source file. It contains a list of the program flow arcs (possible branches taken from one basic block to another) for each function which, in combination with the .bb file, enables gcov to reconstruct the program flow.

In the .bbg file, the format is:

        number of basic blocks for function #0 (4-byte number)
        total number of arcs for function #0 (4-byte number)
        count of arcs in basic block #0 (4-byte number)
        destination basic block of arc #0 (4-byte number)
        flag bits (4-byte number)
        destination basic block of arc #1 (4-byte number)
        flag bits (4-byte number)
        ...
        destination basic block of arc #N (4-byte number)
        flag bits (4-byte number)
        count of arcs in basic block #1 (4-byte number)
        destination basic block of arc #0 (4-byte number)
        flag bits (4-byte number)
        ...

A -1 (stored as a 4-byte number) is used to separate each function's list of basic blocks, and to verify that the file has been read correctly.

The .da file is generated when a program containing object files built with the GNU CC `-fprofile-arcs' option is executed. A separate .da file is created for each source file compiled with this option, and the name of the .da file is stored as an absolute pathname in the resulting object file. This path name is derived from the source file name by substituting a .da suffix.

The format of the .da file is fairly simple. The first 8-byte number is the number of counts in the file, followed by the counts (stored as 8-byte numbers). Each count corresponds to the number of times each arc in the program is executed. The counts are cumulative; each time the program is executed, it attemps to combine the existing .da files with the new counts for this invocation of the program. It ignores the contents of any .da files whose number of arcs doesn't correspond to the current program, and merely overwrites them instead.

All three of these files use the functions in gcov-io.h to store integers; the functions in this header provide a machine-independent mechanism for storing and retrieving data from a stream.


Using and Porting GNU CC - Trouble

Known Causes of Trouble with GNU CC

This section describes known problems that affect users of GNU CC. Most of these are not GNU CC bugs per se--if they were, we would fix them. But the result for a user may be like the result of a bug.

Some of these problems are due to bugs in other software, some are missing features that are too much work to add, and some are places where people's opinions differ as to what is best.


Using and Porting GNU CC - Actual Bugs

Actual Bugs We Haven't Fixed Yet

  • The fixincludes script interacts badly with automounters; if the directory of system header files is automounted, it tends to be unmounted while fixincludes is running. This would seem to be a bug in the automounter. We don't know any good way to work around it.
  • The fixproto script will sometimes add prototypes for the sigsetjmp and siglongjmp functions that reference the jmp_buf type before that type is defined. To work around this, edit the offending file and place the typedef in front of the prototypes.
  • There are several obscure case of mis-using struct, union, and enum tags that are not detected as errors by the compiler.
  • When `-pedantic-errors' is specified, GNU C will incorrectly give an error message when a function name is specified in an expression involving the comma operator.
  • Loop unrolling doesn't work properly for certain C++ programs. This is a bug in the C++ front end. It sometimes emits incorrect debug info, and the loop unrolling code is unable to recover from this error.


Using and Porting GNU CC - Installation Problems

Installation Problems

This is a list of problems (and some apparent problems which don't really mean anything is wrong) that show up during installation of GNU CC.

  • On certain systems, defining certain environment variables such as CC can interfere with the functioning of make.
  • If you encounter seemingly strange errors when trying to build the compiler in a directory other than the source directory, it could be because you have previously configured the compiler in the source directory. Make sure you have done all the necessary preparations. See section Compilation in a Separate Directory.
  • If you build GNU CC on a BSD system using a directory stored in a System V file system, problems may occur in running fixincludes if the System V file system doesn't support symbolic links. These problems result in a failure to fix the declaration of size_t in `sys/types.h'. If you find that size_t is a signed type and that type mismatches occur, this could be the cause. The solution is not to use such a directory for building GNU CC.
  • In previous versions of GNU CC, the gcc driver program looked for as and ld in various places; for example, in files beginning with `/usr/local/lib/gcc-'. GNU CC version 2 looks for them in the directory `/usr/local/lib/gcc-lib/target/version'. Thus, to use a version of as or ld that is not the system default, for example gas or GNU ld, you must put them in that directory (or make links to them from that directory).
  • Some commands executed when making the compiler may fail (return a non-zero status) and be ignored by make. These failures, which are often due to files that were not found, are expected, and can safely be ignored.
  • It is normal to have warnings in compiling certain files about unreachable code and about enumeration type clashes. These files' names begin with `insn-'. Also, `real.c' may get some warnings that you can ignore.
  • Sometimes make recompiles parts of the compiler when installing the compiler. In one case, this was traced down to a bug in make. Either ignore the problem or switch to GNU Make.
  • If you have installed a program known as purify, you may find that it causes errors while linking enquire, which is part of building GNU CC. The fix is to get rid of the file real-ld which purify installs--so that GNU CC won't try to use it.
  • On Linux SLS 1.01, there is a problem with `libc.a': it does not contain the obstack functions. However, GNU CC assumes that the obstack functions are in `libc.a' when it is the GNU C library. To work around this problem, change the __GNU_LIBRARY__ conditional around line 31 to `#if 1'.
  • On some 386 systems, building the compiler never finishes because enquire hangs due to a hardware problem in the motherboard--it reports floating point exceptions to the kernel incorrectly. You can install GNU CC except for `float.h' by patching out the command to run enquire. You may also be able to fix the problem for real by getting a replacement motherboard. This problem was observed in Revision E of the Micronics motherboard, and is fixed in Revision F. It has also been observed in the MYLEX MXA-33 motherboard. If you encounter this problem, you may also want to consider removing the FPU from the socket during the compilation. Alternatively, if you are running SCO Unix, you can reboot and force the FPU to be ignored. To do this, type `hd(40)unix auto ignorefpu'.
  • On some 386 systems, GNU CC crashes trying to compile `enquire.c'. This happens on machines that don't have a 387 FPU chip. On 386 machines, the system kernel is supposed to emulate the 387 when you don't have one. The crash is due to a bug in the emulator. One of these systems is the Unix from Interactive Systems: 386/ix. On this system, an alternate emulator is provided, and it does work. To use it, execute this command as super-user:
    ln /etc/emulator.rel1 /etc/emulator
    and then reboot the system. (The default emulator file remains present under the name `emulator.dflt'.) Try using `/etc/emulator.att', if you have such a problem on the SCO system. Another system which has this problem is Esix. We don't know whether it has an alternate emulator that works. On NetBSD 0.8, a similar problem manifests itself as these error messages:
    enquire.c: In function `fprop':
enquire.c:2328: floating overflow
  • On SCO systems, when compiling GNU CC with the system's compiler, do not use `-O'. Some versions of the system's compiler miscompile GNU CC with `-O'.
  • Sometimes on a Sun 4 you may observe a crash in the program genflags or genoutput while building GNU CC. This is said to be due to a bug in sh. You can probably get around it by running genflags or genoutput manually and then retrying the make.
  • On Solaris 2, executables of GNU CC version 2.0.2 are commonly available, but they have a bug that shows up when compiling current versions of GNU CC: undefined symbol errors occur during assembly if you use `-g'. The solution is to compile the current version of GNU CC without `-g'. That makes a working compiler which you can use to recompile with `-g'.
  • Solaris 2 comes with a number of optional OS packages. Some of these packages are needed to use GNU CC fully. If you did not install all optional packages when installing Solaris, you will need to verify that the packages that GNU CC needs are installed. To check whether an optional package is installed, use the pkginfo command. To add an optional package, use the pkgadd command. For further details, see the Solaris documentation. For Solaris 2.0 and 2.1, GNU CC needs six packages: `SUNWarc', `SUNWbtool', `SUNWesu', `SUNWhea', `SUNWlibm', and `SUNWtoo'. For Solaris 2.2, GNU CC needs an additional seventh package: `SUNWsprot'.
  • On Solaris 2, trying to use the linker and other tools in `/usr/ucb' to install GNU CC has been observed to cause trouble. For example, the linker may hang indefinitely. The fix is to remove `/usr/ucb' from your PATH.
  • If you use the 1.31 version of the MIPS assembler (such as was shipped with Ultrix 3.1), you will need to use the -fno-delayed-branch switch when optimizing floating point code. Otherwise, the assembler will complain when the GCC compiler fills a branch delay slot with a floating point instruction, such as add.d.
  • If on a MIPS system you get an error message saying "does not have gp sections for all it's [sic] sectons [sic]", don't worry about it. This happens whenever you use GAS with the MIPS linker, but there is not really anything wrong, and it is okay to use the output file. You can stop such warnings by installing the GNU linker. It would be nice to extend GAS to produce the gp tables, but they are optional, and there should not be a warning about their absence.
  • In Ultrix 4.0 on the MIPS machine, `stdio.h' does not work with GNU CC at all unless it has been fixed with fixincludes. This causes problems in building GNU CC. Once GNU CC is installed, the problems go away. To work around this problem, when making the stage 1 compiler, specify this option to Make:
    GCC_FOR_TARGET="./xgcc -B./ -I./include"
    When making stage 2 and stage 3, specify this option:
    CFLAGS="-g -I./include"
  • Users have reported some problems with version 2.0 of the MIPS compiler tools that were shipped with Ultrix 4.1. Version 2.10 which came with Ultrix 4.2 seems to work fine. Users have also reported some problems with version 2.20 of the MIPS compiler tools that were shipped with RISC/os 4.x. The earlier version 2.11 seems to work fine.
  • Some versions of the MIPS linker will issue an assertion failure when linking code that uses alloca against shared libraries on RISC-OS 5.0, and DEC's OSF/1 systems. This is a bug in the linker, that is supposed to be fixed in future revisions. To protect against this, GNU CC passes `-non_shared' to the linker unless you pass an explicit `-shared' or `-call_shared' switch.
  • On System V release 3, you may get this error message while linking:
    ld fatal: failed to write symbol name something
 in strings table for file whatever
    This probably indicates that the disk is full or your ULIMIT won't allow the file to be as large as it needs to be. This problem can also result because the kernel parameter MAXUMEM is too small. If so, you must regenerate the kernel and make the value much larger. The default value is reported to be 1024; a value of 32768 is said to work. Smaller values may also work.
  • On System V, if you get an error like this,
    /usr/local/lib/bison.simple: In function `yyparse':
/usr/local/lib/bison.simple:625: virtual memory exhausted
    that too indicates a problem with disk space, ULIMIT, or MAXUMEM.
  • Current GNU CC versions probably do not work on version 2 of the NeXT operating system.
  • On NeXTStep 3.0, the Objective C compiler does not work, due, apparently, to a kernel bug that it happens to trigger. This problem does not happen on 3.1.
  • On the Tower models 4n0 and 6n0, by default a process is not allowed to have more than one megabyte of memory. GNU CC cannot compile itself (or many other programs) with `-O' in that much memory. To solve this problem, reconfigure the kernel adding the following line to the configuration file:
    MAXUMEM = 4096
  • On HP 9000 series 300 or 400 running HP-UX release 8.0, there is a bug in the assembler that must be fixed before GNU CC can be built. This bug manifests itself during the first stage of compilation, while building `libgcc2.a':
    _floatdisf
cc1: warning: `-g' option not supported on this version of GCC
cc1: warning: `-g1' option not supported on this version of GCC
./xgcc: Internal compiler error: program as got fatal signal 11
    A patched version of the assembler is available by anonymous ftp from altdorf.ai.mit.edu as the file `archive/cph/hpux-8.0-assembler'. If you have HP software support, the patch can also be obtained directly from HP, as described in the following note:

    This is the patched assembler, to patch SR#1653-010439, where the assembler aborts on floating point constants.

    The bug is not really in the assembler, but in the shared library version of the function "cvtnum(3c)". The bug on "cvtnum(3c)" is SR#4701-078451. Anyway, the attached assembler uses the archive library version of "cvtnum(3c)" and thus does not exhibit the bug.

    This patch is also known as PHCO_4484.
  • On HP-UX version 8.05, but not on 8.07 or more recent versions, the fixproto shell script triggers a bug in the system shell. If you encounter this problem, upgrade your operating system or use BASH (the GNU shell) to run fixproto.
  • Some versions of the Pyramid C compiler are reported to be unable to compile GNU CC. You must use an older version of GNU CC for bootstrapping. One indication of this problem is if you get a crash when GNU CC compiles the function muldi3 in file `libgcc2.c'. You may be able to succeed by getting GNU CC version 1, installing it, and using it to compile GNU CC version 2. The bug in the Pyramid C compiler does not seem to affect GNU CC version 1.
  • There may be similar problems on System V Release 3.1 on 386 systems.
  • On the Intel Paragon (an i860 machine), if you are using operating system version 1.0, you will get warnings or errors about redefinition of va_arg when you build GNU CC. If this happens, then you need to link most programs with the library `iclib.a'. You must also modify `stdio.h' as follows: before the lines
    #if     defined(__i860__) && !defined(_VA_LIST)
#include <va_list.h>
    insert the line
    #if __PGC__
    and after the lines
    extern int  vprintf(const char *, va_list );
extern int  vsprintf(char *, const char *, va_list );
#endif
    insert the line
    #endif /* __PGC__ */
    These problems don't exist in operating system version 1.1.
  • On the Altos 3068, programs compiled with GNU CC won't work unless you fix a kernel bug. This happens using system versions V.2.2 1.0gT1 and V.2.2 1.0e and perhaps later versions as well. See the file `README.ALTOS'.
  • You will get several sorts of compilation and linking errors on the we32k if you don't follow the special instructions. See section Configurations Supported by GNU CC.
  • A bug in the HP-UX 8.05 (and earlier) shell will cause the fixproto program to report an error of the form:
    ./fixproto: sh internal 1K buffer overflow
    To fix this, change the first line of the fixproto script to look like:
    #!/bin/ksh


Using and Porting GNU CC - Cross-Compiler Problems

Cross-Compiler Problems

You may run into problems with cross compilation on certain machines, for several reasons.

  • Cross compilation can run into trouble for certain machines because some target machines' assemblers require floating point numbers to be written as integer constants in certain contexts. The compiler writes these integer constants by examining the floating point value as an integer and printing that integer, because this is simple to write and independent of the details of the floating point representation. But this does not work if the compiler is running on a different machine with an incompatible floating point format, or even a different byte-ordering. In addition, correct constant folding of floating point values requires representing them in the target machine's format. (The C standard does not quite require this, but in practice it is the only way to win.) It is now possible to overcome these problems by defining macros such as REAL_VALUE_TYPE. But doing so is a substantial amount of work for each target machine. See section Cross Compilation and Floating Point.
  • At present, the program `mips-tfile' which adds debug support to object files on MIPS systems does not work in a cross compile environment.


Using and Porting GNU CC - Interoperation

Interoperation

This section lists various difficulties encountered in using GNU C or GNU C++ together with other compilers or with the assemblers, linkers, libraries and debuggers on certain systems.

  • Objective C does not work on the RS/6000.
  • GNU C++ does not do name mangling in the same way as other C++ compilers. This means that object files compiled with one compiler cannot be used with another. This effect is intentional, to protect you from more subtle problems. Compilers differ as to many internal details of C++ implementation, including: how class instances are laid out, how multiple inheritance is implemented, and how virtual function calls are handled. If the name encoding were made the same, your programs would link against libraries provided from other compilers--but the programs would then crash when run. Incompatible libraries are then detected at link time, rather than at run time.
  • Older GDB versions sometimes fail to read the output of GNU CC version 2. If you have trouble, get GDB version 4.4 or later.
  • DBX rejects some files produced by GNU CC, though it accepts similar constructs in output from PCC. Until someone can supply a coherent description of what is valid DBX input and what is not, there is nothing I can do about these problems. You are on your own.
  • The GNU assembler (GAS) does not support PIC. To generate PIC code, you must use some other assembler, such as `/bin/as'.
  • On some BSD systems, including some versions of Ultrix, use of profiling causes static variable destructors (currently used only in C++) not to be run.
  • Use of `-I/usr/include' may cause trouble. Many systems come with header files that won't work with GNU CC unless corrected by fixincludes. The corrected header files go in a new directory; GNU CC searches this directory before `/usr/include'. If you use `-I/usr/include', this tells GNU CC to search `/usr/include' earlier on, before the corrected headers. The result is that you get the uncorrected header files. Instead, you should use these options (when compiling C programs):
    -I/usr/local/lib/gcc-lib/target/version/include -I/usr/include
    For C++ programs, GNU CC also uses a special directory that defines C++ interfaces to standard C subroutines. This directory is meant to be searched before other standard include directories, so that it takes precedence. If you are compiling C++ programs and specifying include directories explicitly, use this option first, then the two options above:
    -I/usr/local/lib/g++-include
  • On some SGI systems, when you use `-lgl_s' as an option, it gets translated magically to `-lgl_s -lX11_s -lc_s'. Naturally, this does not happen when you use GNU CC. You must specify all three options explicitly.
  • On a Sparc, GNU CC aligns all values of type double on an 8-byte boundary, and it expects every double to be so aligned. The Sun compiler usually gives double values 8-byte alignment, with one exception: function arguments of type double may not be aligned. As a result, if a function compiled with Sun CC takes the address of an argument of type double and passes this pointer of type double * to a function compiled with GNU CC, dereferencing the pointer may cause a fatal signal. One way to solve this problem is to compile your entire program with GNU CC. Another solution is to modify the function that is compiled with Sun CC to copy the argument into a local variable; local variables are always properly aligned. A third solution is to modify the function that uses the pointer to dereference it via the following function access_double instead of directly with `*':
    inline double
access_double (double *unaligned_ptr)
{
  union d2i { double d; int i[2]; };

  union d2i *p = (union d2i *) unaligned_ptr;
  union d2i u;

  u.i[0] = p->i[0];
  u.i[1] = p->i[1];

  return u.d;
}
    Storing into the pointer can be done likewise with the same union.
  • On Solaris, the malloc function in the `libmalloc.a' library may allocate memory that is only 4 byte aligned. Since GNU CC on the Sparc assumes that doubles are 8 byte aligned, this may result in a fatal signal if doubles are stored in memory allocated by the `libmalloc.a' library. The solution is to not use the `libmalloc.a' library. Use instead malloc and related functions from `libc.a'; they do not have this problem.
  • Sun forgot to include a static version of `libdl.a' with some versions of SunOS (mainly 4.1). This results in undefined symbols when linking static binaries (that is, if you use `-static'). If you see undefined symbols _dlclose, _dlsym or _dlopen when linking, compile and link against the file `mit/util/misc/dlsym.c' from the MIT version of X windows.
  • The 128-bit long double format that the Sparc port supports currently works by using the architecturally defined quad-word floating point instructions. Since there is no hardware that supports these instructions they must be emulated by the operating system. Long doubles do not work in Sun OS versions 4.0.3 and earlier, because the kernel emulator uses an obsolete and incompatible format. Long doubles do not work in Sun OS version 4.1.1 due to a problem in a Sun library. Long doubles do work on Sun OS versions 4.1.2 and higher, but GNU CC does not enable them by default. Long doubles appear to work in Sun OS 5.x (Solaris 2.x).
  • On HP-UX version 9.01 on the HP PA, the HP compiler cc does not compile GNU CC correctly. We do not yet know why. However, GNU CC compiled on earlier HP-UX versions works properly on HP-UX 9.01 and can compile itself properly on 9.01.
  • On the HP PA machine, ADB sometimes fails to work on functions compiled with GNU CC. Specifically, it fails to work on functions that use alloca or variable-size arrays. This is because GNU CC doesn't generate HP-UX unwind descriptors for such functions. It may even be impossible to generate them.
  • Debugging (`-g') is not supported on the HP PA machine, unless you use the preliminary GNU tools (see section Installing GNU CC).
  • Taking the address of a label may generate errors from the HP-UX PA assembler. GAS for the PA does not have this problem.
  • Using floating point parameters for indirect calls to static functions will not work when using the HP assembler. There simply is no way for GCC to specify what registers hold arguments for static functions when using the HP assembler. GAS for the PA does not have this problem.
  • In extremely rare cases involving some very large functions you may receive errors from the HP linker complaining about an out of bounds unconditional branch offset. This used to occur more often in previous versions of GNU CC, but is now exceptionally rare. If you should run into it, you can work around by making your function smaller.
  • GNU CC compiled code sometimes emits warnings from the HP-UX assembler of the form:
    (warning) Use of GR3 when
  frame >= 8192 may cause conflict.
    These warnings are harmless and can be safely ignored.
  • The current version of the assembler (`/bin/as') for the RS/6000 has certain problems that prevent the `-g' option in GCC from working. Note that `Makefile.in' uses `-g' by default when compiling `libgcc2.c'. IBM has produced a fixed version of the assembler. The upgraded assembler unfortunately was not included in any of the AIX 3.2 update PTF releases (3.2.2, 3.2.3, or 3.2.3e). Users of AIX 3.1 should request PTF U403044 from IBM and users of AIX 3.2 should request PTF U416277. See the file `README.RS6000' for more details on these updates. You can test for the presense of a fixed assembler by using the command
    as -u < /dev/null
    If the command exits normally, the assembler fix already is installed. If the assembler complains that "-u" is an unknown flag, you need to order the fix.
  • On the IBM RS/6000, compiling code of the form
    extern int foo;

... foo ...

static int foo;
    will cause the linker to report an undefined symbol foo. Although this behavior differs from most other systems, it is not a bug because redefining an extern variable as static is undefined in ANSI C.
  • AIX on the RS/6000 provides support (NLS) for environments outside of the United States. Compilers and assemblers use NLS to support locale-specific representations of various objects including floating-point numbers ("." vs "," for separating decimal fractions). There have been problems reported where the library linked with GCC does not produce the same floating-point formats that the assembler accepts. If you have this problem, set the LANG environment variable to "C" or "En_US".
  • Even if you specify `-fdollars-in-identifiers', you cannot successfully use `$' in identifiers on the RS/6000 due to a restriction in the IBM assembler. GAS supports these identifiers.
  • On the RS/6000, XLC version 1.3.0.0 will miscompile `jump.c'. XLC version 1.3.0.1 or later fixes this problem. You can obtain XLC-1.3.0.2 by requesting PTF 421749 from IBM.
  • There is an assembler bug in versions of DG/UX prior to 5.4.2.01 that occurs when the `fldcr' instruction is used. GNU CC uses `fldcr' on the 88100 to serialize volatile memory references. Use the option `-mno-serialize-volatile' if your version of the assembler has this bug.
  • On VMS, GAS versions 1.38.1 and earlier may cause spurious warning messages from the linker. These warning messages complain of mismatched psect attributes. You can ignore them. See section Installing GNU CC on VMS.
  • On NewsOS version 3, if you include both of the files `stddef.h' and `sys/types.h', you get an error because there are two typedefs of size_t. You should change `sys/types.h' by adding these lines around the definition of size_t:
    #ifndef _SIZE_T
#define _SIZE_T
actual typedef here
#endif
  • On the Alliant, the system's own convention for returning structures and unions is unusual, and is not compatible with GNU CC no matter what options are used.
  • On the IBM RT PC, the MetaWare HighC compiler (hc) uses a different convention for structure and union returning. Use the option `-mhc-struct-return' to tell GNU CC to use a convention compatible with it.
  • On Ultrix, the Fortran compiler expects registers 2 through 5 to be saved by function calls. However, the C compiler uses conventions compatible with BSD Unix: registers 2 through 5 may be clobbered by function calls. GNU CC uses the same convention as the Ultrix C compiler. You can use these options to produce code compatible with the Fortran compiler:
    -fcall-saved-r2 -fcall-saved-r3 -fcall-saved-r4 -fcall-saved-r5
  • On the WE32k, you may find that programs compiled with GNU CC do not work with the standard shared C library. You may need to link with the ordinary C compiler. If you do so, you must specify the following options:
    -L/usr/local/lib/gcc-lib/we32k-att-sysv/2.7.1 -lgcc -lc_s
    The first specifies where to find the library `libgcc.a' specified with the `-lgcc' option. GNU CC does linking by invoking ld, just as cc does, and there is no reason why it should matter which compilation program you use to invoke ld. If someone tracks this problem down, it can probably be fixed easily.
  • On the Alpha, you may get assembler errors about invalid syntax as a result of floating point constants. This is due to a bug in the C library functions ecvt, fcvt and gcvt. Given valid floating point numbers, they sometimes print `NaN'.
  • On Irix 4.0.5F (and perhaps in some other versions), an assembler bug sometimes reorders instructions incorrectly when optimization is turned on. If you think this may be happening to you, try using the GNU assembler; GAS version 2.1 supports ECOFF on Irix. Or use the `-noasmopt' option when you compile GNU CC with itself, and then again when you compile your program. (This is a temporary kludge to turn off assembler optimization on Irix.) If this proves to be what you need, edit the assembler spec in the file `specs' so that it unconditionally passes `-O0' to the assembler, and never passes `-O2' or `-O3'.


Using and Porting GNU CC - External Bugs

Problems Compiling Certain Programs

Certain programs have problems compiling.

  • Parse errors may occur compiling X11 on a Decstation running Ultrix 4.2 because of problems in DEC's versions of the X11 header files `X11/Xlib.h' and `X11/Xutil.h'. People recommend adding `-I/usr/include/mit' to use the MIT versions of the header files, using the `-traditional' switch to turn off ANSI C, or fixing the header files by adding this:
    #ifdef __STDC__
#define NeedFunctionPrototypes 0
#endif
  • If you have trouble compiling Perl on a SunOS 4 system, it may be because Perl specifies `-I/usr/ucbinclude'. This accesses the unfixed header files. Perl specifies the options
    -traditional -Dvolatile=__volatile__
-I/usr/include/sun -I/usr/ucbinclude
-fpcc-struct-return
    most of which are unnecessary with GCC 2.4.5 and newer versions. You can make a properly working Perl by setting ccflags to `-fwritable-strings' (implied by the `-traditional' in the original options) and cppflags to empty in `config.sh', then typing `./doSH; make depend; make'.
  • On various 386 Unix systems derived from System V, including SCO, ISC, and ESIX, you may get error messages about running out of virtual memory while compiling certain programs. You can prevent this problem by linking GNU CC with the GNU malloc (which thus replaces the malloc that comes with the system). GNU malloc is available as a separate package, and also in the file `src/gmalloc.c' in the GNU Emacs 19 distribution. If you have installed GNU malloc as a separate library package, use this option when you relink GNU CC:
    MALLOC=/usr/local/lib/libgmalloc.a
    Alternatively, if you have compiled `gmalloc.c' from Emacs 19, copy the object file to `gmalloc.o' and use this option when you relink GNU CC:
    MALLOC=gmalloc.o


Using and Porting GNU CC - Incompatibilities

Incompatibilities of GNU CC

There are several noteworthy incompatibilities between GNU C and most existing (non-ANSI) versions of C. The `-traditional' option eliminates many of these incompatibilities, but not all, by telling GNU C to behave like the other C compilers.

  • GNU CC normally makes string constants read-only. If several identical-looking string constants are used, GNU CC stores only one copy of the string. One consequence is that you cannot call mktemp with a string constant argument. The function mktemp always alters the string its argument points to. Another consequence is that sscanf does not work on some systems when passed a string constant as its format control string or input. This is because sscanf incorrectly tries to write into the string constant. Likewise fscanf and scanf. The best solution to these problems is to change the program to use char-array variables with initialization strings for these purposes instead of string constants. But if this is not possible, you can use the `-fwritable-strings' flag, which directs GNU CC to handle string constants the same way most C compilers do. `-traditional' also has this effect, among others.
  • -2147483648 is positive. This is because 2147483648 cannot fit in the type int, so (following the ANSI C rules) its data type is unsigned long int. Negating this value yields 2147483648 again.
  • GNU CC does not substitute macro arguments when they appear inside of string constants. For example, the following macro in GNU CC
    #define foo(a) "a"
    will produce output "a" regardless of what the argument a is. The `-traditional' option directs GNU CC to handle such cases (among others) in the old-fashioned (non-ANSI) fashion.
  • When you use setjmp and longjmp, the only automatic variables guaranteed to remain valid are those declared volatile. This is a consequence of automatic register allocation. Consider this function:
    jmp_buf j;

foo ()
{
  int a, b;

  a = fun1 ();
  if (setjmp (j))
    return a;

  a = fun2 ();
  /* longjmp (j) may occur in fun3. */
  return a + fun3 ();
}
    Here a may or may not be restored to its first value when the longjmp occurs. If a is allocated in a register, then its first value is restored; otherwise, it keeps the last value stored in it. If you use the `-W' option with the `-O' option, you will get a warning when GNU CC thinks such a problem might be possible. The `-traditional' option directs GNU C to put variables in the stack by default, rather than in registers, in functions that call setjmp. This results in the behavior found in traditional C compilers.
  • Programs that use preprocessing directives in the middle of macro arguments do not work with GNU CC. For example, a program like this will not work:
    foobar (
#define luser
        hack)
    ANSI C does not permit such a construct. It would make sense to support it when `-traditional' is used, but it is too much work to implement.
  • Declarations of external variables and functions within a block apply only to the block containing the declaration. In other words, they have the same scope as any other declaration in the same place. In some other C compilers, a extern declaration affects all the rest of the file even if it happens within a block. The `-traditional' option directs GNU C to treat all extern declarations as global, like traditional compilers.
  • In traditional C, you can combine long, etc., with a typedef name, as shown here:
    typedef int foo;
typedef long foo bar;
    In ANSI C, this is not allowed: long and other type modifiers require an explicit int. Because this criterion is expressed by Bison grammar rules rather than C code, the `-traditional' flag cannot alter it.
  • PCC allows typedef names to be used as function parameters. The difficulty described immediately above applies here too.
  • PCC allows whitespace in the middle of compound assignment operators such as `+='. GNU CC, following the ANSI standard, does not allow this. The difficulty described immediately above applies here too.
  • GNU CC complains about unterminated character constants inside of preprocessing conditionals that fail. Some programs have English comments enclosed in conditionals that are guaranteed to fail; if these comments contain apostrophes, GNU CC will probably report an error. For example, this code would produce an error:
    #if 0
You can't expect this to work.
#endif
    The best solution to such a problem is to put the text into an actual C comment delimited by `/*...*/'. However, `-traditional' suppresses these error messages.
  • Many user programs contain the declaration `long time ();'. In the past, the system header files on many systems did not actually declare time, so it did not matter what type your program declared it to return. But in systems with ANSI C headers, time is declared to return time_t, and if that is not the same as long, then `long time ();' is erroneous. The solution is to change your program to use time_t as the return type of time.
  • When compiling functions that return float, PCC converts it to a double. GNU CC actually returns a float. If you are concerned with PCC compatibility, you should declare your functions to return double; you might as well say what you mean.
  • When compiling functions that return structures or unions, GNU CC output code normally uses a method different from that used on most versions of Unix. As a result, code compiled with GNU CC cannot call a structure-returning function compiled with PCC, and vice versa. The method used by GNU CC is as follows: a structure or union which is 1, 2, 4 or 8 bytes long is returned like a scalar. A structure or union with any other size is stored into an address supplied by the caller (usually in a special, fixed register, but on some machines it is passed on the stack). The machine-description macros STRUCT_VALUE and STRUCT_INCOMING_VALUE tell GNU CC where to pass this address. By contrast, PCC on most target machines returns structures and unions of any size by copying the data into an area of static storage, and then returning the address of that storage as if it were a pointer value. The caller must copy the data from that memory area to the place where the value is wanted. GNU CC does not use this method because it is slower and nonreentrant. On some newer machines, PCC uses a reentrant convention for all structure and union returning. GNU CC on most of these machines uses a compatible convention when returning structures and unions in memory, but still returns small structures and unions in registers. You can tell GNU CC to use a compatible convention for all structure and union returning with the option `-fpcc-struct-return'.
  • GNU C complains about program fragments such as `0x74ae-0x4000' which appear to be two hexadecimal constants separated by the minus operator. Actually, this string is a single preprocessing token. Each such token must correspond to one token in C. Since this does not, GNU C prints an error message. Although it may appear obvious that what is meant is an operator and two values, the ANSI C standard specifically requires that this be treated as erroneous. A preprocessing token is a preprocessing number if it begins with a digit and is followed by letters, underscores, digits, periods and `e+', `e-', `E+', or `E-' character sequences. To make the above program fragment valid, place whitespace in front of the minus sign. This whitespace will end the preprocessing number.


Using and Porting GNU CC - Fixed Headers

Fixed Header Files

GNU CC needs to install corrected versions of some system header files. This is because most target systems have some header files that won't work with GNU CC unless they are changed. Some have bugs, some are incompatible with ANSI C, and some depend on special features of other compilers.

Installing GNU CC automatically creates and installs the fixed header files, by running a program called fixincludes (or for certain targets an alternative such as fixinc.svr4). Normally, you don't need to pay attention to this. But there are cases where it doesn't do the right thing automatically.

  • If you update the system's header files, such as by installing a new system version, the fixed header files of GNU CC are not automatically updated. The easiest way to update them is to reinstall GNU CC. (If you want to be clever, look in the makefile and you can find a shortcut.)
  • On some systems, in particular SunOS 4, header file directories contain machine-specific symbolic links in certain places. This makes it possible to share most of the header files among hosts running the same version of SunOS 4 on different machine models. The programs that fix the header files do not understand this special way of using symbolic links; therefore, the directory of fixed header files is good only for the machine model used to build it. In SunOS 4, only programs that look inside the kernel will notice the difference between machine models. Therefore, for most purposes, you need not be concerned about this. It is possible to make separate sets of fixed header files for the different machine models, and arrange a structure of symbolic links so as to use the proper set, but you'll have to do this by hand.
  • On Lynxos, GNU CC by default does not fix the header files. This is because bugs in the shell cause the fixincludes script to fail. This means you will encounter problems due to bugs in the system header files. It may be no comfort that they aren't GNU CC's fault, but it does mean that there's nothing for us to do about them.


Using and Porting GNU CC - Standard Libraries

Standard Libraries

GNU CC by itself attempts to be what the ISO/ANSI C standard calls a conforming freestanding implementation. This means all ANSI C language features are available, as well as the contents of `float.h', `limits.h', `stdarg.h', and `stddef.h'. The rest of the C library is supplied by the vendor of the operating system. If that C library doesn't conform to the C standards, then your programs might get warnings (especially when using `-Wall') that you don't expect.

For example, the sprintf function on SunOS 4.1.3 returns char * while the C standard says that sprintf returns an int. The fixincludes program could make the prototype for this function match the Standard, but that would be wrong, since the function will still return char *.

If you need a Standard compliant library, then you need to find one, as GNU CC does not provide one. The GNU C library (called glibc) has been ported to a number of operating systems, and provides ANSI/ISO, POSIX, BSD and SystemV compatibility. You could also ask your operating system vendor if newer libraries are available.


Using and Porting GNU CC - Disappointments

Disappointments and Misunderstandings

These problems are perhaps regrettable, but we don't know any practical way around them.

  • Certain local variables aren't recognized by debuggers when you compile with optimization. This occurs because sometimes GNU CC optimizes the variable out of existence. There is no way to tell the debugger how to compute the value such a variable "would have had", and it is not clear that would be desirable anyway. So GNU CC simply does not mention the eliminated variable when it writes debugging information. You have to expect a certain amount of disagreement between the executable and your source code, when you use optimization.
  • Users often think it is a bug when GNU CC reports an error for code like this:
    int foo (struct mumble *);

struct mumble { ... };

int foo (struct mumble *x)
{ ... }
    This code really is erroneous, because the scope of struct mumble in the prototype is limited to the argument list containing it. It does not refer to the struct mumble defined with file scope immediately below--they are two unrelated types with similar names in different scopes. But in the definition of foo, the file-scope type is used because that is available to be inherited. Thus, the definition and the prototype do not match, and you get an error. This behavior may seem silly, but it's what the ANSI standard specifies. It is easy enough for you to make your code work by moving the definition of struct mumble above the prototype. It's not worth being incompatible with ANSI C just to avoid an error for the example shown above.
  • Accesses to bitfields even in volatile objects works by accessing larger objects, such as a byte or a word. You cannot rely on what size of object is accessed in order to read or write the bitfield; it may even vary for a given bitfield according to the precise usage. If you care about controlling the amount of memory that is accessed, use volatile but do not use bitfields.
  • GNU CC comes with shell scripts to fix certain known problems in system header files. They install corrected copies of various header files in a special directory where only GNU CC will normally look for them. The scripts adapt to various systems by searching all the system header files for the problem cases that we know about. If new system header files are installed, nothing automatically arranges to update the corrected header files. You will have to reinstall GNU CC to fix the new header files. More specifically, go to the build directory and delete the files `stmp-fixinc' and `stmp-headers', and the subdirectory include; then do `make install' again.
  • On 68000 and x86 systems, for instance, you can get paradoxical results if you test the precise values of floating point numbers. For example, you can find that a floating point value which is not a NaN is not equal to itself. This results from the fact that the floating point registers hold a few more bits of precision than fit in a double in memory. Compiled code moves values between memory and floating point registers at its convenience, and moving them into memory truncates them. You can partially avoid this problem by using the `-ffloat-store' option (see section Options That Control Optimization).
  • On the MIPS, variable argument functions using `varargs.h' cannot have a floating point value for the first argument. The reason for this is that in the absence of a prototype in scope, if the first argument is a floating point, it is passed in a floating point register, rather than an integer register. If the code is rewritten to use the ANSI standard `stdarg.h' method of variable arguments, and the prototype is in scope at the time of the call, everything will work fine.
  • On the H8/300 and H8/300H, variable argument functions must be implemented using the ANSI standard `stdarg.h' method of variable arguments. Furthermore, calls to functions using `stdarg.h' variable arguments must have a prototype for the called function in scope at the time of the call.


Using and Porting GNU CC - C++ Misunderstandings

Common Misunderstandings with GNU C++

C++ is a complex language and an evolving one, and its standard definition (the ANSI C++ draft standard) is also evolving. As a result, your C++ compiler may occasionally surprise you, even when its behavior is correct. This section discusses some areas that frequently give rise to questions of this sort.


Using and Porting GNU CC - Static Definitions

Declare and Define Static Members

When a class has static data members, it is not enough to declare the static member; you must also define it. For example:

class Foo
{
  ...
  void method();
  static int bar;
};

This declaration only establishes that the class Foo has an int named Foo::bar, and a member function named Foo::method. But you still need to define both method and bar elsewhere. According to the draft ANSI standard, you must supply an initializer in one (and only one) source file, such as:

int Foo::bar = 0;

Other C++ compilers may not correctly implement the standard behavior. As a result, when you switch to g++ from one of these compilers, you may discover that a program that appeared to work correctly in fact does not conform to the standard: g++ reports as undefined symbols any static data members that lack definitions.


Using and Porting GNU CC - Temporaries

Temporaries May Vanish Before You Expect

It is dangerous to use pointers or references to portions of a temporary object. The compiler may very well delete the object before you expect it to, leaving a pointer to garbage. The most common place where this problem crops up is in classes like the libg++ String class, that define a conversion function to type char * or const char *. However, any class that returns a pointer to some internal structure is potentially subject to this problem.

For example, a program may use a function strfunc that returns String objects, and another function charfunc that operates on pointers to char:

String strfunc ();
void charfunc (const char *);

In this situation, it may seem natural to write `charfunc (strfunc ());' based on the knowledge that class String has an explicit conversion to char pointers. However, what really happens is akin to `charfunc (strfunc ().convert ());', where the convert method is a function to do the same data conversion normally performed by a cast. Since the last use of the temporary String object is the call to the conversion function, the compiler may delete that object before actually calling charfunc. The compiler has no way of knowing that deleting the String object will invalidate the pointer. The pointer then points to garbage, so that by the time charfunc is called, it gets an invalid argument.

Code like this may run successfully under some other compilers, especially those that delete temporaries relatively late. However, the GNU C++ behavior is also standard-conforming, so if your program depends on late destruction of temporaries it is not portable.

If you think this is surprising, you should be aware that the ANSI C++ committee continues to debate the lifetime-of-temporaries problem.

For now, at least, the safe way to write such code is to give the temporary a name, which forces it to remain until the end of the scope of the name. For example:

String& tmp = strfunc ();
charfunc (tmp);


Using and Porting GNU CC - Protoize Caveats

Caveats of using protoize

The conversion programs protoize and unprotoize can sometimes change a source file in a way that won't work unless you rearrange it.

  • protoize can insert references to a type name or type tag before the definition, or in a file where they are not defined. If this happens, compiler error messages should show you where the new references are, so fixing the file by hand is straightforward.
  • There are some C constructs which protoize cannot figure out. For example, it can't determine argument types for declaring a pointer-to-function variable; this you must do by hand. protoize inserts a comment containing `???' each time it finds such a variable; so you can find all such variables by searching for this string. ANSI C does not require declaring the argument types of pointer-to-function types.
  • Using unprotoize can easily introduce bugs. If the program relied on prototypes to bring about conversion of arguments, these conversions will not take place in the program without prototypes. One case in which you can be sure unprotoize is safe is when you are removing prototypes that were made with protoize; if the program worked before without any prototypes, it will work again without them. You can find all the places where this problem might occur by compiling the program with the `-Wconversion' option. It prints a warning whenever an argument is converted.
  • Both conversion programs can be confused if there are macro calls in and around the text to be converted. In other words, the standard syntax for a declaration or definition must not result from expanding a macro. This problem is inherent in the design of C and cannot be fixed. If only a few functions have confusing macro calls, you can easily convert them manually.
  • protoize cannot get the argument types for a function whose definition was not actually compiled due to preprocessing conditionals. When this happens, protoize changes nothing in regard to such a function. protoize tries to detect such instances and warn about them. You can generally work around this problem by using protoize step by step, each time specifying a different set of `-D' options for compilation, until all of the functions have been converted. There is no automatic way to verify that you have got them all, however.
  • Confusion may result if there is an occasion to convert a function declaration or definition in a region of source code where there is more than one formal parameter list present. Thus, attempts to convert code containing multiple (conditionally compiled) versions of a single function header (in the same vicinity) may not produce the desired (or expected) results. If you plan on converting source files which contain such code, it is recommended that you first make sure that each conditionally compiled region of source code which contains an alternative function header also contains at least one additional follower token (past the final right parenthesis of the function header). This should circumvent the problem.
  • unprotoize can become confused when trying to convert a function definition or declaration which contains a declaration for a pointer-to-function formal argument which has the same name as the function being defined or declared. We recommand you avoid such choices of formal parameter names.
  • You might also want to correct some of the indentation by hand and break long lines. (The conversion programs don't write lines longer than eighty characters in any case.)


Using and Porting GNU CC - Non-bugs

Certain Changes We Don't Want to Make

This section lists changes that people frequently request, but which we do not make because we think GNU CC is better without them.

  • Checking the number and type of arguments to a function which has an old-fashioned definition and no prototype. Such a feature would work only occasionally--only for calls that appear in the same file as the called function, following the definition. The only way to check all calls reliably is to add a prototype for the function. But adding a prototype eliminates the motivation for this feature. So the feature is not worthwhile.
  • Warning about using an expression whose type is signed as a shift count. Shift count operands are probably signed more often than unsigned. Warning about this would cause far more annoyance than good.
  • Warning about assigning a signed value to an unsigned variable. Such assignments must be very common; warning about them would cause more annoyance than good.
  • Warning about unreachable code. It's very common to have unreachable code in machine-generated programs. For example, this happens normally in some files of GNU C itself.
  • Warning when a non-void function value is ignored. Coming as I do from a Lisp background, I balk at the idea that there is something dangerous about discarding a value. There are functions that return values which some callers may find useful; it makes no sense to clutter the program with a cast to void whenever the value isn't useful.
  • Assuming (for optimization) that the address of an external symbol is never zero. This assumption is false on certain systems when `#pragma weak' is used.
  • Making `-fshort-enums' the default. This would cause storage layout to be incompatible with most other C compilers. And it doesn't seem very important, given that you can get the same result in other ways. The case where it matters most is when the enumeration-valued object is inside a structure, and in that case you can specify a field width explicitly.
  • Making bitfields unsigned by default on particular machines where "the ABI standard" says to do so. The ANSI C standard leaves it up to the implementation whether a bitfield declared plain int is signed or not. This in effect creates two alternative dialects of C. The GNU C compiler supports both dialects; you can specify the signed dialect with `-fsigned-bitfields' and the unsigned dialect with `-funsigned-bitfields'. However, this leaves open the question of which dialect to use by default. Currently, the preferred dialect makes plain bitfields signed, because this is simplest. Since int is the same as signed int in every other context, it is cleanest for them to be the same in bitfields as well. Some computer manufacturers have published Application Binary Interface standards which specify that plain bitfields should be unsigned. It is a mistake, however, to say anything about this issue in an ABI. This is because the handling of plain bitfields distinguishes two dialects of C. Both dialects are meaningful on every type of machine. Whether a particular object file was compiled using signed bitfields or unsigned is of no concern to other object files, even if they access the same bitfields in the same data structures. A given program is written in one or the other of these two dialects. The program stands a chance to work on most any machine if it is compiled with the proper dialect. It is unlikely to work at all if compiled with the wrong dialect. Many users appreciate the GNU C compiler because it provides an environment that is uniform across machines. These users would be inconvenienced if the compiler treated plain bitfields differently on certain machines. Occasionally users write programs intended only for a particular machine type. On these occasions, the users would benefit if the GNU C compiler were to support by default the same dialect as the other compilers on that machine. But such applications are rare. And users writing a program to run on more than one type of machine cannot possibly benefit from this kind of compatibility. This is why GNU CC does and will treat plain bitfields in the same fashion on all types of machines (by default). There are some arguments for making bitfields unsigned by default on all machines. If, for example, this becomes a universal de facto standard, it would make sense for GNU CC to go along with it. This is something to be considered in the future. (Of course, users strongly concerned about portability should indicate explicitly in each bitfield whether it is signed or not. In this way, they write programs which have the same meaning in both C dialects.)
  • Undefining __STDC__ when `-ansi' is not used. Currently, GNU CC defines __STDC__ as long as you don't use `-traditional'. This provides good results in practice. Programmers normally use conditionals on __STDC__ to ask whether it is safe to use certain features of ANSI C, such as function prototypes or ANSI token concatenation. Since plain `gcc' supports all the features of ANSI C, the correct answer to these questions is "yes". Some users try to use __STDC__ to check for the availability of certain library facilities. This is actually incorrect usage in an ANSI C program, because the ANSI C standard says that a conforming freestanding implementation should define __STDC__ even though it does not have the library facilities. `gcc -ansi -pedantic' is a conforming freestanding implementation, and it is therefore required to define __STDC__, even though it does not come with an ANSI C library. Sometimes people say that defining __STDC__ in a compiler that does not completely conform to the ANSI C standard somehow violates the standard. This is illogical. The standard is a standard for compilers that claim to support ANSI C, such as `gcc -ansi'---not for other compilers such as plain `gcc'. Whatever the ANSI C standard says is relevant to the design of plain `gcc' without `-ansi' only for pragmatic reasons, not as a requirement.
  • Undefining __STDC__ in C++. Programs written to compile with C++-to-C translators get the value of __STDC__ that goes with the C compiler that is subsequently used. These programs must test __STDC__ to determine what kind of C preprocessor that compiler uses: whether they should concatenate tokens in the ANSI C fashion or in the traditional fashion. These programs work properly with GNU C++ if __STDC__ is defined. They would not work otherwise. In addition, many header files are written to provide prototypes in ANSI C but not in traditional C. Many of these header files can work without change in C++ provided __STDC__ is defined. If __STDC__ is not defined, they will all fail, and will all need to be changed to test explicitly for C++ as well.
  • Deleting "empty" loops. GNU CC does not delete "empty" loops because the most likely reason you would put one in a program is to have a delay. Deleting them will not make real programs run any faster, so it would be pointless. It would be different if optimization of a nonempty loop could produce an empty one. But this generally can't happen.
  • Making side effects happen in the same order as in some other compiler. It is never safe to depend on the order of evaluation of side effects. For example, a function call like this may very well behave differently from one compiler to another:
    void func (int, int);

int i = 2;
func (i++, i++);
    There is no guarantee (in either the C or the C++ standard language definitions) that the increments will be evaluated in any particular order. Either increment might happen first. func might get the arguments `2, 3', or it might get `3, 2', or even `2, 2'.
  • Not allowing structures with volatile fields in registers. Strictly speaking, there is no prohibition in the ANSI C standard against allowing structures with volatile fields in registers, but it does not seem to make any sense and is probably not what you wanted to do. So the compiler will give an error message in this case.


Using and Porting GNU CC - Warnings and Errors

Warning Messages and Error Messages

The GNU compiler can produce two kinds of diagnostics: errors and warnings. Each kind has a different purpose:

  • Errors report problems that make it impossible to compile your program. GNU CC reports errors with the source file name and line number where the problem is apparent.
  • Warnings report other unusual conditions in your code that may indicate a problem, although compilation can (and does) proceed. Warning messages also report the source file name and line number, but include the text `warning:' to distinguish them from error messages.

Warnings may indicate danger points where you should check to make sure that your program really does what you intend; or the use of obsolete features; or the use of nonstandard features of GNU C or C++. Many warnings are issued only if you ask for them, with one of the `-W' options (for instance, `-Wall' requests a variety of useful warnings).

GNU CC always tries to compile your program if possible; it never gratuitously rejects a program whose meaning is clear merely because (for instance) it fails to conform to a standard. In some cases, however, the C and C++ standards specify that certain extensions are forbidden, and a diagnostic must be issued by a conforming compiler. The `-pedantic' option tells GNU CC to issue warnings in such cases; `-pedantic-errors' says to make them errors instead. This does not mean that all non-ANSI constructs get warnings or errors.

See section Options to Request or Suppress Warnings, for more detail on these and related command-line options.


Using and Porting GNU CC - Bugs

Reporting Bugs

Your bug reports play an essential role in making GNU CC reliable.

When you encounter a problem, the first thing to do is to see if it is already known. See section Known Causes of Trouble with GNU CC. If it isn't known, then you should report the problem.

Reporting a bug may help you by bringing a solution to your problem, or it may not. (If it does not, look in the service directory; see section How To Get Help with GNU CC.) In any case, the principal function of a bug report is to help the entire community by making the next version of GNU CC work better. Bug reports are your contribution to the maintenance of GNU CC.

Since the maintainers are very overloaded, we cannot respond to every bug report. However, if the bug has not been fixed, we are likely to send you a patch and ask you to tell us whether it works.

In order for a bug report to serve its purpose, you must include the information that makes for fixing the bug.


Using and Porting GNU CC - Bug Criteria

Have You Found a Bug?

If you are not sure whether you have found a bug, here are some guidelines:

  • If the compiler gets a fatal signal, for any input whatever, that is a compiler bug. Reliable compilers never crash.
  • If the compiler produces invalid assembly code, for any input whatever (except an asm statement), that is a compiler bug, unless the compiler reports errors (not just warnings) which would ordinarily prevent the assembler from being run.
  • If the compiler produces valid assembly code that does not correctly execute the input source code, that is a compiler bug. However, you must double-check to make sure, because you may have run into an incompatibility between GNU C and traditional C (see section Incompatibilities of GNU CC). These incompatibilities might be considered bugs, but they are inescapable consequences of valuable features. Or you may have a program whose behavior is undefined, which happened by chance to give the desired results with another C or C++ compiler. For example, in many nonoptimizing compilers, you can write `x;' at the end of a function instead of `return x;', with the same results. But the value of the function is undefined if return is omitted; it is not a bug when GNU CC produces different results. Problems often result from expressions with two increment operators, as in f (*p++, *p++). Your previous compiler might have interpreted that expression the way you intended; GNU CC might interpret it another way. Neither compiler is wrong. The bug is in your code. After you have localized the error to a single source line, it should be easy to check for these things. If your program is correct and well defined, you have found a compiler bug.
  • If the compiler produces an error message for valid input, that is a compiler bug.
  • If the compiler does not produce an error message for invalid input, that is a compiler bug. However, you should note that your idea of "invalid input" might be my idea of "an extension" or "support for traditional practice".
  • If you are an experienced user of C or C++ compilers, your suggestions for improvement of GNU CC or GNU C++ are welcome in any case.


Using and Porting GNU CC - Bug Lists

Where to Report Bugs

Send bug reports for GNU C to `egcs-bugs@cygnus.com'.

Send bug reports for GNU C++ and the C++ runtime libraries to `egcs-bugs@cygnus.com'.

Often people think of posting bug reports to the newsgroup instead of mailing them. This appears to work, but it has one problem which can be crucial: a newsgroup posting does not contain a mail path back to the sender. Thus, if maintainers need more information, they may be unable to reach you. For this reason, you should always send bug reports by mail to the proper mailing list.

As a last resort, send bug reports on paper to:

GNU Compiler Bugs
Free Software Foundation
59 Temple Place - Suite 330
Boston, MA 02111-1307, USA


Using and Porting GNU CC - Bug Reporting

How to Report Bugs

The fundamental principle of reporting bugs usefully is this: report all the facts. If you are not sure whether to state a fact or leave it out, state it!

Often people omit facts because they think they know what causes the problem and they conclude that some details don't matter. Thus, you might assume that the name of the variable you use in an example does not matter. Well, probably it doesn't, but one cannot be sure. Perhaps the bug is a stray memory reference which happens to fetch from the location where that name is stored in memory; perhaps, if the name were different, the contents of that location would fool the compiler into doing the right thing despite the bug. Play it safe and give a specific, complete example. That is the easiest thing for you to do, and the most helpful.

Keep in mind that the purpose of a bug report is to enable someone to fix the bug if it is not known. It isn't very important what happens if the bug is already known. Therefore, always write your bug reports on the assumption that the bug is not known.

Sometimes people give a few sketchy facts and ask, "Does this ring a bell?" This cannot help us fix a bug, so it is basically useless. We respond by asking for enough details to enable us to investigate. You might as well expedite matters by sending them to begin with.

Try to make your bug report self-contained. If we have to ask you for more information, it is best if you include all the previous information in your response, as well as the information that was missing.

Please report each bug in a separate message. This makes it easier for us to track which bugs have been fixed and to forward your bugs reports to the appropriate maintainer.

Do not compress and encode any part of your bug report using programs such as `uuencode'. If you do so it will slow down the processing of your bug. If you must submit multiple large files, use `shar', which allows us to read your message without having to run any decompression programs.

To enable someone to investigate the bug, you should include all these things:

  • The version of GNU CC. You can get this by running it with the `-v' option. Without this, we won't know whether there is any point in looking for the bug in the current version of GNU CC.
  • A complete input file that will reproduce the bug. If the bug is in the C preprocessor, send a source file and any header files that it requires. If the bug is in the compiler proper (`cc1'), run your source file through the C preprocessor by doing `gcc -E sourcefile > outfile', then include the contents of outfile in the bug report. (When you do this, use the same `-I', `-D' or `-U' options that you used in actual compilation.) A single statement is not enough of an example. In order to compile it, it must be embedded in a complete file of compiler input; and the bug might depend on the details of how this is done. Without a real example one can compile, all anyone can do about your bug report is wish you luck. It would be futile to try to guess how to provoke the bug. For example, bugs in register allocation and reloading frequently depend on every little detail of the function they happen in. Even if the input file that fails comes from a GNU program, you should still send the complete test case. Don't ask the GNU CC maintainers to do the extra work of obtaining the program in question--they are all overworked as it is. Also, the problem may depend on what is in the header files on your system; it is unreliable for the GNU CC maintainers to try the problem with the header files available to them. By sending CPP output, you can eliminate this source of uncertainty and save us a certain percentage of wild goose chases.
  • The command arguments you gave GNU CC or GNU C++ to compile that example and observe the bug. For example, did you use `-O'? To guarantee you won't omit something important, list all the options. If we were to try to guess the arguments, we would probably guess wrong and then we would not encounter the bug.
  • The type of machine you are using, and the operating system name and version number.
  • The operands you gave to the configure command when you installed the compiler.
  • A complete list of any modifications you have made to the compiler source. (We don't promise to investigate the bug unless it happens in an unmodified compiler. But if you've made modifications and don't tell us, then you are sending us on a wild goose chase.) Be precise about these changes. A description in English is not enough--send a context diff for them. Adding files of your own (such as a machine description for a machine we don't support) is a modification of the compiler source.
  • Details of any other deviations from the standard procedure for installing GNU CC.
  • A description of what behavior you observe that you believe is incorrect. For example, "The compiler gets a fatal signal," or, "The assembler instruction at line 208 in the output is incorrect." Of course, if the bug is that the compiler gets a fatal signal, then one can't miss it. But if the bug is incorrect output, the maintainer might not notice unless it is glaringly wrong. None of us has time to study all the assembler code from a 50-line C program just on the chance that one instruction might be wrong. We need you to do this part! Even if the problem you experience is a fatal signal, you should still say so explicitly. Suppose something strange is going on, such as, your copy of the compiler is out of synch, or you have encountered a bug in the C library on your system. (This has happened!) Your copy might crash and the copy here would not. If you said to expect a crash, then when the compiler here fails to crash, we would know that the bug was not happening. If you don't say to expect a crash, then we would not know whether the bug was happening. We would not be able to draw any conclusion from our observations. If the problem is a diagnostic when compiling GNU CC with some other compiler, say whether it is a warning or an error. Often the observed symptom is incorrect output when your program is run. Sad to say, this is not enough information unless the program is short and simple. None of us has time to study a large program to figure out how it would work if compiled correctly, much less which line of it was compiled wrong. So you will have to do that. Tell us which source line it is, and what incorrect result happens when that line is executed. A person who understands the program can find this as easily as finding a bug in the program itself.
  • If you send examples of assembler code output from GNU CC or GNU C++, please use `-g' when you make them. The debugging information includes source line numbers which are essential for correlating the output with the input.
  • If you wish to mention something in the GNU CC source, refer to it by context, not by line number. The line numbers in the development sources don't match those in your sources. Your line numbers would convey no useful information to the maintainers.
  • Additional information from a debugger might enable someone to find a problem on a machine which he does not have available. However, you need to think when you collect this information if you want it to have any chance of being useful. For example, many people send just a backtrace, but that is never useful by itself. A simple backtrace with arguments conveys little about GNU CC because the compiler is largely data-driven; the same functions are called over and over for different RTL insns, doing different things depending on the details of the insn. Most of the arguments listed in the backtrace are useless because they are pointers to RTL list structure. The numeric values of the pointers, which the debugger prints in the backtrace, have no significance whatever; all that matters is the contents of the objects they point to (and most of the contents are other such pointers). In addition, most compiler passes consist of one or more loops that scan the RTL insn sequence. The most vital piece of information about such a loop--which insn it has reached--is usually in a local variable, not in an argument. What you need to provide in addition to a backtrace are the values of the local variables for several stack frames up. When a local variable or an argument is an RTX, first print its value and then use the GDB command pr to print the RTL expression that it points to. (If GDB doesn't run on your machine, use your debugger to call the function debug_rtx with the RTX as an argument.) In general, whenever a variable is a pointer, its value is no use without the data it points to.

Here are some things that are not necessary:

  • A description of the envelope of the bug. Often people who encounter a bug spend a lot of time investigating which changes to the input file will make the bug go away and which changes will not affect it. This is often time consuming and not very useful, because the way we will find the bug is by running a single example under the debugger with breakpoints, not by pure deduction from a series of examples. You might as well save your time for something else. Of course, if you can find a simpler example to report instead of the original one, that is a convenience. Errors in the output will be easier to spot, running under the debugger will take less time, etc. Most GNU CC bugs involve just one function, so the most straightforward way to simplify an example is to delete all the function definitions except the one where the bug occurs. Those earlier in the file may be replaced by external declarations if the crucial function depends on them. (Exception: inline functions may affect compilation of functions defined later in the file.) However, simplification is not vital; if you don't want to do this, report the bug anyway and send the entire test case you used.
  • In particular, some people insert conditionals `#ifdef BUG' around a statement which, if removed, makes the bug not happen. These are just clutter; we won't pay any attention to them anyway. Besides, you should send us cpp output, and that can't have conditionals.
  • A patch for the bug. A patch for the bug is useful if it is a good one. But don't omit the necessary information, such as the test case, on the assumption that a patch is all we need. We might see problems with your patch and decide to fix the problem another way, or we might not understand it at all. Sometimes with a program as complicated as GNU CC it is very hard to construct an example that will make the program follow a certain path through the code. If you don't send the example, we won't be able to construct one, so we won't be able to verify that the bug is fixed. And if we can't understand what bug you are trying to fix, or why your patch should be an improvement, we won't install it. A test case will help us to understand. See section Sending Patches for GNU CC, for guidelines on how to make it easy for us to understand and install your patches.
  • A guess about what the bug is or what it depends on. Such guesses are usually wrong. Even I can't guess right about such things without first using the debugger to find the facts.
  • A core dump file. We have no way of examining a core dump for your type of machine unless we have an identical system--and if we do have one, we should be able to reproduce the crash ourselves.


Using and Porting GNU CC - Sending Patches

Sending Patches for GNU CC

If you would like to write bug fixes or improvements for the GNU C compiler, that is very helpful. Send suggested fixes to the bug report mailing list, egcs-bugs@cygnus.com.

Please follow these guidelines so we can study your patches efficiently. If you don't follow these guidelines, your information might still be useful, but using it will take extra work. Maintaining GNU C is a lot of work in the best of circumstances, and we can't keep up unless you do your best to help.

  • Send an explanation with your changes of what problem they fix or what improvement they bring about. For a bug fix, just include a copy of the bug report, and explain why the change fixes the bug. (Referring to a bug report is not as good as including it, because then we will have to look it up, and we have probably already deleted it if we've already fixed the bug.)
  • Always include a proper bug report for the problem you think you have fixed. We need to convince ourselves that the change is right before installing it. Even if it is right, we might have trouble judging it if we don't have a way to reproduce the problem.
  • Include all the comments that are appropriate to help people reading the source in the future understand why this change was needed.
  • Don't mix together changes made for different reasons. Send them individually. If you make two changes for separate reasons, then we might not want to install them both. We might want to install just one. If you send them all jumbled together in a single set of diffs, we have to do extra work to disentangle them--to figure out which parts of the change serve which purpose. If we don't have time for this, we might have to ignore your changes entirely. If you send each change as soon as you have written it, with its own explanation, then the two changes never get tangled up, and we can consider each one properly without any extra work to disentangle them. Ideally, each change you send should be impossible to subdivide into parts that we might want to consider separately, because each of its parts gets its motivation from the other parts.
  • Send each change as soon as that change is finished. Sometimes people think they are helping us by accumulating many changes to send them all together. As explained above, this is absolutely the worst thing you could do. Since you should send each change separately, you might as well send it right away. That gives us the option of installing it immediately if it is important.
  • Use `diff -c' to make your diffs. Diffs without context are hard for us to install reliably. More than that, they make it hard for us to study the diffs to decide whether we want to install them. Unidiff format is better than contextless diffs, but not as easy to read as `-c' format. If you have GNU diff, use `diff -cp', which shows the name of the function that each change occurs in.
  • Write the change log entries for your changes. We get lots of changes, and we don't have time to do all the change log writing ourselves. Read the `ChangeLog' file to see what sorts of information to put in, and to learn the style that we use. The purpose of the change log is to show people where to find what was changed. So you need to be specific about what functions you changed; in large functions, it's often helpful to indicate where within the function the change was. On the other hand, once you have shown people where to find the change, you need not explain its purpose. Thus, if you add a new function, all you need to say about it is that it is new. If you feel that the purpose needs explaining, it probably does--but the explanation will be much more useful if you put it in comments in the code. If you would like your name to appear in the header line for who made the change, send us the header line.
  • When you write the fix, keep in mind that we can't install a change that would break other systems. People often suggest fixing a problem by changing machine-independent files such as `toplev.c' to do something special that a particular system needs. Sometimes it is totally obvious that such changes would break GNU CC for almost all users. We can't possibly make a change like that. At best it might tell us how to write another patch that would solve the problem acceptably. Sometimes people send fixes that might be an improvement in general--but it is hard to be sure of this. It's hard to install such changes because we have to study them very carefully. Of course, a good explanation of the reasoning by which you concluded the change was correct can help convince us. The safest changes are changes to the configuration files for a particular machine. These are safe because they can't create new bugs on other machines. Please help us keep up with the workload by designing the patch in a form that is good to install.


Using and Porting GNU CC - Service

How To Get Help with GNU CC

If you need help installing, using or changing GNU CC, there are two ways to find it:

  • Send a message to a suitable network mailing list. First try egcs-bugs@cygnus.com, and if that brings no response, try egcs@cygnus.com.
  • Look in the service directory for someone who might help you for a fee. The service directory is found in the file named `SERVICE' in the GNU CC distribution.


Using and Porting GNU CC - Contributing

Contributing to GNU CC Development

If you would like to help pretest GNU CC releases to assure they work well, or if you would like to work on improving GNU CC, please contact the maintainers at egcs@cygnus.com. A pretester should be willing to try to investigate bugs as well as report them.

If you'd like to work on improvements, please ask for suggested projects or suggest your own ideas. If you have already written an improvement, please tell us about it. If you have not yet started work, it is useful to contact egcs@cygnus.com before you start; the maintainers may be able to suggest ways to make your extension fit in better with the rest of GNU CC and with other development plans.


Using and Porting GNU CC - VMS

Using GNU CC on VMS

Here is how to use GNU CC on VMS.


Using and Porting GNU CC - Include Files and VMS

Include Files and VMS

Due to the differences between the filesystems of Unix and VMS, GNU CC attempts to translate file names in `#include' into names that VMS will understand. The basic strategy is to prepend a prefix to the specification of the include file, convert the whole filename to a VMS filename, and then try to open the file. GNU CC tries various prefixes one by one until one of them succeeds:

  1. The first prefix is the `GNU_CC_INCLUDE:' logical name: this is where GNU C header files are traditionally stored. If you wish to store header files in non-standard locations, then you can assign the logical `GNU_CC_INCLUDE' to be a search list, where each element of the list is suitable for use with a rooted logical.
  2. The next prefix tried is `SYS$SYSROOT:[SYSLIB.]'. This is where VAX-C header files are traditionally stored.
  3. If the include file specification by itself is a valid VMS filename, the preprocessor then uses this name with no prefix in an attempt to open the include file.
  4. If the file specification is not a valid VMS filename (i.e. does not contain a device or a directory specifier, and contains a `/' character), the preprocessor tries to convert it from Unix syntax to VMS syntax. Conversion works like this: the first directory name becomes a device, and the rest of the directories are converted into VMS-format directory names. For example, the name `X11/foobar.h' is translated to `X11:[000000]foobar.h' or `X11:foobar.h', whichever one can be opened. This strategy allows you to assign a logical name to point to the actual location of the header files.
  5. If none of these strategies succeeds, the `#include' fails.

Include directives of the form:

#include foobar

are a common source of incompatibility between VAX-C and GNU CC. VAX-C treats this much like a standard #include <foobar.h> directive. That is incompatible with the ANSI C behavior implemented by GNU CC: to expand the name foobar as a macro. Macro expansion should eventually yield one of the two standard formats for #include:

#include "file"
#include <file>

If you have this problem, the best solution is to modify the source to convert the #include directives to one of the two standard forms. That will work with either compiler. If you want a quick and dirty fix, define the file names as macros with the proper expansion, like this:

#define stdio <stdio.h>

This will work, as long as the name doesn't conflict with anything else in the program.

Another source of incompatibility is that VAX-C assumes that:

#include "foobar"

is actually asking for the file `foobar.h'. GNU CC does not make this assumption, and instead takes what you ask for literally; it tries to read the file `foobar'. The best way to avoid this problem is to always specify the desired file extension in your include directives.

GNU CC for VMS is distributed with a set of include files that is sufficient to compile most general purpose programs. Even though the GNU CC distribution does not contain header files to define constants and structures for some VMS system-specific functions, there is no reason why you cannot use GNU CC with any of these functions. You first may have to generate or create header files, either by using the public domain utility UNSDL (which can be found on a DECUS tape), or by extracting the relevant modules from one of the system macro libraries, and using an editor to construct a C header file.

A #include file name cannot contain a DECNET node name. The preprocessor reports an I/O error if you attempt to use a node name, whether explicitly, or implicitly via a logical name.


Using and Porting GNU CC - Global Declarations

Global Declarations and VMS

GNU CC does not provide the globalref, globaldef and globalvalue keywords of VAX-C. You can get the same effect with an obscure feature of GAS, the GNU assembler. (This requires GAS version 1.39 or later.) The following macros allow you to use this feature in a fairly natural way:

#ifdef __GNUC__
#define GLOBALREF(TYPE,NAME)                      \
  TYPE NAME                                       \
  asm ("_$$PsectAttributes_GLOBALSYMBOL$$" #NAME)
#define GLOBALDEF(TYPE,NAME,VALUE)                \
  TYPE NAME                                       \
  asm ("_$$PsectAttributes_GLOBALSYMBOL$$" #NAME) \
    = VALUE
#define GLOBALVALUEREF(TYPE,NAME)                 \
  const TYPE NAME[1]                              \
  asm ("_$$PsectAttributes_GLOBALVALUE$$" #NAME)
#define GLOBALVALUEDEF(TYPE,NAME,VALUE)           \
  const TYPE NAME[1]                              \
  asm ("_$$PsectAttributes_GLOBALVALUE$$" #NAME)  \
    = {VALUE}
#else
#define GLOBALREF(TYPE,NAME) \
  globalref TYPE NAME
#define GLOBALDEF(TYPE,NAME,VALUE) \
  globaldef TYPE NAME = VALUE
#define GLOBALVALUEDEF(TYPE,NAME,VALUE) \
  globalvalue TYPE NAME = VALUE
#define GLOBALVALUEREF(TYPE,NAME) \
  globalvalue TYPE NAME
#endif

(The _$$PsectAttributes_GLOBALSYMBOL prefix at the start of the name is removed by the assembler, after it has modified the attributes of the symbol). These macros are provided in the VMS binaries distribution in a header file `GNU_HACKS.H'. An example of the usage is:

GLOBALREF (int, ijk);
GLOBALDEF (int, jkl, 0);

The macros GLOBALREF and GLOBALDEF cannot be used straightforwardly for arrays, since there is no way to insert the array dimension into the declaration at the right place. However, you can declare an array with these macros if you first define a typedef for the array type, like this:

typedef int intvector[10];
GLOBALREF (intvector, foo);

Array and structure initializers will also break the macros; you can define the initializer to be a macro of its own, or you can expand the GLOBALDEF macro by hand. You may find a case where you wish to use the GLOBALDEF macro with a large array, but you are not interested in explicitly initializing each element of the array. In such cases you can use an initializer like: {0,}, which will initialize the entire array to 0.

A shortcoming of this implementation is that a variable declared with GLOBALVALUEREF or GLOBALVALUEDEF is always an array. For example, the declaration:

GLOBALVALUEREF(int, ijk);

declares the variable ijk as an array of type int [1]. This is done because a globalvalue is actually a constant; its "value" is what the linker would normally consider an address. That is not how an integer value works in C, but it is how an array works. So treating the symbol as an array name gives consistent results--with the exception that the value seems to have the wrong type. Don't try to access an element of the array. It doesn't have any elements. The array "address" may not be the address of actual storage.

The fact that the symbol is an array may lead to warnings where the variable is used. Insert type casts to avoid the warnings. Here is an example; it takes advantage of the ANSI C feature allowing macros that expand to use the same name as the macro itself.

GLOBALVALUEREF (int, ss$_normal);
GLOBALVALUEDEF (int, xyzzy,123);
#ifdef __GNUC__
#define ss$_normal ((int) ss$_normal)
#define xyzzy ((int) xyzzy)
#endif

Don't use globaldef or globalref with a variable whose type is an enumeration type; this is not implemented. Instead, make the variable an integer, and use a globalvaluedef for each of the enumeration values. An example of this would be:

#ifdef __GNUC__
GLOBALDEF (int, color, 0);
GLOBALVALUEDEF (int, RED, 0);
GLOBALVALUEDEF (int, BLUE, 1);
GLOBALVALUEDEF (int, GREEN, 3);
#else
enum globaldef color {RED, BLUE, GREEN = 3};
#endif


Using and Porting GNU CC - VMS Misc

Other VMS Issues

GNU CC automatically arranges for main to return 1 by default if you fail to specify an explicit return value. This will be interpreted by VMS as a status code indicating a normal successful completion. Version 1 of GNU CC did not provide this default.

GNU CC on VMS works only with the GNU assembler, GAS. You need version 1.37 or later of GAS in order to produce value debugging information for the VMS debugger. Use the ordinary VMS linker with the object files produced by GAS.

Under previous versions of GNU CC, the generated code would occasionally give strange results when linked to the sharable `VAXCRTL' library. Now this should work.

A caveat for use of const global variables: the const modifier must be specified in every external declaration of the variable in all of the source files that use that variable. Otherwise the linker will issue warnings about conflicting attributes for the variable. Your program will still work despite the warnings, but the variable will be placed in writable storage.

Although the VMS linker does distinguish between upper and lower case letters in global symbols, most VMS compilers convert all such symbols into upper case and most run-time library routines also have upper case names. To be able to reliably call such routines, GNU CC (by means of the assembler GAS) converts global symbols into upper case like other VMS compilers. However, since the usual practice in C is to distinguish case, GNU CC (via GAS) tries to preserve usual C behavior by augmenting each name that is not all lower case. This means truncating the name to at most 23 characters and then adding more characters at the end which encode the case pattern of those 23. Names which contain at least one dollar sign are an exception; they are converted directly into upper case without augmentation.

Name augmentation yields bad results for programs that use precompiled libraries (such as Xlib) which were generated by another compiler. You can use the compiler option `/NOCASE_HACK' to inhibit augmentation; it makes external C functions and variables case-independent as is usual on VMS. Alternatively, you could write all references to the functions and variables in such libraries using lower case; this will work on VMS, but is not portable to other systems. The compiler option `/NAMES' also provides control over global name handling.

Function and variable names are handled somewhat differently with GNU C++. The GNU C++ compiler performs name mangling on function names, which means that it adds information to the function name to describe the data types of the arguments that the function takes. One result of this is that the name of a function can become very long. Since the VMS linker only recognizes the first 31 characters in a name, special action is taken to ensure that each function and variable has a unique name that can be represented in 31 characters.

If the name (plus a name augmentation, if required) is less than 32 characters in length, then no special action is performed. If the name is longer than 31 characters, the assembler (GAS) will generate a hash string based upon the function name, truncate the function name to 23 characters, and append the hash string to the truncated name. If the `/VERBOSE' compiler option is used, the assembler will print both the full and truncated names of each symbol that is truncated.

The `/NOCASE_HACK' compiler option should not be used when you are compiling programs that use libg++. libg++ has several instances of objects (i.e. Filebuf and filebuf) which become indistinguishable in a case-insensitive environment. This leads to cases where you need to inhibit augmentation selectively (if you were using libg++ and Xlib in the same program, for example). There is no special feature for doing this, but you can get the result by defining a macro for each mixed case symbol for which you wish to inhibit augmentation. The macro should expand into the lower case equivalent of itself. For example:

#define StuDlyCapS studlycaps

These macro definitions can be placed in a header file to minimize the number of changes to your source code.


Using and Porting GNU CC - Portability

GNU CC and Portability

The main goal of GNU CC was to make a good, fast compiler for machines in the class that the GNU system aims to run on: 32-bit machines that address 8-bit bytes and have several general registers. Elegance, theoretical power and simplicity are only secondary.

GNU CC gets most of the information about the target machine from a machine description which gives an algebraic formula for each of the machine's instructions. This is a very clean way to describe the target. But when the compiler needs information that is difficult to express in this fashion, I have not hesitated to define an ad-hoc parameter to the machine description. The purpose of portability is to reduce the total work needed on the compiler; it was not of interest for its own sake.

GNU CC does not contain machine dependent code, but it does contain code that depends on machine parameters such as endianness (whether the most significant byte has the highest or lowest address of the bytes in a word) and the availability of autoincrement addressing. In the RTL-generation pass, it is often necessary to have multiple strategies for generating code for a particular kind of syntax tree, strategies that are usable for different combinations of parameters. Often I have not tried to address all possible cases, but only the common ones or only the ones that I have encountered. As a result, a new target may require additional strategies. You will know if this happens because the compiler will call abort. Fortunately, the new strategies can be added in a machine-independent fashion, and will affect only the target machines that need them.


Using and Porting GNU CC - Interface

Interfacing to GNU CC Output

GNU CC is normally configured to use the same function calling convention normally in use on the target system. This is done with the machine-description macros described (see section Target Description Macros).

However, returning of structure and union values is done differently on some target machines. As a result, functions compiled with PCC returning such types cannot be called from code compiled with GNU CC, and vice versa. This does not cause trouble often because few Unix library routines return structures or unions.

GNU CC code returns structures and unions that are 1, 2, 4 or 8 bytes long in the same registers used for int or double return values. (GNU CC typically allocates variables of such types in registers also.) Structures and unions of other sizes are returned by storing them into an address passed by the caller (usually in a register). The machine-description macros STRUCT_VALUE and STRUCT_INCOMING_VALUE tell GNU CC where to pass this address.

By contrast, PCC on most target machines returns structures and unions of any size by copying the data into an area of static storage, and then returning the address of that storage as if it were a pointer value. The caller must copy the data from that memory area to the place where the value is wanted. This is slower than the method used by GNU CC, and fails to be reentrant.

On some target machines, such as RISC machines and the 80386, the standard system convention is to pass to the subroutine the address of where to return the value. On these machines, GNU CC has been configured to be compatible with the standard compiler, when this method is used. It may not be compatible for structures of 1, 2, 4 or 8 bytes.

GNU CC uses the system's standard convention for passing arguments. On some machines, the first few arguments are passed in registers; in others, all are passed on the stack. It would be possible to use registers for argument passing on any machine, and this would probably result in a significant speedup. But the result would be complete incompatibility with code that follows the standard convention. So this change is practical only if you are switching to GNU CC as the sole C compiler for the system. We may implement register argument passing on certain machines once we have a complete GNU system so that we can compile the libraries with GNU CC.

On some machines (particularly the Sparc), certain types of arguments are passed "by invisible reference". This means that the value is stored in memory, and the address of the memory location is passed to the subroutine.

If you use longjmp, beware of automatic variables. ANSI C says that automatic variables that are not declared volatile have undefined values after a longjmp. And this is all GNU CC promises to do, because it is very difficult to restore register variables correctly, and one of GNU CC's features is that it can put variables in registers without your asking it to.

If you want a variable to be unaltered by longjmp, and you don't want to write volatile because old C compilers don't accept it, just take the address of the variable. If a variable's address is ever taken, even if just to compute it and ignore it, then the variable cannot go in a register:

{
  int careful;
  &careful;
  ...
}

Code compiled with GNU CC may call certain library routines. Most of them handle arithmetic for which there are no instructions. This includes multiply and divide on some machines, and floating point operations on any machine for which floating point support is disabled with `-msoft-float'. Some standard parts of the C library, such as bcopy or memcpy, are also called automatically. The usual function call interface is used for calling the library routines.

These library routines should be defined in the library `libgcc.a', which GNU CC automatically searches whenever it links a program. On machines that have multiply and divide instructions, if hardware floating point is in use, normally `libgcc.a' is not needed, but it is searched just in case.

Each arithmetic function is defined in `libgcc1.c' to use the corresponding C arithmetic operator. As long as the file is compiled with another C compiler, which supports all the C arithmetic operators, this file will work portably. However, `libgcc1.c' does not work if compiled with GNU CC, because each arithmetic function would compile into a call to itself!


Using and Porting GNU CC - Passes

Passes and Files of the Compiler

The overall control structure of the compiler is in `toplev.c'. This file is responsible for initialization, decoding arguments, opening and closing files, and sequencing the passes.

The parsing pass is invoked only once, to parse the entire input. The RTL intermediate code for a function is generated as the function is parsed, a statement at a time. Each statement is read in as a syntax tree and then converted to RTL; then the storage for the tree for the statement is reclaimed. Storage for types (and the expressions for their sizes), declarations, and a representation of the binding contours and how they nest, remain until the function is finished being compiled; these are all needed to output the debugging information.

Each time the parsing pass reads a complete function definition or top-level declaration, it calls either the function rest_of_compilation, or the function rest_of_decl_compilation in `toplev.c', which are responsible for all further processing necessary, ending with output of the assembler language. All other compiler passes run, in sequence, within rest_of_compilation. When that function returns from compiling a function definition, the storage used for that function definition's compilation is entirely freed, unless it is an inline function (see section An Inline Function is As Fast As a Macro).

Here is a list of all the passes of the compiler and their source files. Also included is a description of where debugging dumps can be requested with `-d' options.

  • Parsing. This pass reads the entire text of a function definition, constructing partial syntax trees. This and RTL generation are no longer truly separate passes (formerly they were), but it is easier to think of them as separate. The tree representation does not entirely follow C syntax, because it is intended to support other languages as well. Language-specific data type analysis is also done in this pass, and every tree node that represents an expression has a data type attached. Variables are represented as declaration nodes. Constant folding and some arithmetic simplifications are also done during this pass. The language-independent source files for parsing are `stor-layout.c', `fold-const.c', and `tree.c'. There are also header files `tree.h' and `tree.def' which define the format of the tree representation. The source files to parse C are `c-parse.in', `c-decl.c', `c-typeck.c', `c-aux-info.c', `c-convert.c', and `c-lang.c' along with header files `c-lex.h', and `c-tree.h'. The source files for parsing C++ are `cp-parse.y', `cp-class.c',
    `cp-cvt.c', `cp-decl.c', `cp-decl2.c', `cp-dem.c', `cp-except.c',
    `cp-expr.c', `cp-init.c', `cp-lex.c', `cp-method.c', `cp-ptree.c',
    `cp-search.c', `cp-tree.c', `cp-type2.c', and `cp-typeck.c', along with header files `cp-tree.def', `cp-tree.h', and `cp-decl.h'. The special source files for parsing Objective C are `objc-parse.y', `objc-actions.c', `objc-tree.def', and `objc-actions.h'. Certain C-specific files are used for this as well. The file `c-common.c' is also used for all of the above languages.
  • RTL generation. This is the conversion of syntax tree into RTL code. It is actually done statement-by-statement during parsing, but for most purposes it can be thought of as a separate pass. This is where the bulk of target-parameter-dependent code is found, since often it is necessary for strategies to apply only when certain standard kinds of instructions are available. The purpose of named instruction patterns is to provide this information to the RTL generation pass. Optimization is done in this pass for if-conditions that are comparisons, boolean operations or conditional expressions. Tail recursion is detected at this time also. Decisions are made about how best to arrange loops and how to output switch statements. The source files for RTL generation include `stmt.c', `calls.c', `expr.c', `explow.c', `expmed.c', `function.c', `optabs.c' and `emit-rtl.c'. Also, the file `insn-emit.c', generated from the machine description by the program genemit, is used in this pass. The header file `expr.h' is used for communication within this pass. The header files `insn-flags.h' and `insn-codes.h', generated from the machine description by the programs genflags and gencodes, tell this pass which standard names are available for use and which patterns correspond to them. Aside from debugging information output, none of the following passes refers to the tree structure representation of the function (only part of which is saved). The decision of whether the function can and should be expanded inline in its subsequent callers is made at the end of rtl generation. The function must meet certain criteria, currently related to the size of the function and the types and number of parameters it has. Note that this function may contain loops, recursive calls to itself (tail-recursive functions can be inlined!), gotos, in short, all constructs supported by GNU CC. The file `integrate.c' contains the code to save a function's rtl for later inlining and to inline that rtl when the function is called. The header file `integrate.h' is also used for this purpose. The option `-dr' causes a debugging dump of the RTL code after this pass. This dump file's name is made by appending `.rtl' to the input file name.
  • Jump optimization. This pass simplifies jumps to the following instruction, jumps across jumps, and jumps to jumps. It deletes unreferenced labels and unreachable code, except that unreachable code that contains a loop is not recognized as unreachable in this pass. (Such loops are deleted later in the basic block analysis.) It also converts some code originally written with jumps into sequences of instructions that directly set values from the results of comparisons, if the machine has such instructions. Jump optimization is performed two or three times. The first time is immediately following RTL generation. The second time is after CSE, but only if CSE says repeated jump optimization is needed. The last time is right before the final pass. That time, cross-jumping and deletion of no-op move instructions are done together with the optimizations described above. The source file of this pass is `jump.c'. The option `-dj' causes a debugging dump of the RTL code after this pass is run for the first time. This dump file's name is made by appending `.jump' to the input file name.
  • Register scan. This pass finds the first and last use of each register, as a guide for common subexpression elimination. Its source is in `regclass.c'.
  • Jump threading. This pass detects a condition jump that branches to an identical or inverse test. Such jumps can be `threaded' through the second conditional test. The source code for this pass is in `jump.c'. This optimization is only performed if `-fthread-jumps' is enabled.
  • Common subexpression elimination. This pass also does constant propagation. Its source file is `cse.c'. If constant propagation causes conditional jumps to become unconditional or to become no-ops, jump optimization is run again when CSE is finished. The option `-ds' causes a debugging dump of the RTL code after this pass. This dump file's name is made by appending `.cse' to the input file name.
  • Loop optimization. This pass moves constant expressions out of loops, and optionally does strength-reduction and loop unrolling as well. Its source files are `loop.c' and `unroll.c', plus the header `loop.h' used for communication between them. Loop unrolling uses some functions in `integrate.c' and the header `integrate.h'. The option `-dL' causes a debugging dump of the RTL code after this pass. This dump file's name is made by appending `.loop' to the input file name.
  • If `-frerun-cse-after-loop' was enabled, a second common subexpression elimination pass is performed after the loop optimization pass. Jump threading is also done again at this time if it was specified. The option `-dt' causes a debugging dump of the RTL code after this pass. This dump file's name is made by appending `.cse2' to the input file name.
  • Stupid register allocation is performed at this point in a nonoptimizing compilation. It does a little data flow analysis as well. When stupid register allocation is in use, the next pass executed is the reloading pass; the others in between are skipped. The source file is `stupid.c'.
  • Data flow analysis (`flow.c'). This pass divides the program into basic blocks (and in the process deletes unreachable loops); then it computes which pseudo-registers are live at each point in the program, and makes the first instruction that uses a value point at the instruction that computed the value. This pass also deletes computations whose results are never used, and combines memory references with add or subtract instructions to make autoincrement or autodecrement addressing. The option `-df' causes a debugging dump of the RTL code after this pass. This dump file's name is made by appending `.flow' to the input file name. If stupid register allocation is in use, this dump file reflects the full results of such allocation.
  • Instruction combination (`combine.c'). This pass attempts to combine groups of two or three instructions that are related by data flow into single instructions. It combines the RTL expressions for the instructions by substitution, simplifies the result using algebra, and then attempts to match the result against the machine description. The option `-dc' causes a debugging dump of the RTL code after this pass. This dump file's name is made by appending `.combine' to the input file name.
  • Instruction scheduling (`sched.c'). This pass looks for instructions whose output will not be available by the time that it is used in subsequent instructions. (Memory loads and floating point instructions often have this behavior on RISC machines). It re-orders instructions within a basic block to try to separate the definition and use of items that otherwise would cause pipeline stalls. Instruction scheduling is performed twice. The first time is immediately after instruction combination and the second is immediately after reload. The option `-dS' causes a debugging dump of the RTL code after this pass is run for the first time. The dump file's name is made by appending `.sched' to the input file name.
  • Register class preferencing. The RTL code is scanned to find out which register class is best for each pseudo register. The source file is `regclass.c'.
  • Local register allocation (`local-alloc.c'). This pass allocates hard registers to pseudo registers that are used only within one basic block. Because the basic block is linear, it can use fast and powerful techniques to do a very good job. The option `-dl' causes a debugging dump of the RTL code after this pass. This dump file's name is made by appending `.lreg' to the input file name.
  • Global register allocation (`global.c'). This pass allocates hard registers for the remaining pseudo registers (those whose life spans are not contained in one basic block).
  • Reloading. This pass renumbers pseudo registers with the hardware registers numbers they were allocated. Pseudo registers that did not get hard registers are replaced with stack slots. Then it finds instructions that are invalid because a value has failed to end up in a register, or has ended up in a register of the wrong kind. It fixes up these instructions by reloading the problematical values temporarily into registers. Additional instructions are generated to do the copying. The reload pass also optionally eliminates the frame pointer and inserts instructions to save and restore call-clobbered registers around calls. Source files are `reload.c' and `reload1.c', plus the header `reload.h' used for communication between them. The option `-dg' causes a debugging dump of the RTL code after this pass. This dump file's name is made by appending `.greg' to the input file name.
  • Instruction scheduling is repeated here to try to avoid pipeline stalls due to memory loads generated for spilled pseudo registers. The option `-dR' causes a debugging dump of the RTL code after this pass. This dump file's name is made by appending `.sched2' to the input file name.
  • Jump optimization is repeated, this time including cross-jumping and deletion of no-op move instructions. The option `-dJ' causes a debugging dump of the RTL code after this pass. This dump file's name is made by appending `.jump2' to the input file name.
  • Delayed branch scheduling. This optional pass attempts to find instructions that can go into the delay slots of other instructions, usually jumps and calls. The source file name is `reorg.c'. The option `-dd' causes a debugging dump of the RTL code after this pass. This dump file's name is made by appending `.dbr' to the input file name.
  • Conversion from usage of some hard registers to usage of a register stack may be done at this point. Currently, this is supported only for the floating-point registers of the Intel 80387 coprocessor. The source file name is `reg-stack.c'. The options `-dk' causes a debugging dump of the RTL code after this pass. This dump file's name is made by appending `.stack' to the input file name.
  • Final. This pass outputs the assembler code for the function. It is also responsible for identifying spurious test and compare instructions. Machine-specific peephole optimizations are performed at the same time. The function entry and exit sequences are generated directly as assembler code in this pass; they never exist as RTL. The source files are `final.c' plus `insn-output.c'; the latter is generated automatically from the machine description by the tool `genoutput'. The header file `conditions.h' is used for communication between these files.
  • Debugging information output. This is run after final because it must output the stack slot offsets for pseudo registers that did not get hard registers. Source files are `dbxout.c' for DBX symbol table format, `sdbout.c' for SDB symbol table format, and `dwarfout.c' for DWARF symbol table format.

Some additional files are used by all or many passes:

  • Every pass uses `machmode.def' and `machmode.h' which define the machine modes.
  • Several passes use `real.h', which defines the default representation of floating point constants and how to operate on them.
  • All the passes that work with RTL use the header files `rtl.h' and `rtl.def', and subroutines in file `rtl.c'. The tools gen* also use these files to read and work with the machine description RTL.
  • Several passes refer to the header file `insn-config.h' which contains a few parameters (C macro definitions) generated automatically from the machine description RTL by the tool genconfig.
  • Several passes use the instruction recognizer, which consists of `recog.c' and `recog.h', plus the files `insn-recog.c' and `insn-extract.c' that are generated automatically from the machine description by the tools `genrecog' and `genextract'.
  • Several passes use the header files `regs.h' which defines the information recorded about pseudo register usage, and `basic-block.h' which defines the information recorded about basic blocks.
  • `hard-reg-set.h' defines the type HARD_REG_SET, a bit-vector with a bit for each hard register, and some macros to manipulate it. This type is just int if the machine has few enough hard registers; otherwise it is an array of int and some of the macros expand into loops.
  • Several passes use instruction attributes. A definition of the attributes defined for a particular machine is in file `insn-attr.h', which is generated from the machine description by the program `genattr'. The file `insn-attrtab.c' contains subroutines to obtain the attribute values for insns. It is generated from the machine description by the program `genattrtab'.


Using and Porting GNU CC - RTL

RTL Representation

Most of the work of the compiler is done on an intermediate representation called register transfer language. In this language, the instructions to be output are described, pretty much one by one, in an algebraic form that describes what the instruction does.

RTL is inspired by Lisp lists. It has both an internal form, made up of structures that point at other structures, and a textual form that is used in the machine description and in printed debugging dumps. The textual form uses nested parentheses to indicate the pointers in the internal form.


Using and Porting GNU CC - RTL Objects

RTL Object Types

RTL uses five kinds of objects: expressions, integers, wide integers, strings and vectors. Expressions are the most important ones. An RTL expression ("RTX", for short) is a C structure, but it is usually referred to with a pointer; a type that is given the typedef name rtx.

An integer is simply an int; their written form uses decimal digits. A wide integer is an integral object whose type is HOST_WIDE_INT (see section The Configuration File); their written form uses decimal digits.

A string is a sequence of characters. In core it is represented as a char * in usual C fashion, and it is written in C syntax as well. However, strings in RTL may never be null. If you write an empty string in a machine description, it is represented in core as a null pointer rather than as a pointer to a null character. In certain contexts, these null pointers instead of strings are valid. Within RTL code, strings are most commonly found inside symbol_ref expressions, but they appear in other contexts in the RTL expressions that make up machine descriptions.

A vector contains an arbitrary number of pointers to expressions. The number of elements in the vector is explicitly present in the vector. The written form of a vector consists of square brackets (`[...]') surrounding the elements, in sequence and with whitespace separating them. Vectors of length zero are not created; null pointers are used instead.

Expressions are classified by expression codes (also called RTX codes). The expression code is a name defined in `rtl.def', which is also (in upper case) a C enumeration constant. The possible expression codes and their meanings are machine-independent. The code of an RTX can be extracted with the macro GET_CODE (x) and altered with PUT_CODE (x, newcode).

The expression code determines how many operands the expression contains, and what kinds of objects they are. In RTL, unlike Lisp, you cannot tell by looking at an operand what kind of object it is. Instead, you must know from its context--from the expression code of the containing expression. For example, in an expression of code subreg, the first operand is to be regarded as an expression and the second operand as an integer. In an expression of code plus, there are two operands, both of which are to be regarded as expressions. In a symbol_ref expression, there is one operand, which is to be regarded as a string.

Expressions are written as parentheses containing the name of the expression type, its flags and machine mode if any, and then the operands of the expression (separated by spaces).

Expression code names in the `md' file are written in lower case, but when they appear in C code they are written in upper case. In this manual, they are shown as follows: const_int.

In a few contexts a null pointer is valid where an expression is normally wanted. The written form of this is (nil).


Using and Porting GNU CC - Accessors

Access to Operands

For each expression type `rtl.def' specifies the number of contained objects and their kinds, with four possibilities: `e' for expression (actually a pointer to an expression), `i' for integer, `w' for wide integer, `s' for string, and `E' for vector of expressions. The sequence of letters for an expression code is called its format. Thus, the format of subreg is `ei'.

A few other format characters are used occasionally:

u
`u' is equivalent to `e' except that it is printed differently in debugging dumps. It is used for pointers to insns.
n
`n' is equivalent to `i' except that it is printed differently in debugging dumps. It is used for the line number or code number of a note insn.
S
`S' indicates a string which is optional. In the RTL objects in core, `S' is equivalent to `s', but when the object is read, from an `md' file, the string value of this operand may be omitted. An omitted string is taken to be the null string.
V
`V' indicates a vector which is optional. In the RTL objects in core, `V' is equivalent to `E', but when the object is read from an `md' file, the vector value of this operand may be omitted. An omitted vector is effectively the same as a vector of no elements.
0
`0' means a slot whose contents do not fit any normal category. `0' slots are not printed at all in dumps, and are often used in special ways by small parts of the compiler.

There are macros to get the number of operands, the format, and the class of an expression code:

GET_RTX_LENGTH (code)
Number of operands of an RTX of code code.
GET_RTX_FORMAT (code)
The format of an RTX of code code, as a C string.
GET_RTX_CLASS (code)
A single character representing the type of RTX operation that code code performs. The following classes are defined:
o
An RTX code that represents an actual object, such as reg or mem. subreg is not in this class.
<
An RTX code for a comparison. The codes in this class are NE, EQ, LE, LT, GE, GT, LEU, LTU, GEU, GTU.
1
An RTX code for a unary arithmetic operation, such as neg.
c
An RTX code for a commutative binary operation, other than NE and EQ (which have class `<').
2
An RTX code for a noncommutative binary operation, such as MINUS.
b
An RTX code for a bitfield operation, either ZERO_EXTRACT or SIGN_EXTRACT.
3
An RTX code for other three input operations, such as IF_THEN_ELSE.
i
An RTX code for a machine insn (INSN, JUMP_INSN, and CALL_INSN).
m
An RTX code for something that matches in insns, such as MATCH_DUP.
x
All other RTX codes.

Operands of expressions are accessed using the macros XEXP, XINT, XWINT and XSTR. Each of these macros takes two arguments: an expression-pointer (RTX) and an operand number (counting from zero). Thus,

XEXP (x, 2)

accesses operand 2 of expression x, as an expression.

XINT (x, 2)

accesses the same operand as an integer. XSTR, used in the same fashion, would access it as a string.

Any operand can be accessed as an integer, as an expression or as a string. You must choose the correct method of access for the kind of value actually stored in the operand. You would do this based on the expression code of the containing expression. That is also how you would know how many operands there are.

For example, if x is a subreg expression, you know that it has two operands which can be correctly accessed as XEXP (x, 0) and XINT (x, 1). If you did XINT (x, 0), you would get the address of the expression operand but cast as an integer; that might occasionally be useful, but it would be cleaner to write (int) XEXP (x, 0). XEXP (x, 1) would also compile without error, and would return the second, integer operand cast as an expression pointer, which would probably result in a crash when accessed. Nothing stops you from writing XEXP (x, 28) either, but this will access memory past the end of the expression with unpredictable results.

Access to operands which are vectors is more complicated. You can use the macro XVEC to get the vector-pointer itself, or the macros XVECEXP and XVECLEN to access the elements and length of a vector.

XVEC (exp, idx)
Access the vector-pointer which is operand number idx in exp.
XVECLEN (exp, idx)
Access the length (number of elements) in the vector which is in operand number idx in exp. This value is an int.
XVECEXP (exp, idx, eltnum)
Access element number eltnum in the vector which is in operand number idx in exp. This value is an RTX. It is up to you to make sure that eltnum is not negative and is less than XVECLEN (exp, idx).

All the macros defined in this section expand into lvalues and therefore can be used to assign the operands, lengths and vector elements as well as to access them.


Using and Porting GNU CC - Flags

Flags in an RTL Expression

RTL expressions contain several flags (one-bit bitfields) that are used in certain types of expression. Most often they are accessed with the following macros:

MEM_VOLATILE_P (x)
In mem expressions, nonzero for volatile memory references. Stored in the volatil field and printed as `/v'.
MEM_IN_STRUCT_P (x)
In mem expressions, nonzero for reference to an entire structure, union or array, or to a component of one. Zero for references to a scalar variable or through a pointer to a scalar. Stored in the in_struct field and printed as `/s'.
REG_LOOP_TEST_P
In reg expressions, nonzero if this register's entire life is contained in the exit test code for some loop. Stored in the in_struct field and printed as `/s'.
REG_USERVAR_P (x)
In a reg, nonzero if it corresponds to a variable present in the user's source code. Zero for temporaries generated internally by the compiler. Stored in the volatil field and printed as `/v'.
REG_FUNCTION_VALUE_P (x)
Nonzero in a reg if it is the place in which this function's value is going to be returned. (This happens only in a hard register.) Stored in the integrated field and printed as `/i'. The same hard register may be used also for collecting the values of functions called by this one, but REG_FUNCTION_VALUE_P is zero in this kind of use.
SUBREG_PROMOTED_VAR_P
Nonzero in a subreg if it was made when accessing an object that was promoted to a wider mode in accord with the PROMOTED_MODE machine description macro (see section Storage Layout). In this case, the mode of the subreg is the declared mode of the object and the mode of SUBREG_REG is the mode of the register that holds the object. Promoted variables are always either sign- or zero-extended to the wider mode on every assignment. Stored in the in_struct field and printed as `/s'.
SUBREG_PROMOTED_UNSIGNED_P
Nonzero in a subreg that has SUBREG_PROMOTED_VAR_P nonzero if the object being referenced is kept zero-extended and zero if it is kept sign-extended. Stored in the unchanging field and printed as `/u'.
RTX_UNCHANGING_P (x)
Nonzero in a reg or mem if the value is not changed. (This flag is not set for memory references via pointers to constants. Such pointers only guarantee that the object will not be changed explicitly by the current function. The object might be changed by other functions or by aliasing.) Stored in the unchanging field and printed as `/u'.
RTX_INTEGRATED_P (insn)
Nonzero in an insn if it resulted from an in-line function call. Stored in the integrated field and printed as `/i'. This may be deleted; nothing currently depends on it.
SYMBOL_REF_USED (x)
In a symbol_ref, indicates that x has been used. This is normally only used to ensure that x is only declared external once. Stored in the used field.
SYMBOL_REF_FLAG (x)
In a symbol_ref, this is used as a flag for machine-specific purposes. Stored in the volatil field and printed as `/v'.
LABEL_OUTSIDE_LOOP_P
In label_ref expressions, nonzero if this is a reference to a label that is outside the innermost loop containing the reference to the label. Stored in the in_struct field and printed as `/s'.
INSN_DELETED_P (insn)
In an insn, nonzero if the insn has been deleted. Stored in the volatil field and printed as `/v'.
INSN_ANNULLED_BRANCH_P (insn)
In an insn in the delay slot of a branch insn, indicates that an annulling branch should be used. See the discussion under sequence below. Stored in the unchanging field and printed as `/u'.
INSN_FROM_TARGET_P (insn)
In an insn in a delay slot of a branch, indicates that the insn is from the target of the branch. If the branch insn has INSN_ANNULLED_BRANCH_P set, this insn should only be executed if the branch is taken. For annulled branches with this bit clear, the insn should be executed only if the branch is not taken. Stored in the in_struct field and printed as `/s'.
CONSTANT_POOL_ADDRESS_P (x)
Nonzero in a symbol_ref if it refers to part of the current function's "constants pool". These are addresses close to the beginning of the function, and GNU CC assumes they can be addressed directly (perhaps with the help of base registers). Stored in the unchanging field and printed as `/u'.
CONST_CALL_P (x)
In a call_insn, indicates that the insn represents a call to a const function. Stored in the unchanging field and printed as `/u'.
LABEL_PRESERVE_P (x)
In a code_label, indicates that the label can never be deleted. Labels referenced by a non-local goto will have this bit set. Stored in the in_struct field and printed as `/s'.
SCHED_GROUP_P (insn)
During instruction scheduling, in an insn, indicates that the previous insn must be scheduled together with this insn. This is used to ensure that certain groups of instructions will not be split up by the instruction scheduling pass, for example, use insns before a call_insn may not be separated from the call_insn. Stored in the in_struct field and printed as `/s'.

These are the fields which the above macros refer to:

used
Normally, this flag is used only momentarily, at the end of RTL generation for a function, to count the number of times an expression appears in insns. Expressions that appear more than once are copied, according to the rules for shared structure (see section Structure Sharing Assumptions). In a symbol_ref, it indicates that an external declaration for the symbol has already been written. In a reg, it is used by the leaf register renumbering code to ensure that each register is only renumbered once.
volatil
This flag is used in mem, symbol_ref and reg expressions and in insns. In RTL dump files, it is printed as `/v'. In a mem expression, it is 1 if the memory reference is volatile. Volatile memory references may not be deleted, reordered or combined. In a symbol_ref expression, it is used for machine-specific purposes. In a reg expression, it is 1 if the value is a user-level variable. 0 indicates an internal compiler temporary. In an insn, 1 means the insn has been deleted.
in_struct
In mem expressions, it is 1 if the memory datum referred to is all or part of a structure or array; 0 if it is (or might be) a scalar variable. A reference through a C pointer has 0 because the pointer might point to a scalar variable. This information allows the compiler to determine something about possible cases of aliasing. In an insn in the delay slot of a branch, 1 means that this insn is from the target of the branch. During instruction scheduling, in an insn, 1 means that this insn must be scheduled as part of a group together with the previous insn. In reg expressions, it is 1 if the register has its entire life contained within the test expression of some loop. In subreg expressions, 1 means that the subreg is accessing an object that has had its mode promoted from a wider mode. In label_ref expressions, 1 means that the referenced label is outside the innermost loop containing the insn in which the label_ref was found. In code_label expressions, it is 1 if the label may never be deleted. This is used for labels which are the target of non-local gotos. In an RTL dump, this flag is represented as `/s'.
unchanging
In reg and mem expressions, 1 means that the value of the expression never changes. In subreg expressions, it is 1 if the subreg references an unsigned object whose mode has been promoted to a wider mode. In an insn, 1 means that this is an annulling branch. In a symbol_ref expression, 1 means that this symbol addresses something in the per-function constants pool. In a call_insn, 1 means that this instruction is a call to a const function. In an RTL dump, this flag is represented as `/u'.
integrated
In some kinds of expressions, including insns, this flag means the rtl was produced by procedure integration. In a reg expression, this flag indicates the register containing the value to be returned by the current function. On machines that pass parameters in registers, the same register number may be used for parameters as well, but this flag is not set on such uses.


Using and Porting GNU CC - Machine Modes

Machine Modes

A machine mode describes a size of data object and the representation used for it. In the C code, machine modes are represented by an enumeration type, enum machine_mode, defined in `machmode.def'. Each RTL expression has room for a machine mode and so do certain kinds of tree expressions (declarations and types, to be precise).

In debugging dumps and machine descriptions, the machine mode of an RTL expression is written after the expression code with a colon to separate them. The letters `mode' which appear at the end of each machine mode name are omitted. For example, (reg:SI 38) is a reg expression with machine mode SImode. If the mode is VOIDmode, it is not written at all.

Here is a table of machine modes. The term "byte" below refers to an object of BITS_PER_UNIT bits (see section Storage Layout).

QImode
"Quarter-Integer" mode represents a single byte treated as an integer.
HImode
"Half-Integer" mode represents a two-byte integer.
PSImode
"Partial Single Integer" mode represents an integer which occupies four bytes but which doesn't really use all four. On some machines, this is the right mode to use for pointers.
SImode
"Single Integer" mode represents a four-byte integer.
PDImode
"Partial Double Integer" mode represents an integer which occupies eight bytes but which doesn't really use all eight. On some machines, this is the right mode to use for certain pointers.
DImode
"Double Integer" mode represents an eight-byte integer.
TImode
"Tetra Integer" (?) mode represents a sixteen-byte integer.
SFmode
"Single Floating" mode represents a single-precision (four byte) floating point number.
DFmode
"Double Floating" mode represents a double-precision (eight byte) floating point number.
XFmode
"Extended Floating" mode represents a triple-precision (twelve byte) floating point number. This mode is used for IEEE extended floating point. On some systems not all bits within these bytes will actually be used.
TFmode
"Tetra Floating" mode represents a quadruple-precision (sixteen byte) floating point number.
CCmode
"Condition Code" mode represents the value of a condition code, which is a machine-specific set of bits used to represent the result of a comparison operation. Other machine-specific modes may also be used for the condition code. These modes are not used on machines that use cc0 (see see section Condition Code Status).
BLKmode
"Block" mode represents values that are aggregates to which none of the other modes apply. In RTL, only memory references can have this mode, and only if they appear in string-move or vector instructions. On machines which have no such instructions, BLKmode will not appear in RTL.
VOIDmode
Void mode means the absence of a mode or an unspecified mode. For example, RTL expressions of code const_int have mode VOIDmode because they can be taken to have whatever mode the context requires. In debugging dumps of RTL, VOIDmode is expressed by the absence of any mode.
SCmode, DCmode, XCmode, TCmode
These modes stand for a complex number represented as a pair of floating point values. The floating point values are in SFmode, DFmode, XFmode, and TFmode, respectively.
CQImode, CHImode, CSImode, CDImode, CTImode, COImode
These modes stand for a complex number represented as a pair of integer values. The integer values are in QImode, HImode, SImode, DImode, TImode, and OImode, respectively.

The machine description defines Pmode as a C macro which expands into the machine mode used for addresses. Normally this is the mode whose size is BITS_PER_WORD, SImode on 32-bit machines.

The only modes which a machine description must support are QImode, and the modes corresponding to BITS_PER_WORD, FLOAT_TYPE_SIZE and DOUBLE_TYPE_SIZE. The compiler will attempt to use DImode for 8-byte structures and unions, but this can be prevented by overriding the definition of MAX_FIXED_MODE_SIZE. Alternatively, you can have the compiler use TImode for 16-byte structures and unions. Likewise, you can arrange for the C type short int to avoid using HImode.

Very few explicit references to machine modes remain in the compiler and these few references will soon be removed. Instead, the machine modes are divided into mode classes. These are represented by the enumeration type enum mode_class defined in `machmode.h'. The possible mode classes are:

MODE_INT
Integer modes. By default these are QImode, HImode, SImode, DImode, and TImode.
MODE_PARTIAL_INT
The "partial integer" modes, PSImode and PDImode.
MODE_FLOAT
floating point modes. By default these are SFmode, DFmode, XFmode and TFmode.
MODE_COMPLEX_INT
Complex integer modes. (These are not currently implemented).
MODE_COMPLEX_FLOAT
Complex floating point modes. By default these are SCmode, DCmode, XCmode, and TCmode.
MODE_FUNCTION
Algol or Pascal function variables including a static chain. (These are not currently implemented).
MODE_CC
Modes representing condition code values. These are CCmode plus any modes listed in the EXTRA_CC_MODES macro. See section Defining Jump Instruction Patterns, also see section Condition Code Status.
MODE_RANDOM
This is a catchall mode class for modes which don't fit into the above classes. Currently VOIDmode and BLKmode are in MODE_RANDOM.

Here are some C macros that relate to machine modes:

GET_MODE (x)
Returns the machine mode of the RTX x.
PUT_MODE (x, newmode)
Alters the machine mode of the RTX x to be newmode.
NUM_MACHINE_MODES
Stands for the number of machine modes available on the target machine. This is one greater than the largest numeric value of any machine mode.
GET_MODE_NAME (m)
Returns the name of mode m as a string.
GET_MODE_CLASS (m)
Returns the mode class of mode m.
GET_MODE_WIDER_MODE (m)
Returns the next wider natural mode. For example, the expression GET_MODE_WIDER_MODE (QImode) returns HImode.
GET_MODE_SIZE (m)
Returns the size in bytes of a datum of mode m.
GET_MODE_BITSIZE (m)
Returns the size in bits of a datum of mode m.
GET_MODE_MASK (m)
Returns a bitmask containing 1 for all bits in a word that fit within mode m. This macro can only be used for modes whose bitsize is less than or equal to HOST_BITS_PER_INT.
GET_MODE_ALIGNMENT (m))
Return the required alignment, in bits, for an object of mode m.
GET_MODE_UNIT_SIZE (m)
Returns the size in bytes of the subunits of a datum of mode m. This is the same as GET_MODE_SIZE except in the case of complex modes. For them, the unit size is the size of the real or imaginary part.
GET_MODE_NUNITS (m)
Returns the number of units contained in a mode, i.e., GET_MODE_SIZE divided by GET_MODE_UNIT_SIZE.
GET_CLASS_NARROWEST_MODE (c)
Returns the narrowest mode in mode class c.

The global variables byte_mode and word_mode contain modes whose classes are MODE_INT and whose bitsizes are either BITS_PER_UNIT or BITS_PER_WORD, respectively. On 32-bit machines, these are QImode and SImode, respectively.


Using and Porting GNU CC - Constants

Constant Expression Types

The simplest RTL expressions are those that represent constant values.

(const_int i)
This type of expression represents the integer value i. i is customarily accessed with the macro INTVAL as in INTVAL (exp), which is equivalent to XWINT (exp, 0). There is only one expression object for the integer value zero; it is the value of the variable const0_rtx. Likewise, the only expression for integer value one is found in const1_rtx, the only expression for integer value two is found in const2_rtx, and the only expression for integer value negative one is found in constm1_rtx. Any attempt to create an expression of code const_int and value zero, one, two or negative one will return const0_rtx, const1_rtx, const2_rtx or constm1_rtx as appropriate. Similarly, there is only one object for the integer whose value is STORE_FLAG_VALUE. It is found in const_true_rtx. If STORE_FLAG_VALUE is one, const_true_rtx and const1_rtx will point to the same object. If STORE_FLAG_VALUE is -1, const_true_rtx and constm1_rtx will point to the same object.
(const_double:m addr i0 i1 ...)
Represents either a floating-point constant of mode m or an integer constant too large to fit into HOST_BITS_PER_WIDE_INT bits but small enough to fit within twice that number of bits (GNU CC does not provide a mechanism to represent even larger constants). In the latter case, m will be VOIDmode. addr is used to contain the mem expression that corresponds to the location in memory that at which the constant can be found. If it has not been allocated a memory location, but is on the chain of all const_double expressions in this compilation (maintained using an undisplayed field), addr contains const0_rtx. If it is not on the chain, addr contains cc0_rtx. addr is customarily accessed with the macro CONST_DOUBLE_MEM and the chain field via CONST_DOUBLE_CHAIN. If m is VOIDmode, the bits of the value are stored in i0 and i1. i0 is customarily accessed with the macro CONST_DOUBLE_LOW and i1 with CONST_DOUBLE_HIGH. If the constant is floating point (regardless of its precision), then the number of integers used to store the value depends on the size of REAL_VALUE_TYPE (see section Cross Compilation and Floating Point). The integers represent a floating point number, but not precisely in the target machine's or host machine's floating point format. To convert them to the precise bit pattern used by the target machine, use the macro REAL_VALUE_TO_TARGET_DOUBLE and friends (see section Output of Data). The macro CONST0_RTX (mode) refers to an expression with value 0 in mode mode. If mode mode is of mode class MODE_INT, it returns const0_rtx. Otherwise, it returns a CONST_DOUBLE expression in mode mode. Similarly, the macro CONST1_RTX (mode) refers to an expression with value 1 in mode mode and similarly for CONST2_RTX.
(const_string str)
Represents a constant string with value str. Currently this is used only for insn attributes (see section Instruction Attributes) since constant strings in C are placed in memory.
(symbol_ref:mode symbol)
Represents the value of an assembler label for data. symbol is a string that describes the name of the assembler label. If it starts with a `*', the label is the rest of symbol not including the `*'. Otherwise, the label is symbol, usually prefixed with `_'. The symbol_ref contains a mode, which is usually Pmode. Usually that is the only mode for which a symbol is directly valid.
(label_ref label)
Represents the value of an assembler label for code. It contains one operand, an expression, which must be a code_label that appears in the instruction sequence to identify the place where the label should go. The reason for using a distinct expression type for code label references is so that jump optimization can distinguish them.
(const:m exp)
Represents a constant that is the result of an assembly-time arithmetic computation. The operand, exp, is an expression that contains only constants (const_int, symbol_ref and label_ref expressions) combined with plus and minus. However, not all combinations are valid, since the assembler cannot do arbitrary arithmetic on relocatable symbols. m should be Pmode.
(high:m exp)
Represents the high-order bits of exp, usually a symbol_ref. The number of bits is machine-dependent and is normally the number of bits specified in an instruction that initializes the high order bits of a register. It is used with lo_sum to represent the typical two-instruction sequence used in RISC machines to reference a global memory location. m should be Pmode.


Using and Porting GNU CC - Regs and Memory

Registers and Memory

Here are the RTL expression types for describing access to machine registers and to main memory.

(reg:m n)
For small values of the integer n (those that are less than FIRST_PSEUDO_REGISTER), this stands for a reference to machine register number n: a hard register. For larger values of n, it stands for a temporary value or pseudo register. The compiler's strategy is to generate code assuming an unlimited number of such pseudo registers, and later convert them into hard registers or into memory references. m is the machine mode of the reference. It is necessary because machines can generally refer to each register in more than one mode. For example, a register may contain a full word but there may be instructions to refer to it as a half word or as a single byte, as well as instructions to refer to it as a floating point number of various precisions. Even for a register that the machine can access in only one mode, the mode must always be specified. The symbol FIRST_PSEUDO_REGISTER is defined by the machine description, since the number of hard registers on the machine is an invariant characteristic of the machine. Note, however, that not all of the machine registers must be general registers. All the machine registers that can be used for storage of data are given hard register numbers, even those that can be used only in certain instructions or can hold only certain types of data. A hard register may be accessed in various modes throughout one function, but each pseudo register is given a natural mode and is accessed only in that mode. When it is necessary to describe an access to a pseudo register using a nonnatural mode, a subreg expression is used. A reg expression with a machine mode that specifies more than one word of data may actually stand for several consecutive registers. If in addition the register number specifies a hardware register, then it actually represents several consecutive hardware registers starting with the specified one. Each pseudo register number used in a function's RTL code is represented by a unique reg expression. Some pseudo register numbers, those within the range of FIRST_VIRTUAL_REGISTER to LAST_VIRTUAL_REGISTER only appear during the RTL generation phase and are eliminated before the optimization phases. These represent locations in the stack frame that cannot be determined until RTL generation for the function has been completed. The following virtual register numbers are defined:
VIRTUAL_INCOMING_ARGS_REGNUM
This points to the first word of the incoming arguments passed on the stack. Normally these arguments are placed there by the caller, but the callee may have pushed some arguments that were previously passed in registers. When RTL generation is complete, this virtual register is replaced by the sum of the register given by ARG_POINTER_REGNUM and the value of FIRST_PARM_OFFSET.
VIRTUAL_STACK_VARS_REGNUM
If FRAME_GROWS_DOWNWARD is defined, this points to immediately above the first variable on the stack. Otherwise, it points to the first variable on the stack. VIRTUAL_STACK_VARS_REGNUM is replaced with the sum of the register given by FRAME_POINTER_REGNUM and the value STARTING_FRAME_OFFSET.
VIRTUAL_STACK_DYNAMIC_REGNUM
This points to the location of dynamically allocated memory on the stack immediately after the stack pointer has been adjusted by the amount of memory desired. This virtual register is replaced by the sum of the register given by STACK_POINTER_REGNUM and the value STACK_DYNAMIC_OFFSET.
VIRTUAL_OUTGOING_ARGS_REGNUM
This points to the location in the stack at which outgoing arguments should be written when the stack is pre-pushed (arguments pushed using push insns should always use STACK_POINTER_REGNUM). This virtual register is replaced by the sum of the register given by STACK_POINTER_REGNUM and the value STACK_POINTER_OFFSET.
(subreg:m reg wordnum)
subreg expressions are used to refer to a register in a machine mode other than its natural one, or to refer to one register of a multi-word reg that actually refers to several registers. Each pseudo-register has a natural mode. If it is necessary to operate on it in a different mode--for example, to perform a fullword move instruction on a pseudo-register that contains a single byte--the pseudo-register must be enclosed in a subreg. In such a case, wordnum is zero. Usually m is at least as narrow as the mode of reg, in which case it is restricting consideration to only the bits of reg that are in m. Sometimes m is wider than the mode of reg. These subreg expressions are often called paradoxical. They are used in cases where we want to refer to an object in a wider mode but do not care what value the additional bits have. The reload pass ensures that paradoxical references are only made to hard registers. The other use of subreg is to extract the individual registers of a multi-register value. Machine modes such as DImode and TImode can indicate values longer than a word, values which usually require two or more consecutive registers. To access one of the registers, use a subreg with mode SImode and a wordnum that says which register. Storing in a non-paradoxical subreg has undefined results for bits belonging to the same word as the subreg. This laxity makes it easier to generate efficient code for such instructions. To represent an instruction that preserves all the bits outside of those in the subreg, use strict_low_part around the subreg. The compilation parameter WORDS_BIG_ENDIAN, if set to 1, says that word number zero is the most significant part; otherwise, it is the least significant part. Between the combiner pass and the reload pass, it is possible to have a paradoxical subreg which contains a mem instead of a reg as its first operand. After the reload pass, it is also possible to have a non-paradoxical subreg which contains a mem; this usually occurs when the mem is a stack slot which replaced a pseudo register. Note that it is not valid to access a DFmode value in SFmode using a subreg. On some machines the most significant part of a DFmode value does not have the same format as a single-precision floating value. It is also not valid to access a single word of a multi-word value in a hard register when less registers can hold the value than would be expected from its size. For example, some 32-bit machines have floating-point registers that can hold an entire DFmode value. If register 10 were such a register (subreg:SI (reg:DF 10) 1) would be invalid because there is no way to convert that reference to a single machine register. The reload pass prevents subreg expressions such as these from being formed. The first operand of a subreg expression is customarily accessed with the SUBREG_REG macro and the second operand is customarily accessed with the SUBREG_WORD macro.
(scratch:m)
This represents a scratch register that will be required for the execution of a single instruction and not used subsequently. It is converted into a reg by either the local register allocator or the reload pass. scratch is usually present inside a clobber operation (see section Side Effect Expressions).
(cc0)
This refers to the machine's condition code register. It has no operands and may not have a machine mode. There are two ways to use it:
  • To stand for a complete set of condition code flags. This is best on most machines, where each comparison sets the entire series of flags. With this technique, (cc0) may be validly used in only two contexts: as the destination of an assignment (in test and compare instructions) and in comparison operators comparing against zero (const_int with value zero; that is to say, const0_rtx).
  • To stand for a single flag that is the result of a single condition. This is useful on machines that have only a single flag bit, and in which comparison instructions must specify the condition to test. With this technique, (cc0) may be validly used in only two contexts: as the destination of an assignment (in test and compare instructions) where the source is a comparison operator, and as the first operand of if_then_else (in a conditional branch).
There is only one expression object of code cc0; it is the value of the variable cc0_rtx. Any attempt to create an expression of code cc0 will return cc0_rtx. Instructions can set the condition code implicitly. On many machines, nearly all instructions set the condition code based on the value that they compute or store. It is not necessary to record these actions explicitly in the RTL because the machine description includes a prescription for recognizing the instructions that do so (by means of the macro NOTICE_UPDATE_CC). See section Condition Code Status. Only instructions whose sole purpose is to set the condition code, and instructions that use the condition code, need mention (cc0). On some machines, the condition code register is given a register number and a reg is used instead of (cc0). This is usually the preferable approach if only a small subset of instructions modify the condition code. Other machines store condition codes in general registers; in such cases a pseudo register should be used. Some machines, such as the Sparc and RS/6000, have two sets of arithmetic instructions, one that sets and one that does not set the condition code. This is best handled by normally generating the instruction that does not set the condition code, and making a pattern that both performs the arithmetic and sets the condition code register (which would not be (cc0) in this case). For examples, search for `addcc' and `andcc' in `sparc.md'.
(pc)
This represents the machine's program counter. It has no operands and may not have a machine mode. (pc) may be validly used only in certain specific contexts in jump instructions. There is only one expression object of code pc; it is the value of the variable pc_rtx. Any attempt to create an expression of code pc will return pc_rtx. All instructions that do not jump alter the program counter implicitly by incrementing it, but there is no need to mention this in the RTL.
(mem:m addr)
This RTX represents a reference to main memory at an address represented by the expression addr. m specifies how large a unit of memory is accessed.


Using and Porting GNU CC - Arithmetic

RTL Expressions for Arithmetic

Unless otherwise specified, all the operands of arithmetic expressions must be valid for mode m. An operand is valid for mode m if it has mode m, or if it is a const_int or const_double and m is a mode of class MODE_INT.

For commutative binary operations, constants should be placed in the second operand.

(plus:m x y)
Represents the sum of the values represented by x and y carried out in machine mode m.
(lo_sum:m x y)
Like plus, except that it represents that sum of x and the low-order bits of y. The number of low order bits is machine-dependent but is normally the number of bits in a Pmode item minus the number of bits set by the high code (see section Constant Expression Types). m should be Pmode.
(minus:m x y)
Like plus but represents subtraction.
(compare:m x y)
Represents the result of subtracting y from x for purposes of comparison. The result is computed without overflow, as if with infinite precision. Of course, machines can't really subtract with infinite precision. However, they can pretend to do so when only the sign of the result will be used, which is the case when the result is stored in the condition code. And that is the only way this kind of expression may validly be used: as a value to be stored in the condition codes. The mode m is not related to the modes of x and y, but instead is the mode of the condition code value. If (cc0) is used, it is VOIDmode. Otherwise it is some mode in class MODE_CC, often CCmode. See section Condition Code Status. Normally, x and y must have the same mode. Otherwise, compare is valid only if the mode of x is in class MODE_INT and y is a const_int or const_double with mode VOIDmode. The mode of x determines what mode the comparison is to be done in; thus it must not be VOIDmode. If one of the operands is a constant, it should be placed in the second operand and the comparison code adjusted as appropriate. A compare specifying two VOIDmode constants is not valid since there is no way to know in what mode the comparison is to be performed; the comparison must either be folded during the compilation or the first operand must be loaded into a register while its mode is still known.
(neg:m x)
Represents the negation (subtraction from zero) of the value represented by x, carried out in mode m.
(mult:m x y)
Represents the signed product of the values represented by x and y carried out in machine mode m. Some machines support a multiplication that generates a product wider than the operands. Write the pattern for this as
(mult:m (sign_extend:m x) (sign_extend:m y))
where m is wider than the modes of x and y, which need not be the same. Write patterns for unsigned widening multiplication similarly using zero_extend.
(div:m x y)
Represents the quotient in signed division of x by y, carried out in machine mode m. If m is a floating point mode, it represents the exact quotient; otherwise, the integerized quotient. Some machines have division instructions in which the operands and quotient widths are not all the same; you should represent such instructions using truncate and sign_extend as in,
(truncate:m1 (div:m2 x (sign_extend:m2 y)))
(udiv:m x y)
Like div but represents unsigned division.
(mod:m x y)
(umod:m x y)
Like div and udiv but represent the remainder instead of the quotient.
(smin:m x y)
(smax:m x y)
Represents the smaller (for smin) or larger (for smax) of x and y, interpreted as signed integers in mode m.
(umin:m x y)
(umax:m x y)
Like smin and smax, but the values are interpreted as unsigned integers.
(not:m x)
Represents the bitwise complement of the value represented by x, carried out in mode m, which must be a fixed-point machine mode.
(and:m x y)
Represents the bitwise logical-and of the values represented by x and y, carried out in machine mode m, which must be a fixed-point machine mode.
(ior:m x y)
Represents the bitwise inclusive-or of the values represented by x and y, carried out in machine mode m, which must be a fixed-point mode.
(xor:m x y)
Represents the bitwise exclusive-or of the values represented by x and y, carried out in machine mode m, which must be a fixed-point mode.
(ashift:m x c)
Represents the result of arithmetically shifting x left by c places. x have mode m, a fixed-point machine mode. c be a fixed-point mode or be a constant with mode VOIDmode; which mode is determined by the mode called for in the machine description entry for the left-shift instruction. For example, on the Vax, the mode of c is QImode regardless of m.
(lshiftrt:m x c)
(ashiftrt:m x c)
Like ashift but for right shift. Unlike the case for left shift, these two operations are distinct.
(rotate:m x c)
(rotatert:m x c)
Similar but represent left and right rotate. If c is a constant, use rotate.
(abs:m x)
Represents the absolute value of x, computed in mode m.
(sqrt:m x)
Represents the square root of x, computed in mode m. Most often m will be a floating point mode.
(ffs:m x)
Represents one plus the index of the least significant 1-bit in x, represented as an integer of mode m. (The value is zero if x is zero.) The mode of x need not be m; depending on the target machine, various mode combinations may be valid.


Using and Porting GNU CC - Comparisons

Comparison Operations

Comparison operators test a relation on two operands and are considered to represent a machine-dependent nonzero value described by, but not necessarily equal to, STORE_FLAG_VALUE (see section Miscellaneous Parameters) if the relation holds, or zero if it does not. The mode of the comparison operation is independent of the mode of the data being compared. If the comparison operation is being tested (e.g., the first operand of an if_then_else), the mode must be VOIDmode. If the comparison operation is producing data to be stored in some variable, the mode must be in class MODE_INT. All comparison operations producing data must use the same mode, which is machine-specific.

There are two ways that comparison operations may be used. The comparison operators may be used to compare the condition codes (cc0) against zero, as in (eq (cc0) (const_int 0)). Such a construct actually refers to the result of the preceding instruction in which the condition codes were set. The instructing setting the condition code must be adjacent to the instruction using the condition code; only note insns may separate them.

Alternatively, a comparison operation may directly compare two data objects. The mode of the comparison is determined by the operands; they must both be valid for a common machine mode. A comparison with both operands constant would be invalid as the machine mode could not be deduced from it, but such a comparison should never exist in RTL due to constant folding.

In the example above, if (cc0) were last set to (compare x y), the comparison operation is identical to (eq x y). Usually only one style of comparisons is supported on a particular machine, but the combine pass will try to merge the operations to produce the eq shown in case it exists in the context of the particular insn involved.

Inequality comparisons come in two flavors, signed and unsigned. Thus, there are distinct expression codes gt and gtu for signed and unsigned greater-than. These can produce different results for the same pair of integer values: for example, 1 is signed greater-than -1 but not unsigned greater-than, because -1 when regarded as unsigned is actually 0xffffffff which is greater than 1.

The signed comparisons are also used for floating point values. Floating point comparisons are distinguished by the machine modes of the operands.

(eq:m x y)
1 if the values represented by x and y are equal, otherwise 0.
(ne:m x y)
1 if the values represented by x and y are not equal, otherwise 0.
(gt:m x y)
1 if the x is greater than y. If they are fixed-point, the comparison is done in a signed sense.
(gtu:m x y)
Like gt but does unsigned comparison, on fixed-point numbers only.
(lt:m x y)
(ltu:m x y)
Like gt and gtu but test for "less than".
(ge:m x y)
(geu:m x y)
Like gt and gtu but test for "greater than or equal".
(le:m x y)
(leu:m x y)
Like gt and gtu but test for "less than or equal".
(if_then_else cond then else)
This is not a comparison operation but is listed here because it is always used in conjunction with a comparison operation. To be precise, cond is a comparison expression. This expression represents a choice, according to cond, between the value represented by then and the one represented by else. On most machines, if_then_else expressions are valid only to express conditional jumps.
(cond [test1 value1 test2 value2 ...] default)
Similar to if_then_else, but more general. Each of test1, test2, ... is performed in turn. The result of this expression is the value corresponding to the first non-zero test, or default if none of the tests are non-zero expressions. This is currently not valid for instruction patterns and is supported only for insn attributes. See section Instruction Attributes.


Using and Porting GNU CC - Bit Fields

Bit Fields

Special expression codes exist to represent bitfield instructions. These types of expressions are lvalues in RTL; they may appear on the left side of an assignment, indicating insertion of a value into the specified bit field.

(sign_extract:m loc size pos)
This represents a reference to a sign-extended bit field contained or starting in loc (a memory or register reference). The bit field is size bits wide and starts at bit pos. The compilation option BITS_BIG_ENDIAN says which end of the memory unit pos counts from. If loc is in memory, its mode must be a single-byte integer mode. If loc is in a register, the mode to use is specified by the operand of the insv or extv pattern (see section Standard Pattern Names For Generation) and is usually a full-word integer mode, which is the default if none is specified. The mode of pos is machine-specific and is also specified in the insv or extv pattern. The mode m is the same as the mode that would be used for loc if it were a register.
(zero_extract:m loc size pos)
Like sign_extract but refers to an unsigned or zero-extended bit field. The same sequence of bits are extracted, but they are filled to an entire word with zeros instead of by sign-extension.


Using and Porting GNU CC - Conversions

Conversions

All conversions between machine modes must be represented by explicit conversion operations. For example, an expression which is the sum of a byte and a full word cannot be written as (plus:SI (reg:QI 34) (reg:SI 80)) because the plus operation requires two operands of the same machine mode. Therefore, the byte-sized operand is enclosed in a conversion operation, as in

(plus:SI (sign_extend:SI (reg:QI 34)) (reg:SI 80))

The conversion operation is not a mere placeholder, because there may be more than one way of converting from a given starting mode to the desired final mode. The conversion operation code says how to do it.

For all conversion operations, x must not be VOIDmode because the mode in which to do the conversion would not be known. The conversion must either be done at compile-time or x must be placed into a register.

(sign_extend:m x)
Represents the result of sign-extending the value x to machine mode m. m must be a fixed-point mode and x a fixed-point value of a mode narrower than m.
(zero_extend:m x)
Represents the result of zero-extending the value x to machine mode m. m must be a fixed-point mode and x a fixed-point value of a mode narrower than m.
(float_extend:m x)
Represents the result of extending the value x to machine mode m. m must be a floating point mode and x a floating point value of a mode narrower than m.
(truncate:m x)
Represents the result of truncating the value x to machine mode m. m must be a fixed-point mode and x a fixed-point value of a mode wider than m.
(float_truncate:m x)
Represents the result of truncating the value x to machine mode m. m must be a floating point mode and x a floating point value of a mode wider than m.
(float:m x)
Represents the result of converting fixed point value x, regarded as signed, to floating point mode m.
(unsigned_float:m x)
Represents the result of converting fixed point value x, regarded as unsigned, to floating point mode m.
(fix:m x)
When m is a fixed point mode, represents the result of converting floating point value x to mode m, regarded as signed. How rounding is done is not specified, so this operation may be used validly in compiling C code only for integer-valued operands.
(unsigned_fix:m x)
Represents the result of converting floating point value x to fixed point mode m, regarded as unsigned. How rounding is done is not specified.
(fix:m x)
When m is a floating point mode, represents the result of converting floating point value x (valid for mode m) to an integer, still represented in floating point mode m, by rounding towards zero.


Using and Porting GNU CC - RTL Declarations

Declarations

Declaration expression codes do not represent arithmetic operations but rather state assertions about their operands.

(strict_low_part (subreg:m (reg:n r) 0))
This expression code is used in only one context: as the destination operand of a set expression. In addition, the operand of this expression must be a non-paradoxical subreg expression. The presence of strict_low_part says that the part of the register which is meaningful in mode n, but is not part of mode m, is not to be altered. Normally, an assignment to such a subreg is allowed to have undefined effects on the rest of the register when m is less than a word.


Using and Porting GNU CC - Side Effects

Side Effect Expressions

The expression codes described so far represent values, not actions. But machine instructions never produce values; they are meaningful only for their side effects on the state of the machine. Special expression codes are used to represent side effects.

The body of an instruction is always one of these side effect codes; the codes described above, which represent values, appear only as the operands of these.

(set lval x)
Represents the action of storing the value of x into the place represented by lval. lval must be an expression representing a place that can be stored in: reg (or subreg or strict_low_part), mem, pc or cc0. If lval is a reg, subreg or mem, it has a machine mode; then x must be valid for that mode. If lval is a reg whose machine mode is less than the full width of the register, then it means that the part of the register specified by the machine mode is given the specified value and the rest of the register receives an undefined value. Likewise, if lval is a subreg whose machine mode is narrower than the mode of the register, the rest of the register can be changed in an undefined way. If lval is a strict_low_part of a subreg, then the part of the register specified by the machine mode of the subreg is given the value x and the rest of the register is not changed. If lval is (cc0), it has no machine mode, and x may be either a compare expression or a value that may have any mode. The latter case represents a "test" instruction. The expression (set (cc0) (reg:m n)) is equivalent to (set (cc0) (compare (reg:m n) (const_int 0))). Use the former expression to save space during the compilation. If lval is (pc), we have a jump instruction, and the possibilities for x are very limited. It may be a label_ref expression (unconditional jump). It may be an if_then_else (conditional jump), in which case either the second or the third operand must be (pc) (for the case which does not jump) and the other of the two must be a label_ref (for the case which does jump). x may also be a mem or (plus:SI (pc) y), where y may be a reg or a mem; these unusual patterns are used to represent jumps through branch tables. If lval is neither (cc0) nor (pc), the mode of lval must not be VOIDmode and the mode of x must be valid for the mode of lval. lval is customarily accessed with the SET_DEST macro and x with the SET_SRC macro.
(return)
As the sole expression in a pattern, represents a return from the current function, on machines where this can be done with one instruction, such as Vaxes. On machines where a multi-instruction "epilogue" must be executed in order to return from the function, returning is done by jumping to a label which precedes the epilogue, and the return expression code is never used. Inside an if_then_else expression, represents the value to be placed in pc to return to the caller. Note that an insn pattern of (return) is logically equivalent to (set (pc) (return)), but the latter form is never used.
(call function nargs)
Represents a function call. function is a mem expression whose address is the address of the function to be called. nargs is an expression which can be used for two purposes: on some machines it represents the number of bytes of stack argument; on others, it represents the number of argument registers. Each machine has a standard machine mode which function must have. The machine description defines macro FUNCTION_MODE to expand into the requisite mode name. The purpose of this mode is to specify what kind of addressing is allowed, on machines where the allowed kinds of addressing depend on the machine mode being addressed.
(clobber x)
Represents the storing or possible storing of an unpredictable, undescribed value into x, which must be a reg, scratch or mem expression. One place this is used is in string instructions that store standard values into particular hard registers. It may not be worth the trouble to describe the values that are stored, but it is essential to inform the compiler that the registers will be altered, lest it attempt to keep data in them across the string instruction. If x is (mem:BLK (const_int 0)), it means that all memory locations must be presumed clobbered. Note that the machine description classifies certain hard registers as "call-clobbered". All function call instructions are assumed by default to clobber these registers, so there is no need to use clobber expressions to indicate this fact. Also, each function call is assumed to have the potential to alter any memory location, unless the function is declared const. If the last group of expressions in a parallel are each a clobber expression whose arguments are reg or match_scratch (see section RTL Template) expressions, the combiner phase can add the appropriate clobber expressions to an insn it has constructed when doing so will cause a pattern to be matched. This feature can be used, for example, on a machine that whose multiply and add instructions don't use an MQ register but which has an add-accumulate instruction that does clobber the MQ register. Similarly, a combined instruction might require a temporary register while the constituent instructions might not. When a clobber expression for a register appears inside a parallel with other side effects, the register allocator guarantees that the register is unoccupied both before and after that insn. However, the reload phase may allocate a register used for one of the inputs unless the `&' constraint is specified for the selected alternative (see section Constraint Modifier Characters). You can clobber either a specific hard register, a pseudo register, or a scratch expression; in the latter two cases, GNU CC will allocate a hard register that is available there for use as a temporary. For instructions that require a temporary register, you should use scratch instead of a pseudo-register because this will allow the combiner phase to add the clobber when required. You do this by coding (clobber (match_scratch ...)). If you do clobber a pseudo register, use one which appears nowhere else--generate a new one each time. Otherwise, you may confuse CSE. There is one other known use for clobbering a pseudo register in a parallel: when one of the input operands of the insn is also clobbered by the insn. In this case, using the same pseudo register in the clobber and elsewhere in the insn produces the expected results.
(use x)
Represents the use of the value of x. It indicates that the value in x at this point in the program is needed, even though it may not be apparent why this is so. Therefore, the compiler will not attempt to delete previous instructions whose only effect is to store a value in x. x must be a reg expression. During the delayed branch scheduling phase, x may be an insn. This indicates that x previously was located at this place in the code and its data dependencies need to be taken into account. These use insns will be deleted before the delayed branch scheduling phase exits.
(parallel [x0 x1 ...])
Represents several side effects performed in parallel. The square brackets stand for a vector; the operand of parallel is a vector of expressions. x0, x1 and so on are individual side effect expressions--expressions of code set, call, return, clobber or use. "In parallel" means that first all the values used in the individual side-effects are computed, and second all the actual side-effects are performed. For example,
(parallel [(set (reg:SI 1) (mem:SI (reg:SI 1)))
           (set (mem:SI (reg:SI 1)) (reg:SI 1))])
says unambiguously that the values of hard register 1 and the memory location addressed by it are interchanged. In both places where (reg:SI 1) appears as a memory address it refers to the value in register 1 before the execution of the insn. It follows that it is incorrect to use parallel and expect the result of one set to be available for the next one. For example, people sometimes attempt to represent a jump-if-zero instruction this way:
(parallel [(set (cc0) (reg:SI 34))
           (set (pc) (if_then_else
                        (eq (cc0) (const_int 0))
                        (label_ref ...)
                        (pc)))])
But this is incorrect, because it says that the jump condition depends on the condition code value before this instruction, not on the new value that is set by this instruction. Peephole optimization, which takes place together with final assembly code output, can produce insns whose patterns consist of a parallel whose elements are the operands needed to output the resulting assembler code--often reg, mem or constant expressions. This would not be well-formed RTL at any other stage in compilation, but it is ok then because no further optimization remains to be done. However, the definition of the macro NOTICE_UPDATE_CC, if any, must deal with such insns if you define any peephole optimizations.
(sequence [insns ...])
Represents a sequence of insns. Each of the insns that appears in the vector is suitable for appearing in the chain of insns, so it must be an insn, jump_insn, call_insn, code_label, barrier or note. A sequence RTX is never placed in an actual insn during RTL generation. It represents the sequence of insns that result from a define_expand before those insns are passed to emit_insn to insert them in the chain of insns. When actually inserted, the individual sub-insns are separated out and the sequence is forgotten. After delay-slot scheduling is completed, an insn and all the insns that reside in its delay slots are grouped together into a sequence. The insn requiring the delay slot is the first insn in the vector; subsequent insns are to be placed in the delay slot. INSN_ANNULLED_BRANCH_P is set on an insn in a delay slot to indicate that a branch insn should be used that will conditionally annul the effect of the insns in the delay slots. In such a case, INSN_FROM_TARGET_P indicates that the insn is from the target of the branch and should be executed only if the branch is taken; otherwise the insn should be executed only if the branch is not taken. See section Delay Slot Scheduling.

These expression codes appear in place of a side effect, as the body of an insn, though strictly speaking they do not always describe side effects as such:

(asm_input s)
Represents literal assembler code as described by the string s.
(unspec [operands ...] index)
(unspec_volatile [operands ...] index)
Represents a machine-specific operation on operands. index selects between multiple machine-specific operations. unspec_volatile is used for volatile operations and operations that may trap; unspec is used for other operations. These codes may appear inside a pattern of an insn, inside a parallel, or inside an expression.
(addr_vec:m [lr0 lr1 ...])
Represents a table of jump addresses. The vector elements lr0, etc., are label_ref expressions. The mode m specifies how much space is given to each address; normally m would be Pmode.
(addr_diff_vec:m base [lr0 lr1 ...])
Represents a table of jump addresses expressed as offsets from base. The vector elements lr0, etc., are label_ref expressions and so is base. The mode m specifies how much space is given to each address-difference.


Using and Porting GNU CC - Incdec

Embedded Side-Effects on Addresses

Four special side-effect expression codes appear as memory addresses.

(pre_dec:m x)
Represents the side effect of decrementing x by a standard amount and represents also the value that x has after being decremented. x must be a reg or mem, but most machines allow only a reg. m must be the machine mode for pointers on the machine in use. The amount x is decremented by is the length in bytes of the machine mode of the containing memory reference of which this expression serves as the address. Here is an example of its use:
(mem:DF (pre_dec:SI (reg:SI 39)))
This says to decrement pseudo register 39 by the length of a DFmode value and use the result to address a DFmode value.
(pre_inc:m x)
Similar, but specifies incrementing x instead of decrementing it.
(post_dec:m x)
Represents the same side effect as pre_dec but a different value. The value represented here is the value x has before being decremented.
(post_inc:m x)
Similar, but specifies incrementing x instead of decrementing it.

These embedded side effect expressions must be used with care. Instruction patterns may not use them. Until the `flow' pass of the compiler, they may occur only to represent pushes onto the stack. The `flow' pass finds cases where registers are incremented or decremented in one instruction and used as an address shortly before or after; these cases are then transformed to use pre- or post-increment or -decrement.

If a register used as the operand of these expressions is used in another address in an insn, the original value of the register is used. Uses of the register outside of an address are not permitted within the same insn as a use in an embedded side effect expression because such insns behave differently on different machines and hence must be treated as ambiguous and disallowed.

An instruction that can be represented with an embedded side effect could also be represented using parallel containing an additional set to describe how the address register is altered. This is not done because machines that allow these operations at all typically allow them wherever a memory address is called for. Describing them as additional parallel stores would require doubling the number of entries in the machine description.


Using and Porting GNU CC - Assembler

Assembler Instructions as Expressions

The RTX code asm_operands represents a value produced by a user-specified assembler instruction. It is used to represent an asm statement with arguments. An asm statement with a single output operand, like this:

asm ("foo %1,%2,%0" : "=a" (outputvar) : "g" (x + y), "di" (*z));

is represented using a single asm_operands RTX which represents the value that is stored in outputvar:

(set rtx-for-outputvar
     (asm_operands "foo %1,%2,%0" "a" 0
                   [rtx-for-addition-result rtx-for-*z]
                   [(asm_input:m1 "g")
                    (asm_input:m2 "di")]))

Here the operands of the asm_operands RTX are the assembler template string, the output-operand's constraint, the index-number of the output operand among the output operands specified, a vector of input operand RTX's, and a vector of input-operand modes and constraints. The mode m1 is the mode of the sum x+y; m2 is that of *z.

When an asm statement has multiple output values, its insn has several such set RTX's inside of a parallel. Each set contains a asm_operands; all of these share the same assembler template and vectors, but each contains the constraint for the respective output operand. They are also distinguished by the output-operand index number, which is 0, 1, ... for successive output operands.


Using and Porting GNU CC - Insns

Insns

The RTL representation of the code for a function is a doubly-linked chain of objects called insns. Insns are expressions with special codes that are used for no other purpose. Some insns are actual instructions; others represent dispatch tables for switch statements; others represent labels to jump to or various sorts of declarative information.

In addition to its own specific data, each insn must have a unique id-number that distinguishes it from all other insns in the current function (after delayed branch scheduling, copies of an insn with the same id-number may be present in multiple places in a function, but these copies will always be identical and will only appear inside a sequence), and chain pointers to the preceding and following insns. These three fields occupy the same position in every insn, independent of the expression code of the insn. They could be accessed with XEXP and XINT, but instead three special macros are always used:

INSN_UID (i)
Accesses the unique id of insn i.
PREV_INSN (i)
Accesses the chain pointer to the insn preceding i. If i is the first insn, this is a null pointer.
NEXT_INSN (i)
Accesses the chain pointer to the insn following i. If i is the last insn, this is a null pointer.

The first insn in the chain is obtained by calling get_insns; the last insn is the result of calling get_last_insn. Within the chain delimited by these insns, the NEXT_INSN and PREV_INSN pointers must always correspond: if insn is not the first insn,

NEXT_INSN (PREV_INSN (insn)) == insn

is always true and if insn is not the last insn,

PREV_INSN (NEXT_INSN (insn)) == insn

is always true.

After delay slot scheduling, some of the insns in the chain might be sequence expressions, which contain a vector of insns. The value of NEXT_INSN in all but the last of these insns is the next insn in the vector; the value of NEXT_INSN of the last insn in the vector is the same as the value of NEXT_INSN for the sequence in which it is contained. Similar rules apply for PREV_INSN.

This means that the above invariants are not necessarily true for insns inside sequence expressions. Specifically, if insn is the first insn in a sequence, NEXT_INSN (PREV_INSN (insn)) is the insn containing the sequence expression, as is the value of PREV_INSN (NEXT_INSN (insn)) is insn is the last insn in the sequence expression. You can use these expressions to find the containing sequence expression.

Every insn has one of the following six expression codes:

insn
The expression code insn is used for instructions that do not jump and do not do function calls. sequence expressions are always contained in insns with code insn even if one of those insns should jump or do function calls. Insns with code insn have four additional fields beyond the three mandatory ones listed above. These four are described in a table below.
jump_insn
The expression code jump_insn is used for instructions that may jump (or, more generally, may contain label_ref expressions). If there is an instruction to return from the current function, it is recorded as a jump_insn. jump_insn insns have the same extra fields as insn insns, accessed in the same way and in addition contain a field JUMP_LABEL which is defined once jump optimization has completed. For simple conditional and unconditional jumps, this field contains the code_label to which this insn will (possibly conditionally) branch. In a more complex jump, JUMP_LABEL records one of the labels that the insn refers to; the only way to find the others is to scan the entire body of the insn. Return insns count as jumps, but since they do not refer to any labels, they have zero in the JUMP_LABEL field.
call_insn
The expression code call_insn is used for instructions that may do function calls. It is important to distinguish these instructions because they imply that certain registers and memory locations may be altered unpredictably. call_insn insns have the same extra fields as insn insns, accessed in the same way and in addition contain a field CALL_INSN_FUNCTION_USAGE, which contains a list (chain of expr_list expressions) containing use and clobber expressions that denote hard registers used or clobbered by the called function. A register specified in a clobber in this list is modified after the execution of the call_insn, while a register in a clobber in the body of the call_insn is clobbered before the insn completes execution. clobber expressions in this list augment registers specified in CALL_USED_REGISTERS (see section Basic Characteristics of Registers).
code_label
A code_label insn represents a label that a jump insn can jump to. It contains two special fields of data in addition to the three standard ones. CODE_LABEL_NUMBER is used to hold the label number, a number that identifies this label uniquely among all the labels in the compilation (not just in the current function). Ultimately, the label is represented in the assembler output as an assembler label, usually of the form `Ln' where n is the label number. When a code_label appears in an RTL expression, it normally appears within a label_ref which represents the address of the label, as a number. The field LABEL_NUSES is only defined once the jump optimization phase is completed and contains the number of times this label is referenced in the current function.
barrier
Barriers are placed in the instruction stream when control cannot flow past them. They are placed after unconditional jump instructions to indicate that the jumps are unconditional and after calls to volatile functions, which do not return (e.g., exit). They contain no information beyond the three standard fields.
note
note insns are used to represent additional debugging and declarative information. They contain two nonstandard fields, an integer which is accessed with the macro NOTE_LINE_NUMBER and a string accessed with NOTE_SOURCE_FILE. If NOTE_LINE_NUMBER is positive, the note represents the position of a source line and NOTE_SOURCE_FILE is the source file name that the line came from. These notes control generation of line number data in the assembler output. Otherwise, NOTE_LINE_NUMBER is not really a line number but a code with one of the following values (and NOTE_SOURCE_FILE must contain a null pointer):
NOTE_INSN_DELETED
Such a note is completely ignorable. Some passes of the compiler delete insns by altering them into notes of this kind.
NOTE_INSN_BLOCK_BEG
NOTE_INSN_BLOCK_END
These types of notes indicate the position of the beginning and end of a level of scoping of variable names. They control the output of debugging information.
NOTE_INSN_EH_REGION_BEG
NOTE_INSN_EH_REGION_END
These types of notes indicate the position of the beginning and end of a level of scoping for exception handling. NOTE_BLOCK_NUMBER identifies which CODE_LABEL is associated with the given region.
NOTE_INSN_LOOP_BEG
NOTE_INSN_LOOP_END
These types of notes indicate the position of the beginning and end of a while or for loop. They enable the loop optimizer to find loops quickly.
NOTE_INSN_LOOP_CONT
Appears at the place in a loop that continue statements jump to.
NOTE_INSN_LOOP_VTOP
This note indicates the place in a loop where the exit test begins for those loops in which the exit test has been duplicated. This position becomes another virtual start of the loop when considering loop invariants.
NOTE_INSN_FUNCTION_END
Appears near the end of the function body, just before the label that return statements jump to (on machine where a single instruction does not suffice for returning). This note may be deleted by jump optimization.
NOTE_INSN_SETJMP
Appears following each call to setjmp or a related function.
These codes are printed symbolically when they appear in debugging dumps.

The machine mode of an insn is normally VOIDmode, but some phases use the mode for various purposes; for example, the reload pass sets it to HImode if the insn needs reloading but not register elimination and QImode if both are required. The common subexpression elimination pass sets the mode of an insn to QImode when it is the first insn in a block that has already been processed.

Here is a table of the extra fields of insn, jump_insn and call_insn insns:

PATTERN (i)
An expression for the side effect performed by this insn. This must be one of the following codes: set, call, use, clobber, return, asm_input, asm_output, addr_vec, addr_diff_vec, trap_if, unspec, unspec_volatile, parallel, or sequence. If it is a parallel, each element of the parallel must be one these codes, except that parallel expressions cannot be nested and addr_vec and addr_diff_vec are not permitted inside a parallel expression.
INSN_CODE (i)
An integer that says which pattern in the machine description matches this insn, or -1 if the matching has not yet been attempted. Such matching is never attempted and this field remains -1 on an insn whose pattern consists of a single use, clobber, asm_input, addr_vec or addr_diff_vec expression. Matching is also never attempted on insns that result from an asm statement. These contain at least one asm_operands expression. The function asm_noperands returns a non-negative value for such insns. In the debugging output, this field is printed as a number followed by a symbolic representation that locates the pattern in the `md' file as some small positive or negative offset from a named pattern.
LOG_LINKS (i)
A list (chain of insn_list expressions) giving information about dependencies between instructions within a basic block. Neither a jump nor a label may come between the related insns.
REG_NOTES (i)
A list (chain of expr_list and insn_list expressions) giving miscellaneous information about the insn. It is often information pertaining to the registers used in this insn.

The LOG_LINKS field of an insn is a chain of insn_list expressions. Each of these has two operands: the first is an insn, and the second is another insn_list expression (the next one in the chain). The last insn_list in the chain has a null pointer as second operand. The significant thing about the chain is which insns appear in it (as first operands of insn_list expressions). Their order is not significant.

This list is originally set up by the flow analysis pass; it is a null pointer until then. Flow only adds links for those data dependencies which can be used for instruction combination. For each insn, the flow analysis pass adds a link to insns which store into registers values that are used for the first time in this insn. The instruction scheduling pass adds extra links so that every dependence will be represented. Links represent data dependencies, antidependencies and output dependencies; the machine mode of the link distinguishes these three types: antidependencies have mode REG_DEP_ANTI, output dependencies have mode REG_DEP_OUTPUT, and data dependencies have mode VOIDmode.

The REG_NOTES field of an insn is a chain similar to the LOG_LINKS field but it includes expr_list expressions in addition to insn_list expressions. There are several kinds of register notes, which are distinguished by the machine mode, which in a register note is really understood as being an enum reg_note. The first operand op of the note is data whose meaning depends on the kind of note.

The macro REG_NOTE_KIND (x) returns the kind of register note. Its counterpart, the macro PUT_REG_NOTE_KIND (x, newkind) sets the register note type of x to be newkind.

Register notes are of three classes: They may say something about an input to an insn, they may say something about an output of an insn, or they may create a linkage between two insns. There are also a set of values that are only used in LOG_LINKS.

These register notes annotate inputs to an insn:

REG_DEAD
The value in op dies in this insn; that is to say, altering the value immediately after this insn would not affect the future behavior of the program. This does not necessarily mean that the register op has no useful value after this insn since it may also be an output of the insn. In such a case, however, a REG_DEAD note would be redundant and is usually not present until after the reload pass, but no code relies on this fact.
REG_INC
The register op is incremented (or decremented; at this level there is no distinction) by an embedded side effect inside this insn. This means it appears in a post_inc, pre_inc, post_dec or pre_dec expression.
REG_NONNEG
The register op is known to have a nonnegative value when this insn is reached. This is used so that decrement and branch until zero instructions, such as the m68k dbra, can be matched. The REG_NONNEG note is added to insns only if the machine description has a `decrement_and_branch_until_zero' pattern.
REG_NO_CONFLICT
This insn does not cause a conflict between op and the item being set by this insn even though it might appear that it does. In other words, if the destination register and op could otherwise be assigned the same register, this insn does not prevent that assignment. Insns with this note are usually part of a block that begins with a clobber insn specifying a multi-word pseudo register (which will be the output of the block), a group of insns that each set one word of the value and have the REG_NO_CONFLICT note attached, and a final insn that copies the output to itself with an attached REG_EQUAL note giving the expression being computed. This block is encapsulated with REG_LIBCALL and REG_RETVAL notes on the first and last insns, respectively.
REG_LABEL
This insn uses op, a code_label, but is not a jump_insn. The presence of this note allows jump optimization to be aware that op is, in fact, being used.

The following notes describe attributes of outputs of an insn:

REG_EQUIV
REG_EQUAL
This note is only valid on an insn that sets only one register and indicates that that register will be equal to op at run time; the scope of this equivalence differs between the two types of notes. The value which the insn explicitly copies into the register may look different from op, but they will be equal at run time. If the output of the single set is a strict_low_part expression, the note refers to the register that is contained in SUBREG_REG of the subreg expression. For REG_EQUIV, the register is equivalent to op throughout the entire function, and could validly be replaced in all its occurrences by op. ("Validly" here refers to the data flow of the program; simple replacement may make some insns invalid.) For example, when a constant is loaded into a register that is never assigned any other value, this kind of note is used. When a parameter is copied into a pseudo-register at entry to a function, a note of this kind records that the register is equivalent to the stack slot where the parameter was passed. Although in this case the register may be set by other insns, it is still valid to replace the register by the stack slot throughout the function. A REG_EQUIV note is also used on an instruction which copies a register parameter into a pseudo-register at entry to a function, if there is a stack slot where that parameter could be stored. Although other insns may set the pseudo-register, it is valid for the compiler to replace the pseudo-register by stack slot throughout the function, provided the compiler ensures that the stack slot is properly initialized by making the replacement in the initial copy instruction as well. This is used on machines for which the calling convention allocates stack space for register parameters. See REG_PARM_STACK_SPACE in section Passing Function Arguments on the Stack. In the case of REG_EQUAL, the register that is set by this insn will be equal to op at run time at the end of this insn but not necessarily elsewhere in the function. In this case, op is typically an arithmetic expression. For example, when a sequence of insns such as a library call is used to perform an arithmetic operation, this kind of note is attached to the insn that produces or copies the final value. These two notes are used in different ways by the compiler passes. REG_EQUAL is used by passes prior to register allocation (such as common subexpression elimination and loop optimization) to tell them how to think of that value. REG_EQUIV notes are used by register allocation to indicate that there is an available substitute expression (either a constant or a mem expression for the location of a parameter on the stack) that may be used in place of a register if insufficient registers are available. Except for stack homes for parameters, which are indicated by a REG_EQUIV note and are not useful to the early optimization passes and pseudo registers that are equivalent to a memory location throughout there entire life, which is not detected until later in the compilation, all equivalences are initially indicated by an attached REG_EQUAL note. In the early stages of register allocation, a REG_EQUAL note is changed into a REG_EQUIV note if op is a constant and the insn represents the only set of its destination register. Thus, compiler passes prior to register allocation need only check for REG_EQUAL notes and passes subsequent to register allocation need only check for REG_EQUIV notes.
REG_UNUSED
The register op being set by this insn will not be used in a subsequent insn. This differs from a REG_DEAD note, which indicates that the value in an input will not be used subsequently. These two notes are independent; both may be present for the same register.
REG_WAS_0
The single output of this insn contained zero before this insn. op is the insn that set it to zero. You can rely on this note if it is present and op has not been deleted or turned into a note; its absence implies nothing.

These notes describe linkages between insns. They occur in pairs: one insn has one of a pair of notes that points to a second insn, which has the inverse note pointing back to the first insn.

REG_RETVAL
This insn copies the value of a multi-insn sequence (for example, a library call), and op is the first insn of the sequence (for a library call, the first insn that was generated to set up the arguments for the library call). Loop optimization uses this note to treat such a sequence as a single operation for code motion purposes and flow analysis uses this note to delete such sequences whose results are dead. A REG_EQUAL note will also usually be attached to this insn to provide the expression being computed by the sequence.
REG_LIBCALL
This is the inverse of REG_RETVAL: it is placed on the first insn of a multi-insn sequence, and it points to the last one.
REG_CC_SETTER
REG_CC_USER
On machines that use cc0, the insns which set and use cc0 set and use cc0 are adjacent. However, when branch delay slot filling is done, this may no longer be true. In this case a REG_CC_USER note will be placed on the insn setting cc0 to point to the insn using cc0 and a REG_CC_SETTER note will be placed on the insn using cc0 to point to the insn setting cc0.

These values are only used in the LOG_LINKS field, and indicate the type of dependency that each link represents. Links which indicate a data dependence (a read after write dependence) do not use any code, they simply have mode VOIDmode, and are printed without any descriptive text.

REG_DEP_ANTI
This indicates an anti dependence (a write after read dependence).
REG_DEP_OUTPUT
This indicates an output dependence (a write after write dependence).

These notes describe information gathered from gcov profile data. They are stored in the REG_NOTES field of an insn as an expr_list.

REG_EXEC_COUNT
This is used to indicate the number of times a basic block was executed according to the profile data. The note is attached to the first insn in the basic block.
REG_BR_PROB
This is used to specify the ratio of branches to non-branches of a branch insn according to the profile data. The value is stored as a value between 0 and REG_BR_PROB_BASE; larger values indicate a higher probability that the branch will be taken.
REG_BR_PRED
These notes are found in JUMP insns after delayed branch scheduling has taken place. They indicate both the direction and the likelyhood of the JUMP. The format is a bitmask of ATTR_FLAG_* values.

For convenience, the machine mode in an insn_list or expr_list is printed using these symbolic codes in debugging dumps.

The only difference between the expression codes insn_list and expr_list is that the first operand of an insn_list is assumed to be an insn and is printed in debugging dumps as the insn's unique id; the first operand of an expr_list is printed in the ordinary way as an expression.


Using and Porting GNU CC - Calls

RTL Representation of Function-Call Insns

Insns that call subroutines have the RTL expression code call_insn. These insns must satisfy special rules, and their bodies must use a special RTL expression code, call.

A call expression has two operands, as follows:

(call (mem:fm addr) nbytes)

Here nbytes is an operand that represents the number of bytes of argument data being passed to the subroutine, fm is a machine mode (which must equal as the definition of the FUNCTION_MODE macro in the machine description) and addr represents the address of the subroutine.

For a subroutine that returns no value, the call expression as shown above is the entire body of the insn, except that the insn might also contain use or clobber expressions.

For a subroutine that returns a value whose mode is not BLKmode, the value is returned in a hard register. If this register's number is r, then the body of the call insn looks like this:

(set (reg:m r)
     (call (mem:fm addr) nbytes))

This RTL expression makes it clear (to the optimizer passes) that the appropriate register receives a useful value in this insn.

When a subroutine returns a BLKmode value, it is handled by passing to the subroutine the address of a place to store the value. So the call insn itself does not "return" any value, and it has the same RTL form as a call that returns nothing.

On some machines, the call instruction itself clobbers some register, for example to contain the return address. call_insn insns on these machines should have a body which is a parallel that contains both the call expression and clobber expressions that indicate which registers are destroyed. Similarly, if the call instruction requires some register other than the stack pointer that is not explicitly mentioned it its RTL, a use subexpression should mention that register.

Functions that are called are assumed to modify all registers listed in the configuration macro CALL_USED_REGISTERS (see section Basic Characteristics of Registers) and, with the exception of const functions and library calls, to modify all of memory.

Insns containing just use expressions directly precede the call_insn insn to indicate which registers contain inputs to the function. Similarly, if registers other than those in CALL_USED_REGISTERS are clobbered by the called function, insns containing a single clobber follow immediately after the call to indicate which registers.


Using and Porting GNU CC - Sharing

Structure Sharing Assumptions

The compiler assumes that certain kinds of RTL expressions are unique; there do not exist two distinct objects representing the same value. In other cases, it makes an opposite assumption: that no RTL expression object of a certain kind appears in more than one place in the containing structure.

These assumptions refer to a single function; except for the RTL objects that describe global variables and external functions, and a few standard objects such as small integer constants, no RTL objects are common to two functions.

  • Each pseudo-register has only a single reg object to represent it, and therefore only a single machine mode.
  • For any symbolic label, there is only one symbol_ref object referring to it.
  • There is only one const_int expression with value 0, only one with value 1, and only one with value -1. Some other integer values are also stored uniquely.
  • There is only one pc expression.
  • There is only one cc0 expression.
  • There is only one const_double expression with value 0 for each floating point mode. Likewise for values 1 and 2.
  • No label_ref or scratch appears in more than one place in the RTL structure; in other words, it is safe to do a tree-walk of all the insns in the function and assume that each time a label_ref or scratch is seen it is distinct from all others that are seen.
  • Only one mem object is normally created for each static variable or stack slot, so these objects are frequently shared in all the places they appear. However, separate but equal objects for these variables are occasionally made.
  • When a single asm statement has multiple output operands, a distinct asm_operands expression is made for each output operand. However, these all share the vector which contains the sequence of input operands. This sharing is used later on to test whether two asm_operands expressions come from the same statement, so all optimizations must carefully preserve the sharing if they copy the vector at all.
  • No RTL object appears in more than one place in the RTL structure except as described above. Many passes of the compiler rely on this by assuming that they can modify RTL objects in place without unwanted side-effects on other insns.
  • During initial RTL generation, shared structure is freely introduced. After all the RTL for a function has been generated, all shared structure is copied by unshare_all_rtl in `emit-rtl.c', after which the above rules are guaranteed to be followed.
  • During the combiner pass, shared structure within an insn can exist temporarily. However, the shared structure is copied before the combiner is finished with the insn. This is done by calling copy_rtx_if_shared, which is a subroutine of unshare_all_rtl.


Using and Porting GNU CC - Reading RTL

Reading RTL

To read an RTL object from a file, call read_rtx. It takes one argument, a stdio stream, and returns a single RTL object.

Reading RTL from a file is very slow. This is not currently a problem since reading RTL occurs only as part of building the compiler.

People frequently have the idea of using RTL stored as text in a file as an interface between a language front end and the bulk of GNU CC. This idea is not feasible.

GNU CC was designed to use RTL internally only. Correct RTL for a given program is very dependent on the particular target machine. And the RTL does not contain all the information about the program.

The proper way to interface GNU CC to a new language front end is with the "tree" data structure. There is no manual for this data structure, but it is described in the files `tree.h' and `tree.def'.


Using and Porting GNU CC - Machine Desc

Machine Descriptions

A machine description has two parts: a file of instruction patterns (`.md' file) and a C header file of macro definitions.

The `.md' file for a target machine contains a pattern for each instruction that the target machine supports (or at least each instruction that is worth telling the compiler about). It may also contain comments. A semicolon causes the rest of the line to be a comment, unless the semicolon is inside a quoted string.

See the next chapter for information on the C header file.


Using and Porting GNU CC - Patterns

Everything about Instruction Patterns

Each instruction pattern contains an incomplete RTL expression, with pieces to be filled in later, operand constraints that restrict how the pieces can be filled in, and an output pattern or C code to generate the assembler output, all wrapped up in a define_insn expression.

A define_insn is an RTL expression containing four or five operands:

  1. An optional name. The presence of a name indicate that this instruction pattern can perform a certain standard job for the RTL-generation pass of the compiler. This pass knows certain names and will use the instruction patterns with those names, if the names are defined in the machine description. The absence of a name is indicated by writing an empty string where the name should go. Nameless instruction patterns are never used for generating RTL code, but they may permit several simpler insns to be combined later on. Names that are not thus known and used in RTL-generation have no effect; they are equivalent to no name at all.
  2. The RTL template (see section RTL Template) is a vector of incomplete RTL expressions which show what the instruction should look like. It is incomplete because it may contain match_operand, match_operator, and match_dup expressions that stand for operands of the instruction. If the vector has only one element, that element is the template for the instruction pattern. If the vector has multiple elements, then the instruction pattern is a parallel expression containing the elements described.
  3. A condition. This is a string which contains a C expression that is the final test to decide whether an insn body matches this pattern. For a named pattern, the condition (if present) may not depend on the data in the insn being matched, but only the target-machine-type flags. The compiler needs to test these conditions during initialization in order to learn exactly which named instructions are available in a particular run. For nameless patterns, the condition is applied only when matching an individual insn, and only after the insn has matched the pattern's recognition template. The insn's operands may be found in the vector operands.
  4. The output template: a string that says how to output matching insns as assembler code. `%' in this string specifies where to substitute the value of an operand. See section Output Templates and Operand Substitution. When simple substitution isn't general enough, you can specify a piece of C code to compute the output. See section C Statements for Assembler Output.
  5. Optionally, a vector containing the values of attributes for insns matching this pattern. See section Instruction Attributes.


Using and Porting GNU CC - Example

Example of define_insn

Here is an actual example of an instruction pattern, for the 68000/68020.

(define_insn "tstsi"
  [(set (cc0)
        (match_operand:SI 0 "general_operand" "rm"))]
  ""
  "*
{ if (TARGET_68020 || ! ADDRESS_REG_P (operands[0]))
    return \"tstl %0\";
  return \"cmpl #0,%0\"; }")

This is an instruction that sets the condition codes based on the value of a general operand. It has no condition, so any insn whose RTL description has the form shown may be handled according to this pattern. The name `tstsi' means "test a SImode value" and tells the RTL generation pass that, when it is necessary to test such a value, an insn to do so can be constructed using this pattern.

The output control string is a piece of C code which chooses which output template to return based on the kind of operand and the specific type of CPU for which code is being generated.

`"rm"' is an operand constraint. Its meaning is explained below.


Using and Porting GNU CC - RTL Template

RTL Template

The RTL template is used to define which insns match the particular pattern and how to find their operands. For named patterns, the RTL template also says how to construct an insn from specified operands.

Construction involves substituting specified operands into a copy of the template. Matching involves determining the values that serve as the operands in the insn being matched. Both of these activities are controlled by special expression types that direct matching and substitution of the operands.

(match_operand:m n predicate constraint)
This expression is a placeholder for operand number n of the insn. When constructing an insn, operand number n will be substituted at this point. When matching an insn, whatever appears at this position in the insn will be taken as operand number n; but it must satisfy predicate or this instruction pattern will not match at all. Operand numbers must be chosen consecutively counting from zero in each instruction pattern. There may be only one match_operand expression in the pattern for each operand number. Usually operands are numbered in the order of appearance in match_operand expressions. predicate is a string that is the name of a C function that accepts two arguments, an expression and a machine mode. During matching, the function will be called with the putative operand as the expression and m as the mode argument (if m is not specified, VOIDmode will be used, which normally causes predicate to accept any mode). If it returns zero, this instruction pattern fails to match. predicate may be an empty string; then it means no test is to be done on the operand, so anything which occurs in this position is valid. Most of the time, predicate will reject modes other than m---but not always. For example, the predicate address_operand uses m as the mode of memory ref that the address should be valid for. Many predicates accept const_int nodes even though their mode is VOIDmode. constraint controls reloading and the choice of the best register class to use for a value, as explained later (see section Operand Constraints). People are often unclear on the difference between the constraint and the predicate. The predicate helps decide whether a given insn matches the pattern. The constraint plays no role in this decision; instead, it controls various decisions in the case of an insn which does match. On CISC machines, the most common predicate is "general_operand". This function checks that the putative operand is either a constant, a register or a memory reference, and that it is valid for mode m. For an operand that must be a register, predicate should be "register_operand". Using "general_operand" would be valid, since the reload pass would copy any non-register operands through registers, but this would make GNU CC do extra work, it would prevent invariant operands (such as constant) from being removed from loops, and it would prevent the register allocator from doing the best possible job. On RISC machines, it is usually most efficient to allow predicate to accept only objects that the constraints allow. For an operand that must be a constant, you must be sure to either use "immediate_operand" for predicate, or make the instruction pattern's extra condition require a constant, or both. You cannot expect the constraints to do this work! If the constraints allow only constants, but the predicate allows something else, the compiler will crash when that case arises.
(match_scratch:m n constraint)
This expression is also a placeholder for operand number n and indicates that operand must be a scratch or reg expression. When matching patterns, this is equivalent to
(match_operand:m n "scratch_operand" pred)
but, when generating RTL, it produces a (scratch:m) expression. If the last few expressions in a parallel are clobber expressions whose operands are either a hard register or match_scratch, the combiner can add or delete them when necessary. See section Side Effect Expressions.
(match_dup n)
This expression is also a placeholder for operand number n. It is used when the operand needs to appear more than once in the insn. In construction, match_dup acts just like match_operand: the operand is substituted into the insn being constructed. But in matching, match_dup behaves differently. It assumes that operand number n has already been determined by a match_operand appearing earlier in the recognition template, and it matches only an identical-looking expression.
(match_operator:m n predicate [operands...])
This pattern is a kind of placeholder for a variable RTL expression code. When constructing an insn, it stands for an RTL expression whose expression code is taken from that of operand n, and whose operands are constructed from the patterns operands. When matching an expression, it matches an expression if the function predicate returns nonzero on that expression and the patterns operands match the operands of the expression. Suppose that the function commutative_operator is defined as follows, to match any expression whose operator is one of the commutative arithmetic operators of RTL and whose mode is mode:
int
commutative_operator (x, mode)
     rtx x;
     enum machine_mode mode;
{
  enum rtx_code code = GET_CODE (x);
  if (GET_MODE (x) != mode)
    return 0;
  return (GET_RTX_CLASS (code) == 'c'
          || code == EQ || code == NE);
}
Then the following pattern will match any RTL expression consisting of a commutative operator applied to two general operands:
(match_operator:SI 3 "commutative_operator"
  [(match_operand:SI 1 "general_operand" "g")
   (match_operand:SI 2 "general_operand" "g")])
Here the vector [operands...] contains two patterns because the expressions to be matched all contain two operands. When this pattern does match, the two operands of the commutative operator are recorded as operands 1 and 2 of the insn. (This is done by the two instances of match_operand.) Operand 3 of the insn will be the entire commutative expression: use GET_CODE (operands[3]) to see which commutative operator was used. The machine mode m of match_operator works like that of match_operand: it is passed as the second argument to the predicate function, and that function is solely responsible for deciding whether the expression to be matched "has" that mode. When constructing an insn, argument 3 of the gen-function will specify the operation (i.e. the expression code) for the expression to be made. It should be an RTL expression, whose expression code is copied into a new expression whose operands are arguments 1 and 2 of the gen-function. The subexpressions of argument 3 are not used; only its expression code matters. When match_operator is used in a pattern for matching an insn, it usually best if the operand number of the match_operator is higher than that of the actual operands of the insn. This improves register allocation because the register allocator often looks at operands 1 and 2 of insns to see if it can do register tying. There is no way to specify constraints in match_operator. The operand of the insn which corresponds to the match_operator never has any constraints because it is never reloaded as a whole. However, if parts of its operands are matched by match_operand patterns, those parts may have constraints of their own.
(match_op_dup:m n[operands...])
Like match_dup, except that it applies to operators instead of operands. When constructing an insn, operand number n will be substituted at this point. But in matching, match_op_dup behaves differently. It assumes that operand number n has already been determined by a match_operator appearing earlier in the recognition template, and it matches only an identical-looking expression.
(match_parallel n predicate [subpat...])
This pattern is a placeholder for an insn that consists of a parallel expression with a variable number of elements. This expression should only appear at the top level of an insn pattern. When constructing an insn, operand number n will be substituted at this point. When matching an insn, it matches if the body of the insn is a parallel expression with at least as many elements as the vector of subpat expressions in the match_parallel, if each subpat matches the corresponding element of the parallel, and the function predicate returns nonzero on the parallel that is the body of the insn. It is the responsibility of the predicate to validate elements of the parallel beyond those listed in the match_parallel. A typical use of match_parallel is to match load and store multiple expressions, which can contain a variable number of elements in a parallel. For example,
(define_insn ""
  [(match_parallel 0 "load_multiple_operation"
     [(set (match_operand:SI 1 "gpc_reg_operand" "=r")
           (match_operand:SI 2 "memory_operand" "m"))
      (use (reg:SI 179))
      (clobber (reg:SI 179))])]
  ""
  "loadm 0,0,%1,%2")
This example comes from `a29k.md'. The function load_multiple_operations is defined in `a29k.c' and checks that subsequent elements in the parallel are the same as the set in the pattern, except that they are referencing subsequent registers and memory locations. An insn that matches this pattern might look like:
(parallel
 [(set (reg:SI 20) (mem:SI (reg:SI 100)))
  (use (reg:SI 179))
  (clobber (reg:SI 179))
  (set (reg:SI 21)
       (mem:SI (plus:SI (reg:SI 100)
                        (const_int 4))))
  (set (reg:SI 22)
       (mem:SI (plus:SI (reg:SI 100)
                        (const_int 8))))])
(match_par_dup n [subpat...])
Like match_op_dup, but for match_parallel instead of match_operator.
(address (match_operand:m n "address_operand" ""))
This complex of expressions is a placeholder for an operand number n in a "load address" instruction: an operand which specifies a memory location in the usual way, but for which the actual operand value used is the address of the location, not the contents of the location. address expressions never appear in RTL code, only in machine descriptions. And they are used only in machine descriptions that do not use the operand constraint feature. When operand constraints are in use, the letter `p' in the constraint serves this purpose. m is the machine mode of the memory location being addressed, not the machine mode of the address itself. That mode is always the same on a given target machine (it is Pmode, which normally is SImode), so there is no point in mentioning it; thus, no machine mode is written in the address expression. If some day support is added for machines in which addresses of different kinds of objects appear differently or are used differently (such as the PDP-10), different formats would perhaps need different machine modes and these modes might be written in the address expression.


Using and Porting GNU CC - Output Template

Output Templates and Operand Substitution

The output template is a string which specifies how to output the assembler code for an instruction pattern. Most of the template is a fixed string which is output literally. The character `%' is used to specify where to substitute an operand; it can also be used to identify places where different variants of the assembler require different syntax.

In the simplest case, a `%' followed by a digit n says to output operand n at that point in the string.

`%' followed by a letter and a digit says to output an operand in an alternate fashion. Four letters have standard, built-in meanings described below. The machine description macro PRINT_OPERAND can define additional letters with nonstandard meanings.

`%cdigit' can be used to substitute an operand that is a constant value without the syntax that normally indicates an immediate operand.

`%ndigit' is like `%cdigit' except that the value of the constant is negated before printing.

`%adigit' can be used to substitute an operand as if it were a memory reference, with the actual operand treated as the address. This may be useful when outputting a "load address" instruction, because often the assembler syntax for such an instruction requires you to write the operand as if it were a memory reference.

`%ldigit' is used to substitute a label_ref into a jump instruction.

`%=' outputs a number which is unique to each instruction in the entire compilation. This is useful for making local labels to be referred to more than once in a single template that generates multiple assembler instructions.

`%' followed by a punctuation character specifies a substitution that does not use an operand. Only one case is standard: `%%' outputs a `%' into the assembler code. Other nonstandard cases can be defined in the PRINT_OPERAND macro. You must also define which punctuation characters are valid with the PRINT_OPERAND_PUNCT_VALID_P macro.

The template may generate multiple assembler instructions. Write the text for the instructions, with `\;' between them.

When the RTL contains two operands which are required by constraint to match each other, the output template must refer only to the lower-numbered operand. Matching operands are not always identical, and the rest of the compiler arranges to put the proper RTL expression for printing into the lower-numbered operand.

One use of nonstandard letters or punctuation following `%' is to distinguish between different assembler languages for the same machine; for example, Motorola syntax versus MIT syntax for the 68000. Motorola syntax requires periods in most opcode names, while MIT syntax does not. For example, the opcode `movel' in MIT syntax is `move.l' in Motorola syntax. The same file of patterns is used for both kinds of output syntax, but the character sequence `%.' is used in each place where Motorola syntax wants a period. The PRINT_OPERAND macro for Motorola syntax defines the sequence to output a period; the macro for MIT syntax defines it to do nothing.

As a special case, a template consisting of the single character # instructs the compiler to first split the insn, and then output the resulting instructions separately. This helps eliminate redundancy in the output templates. If you have a define_insn that needs to emit multiple assembler instructions, and there is an matching define_split already defined, then you can simply use # as the output template instead of writing an output template that emits the multiple assembler instructions.

If the macro ASSEMBLER_DIALECT is defined, you can use construct of the form `{option0|option1|option2}' in the templates. These describe multiple variants of assembler language syntax. See section Output of Assembler Instructions.


Using and Porting GNU CC - Output Statement

C Statements for Assembler Output

Often a single fixed template string cannot produce correct and efficient assembler code for all the cases that are recognized by a single instruction pattern. For example, the opcodes may depend on the kinds of operands; or some unfortunate combinations of operands may require extra machine instructions.

If the output control string starts with a `@', then it is actually a series of templates, each on a separate line. (Blank lines and leading spaces and tabs are ignored.) The templates correspond to the pattern's constraint alternatives (see section Multiple Alternative Constraints). For example, if a target machine has a two-address add instruction `addr' to add into a register and another `addm' to add a register to memory, you might write this pattern:

(define_insn "addsi3"
  [(set (match_operand:SI 0 "general_operand" "=r,m")
        (plus:SI (match_operand:SI 1 "general_operand" "0,0")
                 (match_operand:SI 2 "general_operand" "g,r")))]
  ""
  "@
   addr %2,%0
   addm %2,%0")

If the output control string starts with a `*', then it is not an output template but rather a piece of C program that should compute a template. It should execute a return statement to return the template-string you want. Most such templates use C string literals, which require doublequote characters to delimit them. To include these doublequote characters in the string, prefix each one with `\'.

The operands may be found in the array operands, whose C data type is rtx [].

It is very common to select different ways of generating assembler code based on whether an immediate operand is within a certain range. Be careful when doing this, because the result of INTVAL is an integer on the host machine. If the host machine has more bits in an int than the target machine has in the mode in which the constant will be used, then some of the bits you get from INTVAL will be superfluous. For proper results, you must carefully disregard the values of those bits.

It is possible to output an assembler instruction and then go on to output or compute more of them, using the subroutine output_asm_insn. This receives two arguments: a template-string and a vector of operands. The vector may be operands, or it may be another array of rtx that you declare locally and initialize yourself.

When an insn pattern has multiple alternatives in its constraints, often the appearance of the assembler code is determined mostly by which alternative was matched. When this is so, the C code can test the variable which_alternative, which is the ordinal number of the alternative that was actually satisfied (0 for the first, 1 for the second alternative, etc.).

For example, suppose there are two opcodes for storing zero, `clrreg' for registers and `clrmem' for memory locations. Here is how a pattern could use which_alternative to choose between them:

(define_insn ""
  [(set (match_operand:SI 0 "general_operand" "=r,m")
        (const_int 0))]
  ""
  "*
  return (which_alternative == 0
          ? \"clrreg %0\" : \"clrmem %0\");
  ")

The example above, where the assembler code to generate was solely determined by the alternative, could also have been specified as follows, having the output control string start with a `@':

(define_insn ""
  [(set (match_operand:SI 0 "general_operand" "=r,m")
        (const_int 0))]
  ""
  "@
   clrreg %0
   clrmem %0")


Using and Porting GNU CC - Constraints

Operand Constraints

Each match_operand in an instruction pattern can specify a constraint for the type of operands allowed. Constraints can say whether an operand may be in a register, and which kinds of register; whether the operand can be a memory reference, and which kinds of address; whether the operand may be an immediate constant, and which possible values it may have. Constraints can also require two operands to match.


Using and Porting GNU CC - Simple Constraints

Simple Constraints

The simplest kind of constraint is a string full of letters, each of which describes one kind of operand that is permitted. Here are the letters that are allowed:

`m'
A memory operand is allowed, with any kind of address that the machine supports in general.
`o'
A memory operand is allowed, but only if the address is offsettable. This means that adding a small integer (actually, the width in bytes of the operand, as determined by its machine mode) may be added to the address and the result is also a valid memory address. For example, an address which is constant is offsettable; so is an address that is the sum of a register and a constant (as long as a slightly larger constant is also within the range of address-offsets supported by the machine); but an autoincrement or autodecrement address is not offsettable. More complicated indirect/indexed addresses may or may not be offsettable depending on the other addressing modes that the machine supports. Note that in an output operand which can be matched by another operand, the constraint letter `o' is valid only when accompanied by both `<' (if the target machine has predecrement addressing) and `>' (if the target machine has preincrement addressing).
`V'
A memory operand that is not offsettable. In other words, anything that would fit the `m' constraint but not the `o' constraint.
`<'
A memory operand with autodecrement addressing (either predecrement or postdecrement) is allowed.
`>'
A memory operand with autoincrement addressing (either preincrement or postincrement) is allowed.
`r'
A register operand is allowed provided that it is in a general register.
`d', `a', `f', ...
Other letters can be defined in machine-dependent fashion to stand for particular classes of registers. `d', `a' and `f' are defined on the 68000/68020 to stand for data, address and floating point registers.
`i'
An immediate integer operand (one with constant value) is allowed. This includes symbolic constants whose values will be known only at assembly time.
`n'
An immediate integer operand with a known numeric value is allowed. Many systems cannot support assembly-time constants for operands less than a word wide. Constraints for these operands should use `n' rather than `i'.
`I', `J', `K', ... `P'
Other letters in the range `I' through `P' may be defined in a machine-dependent fashion to permit immediate integer operands with explicit integer values in specified ranges. For example, on the 68000, `I' is defined to stand for the range of values 1 to 8. This is the range permitted as a shift count in the shift instructions.
`E'
An immediate floating operand (expression code const_double) is allowed, but only if the target floating point format is the same as that of the host machine (on which the compiler is running).
`F'
An immediate floating operand (expression code const_double) is allowed.
`G', `H'
`G' and `H' may be defined in a machine-dependent fashion to permit immediate floating operands in particular ranges of values.
`s'
An immediate integer operand whose value is not an explicit integer is allowed. This might appear strange; if an insn allows a constant operand with a value not known at compile time, it certainly must allow any known value. So why use `s' instead of `i'? Sometimes it allows better code to be generated. For example, on the 68000 in a fullword instruction it is possible to use an immediate operand; but if the immediate value is between -128 and 127, better code results from loading the value into a register and using the register. This is because the load into the register can be done with a `moveq' instruction. We arrange for this to happen by defining the letter `K' to mean "any integer outside the range -128 to 127", and then specifying `Ks' in the operand constraints.
`g'
Any register, memory or immediate integer operand is allowed, except for registers that are not general registers.
`X'
Any operand whatsoever is allowed, even if it does not satisfy general_operand. This is normally used in the constraint of a match_scratch when certain alternatives will not actually require a scratch register.
`0', `1', `2', ... `9'
An operand that matches the specified operand number is allowed. If a digit is used together with letters within the same alternative, the digit should come last. This is called a matching constraint and what it really means is that the assembler has only a single operand that fills two roles considered separate in the RTL insn. For example, an add insn has two input operands and one output operand in the RTL, but on most CISC machines an add instruction really has only two operands, one of them an input-output operand:
addl #35,r12
Matching constraints are used in these circumstances. More precisely, the two operands that match must include one input-only operand and one output-only operand. Moreover, the digit must be a smaller number than the number of the operand that uses it in the constraint. For operands to match in a particular case usually means that they are identical-looking RTL expressions. But in a few special cases specific kinds of dissimilarity are allowed. For example, *x as an input operand will match *x++ as an output operand. For proper results in such cases, the output template should always use the output-operand's number when printing the operand.
`p'
An operand that is a valid memory address is allowed. This is for "load address" and "push address" instructions. `p' in the constraint must be accompanied by address_operand as the predicate in the match_operand. This predicate interprets the mode specified in the match_operand as the mode of the memory reference for which the address would be valid.
`Q', `R', `S', ... `U'
Letters in the range `Q' through `U' may be defined in a machine-dependent fashion to stand for arbitrary operand types. The machine description macro EXTRA_CONSTRAINT is passed the operand as its first argument and the constraint letter as its second operand. A typical use for this would be to distinguish certain types of memory references that affect other insn operands. Do not define these constraint letters to accept register references (reg); the reload pass does not expect this and would not handle it properly.

In order to have valid assembler code, each operand must satisfy its constraint. But a failure to do so does not prevent the pattern from applying to an insn. Instead, it directs the compiler to modify the code so that the constraint will be satisfied. Usually this is done by copying an operand into a register.

Contrast, therefore, the two instruction patterns that follow:

(define_insn ""
  [(set (match_operand:SI 0 "general_operand" "=r")
        (plus:SI (match_dup 0)
                 (match_operand:SI 1 "general_operand" "r")))]
  ""
  "...")

which has two operands, one of which must appear in two places, and

(define_insn ""
  [(set (match_operand:SI 0 "general_operand" "=r")
        (plus:SI (match_operand:SI 1 "general_operand" "0")
                 (match_operand:SI 2 "general_operand" "r")))]
  ""
  "...")

which has three operands, two of which are required by a constraint to be identical. If we are considering an insn of the form

(insn n prev next
  (set (reg:SI 3)
       (plus:SI (reg:SI 6) (reg:SI 109)))
  ...)

the first pattern would not apply at all, because this insn does not contain two identical subexpressions in the right place. The pattern would say, "That does not look like an add instruction; try other patterns." The second pattern would say, "Yes, that's an add instruction, but there is something wrong with it." It would direct the reload pass of the compiler to generate additional insns to make the constraint true. The results might look like this:

(insn n2 prev n
  (set (reg:SI 3) (reg:SI 6))
  ...)

(insn n n2 next
  (set (reg:SI 3)
       (plus:SI (reg:SI 3) (reg:SI 109)))
  ...)

It is up to you to make sure that each operand, in each pattern, has constraints that can handle any RTL expression that could be present for that operand. (When multiple alternatives are in use, each pattern must, for each possible combination of operand expressions, have at least one alternative which can handle that combination of operands.) The constraints don't need to allow any possible operand--when this is the case, they do not constrain--but they must at least point the way to reloading any possible operand so that it will fit.

  • If the constraint accepts whatever operands the predicate permits, there is no problem: reloading is never necessary for this operand. For example, an operand whose constraints permit everything except registers is safe provided its predicate rejects registers. An operand whose predicate accepts only constant values is safe provided its constraints include the letter `i'. If any possible constant value is accepted, then nothing less than `i' will do; if the predicate is more selective, then the constraints may also be more selective.
  • Any operand expression can be reloaded by copying it into a register. So if an operand's constraints allow some kind of register, it is certain to be safe. It need not permit all classes of registers; the compiler knows how to copy a register into another register of the proper class in order to make an instruction valid.
  • A nonoffsettable memory reference can be reloaded by copying the address into a register. So if the constraint uses the letter `o', all memory references are taken care of.
  • A constant operand can be reloaded by allocating space in memory to hold it as preinitialized data. Then the memory reference can be used in place of the constant. So if the constraint uses the letters `o' or `m', constant operands are not a problem.
  • If the constraint permits a constant and a pseudo register used in an insn was not allocated to a hard register and is equivalent to a constant, the register will be replaced with the constant. If the predicate does not permit a constant and the insn is re-recognized for some reason, the compiler will crash. Thus the predicate must always recognize any objects allowed by the constraint.

If the operand's predicate can recognize registers, but the constraint does not permit them, it can make the compiler crash. When this operand happens to be a register, the reload pass will be stymied, because it does not know how to copy a register temporarily into memory.

If the predicate accepts a unary operator, the constraint applies to the operand. For example, the MIPS processor at ISA level 3 supports an instruction which adds two registers in SImode to produce a DImode result, but only if the registers are correctly sign extended. This predicate for the input operands accepts a sign_extend of an SImode register. Write the constraint to indicate the type of register that is required for the operand of the sign_extend.


Using and Porting GNU CC - Multi-Alternative

Multiple Alternative Constraints

Sometimes a single instruction has multiple alternative sets of possible operands. For example, on the 68000, a logical-or instruction can combine register or an immediate value into memory, or it can combine any kind of operand into a register; but it cannot combine one memory location into another.

These constraints are represented as multiple alternatives. An alternative can be described by a series of letters for each operand. The overall constraint for an operand is made from the letters for this operand from the first alternative, a comma, the letters for this operand from the second alternative, a comma, and so on until the last alternative. Here is how it is done for fullword logical-or on the 68000:

(define_insn "iorsi3"
  [(set (match_operand:SI 0 "general_operand" "=m,d")
        (ior:SI (match_operand:SI 1 "general_operand" "%0,0")
                (match_operand:SI 2 "general_operand" "dKs,dmKs")))]
  ...)

The first alternative has `m' (memory) for operand 0, `0' for operand 1 (meaning it must match operand 0), and `dKs' for operand 2. The second alternative has `d' (data register) for operand 0, `0' for operand 1, and `dmKs' for operand 2. The `=' and `%' in the constraints apply to all the alternatives; their meaning is explained in the next section (see section Register Class Preferences).

If all the operands fit any one alternative, the instruction is valid. Otherwise, for each alternative, the compiler counts how many instructions must be added to copy the operands so that that alternative applies. The alternative requiring the least copying is chosen. If two alternatives need the same amount of copying, the one that comes first is chosen. These choices can be altered with the `?' and `!' characters:

?
Disparage slightly the alternative that the `?' appears in, as a choice when no alternative applies exactly. The compiler regards this alternative as one unit more costly for each `?' that appears in it.
!
Disparage severely the alternative that the `!' appears in. This alternative can still be used if it fits without reloading, but if reloading is needed, some other alternative will be used.

When an insn pattern has multiple alternatives in its constraints, often the appearance of the assembler code is determined mostly by which alternative was matched. When this is so, the C code for writing the assembler code can use the variable which_alternative, which is the ordinal number of the alternative that was actually satisfied (0 for the first, 1 for the second alternative, etc.). See section C Statements for Assembler Output.


Using and Porting GNU CC - Class Preferences

Register Class Preferences

The operand constraints have another function: they enable the compiler to decide which kind of hardware register a pseudo register is best allocated to. The compiler examines the constraints that apply to the insns that use the pseudo register, looking for the machine-dependent letters such as `d' and `a' that specify classes of registers. The pseudo register is put in whichever class gets the most "votes". The constraint letters `g' and `r' also vote: they vote in favor of a general register. The machine description says which registers are considered general.

Of course, on some machines all registers are equivalent, and no register classes are defined. Then none of this complexity is relevant.


Using and Porting GNU CC - Modifiers

Constraint Modifier Characters

Here are constraint modifier characters.

`='
Means that this operand is write-only for this instruction: the previous value is discarded and replaced by output data.
`+'
Means that this operand is both read and written by the instruction. When the compiler fixes up the operands to satisfy the constraints, it needs to know which operands are inputs to the instruction and which are outputs from it. `=' identifies an output; `+' identifies an operand that is both input and output; all other operands are assumed to be input only.
`&'
Means (in a particular alternative) that this operand is an earlyclobber operand, which is modified before the instruction is finished using the input operands. Therefore, this operand may not lie in a register that is used as an input operand or as part of any memory address. `&' applies only to the alternative in which it is written. In constraints with multiple alternatives, sometimes one alternative requires `&' while others do not. See, for example, the `movdf' insn of the 68000. An input operand can be tied to an earlyclobber operand if its only use as an input occurs before the early result is written. Adding alternatives of this form often allows GCC to produce better code when only some of the inputs can be affected by the earlyclobber. See, for example, the `mulsi3' insn of the ARM. `&' does not obviate the need to write `='.
`%'
Declares the instruction to be commutative for this operand and the following operand. This means that the compiler may interchange the two operands if that is the cheapest way to make all operands fit the constraints. This is often used in patterns for addition instructions that really have only two operands: the result must go in one of the arguments. Here for example, is how the 68000 halfword-add instruction is defined:
(define_insn "addhi3"
  [(set (match_operand:HI 0 "general_operand" "=m,r")
     (plus:HI (match_operand:HI 1 "general_operand" "%0,0")
              (match_operand:HI 2 "general_operand" "di,g")))]
  ...)
`#'
Says that all following characters, up to the next comma, are to be ignored as a constraint. They are significant only for choosing register preferences.
`*'
Says that the following character should be ignored when choosing register preferences. `*' has no effect on the meaning of the constraint as a constraint, and no effect on reloading. Here is an example: the 68000 has an instruction to sign-extend a halfword in a data register, and can also sign-extend a value by copying it into an address register. While either kind of register is acceptable, the constraints on an address-register destination are less strict, so it is best if register allocation makes an address register its goal. Therefore, `*' is used so that the `d' constraint letter (for data register) is ignored when computing register preferences.
(define_insn "extendhisi2"
  [(set (match_operand:SI 0 "general_operand" "=*d,a")
        (sign_extend:SI
         (match_operand:HI 1 "general_operand" "0,g")))]
  ...)


Using and Porting GNU CC - Machine Constraints

Constraints for Particular Machines

Whenever possible, you should use the general-purpose constraint letters in asm arguments, since they will convey meaning more readily to people reading your code. Failing that, use the constraint letters that usually have very similar meanings across architectures. The most commonly used constraints are `m' and `r' (for memory and general-purpose registers respectively; see section Simple Constraints), and `I', usually the letter indicating the most common immediate-constant format.

For each machine architecture, the `config/machine.h' file defines additional constraints. These constraints are used by the compiler itself for instruction generation, as well as for asm statements; therefore, some of the constraints are not particularly interesting for asm. The constraints are defined through these macros:

REG_CLASS_FROM_LETTER
Register class constraints (usually lower case).
CONST_OK_FOR_LETTER_P
Immediate constant constraints, for non-floating point constants of word size or smaller precision (usually upper case).
CONST_DOUBLE_OK_FOR_LETTER_P
Immediate constant constraints, for all floating point constants and for constants of greater than word size precision (usually upper case).
EXTRA_CONSTRAINT
Special cases of registers or memory. This macro is not required, and is only defined for some machines.

Inspecting these macro definitions in the compiler source for your machine is the best way to be certain you have the right constraints. However, here is a summary of the machine-dependent constraints available on some particular machines.

ARM family---`arm.h'
f
Floating-point register
F
One of the floating-point constants 0.0, 0.5, 1.0, 2.0, 3.0, 4.0, 5.0 or 10.0
G
Floating-point constant that would satisfy the constraint `F' if it were negated
I
Integer that is valid as an immediate operand in a data processing instruction. That is, an integer in the range 0 to 255 rotated by a multiple of 2
J
Integer in the range -4095 to 4095
K
Integer that satisfies constraint `I' when inverted (ones complement)
L
Integer that satisfies constraint `I' when negated (twos complement)
M
Integer in the range 0 to 32
Q
A memory reference where the exact address is in a single register (``m'' is preferable for asm statements)
R
An item in the constant pool
S
A symbol in the text segment of the current file
AMD 29000 family---`a29k.h'
l
Local register 0
b
Byte Pointer (`BP') register
q
`Q' register
h
Special purpose register
A
First accumulator register
a
Other accumulator register
f
Floating point register
I
Constant greater than 0, less than 0x100
J
Constant greater than 0, less than 0x10000
K
Constant whose high 24 bits are on (1)
L
16 bit constant whose high 8 bits are on (1)
M
32 bit constant whose high 16 bits are on (1)
N
32 bit negative constant that fits in 8 bits
O
The constant 0x80000000 or, on the 29050, any 32 bit constant whose low 16 bits are 0.
P
16 bit negative constant that fits in 8 bits
G
H
A floating point constant (in asm statements, use the machine independent `E' or `F' instead)
IBM RS6000---`rs6000.h'
b
Address base register
f
Floating point register
h
`MQ', `CTR', or `LINK' register
q
`MQ' register
c
`CTR' register
l
`LINK' register
x
`CR' register (condition register) number 0
y
`CR' register (condition register)
I
Signed 16 bit constant
J
Constant whose low 16 bits are 0
K
Constant whose high 16 bits are 0
L
Constant suitable as a mask operand
M
Constant larger than 31
N
Exact power of 2
O
Zero
P
Constant whose negation is a signed 16 bit constant
G
Floating point constant that can be loaded into a register with one instruction per word
Q
Memory operand that is an offset from a register (`m' is preferable for asm statements)
R
AIX TOC entry
S
Windows NT SYMBOL_REF
T
Windows NT LABEL_REF
U
System V Release 4 small data area reference
Intel 386---`i386.h'
q
`a', b, c, or d register
A
`a', or d register (for 64-bit ints)
f
Floating point register
t
First (top of stack) floating point register
u
Second floating point register
a
`a' register
b
`b' register
c
`c' register
d
`d' register
D
`di' register
S
`si' register
I
Constant in range 0 to 31 (for 32 bit shifts)
J
Constant in range 0 to 63 (for 64 bit shifts)
K
`0xff'
L
`0xffff'
M
0, 1, 2, or 3 (shifts for lea instruction)
N
Constant in range 0 to 255 (for out instruction)
G
Standard 80387 floating point constant
Intel 960---`i960.h'
f
Floating point register (fp0 to fp3)
l
Local register (r0 to r15)
b
Global register (g0 to g15)
d
Any local or global register
I
Integers from 0 to 31
J
0
K
Integers from -31 to 0
G
Floating point 0
H
Floating point 1
MIPS---`mips.h'
d
General-purpose integer register
f
Floating-point register (if available)
h
`Hi' register
l
`Lo' register
x
`Hi' or `Lo' register
y
General-purpose integer register
z
Floating-point status register
I
Signed 16 bit constant (for arithmetic instructions)
J
Zero
K
Zero-extended 16-bit constant (for logic instructions)
L
Constant with low 16 bits zero (can be loaded with lui)
M
32 bit constant which requires two instructions to load (a constant which is not `I', `K', or `L')
N
Negative 16 bit constant
O
Exact power of two
P
Positive 16 bit constant
G
Floating point zero
Q
Memory reference that can be loaded with more than one instruction (`m' is preferable for asm statements)
R
Memory reference that can be loaded with one instruction (`m' is preferable for asm statements)
S
Memory reference in external OSF/rose PIC format (`m' is preferable for asm statements)
Motorola 680x0---`m68k.h'
a
Address register
d
Data register
f
68881 floating-point register, if available
x
Sun FPA (floating-point) register, if available
y
First 16 Sun FPA registers, if available
I
Integer in the range 1 to 8
J
16 bit signed number
K
Signed number whose magnitude is greater than 0x80
L
Integer in the range -8 to -1
M
Signed number whose magnitude is greater than 0x100
G
Floating point constant that is not a 68881 constant
H
Floating point constant that can be used by Sun FPA
SPARC---`sparc.h'
f
Floating-point register that can hold 32 or 64 bit values.
e
Floating-point register that can hold 64 or 128 bit values.
I
Signed 13 bit constant
J
Zero
K
32 bit constant with the low 12 bits clear (a constant that can be loaded with the sethi instruction)
G
Floating-point zero
H
Signed 13 bit constant, sign-extended to 32 or 64 bits
Q
Memory reference that can be loaded with one instruction (`m' is more appropriate for asm statements)
S
Constant, or memory address
T
Memory address aligned to an 8-byte boundary
U
Even register


Using and Porting GNU CC - No Constraints

Not Using Constraints

Some machines are so clean that operand constraints are not required. For example, on the Vax, an operand valid in one context is valid in any other context. On such a machine, every operand constraint would be `g', excepting only operands of "load address" instructions which are written as if they referred to a memory location's contents but actual refer to its address. They would have constraint `p'.

For such machines, instead of writing `g' and `p' for all the constraints, you can choose to write a description with empty constraints. Then you write `""' for the constraint in every match_operand. Address operands are identified by writing an address expression around the match_operand, not by their constraints.

When the machine description has just empty constraints, certain parts of compilation are skipped, making the compiler faster. However, few machines actually do not need constraints; all machine descriptions now in existence use constraints.


Using and Porting GNU CC - Standard Names

Standard Pattern Names For Generation

Here is a table of the instruction names that are meaningful in the RTL generation pass of the compiler. Giving one of these names to an instruction pattern tells the RTL generation pass that it can use the pattern in to accomplish a certain task.

`movm'
Here m stands for a two-letter machine mode name, in lower case. This instruction pattern moves data with that machine mode from operand 1 to operand 0. For example, `movsi' moves full-word data. If operand 0 is a subreg with mode m of a register whose own mode is wider than m, the effect of this instruction is to store the specified value in the part of the register that corresponds to mode m. The effect on the rest of the register is undefined. This class of patterns is special in several ways. First of all, each of these names must be defined, because there is no other way to copy a datum from one place to another. Second, these patterns are not used solely in the RTL generation pass. Even the reload pass can generate move insns to copy values from stack slots into temporary registers. When it does so, one of the operands is a hard register and the other is an operand that can need to be reloaded into a register. Therefore, when given such a pair of operands, the pattern must generate RTL which needs no reloading and needs no temporary registers--no registers other than the operands. For example, if you support the pattern with a define_expand, then in such a case the define_expand mustn't call force_reg or any other such function which might generate new pseudo registers. This requirement exists even for subword modes on a RISC machine where fetching those modes from memory normally requires several insns and some temporary registers. Look in `spur.md' to see how the requirement can be satisfied. During reload a memory reference with an invalid address may be passed as an operand. Such an address will be replaced with a valid address later in the reload pass. In this case, nothing may be done with the address except to use it as it stands. If it is copied, it will not be replaced with a valid address. No attempt should be made to make such an address into a valid address and no routine (such as change_address) that will do so may be called. Note that general_operand will fail when applied to such an address. The global variable reload_in_progress (which must be explicitly declared if required) can be used to determine whether such special handling is required. The variety of operands that have reloads depends on the rest of the machine description, but typically on a RISC machine these can only be pseudo registers that did not get hard registers, while on other machines explicit memory references will get optional reloads. If a scratch register is required to move an object to or from memory, it can be allocated using gen_reg_rtx prior to reload. But this is impossible during and after reload. If there are cases needing scratch registers after reload, you must define SECONDARY_INPUT_RELOAD_CLASS and perhaps also SECONDARY_OUTPUT_RELOAD_CLASS to detect them, and provide patterns `reload_inm' or `reload_outm' to handle them. See section Register Classes. The constraints on a `movem' must permit moving any hard register to any other hard register provided that HARD_REGNO_MODE_OK permits mode m in both registers and REGISTER_MOVE_COST applied to their classes returns a value of 2. It is obligatory to support floating point `movem' instructions into and out of any registers that can hold fixed point values, because unions and structures (which have modes SImode or DImode) can be in those registers and they may have floating point members. There may also be a need to support fixed point `movem' instructions in and out of floating point registers. Unfortunately, I have forgotten why this was so, and I don't know whether it is still true. If HARD_REGNO_MODE_OK rejects fixed point values in floating point registers, then the constraints of the fixed point `movem' instructions must be designed to avoid ever trying to reload into a floating point register.
`reload_inm'
`reload_outm'
Like `movm', but used when a scratch register is required to move between operand 0 and operand 1. Operand 2 describes the scratch register. See the discussion of the SECONDARY_RELOAD_CLASS macro in see section Register Classes.
`movstrictm'
Like `movm' except that if operand 0 is a subreg with mode m of a register whose natural mode is wider, the `movstrictm' instruction is guaranteed not to alter any of the register except the part which belongs to mode m.
`load_multiple'
Load several consecutive memory locations into consecutive registers. Operand 0 is the first of the consecutive registers, operand 1 is the first memory location, and operand 2 is a constant: the number of consecutive registers. Define this only if the target machine really has such an instruction; do not define this if the most efficient way of loading consecutive registers from memory is to do them one at a time. On some machines, there are restrictions as to which consecutive registers can be stored into memory, such as particular starting or ending register numbers or only a range of valid counts. For those machines, use a define_expand (see section Defining RTL Sequences for Code Generation) and make the pattern fail if the restrictions are not met. Write the generated insn as a parallel with elements being a set of one register from the appropriate memory location (you may also need use or clobber elements). Use a match_parallel (see section RTL Template) to recognize the insn. See `a29k.md' and `rs6000.md' for examples of the use of this insn pattern.
`store_multiple'
Similar to `load_multiple', but store several consecutive registers into consecutive memory locations. Operand 0 is the first of the consecutive memory locations, operand 1 is the first register, and operand 2 is a constant: the number of consecutive registers.
`addm3'
Add operand 2 and operand 1, storing the result in operand 0. All operands must have mode m. This can be used even on two-address machines, by means of constraints requiring operands 1 and 0 to be the same location.
`subm3', `mulm3'
`divm3', `udivm3', `modm3', `umodm3'
`sminm3', `smaxm3', `uminm3', `umaxm3'
`andm3', `iorm3', `xorm3'
Similar, for other arithmetic operations.
`mulhisi3'
Multiply operands 1 and 2, which have mode HImode, and store a SImode product in operand 0.
`mulqihi3', `mulsidi3'
Similar widening-multiplication instructions of other widths.
`umulqihi3', `umulhisi3', `umulsidi3'
Similar widening-multiplication instructions that do unsigned multiplication.
`mulm3_highpart'
Perform a signed multiplication of operands 1 and 2, which have mode m, and store the most significant half of the product in operand 0. The least significant half of the product is discarded.
`umulm3_highpart'
Similar, but the multiplication is unsigned.
`divmodm4'
Signed division that produces both a quotient and a remainder. Operand 1 is divided by operand 2 to produce a quotient stored in operand 0 and a remainder stored in operand 3. For machines with an instruction that produces both a quotient and a remainder, provide a pattern for `divmodm4' but do not provide patterns for `divm3' and `modm3'. This allows optimization in the relatively common case when both the quotient and remainder are computed. If an instruction that just produces a quotient or just a remainder exists and is more efficient than the instruction that produces both, write the output routine of `divmodm4' to call find_reg_note and look for a REG_UNUSED note on the quotient or remainder and generate the appropriate instruction.
`udivmodm4'
Similar, but does unsigned division.
`ashlm3'
Arithmetic-shift operand 1 left by a number of bits specified by operand 2, and store the result in operand 0. Here m is the mode of operand 0 and operand 1; operand 2's mode is specified by the instruction pattern, and the compiler will convert the operand to that mode before generating the instruction.
`ashrm3', `lshrm3', `rotlm3', `rotrm3'
Other shift and rotate instructions, analogous to the ashlm3 instructions.
`negm2'
Negate operand 1 and store the result in operand 0.
`absm2'
Store the absolute value of operand 1 into operand 0.
`sqrtm2'
Store the square root of operand 1 into operand 0. The sqrt built-in function of C always uses the mode which corresponds to the C data type double.
`ffsm2'
Store into operand 0 one plus the index of the least significant 1-bit of operand 1. If operand 1 is zero, store zero. m is the mode of operand 0; operand 1's mode is specified by the instruction pattern, and the compiler will convert the operand to that mode before generating the instruction. The ffs built-in function of C always uses the mode which corresponds to the C data type int.
`one_cmplm2'
Store the bitwise-complement of operand 1 into operand 0.
`cmpm'
Compare operand 0 and operand 1, and set the condition codes. The RTL pattern should look like this:
(set (cc0) (compare (match_operand:m 0 ...)
                    (match_operand:m 1 ...)))
`tstm'
Compare operand 0 against zero, and set the condition codes. The RTL pattern should look like this:
(set (cc0) (match_operand:m 0 ...))
`tstm' patterns should not be defined for machines that do not use (cc0). Doing so would confuse the optimizer since it would no longer be clear which set operations were comparisons. The `cmpm' patterns should be used instead.
`movstrm'
Block move instruction. The addresses of the destination and source strings are the first two operands, and both are in mode Pmode. The number of bytes to move is the third operand, in mode m. The fourth operand is the known shared alignment of the source and destination, in the form of a const_int rtx. Thus, if the compiler knows that both source and destination are word-aligned, it may provide the value 4 for this operand. These patterns need not give special consideration to the possibility that the source and destination strings might overlap.
`clrstrm'
Block clear instruction. The addresses of the destination string is the first operand, in mode Pmode. The number of bytes to clear is the second operand, in mode m. The third operand is the known alignment of the destination, in the form of a const_int rtx. Thus, if the compiler knows that the destination is word-aligned, it may provide the value 4 for this operand.
`cmpstrm'
Block compare instruction, with five operands. Operand 0 is the output; it has mode m. The remaining four operands are like the operands of `movstrm'. The two memory blocks specified are compared byte by byte in lexicographic order. The effect of the instruction is to store a value in operand 0 whose sign indicates the result of the comparison.
`strlenm'
Compute the length of a string, with three operands. Operand 0 is the result (of mode m), operand 1 is a mem referring to the first character of the string, operand 2 is the character to search for (normally zero), and operand 3 is a constant describing the known alignment of the beginning of the string.
`floatmn2'
Convert signed integer operand 1 (valid for fixed point mode m) to floating point mode n and store in operand 0 (which has mode n).
`floatunsmn2'
Convert unsigned integer operand 1 (valid for fixed point mode m) to floating point mode n and store in operand 0 (which has mode n).
`fixmn2'
Convert operand 1 (valid for floating point mode m) to fixed point mode n as a signed number and store in operand 0 (which has mode n). This instruction's result is defined only when the value of operand 1 is an integer.
`fixunsmn2'
Convert operand 1 (valid for floating point mode m) to fixed point mode n as an unsigned number and store in operand 0 (which has mode n). This instruction's result is defined only when the value of operand 1 is an integer.
`ftruncm2'
Convert operand 1 (valid for floating point mode m) to an integer value, still represented in floating point mode m, and store it in operand 0 (valid for floating point mode m).
`fix_truncmn2'
Like `fixmn2' but works for any floating point value of mode m by converting the value to an integer.
`fixuns_truncmn2'
Like `fixunsmn2' but works for any floating point value of mode m by converting the value to an integer.
`truncmn2'
Truncate operand 1 (valid for mode m) to mode n and store in operand 0 (which has mode n). Both modes must be fixed point or both floating point.
`extendmn2'
Sign-extend operand 1 (valid for mode m) to mode n and store in operand 0 (which has mode n). Both modes must be fixed point or both floating point.
`zero_extendmn2'
Zero-extend operand 1 (valid for mode m) to mode n and store in operand 0 (which has mode n). Both modes must be fixed point.
`extv'
Extract a bit field from operand 1 (a register or memory operand), where operand 2 specifies the width in bits and operand 3 the starting bit, and store it in operand 0. Operand 0 must have mode word_mode. Operand 1 may have mode byte_mode or word_mode; often word_mode is allowed only for registers. Operands 2 and 3 must be valid for word_mode. The RTL generation pass generates this instruction only with constants for operands 2 and 3. The bit-field value is sign-extended to a full word integer before it is stored in operand 0.
`extzv'
Like `extv' except that the bit-field value is zero-extended.
`insv'
Store operand 3 (which must be valid for word_mode) into a bit field in operand 0, where operand 1 specifies the width in bits and operand 2 the starting bit. Operand 0 may have mode byte_mode or word_mode; often word_mode is allowed only for registers. Operands 1 and 2 must be valid for word_mode. The RTL generation pass generates this instruction only with constants for operands 1 and 2.
`movmodecc'
Conditionally move operand 2 or operand 3 into operand 0 according to the comparison in operand 1. If the comparison is true, operand 2 is moved into operand 0, otherwise operand 3 is moved. The mode of the operands being compared need not be the same as the operands being moved. Some machines, sparc64 for example, have instructions that conditionally move an integer value based on the floating point condition codes and vice versa. If the machine does not have conditional move instructions, do not define these patterns.
`scond'
Store zero or nonzero in the operand according to the condition codes. Value stored is nonzero iff the condition cond is true. cond is the name of a comparison operation expression code, such as eq, lt or leu. You specify the mode that the operand must have when you write the match_operand expression. The compiler automatically sees which mode you have used and supplies an operand of that mode. The value stored for a true condition must have 1 as its low bit, or else must be negative. Otherwise the instruction is not suitable and you should omit it from the machine description. You describe to the compiler exactly which value is stored by defining the macro STORE_FLAG_VALUE (see section Miscellaneous Parameters). If a description cannot be found that can be used for all the `scond' patterns, you should omit those operations from the machine description. These operations may fail, but should do so only in relatively uncommon cases; if they would fail for common cases involving integer comparisons, it is best to omit these patterns. If these operations are omitted, the compiler will usually generate code that copies the constant one to the target and branches around an assignment of zero to the target. If this code is more efficient than the potential instructions used for the `scond' pattern followed by those required to convert the result into a 1 or a zero in SImode, you should omit the `scond' operations from the machine description.
`bcond'
Conditional branch instruction. Operand 0 is a label_ref that refers to the label to jump to. Jump if the condition codes meet condition cond. Some machines do not follow the model assumed here where a comparison instruction is followed by a conditional branch instruction. In that case, the `cmpm' (and `tstm') patterns should simply store the operands away and generate all the required insns in a define_expand (see section Defining RTL Sequences for Code Generation) for the conditional branch operations. All calls to expand `bcond' patterns are immediately preceded by calls to expand either a `cmpm' pattern or a `tstm' pattern. Machines that use a pseudo register for the condition code value, or where the mode used for the comparison depends on the condition being tested, should also use the above mechanism. See section Defining Jump Instruction Patterns The above discussion also applies to the `movmodecc' and `scond' patterns.
`call'
Subroutine call instruction returning no value. Operand 0 is the function to call; operand 1 is the number of bytes of arguments pushed (in mode SImode, except it is normally a const_int); operand 2 is the number of registers used as operands. On most machines, operand 2 is not actually stored into the RTL pattern. It is supplied for the sake of some RISC machines which need to put this information into the assembler code; they can put it in the RTL instead of operand 1. Operand 0 should be a mem RTX whose address is the address of the function. Note, however, that this address can be a symbol_ref expression even if it would not be a legitimate memory address on the target machine. If it is also not a valid argument for a call instruction, the pattern for this operation should be a define_expand (see section Defining RTL Sequences for Code Generation) that places the address into a register and uses that register in the call instruction.
`call_value'
Subroutine call instruction returning a value. Operand 0 is the hard register in which the value is returned. There are three more operands, the same as the three operands of the `call' instruction (but with numbers increased by one). Subroutines that return BLKmode objects use the `call' insn.
`call_pop', `call_value_pop'
Similar to `call' and `call_value', except used if defined and if RETURN_POPS_ARGS is non-zero. They should emit a parallel that contains both the function call and a set to indicate the adjustment made to the frame pointer. For machines where RETURN_POPS_ARGS can be non-zero, the use of these patterns increases the number of functions for which the frame pointer can be eliminated, if desired.
`untyped_call'
Subroutine call instruction returning a value of any type. Operand 0 is the function to call; operand 1 is a memory location where the result of calling the function is to be stored; operand 2 is a parallel expression where each element is a set expression that indicates the saving of a function return value into the result block. This instruction pattern should be defined to support __builtin_apply on machines where special instructions are needed to call a subroutine with arbitrary arguments or to save the value returned. This instruction pattern is required on machines that have multiple registers that can hold a return value (i.e. FUNCTION_VALUE_REGNO_P is true for more than one register).
`return'
Subroutine return instruction. This instruction pattern name should be defined only if a single instruction can do all the work of returning from a function. Like the `movm' patterns, this pattern is also used after the RTL generation phase. In this case it is to support machines where multiple instructions are usually needed to return from a function, but some class of functions only requires one instruction to implement a return. Normally, the applicable functions are those which do not need to save any registers or allocate stack space. For such machines, the condition specified in this pattern should only be true when reload_completed is non-zero and the function's epilogue would only be a single instruction. For machines with register windows, the routine leaf_function_p may be used to determine if a register window push is required. Machines that have conditional return instructions should define patterns such as
(define_insn ""
  [(set (pc)
        (if_then_else (match_operator
                         0 "comparison_operator"
                         [(cc0) (const_int 0)])
                      (return)
                      (pc)))]
  "condition"
  "...")
where condition would normally be the same condition specified on the named `return' pattern.
`untyped_return'
Untyped subroutine return instruction. This instruction pattern should be defined to support __builtin_return on machines where special instructions are needed to return a value of any type. Operand 0 is a memory location where the result of calling a function with __builtin_apply is stored; operand 1 is a parallel expression where each element is a set expression that indicates the restoring of a function return value from the result block.
`nop'
No-op instruction. This instruction pattern name should always be defined to output a no-op in assembler code. (const_int 0) will do as an RTL pattern.
`indirect_jump'
An instruction to jump to an address which is operand zero. This pattern name is mandatory on all machines.
`casesi'
Instruction to jump through a dispatch table, including bounds checking. This instruction takes five operands:
  1. The index to dispatch on, which has mode SImode.
  2. The lower bound for indices in the table, an integer constant.
  3. The total range of indices in the table--the largest index minus the smallest one (both inclusive).
  4. A label that precedes the table itself.
  5. A label to jump to if the index has a value outside the bounds. (If the machine-description macro CASE_DROPS_THROUGH is defined, then an out-of-bounds index drops through to the code following the jump table instead of jumping to this label. In that case, this label is not actually used by the `casesi' instruction, but it is always provided as an operand.)
The table is a addr_vec or addr_diff_vec inside of a jump_insn. The number of elements in the table is one plus the difference between the upper bound and the lower bound.
`tablejump'
Instruction to jump to a variable address. This is a low-level capability which can be used to implement a dispatch table when there is no `casesi' pattern. This pattern requires two operands: the address or offset, and a label which should immediately precede the jump table. If the macro CASE_VECTOR_PC_RELATIVE is defined then the first operand is an offset which counts from the address of the table; otherwise, it is an absolute address to jump to. In either case, the first operand has mode Pmode. The `tablejump' insn is always the last insn before the jump table it uses. Its assembler code normally has no need to use the second operand, but you should incorporate it in the RTL pattern so that the jump optimizer will not delete the table as unreachable code.
`canonicalize_funcptr_for_compare'
Canonicalize the function pointer in operand 1 and store the result into operand 0. Operand 0 is always a reg and has mode Pmode; operand 1 may be a reg, mem, symbol_ref, const_int, etc and also has mode Pmode. Canonicalization of a function pointer usually involves computing the address of the function which would be called if the function pointer were used in an indirect call. Only define this pattern if function pointers on the target machine can have different values but still call the same function when used in an indirect call.
`save_stack_block'
`save_stack_function'
`save_stack_nonlocal'
`restore_stack_block'
`restore_stack_function'
`restore_stack_nonlocal'
Most machines save and restore the stack pointer by copying it to or from an object of mode Pmode. Do not define these patterns on such machines. Some machines require special handling for stack pointer saves and restores. On those machines, define the patterns corresponding to the non-standard cases by using a define_expand (see section Defining RTL Sequences for Code Generation) that produces the required insns. The three types of saves and restores are:
  1. `save_stack_block' saves the stack pointer at the start of a block that allocates a variable-sized object, and `restore_stack_block' restores the stack pointer when the block is exited.
  2. `save_stack_function' and `restore_stack_function' do a similar job for the outermost block of a function and are used when the function allocates variable-sized objects or calls alloca. Only the epilogue uses the restored stack pointer, allowing a simpler save or restore sequence on some machines.
  3. `save_stack_nonlocal' is used in functions that contain labels branched to by nested functions. It saves the stack pointer in such a way that the inner function can use `restore_stack_nonlocal' to restore the stack pointer. The compiler generates code to restore the frame and argument pointer registers, but some machines require saving and restoring additional data such as register window information or stack backchains. Place insns in these patterns to save and restore any such required data.
When saving the stack pointer, operand 0 is the save area and operand 1 is the stack pointer. The mode used to allocate the save area is the mode of operand 0. You must specify an integral mode, or VOIDmode if no save area is needed for a particular type of save (either because no save is needed or because a machine-specific save area can be used). Operand 0 is the stack pointer and operand 1 is the save area for restore operations. If `save_stack_block' is defined, operand 0 must not be VOIDmode since these saves can be arbitrarily nested. A save area is a mem that is at a constant offset from virtual_stack_vars_rtx when the stack pointer is saved for use by nonlocal gotos and a reg in the other two cases.
`allocate_stack'
Subtract (or add if STACK_GROWS_DOWNWARD is undefined) operand 0 from the stack pointer to create space for dynamically allocated data. Do not define this pattern if all that must be done is the subtraction. Some machines require other operations such as stack probes or maintaining the back chain. Define this pattern to emit those operations in addition to updating the stack pointer.
`probe'
Some machines require instructions to be executed after space is allocated from the stack, for example to generate a reference at the bottom of the stack. If you need to emit instructions before the stack has been adjusted, put them into the `allocate_stack' pattern. Otherwise, define this pattern to emit the required instructions. No operands are provided.
`check_stack'
If stack checking cannot be done on your system by probing the stack with a load or store instruction (see section Specifying How Stack Checking is Done), define this pattern to perform the needed check and signaling an error if the stack has overflowed. The single operand is the location in the stack furthest from the current stack pointer that you need to validate. Normally, on machines where this pattern is needed, you would obtain the stack limit from a global or thread-specific variable or register.
`nonlocal_goto'
Emit code to generate a non-local goto, e.g., a jump from one function to a label in an outer function. This pattern has four arguments, each representing a value to be used in the jump. The first argument is to be loadedd into the frame pointer, the second is the address to branch to (code to dispatch to the actual label), the third is the address of a location where the stack is saved, and the last is the address of the label, to be placed in the location for the incoming static chain. On most machines you need not define this pattern, since GNU CC will already generate the correct code, which is to load the frame pointer and static chain, restore the stack (using the `restore_stack_nonlocal' pattern, if defined), and jump indirectly to the dispatcher. You need only define this pattern if this code will not work on your machine.
`nonlocal_goto_receiver'
This pattern, if defined, contains code needed at the target of a nonlocal goto after the code already generated by GNU CC. You will not normally need to define this pattern. A typical reason why you might need this pattern is if some value, such as a pointer to a global table, must be restored when the frame pointer is restored. There are no arguments.
`exception_receiver'
This pattern, if defined, contains code needed at the site of an exception handler that isn't needed at the site of a nonlocal goto. You will not normally need to define this pattern. A typical reason why you might need this pattern is if some value, such as a pointer to a global table, must be restored after control flow is branched to the handler of an exception. There are no arguments.


Using and Porting GNU CC - Pattern Ordering

When the Order of Patterns Matters

Sometimes an insn can match more than one instruction pattern. Then the pattern that appears first in the machine description is the one used. Therefore, more specific patterns (patterns that will match fewer things) and faster instructions (those that will produce better code when they do match) should usually go first in the description.

In some cases the effect of ordering the patterns can be used to hide a pattern when it is not valid. For example, the 68000 has an instruction for converting a fullword to floating point and another for converting a byte to floating point. An instruction converting an integer to floating point could match either one. We put the pattern to convert the fullword first to make sure that one will be used rather than the other. (Otherwise a large integer might be generated as a single-byte immediate quantity, which would not work.) Instead of using this pattern ordering it would be possible to make the pattern for convert-a-byte smart enough to deal properly with any constant value.


Using and Porting GNU CC - Dependent Patterns

Interdependence of Patterns

Every machine description must have a named pattern for each of the conditional branch names `bcond'. The recognition template must always have the form

(set (pc)
     (if_then_else (cond (cc0) (const_int 0))
                   (label_ref (match_operand 0 "" ""))
                   (pc)))

In addition, every machine description must have an anonymous pattern for each of the possible reverse-conditional branches. Their templates look like

(set (pc)
     (if_then_else (cond (cc0) (const_int 0))
                   (pc)
                   (label_ref (match_operand 0 "" ""))))

They are necessary because jump optimization can turn direct-conditional branches into reverse-conditional branches.

It is often convenient to use the match_operator construct to reduce the number of patterns that must be specified for branches. For example,

(define_insn ""
  [(set (pc)
        (if_then_else (match_operator 0 "comparison_operator"
                                      [(cc0) (const_int 0)])
                      (pc)
                      (label_ref (match_operand 1 "" ""))))]
  "condition"
  "...")

In some cases machines support instructions identical except for the machine mode of one or more operands. For example, there may be "sign-extend halfword" and "sign-extend byte" instructions whose patterns are

(set (match_operand:SI 0 ...)
     (extend:SI (match_operand:HI 1 ...)))

(set (match_operand:SI 0 ...)
     (extend:SI (match_operand:QI 1 ...)))

Constant integers do not specify a machine mode, so an instruction to extend a constant value could match either pattern. The pattern it actually will match is the one that appears first in the file. For correct results, this must be the one for the widest possible mode (HImode, here). If the pattern matches the QImode instruction, the results will be incorrect if the constant value does not actually fit that mode.

Such instructions to extend constants are rarely generated because they are optimized away, but they do occasionally happen in nonoptimized compilations.

If a constraint in a pattern allows a constant, the reload pass may replace a register with a constant permitted by the constraint in some cases. Similarly for memory references. Because of this substitution, you should not provide separate patterns for increment and decrement instructions. Instead, they should be generated from the same pattern that supports register-register add insns by examining the operands and generating the appropriate machine instruction.


Using and Porting GNU CC - Jump Patterns

Defining Jump Instruction Patterns

For most machines, GNU CC assumes that the machine has a condition code. A comparison insn sets the condition code, recording the results of both signed and unsigned comparison of the given operands. A separate branch insn tests the condition code and branches or not according its value. The branch insns come in distinct signed and unsigned flavors. Many common machines, such as the Vax, the 68000 and the 32000, work this way.

Some machines have distinct signed and unsigned compare instructions, and only one set of conditional branch instructions. The easiest way to handle these machines is to treat them just like the others until the final stage where assembly code is written. At this time, when outputting code for the compare instruction, peek ahead at the following branch using next_cc0_user (insn). (The variable insn refers to the insn being output, in the output-writing code in an instruction pattern.) If the RTL says that is an unsigned branch, output an unsigned compare; otherwise output a signed compare. When the branch itself is output, you can treat signed and unsigned branches identically.

The reason you can do this is that GNU CC always generates a pair of consecutive RTL insns, possibly separated by note insns, one to set the condition code and one to test it, and keeps the pair inviolate until the end.

To go with this technique, you must define the machine-description macro NOTICE_UPDATE_CC to do CC_STATUS_INIT; in other words, no compare instruction is superfluous.

Some machines have compare-and-branch instructions and no condition code. A similar technique works for them. When it is time to "output" a compare instruction, record its operands in two static variables. When outputting the branch-on-condition-code instruction that follows, actually output a compare-and-branch instruction that uses the remembered operands.

It also works to define patterns for compare-and-branch instructions. In optimizing compilation, the pair of compare and branch instructions will be combined according to these patterns. But this does not happen if optimization is not requested. So you must use one of the solutions above in addition to any special patterns you define.

In many RISC machines, most instructions do not affect the condition code and there may not even be a separate condition code register. On these machines, the restriction that the definition and use of the condition code be adjacent insns is not necessary and can prevent important optimizations. For example, on the IBM RS/6000, there is a delay for taken branches unless the condition code register is set three instructions earlier than the conditional branch. The instruction scheduler cannot perform this optimization if it is not permitted to separate the definition and use of the condition code register.

On these machines, do not use (cc0), but instead use a register to represent the condition code. If there is a specific condition code register in the machine, use a hard register. If the condition code or comparison result can be placed in any general register, or if there are multiple condition registers, use a pseudo register.

On some machines, the type of branch instruction generated may depend on the way the condition code was produced; for example, on the 68k and Sparc, setting the condition code directly from an add or subtract instruction does not clear the overflow bit the way that a test instruction does, so a different branch instruction must be used for some conditional branches. For machines that use (cc0), the set and use of the condition code must be adjacent (separated only by note insns) allowing flags in cc_status to be used. (See section Condition Code Status.) Also, the comparison and branch insns can be located from each other by using the functions prev_cc0_setter and next_cc0_user.

However, this is not true on machines that do not use (cc0). On those machines, no assumptions can be made about the adjacency of the compare and branch insns and the above methods cannot be used. Instead, we use the machine mode of the condition code register to record different formats of the condition code register.

Registers used to store the condition code value should have a mode that is in class MODE_CC. Normally, it will be CCmode. If additional modes are required (as for the add example mentioned above in the Sparc), define the macro EXTRA_CC_MODES to list the additional modes required (see section Condition Code Status). Also define EXTRA_CC_NAMES to list the names of those modes and SELECT_CC_MODE to choose a mode given an operand of a compare.

If it is known during RTL generation that a different mode will be required (for example, if the machine has separate compare instructions for signed and unsigned quantities, like most IBM processors), they can be specified at that time.

If the cases that require different modes would be made by instruction combination, the macro SELECT_CC_MODE determines which machine mode should be used for the comparison result. The patterns should be written using that mode. To support the case of the add on the Sparc discussed above, we have the pattern

(define_insn ""
  [(set (reg:CC_NOOV 0)
        (compare:CC_NOOV
          (plus:SI (match_operand:SI 0 "register_operand" "%r")
                   (match_operand:SI 1 "arith_operand" "rI"))
          (const_int 0)))]
  ""
  "...")

The SELECT_CC_MODE macro on the Sparc returns CC_NOOVmode for comparisons whose argument is a plus.


Using and Porting GNU CC - Insn Canonicalizations

Canonicalization of Instructions

There are often cases where multiple RTL expressions could represent an operation performed by a single machine instruction. This situation is most commonly encountered with logical, branch, and multiply-accumulate instructions. In such cases, the compiler attempts to convert these multiple RTL expressions into a single canonical form to reduce the number of insn patterns required.

In addition to algebraic simplifications, following canonicalizations are performed:

  • For commutative and comparison operators, a constant is always made the second operand. If a machine only supports a constant as the second operand, only patterns that match a constant in the second operand need be supplied. For these operators, if only one operand is a neg, not, mult, plus, or minus expression, it will be the first operand.
  • For the compare operator, a constant is always the second operand on machines where cc0 is used (see section Defining Jump Instruction Patterns). On other machines, there are rare cases where the compiler might want to construct a compare with a constant as the first operand. However, these cases are not common enough for it to be worthwhile to provide a pattern matching a constant as the first operand unless the machine actually has such an instruction. An operand of neg, not, mult, plus, or minus is made the first operand under the same conditions as above.
  • (minus x (const_int n)) is converted to (plus x (const_int -n)).
  • Within address computations (i.e., inside mem), a left shift is converted into the appropriate multiplication by a power of two.
  • De`Morgan's Law is used to move bitwise negation inside a bitwise logical-and or logical-or operation. If this results in only one operand being a not expression, it will be the first one. A machine that has an instruction that performs a bitwise logical-and of one operand with the bitwise negation of the other should specify the pattern for that instruction as
    (define_insn ""
  [(set (match_operand:m 0 ...)
        (and:m (not:m (match_operand:m 1 ...))
                     (match_operand:m 2 ...)))]
  "..."
  "...")
    Similarly, a pattern for a "NAND" instruction should be written
    (define_insn ""
  [(set (match_operand:m 0 ...)
        (ior:m (not:m (match_operand:m 1 ...))
                     (not:m (match_operand:m 2 ...))))]
  "..."
  "...")
    In both cases, it is not necessary to include patterns for the many logically equivalent RTL expressions.
  • The only possible RTL expressions involving both bitwise exclusive-or and bitwise negation are (xor:m x y) and (not:m (xor:m x y)).
  • The sum of three items, one of which is a constant, will only appear in the form
    (plus:m (plus:m x y) constant)
  • On machines that do not use cc0, (compare x (const_int 0)) will be converted to x.
  • Equality comparisons of a group of bits (usually a single bit) with zero will be written using zero_extract rather than the equivalent and or sign_extract operations.


Using and Porting GNU CC - Peephole Definitions

Machine-Specific Peephole Optimizers

In addition to instruction patterns the `md' file may contain definitions of machine-specific peephole optimizations.

The combiner does not notice certain peephole optimizations when the data flow in the program does not suggest that it should try them. For example, sometimes two consecutive insns related in purpose can be combined even though the second one does not appear to use a register computed in the first one. A machine-specific peephole optimizer can detect such opportunities.

A definition looks like this:

(define_peephole
  [insn-pattern-1
   insn-pattern-2
   ...]
  "condition"
  "template"
  "optional insn-attributes")

The last string operand may be omitted if you are not using any machine-specific information in this machine description. If present, it must obey the same rules as in a define_insn.

In this skeleton, insn-pattern-1 and so on are patterns to match consecutive insns. The optimization applies to a sequence of insns when insn-pattern-1 matches the first one, insn-pattern-2 matches the next, and so on.

Each of the insns matched by a peephole must also match a define_insn. Peepholes are checked only at the last stage just before code generation, and only optionally. Therefore, any insn which would match a peephole but no define_insn will cause a crash in code generation in an unoptimized compilation, or at various optimization stages.

The operands of the insns are matched with match_operands, match_operator, and match_dup, as usual. What is not usual is that the operand numbers apply to all the insn patterns in the definition. So, you can check for identical operands in two insns by using match_operand in one insn and match_dup in the other.

The operand constraints used in match_operand patterns do not have any direct effect on the applicability of the peephole, but they will be validated afterward, so make sure your constraints are general enough to apply whenever the peephole matches. If the peephole matches but the constraints are not satisfied, the compiler will crash.

It is safe to omit constraints in all the operands of the peephole; or you can write constraints which serve as a double-check on the criteria previously tested.

Once a sequence of insns matches the patterns, the condition is checked. This is a C expression which makes the final decision whether to perform the optimization (we do so if the expression is nonzero). If condition is omitted (in other words, the string is empty) then the optimization is applied to every sequence of insns that matches the patterns.

The defined peephole optimizations are applied after register allocation is complete. Therefore, the peephole definition can check which operands have ended up in which kinds of registers, just by looking at the operands.

The way to refer to the operands in condition is to write operands[i] for operand number i (as matched by (match_operand i ...)). Use the variable insn to refer to the last of the insns being matched; use prev_active_insn to find the preceding insns.

When optimizing computations with intermediate results, you can use condition to match only when the intermediate results are not used elsewhere. Use the C expression dead_or_set_p (insn, op), where insn is the insn in which you expect the value to be used for the last time (from the value of insn, together with use of prev_nonnote_insn), and op is the intermediate value (from operands[i]).

Applying the optimization means replacing the sequence of insns with one new insn. The template controls ultimate output of assembler code for this combined insn. It works exactly like the template of a define_insn. Operand numbers in this template are the same ones used in matching the original sequence of insns.

The result of a defined peephole optimizer does not need to match any of the insn patterns in the machine description; it does not even have an opportunity to match them. The peephole optimizer definition itself serves as the insn pattern to control how the insn is output.

Defined peephole optimizers are run as assembler code is being output, so the insns they produce are never combined or rearranged in any way.

Here is an example, taken from the 68000 machine description:

(define_peephole
  [(set (reg:SI 15) (plus:SI (reg:SI 15) (const_int 4)))
   (set (match_operand:DF 0 "register_operand" "=f")
        (match_operand:DF 1 "register_operand" "ad"))]
  "FP_REG_P (operands[0]) && ! FP_REG_P (operands[1])"
  "*
{
  rtx xoperands[2];
  xoperands[1] = gen_rtx (REG, SImode, REGNO (operands[1]) + 1);
#ifdef MOTOROLA
  output_asm_insn (\"move.l %1,(sp)\", xoperands);
  output_asm_insn (\"move.l %1,-(sp)\", operands);
  return \"fmove.d (sp)+,%0\";
#else
  output_asm_insn (\"movel %1,sp@\", xoperands);
  output_asm_insn (\"movel %1,sp@-\", operands);
  return \"fmoved sp@+,%0\";
#endif
}
")

The effect of this optimization is to change

jbsr _foobar
addql #4,sp
movel d1,sp@-
movel d0,sp@-
fmoved sp@+,fp0

into

jbsr _foobar
movel d1,sp@
movel d0,sp@-
fmoved sp@+,fp0

insn-pattern-1 and so on look almost like the second operand of define_insn. There is one important difference: the second operand of define_insn consists of one or more RTX's enclosed in square brackets. Usually, there is only one: then the same action can be written as an element of a define_peephole. But when there are multiple actions in a define_insn, they are implicitly enclosed in a parallel. Then you must explicitly write the parallel, and the square brackets within it, in the define_peephole. Thus, if an insn pattern looks like this,

(define_insn "divmodsi4"
  [(set (match_operand:SI 0 "general_operand" "=d")
        (div:SI (match_operand:SI 1 "general_operand" "0")
                (match_operand:SI 2 "general_operand" "dmsK")))
   (set (match_operand:SI 3 "general_operand" "=d")
        (mod:SI (match_dup 1) (match_dup 2)))]
  "TARGET_68020"
  "divsl%.l %2,%3:%0")

then the way to mention this insn in a peephole is as follows:

(define_peephole
  [...
   (parallel
    [(set (match_operand:SI 0 "general_operand" "=d")
          (div:SI (match_operand:SI 1 "general_operand" "0")
                  (match_operand:SI 2 "general_operand" "dmsK")))
     (set (match_operand:SI 3 "general_operand" "=d")
          (mod:SI (match_dup 1) (match_dup 2)))])
   ...]
  ...)


Using and Porting GNU CC - Expander Definitions

Defining RTL Sequences for Code Generation

On some target machines, some standard pattern names for RTL generation cannot be handled with single insn, but a sequence of RTL insns can represent them. For these target machines, you can write a define_expand to specify how to generate the sequence of RTL.

A define_expand is an RTL expression that looks almost like a define_insn; but, unlike the latter, a define_expand is used only for RTL generation and it can produce more than one RTL insn.

A define_expand RTX has four operands:

  • The name. Each define_expand must have a name, since the only use for it is to refer to it by name.
  • The RTL template. This is just like the RTL template for a define_peephole in that it is a vector of RTL expressions each being one insn.
  • The condition, a string containing a C expression. This expression is used to express how the availability of this pattern depends on subclasses of target machine, selected by command-line options when GNU CC is run. This is just like the condition of a define_insn that has a standard name. Therefore, the condition (if present) may not depend on the data in the insn being matched, but only the target-machine-type flags. The compiler needs to test these conditions during initialization in order to learn exactly which named instructions are available in a particular run.
  • The preparation statements, a string containing zero or more C statements which are to be executed before RTL code is generated from the RTL template. Usually these statements prepare temporary registers for use as internal operands in the RTL template, but they can also generate RTL insns directly by calling routines such as emit_insn, etc. Any such insns precede the ones that come from the RTL template.

Every RTL insn emitted by a define_expand must match some define_insn in the machine description. Otherwise, the compiler will crash when trying to generate code for the insn or trying to optimize it.

The RTL template, in addition to controlling generation of RTL insns, also describes the operands that need to be specified when this pattern is used. In particular, it gives a predicate for each operand.

A true operand, which needs to be specified in order to generate RTL from the pattern, should be described with a match_operand in its first occurrence in the RTL template. This enters information on the operand's predicate into the tables that record such things. GNU CC uses the information to preload the operand into a register if that is required for valid RTL code. If the operand is referred to more than once, subsequent references should use match_dup.

The RTL template may also refer to internal "operands" which are temporary registers or labels used only within the sequence made by the define_expand. Internal operands are substituted into the RTL template with match_dup, never with match_operand. The values of the internal operands are not passed in as arguments by the compiler when it requests use of this pattern. Instead, they are computed within the pattern, in the preparation statements. These statements compute the values and store them into the appropriate elements of operands so that match_dup can find them.

There are two special macros defined for use in the preparation statements: DONE and FAIL. Use them with a following semicolon, as a statement.

DONE
Use the DONE macro to end RTL generation for the pattern. The only RTL insns resulting from the pattern on this occasion will be those already emitted by explicit calls to emit_insn within the preparation statements; the RTL template will not be generated.
FAIL
Make the pattern fail on this occasion. When a pattern fails, it means that the pattern was not truly available. The calling routines in the compiler will try other strategies for code generation using other patterns. Failure is currently supported only for binary (addition, multiplication, shifting, etc.) and bitfield (extv, extzv, and insv) operations.

Here is an example, the definition of left-shift for the SPUR chip:

(define_expand "ashlsi3"
  [(set (match_operand:SI 0 "register_operand" "")
        (ashift:SI
          (match_operand:SI 1 "register_operand" "")
          (match_operand:SI 2 "nonmemory_operand" "")))]
  ""
  "

{
  if (GET_CODE (operands[2]) != CONST_INT
      || (unsigned) INTVAL (operands[2]) > 3)
    FAIL;
}")

This example uses define_expand so that it can generate an RTL insn for shifting when the shift-count is in the supported range of 0 to 3 but fail in other cases where machine insns aren't available. When it fails, the compiler tries another strategy using different patterns (such as, a library call).

If the compiler were able to handle nontrivial condition-strings in patterns with names, then it would be possible to use a define_insn in that case. Here is another case (zero-extension on the 68000) which makes more use of the power of define_expand:

(define_expand "zero_extendhisi2"
  [(set (match_operand:SI 0 "general_operand" "")
        (const_int 0))
   (set (strict_low_part
          (subreg:HI
            (match_dup 0)
            0))
        (match_operand:HI 1 "general_operand" ""))]
  ""
  "operands[1] = make_safe_from (operands[1], operands[0]);")

Here two RTL insns are generated, one to clear the entire output operand and the other to copy the input operand into its low half. This sequence is incorrect if the input operand refers to [the old value of] the output operand, so the preparation statement makes sure this isn't so. The function make_safe_from copies the operands[1] into a temporary register if it refers to operands[0]. It does this by emitting another RTL insn.

Finally, a third example shows the use of an internal operand. Zero-extension on the SPUR chip is done by and-ing the result against a halfword mask. But this mask cannot be represented by a const_int because the constant value is too large to be legitimate on this machine. So it must be copied into a register with force_reg and then the register used in the and.

(define_expand "zero_extendhisi2"
  [(set (match_operand:SI 0 "register_operand" "")
        (and:SI (subreg:SI
                  (match_operand:HI 1 "register_operand" "")
                  0)
                (match_dup 2)))]
  ""
  "operands[2]
     = force_reg (SImode, gen_rtx (CONST_INT,
                                   VOIDmode, 65535)); ")

Note: If the define_expand is used to serve a standard binary or unary arithmetic operation or a bitfield operation, then the last insn it generates must not be a code_label, barrier or note. It must be an insn, jump_insn or call_insn. If you don't need a real insn at the end, emit an insn to copy the result of the operation into itself. Such an insn will generate no code, but it can avoid problems in the compiler.


Using and Porting GNU CC - Insn Splitting

Defining How to Split Instructions

There are two cases where you should specify how to split a pattern into multiple insns. On machines that have instructions requiring delay slots (see section Delay Slot Scheduling) or that have instructions whose output is not available for multiple cycles (see section Specifying Function Units), the compiler phases that optimize these cases need to be able to move insns into one-instruction delay slots. However, some insns may generate more than one machine instruction. These insns cannot be placed into a delay slot.

Often you can rewrite the single insn as a list of individual insns, each corresponding to one machine instruction. The disadvantage of doing so is that it will cause the compilation to be slower and require more space. If the resulting insns are too complex, it may also suppress some optimizations. The compiler splits the insn if there is a reason to believe that it might improve instruction or delay slot scheduling.

The insn combiner phase also splits putative insns. If three insns are merged into one insn with a complex expression that cannot be matched by some define_insn pattern, the combiner phase attempts to split the complex pattern into two insns that are recognized. Usually it can break the complex pattern into two patterns by splitting out some subexpression. However, in some other cases, such as performing an addition of a large constant in two insns on a RISC machine, the way to split the addition into two insns is machine-dependent.

The define_split definition tells the compiler how to split a complex insn into several simpler insns. It looks like this:

(define_split
  [insn-pattern]
  "condition"
  [new-insn-pattern-1
   new-insn-pattern-2
   ...]
  "preparation statements")

insn-pattern is a pattern that needs to be split and condition is the final condition to be tested, as in a define_insn. When an insn matching insn-pattern and satisfying condition is found, it is replaced in the insn list with the insns given by new-insn-pattern-1, new-insn-pattern-2, etc.

The preparation statements are similar to those statements that are specified for define_expand (see section Defining RTL Sequences for Code Generation) and are executed before the new RTL is generated to prepare for the generated code or emit some insns whose pattern is not fixed. Unlike those in define_expand, however, these statements must not generate any new pseudo-registers. Once reload has completed, they also must not allocate any space in the stack frame.

Patterns are matched against insn-pattern in two different circumstances. If an insn needs to be split for delay slot scheduling or insn scheduling, the insn is already known to be valid, which means that it must have been matched by some define_insn and, if reload_completed is non-zero, is known to satisfy the constraints of that define_insn. In that case, the new insn patterns must also be insns that are matched by some define_insn and, if reload_completed is non-zero, must also satisfy the constraints of those definitions.

As an example of this usage of define_split, consider the following example from `a29k.md', which splits a sign_extend from HImode to SImode into a pair of shift insns:

(define_split
  [(set (match_operand:SI 0 "gen_reg_operand" "")
        (sign_extend:SI (match_operand:HI 1 "gen_reg_operand" "")))]
  ""
  [(set (match_dup 0)
        (ashift:SI (match_dup 1)
                   (const_int 16)))
   (set (match_dup 0)
        (ashiftrt:SI (match_dup 0)
                     (const_int 16)))]
  "
{ operands[1] = gen_lowpart (SImode, operands[1]); }")

When the combiner phase tries to split an insn pattern, it is always the case that the pattern is not matched by any define_insn. The combiner pass first tries to split a single set expression and then the same set expression inside a parallel, but followed by a clobber of a pseudo-reg to use as a scratch register. In these cases, the combiner expects exactly two new insn patterns to be generated. It will verify that these patterns match some define_insn definitions, so you need not do this test in the define_split (of course, there is no point in writing a define_split that will never produce insns that match).

Here is an example of this use of define_split, taken from `rs6000.md':

(define_split
  [(set (match_operand:SI 0 "gen_reg_operand" "")
        (plus:SI (match_operand:SI 1 "gen_reg_operand" "")
                 (match_operand:SI 2 "non_add_cint_operand" "")))]
  ""
  [(set (match_dup 0) (plus:SI (match_dup 1) (match_dup 3)))
   (set (match_dup 0) (plus:SI (match_dup 0) (match_dup 4)))]
"
{
  int low = INTVAL (operands[2]) & 0xffff;
  int high = (unsigned) INTVAL (operands[2]) >> 16;

  if (low & 0x8000)
    high++, low |= 0xffff0000;

  operands[3] = gen_rtx (CONST_INT, VOIDmode, high << 16);
  operands[4] = gen_rtx (CONST_INT, VOIDmode, low);
}")

Here the predicate non_add_cint_operand matches any const_int that is not a valid operand of a single add insn. The add with the smaller displacement is written so that it can be substituted into the address of a subsequent operation.

An example that uses a scratch register, from the same file, generates an equality comparison of a register and a large constant:

(define_split
  [(set (match_operand:CC 0 "cc_reg_operand" "")
        (compare:CC (match_operand:SI 1 "gen_reg_operand" "")
                    (match_operand:SI 2 "non_short_cint_operand" "")))
   (clobber (match_operand:SI 3 "gen_reg_operand" ""))]
  "find_single_use (operands[0], insn, 0)
   && (GET_CODE (*find_single_use (operands[0], insn, 0)) == EQ
       || GET_CODE (*find_single_use (operands[0], insn, 0)) == NE)"
  [(set (match_dup 3) (xor:SI (match_dup 1) (match_dup 4)))
   (set (match_dup 0) (compare:CC (match_dup 3) (match_dup 5)))]
  "
{
  /* Get the constant we are comparing against, C, and see what it
     looks like sign-extended to 16 bits.  Then see what constant
     could be XOR'ed with C to get the sign-extended value.  */

  int c = INTVAL (operands[2]);
  int sextc = (c << 16) >> 16;
  int xorv = c ^ sextc;

  operands[4] = gen_rtx (CONST_INT, VOIDmode, xorv);
  operands[5] = gen_rtx (CONST_INT, VOIDmode, sextc);
}")

To avoid confusion, don't write a single define_split that accepts some insns that match some define_insn as well as some insns that don't. Instead, write two separate define_split definitions, one for the insns that are valid and one for the insns that are not valid.


Using and Porting GNU CC - Insn Attributes

Instruction Attributes

In addition to describing the instruction supported by the target machine, the `md' file also defines a group of attributes and a set of values for each. Every generated insn is assigned a value for each attribute. One possible attribute would be the effect that the insn has on the machine's condition code. This attribute can then be used by NOTICE_UPDATE_CC to track the condition codes.


Using and Porting GNU CC - Defining Attributes

Defining Attributes and their Values

The define_attr expression is used to define each attribute required by the target machine. It looks like:

(define_attr name list-of-values default)

name is a string specifying the name of the attribute being defined.

list-of-values is either a string that specifies a comma-separated list of values that can be assigned to the attribute, or a null string to indicate that the attribute takes numeric values.

default is an attribute expression that gives the value of this attribute for insns that match patterns whose definition does not include an explicit value for this attribute. See section Example of Attribute Specifications, for more information on the handling of defaults. See section Constant Attributes, for information on attributes that do not depend on any particular insn.

For each defined attribute, a number of definitions are written to the `insn-attr.h' file. For cases where an explicit set of values is specified for an attribute, the following are defined:

  • A `#define' is written for the symbol `HAVE_ATTR_name'.
  • An enumeral class is defined for `attr_name' with elements of the form `upper-name_upper-value' where the attribute name and value are first converted to upper case.
  • A function `get_attr_name' is defined that is passed an insn and returns the attribute value for that insn.

For example, if the following is present in the `md' file:

(define_attr "type" "branch,fp,load,store,arith" ...)

the following lines will be written to the file `insn-attr.h'.

#define HAVE_ATTR_type
enum attr_type {TYPE_BRANCH, TYPE_FP, TYPE_LOAD,
                 TYPE_STORE, TYPE_ARITH};
extern enum attr_type get_attr_type ();

If the attribute takes numeric values, no enum type will be defined and the function to obtain the attribute's value will return int.


Using and Porting GNU CC - Expressions

Attribute Expressions

RTL expressions used to define attributes use the codes described above plus a few specific to attribute definitions, to be discussed below. Attribute value expressions must have one of the following forms:

(const_int i)
The integer i specifies the value of a numeric attribute. i must be non-negative. The value of a numeric attribute can be specified either with a const_int or as an integer represented as a string in const_string, eq_attr (see below), and set_attr (see section Assigning Attribute Values to Insns) expressions.
(const_string value)
The string value specifies a constant attribute value. If value is specified as `"*"', it means that the default value of the attribute is to be used for the insn containing this expression. `"*"' obviously cannot be used in the default expression of a define_attr. If the attribute whose value is being specified is numeric, value must be a string containing a non-negative integer (normally const_int would be used in this case). Otherwise, it must contain one of the valid values for the attribute.
(if_then_else test true-value false-value)
test specifies an attribute test, whose format is defined below. The value of this expression is true-value if test is true, otherwise it is false-value.
(cond [test1 value1 ...] default)
The first operand of this expression is a vector containing an even number of expressions and consisting of pairs of test and value expressions. The value of the cond expression is that of the value corresponding to the first true test expression. If none of the test expressions are true, the value of the cond expression is that of the default expression.

test expressions can have one of the following forms:

(const_int i)
This test is true if i is non-zero and false otherwise.
(not test)
(ior test1 test2)
(and test1 test2)
These tests are true if the indicated logical function is true.
(match_operand:m n pred constraints)
This test is true if operand n of the insn whose attribute value is being determined has mode m (this part of the test is ignored if m is VOIDmode) and the function specified by the string pred returns a non-zero value when passed operand n and mode m (this part of the test is ignored if pred is the null string). The constraints operand is ignored and should be the null string.
(le arith1 arith2)
(leu arith1 arith2)
(lt arith1 arith2)
(ltu arith1 arith2)
(gt arith1 arith2)
(gtu arith1 arith2)
(ge arith1 arith2)
(geu arith1 arith2)
(ne arith1 arith2)
(eq arith1 arith2)
These tests are true if the indicated comparison of the two arithmetic expressions is true. Arithmetic expressions are formed with plus, minus, mult, div, mod, abs, neg, and, ior, xor, not, ashift, lshiftrt, and ashiftrt expressions. const_int and symbol_ref are always valid terms (see section Computing the Length of an Insn,for additional forms). symbol_ref is a string denoting a C expression that yields an int when evaluated by the `get_attr_...' routine. It should normally be a global variable.
(eq_attr name value)
name is a string specifying the name of an attribute. value is a string that is either a valid value for attribute name, a comma-separated list of values, or `!' followed by a value or list. If value does not begin with a `!', this test is true if the value of the name attribute of the current insn is in the list specified by value. If value begins with a `!', this test is true if the attribute's value is not in the specified list. For example,
(eq_attr "type" "load,store")
is equivalent to
(ior (eq_attr "type" "load") (eq_attr "type" "store"))
If name specifies an attribute of `alternative', it refers to the value of the compiler variable which_alternative (see section C Statements for Assembler Output) and the values must be small integers. For example,
(eq_attr "alternative" "2,3")
is equivalent to
(ior (eq (symbol_ref "which_alternative") (const_int 2))
     (eq (symbol_ref "which_alternative") (const_int 3)))
Note that, for most attributes, an eq_attr test is simplified in cases where the value of the attribute being tested is known for all insns matching a particular pattern. This is by far the most common case.
(attr_flag name)
The value of an attr_flag expression is true if the flag specified by name is true for the insn currently being scheduled. name is a string specifying one of a fixed set of flags to test. Test the flags forward and backward to determine the direction of a conditional branch. Test the flags very_likely, likely, very_unlikely, and unlikely to determine if a conditional branch is expected to be taken. If the very_likely flag is true, then the likely flag is also true. Likewise for the very_unlikely and unlikely flags. This example describes a conditional branch delay slot which can be nullified for forward branches that are taken (annul-true) or for backward branches which are not taken (annul-false).
(define_delay (eq_attr "type" "cbranch")
  [(eq_attr "in_branch_delay" "true")
   (and (eq_attr "in_branch_delay" "true")
        (attr_flag "forward"))
   (and (eq_attr "in_branch_delay" "true")
        (attr_flag "backward"))])
The forward and backward flags are false if the current insn being scheduled is not a conditional branch. The very_likely and likely flags are true if the insn being scheduled is not a conditional branch. The very_unlikely and unlikely flags are false if the insn being scheduled is not a conditional branch. attr_flag is only used during delay slot scheduling and has no meaning to other passes of the compiler.


Using and Porting GNU CC - Tagging Insns

Assigning Attribute Values to Insns

The value assigned to an attribute of an insn is primarily determined by which pattern is matched by that insn (or which define_peephole generated it). Every define_insn and define_peephole can have an optional last argument to specify the values of attributes for matching insns. The value of any attribute not specified in a particular insn is set to the default value for that attribute, as specified in its define_attr. Extensive use of default values for attributes permits the specification of the values for only one or two attributes in the definition of most insn patterns, as seen in the example in the next section.

The optional last argument of define_insn and define_peephole is a vector of expressions, each of which defines the value for a single attribute. The most general way of assigning an attribute's value is to use a set expression whose first operand is an attr expression giving the name of the attribute being set. The second operand of the set is an attribute expression (see section Attribute Expressions) giving the value of the attribute.

When the attribute value depends on the `alternative' attribute (i.e., which is the applicable alternative in the constraint of the insn), the set_attr_alternative expression can be used. It allows the specification of a vector of attribute expressions, one for each alternative.

When the generality of arbitrary attribute expressions is not required, the simpler set_attr expression can be used, which allows specifying a string giving either a single attribute value or a list of attribute values, one for each alternative.

The form of each of the above specifications is shown below. In each case, name is a string specifying the attribute to be set.

(set_attr name value-string)
value-string is either a string giving the desired attribute value, or a string containing a comma-separated list giving the values for succeeding alternatives. The number of elements must match the number of alternatives in the constraint of the insn pattern. Note that it may be useful to specify `*' for some alternative, in which case the attribute will assume its default value for insns matching that alternative.
(set_attr_alternative name [value1 value2 ...])
Depending on the alternative of the insn, the value will be one of the specified values. This is a shorthand for using a cond with tests on the `alternative' attribute.
(set (attr name) value)
The first operand of this set must be the special RTL expression attr, whose sole operand is a string giving the name of the attribute being set. value is the value of the attribute.

The following shows three different ways of representing the same attribute value specification:

(set_attr "type" "load,store,arith")

(set_attr_alternative "type"
                      [(const_string "load") (const_string "store")
                       (const_string "arith")])

(set (attr "type")
     (cond [(eq_attr "alternative" "1") (const_string "load")
            (eq_attr "alternative" "2") (const_string "store")]
           (const_string "arith")))

The define_asm_attributes expression provides a mechanism to specify the attributes assigned to insns produced from an asm statement. It has the form:

(define_asm_attributes [attr-sets])

where attr-sets is specified the same as for both the define_insn and the define_peephole expressions.

These values will typically be the "worst case" attribute values. For example, they might indicate that the condition code will be clobbered.

A specification for a length attribute is handled specially. The way to compute the length of an asm insn is to multiply the length specified in the expression define_asm_attributes by the number of machine instructions specified in the asm statement, determined by counting the number of semicolons and newlines in the string. Therefore, the value of the length attribute specified in a define_asm_attributes should be the maximum possible length of a single machine instruction.


Using and Porting GNU CC - Attr Example

Example of Attribute Specifications

The judicious use of defaulting is important in the efficient use of insn attributes. Typically, insns are divided into types and an attribute, customarily called type, is used to represent this value. This attribute is normally used only to define the default value for other attributes. An example will clarify this usage.

Assume we have a RISC machine with a condition code and in which only full-word operations are performed in registers. Let us assume that we can divide all insns into loads, stores, (integer) arithmetic operations, floating point operations, and branches.

Here we will concern ourselves with determining the effect of an insn on the condition code and will limit ourselves to the following possible effects: The condition code can be set unpredictably (clobbered), not be changed, be set to agree with the results of the operation, or only changed if the item previously set into the condition code has been modified.

Here is part of a sample `md' file for such a machine:

(define_attr "type" "load,store,arith,fp,branch" (const_string "arith"))

(define_attr "cc" "clobber,unchanged,set,change0"
             (cond [(eq_attr "type" "load")
                        (const_string "change0")
                    (eq_attr "type" "store,branch")
                        (const_string "unchanged")
                    (eq_attr "type" "arith")
                        (if_then_else (match_operand:SI 0 "" "")
                                      (const_string "set")
                                      (const_string "clobber"))]
                   (const_string "clobber")))

(define_insn ""
  [(set (match_operand:SI 0 "general_operand" "=r,r,m")
        (match_operand:SI 1 "general_operand" "r,m,r"))]
  ""
  "@
   move %0,%1
   load %0,%1
   store %0,%1"
  [(set_attr "type" "arith,load,store")])

Note that we assume in the above example that arithmetic operations performed on quantities smaller than a machine word clobber the condition code since they will set the condition code to a value corresponding to the full-word result.


Using and Porting GNU CC - Insn Lengths

Computing the Length of an Insn

For many machines, multiple types of branch instructions are provided, each for different length branch displacements. In most cases, the assembler will choose the correct instruction to use. However, when the assembler cannot do so, GCC can when a special attribute, the `length' attribute, is defined. This attribute must be defined to have numeric values by specifying a null string in its define_attr.

In the case of the `length' attribute, two additional forms of arithmetic terms are allowed in test expressions:

(match_dup n)
This refers to the address of operand n of the current insn, which must be a label_ref.
(pc)
This refers to the address of the current insn. It might have been more consistent with other usage to make this the address of the next insn but this would be confusing because the length of the current insn is to be computed.

For normal insns, the length will be determined by value of the `length' attribute. In the case of addr_vec and addr_diff_vec insn patterns, the length is computed as the number of vectors multiplied by the size of each vector.

Lengths are measured in addressable storage units (bytes).

The following macros can be used to refine the length computation:

FIRST_INSN_ADDRESS
When the length insn attribute is used, this macro specifies the value to be assigned to the address of the first insn in a function. If not specified, 0 is used.
ADJUST_INSN_LENGTH (insn, length)
If defined, modifies the length assigned to instruction insn as a function of the context in which it is used. length is an lvalue that contains the initially computed length of the insn and should be updated with the correct length of the insn. If updating is required, insn must not be a varying-length insn. This macro will normally not be required. A case in which it is required is the ROMP. On this machine, the size of an addr_vec insn must be increased by two to compensate for the fact that alignment may be required.

The routine that returns get_attr_length (the value of the length attribute) can be used by the output routine to determine the form of the branch instruction to be written, as the example below illustrates.

As an example of the specification of variable-length branches, consider the IBM 360. If we adopt the convention that a register will be set to the starting address of a function, we can jump to labels within 4k of the start using a four-byte instruction. Otherwise, we need a six-byte sequence to load the address from memory and then branch to it.

On such a machine, a pattern for a branch instruction might be specified as follows:

(define_insn "jump"
  [(set (pc)
        (label_ref (match_operand 0 "" "")))]
  ""
  "*
{
   return (get_attr_length (insn) == 4
           ? \"b %l0\" : \"l r15,=a(%l0); br r15\");
}"
  [(set (attr "length") (if_then_else (lt (match_dup 0) (const_int 4096))
                                      (const_int 4)
                                      (const_int 6)))])


Using and Porting GNU CC - Constant Attributes

Constant Attributes

A special form of define_attr, where the expression for the default value is a const expression, indicates an attribute that is constant for a given run of the compiler. Constant attributes may be used to specify which variety of processor is used. For example,

(define_attr "cpu" "m88100,m88110,m88000"
 (const
  (cond [(symbol_ref "TARGET_88100") (const_string "m88100")
         (symbol_ref "TARGET_88110") (const_string "m88110")]
        (const_string "m88000"))))

(define_attr "memory" "fast,slow"
 (const
  (if_then_else (symbol_ref "TARGET_FAST_MEM")
                (const_string "fast")
                (const_string "slow"))))

The routine generated for constant attributes has no parameters as it does not depend on any particular insn. RTL expressions used to define the value of a constant attribute may use the symbol_ref form, but may not use either the match_operand form or eq_attr forms involving insn attributes.


Using and Porting GNU CC - Delay Slots

Delay Slot Scheduling

The insn attribute mechanism can be used to specify the requirements for delay slots, if any, on a target machine. An instruction is said to require a delay slot if some instructions that are physically after the instruction are executed as if they were located before it. Classic examples are branch and call instructions, which often execute the following instruction before the branch or call is performed.

On some machines, conditional branch instructions can optionally annul instructions in the delay slot. This means that the instruction will not be executed for certain branch outcomes. Both instructions that annul if the branch is true and instructions that annul if the branch is false are supported.

Delay slot scheduling differs from instruction scheduling in that determining whether an instruction needs a delay slot is dependent only on the type of instruction being generated, not on data flow between the instructions. See the next section for a discussion of data-dependent instruction scheduling.

The requirement of an insn needing one or more delay slots is indicated via the define_delay expression. It has the following form:

(define_delay test
              [delay-1 annul-true-1 annul-false-1
               delay-2 annul-true-2 annul-false-2
               ...])

test is an attribute test that indicates whether this define_delay applies to a particular insn. If so, the number of required delay slots is determined by the length of the vector specified as the second argument. An insn placed in delay slot n must satisfy attribute test delay-n. annul-true-n is an attribute test that specifies which insns may be annulled if the branch is true. Similarly, annul-false-n specifies which insns in the delay slot may be annulled if the branch is false. If annulling is not supported for that delay slot, (nil) should be coded.

For example, in the common case where branch and call insns require a single delay slot, which may contain any insn other than a branch or call, the following would be placed in the `md' file:

(define_delay (eq_attr "type" "branch,call")
              [(eq_attr "type" "!branch,call") (nil) (nil)])

Multiple define_delay expressions may be specified. In this case, each such expression specifies different delay slot requirements and there must be no insn for which tests in two define_delay expressions are both true.

For example, if we have a machine that requires one delay slot for branches but two for calls, no delay slot can contain a branch or call insn, and any valid insn in the delay slot for the branch can be annulled if the branch is true, we might represent this as follows:

(define_delay (eq_attr "type" "branch")
   [(eq_attr "type" "!branch,call")
    (eq_attr "type" "!branch,call")
    (nil)])

(define_delay (eq_attr "type" "call")
              [(eq_attr "type" "!branch,call") (nil) (nil)
               (eq_attr "type" "!branch,call") (nil) (nil)])


Using and Porting GNU CC - Function Units

Specifying Function Units

On most RISC machines, there are instructions whose results are not available for a specific number of cycles. Common cases are instructions that load data from memory. On many machines, a pipeline stall will result if the data is referenced too soon after the load instruction.

In addition, many newer microprocessors have multiple function units, usually one for integer and one for floating point, and often will incur pipeline stalls when a result that is needed is not yet ready.

The descriptions in this section allow the specification of how much time must elapse between the execution of an instruction and the time when its result is used. It also allows specification of when the execution of an instruction will delay execution of similar instructions due to function unit conflicts.

For the purposes of the specifications in this section, a machine is divided into function units, each of which execute a specific class of instructions in first-in-first-out order. Function units that accept one instruction each cycle and allow a result to be used in the succeeding instruction (usually via forwarding) need not be specified. Classic RISC microprocessors will normally have a single function unit, which we can call `memory'. The newer "superscalar" processors will often have function units for floating point operations, usually at least a floating point adder and multiplier.

Each usage of a function units by a class of insns is specified with a define_function_unit expression, which looks like this:

(define_function_unit name multiplicity simultaneity
                      test ready-delay issue-delay
                     [conflict-list])

name is a string giving the name of the function unit.

multiplicity is an integer specifying the number of identical units in the processor. If more than one unit is specified, they will be scheduled independently. Only truly independent units should be counted; a pipelined unit should be specified as a single unit. (The only common example of a machine that has multiple function units for a single instruction class that are truly independent and not pipelined are the two multiply and two increment units of the CDC 6600.)

simultaneity specifies the maximum number of insns that can be executing in each instance of the function unit simultaneously or zero if the unit is pipelined and has no limit.

All define_function_unit definitions referring to function unit name must have the same name and values for multiplicity and simultaneity.

test is an attribute test that selects the insns we are describing in this definition. Note that an insn may use more than one function unit and a function unit may be specified in more than one define_function_unit.

ready-delay is an integer that specifies the number of cycles after which the result of the instruction can be used without introducing any stalls.

issue-delay is an integer that specifies the number of cycles after the instruction matching the test expression begins using this unit until a subsequent instruction can begin. A cost of N indicates an N-1 cycle delay. A subsequent instruction may also be delayed if an earlier instruction has a longer ready-delay value. This blocking effect is computed using the simultaneity, ready-delay, issue-delay, and conflict-list terms. For a normal non-pipelined function unit, simultaneity is one, the unit is taken to block for the ready-delay cycles of the executing insn, and smaller values of issue-delay are ignored.

conflict-list is an optional list giving detailed conflict costs for this unit. If specified, it is a list of condition test expressions to be applied to insns chosen to execute in name following the particular insn matching test that is already executing in name. For each insn in the list, issue-delay specifies the conflict cost; for insns not in the list, the cost is zero. If not specified, conflict-list defaults to all instructions that use the function unit.

Typical uses of this vector are where a floating point function unit can pipeline either single- or double-precision operations, but not both, or where a memory unit can pipeline loads, but not stores, etc.

As an example, consider a classic RISC machine where the result of a load instruction is not available for two cycles (a single "delay" instruction is required) and where only one load instruction can be executed simultaneously. This would be specified as:

(define_function_unit "memory" 1 1 (eq_attr "type" "load") 2 0)

For the case of a floating point function unit that can pipeline either single or double precision, but not both, the following could be specified:

(define_function_unit
   "fp" 1 0 (eq_attr "type" "sp_fp") 4 4 [(eq_attr "type" "dp_fp")])
(define_function_unit
   "fp" 1 0 (eq_attr "type" "dp_fp") 4 4 [(eq_attr "type" "sp_fp")])

Note: The scheduler attempts to avoid function unit conflicts and uses all the specifications in the define_function_unit expression. It has recently come to our attention that these specifications may not allow modeling of some of the newer "superscalar" processors that have insns using multiple pipelined units. These insns will cause a potential conflict for the second unit used during their execution and there is no way of representing that conflict. We welcome any examples of how function unit conflicts work in such processors and suggestions for their representation.


Using and Porting GNU CC - Target Macros

Target Description Macros

In addition to the file `machine.md', a machine description includes a C header file conventionally given the name `machine.h'. This header file defines numerous macros that convey the information about the target machine that does not fit into the scheme of the `.md' file. The file `tm.h' should be a link to `machine.h'. The header file `config.h' includes `tm.h' and most compiler source files include `config.h'.


Using and Porting GNU CC - Driver

Controlling the Compilation Driver, `gcc'

You can control the compilation driver.

SWITCH_TAKES_ARG (char)
A C expression which determines whether the option `-char' takes arguments. The value should be the number of arguments that option takes--zero, for many options. By default, this macro is defined as DEFAULT_SWITCH_TAKES_ARG, which handles the standard options properly. You need not define SWITCH_TAKES_ARG unless you wish to add additional options which take arguments. Any redefinition should call DEFAULT_SWITCH_TAKES_ARG and then check for additional options.
WORD_SWITCH_TAKES_ARG (name)
A C expression which determines whether the option `-name' takes arguments. The value should be the number of arguments that option takes--zero, for many options. This macro rather than SWITCH_TAKES_ARG is used for multi-character option names. By default, this macro is defined as DEFAULT_WORD_SWITCH_TAKES_ARG, which handles the standard options properly. You need not define WORD_SWITCH_TAKES_ARG unless you wish to add additional options which take arguments. Any redefinition should call DEFAULT_WORD_SWITCH_TAKES_ARG and then check for additional options.
SWITCHES_NEED_SPACES
A string-valued C expression which enumerates the options for which the linker needs a space between the option and its argument. If this macro is not defined, the default value is "".
CPP_SPEC
A C string constant that tells the GNU CC driver program options to pass to CPP. It can also specify how to translate options you give to GNU CC into options for GNU CC to pass to the CPP. Do not define this macro if it does not need to do anything.
NO_BUILTIN_SIZE_TYPE
If this macro is defined, the preprocessor will not define the builtin macro __SIZE_TYPE__. The macro __SIZE_TYPE__ must then be defined by CPP_SPEC instead. This should be defined if SIZE_TYPE depends on target dependent flags which are not accessible to the preprocessor. Otherwise, it should not be defined.
NO_BUILTIN_PTRDIFF_TYPE
If this macro is defined, the preprocessor will not define the builtin macro __PTRDIFF_TYPE__. The macro __PTRDIFF_TYPE__ must then be defined by CPP_SPEC instead. This should be defined if PTRDIFF_TYPE depends on target dependent flags which are not accessible to the preprocessor. Otherwise, it should not be defined.
SIGNED_CHAR_SPEC
A C string constant that tells the GNU CC driver program options to pass to CPP. By default, this macro is defined to pass the option `-D__CHAR_UNSIGNED__' to CPP if char will be treated as unsigned char by cc1. Do not define this macro unless you need to override the default definition.
CC1_SPEC
A C string constant that tells the GNU CC driver program options to pass to cc1. It can also specify how to translate options you give to GNU CC into options for GNU CC to pass to the cc1. Do not define this macro if it does not need to do anything.
CC1PLUS_SPEC
A C string constant that tells the GNU CC driver program options to pass to cc1plus. It can also specify how to translate options you give to GNU CC into options for GNU CC to pass to the cc1plus. Do not define this macro if it does not need to do anything.
ASM_SPEC
A C string constant that tells the GNU CC driver program options to pass to the assembler. It can also specify how to translate options you give to GNU CC into options for GNU CC to pass to the assembler. See the file `sun3.h' for an example of this. Do not define this macro if it does not need to do anything.
ASM_FINAL_SPEC
A C string constant that tells the GNU CC driver program how to run any programs which cleanup after the normal assembler. Normally, this is not needed. See the file `mips.h' for an example of this. Do not define this macro if it does not need to do anything.
LINK_SPEC
A C string constant that tells the GNU CC driver program options to pass to the linker. It can also specify how to translate options you give to GNU CC into options for GNU CC to pass to the linker. Do not define this macro if it does not need to do anything.
LIB_SPEC
Another C string constant used much like LINK_SPEC. The difference between the two is that LIB_SPEC is used at the end of the command given to the linker. If this macro is not defined, a default is provided that loads the standard C library from the usual place. See `gcc.c'.
LIBGCC_SPEC
Another C string constant that tells the GNU CC driver program how and when to place a reference to `libgcc.a' into the linker command line. This constant is placed both before and after the value of LIB_SPEC. If this macro is not defined, the GNU CC driver provides a default that passes the string `-lgcc' to the linker unless the `-shared' option is specified.
STARTFILE_SPEC
Another C string constant used much like LINK_SPEC. The difference between the two is that STARTFILE_SPEC is used at the very beginning of the command given to the linker. If this macro is not defined, a default is provided that loads the standard C startup file from the usual place. See `gcc.c'.
ENDFILE_SPEC
Another C string constant used much like LINK_SPEC. The difference between the two is that ENDFILE_SPEC is used at the very end of the command given to the linker. Do not define this macro if it does not need to do anything.
EXTRA_SPECS
Define this macro to provide additional specifications to put in the `specs' file that can be used in various specifications like CC1_SPEC. The definition should be an initializer for an array of structures, containing a string constant, that defines the specification name, and a string constant that provides the specification. Do not define this macro if it does not need to do anything. EXTRA_SPECS is useful when an architecture contains several related targets, which have various ..._SPECS which are similar to each other, and the maintainer would like one central place to keep these definitions. For example, the PowerPC System V.4 targets use EXTRA_SPECS to define either _CALL_SYSV when the System V calling sequence is used or _CALL_AIX when the older AIX-based calling sequence is used. The `config/rs6000/rs6000.h' target file defines:
#define EXTRA_SPECS \
  { "cpp_sysv_default", CPP_SYSV_DEFAULT },

#define CPP_SYS_DEFAULT ""
The `config/rs6000/sysv.h' target file defines:
#undef CPP_SPEC
#define CPP_SPEC \
"%{posix: -D_POSIX_SOURCE } \
%{mcall-sysv: -D_CALL_SYSV } %{mcall-aix: -D_CALL_AIX } \
%{!mcall-sysv: %{!mcall-aix: %(cpp_sysv_default) }} \
%{msoft-float: -D_SOFT_FLOAT} %{mcpu=403: -D_SOFT_FLOAT}"

#undef CPP_SYSV_DEFAULT
#define CPP_SYSV_DEFAULT "-D_CALL_SYSV"
while the `config/rs6000/eabiaix.h' target file defines CPP_SYSV_DEFAULT as:
#undef CPP_SYSV_DEFAULT
#define CPP_SYSV_DEFAULT "-D_CALL_AIX"
LINK_LIBGCC_SPECIAL
Define this macro if the driver program should find the library `libgcc.a' itself and should not pass `-L' options to the linker. If you do not define this macro, the driver program will pass the argument `-lgcc' to tell the linker to do the search and will pass `-L' options to it.
LINK_LIBGCC_SPECIAL_1
Define this macro if the driver program should find the library `libgcc.a'. If you do not define this macro, the driver program will pass the argument `-lgcc' to tell the linker to do the search. This macro is similar to LINK_LIBGCC_SPECIAL, except that it does not affect `-L' options.
MULTILIB_DEFAULTS
Define this macro as a C expression for the initializer of an array of string to tell the driver program which options are defaults for this target and thus do not need to be handled specially when using MULTILIB_OPTIONS. Do not define this macro if MULTILIB_OPTIONS is not defined in the target makefile fragment or if none of the options listed in MULTILIB_OPTIONS are set by default. See section The Target Makefile Fragment.
RELATIVE_PREFIX_NOT_LINKDIR
Define this macro to tell gcc that it should only translate a `-B' prefix into a `-L' linker option if the prefix indicates an absolute file name.
STANDARD_EXEC_PREFIX
Define this macro as a C string constant if you wish to override the standard choice of `/usr/local/lib/gcc-lib/' as the default prefix to try when searching for the executable files of the compiler.
MD_EXEC_PREFIX
If defined, this macro is an additional prefix to try after STANDARD_EXEC_PREFIX. MD_EXEC_PREFIX is not searched when the `-b' option is used, or the compiler is built as a cross compiler.
STANDARD_STARTFILE_PREFIX
Define this macro as a C string constant if you wish to override the standard choice of `/usr/local/lib/' as the default prefix to try when searching for startup files such as `crt0.o'.
MD_STARTFILE_PREFIX
If defined, this macro supplies an additional prefix to try after the standard prefixes. MD_EXEC_PREFIX is not searched when the `-b' option is used, or when the compiler is built as a cross compiler.
MD_STARTFILE_PREFIX_1
If defined, this macro supplies yet another prefix to try after the standard prefixes. It is not searched when the `-b' option is used, or when the compiler is built as a cross compiler.
INIT_ENVIRONMENT
Define this macro as a C string constant if you with to set environment variables for programs called by the driver, such as the assembler and loader. The driver passes the value of this macro to putenv to initialize the necessary environment variables.
LOCAL_INCLUDE_DIR
Define this macro as a C string constant if you wish to override the standard choice of `/usr/local/include' as the default prefix to try when searching for local header files. LOCAL_INCLUDE_DIR comes before SYSTEM_INCLUDE_DIR in the search order. Cross compilers do not use this macro and do not search either `/usr/local/include' or its replacement.
SYSTEM_INCLUDE_DIR
Define this macro as a C string constant if you wish to specify a system-specific directory to search for header files before the standard directory. SYSTEM_INCLUDE_DIR comes before STANDARD_INCLUDE_DIR in the search order. Cross compilers do not use this macro and do not search the directory specified.
STANDARD_INCLUDE_DIR
Define this macro as a C string constant if you wish to override the standard choice of `/usr/include' as the default prefix to try when searching for header files. Cross compilers do not use this macro and do not search either `/usr/include' or its replacement.
INCLUDE_DEFAULTS
Define this macro if you wish to override the entire default search path for include files. The default search path includes GCC_INCLUDE_DIR, LOCAL_INCLUDE_DIR, SYSTEM_INCLUDE_DIR, GPLUSPLUS_INCLUDE_DIR, and STANDARD_INCLUDE_DIR. In addition, GPLUSPLUS_INCLUDE_DIR and GCC_INCLUDE_DIR are defined automatically by `Makefile', and specify private search areas for GCC. The directory GPLUSPLUS_INCLUDE_DIR is used only for C++ programs. The definition should be an initializer for an array of structures. Each array element should have two elements: the directory name (a string constant) and a flag for C++-only directories. Mark the end of the array with a null element. For example, here is the definition used for VMS:
#define INCLUDE_DEFAULTS \
{                                       \
  { "GNU_GXX_INCLUDE:", 1},             \
  { "GNU_CC_INCLUDE:", 0},              \
  { "SYS$SYSROOT:[SYSLIB.]", 0},        \
  { ".", 0},                            \
  { 0, 0}                               \
}

Here is the order of prefixes tried for exec files:

  1. Any prefixes specified by the user with `-B'.
  2. The environment variable GCC_EXEC_PREFIX, if any.
  3. The directories specified by the environment variable COMPILER_PATH.
  4. The macro STANDARD_EXEC_PREFIX.
  5. `/usr/lib/gcc/'.
  6. The macro MD_EXEC_PREFIX, if any.

Here is the order of prefixes tried for startfiles:

  1. Any prefixes specified by the user with `-B'.
  2. The environment variable GCC_EXEC_PREFIX, if any.
  3. The directories specified by the environment variable LIBRARY_PATH (native only, cross compilers do not use this).
  4. The macro STANDARD_EXEC_PREFIX.
  5. `/usr/lib/gcc/'.
  6. The macro MD_EXEC_PREFIX, if any.
  7. The macro MD_STARTFILE_PREFIX, if any.
  8. The macro STANDARD_STARTFILE_PREFIX.
  9. `/lib/'.
  10. `/usr/lib/'.


Using and Porting GNU CC - Run-time Target

Run-time Target Specification

Here are run-time target specifications.

CPP_PREDEFINES
Define this to be a string constant containing `-D' options to define the predefined macros that identify this machine and system. These macros will be predefined unless the `-ansi' option is specified. In addition, a parallel set of macros are predefined, whose names are made by appending `__' at the beginning and at the end. These `__' macros are permitted by the ANSI standard, so they are predefined regardless of whether `-ansi' is specified. For example, on the Sun, one can use the following value:
"-Dmc68000 -Dsun -Dunix"
The result is to define the macros __mc68000__, __sun__ and __unix__ unconditionally, and the macros mc68000, sun and unix provided `-ansi' is not specified.
extern int target_flags;
This declaration should be present.
TARGET_...
This series of macros is to allow compiler command arguments to enable or disable the use of optional features of the target machine. For example, one machine description serves both the 68000 and the 68020; a command argument tells the compiler whether it should use 68020-only instructions or not. This command argument works by means of a macro TARGET_68020 that tests a bit in target_flags. Define a macro TARGET_featurename for each such option. Its definition should test a bit in target_flags; for example:
#define TARGET_68020 (target_flags & 1)
One place where these macros are used is in the condition-expressions of instruction patterns. Note how TARGET_68020 appears frequently in the 68000 machine description file, `m68k.md'. Another place they are used is in the definitions of the other macros in the `machine.h' file.
TARGET_SWITCHES
This macro defines names of command options to set and clear bits in target_flags. Its definition is an initializer with a subgrouping for each command option. Each subgrouping contains a string constant, that defines the option name, and a number, which contains the bits to set in target_flags. A negative number says to clear bits instead; the negative of the number is which bits to clear. The actual option name is made by appending `-m' to the specified name. One of the subgroupings should have a null string. The number in this grouping is the default value for target_flags. Any target options act starting with that value. Here is an example which defines `-m68000' and `-m68020' with opposite meanings, and picks the latter as the default:
#define TARGET_SWITCHES \
  { { "68020", 1},      \
    { "68000", -1},     \
    { "", 1}}
TARGET_OPTIONS
This macro is similar to TARGET_SWITCHES but defines names of command options that have values. Its definition is an initializer with a subgrouping for each command option. Each subgrouping contains a string constant, that defines the fixed part of the option name, and the address of a variable. The variable, type char *, is set to the variable part of the given option if the fixed part matches. The actual option name is made by appending `-m' to the specified name. Here is an example which defines `-mshort-data-number'. If the given option is `-mshort-data-512', the variable m88k_short_data will be set to the string "512".
extern char *m88k_short_data;
#define TARGET_OPTIONS \
 { { "short-data-", &m88k_short_data } }
TARGET_VERSION
This macro is a C statement to print on stderr a string describing the particular machine description choice. Every machine description should define TARGET_VERSION. For example:
#ifdef MOTOROLA
#define TARGET_VERSION \
  fprintf (stderr, " (68k, Motorola syntax)");
#else
#define TARGET_VERSION \
  fprintf (stderr, " (68k, MIT syntax)");
#endif
OVERRIDE_OPTIONS
Sometimes certain combinations of command options do not make sense on a particular target machine. You can define a macro OVERRIDE_OPTIONS to take account of this. This macro, if defined, is executed once just after all the command options have been parsed. Don't use this macro to turn on various extra optimizations for `-O'. That is what OPTIMIZATION_OPTIONS is for.
OPTIMIZATION_OPTIONS (level)
Some machines may desire to change what optimizations are performed for various optimization levels. This macro, if defined, is executed once just after the optimization level is determined and before the remainder of the command options have been parsed. Values set in this macro are used as the default values for the other command line options. level is the optimization level specified; 2 if `-O2' is specified, 1 if `-O' is specified, and 0 if neither is specified. You should not use this macro to change options that are not machine-specific. These should uniformly selected by the same optimization level on all supported machines. Use this macro to enable machine-specific optimizations. Do not examine write_symbols in this macro! The debugging options are not supposed to alter the generated code.
CAN_DEBUG_WITHOUT_FP
Define this macro if debugging can be performed even without a frame pointer. If this macro is defined, GNU CC will turn on the `-fomit-frame-pointer' option whenever `-O' is specified.


Using and Porting GNU CC - Storage Layout

Storage Layout

Note that the definitions of the macros in this table which are sizes or alignments measured in bits do not need to be constant. They can be C expressions that refer to static variables, such as the target_flags. See section Run-time Target Specification.

BITS_BIG_ENDIAN
Define this macro to have the value 1 if the most significant bit in a byte has the lowest number; otherwise define it to have the value zero. This means that bit-field instructions count from the most significant bit. If the machine has no bit-field instructions, then this must still be defined, but it doesn't matter which value it is defined to. This macro need not be a constant. This macro does not affect the way structure fields are packed into bytes or words; that is controlled by BYTES_BIG_ENDIAN.
BYTES_BIG_ENDIAN
Define this macro to have the value 1 if the most significant byte in a word has the lowest number. This macro need not be a constant.
WORDS_BIG_ENDIAN
Define this macro to have the value 1 if, in a multiword object, the most significant word has the lowest number. This applies to both memory locations and registers; GNU CC fundamentally assumes that the order of words in memory is the same as the order in registers. This macro need not be a constant.
LIBGCC2_WORDS_BIG_ENDIAN
Define this macro if WORDS_BIG_ENDIAN is not constant. This must be a constant value with the same meaning as WORDS_BIG_ENDIAN, which will be used only when compiling libgcc2.c. Typically the value will be set based on preprocessor defines.
FLOAT_WORDS_BIG_ENDIAN
Define this macro to have the value 1 if DFmode, XFmode or TFmode floating point numbers are stored in memory with the word containing the sign bit at the lowest address; otherwise define it to have the value 0. This macro need not be a constant. You need not define this macro if the ordering is the same as for multi-word integers.
BITS_PER_UNIT
Define this macro to be the number of bits in an addressable storage unit (byte); normally 8.
BITS_PER_WORD
Number of bits in a word; normally 32.
MAX_BITS_PER_WORD
Maximum number of bits in a word. If this is undefined, the default is BITS_PER_WORD. Otherwise, it is the constant value that is the largest value that BITS_PER_WORD can have at run-time.
UNITS_PER_WORD
Number of storage units in a word; normally 4.
MIN_UNITS_PER_WORD
Minimum number of units in a word. If this is undefined, the default is UNITS_PER_WORD. Otherwise, it is the constant value that is the smallest value that UNITS_PER_WORD can have at run-time.
POINTER_SIZE
Width of a pointer, in bits. You must specify a value no wider than the width of Pmode. If it is not equal to the width of Pmode, you must define POINTERS_EXTEND_UNSIGNED.
POINTERS_EXTEND_UNSIGNED
A C expression whose value is nonzero if pointers that need to be extended from being POINTER_SIZE bits wide to Pmode are sign-extended and zero if they are zero-extended. You need not define this macro if the POINTER_SIZE is equal to the width of Pmode.
PROMOTE_MODE (m, unsignedp, type)
A macro to update m and unsignedp when an object whose type is type and which has the specified mode and signedness is to be stored in a register. This macro is only called when type is a scalar type. On most RISC machines, which only have operations that operate on a full register, define this macro to set m to word_mode if m is an integer mode narrower than BITS_PER_WORD. In most cases, only integer modes should be widened because wider-precision floating-point operations are usually more expensive than their narrower counterparts. For most machines, the macro definition does not change unsignedp. However, some machines, have instructions that preferentially handle either signed or unsigned quantities of certain modes. For example, on the DEC Alpha, 32-bit loads from memory and 32-bit add instructions sign-extend the result to 64 bits. On such machines, set unsignedp according to which kind of extension is more efficient. Do not define this macro if it would never modify m.
PROMOTE_FUNCTION_ARGS
Define this macro if the promotion described by PROMOTE_MODE should also be done for outgoing function arguments.
PROMOTE_FUNCTION_RETURN
Define this macro if the promotion described by PROMOTE_MODE should also be done for the return value of functions. If this macro is defined, FUNCTION_VALUE must perform the same promotions done by PROMOTE_MODE.
PROMOTE_FOR_CALL_ONLY
Define this macro if the promotion described by PROMOTE_MODE should only be performed for outgoing function arguments or function return values, as specified by PROMOTE_FUNCTION_ARGS and PROMOTE_FUNCTION_RETURN, respectively.
PARM_BOUNDARY
Normal alignment required for function parameters on the stack, in bits. All stack parameters receive at least this much alignment regardless of data type. On most machines, this is the same as the size of an integer.
STACK_BOUNDARY
Define this macro if you wish to preserve a certain alignment for the stack pointer. The definition is a C expression for the desired alignment (measured in bits). If PUSH_ROUNDING is not defined, the stack will always be aligned to the specified boundary. If PUSH_ROUNDING is defined and specifies a less strict alignment than STACK_BOUNDARY, the stack may be momentarily unaligned while pushing arguments.
FUNCTION_BOUNDARY
Alignment required for a function entry point, in bits.
BIGGEST_ALIGNMENT
Biggest alignment that any data type can require on this machine, in bits.
MINIMUM_ATOMIC_ALIGNMENT
If defined, the smallest alignment, in bits, that can be given to an object that can be referenced in one operation, without disturbing any nearby object. Normally, this is BITS_PER_UNIT, but may be larger on machines that don't have byte or half-word store operations.
BIGGEST_FIELD_ALIGNMENT
Biggest alignment that any structure field can require on this machine, in bits. If defined, this overrides BIGGEST_ALIGNMENT for structure fields only.
ADJUST_FIELD_ALIGN (field, computed)
An expression for the alignment of a structure field field if the alignment computed in the usual way is computed. GNU CC uses this value instead of the value in BIGGEST_ALIGNMENT or BIGGEST_FIELD_ALIGNMENT, if defined, for structure fields only.
MAX_OFILE_ALIGNMENT
Biggest alignment supported by the object file format of this machine. Use this macro to limit the alignment which can be specified using the __attribute__ ((aligned (n))) construct. If not defined, the default value is BIGGEST_ALIGNMENT.
DATA_ALIGNMENT (type, basic-align)
If defined, a C expression to compute the alignment for a static variable. type is the data type, and basic-align is the alignment that the object would ordinarily have. The value of this macro is used instead of that alignment to align the object. If this macro is not defined, then basic-align is used. One use of this macro is to increase alignment of medium-size data to make it all fit in fewer cache lines. Another is to cause character arrays to be word-aligned so that strcpy calls that copy constants to character arrays can be done inline.
CONSTANT_ALIGNMENT (constant, basic-align)
If defined, a C expression to compute the alignment given to a constant that is being placed in memory. constant is the constant and basic-align is the alignment that the object would ordinarily have. The value of this macro is used instead of that alignment to align the object. If this macro is not defined, then basic-align is used. The typical use of this macro is to increase alignment for string constants to be word aligned so that strcpy calls that copy constants can be done inline.
EMPTY_FIELD_BOUNDARY
Alignment in bits to be given to a structure bit field that follows an empty field such as int : 0;. Note that PCC_BITFIELD_TYPE_MATTERS also affects the alignment that results from an empty field.
STRUCTURE_SIZE_BOUNDARY
Number of bits which any structure or union's size must be a multiple of. Each structure or union's size is rounded up to a multiple of this. If you do not define this macro, the default is the same as BITS_PER_UNIT.
STRICT_ALIGNMENT
Define this macro to be the value 1 if instructions will fail to work if given data not on the nominal alignment. If instructions will merely go slower in that case, define this macro as 0.
PCC_BITFIELD_TYPE_MATTERS
Define this if you wish to imitate the way many other C compilers handle alignment of bitfields and the structures that contain them. The behavior is that the type written for a bitfield (int, short, or other integer type) imposes an alignment for the entire structure, as if the structure really did contain an ordinary field of that type. In addition, the bitfield is placed within the structure so that it would fit within such a field, not crossing a boundary for it. Thus, on most machines, a bitfield whose type is written as int would not cross a four-byte boundary, and would force four-byte alignment for the whole structure. (The alignment used may not be four bytes; it is controlled by the other alignment parameters.) If the macro is defined, its definition should be a C expression; a nonzero value for the expression enables this behavior. Note that if this macro is not defined, or its value is zero, some bitfields may cross more than one alignment boundary. The compiler can support such references if there are `insv', `extv', and `extzv' insns that can directly reference memory. The other known way of making bitfields work is to define STRUCTURE_SIZE_BOUNDARY as large as BIGGEST_ALIGNMENT. Then every structure can be accessed with fullwords. Unless the machine has bitfield instructions or you define STRUCTURE_SIZE_BOUNDARY that way, you must define PCC_BITFIELD_TYPE_MATTERS to have a nonzero value. If your aim is to make GNU CC use the same conventions for laying out bitfields as are used by another compiler, here is how to investigate what the other compiler does. Compile and run this program:
struct foo1
{
  char x;
  char :0;
  char y;
};

struct foo2
{
  char x;
  int :0;
  char y;
};

main ()
{
  printf ("Size of foo1 is %d\n",
          sizeof (struct foo1));
  printf ("Size of foo2 is %d\n",
          sizeof (struct foo2));
  exit (0);
}
If this prints 2 and 5, then the compiler's behavior is what you would get from PCC_BITFIELD_TYPE_MATTERS.
BITFIELD_NBYTES_LIMITED
Like PCC_BITFIELD_TYPE_MATTERS except that its effect is limited to aligning a bitfield within the structure.
ROUND_TYPE_SIZE (struct, size, align)
Define this macro as an expression for the overall size of a structure (given by struct as a tree node) when the size computed from the fields is size and the alignment is align. The default is to round size up to a multiple of align.
ROUND_TYPE_ALIGN (struct, computed, specified)
Define this macro as an expression for the alignment of a structure (given by struct as a tree node) if the alignment computed in the usual way is computed and the alignment explicitly specified was specified. The default is to use specified if it is larger; otherwise, use the smaller of computed and BIGGEST_ALIGNMENT
MAX_FIXED_MODE_SIZE
An integer expression for the size in bits of the largest integer machine mode that should actually be used. All integer machine modes of this size or smaller can be used for structures and unions with the appropriate sizes. If this macro is undefined, GET_MODE_BITSIZE (DImode) is assumed.
CHECK_FLOAT_VALUE (mode, value, overflow)
A C statement to validate the value value (of type double) for mode mode. This means that you check whether value fits within the possible range of values for mode mode on this target machine. The mode mode is always a mode of class MODE_FLOAT. overflow is nonzero if the value is already known to be out of range. If value is not valid or if overflow is nonzero, you should set overflow to 1 and then assign some valid value to value. Allowing an invalid value to go through the compiler can produce incorrect assembler code which may even cause Unix assemblers to crash. This macro need not be defined if there is no work for it to do.
TARGET_FLOAT_FORMAT
A code distinguishing the floating point format of the target machine. There are three defined values:
IEEE_FLOAT_FORMAT
This code indicates IEEE floating point. It is the default; there is no need to define this macro when the format is IEEE.
VAX_FLOAT_FORMAT
This code indicates the peculiar format used on the Vax.
UNKNOWN_FLOAT_FORMAT
This code indicates any other format.
The value of this macro is compared with HOST_FLOAT_FORMAT (see section The Configuration File) to determine whether the target machine has the same format as the host machine. If any other formats are actually in use on supported machines, new codes should be defined for them. The ordering of the component words of floating point values stored in memory is controlled by FLOAT_WORDS_BIG_ENDIAN for the target machine and HOST_FLOAT_WORDS_BIG_ENDIAN for the host.


Using and Porting GNU CC - Type Layout

Layout of Source Language Data Types

These macros define the sizes and other characteristics of the standard basic data types used in programs being compiled. Unlike the macros in the previous section, these apply to specific features of C and related languages, rather than to fundamental aspects of storage layout.

INT_TYPE_SIZE
A C expression for the size in bits of the type int on the target machine. If you don't define this, the default is one word.
MAX_INT_TYPE_SIZE
Maximum number for the size in bits of the type int on the target machine. If this is undefined, the default is INT_TYPE_SIZE. Otherwise, it is the constant value that is the largest value that INT_TYPE_SIZE can have at run-time. This is used in cpp.
SHORT_TYPE_SIZE
A C expression for the size in bits of the type short on the target machine. If you don't define this, the default is half a word. (If this would be less than one storage unit, it is rounded up to one unit.)
LONG_TYPE_SIZE
A C expression for the size in bits of the type long on the target machine. If you don't define this, the default is one word.
MAX_LONG_TYPE_SIZE
Maximum number for the size in bits of the type long on the target machine. If this is undefined, the default is LONG_TYPE_SIZE. Otherwise, it is the constant value that is the largest value that LONG_TYPE_SIZE can have at run-time. This is used in cpp.
LONG_LONG_TYPE_SIZE
A C expression for the size in bits of the type long long on the target machine. If you don't define this, the default is two words. If you want to support GNU Ada on your machine, the value of macro must be at least 64.
CHAR_TYPE_SIZE
A C expression for the size in bits of the type char on the target machine. If you don't define this, the default is one quarter of a word. (If this would be less than one storage unit, it is rounded up to one unit.)
MAX_CHAR_TYPE_SIZE
Maximum number for the size in bits of the type char on the target machine. If this is undefined, the default is CHAR_TYPE_SIZE. Otherwise, it is the constant value that is the largest value that CHAR_TYPE_SIZE can have at run-time. This is used in cpp.
FLOAT_TYPE_SIZE
A C expression for the size in bits of the type float on the target machine. If you don't define this, the default is one word.
DOUBLE_TYPE_SIZE
A C expression for the size in bits of the type double on the target machine. If you don't define this, the default is two words.
LONG_DOUBLE_TYPE_SIZE
A C expression for the size in bits of the type long double on the target machine. If you don't define this, the default is two words.
DEFAULT_SIGNED_CHAR
An expression whose value is 1 or 0, according to whether the type char should be signed or unsigned by default. The user can always override this default with the options `-fsigned-char' and `-funsigned-char'.
DEFAULT_SHORT_ENUMS
A C expression to determine whether to give an enum type only as many bytes as it takes to represent the range of possible values of that type. A nonzero value means to do that; a zero value means all enum types should be allocated like int. If you don't define the macro, the default is 0.
SIZE_TYPE
A C expression for a string describing the name of the data type to use for size values. The typedef name size_t is defined using the contents of the string. The string can contain more than one keyword. If so, separate them with spaces, and write first any length keyword, then unsigned if appropriate, and finally int. The string must exactly match one of the data type names defined in the function init_decl_processing in the file `c-decl.c'. You may not omit int or change the order--that would cause the compiler to crash on startup. If you don't define this macro, the default is "long unsigned int".
PTRDIFF_TYPE
A C expression for a string describing the name of the data type to use for the result of subtracting two pointers. The typedef name ptrdiff_t is defined using the contents of the string. See SIZE_TYPE above for more information. If you don't define this macro, the default is "long int".
WCHAR_TYPE
A C expression for a string describing the name of the data type to use for wide characters. The typedef name wchar_t is defined using the contents of the string. See SIZE_TYPE above for more information. If you don't define this macro, the default is "int".
WCHAR_TYPE_SIZE
A C expression for the size in bits of the data type for wide characters. This is used in cpp, which cannot make use of WCHAR_TYPE.
MAX_WCHAR_TYPE_SIZE
Maximum number for the size in bits of the data type for wide characters. If this is undefined, the default is WCHAR_TYPE_SIZE. Otherwise, it is the constant value that is the largest value that WCHAR_TYPE_SIZE can have at run-time. This is used in cpp.
OBJC_INT_SELECTORS
Define this macro if the type of Objective C selectors should be int. If this macro is not defined, then selectors should have the type struct objc_selector *.
OBJC_SELECTORS_WITHOUT_LABELS
Define this macro if the compiler can group all the selectors together into a vector and use just one label at the beginning of the vector. Otherwise, the compiler must give each selector its own assembler label. On certain machines, it is important to have a separate label for each selector because this enables the linker to eliminate duplicate selectors.
TARGET_BELL
A C constant expression for the integer value for escape sequence `\a'.
TARGET_BS
TARGET_TAB
TARGET_NEWLINE
C constant expressions for the integer values for escape sequences `\b', `\t' and `\n'.
TARGET_VT
TARGET_FF
TARGET_CR
C constant expressions for the integer values for escape sequences `\v', `\f' and `\r'.


Using and Porting GNU CC - Registers

Register Usage

This section explains how to describe what registers the target machine has, and how (in general) they can be used.

The description of which registers a specific instruction can use is done with register classes; see section Register Classes. For information on using registers to access a stack frame, see section Registers That Address the Stack Frame. For passing values in registers, see section Passing Arguments in Registers. For returning values in registers, see section How Scalar Function Values Are Returned.


Using and Porting GNU CC - Register Basics

Basic Characteristics of Registers

Registers have various characteristics.

FIRST_PSEUDO_REGISTER
Number of hardware registers known to the compiler. They receive numbers 0 through FIRST_PSEUDO_REGISTER-1; thus, the first pseudo register's number really is assigned the number FIRST_PSEUDO_REGISTER.
FIXED_REGISTERS
An initializer that says which registers are used for fixed purposes all throughout the compiled code and are therefore not available for general allocation. These would include the stack pointer, the frame pointer (except on machines where that can be used as a general register when no frame pointer is needed), the program counter on machines where that is considered one of the addressable registers, and any other numbered register with a standard use. This information is expressed as a sequence of numbers, separated by commas and surrounded by braces. The nth number is 1 if register n is fixed, 0 otherwise. The table initialized from this macro, and the table initialized by the following one, may be overridden at run time either automatically, by the actions of the macro CONDITIONAL_REGISTER_USAGE, or by the user with the command options `-ffixed-reg', `-fcall-used-reg' and `-fcall-saved-reg'.
CALL_USED_REGISTERS
Like FIXED_REGISTERS but has 1 for each register that is clobbered (in general) by function calls as well as for fixed registers. This macro therefore identifies the registers that are not available for general allocation of values that must live across function calls. If a register has 0 in CALL_USED_REGISTERS, the compiler automatically saves it on function entry and restores it on function exit, if the register is used within the function.
CONDITIONAL_REGISTER_USAGE
Zero or more C statements that may conditionally modify two variables fixed_regs and call_used_regs (both of type char []) after they have been initialized from the two preceding macros. This is necessary in case the fixed or call-clobbered registers depend on target flags. You need not define this macro if it has no work to do. If the usage of an entire class of registers depends on the target flags, you may indicate this to GCC by using this macro to modify fixed_regs and call_used_regs to 1 for each of the registers in the classes which should not be used by GCC. Also define the macro REG_CLASS_FROM_LETTER to return NO_REGS if it is called with a letter for a class that shouldn't be used. (However, if this class is not included in GENERAL_REGS and all of the insn patterns whose constraints permit this class are controlled by target switches, then GCC will automatically avoid using these registers when the target switches are opposed to them.)
NON_SAVING_SETJMP
If this macro is defined and has a nonzero value, it means that setjmp and related functions fail to save the registers, or that longjmp fails to restore them. To compensate, the compiler avoids putting variables in registers in functions that use setjmp.
INCOMING_REGNO (out)
Define this macro if the target machine has register windows. This C expression returns the register number as seen by the called function corresponding to the register number out as seen by the calling function. Return out if register number out is not an outbound register.
OUTGOING_REGNO (in)
Define this macro if the target machine has register windows. This C expression returns the register number as seen by the calling function corresponding to the register number in as seen by the called function. Return in if register number in is not an inbound register.


Using and Porting GNU CC - Allocation Order

Order of Allocation of Registers

Registers are allocated in order.

REG_ALLOC_ORDER
If defined, an initializer for a vector of integers, containing the numbers of hard registers in the order in which GNU CC should prefer to use them (from most preferred to least). If this macro is not defined, registers are used lowest numbered first (all else being equal). One use of this macro is on machines where the highest numbered registers must always be saved and the save-multiple-registers instruction supports only sequences of consecutive registers. On such machines, define REG_ALLOC_ORDER to be an initializer that lists the highest numbered allocatable register first.
ORDER_REGS_FOR_LOCAL_ALLOC
A C statement (sans semicolon) to choose the order in which to allocate hard registers for pseudo-registers local to a basic block. Store the desired register order in the array reg_alloc_order. Element 0 should be the register to allocate first; element 1, the next register; and so on. The macro body should not assume anything about the contents of reg_alloc_order before execution of the macro. On most machines, it is not necessary to define this macro.


Using and Porting GNU CC - Values in Registers

How Values Fit in Registers

This section discusses the macros that describe which kinds of values (specifically, which machine modes) each register can hold, and how many consecutive registers are needed for a given mode.

HARD_REGNO_NREGS (regno, mode)
A C expression for the number of consecutive hard registers, starting at register number regno, required to hold a value of mode mode. On a machine where all registers are exactly one word, a suitable definition of this macro is
#define HARD_REGNO_NREGS(REGNO, MODE)            \
   ((GET_MODE_SIZE (MODE) + UNITS_PER_WORD - 1)  \
    / UNITS_PER_WORD))
HARD_REGNO_MODE_OK (regno, mode)
A C expression that is nonzero if it is permissible to store a value of mode mode in hard register number regno (or in several registers starting with that one). For a machine where all registers are equivalent, a suitable definition is
#define HARD_REGNO_MODE_OK(REGNO, MODE) 1
It is not necessary for this macro to check for the numbers of fixed registers, because the allocation mechanism considers them to be always occupied. On some machines, double-precision values must be kept in even/odd register pairs. The way to implement that is to define this macro to reject odd register numbers for such modes. The minimum requirement for a mode to be OK in a register is that the `movmode' instruction pattern support moves between the register and any other hard register for which the mode is OK; and that moving a value into the register and back out not alter it. Since the same instruction used to move SImode will work for all narrower integer modes, it is not necessary on any machine for HARD_REGNO_MODE_OK to distinguish between these modes, provided you define patterns `movhi', etc., to take advantage of this. This is useful because of the interaction between HARD_REGNO_MODE_OK and MODES_TIEABLE_P; it is very desirable for all integer modes to be tieable. Many machines have special registers for floating point arithmetic. Often people assume that floating point machine modes are allowed only in floating point registers. This is not true. Any registers that can hold integers can safely hold a floating point machine mode, whether or not floating arithmetic can be done on it in those registers. Integer move instructions can be used to move the values. On some machines, though, the converse is true: fixed-point machine modes may not go in floating registers. This is true if the floating registers normalize any value stored in them, because storing a non-floating value there would garble it. In this case, HARD_REGNO_MODE_OK should reject fixed-point machine modes in floating registers. But if the floating registers do not automatically normalize, if you can store any bit pattern in one and retrieve it unchanged without a trap, then any machine mode may go in a floating register, so you can define this macro to say so. The primary significance of special floating registers is rather that they are the registers acceptable in floating point arithmetic instructions. However, this is of no concern to HARD_REGNO_MODE_OK. You handle it by writing the proper constraints for those instructions. On some machines, the floating registers are especially slow to access, so that it is better to store a value in a stack frame than in such a register if floating point arithmetic is not being done. As long as the floating registers are not in class GENERAL_REGS, they will not be used unless some pattern's constraint asks for one.
MODES_TIEABLE_P (mode1, mode2)
A C expression that is nonzero if it is desirable to choose register allocation so as to avoid move instructions between a value of mode mode1 and a value of mode mode2. If HARD_REGNO_MODE_OK (r, mode1) and HARD_REGNO_MODE_OK (r, mode2) are ever different for any r, then MODES_TIEABLE_P (mode1, mode2) must be zero.


Using and Porting GNU CC - Leaf Functions

Handling Leaf Functions

On some machines, a leaf function (i.e., one which makes no calls) can run more efficiently if it does not make its own register window. Often this means it is required to receive its arguments in the registers where they are passed by the caller, instead of the registers where they would normally arrive.

The special treatment for leaf functions generally applies only when other conditions are met; for example, often they may use only those registers for its own variables and temporaries. We use the term "leaf function" to mean a function that is suitable for this special handling, so that functions with no calls are not necessarily "leaf functions".

GNU CC assigns register numbers before it knows whether the function is suitable for leaf function treatment. So it needs to renumber the registers in order to output a leaf function. The following macros accomplish this.

LEAF_REGISTERS
A C initializer for a vector, indexed by hard register number, which contains 1 for a register that is allowable in a candidate for leaf function treatment. If leaf function treatment involves renumbering the registers, then the registers marked here should be the ones before renumbering--those that GNU CC would ordinarily allocate. The registers which will actually be used in the assembler code, after renumbering, should not be marked with 1 in this vector. Define this macro only if the target machine offers a way to optimize the treatment of leaf functions.
LEAF_REG_REMAP (regno)
A C expression whose value is the register number to which regno should be renumbered, when a function is treated as a leaf function. If regno is a register number which should not appear in a leaf function before renumbering, then the expression should yield -1, which will cause the compiler to abort. Define this macro only if the target machine offers a way to optimize the treatment of leaf functions, and registers need to be renumbered to do this.

Normally, FUNCTION_PROLOGUE and FUNCTION_EPILOGUE must treat leaf functions specially. It can test the C variable leaf_function which is nonzero for leaf functions. (The variable leaf_function is defined only if LEAF_REGISTERS is defined.)


Using and Porting GNU CC - Stack Registers

Registers That Form a Stack

There are special features to handle computers where some of the "registers" form a stack, as in the 80387 coprocessor for the 80386. Stack registers are normally written by pushing onto the stack, and are numbered relative to the top of the stack.

Currently, GNU CC can only handle one group of stack-like registers, and they must be consecutively numbered.

STACK_REGS
Define this if the machine has any stack-like registers.
FIRST_STACK_REG
The number of the first stack-like register. This one is the top of the stack.
LAST_STACK_REG
The number of the last stack-like register. This one is the bottom of the stack.


Using and Porting GNU CC - Obsolete Register Macros

Obsolete Macros for Controlling Register Usage

These features do not work very well. They exist because they used to be required to generate correct code for the 80387 coprocessor of the 80386. They are no longer used by that machine description and may be removed in a later version of the compiler. Don't use them!

OVERLAPPING_REGNO_P (regno)
If defined, this is a C expression whose value is nonzero if hard register number regno is an overlapping register. This means a hard register which overlaps a hard register with a different number. (Such overlap is undesirable, but occasionally it allows a machine to be supported which otherwise could not be.) This macro must return nonzero for all the registers which overlap each other. GNU CC can use an overlapping register only in certain limited ways. It can be used for allocation within a basic block, and may be spilled for reloading; that is all. If this macro is not defined, it means that none of the hard registers overlap each other. This is the usual situation.
INSN_CLOBBERS_REGNO_P (insn, regno)
If defined, this is a C expression whose value should be nonzero if the insn insn has the effect of mysteriously clobbering the contents of hard register number regno. By "mysterious" we mean that the insn's RTL expression doesn't describe such an effect. If this macro is not defined, it means that no insn clobbers registers mysteriously. This is the usual situation; all else being equal, it is best for the RTL expression to show all the activity.
PRESERVE_DEATH_INFO_REGNO_P (regno)
If defined, this is a C expression whose value is nonzero if correct REG_DEAD notes are needed for hard register number regno after reload. You would arrange to preserve death info for a register when some of the code in the machine description which is executed to write the assembler code looks at the death notes. This is necessary only when the actual hardware feature which GNU CC thinks of as a register is not actually a register of the usual sort. (It might, for example, be a hardware stack.) It is also useful for peepholes and linker relaxation. If this macro is not defined, it means that no death notes need to be preserved, and some may even be incorrect. This is the usual situation.


Using and Porting GNU CC - Register Classes

Register Classes

On many machines, the numbered registers are not all equivalent. For example, certain registers may not be allowed for indexed addressing; certain registers may not be allowed in some instructions. These machine restrictions are described to the compiler using register classes.

You define a number of register classes, giving each one a name and saying which of the registers belong to it. Then you can specify register classes that are allowed as operands to particular instruction patterns.

In general, each register will belong to several classes. In fact, one class must be named ALL_REGS and contain all the registers. Another class must be named NO_REGS and contain no registers. Often the union of two classes will be another class; however, this is not required.

One of the classes must be named GENERAL_REGS. There is nothing terribly special about the name, but the operand constraint letters `r' and `g' specify this class. If GENERAL_REGS is the same as ALL_REGS, just define it as a macro which expands to ALL_REGS.

Order the classes so that if class x is contained in class y then x has a lower class number than y.

The way classes other than GENERAL_REGS are specified in operand constraints is through machine-dependent operand constraint letters. You can define such letters to correspond to various classes, then use them in operand constraints.

You should define a class for the union of two classes whenever some instruction allows both classes. For example, if an instruction allows either a floating point (coprocessor) register or a general register for a certain operand, you should define a class FLOAT_OR_GENERAL_REGS which includes both of them. Otherwise you will get suboptimal code.

You must also specify certain redundant information about the register classes: for each class, which classes contain it and which ones are contained in it; for each pair of classes, the largest class contained in their union.

When a value occupying several consecutive registers is expected in a certain class, all the registers used must belong to that class. Therefore, register classes cannot be used to enforce a requirement for a register pair to start with an even-numbered register. The way to specify this requirement is with HARD_REGNO_MODE_OK.

Register classes used for input-operands of bitwise-and or shift instructions have a special requirement: each such class must have, for each fixed-point machine mode, a subclass whose registers can transfer that mode to or from memory. For example, on some machines, the operations for single-byte values (QImode) are limited to certain registers. When this is so, each register class that is used in a bitwise-and or shift instruction must have a subclass consisting of registers from which single-byte values can be loaded or stored. This is so that PREFERRED_RELOAD_CLASS can always have a possible value to return.

enum reg_class
An enumeral type that must be defined with all the register class names as enumeral values. NO_REGS must be first. ALL_REGS must be the last register class, followed by one more enumeral value, LIM_REG_CLASSES, which is not a register class but rather tells how many classes there are. Each register class has a number, which is the value of casting the class name to type int. The number serves as an index in many of the tables described below.
N_REG_CLASSES
The number of distinct register classes, defined as follows:
#define N_REG_CLASSES (int) LIM_REG_CLASSES
REG_CLASS_NAMES
An initializer containing the names of the register classes as C string constants. These names are used in writing some of the debugging dumps.
REG_CLASS_CONTENTS
An initializer containing the contents of the register classes, as integers which are bit masks. The nth integer specifies the contents of class n. The way the integer mask is interpreted is that register r is in the class if mask & (1 << r) is 1. When the machine has more than 32 registers, an integer does not suffice. Then the integers are replaced by sub-initializers, braced groupings containing several integers. Each sub-initializer must be suitable as an initializer for the type HARD_REG_SET which is defined in `hard-reg-set.h'.
REGNO_REG_CLASS (regno)
A C expression whose value is a register class containing hard register regno. In general there is more than one such class; choose a class which is minimal, meaning that no smaller class also contains the register.
BASE_REG_CLASS
A macro whose definition is the name of the class to which a valid base register must belong. A base register is one used in an address which is the register value plus a displacement.
INDEX_REG_CLASS
A macro whose definition is the name of the class to which a valid index register must belong. An index register is one used in an address where its value is either multiplied by a scale factor or added to another register (as well as added to a displacement).
REG_CLASS_FROM_LETTER (char)
A C expression which defines the machine-dependent operand constraint letters for register classes. If char is such a letter, the value should be the register class corresponding to it. Otherwise, the value should be NO_REGS. The register letter `r', corresponding to class GENERAL_REGS, will not be passed to this macro; you do not need to handle it.
REGNO_OK_FOR_BASE_P (num)
A C expression which is nonzero if register number num is suitable for use as a base register in operand addresses. It may be either a suitable hard register or a pseudo register that has been allocated such a hard register.
REGNO_MODE_OK_FOR_BASE_P (num, mode)
A C expression that is just like REGNO_OK_FOR_BASE_P, except that that expression may examine the mode of the memory reference in mode. You should define this macro if the mode of the memory reference affects whether a register may be used as a base register. If you define this macro, the compiler will use it instead of REGNO_OK_FOR_BASE_P.
REGNO_OK_FOR_INDEX_P (num)
A C expression which is nonzero if register number num is suitable for use as an index register in operand addresses. It may be either a suitable hard register or a pseudo register that has been allocated such a hard register. The difference between an index register and a base register is that the index register may be scaled. If an address involves the sum of two registers, neither one of them scaled, then either one may be labeled the "base" and the other the "index"; but whichever labeling is used must fit the machine's constraints of which registers may serve in each capacity. The compiler will try both labelings, looking for one that is valid, and will reload one or both registers only if neither labeling works.
PREFERRED_RELOAD_CLASS (x, class)
A C expression that places additional restrictions on the register class to use when it is necessary to copy value x into a register in class class. The value is a register class; perhaps class, or perhaps another, smaller class. On many machines, the following definition is safe:
#define PREFERRED_RELOAD_CLASS(X,CLASS) CLASS
Sometimes returning a more restrictive class makes better code. For example, on the 68000, when x is an integer constant that is in range for a `moveq' instruction, the value of this macro is always DATA_REGS as long as class includes the data registers. Requiring a data register guarantees that a `moveq' will be used. If x is a const_double, by returning NO_REGS you can force x into a memory constant. This is useful on certain machines where immediate floating values cannot be loaded into certain kinds of registers.
PREFERRED_OUTPUT_RELOAD_CLASS (x, class)
Like PREFERRED_RELOAD_CLASS, but for output reloads instead of input reloads. If you don't define this macro, the default is to use class, unchanged.
LIMIT_RELOAD_CLASS (mode, class)
A C expression that places additional restrictions on the register class to use when it is necessary to be able to hold a value of mode mode in a reload register for which class class would ordinarily be used. Unlike PREFERRED_RELOAD_CLASS, this macro should be used when there are certain modes that simply can't go in certain reload classes. The value is a register class; perhaps class, or perhaps another, smaller class. Don't define this macro unless the target machine has limitations which require the macro to do something nontrivial.
SECONDARY_RELOAD_CLASS (class, mode, x)
SECONDARY_INPUT_RELOAD_CLASS (class, mode, x)
SECONDARY_OUTPUT_RELOAD_CLASS (class, mode, x)
Many machines have some registers that cannot be copied directly to or from memory or even from other types of registers. An example is the `MQ' register, which on most machines, can only be copied to or from general registers, but not memory. Some machines allow copying all registers to and from memory, but require a scratch register for stores to some memory locations (e.g., those with symbolic address on the RT, and those with certain symbolic address on the Sparc when compiling PIC). In some cases, both an intermediate and a scratch register are required. You should define these macros to indicate to the reload phase that it may need to allocate at least one register for a reload in addition to the register to contain the data. Specifically, if copying x to a register class in mode requires an intermediate register, you should define SECONDARY_INPUT_RELOAD_CLASS to return the largest register class all of whose registers can be used as intermediate registers or scratch registers. If copying a register class in mode to x requires an intermediate or scratch register, SECONDARY_OUTPUT_RELOAD_CLASS should be defined to return the largest register class required. If the requirements for input and output reloads are the same, the macro SECONDARY_RELOAD_CLASS should be used instead of defining both macros identically. The values returned by these macros are often GENERAL_REGS. Return NO_REGS if no spare register is needed; i.e., if x can be directly copied to or from a register of class in mode without requiring a scratch register. Do not define this macro if it would always return NO_REGS. If a scratch register is required (either with or without an intermediate register), you should define patterns for `reload_inm' or `reload_outm', as required (see section Standard Pattern Names For Generation. These patterns, which will normally be implemented with a define_expand, should be similar to the `movm' patterns, except that operand 2 is the scratch register. Define constraints for the reload register and scratch register that contain a single register class. If the original reload register (whose class is class) can meet the constraint given in the pattern, the value returned by these macros is used for the class of the scratch register. Otherwise, two additional reload registers are required. Their classes are obtained from the constraints in the insn pattern. x might be a pseudo-register or a subreg of a pseudo-register, which could either be in a hard register or in memory. Use true_regnum to find out; it will return -1 if the pseudo is in memory and the hard register number if it is in a register. These macros should not be used in the case where a particular class of registers can only be copied to memory and not to another class of registers. In that case, secondary reload registers are not needed and would not be helpful. Instead, a stack location must be used to perform the copy and the movm pattern should use memory as a intermediate storage. This case often occurs between floating-point and general registers.
SECONDARY_MEMORY_NEEDED (class1, class2, m)
Certain machines have the property that some registers cannot be copied to some other registers without using memory. Define this macro on those machines to be a C expression that is non-zero if objects of mode m in registers of class1 can only be copied to registers of class class2 by storing a register of class1 into memory and loading that memory location into a register of class2. Do not define this macro if its value would always be zero.
SECONDARY_MEMORY_NEEDED_RTX (mode)
Normally when SECONDARY_MEMORY_NEEDED is defined, the compiler allocates a stack slot for a memory location needed for register copies. If this macro is defined, the compiler instead uses the memory location defined by this macro. Do not define this macro if you do not define SECONDARY_MEMORY_NEEDED.
SECONDARY_MEMORY_NEEDED_MODE (mode)
When the compiler needs a secondary memory location to copy between two registers of mode mode, it normally allocates sufficient memory to hold a quantity of BITS_PER_WORD bits and performs the store and load operations in a mode that many bits wide and whose class is the same as that of mode. This is right thing to do on most machines because it ensures that all bits of the register are copied and prevents accesses to the registers in a narrower mode, which some machines prohibit for floating-point registers. However, this default behavior is not correct on some machines, such as the DEC Alpha, that store short integers in floating-point registers differently than in integer registers. On those machines, the default widening will not work correctly and you must define this macro to suppress that widening in some cases. See the file `alpha.h' for details. Do not define this macro if you do not define SECONDARY_MEMORY_NEEDED or if widening mode to a mode that is BITS_PER_WORD bits wide is correct for your machine.
SMALL_REGISTER_CLASSES
Normally the compiler avoids choosing registers that have been explicitly mentioned in the rtl as spill registers (these registers are normally those used to pass parameters and return values). However, some machines have so few registers of certain classes that there would not be enough registers to use as spill registers if this were done. Define SMALL_REGISTER_CLASSES to be an expression with a non-zero value on these machines. When this macro has a non-zero value, the compiler allows registers explicitly used in the rtl to be used as spill registers but avoids extending the lifetime of these registers. It is always safe to define this macro with a non-zero value, but if you unnecessarily define it, you will reduce the amount of optimizations that can be performed in some cases. If you do not define this macro with a non-zero value when it is required, the compiler will run out of spill registers and print a fatal error message. For most machines, you should not define this macro at all.
CLASS_LIKELY_SPILLED_P (class)
A C expression whose value is nonzero if pseudos that have been assigned to registers of class class would likely be spilled because registers of class are needed for spill registers. The default value of this macro returns 1 if class has exactly one register and zero otherwise. On most machines, this default should be used. Only define this macro to some other expression if pseudo allocated by `local-alloc.c' end up in memory because their hard registers were needed for spill registers. If this macro returns nonzero for those classes, those pseudos will only be allocated by `global.c', which knows how to reallocate the pseudo to another register. If there would not be another register available for reallocation, you should not change the definition of this macro since the only effect of such a definition would be to slow down register allocation.
CLASS_MAX_NREGS (class, mode)
A C expression for the maximum number of consecutive registers of class class needed to hold a value of mode mode. This is closely related to the macro HARD_REGNO_NREGS. In fact, the value of the macro CLASS_MAX_NREGS (class, mode) should be the maximum value of HARD_REGNO_NREGS (regno, mode) for all regno values in the class class. This macro helps control the handling of multiple-word values in the reload pass.
CLASS_CANNOT_CHANGE_SIZE
If defined, a C expression for a class that contains registers which the compiler must always access in a mode that is the same size as the mode in which it loaded the register. For the example, loading 32-bit integer or floating-point objects into floating-point registers on the Alpha extends them to 64-bits. Therefore loading a 64-bit object and then storing it as a 32-bit object does not store the low-order 32-bits, as would be the case for a normal register. Therefore, `alpha.h' defines this macro as FLOAT_REGS.

Three other special macros describe which operands fit which constraint letters.

CONST_OK_FOR_LETTER_P (value, c)
A C expression that defines the machine-dependent operand constraint letters (`I', `J', `K', ... `P') that specify particular ranges of integer values. If c is one of those letters, the expression should check that value, an integer, is in the appropriate range and return 1 if so, 0 otherwise. If c is not one of those letters, the value should be 0 regardless of value.
CONST_DOUBLE_OK_FOR_LETTER_P (value, c)
A C expression that defines the machine-dependent operand constraint letters that specify particular ranges of const_double values (`G' or `H'). If c is one of those letters, the expression should check that value, an RTX of code const_double, is in the appropriate range and return 1 if so, 0 otherwise. If c is not one of those letters, the value should be 0 regardless of value. const_double is used for all floating-point constants and for DImode fixed-point constants. A given letter can accept either or both kinds of values. It can use GET_MODE to distinguish between these kinds.
EXTRA_CONSTRAINT (value, c)
A C expression that defines the optional machine-dependent constraint letters (@item `Q', `R', `S', `T', `U') that can be used to segregate specific types of operands, usually memory references, for the target machine. Normally this macro will not be defined. If it is required for a particular target machine, it should return 1 if value corresponds to the operand type represented by the constraint letter c. If c is not defined as an extra constraint, the value returned should be 0 regardless of value. For example, on the ROMP, load instructions cannot have their output in r0 if the memory reference contains a symbolic address. Constraint letter `Q' is defined as representing a memory address that does not contain a symbolic address. An alternative is specified with a `Q' constraint on the input and `r' on the output. The next alternative specifies `m' on the input and a register class that does not include r0 on the output.


Using and Porting GNU CC - Stack and Calling

Stack Layout and Calling Conventions

This describes the stack layout and calling conventions.


Using and Porting GNU CC - Frame Layout

Basic Stack Layout

Here is the basic stack layout.

STACK_GROWS_DOWNWARD
Define this macro if pushing a word onto the stack moves the stack pointer to a smaller address. When we say, "define this macro if ...," it means that the compiler checks this macro only with #ifdef so the precise definition used does not matter.
FRAME_GROWS_DOWNWARD
Define this macro if the addresses of local variable slots are at negative offsets from the frame pointer.
ARGS_GROW_DOWNWARD
Define this macro if successive arguments to a function occupy decreasing addresses on the stack.
STARTING_FRAME_OFFSET
Offset from the frame pointer to the first local variable slot to be allocated. If FRAME_GROWS_DOWNWARD, find the next slot's offset by subtracting the first slot's length from STARTING_FRAME_OFFSET. Otherwise, it is found by adding the length of the first slot to the value STARTING_FRAME_OFFSET.
STACK_POINTER_OFFSET
Offset from the stack pointer register to the first location at which outgoing arguments are placed. If not specified, the default value of zero is used. This is the proper value for most machines. If ARGS_GROW_DOWNWARD, this is the offset to the location above the first location at which outgoing arguments are placed.
FIRST_PARM_OFFSET (fundecl)
Offset from the argument pointer register to the first argument's address. On some machines it may depend on the data type of the function. If ARGS_GROW_DOWNWARD, this is the offset to the location above the first argument's address.
STACK_DYNAMIC_OFFSET (fundecl)
Offset from the stack pointer register to an item dynamically allocated on the stack, e.g., by alloca. The default value for this macro is STACK_POINTER_OFFSET plus the length of the outgoing arguments. The default is correct for most machines. See `function.c' for details.
DYNAMIC_CHAIN_ADDRESS (frameaddr)
A C expression whose value is RTL representing the address in a stack frame where the pointer to the caller's frame is stored. Assume that frameaddr is an RTL expression for the address of the stack frame itself. If you don't define this macro, the default is to return the value of frameaddr---that is, the stack frame address is also the address of the stack word that points to the previous frame.
SETUP_FRAME_ADDRESSES ()
If defined, a C expression that produces the machine-specific code to setup the stack so that arbitrary frames can be accessed. For example, on the Sparc, we must flush all of the register windows to the stack before we can access arbitrary stack frames. This macro will seldom need to be defined.
RETURN_ADDR_RTX (count, frameaddr)
A C expression whose value is RTL representing the value of the return address for the frame count steps up from the current frame, after the prologue. frameaddr is the frame pointer of the count frame, or the frame pointer of the count - 1 frame if RETURN_ADDR_IN_PREVIOUS_FRAME is defined.
RETURN_ADDR_IN_PREVIOUS_FRAME
Define this if the return address of a particular stack frame is accessed from the frame pointer of the previous stack frame.
INCOMING_RETURN_ADDR_RTX
A C expression whose value is RTL representing the location of the incoming return address at the beginning of any function, before the prologue. This RTL is either a REG, indicating that the return value is saved in `REG', or a MEM representing a location in the stack. You only need to define this macro if you want to support call frame debugging information like that provided by DWARF 2.
INCOMING_FRAME_SP_OFFSET
A C expression whose value is an integer giving the offset, in bytes, from the value of the stack pointer register to the top of the stack frame at the beginning of any function, before the prologue. The top of the frame is defined to be the value of the stack pointer in the previous frame, just before the call instruction. You only need to define this macro if you want to support call frame debugging information like that provided by DWARF 2.


Using and Porting GNU CC - Stack Checking

Specifying How Stack Checking is Done

GNU CC will check that stack references are within the boundaries of the stack, if the `-fstack-check' is specified, in one of three ways:

  1. If the value of the STACK_CHECK_BUILTIN macro is nonzero, GNU CC will assume that you have arranged for stack checking to be done at appropriate places in the configuration files, e.g., in FUNCTION_PROLOGUE. GNU CC will do not other special processing.
  2. If STACK_CHECK_BUILTIN is zero and you defined a named pattern called check_stack in your `md' file, GNU CC will call that pattern with one argument which is the address to compare the stack value against. You must arrange for this pattern to report an error if the stack pointer is out of range.
  3. If neither of the above are true, GNU CC will generate code to periodically "probe" the stack pointer using the values of the macros defined below.

Normally, you will use the default values of these macros, so GNU CC will use the third approach.

STACK_CHECK_BUILTIN
A nonzero value if stack checking is done by the configuration files in a machine-dependent manner. You should define this macro if stack checking is require by the ABI of your machine or if you would like to have to stack checking in some more efficient way than GNU CC's portable approach. The default value of this macro is zero.
STACK_CHECK_PROBE_INTERVAL
An integer representing the interval at which GNU CC must generate stack probe instructions. You will normally define this macro to be no larger than the size of the "guard pages" at the end of a stack area. The default value of 4096 is suitable for most systems.
STACK_CHECK_PROBE_LOAD
A integer which is nonzero if GNU CC should perform the stack probe as a load instruction and zero if GNU CC should use a store instruction. The default is zero, which is the most efficient choice on most systems.
STACK_CHECK_PROTECT
The number of bytes of stack needed to recover from a stack overflow, for languages where such a recovery is supported. The default value of 75 words should be adequate for most machines.
STACK_CHECK_MAX_FRAME_SIZE
The maximum size of a stack frame, in bytes. GNU CC will generate probe instructions in non-leaf functions to ensure at least this many bytes of stack are available. If a stack frame is larger than this size, stack checking will not be reliable and GNU CC will issue a warning. The default is chosen so that GNU CC only generates one instruction on most systems. You should normally not change the default value of this macro.
STACK_CHECK_FIXED_FRAME_SIZE
GNU CC uses this value to generate the above warning message. It represents the amount of fixed frame used by a function, not including space for any callee-saved registers, temporaries and user variables. You need only specify an upper bound for this amount and will normally use the default of four words.
STACK_CHECK_MAX_VAR_SIZE
The maximum size, in bytes, of an object that GNU CC will place in the fixed area of the stack frame when the user specifies `-fstack-check'. GNU CC computed the default from the values of the above macros and you will normally not need to override that default.


Using and Porting GNU CC - Frame Registers

Registers That Address the Stack Frame

This discusses registers that address the stack frame.

STACK_POINTER_REGNUM
The register number of the stack pointer register, which must also be a fixed register according to FIXED_REGISTERS. On most machines, the hardware determines which register this is.
FRAME_POINTER_REGNUM
The register number of the frame pointer register, which is used to access automatic variables in the stack frame. On some machines, the hardware determines which register this is. On other machines, you can choose any register you wish for this purpose.
HARD_FRAME_POINTER_REGNUM
On some machines the offset between the frame pointer and starting offset of the automatic variables is not known until after register allocation has been done (for example, because the saved registers are between these two locations). On those machines, define FRAME_POINTER_REGNUM the number of a special, fixed register to be used internally until the offset is known, and define HARD_FRAME_POINTER_REGNUM to be actual the hard register number used for the frame pointer. You should define this macro only in the very rare circumstances when it is not possible to calculate the offset between the frame pointer and the automatic variables until after register allocation has been completed. When this macro is defined, you must also indicate in your definition of ELIMINABLE_REGS how to eliminate FRAME_POINTER_REGNUM into either HARD_FRAME_POINTER_REGNUM or STACK_POINTER_REGNUM. Do not define this macro if it would be the same as FRAME_POINTER_REGNUM.
ARG_POINTER_REGNUM
The register number of the arg pointer register, which is used to access the function's argument list. On some machines, this is the same as the frame pointer register. On some machines, the hardware determines which register this is. On other machines, you can choose any register you wish for this purpose. If this is not the same register as the frame pointer register, then you must mark it as a fixed register according to FIXED_REGISTERS, or arrange to be able to eliminate it (see section Eliminating Frame Pointer and Arg Pointer).
RETURN_ADDRESS_POINTER_REGNUM
The register number of the return address pointer register, which is used to access the current function's return address from the stack. On some machines, the return address is not at a fixed offset from the frame pointer or stack pointer or argument pointer. This register can be defined to point to the return address on the stack, and then be converted by ELIMINABLE_REGS into either the frame pointer or stack pointer. Do not define this macro unless there is no other way to get the return address from the stack.
STATIC_CHAIN_REGNUM
STATIC_CHAIN_INCOMING_REGNUM
Register numbers used for passing a function's static chain pointer. If register windows are used, the register number as seen by the called function is STATIC_CHAIN_INCOMING_REGNUM, while the register number as seen by the calling function is STATIC_CHAIN_REGNUM. If these registers are the same, STATIC_CHAIN_INCOMING_REGNUM need not be defined. The static chain register need not be a fixed register. If the static chain is passed in memory, these macros should not be defined; instead, the next two macros should be defined.
STATIC_CHAIN
STATIC_CHAIN_INCOMING
If the static chain is passed in memory, these macros provide rtx giving mem expressions that denote where they are stored. STATIC_CHAIN and STATIC_CHAIN_INCOMING give the locations as seen by the calling and called functions, respectively. Often the former will be at an offset from the stack pointer and the latter at an offset from the frame pointer. The variables stack_pointer_rtx, frame_pointer_rtx, and arg_pointer_rtx will have been initialized prior to the use of these macros and should be used to refer to those items. If the static chain is passed in a register, the two previous macros should be defined instead.


Using and Porting GNU CC - Elimination

Eliminating Frame Pointer and Arg Pointer

This is about eliminating the frame pointer and arg pointer.

FRAME_POINTER_REQUIRED
A C expression which is nonzero if a function must have and use a frame pointer. This expression is evaluated in the reload pass. If its value is nonzero the function will have a frame pointer. The expression can in principle examine the current function and decide according to the facts, but on most machines the constant 0 or the constant 1 suffices. Use 0 when the machine allows code to be generated with no frame pointer, and doing so saves some time or space. Use 1 when there is no possible advantage to avoiding a frame pointer. In certain cases, the compiler does not know how to produce valid code without a frame pointer. The compiler recognizes those cases and automatically gives the function a frame pointer regardless of what FRAME_POINTER_REQUIRED says. You don't need to worry about them. In a function that does not require a frame pointer, the frame pointer register can be allocated for ordinary usage, unless you mark it as a fixed register. See FIXED_REGISTERS for more information.
INITIAL_FRAME_POINTER_OFFSET (depth-var)
A C statement to store in the variable depth-var the difference between the frame pointer and the stack pointer values immediately after the function prologue. The value would be computed from information such as the result of get_frame_size () and the tables of registers regs_ever_live and call_used_regs. If ELIMINABLE_REGS is defined, this macro will be not be used and need not be defined. Otherwise, it must be defined even if FRAME_POINTER_REQUIRED is defined to always be true; in that case, you may set depth-var to anything.
ELIMINABLE_REGS
If defined, this macro specifies a table of register pairs used to eliminate unneeded registers that point into the stack frame. If it is not defined, the only elimination attempted by the compiler is to replace references to the frame pointer with references to the stack pointer. The definition of this macro is a list of structure initializations, each of which specifies an original and replacement register. On some machines, the position of the argument pointer is not known until the compilation is completed. In such a case, a separate hard register must be used for the argument pointer. This register can be eliminated by replacing it with either the frame pointer or the argument pointer, depending on whether or not the frame pointer has been eliminated. In this case, you might specify:
#define ELIMINABLE_REGS  \
{{ARG_POINTER_REGNUM, STACK_POINTER_REGNUM}, \
 {ARG_POINTER_REGNUM, FRAME_POINTER_REGNUM}, \
 {FRAME_POINTER_REGNUM, STACK_POINTER_REGNUM}}
Note that the elimination of the argument pointer with the stack pointer is specified first since that is the preferred elimination.
CAN_ELIMINATE (from-reg, to-reg)
A C expression that returns non-zero if the compiler is allowed to try to replace register number from-reg with register number to-reg. This macro need only be defined if ELIMINABLE_REGS is defined, and will usually be the constant 1, since most of the cases preventing register elimination are things that the compiler already knows about.
INITIAL_ELIMINATION_OFFSET (from-reg, to-reg, offset-var)
This macro is similar to INITIAL_FRAME_POINTER_OFFSET. It specifies the initial difference between the specified pair of registers. This macro must be defined if ELIMINABLE_REGS is defined.
LONGJMP_RESTORE_FROM_STACK
Define this macro if the longjmp function restores registers from the stack frames, rather than from those saved specifically by setjmp. Certain quantities must not be kept in registers across a call to setjmp on such machines.


Using and Porting GNU CC - Stack Arguments

Passing Function Arguments on the Stack

The macros in this section control how arguments are passed on the stack. See the following section for other macros that control passing certain arguments in registers.

PROMOTE_PROTOTYPES
Define this macro if an argument declared in a prototype as an integral type smaller than int should actually be passed as an int. In addition to avoiding errors in certain cases of mismatch, it also makes for better code on certain machines.
PUSH_ROUNDING (npushed)
A C expression that is the number of bytes actually pushed onto the stack when an instruction attempts to push npushed bytes. If the target machine does not have a push instruction, do not define this macro. That directs GNU CC to use an alternate strategy: to allocate the entire argument block and then store the arguments into it. On some machines, the definition
#define PUSH_ROUNDING(BYTES) (BYTES)
will suffice. But on other machines, instructions that appear to push one byte actually push two bytes in an attempt to maintain alignment. Then the definition should be
#define PUSH_ROUNDING(BYTES) (((BYTES) + 1) & ~1)
ACCUMULATE_OUTGOING_ARGS
If defined, the maximum amount of space required for outgoing arguments will be computed and placed into the variable current_function_outgoing_args_size. No space will be pushed onto the stack for each call; instead, the function prologue should increase the stack frame size by this amount. Defining both PUSH_ROUNDING and ACCUMULATE_OUTGOING_ARGS is not proper.
REG_PARM_STACK_SPACE (fndecl)
Define this macro if functions should assume that stack space has been allocated for arguments even when their values are passed in registers. The value of this macro is the size, in bytes, of the area reserved for arguments passed in registers for the function represented by fndecl. This space can be allocated by the caller, or be a part of the machine-dependent stack frame: OUTGOING_REG_PARM_STACK_SPACE says which.
MAYBE_REG_PARM_STACK_SPACE
FINAL_REG_PARM_STACK_SPACE (const_size, var_size)
Define these macros in addition to the one above if functions might allocate stack space for arguments even when their values are passed in registers. These should be used when the stack space allocated for arguments in registers is not a simple constant independent of the function declaration. The value of the first macro is the size, in bytes, of the area that we should initially assume would be reserved for arguments passed in registers. The value of the second macro is the actual size, in bytes, of the area that will be reserved for arguments passed in registers. This takes two arguments: an integer representing the number of bytes of fixed sized arguments on the stack, and a tree representing the number of bytes of variable sized arguments on the stack. When these macros are defined, REG_PARM_STACK_SPACE will only be called for libcall functions, the current function, or for a function being called when it is known that such stack space must be allocated. In each case this value can be easily computed. When deciding whether a called function needs such stack space, and how much space to reserve, GNU CC uses these two macros instead of REG_PARM_STACK_SPACE.
OUTGOING_REG_PARM_STACK_SPACE
Define this if it is the responsibility of the caller to allocate the area reserved for arguments passed in registers. If ACCUMULATE_OUTGOING_ARGS is defined, this macro controls whether the space for these arguments counts in the value of current_function_outgoing_args_size.
STACK_PARMS_IN_REG_PARM_AREA
Define this macro if REG_PARM_STACK_SPACE is defined, but the stack parameters don't skip the area specified by it. Normally, when a parameter is not passed in registers, it is placed on the stack beyond the REG_PARM_STACK_SPACE area. Defining this macro suppresses this behavior and causes the parameter to be passed on the stack in its natural location.
RETURN_POPS_ARGS (fundecl, funtype, stack-size)
A C expression that should indicate the number of bytes of its own arguments that a function pops on returning, or 0 if the function pops no arguments and the caller must therefore pop them all after the function returns. fundecl is a C variable whose value is a tree node that describes the function in question. Normally it is a node of type FUNCTION_DECL that describes the declaration of the function. From this you can obtain the DECL_MACHINE_ATTRIBUTES of the function. funtype is a C variable whose value is a tree node that describes the function in question. Normally it is a node of type FUNCTION_TYPE that describes the data type of the function. From this it is possible to obtain the data types of the value and arguments (if known). When a call to a library function is being considered, fundecl will contain an identifier node for the library function. Thus, if you need to distinguish among various library functions, you can do so by their names. Note that "library function" in this context means a function used to perform arithmetic, whose name is known specially in the compiler and was not mentioned in the C code being compiled. stack-size is the number of bytes of arguments passed on the stack. If a variable number of bytes is passed, it is zero, and argument popping will always be the responsibility of the calling function. On the Vax, all functions always pop their arguments, so the definition of this macro is stack-size. On the 68000, using the standard calling convention, no functions pop their arguments, so the value of the macro is always 0 in this case. But an alternative calling convention is available in which functions that take a fixed number of arguments pop them but other functions (such as printf) pop nothing (the caller pops all). When this convention is in use, funtype is examined to determine whether a function takes a fixed number of arguments.


Using and Porting GNU CC - Register Arguments

Passing Arguments in Registers

This section describes the macros which let you control how various types of arguments are passed in registers or how they are arranged in the stack.

FUNCTION_ARG (cum, mode, type, named)
A C expression that controls whether a function argument is passed in a register, and which register. The arguments are cum, which summarizes all the previous arguments; mode, the machine mode of the argument; type, the data type of the argument as a tree node or 0 if that is not known (which happens for C support library functions); and named, which is 1 for an ordinary argument and 0 for nameless arguments that correspond to `...' in the called function's prototype. The value of the expression is usually either a reg RTX for the hard register in which to pass the argument, or zero to pass the argument on the stack. For machines like the Vax and 68000, where normally all arguments are pushed, zero suffices as a definition. The value of the expression can also be a parallel RTX. This is used when an argument is passed in multiple locations. The mode of the of the parallel should be the mode of the entire argument. The parallel holds any number of expr_list pairs; each one describes where part of the argument is passed. In each expr_list, the first operand can be either a reg RTX for the hard register in which to pass this part of the argument, or zero to pass the argument on the stack. If this operand is a reg, then the mode indicates how large this part of the argument is. The second operand of the expr_list is a const_int which gives the offset in bytes into the entire argument where this part starts. The usual way to make the ANSI library `stdarg.h' work on a machine where some arguments are usually passed in registers, is to cause nameless arguments to be passed on the stack instead. This is done by making FUNCTION_ARG return 0 whenever named is 0. You may use the macro MUST_PASS_IN_STACK (mode, type) in the definition of this macro to determine if this argument is of a type that must be passed in the stack. If REG_PARM_STACK_SPACE is not defined and FUNCTION_ARG returns non-zero for such an argument, the compiler will abort. If REG_PARM_STACK_SPACE is defined, the argument will be computed in the stack and then loaded into a register.
FUNCTION_INCOMING_ARG (cum, mode, type, named)
Define this macro if the target machine has "register windows", so that the register in which a function sees an arguments is not necessarily the same as the one in which the caller passed the argument. For such machines, FUNCTION_ARG computes the register in which the caller passes the value, and FUNCTION_INCOMING_ARG should be defined in a similar fashion to tell the function being called where the arguments will arrive. If FUNCTION_INCOMING_ARG is not defined, FUNCTION_ARG serves both purposes.
FUNCTION_ARG_PARTIAL_NREGS (cum, mode, type, named)
A C expression for the number of words, at the beginning of an argument, must be put in registers. The value must be zero for arguments that are passed entirely in registers or that are entirely pushed on the stack. On some machines, certain arguments must be passed partially in registers and partially in memory. On these machines, typically the first n words of arguments are passed in registers, and the rest on the stack. If a multi-word argument (a double or a structure) crosses that boundary, its first few words must be passed in registers and the rest must be pushed. This macro tells the compiler when this occurs, and how many of the words should go in registers. FUNCTION_ARG for these arguments should return the first register to be used by the caller for this argument; likewise FUNCTION_INCOMING_ARG, for the called function.
FUNCTION_ARG_PASS_BY_REFERENCE (cum, mode, type, named)
A C expression that indicates when an argument must be passed by reference. If nonzero for an argument, a copy of that argument is made in memory and a pointer to the argument is passed instead of the argument itself. The pointer is passed in whatever way is appropriate for passing a pointer to that type. On machines where REG_PARM_STACK_SPACE is not defined, a suitable definition of this macro might be
#define FUNCTION_ARG_PASS_BY_REFERENCE\
(CUM, MODE, TYPE, NAMED)  \
  MUST_PASS_IN_STACK (MODE, TYPE)
FUNCTION_ARG_CALLEE_COPIES (cum, mode, type, named)
If defined, a C expression that indicates when it is the called function's responsibility to make a copy of arguments passed by invisible reference. Normally, the caller makes a copy and passes the address of the copy to the routine being called. When FUNCTION_ARG_CALLEE_COPIES is defined and is nonzero, the caller does not make a copy. Instead, it passes a pointer to the "live" value. The called function must not modify this value. If it can be determined that the value won't be modified, it need not make a copy; otherwise a copy must be made.
CUMULATIVE_ARGS
A C type for declaring a variable that is used as the first argument of FUNCTION_ARG and other related values. For some target machines, the type int suffices and can hold the number of bytes of argument so far. There is no need to record in CUMULATIVE_ARGS anything about the arguments that have been passed on the stack. The compiler has other variables to keep track of that. For target machines on which all arguments are passed on the stack, there is no need to store anything in CUMULATIVE_ARGS; however, the data structure must exist and should not be empty, so use int.
INIT_CUMULATIVE_ARGS (cum, fntype, libname, indirect)
A C statement (sans semicolon) for initializing the variable cum for the state at the beginning of the argument list. The variable has type CUMULATIVE_ARGS. The value of fntype is the tree node for the data type of the function which will receive the args, or 0 if the args are to a compiler support library function. The value of indirect is nonzero when processing an indirect call, for example a call through a function pointer. The value of indirect is zero for a call to an explicitly named function, a library function call, or when INIT_CUMULATIVE_ARGS is used to find arguments for the function being compiled. When processing a call to a compiler support library function, libname identifies which one. It is a symbol_ref rtx which contains the name of the function, as a string. libname is 0 when an ordinary C function call is being processed. Thus, each time this macro is called, either libname or fntype is nonzero, but never both of them at once.
INIT_CUMULATIVE_INCOMING_ARGS (cum, fntype, libname)
Like INIT_CUMULATIVE_ARGS but overrides it for the purposes of finding the arguments for the function being compiled. If this macro is undefined, INIT_CUMULATIVE_ARGS is used instead. The value passed for libname is always 0, since library routines with special calling conventions are never compiled with GNU CC. The argument libname exists for symmetry with INIT_CUMULATIVE_ARGS.
FUNCTION_ARG_ADVANCE (cum, mode, type, named)
A C statement (sans semicolon) to update the summarizer variable cum to advance past an argument in the argument list. The values mode, type and named describe that argument. Once this is done, the variable cum is suitable for analyzing the following argument with FUNCTION_ARG, etc. This macro need not do anything if the argument in question was passed on the stack. The compiler knows how to track the amount of stack space used for arguments without any special help.
FUNCTION_ARG_PADDING (mode, type)
If defined, a C expression which determines whether, and in which direction, to pad out an argument with extra space. The value should be of type enum direction: either upward to pad above the argument, downward to pad below, or none to inhibit padding. The amount of padding is always just enough to reach the next multiple of FUNCTION_ARG_BOUNDARY; this macro does not control it. This macro has a default definition which is right for most systems. For little-endian machines, the default is to pad upward. For big-endian machines, the default is to pad downward for an argument of constant size shorter than an int, and upward otherwise.
FUNCTION_ARG_BOUNDARY (mode, type)
If defined, a C expression that gives the alignment boundary, in bits, of an argument with the specified mode and type. If it is not defined, PARM_BOUNDARY is used for all arguments.
FUNCTION_ARG_REGNO_P (regno)
A C expression that is nonzero if regno is the number of a hard register in which function arguments are sometimes passed. This does not include implicit arguments such as the static chain and the structure-value address. On many machines, no registers can be used for this purpose since all function arguments are pushed on the stack.


Using and Porting GNU CC - Scalar Return

How Scalar Function Values Are Returned

This section discusses the macros that control returning scalars as values--values that can fit in registers.

TRADITIONAL_RETURN_FLOAT
Define this macro if `-traditional' should not cause functions declared to return float to convert the value to double.
FUNCTION_VALUE (valtype, func)
A C expression to create an RTX representing the place where a function returns a value of data type valtype. valtype is a tree node representing a data type. Write TYPE_MODE (valtype) to get the machine mode used to represent that type. On many machines, only the mode is relevant. (Actually, on most machines, scalar values are returned in the same place regardless of mode). The value of the expression is usually a reg RTX for the hard register where the return value is stored. The value can also be a parallel RTX, if the return value is in multiple places. See FUNCTION_ARG for an explanation of the parallel form. If PROMOTE_FUNCTION_RETURN is defined, you must apply the same promotion rules specified in PROMOTE_MODE if valtype is a scalar type. If the precise function being called is known, func is a tree node (FUNCTION_DECL) for it; otherwise, func is a null pointer. This makes it possible to use a different value-returning convention for specific functions when all their calls are known. FUNCTION_VALUE is not used for return vales with aggregate data types, because these are returned in another way. See STRUCT_VALUE_REGNUM and related macros, below.
FUNCTION_OUTGOING_VALUE (valtype, func)
Define this macro if the target machine has "register windows" so that the register in which a function returns its value is not the same as the one in which the caller sees the value. For such machines, FUNCTION_VALUE computes the register in which the caller will see the value. FUNCTION_OUTGOING_VALUE should be defined in a similar fashion to tell the function where to put the value. If FUNCTION_OUTGOING_VALUE is not defined, FUNCTION_VALUE serves both purposes. FUNCTION_OUTGOING_VALUE is not used for return vales with aggregate data types, because these are returned in another way. See STRUCT_VALUE_REGNUM and related macros, below.
LIBCALL_VALUE (mode)
A C expression to create an RTX representing the place where a library function returns a value of mode mode. If the precise function being called is known, func is a tree node (FUNCTION_DECL) for it; otherwise, func is a null pointer. This makes it possible to use a different value-returning convention for specific functions when all their calls are known. Note that "library function" in this context means a compiler support routine, used to perform arithmetic, whose name is known specially by the compiler and was not mentioned in the C code being compiled. The definition of LIBRARY_VALUE need not be concerned aggregate data types, because none of the library functions returns such types.
FUNCTION_VALUE_REGNO_P (regno)
A C expression that is nonzero if regno is the number of a hard register in which the values of called function may come back. A register whose use for returning values is limited to serving as the second of a pair (for a value of type double, say) need not be recognized by this macro. So for most machines, this definition suffices:
#define FUNCTION_VALUE_REGNO_P(N) ((N) == 0)
If the machine has register windows, so that the caller and the called function use different registers for the return value, this macro should recognize only the caller's register numbers.
APPLY_RESULT_SIZE
Define this macro if `untyped_call' and `untyped_return' need more space than is implied by FUNCTION_VALUE_REGNO_P for saving and restoring an arbitrary return value.


Using and Porting GNU CC - Aggregate Return

How Large Values Are Returned

When a function value's mode is BLKmode (and in some other cases), the value is not returned according to FUNCTION_VALUE (see section How Scalar Function Values Are Returned). Instead, the caller passes the address of a block of memory in which the value should be stored. This address is called the structure value address.

This section describes how to control returning structure values in memory.

RETURN_IN_MEMORY (type)
A C expression which can inhibit the returning of certain function values in registers, based on the type of value. A nonzero value says to return the function value in memory, just as large structures are always returned. Here type will be a C expression of type tree, representing the data type of the value. Note that values of mode BLKmode must be explicitly handled by this macro. Also, the option `-fpcc-struct-return' takes effect regardless of this macro. On most systems, it is possible to leave the macro undefined; this causes a default definition to be used, whose value is the constant 1 for BLKmode values, and 0 otherwise. Do not use this macro to indicate that structures and unions should always be returned in memory. You should instead use DEFAULT_PCC_STRUCT_RETURN to indicate this.
DEFAULT_PCC_STRUCT_RETURN
Define this macro to be 1 if all structure and union return values must be in memory. Since this results in slower code, this should be defined only if needed for compatibility with other compilers or with an ABI. If you define this macro to be 0, then the conventions used for structure and union return values are decided by the RETURN_IN_MEMORY macro. If not defined, this defaults to the value 1.
STRUCT_VALUE_REGNUM
If the structure value address is passed in a register, then STRUCT_VALUE_REGNUM should be the number of that register.
STRUCT_VALUE
If the structure value address is not passed in a register, define STRUCT_VALUE as an expression returning an RTX for the place where the address is passed. If it returns 0, the address is passed as an "invisible" first argument.
STRUCT_VALUE_INCOMING_REGNUM
On some architectures the place where the structure value address is found by the called function is not the same place that the caller put it. This can be due to register windows, or it could be because the function prologue moves it to a different place. If the incoming location of the structure value address is in a register, define this macro as the register number.
STRUCT_VALUE_INCOMING
If the incoming location is not a register, then you should define STRUCT_VALUE_INCOMING as an expression for an RTX for where the called function should find the value. If it should find the value on the stack, define this to create a mem which refers to the frame pointer. A definition of 0 means that the address is passed as an "invisible" first argument.
PCC_STATIC_STRUCT_RETURN
Define this macro if the usual system convention on the target machine for returning structures and unions is for the called function to return the address of a static variable containing the value. Do not define this if the usual system convention is for the caller to pass an address to the subroutine. This macro has effect in `-fpcc-struct-return' mode, but it does nothing when you use `-freg-struct-return' mode.


Using and Porting GNU CC - Caller Saves

Caller-Saves Register Allocation

If you enable it, GNU CC can save registers around function calls. This makes it possible to use call-clobbered registers to hold variables that must live across calls.

DEFAULT_CALLER_SAVES
Define this macro if function calls on the target machine do not preserve any registers; in other words, if CALL_USED_REGISTERS has 1 for all registers. This macro enables `-fcaller-saves' by default. Eventually that option will be enabled by default on all machines and both the option and this macro will be eliminated.
CALLER_SAVE_PROFITABLE (refs, calls)
A C expression to determine whether it is worthwhile to consider placing a pseudo-register in a call-clobbered hard register and saving and restoring it around each function call. The expression should be 1 when this is worth doing, and 0 otherwise. If you don't define this macro, a default is used which is good on most machines: 4 * calls < refs.


Using and Porting GNU CC - Function Entry

Function Entry and Exit

This section describes the macros that output function entry (prologue) and exit (epilogue) code.

FUNCTION_PROLOGUE (file, size)
A C compound statement that outputs the assembler code for entry to a function. The prologue is responsible for setting up the stack frame, initializing the frame pointer register, saving registers that must be saved, and allocating size additional bytes of storage for the local variables. size is an integer. file is a stdio stream to which the assembler code should be output. The label for the beginning of the function need not be output by this macro. That has already been done when the macro is run. To determine which registers to save, the macro can refer to the array regs_ever_live: element r is nonzero if hard register r is used anywhere within the function. This implies the function prologue should save register r, provided it is not one of the call-used registers. (FUNCTION_EPILOGUE must likewise use regs_ever_live.) On machines that have "register windows", the function entry code does not save on the stack the registers that are in the windows, even if they are supposed to be preserved by function calls; instead it takes appropriate steps to "push" the register stack, if any non-call-used registers are used in the function. On machines where functions may or may not have frame-pointers, the function entry code must vary accordingly; it must set up the frame pointer if one is wanted, and not otherwise. To determine whether a frame pointer is in wanted, the macro can refer to the variable frame_pointer_needed. The variable's value will be 1 at run time in a function that needs a frame pointer. See section Eliminating Frame Pointer and Arg Pointer. The function entry code is responsible for allocating any stack space required for the function. This stack space consists of the regions listed below. In most cases, these regions are allocated in the order listed, with the last listed region closest to the top of the stack (the lowest address if STACK_GROWS_DOWNWARD is defined, and the highest address if it is not defined). You can use a different order for a machine if doing so is more convenient or required for compatibility reasons. Except in cases where required by standard or by a debugger, there is no reason why the stack layout used by GCC need agree with that used by other compilers for a machine.
  • A region of current_function_pretend_args_size bytes of uninitialized space just underneath the first argument arriving on the stack. (This may not be at the very start of the allocated stack region if the calling sequence has pushed anything else since pushing the stack arguments. But usually, on such machines, nothing else has been pushed yet, because the function prologue itself does all the pushing.) This region is used on machines where an argument may be passed partly in registers and partly in memory, and, in some cases to support the features in `varargs.h' and `stdargs.h'.
  • An area of memory used to save certain registers used by the function. The size of this area, which may also include space for such things as the return address and pointers to previous stack frames, is machine-specific and usually depends on which registers have been used in the function. Machines with register windows often do not require a save area.
  • A region of at least size bytes, possibly rounded up to an allocation boundary, to contain the local variables of the function. On some machines, this region and the save area may occur in the opposite order, with the save area closer to the top of the stack.
  • Optionally, when ACCUMULATE_OUTGOING_ARGS is defined, a region of current_function_outgoing_args_size bytes to be used for outgoing argument lists of the function. See section Passing Function Arguments on the Stack.
Normally, it is necessary for the macros FUNCTION_PROLOGUE and FUNCTION_EPILOGUE to treat leaf functions specially. The C variable leaf_function is nonzero for such a function.
EXIT_IGNORE_STACK
Define this macro as a C expression that is nonzero if the return instruction or the function epilogue ignores the value of the stack pointer; in other words, if it is safe to delete an instruction to adjust the stack pointer before a return from the function. Note that this macro's value is relevant only for functions for which frame pointers are maintained. It is never safe to delete a final stack adjustment in a function that has no frame pointer, and the compiler knows this regardless of EXIT_IGNORE_STACK.
EPILOGUE_USES (regno)
Define this macro as a C expression that is nonzero for registers are used by the epilogue or the `return' pattern. The stack and frame pointer registers are already be assumed to be used as needed.
FUNCTION_EPILOGUE (file, size)
A C compound statement that outputs the assembler code for exit from a function. The epilogue is responsible for restoring the saved registers and stack pointer to their values when the function was called, and returning control to the caller. This macro takes the same arguments as the macro FUNCTION_PROLOGUE, and the registers to restore are determined from regs_ever_live and CALL_USED_REGISTERS in the same way. On some machines, there is a single instruction that does all the work of returning from the function. On these machines, give that instruction the name `return' and do not define the macro FUNCTION_EPILOGUE at all. Do not define a pattern named `return' if you want the FUNCTION_EPILOGUE to be used. If you want the target switches to control whether return instructions or epilogues are used, define a `return' pattern with a validity condition that tests the target switches appropriately. If the `return' pattern's validity condition is false, epilogues will be used. On machines where functions may or may not have frame-pointers, the function exit code must vary accordingly. Sometimes the code for these two cases is completely different. To determine whether a frame pointer is wanted, the macro can refer to the variable frame_pointer_needed. The variable's value will be 1 when compiling a function that needs a frame pointer. Normally, FUNCTION_PROLOGUE and FUNCTION_EPILOGUE must treat leaf functions specially. The C variable leaf_function is nonzero for such a function. See section Handling Leaf Functions. On some machines, some functions pop their arguments on exit while others leave that for the caller to do. For example, the 68020 when given `-mrtd' pops arguments in functions that take a fixed number of arguments. Your definition of the macro RETURN_POPS_ARGS decides which functions pop their own arguments. FUNCTION_EPILOGUE needs to know what was decided. The variable that is called current_function_pops_args is the number of bytes of its arguments that a function should pop. See section How Scalar Function Values Are Returned.
DELAY_SLOTS_FOR_EPILOGUE
Define this macro if the function epilogue contains delay slots to which instructions from the rest of the function can be "moved". The definition should be a C expression whose value is an integer representing the number of delay slots there.
ELIGIBLE_FOR_EPILOGUE_DELAY (insn, n)
A C expression that returns 1 if insn can be placed in delay slot number n of the epilogue. The argument n is an integer which identifies the delay slot now being considered (since different slots may have different rules of eligibility). It is never negative and is always less than the number of epilogue delay slots (what DELAY_SLOTS_FOR_EPILOGUE returns). If you reject a particular insn for a given delay slot, in principle, it may be reconsidered for a subsequent delay slot. Also, other insns may (at least in principle) be considered for the so far unfilled delay slot. The insns accepted to fill the epilogue delay slots are put in an RTL list made with insn_list objects, stored in the variable current_function_epilogue_delay_list. The insn for the first delay slot comes first in the list. Your definition of the macro FUNCTION_EPILOGUE should fill the delay slots by outputting the insns in this list, usually by calling final_scan_insn. You need not define this macro if you did not define DELAY_SLOTS_FOR_EPILOGUE.
ASM_OUTPUT_MI_THUNK (file, thunk_fndecl, delta, function)
A C compound statement that outputs the assembler code for a thunk function, used to implement C++ virtual function calls with multiple inheritance. The thunk acts as a wrapper around a virtual function, adjusting the implicit object parameter before handing control off to the real function. First, emit code to add the integer delta to the location that contains the incoming first argument. Assume that this argument contains a pointer, and is the one used to pass the this pointer in C++. This is the incoming argument before the function prologue, e.g. `%o0' on a sparc. The addition must preserve the values of all other incoming arguments. After the addition, emit code to jump to function, which is a FUNCTION_DECL. This is a direct pure jump, not a call, and does not touch the return address. Hence returning from FUNCTION will return to whoever called the current `thunk'. The effect must be as if function had been called directly with the adjusted first argument. This macro is responsible for emitting all of the code for a thunk function; FUNCTION_PROLOGUE and FUNCTION_EPILOGUE are not invoked. The thunk_fndecl is redundant. (delta and function have already been extracted from it.) It might possibly be useful on some targets, but probably not. If you do not define this macro, the target-independent code in the C++ frontend will generate a less efficient heavyweight thunk that calls function instead of jumping to it. The generic approach does not support varargs.


Using and Porting GNU CC - Profiling

Generating Code for Profiling

These macros will help you generate code for profiling.

FUNCTION_PROFILER (file, labelno)
A C statement or compound statement to output to file some assembler code to call the profiling subroutine mcount. Before calling, the assembler code must load the address of a counter variable into a register where mcount expects to find the address. The name of this variable is `LP' followed by the number labelno, so you would generate the name using `LP%d' in a fprintf. The details of how the address should be passed to mcount are determined by your operating system environment, not by GNU CC. To figure them out, compile a small program for profiling using the system's installed C compiler and look at the assembler code that results.
PROFILE_BEFORE_PROLOGUE
Define this macro if the code for function profiling should come before the function prologue. Normally, the profiling code comes after.
FUNCTION_BLOCK_PROFILER (file, labelno)
A C statement or compound statement to output to file some assembler code to initialize basic-block profiling for the current object module. The global compile flag profile_block_flag distingishes two profile modes.
profile_block_flag != 2
Output code to call the subroutine __bb_init_func once per object module, passing it as its sole argument the address of a block allocated in the object module. The name of the block is a local symbol made with this statement:
ASM_GENERATE_INTERNAL_LABEL (buffer, "LPBX", 0);
Of course, since you are writing the definition of ASM_GENERATE_INTERNAL_LABEL as well as that of this macro, you can take a short cut in the definition of this macro and use the name that you know will result. The first word of this block is a flag which will be nonzero if the object module has already been initialized. So test this word first, and do not call __bb_init_func if the flag is nonzero. BLOCK_OR_LABEL contains a unique number which may be used to generate a label as a branch destination when __bb_init_func will not be called. Described in assembler language, the code to be output looks like:
  cmp (LPBX0),0
  bne local_label
  parameter1 <- LPBX0
  call __bb_init_func
local_label:
profile_block_flag == 2
Output code to call the subroutine __bb_init_trace_func and pass two parameters to it. The first parameter is the same as for __bb_init_func. The second parameter is the number of the first basic block of the function as given by BLOCK_OR_LABEL. Note that __bb_init_trace_func has to be called, even if the object module has been initialized already. Described in assembler language, the code to be output looks like:
parameter1 <- LPBX0
parameter2 <- BLOCK_OR_LABEL
call __bb_init_trace_func
BLOCK_PROFILER (file, blockno)
A C statement or compound statement to output to file some assembler code to increment the count associated with the basic block number blockno. The global compile flag profile_block_flag distingishes two profile modes.
profile_block_flag != 2
Output code to increment the counter directly. Basic blocks are numbered separately from zero within each compilation. The count associated with block number blockno is at index blockno in a vector of words; the name of this array is a local symbol made with this statement:
ASM_GENERATE_INTERNAL_LABEL (buffer, "LPBX", 2);
Of course, since you are writing the definition of ASM_GENERATE_INTERNAL_LABEL as well as that of this macro, you can take a short cut in the definition of this macro and use the name that you know will result. Described in assembler language, the code to be output looks like:
inc (LPBX2+4*BLOCKNO)
profile_block_flag == 2
Output code to initialize the global structure __bb and call the function __bb_trace_func, which will increment the counter. __bb consists of two words. In the first word, the current basic block number, as given by BLOCKNO, has to be stored. In the second word, the address of a block allocated in the object module has to be stored. The address is given by the label created with this statement:
ASM_GENERATE_INTERNAL_LABEL (buffer, "LPBX", 0);
Described in assembler language, the code to be output looks like:
move BLOCKNO -> (__bb)
move LPBX0 -> (__bb+4)
call __bb_trace_func
FUNCTION_BLOCK_PROFILER_EXIT (file)
A C statement or compound statement to output to file assembler code to call function __bb_trace_ret. The assembler code should only be output if the global compile flag profile_block_flag == 2. This macro has to be used at every place where code for returning from a function is generated (e.g. FUNCTION_EPILOGUE). Although you have to write the definition of FUNCTION_EPILOGUE as well, you have to define this macro to tell the compiler, that the proper call to __bb_trace_ret is produced.
MACHINE_STATE_SAVE (id)
A C statement or compound statement to save all registers, which may be clobbered by a function call, including condition codes. The asm statement will be mostly likely needed to handle this task. Local labels in the assembler code can be concatenated with the string id, to obtain a unique lable name. Registers or condition codes clobbered by FUNCTION_PROLOGUE or FUNCTION_EPILOGUE must be saved in the macros FUNCTION_BLOCK_PROFILER, FUNCTION_BLOCK_PROFILER_EXIT and BLOCK_PROFILER prior calling __bb_init_trace_func, __bb_trace_ret and __bb_trace_func respectively.
MACHINE_STATE_RESTORE (id)
A C statement or compound statement to restore all registers, including condition codes, saved by MACHINE_STATE_SAVE. Registers or condition codes clobbered by FUNCTION_PROLOGUE or FUNCTION_EPILOGUE must be restored in the macros FUNCTION_BLOCK_PROFILER, FUNCTION_BLOCK_PROFILER_EXIT and BLOCK_PROFILER after calling __bb_init_trace_func, __bb_trace_ret and __bb_trace_func respectively.
BLOCK_PROFILER_CODE
A C function or functions which are needed in the library to support block profiling.


Using and Porting GNU CC - Varargs

Implementing the Varargs Macros

GNU CC comes with an implementation of `varargs.h' and `stdarg.h' that work without change on machines that pass arguments on the stack. Other machines require their own implementations of varargs, and the two machine independent header files must have conditionals to include it.

ANSI `stdarg.h' differs from traditional `varargs.h' mainly in the calling convention for va_start. The traditional implementation takes just one argument, which is the variable in which to store the argument pointer. The ANSI implementation of va_start takes an additional second argument. The user is supposed to write the last named argument of the function here.

However, va_start should not use this argument. The way to find the end of the named arguments is with the built-in functions described below.

__builtin_saveregs ()
Use this built-in function to save the argument registers in memory so that the varargs mechanism can access them. Both ANSI and traditional versions of va_start must use __builtin_saveregs, unless you use SETUP_INCOMING_VARARGS (see below) instead. On some machines, __builtin_saveregs is open-coded under the control of the macro EXPAND_BUILTIN_SAVEREGS. On other machines, it calls a routine written in assembler language, found in `libgcc2.c'. Code generated for the call to __builtin_saveregs appears at the beginning of the function, as opposed to where the call to __builtin_saveregs is written, regardless of what the code is. This is because the registers must be saved before the function starts to use them for its own purposes.
__builtin_args_info (category)
Use this built-in function to find the first anonymous arguments in registers. In general, a machine may have several categories of registers used for arguments, each for a particular category of data types. (For example, on some machines, floating-point registers are used for floating-point arguments while other arguments are passed in the general registers.) To make non-varargs functions use the proper calling convention, you have defined the CUMULATIVE_ARGS data type to record how many registers in each category have been used so far __builtin_args_info accesses the same data structure of type CUMULATIVE_ARGS after the ordinary argument layout is finished with it, with category specifying which word to access. Thus, the value indicates the first unused register in a given category. Normally, you would use __builtin_args_info in the implementation of va_start, accessing each category just once and storing the value in the va_list object. This is because va_list will have to update the values, and there is no way to alter the values accessed by __builtin_args_info.
__builtin_next_arg (lastarg)
This is the equivalent of __builtin_args_info, for stack arguments. It returns the address of the first anonymous stack argument, as type void *. If ARGS_GROW_DOWNWARD, it returns the address of the location above the first anonymous stack argument. Use it in va_start to initialize the pointer for fetching arguments from the stack. Also use it in va_start to verify that the second parameter lastarg is the last named argument of the current function.
__builtin_classify_type (object)
Since each machine has its own conventions for which data types are passed in which kind of register, your implementation of va_arg has to embody these conventions. The easiest way to categorize the specified data type is to use __builtin_classify_type together with sizeof and __alignof__. __builtin_classify_type ignores the value of object, considering only its data type. It returns an integer describing what kind of type that is--integer, floating, pointer, structure, and so on. The file `typeclass.h' defines an enumeration that you can use to interpret the values of __builtin_classify_type.

These machine description macros help implement varargs:

EXPAND_BUILTIN_SAVEREGS (args)
If defined, is a C expression that produces the machine-specific code for a call to __builtin_saveregs. This code will be moved to the very beginning of the function, before any parameter access are made. The return value of this function should be an RTX that contains the value to use as the return of __builtin_saveregs. The argument args is a tree_list containing the arguments that were passed to __builtin_saveregs. If this macro is not defined, the compiler will output an ordinary call to the library function `__builtin_saveregs'.
SETUP_INCOMING_VARARGS (args_so_far, mode, type,
pretend_args_size, second_time) This macro offers an alternative to using __builtin_saveregs and defining the macro EXPAND_BUILTIN_SAVEREGS. Use it to store the anonymous register arguments into the stack so that all the arguments appear to have been passed consecutively on the stack. Once this is done, you can use the standard implementation of varargs that works for machines that pass all their arguments on the stack. The argument args_so_far is the CUMULATIVE_ARGS data structure, containing the values that obtain after processing of the named arguments. The arguments mode and type describe the last named argument--its machine mode and its data type as a tree node. The macro implementation should do two things: first, push onto the stack all the argument registers not used for the named arguments, and second, store the size of the data thus pushed into the int-valued variable whose name is supplied as the argument pretend_args_size. The value that you store here will serve as additional offset for setting up the stack frame. Because you must generate code to push the anonymous arguments at compile time without knowing their data types, SETUP_INCOMING_VARARGS is only useful on machines that have just a single category of argument register and use it uniformly for all data types. If the argument second_time is nonzero, it means that the arguments of the function are being analyzed for the second time. This happens for an inline function, which is not actually compiled until the end of the source file. The macro SETUP_INCOMING_VARARGS should not generate any instructions in this case.
STRICT_ARGUMENT_NAMING
Define this macro if the location where a function argument is passed depends on whether or not it is a named argument. This macro controls how the named argument to FUNCTION_ARG is set for varargs and stdarg functions. With this macro defined, the named argument is always true for named arguments, and false for unnamed arguments. If this is not defined, but SETUP_INCOMING_VARARGS is defined, then all arguments are treated as named. Otherwise, all named arguments except the last are treated as named.


Using and Porting GNU CC - Trampolines

Trampolines for Nested Functions

A trampoline is a small piece of code that is created at run time when the address of a nested function is taken. It normally resides on the stack, in the stack frame of the containing function. These macros tell GNU CC how to generate code to allocate and initialize a trampoline.

The instructions in the trampoline must do two things: load a constant address into the static chain register, and jump to the real address of the nested function. On CISC machines such as the m68k, this requires two instructions, a move immediate and a jump. Then the two addresses exist in the trampoline as word-long immediate operands. On RISC machines, it is often necessary to load each address into a register in two parts. Then pieces of each address form separate immediate operands.

The code generated to initialize the trampoline must store the variable parts--the static chain value and the function address--into the immediate operands of the instructions. On a CISC machine, this is simply a matter of copying each address to a memory reference at the proper offset from the start of the trampoline. On a RISC machine, it may be necessary to take out pieces of the address and store them separately.

TRAMPOLINE_TEMPLATE (file)
A C statement to output, on the stream file, assembler code for a block of data that contains the constant parts of a trampoline. This code should not include a label--the label is taken care of automatically. If you do not define this macro, it means no template is needed for the target. Do not define this macro on systems where the block move code to copy the trampoline into place would be larger than the code to generate it on the spot.
TRAMPOLINE_SECTION
The name of a subroutine to switch to the section in which the trampoline template is to be placed (see section Dividing the Output into Sections (Texts, Data, ...)). The default is a value of `readonly_data_section', which places the trampoline in the section containing read-only data.
TRAMPOLINE_SIZE
A C expression for the size in bytes of the trampoline, as an integer.
TRAMPOLINE_ALIGNMENT
Alignment required for trampolines, in bits. If you don't define this macro, the value of BIGGEST_ALIGNMENT is used for aligning trampolines.
INITIALIZE_TRAMPOLINE (addr, fnaddr, static_chain)
A C statement to initialize the variable parts of a trampoline. addr is an RTX for the address of the trampoline; fnaddr is an RTX for the address of the nested function; static_chain is an RTX for the static chain value that should be passed to the function when it is called.
ALLOCATE_TRAMPOLINE (fp)
A C expression to allocate run-time space for a trampoline. The expression value should be an RTX representing a memory reference to the space for the trampoline. If this macro is not defined, by default the trampoline is allocated as a stack slot. This default is right for most machines. The exceptions are machines where it is impossible to execute instructions in the stack area. On such machines, you may have to implement a separate stack, using this macro in conjunction with FUNCTION_PROLOGUE and FUNCTION_EPILOGUE. fp points to a data structure, a struct function, which describes the compilation status of the immediate containing function of the function which the trampoline is for. Normally (when ALLOCATE_TRAMPOLINE is not defined), the stack slot for the trampoline is in the stack frame of this containing function. Other allocation strategies probably must do something analogous with this information.

Implementing trampolines is difficult on many machines because they have separate instruction and data caches. Writing into a stack location fails to clear the memory in the instruction cache, so when the program jumps to that location, it executes the old contents.

Here are two possible solutions. One is to clear the relevant parts of the instruction cache whenever a trampoline is set up. The other is to make all trampolines identical, by having them jump to a standard subroutine. The former technique makes trampoline execution faster; the latter makes initialization faster.

To clear the instruction cache when a trampoline is initialized, define the following macros which describe the shape of the cache.

INSN_CACHE_SIZE
The total size in bytes of the cache.
INSN_CACHE_LINE_WIDTH
The length in bytes of each cache line. The cache is divided into cache lines which are disjoint slots, each holding a contiguous chunk of data fetched from memory. Each time data is brought into the cache, an entire line is read at once. The data loaded into a cache line is always aligned on a boundary equal to the line size.
INSN_CACHE_DEPTH
The number of alternative cache lines that can hold any particular memory location.

Alternatively, if the machine has system calls or instructions to clear the instruction cache directly, you can define the following macro.

CLEAR_INSN_CACHE (BEG, END)
If defined, expands to a C expression clearing the instruction cache in the specified interval. If it is not defined, and the macro INSN_CACHE_SIZE is defined, some generic code is generated to clear the cache. The definition of this macro would typically be a series of asm statements. Both BEG and END are both pointer expressions.

To use a standard subroutine, define the following macro. In addition, you must make sure that the instructions in a trampoline fill an entire cache line with identical instructions, or else ensure that the beginning of the trampoline code is always aligned at the same point in its cache line. Look in `m68k.h' as a guide.

TRANSFER_FROM_TRAMPOLINE
Define this macro if trampolines need a special subroutine to do their work. The macro should expand to a series of asm statements which will be compiled with GNU CC. They go in a library function named __transfer_from_trampoline. If you need to avoid executing the ordinary prologue code of a compiled C function when you jump to the subroutine, you can do so by placing a special label of your own in the assembler code. Use one asm statement to generate an assembler label, and another to make the label global. Then trampolines can use that label to jump directly to your special assembler code.


Using and Porting GNU CC - Library Calls

Implicit Calls to Library Routines

Here is an explanation of implicit calls to library routines.

MULSI3_LIBCALL
A C string constant giving the name of the function to call for multiplication of one signed full-word by another. If you do not define this macro, the default name is used, which is __mulsi3, a function defined in `libgcc.a'.
DIVSI3_LIBCALL
A C string constant giving the name of the function to call for division of one signed full-word by another. If you do not define this macro, the default name is used, which is __divsi3, a function defined in `libgcc.a'.
UDIVSI3_LIBCALL
A C string constant giving the name of the function to call for division of one unsigned full-word by another. If you do not define this macro, the default name is used, which is __udivsi3, a function defined in `libgcc.a'.
MODSI3_LIBCALL
A C string constant giving the name of the function to call for the remainder in division of one signed full-word by another. If you do not define this macro, the default name is used, which is __modsi3, a function defined in `libgcc.a'.
UMODSI3_LIBCALL
A C string constant giving the name of the function to call for the remainder in division of one unsigned full-word by another. If you do not define this macro, the default name is used, which is __umodsi3, a function defined in `libgcc.a'.
MULDI3_LIBCALL
A C string constant giving the name of the function to call for multiplication of one signed double-word by another. If you do not define this macro, the default name is used, which is __muldi3, a function defined in `libgcc.a'.
DIVDI3_LIBCALL
A C string constant giving the name of the function to call for division of one signed double-word by another. If you do not define this macro, the default name is used, which is __divdi3, a function defined in `libgcc.a'.
UDIVDI3_LIBCALL
A C string constant giving the name of the function to call for division of one unsigned full-word by another. If you do not define this macro, the default name is used, which is __udivdi3, a function defined in `libgcc.a'.
MODDI3_LIBCALL
A C string constant giving the name of the function to call for the remainder in division of one signed double-word by another. If you do not define this macro, the default name is used, which is __moddi3, a function defined in `libgcc.a'.
UMODDI3_LIBCALL
A C string constant giving the name of the function to call for the remainder in division of one unsigned full-word by another. If you do not define this macro, the default name is used, which is __umoddi3, a function defined in `libgcc.a'.
INIT_TARGET_OPTABS
Define this macro as a C statement that declares additional library routines renames existing ones. init_optabs calls this macro after initializing all the normal library routines.
TARGET_EDOM
The value of EDOM on the target machine, as a C integer constant expression. If you don't define this macro, GNU CC does not attempt to deposit the value of EDOM into errno directly. Look in `/usr/include/errno.h' to find the value of EDOM on your system. If you do not define TARGET_EDOM, then compiled code reports domain errors by calling the library function and letting it report the error. If mathematical functions on your system use matherr when there is an error, then you should leave TARGET_EDOM undefined so that matherr is used normally.
GEN_ERRNO_RTX
Define this macro as a C expression to create an rtl expression that refers to the global "variable" errno. (On certain systems, errno may not actually be a variable.) If you don't define this macro, a reasonable default is used.
TARGET_MEM_FUNCTIONS
Define this macro if GNU CC should generate calls to the System V (and ANSI C) library functions memcpy and memset rather than the BSD functions bcopy and bzero.
LIBGCC_NEEDS_DOUBLE
Define this macro if only float arguments cannot be passed to library routines (so they must be converted to double). This macro affects both how library calls are generated and how the library routines in `libgcc1.c' accept their arguments. It is useful on machines where floating and fixed point arguments are passed differently, such as the i860.
FLOAT_ARG_TYPE
Define this macro to override the type used by the library routines to pick up arguments of type float. (By default, they use a union of float and int.) The obvious choice would be float---but that won't work with traditional C compilers that expect all arguments declared as float to arrive as double. To avoid this conversion, the library routines ask for the value as some other type and then treat it as a float. On some systems, no other type will work for this. For these systems, you must use LIBGCC_NEEDS_DOUBLE instead, to force conversion of the values double before they are passed.
FLOATIFY (passed-value)
Define this macro to override the way library routines redesignate a float argument as a float instead of the type it was passed as. The default is an expression which takes the float field of the union.
FLOAT_VALUE_TYPE
Define this macro to override the type used by the library routines to return values that ought to have type float. (By default, they use int.) The obvious choice would be float---but that won't work with traditional C compilers gratuitously convert values declared as float into double.
INTIFY (float-value)
Define this macro to override the way the value of a float-returning library routine should be packaged in order to return it. These functions are actually declared to return type FLOAT_VALUE_TYPE (normally int). These values can't be returned as type float because traditional C compilers would gratuitously convert the value to a double. A local variable named intify is always available when the macro INTIFY is used. It is a union of a float field named f and a field named i whose type is FLOAT_VALUE_TYPE or int. If you don't define this macro, the default definition works by copying the value through that union.
nongcc_SI_type
Define this macro as the name of the data type corresponding to SImode in the system's own C compiler. You need not define this macro if that type is long int, as it usually is.
nongcc_word_type
Define this macro as the name of the data type corresponding to the word_mode in the system's own C compiler. You need not define this macro if that type is long int, as it usually is.
perform_...
Define these macros to supply explicit C statements to carry out various arithmetic operations on types float and double in the library routines in `libgcc1.c'. See that file for a full list of these macros and their arguments. On most machines, you don't need to define any of these macros, because the C compiler that comes with the system takes care of doing them.
NEXT_OBJC_RUNTIME
Define this macro to generate code for Objective C message sending using the calling convention of the NeXT system. This calling convention involves passing the object, the selector and the method arguments all at once to the method-lookup library function. The default calling convention passes just the object and the selector to the lookup function, which returns a pointer to the method.


Using and Porting GNU CC - Addressing Modes

Addressing Modes

This is about addressing modes.

HAVE_POST_INCREMENT
Define this macro if the machine supports post-increment addressing.
HAVE_PRE_INCREMENT
HAVE_POST_DECREMENT
HAVE_PRE_DECREMENT
Similar for other kinds of addressing.
CONSTANT_ADDRESS_P (x)
A C expression that is 1 if the RTX x is a constant which is a valid address. On most machines, this can be defined as CONSTANT_P (x), but a few machines are more restrictive in which constant addresses are supported. CONSTANT_P accepts integer-values expressions whose values are not explicitly known, such as symbol_ref, label_ref, and high expressions and const arithmetic expressions, in addition to const_int and const_double expressions.
MAX_REGS_PER_ADDRESS
A number, the maximum number of registers that can appear in a valid memory address. Note that it is up to you to specify a value equal to the maximum number that GO_IF_LEGITIMATE_ADDRESS would ever accept.
GO_IF_LEGITIMATE_ADDRESS (mode, x, label)
A C compound statement with a conditional goto label; executed if x (an RTX) is a legitimate memory address on the target machine for a memory operand of mode mode. It usually pays to define several simpler macros to serve as subroutines for this one. Otherwise it may be too complicated to understand. This macro must exist in two variants: a strict variant and a non-strict one. The strict variant is used in the reload pass. It must be defined so that any pseudo-register that has not been allocated a hard register is considered a memory reference. In contexts where some kind of register is required, a pseudo-register with no hard register must be rejected. The non-strict variant is used in other passes. It must be defined to accept all pseudo-registers in every context where some kind of register is required. Compiler source files that want to use the strict variant of this macro define the macro REG_OK_STRICT. You should use an #ifdef REG_OK_STRICT conditional to define the strict variant in that case and the non-strict variant otherwise. Subroutines to check for acceptable registers for various purposes (one for base registers, one for index registers, and so on) are typically among the subroutines used to define GO_IF_LEGITIMATE_ADDRESS. Then only these subroutine macros need have two variants; the higher levels of macros may be the same whether strict or not. Normally, constant addresses which are the sum of a symbol_ref and an integer are stored inside a const RTX to mark them as constant. Therefore, there is no need to recognize such sums specifically as legitimate addresses. Normally you would simply recognize any const as legitimate. Usually PRINT_OPERAND_ADDRESS is not prepared to handle constant sums that are not marked with const. It assumes that a naked plus indicates indexing. If so, then you must reject such naked constant sums as illegitimate addresses, so that none of them will be given to PRINT_OPERAND_ADDRESS. On some machines, whether a symbolic address is legitimate depends on the section that the address refers to. On these machines, define the macro ENCODE_SECTION_INFO to store the information into the symbol_ref, and then check for it here. When you see a const, you will have to look inside it to find the symbol_ref in order to determine the section. See section Defining the Output Assembler Language. The best way to modify the name string is by adding text to the beginning, with suitable punctuation to prevent any ambiguity. Allocate the new name in saveable_obstack. You will have to modify ASM_OUTPUT_LABELREF to remove and decode the added text and output the name accordingly, and define STRIP_NAME_ENCODING to access the original name string. You can check the information stored here into the symbol_ref in the definitions of the macros GO_IF_LEGITIMATE_ADDRESS and PRINT_OPERAND_ADDRESS.
REG_OK_FOR_BASE_P (x)
A C expression that is nonzero if x (assumed to be a reg RTX) is valid for use as a base register. For hard registers, it should always accept those which the hardware permits and reject the others. Whether the macro accepts or rejects pseudo registers must be controlled by REG_OK_STRICT as described above. This usually requires two variant definitions, of which REG_OK_STRICT controls the one actually used.
REG_MODE_OK_FOR_BASE_P (x, mode)
A C expression that is just like REG_OK_FOR_BASE_P, except that that expression may examine the mode of the memory reference in mode. You should define this macro if the mode of the memory reference affects whether a register may be used as a base register. If you define this macro, the compiler will use it instead of REG_OK_FOR_BASE_P.
REG_OK_FOR_INDEX_P (x)
A C expression that is nonzero if x (assumed to be a reg RTX) is valid for use as an index register. The difference between an index register and a base register is that the index register may be scaled. If an address involves the sum of two registers, neither one of them scaled, then either one may be labeled the "base" and the other the "index"; but whichever labeling is used must fit the machine's constraints of which registers may serve in each capacity. The compiler will try both labelings, looking for one that is valid, and will reload one or both registers only if neither labeling works.
LEGITIMIZE_ADDRESS (x, oldx, mode, win)
A C compound statement that attempts to replace x with a valid memory address for an operand of mode mode. win will be a C statement label elsewhere in the code; the macro definition may use
GO_IF_LEGITIMATE_ADDRESS (mode, x, win);
to avoid further processing if the address has become legitimate. x will always be the result of a call to break_out_memory_refs, and oldx will be the operand that was given to that function to produce x. The code generated by this macro should not alter the substructure of x. If it transforms x into a more legitimate form, it should assign x (which will always be a C variable) a new value. It is not necessary for this macro to come up with a legitimate address. The compiler has standard ways of doing so in all cases. In fact, it is safe for this macro to do nothing. But often a machine-dependent strategy can generate better code.
GO_IF_MODE_DEPENDENT_ADDRESS (addr, label)
A C statement or compound statement with a conditional goto label; executed if memory address x (an RTX) can have different meanings depending on the machine mode of the memory reference it is used for or if the address is valid for some modes but not others. Autoincrement and autodecrement addresses typically have mode-dependent effects because the amount of the increment or decrement is the size of the operand being addressed. Some machines have other mode-dependent addresses. Many RISC machines have no mode-dependent addresses. You may assume that addr is a valid address for the machine.
LEGITIMATE_CONSTANT_P (x)
A C expression that is nonzero if x is a legitimate constant for an immediate operand on the target machine. You can assume that x satisfies CONSTANT_P, so you need not check this. In fact, `1' is a suitable definition for this macro on machines where anything CONSTANT_P is valid.
DONT_RECORD_EQUIVALENCE (note)
A C expression that is nonzero if the REG_EQUAL note x should not be promoted to a REG_EQUIV note. Define this macro if note refers to a constant that must be accepted by LEGITIMATE_CONSTANT_P, but must not appear as an immediate operand. Most machine descriptions do not need to define this macro.


Using and Porting GNU CC - Condition Code

Condition Code Status

This describes the condition code status.

The file `conditions.h' defines a variable cc_status to describe how the condition code was computed (in case the interpretation of the condition code depends on the instruction that it was set by). This variable contains the RTL expressions on which the condition code is currently based, and several standard flags.

Sometimes additional machine-specific flags must be defined in the machine description header file. It can also add additional machine-specific information by defining CC_STATUS_MDEP.

CC_STATUS_MDEP
C code for a data type which is used for declaring the mdep component of cc_status. It defaults to int. This macro is not used on machines that do not use cc0.
CC_STATUS_MDEP_INIT
A C expression to initialize the mdep field to "empty". The default definition does nothing, since most machines don't use the field anyway. If you want to use the field, you should probably define this macro to initialize it. This macro is not used on machines that do not use cc0.
NOTICE_UPDATE_CC (exp, insn)
A C compound statement to set the components of cc_status appropriately for an insn insn whose body is exp. It is this macro's responsibility to recognize insns that set the condition code as a byproduct of other activity as well as those that explicitly set (cc0). This macro is not used on machines that do not use cc0. If there are insns that do not set the condition code but do alter other machine registers, this macro must check to see whether they invalidate the expressions that the condition code is recorded as reflecting. For example, on the 68000, insns that store in address registers do not set the condition code, which means that usually NOTICE_UPDATE_CC can leave cc_status unaltered for such insns. But suppose that the previous insn set the condition code based on location `a4@(102)' and the current insn stores a new value in `a4'. Although the condition code is not changed by this, it will no longer be true that it reflects the contents of `a4@(102)'. Therefore, NOTICE_UPDATE_CC must alter cc_status in this case to say that nothing is known about the condition code value. The definition of NOTICE_UPDATE_CC must be prepared to deal with the results of peephole optimization: insns whose patterns are parallel RTXs containing various reg, mem or constants which are just the operands. The RTL structure of these insns is not sufficient to indicate what the insns actually do. What NOTICE_UPDATE_CC should do when it sees one is just to run CC_STATUS_INIT. A possible definition of NOTICE_UPDATE_CC is to call a function that looks at an attribute (see section Instruction Attributes) named, for example, `cc'. This avoids having detailed information about patterns in two places, the `md' file and in NOTICE_UPDATE_CC.
EXTRA_CC_MODES
A list of names to be used for additional modes for condition code values in registers (see section Defining Jump Instruction Patterns). These names are added to enum machine_mode and all have class MODE_CC. By convention, they should start with `CC' and end with `mode'. You should only define this macro if your machine does not use cc0 and only if additional modes are required.
EXTRA_CC_NAMES
A list of C strings giving the names for the modes listed in EXTRA_CC_MODES. For example, the Sparc defines this macro and EXTRA_CC_MODES as
#define EXTRA_CC_MODES CC_NOOVmode, CCFPmode, CCFPEmode
#define EXTRA_CC_NAMES "CC_NOOV", "CCFP", "CCFPE"
This macro is not required if EXTRA_CC_MODES is not defined.
SELECT_CC_MODE (op, x, y)
Returns a mode from class MODE_CC to be used when comparison operation code op is applied to rtx x and y. For example, on the Sparc, SELECT_CC_MODE is defined as (see see section Defining Jump Instruction Patterns for a description of the reason for this definition)
#define SELECT_CC_MODE(OP,X,Y) \
  (GET_MODE_CLASS (GET_MODE (X)) == MODE_FLOAT          \
   ? ((OP == EQ || OP == NE) ? CCFPmode : CCFPEmode)    \
   : ((GET_CODE (X) == PLUS || GET_CODE (X) == MINUS    \
       || GET_CODE (X) == NEG) \
      ? CC_NOOVmode : CCmode))
You need not define this macro if EXTRA_CC_MODES is not defined.
CANONICALIZE_COMPARISON (code, op0, op1)
One some machines not all possible comparisons are defined, but you can convert an invalid comparison into a valid one. For example, the Alpha does not have a GT comparison, but you can use an LT comparison instead and swap the order of the operands. On such machines, define this macro to be a C statement to do any required conversions. code is the initial comparison code and op0 and op1 are the left and right operands of the comparison, respectively. You should modify code, op0, and op1 as required. GNU CC will not assume that the comparison resulting from this macro is valid but will see if the resulting insn matches a pattern in the `md' file. You need not define this macro if it would never change the comparison code or operands.
REVERSIBLE_CC_MODE (mode)
A C expression whose value is one if it is always safe to reverse a comparison whose mode is mode. If SELECT_CC_MODE can ever return mode for a floating-point inequality comparison, then REVERSIBLE_CC_MODE (mode) must be zero. You need not define this macro if it would always returns zero or if the floating-point format is anything other than IEEE_FLOAT_FORMAT. For example, here is the definition used on the Sparc, where floating-point inequality comparisons are always given CCFPEmode:
#define REVERSIBLE_CC_MODE(MODE)  ((MODE) != CCFPEmode)


Using and Porting GNU CC - Costs

Describing Relative Costs of Operations

These macros let you describe the relative speed of various operations on the target machine.

CONST_COSTS (x, code, outer_code)
A part of a C switch statement that describes the relative costs of constant RTL expressions. It must contain case labels for expression codes const_int, const, symbol_ref, label_ref and const_double. Each case must ultimately reach a return statement to return the relative cost of the use of that kind of constant value in an expression. The cost may depend on the precise value of the constant, which is available for examination in x, and the rtx code of the expression in which it is contained, found in outer_code. code is the expression code--redundant, since it can be obtained with GET_CODE (x).
RTX_COSTS (x, code, outer_code)
Like CONST_COSTS but applies to nonconstant RTL expressions. This can be used, for example, to indicate how costly a multiply instruction is. In writing this macro, you can use the construct COSTS_N_INSNS (n) to specify a cost equal to n fast instructions. outer_code is the code of the expression in which x is contained. This macro is optional; do not define it if the default cost assumptions are adequate for the target machine.
ADDRESS_COST (address)
An expression giving the cost of an addressing mode that contains address. If not defined, the cost is computed from the address expression and the CONST_COSTS values. For most CISC machines, the default cost is a good approximation of the true cost of the addressing mode. However, on RISC machines, all instructions normally have the same length and execution time. Hence all addresses will have equal costs. In cases where more than one form of an address is known, the form with the lowest cost will be used. If multiple forms have the same, lowest, cost, the one that is the most complex will be used. For example, suppose an address that is equal to the sum of a register and a constant is used twice in the same basic block. When this macro is not defined, the address will be computed in a register and memory references will be indirect through that register. On machines where the cost of the addressing mode containing the sum is no higher than that of a simple indirect reference, this will produce an additional instruction and possibly require an additional register. Proper specification of this macro eliminates this overhead for such machines. Similar use of this macro is made in strength reduction of loops. address need not be valid as an address. In such a case, the cost is not relevant and can be any value; invalid addresses need not be assigned a different cost. On machines where an address involving more than one register is as cheap as an address computation involving only one register, defining ADDRESS_COST to reflect this can cause two registers to be live over a region of code where only one would have been if ADDRESS_COST were not defined in that manner. This effect should be considered in the definition of this macro. Equivalent costs should probably only be given to addresses with different numbers of registers on machines with lots of registers. This macro will normally either not be defined or be defined as a constant.
REGISTER_MOVE_COST (from, to)
A C expression for the cost of moving data from a register in class from to one in class to. The classes are expressed using the enumeration values such as GENERAL_REGS. A value of 2 is the default; other values are interpreted relative to that. It is not required that the cost always equal 2 when from is the same as to; on some machines it is expensive to move between registers if they are not general registers. If reload sees an insn consisting of a single set between two hard registers, and if REGISTER_MOVE_COST applied to their classes returns a value of 2, reload does not check to ensure that the constraints of the insn are met. Setting a cost of other than 2 will allow reload to verify that the constraints are met. You should do this if the `movm' pattern's constraints do not allow such copying.
MEMORY_MOVE_COST (m)
A C expression for the cost of moving data of mode m between a register and memory. A value of 4 is the default; this cost is relative to those in REGISTER_MOVE_COST. If moving between registers and memory is more expensive than between two registers, you should define this macro to express the relative cost.
BRANCH_COST
A C expression for the cost of a branch instruction. A value of 1 is the default; other values are interpreted relative to that.

Here are additional macros which do not specify precise relative costs, but only that certain actions are more expensive than GNU CC would ordinarily expect.

SLOW_BYTE_ACCESS
Define this macro as a C expression which is nonzero if accessing less than a word of memory (i.e. a char or a short) is no faster than accessing a word of memory, i.e., if such access require more than one instruction or if there is no difference in cost between byte and (aligned) word loads. When this macro is not defined, the compiler will access a field by finding the smallest containing object; when it is defined, a fullword load will be used if alignment permits. Unless bytes accesses are faster than word accesses, using word accesses is preferable since it may eliminate subsequent memory access if subsequent accesses occur to other fields in the same word of the structure, but to different bytes.
SLOW_ZERO_EXTEND
Define this macro if zero-extension (of a char or short to an int) can be done faster if the destination is a register that is known to be zero. If you define this macro, you must have instruction patterns that recognize RTL structures like this:
(set (strict_low_part (subreg:QI (reg:SI ...) 0)) ...)
and likewise for HImode.
SLOW_UNALIGNED_ACCESS
Define this macro to be the value 1 if unaligned accesses have a cost many times greater than aligned accesses, for example if they are emulated in a trap handler. When this macro is non-zero, the compiler will act as if STRICT_ALIGNMENT were non-zero when generating code for block moves. This can cause significantly more instructions to be produced. Therefore, do not set this macro non-zero if unaligned accesses only add a cycle or two to the time for a memory access. If the value of this macro is always zero, it need not be defined.
DONT_REDUCE_ADDR
Define this macro to inhibit strength reduction of memory addresses. (On some machines, such strength reduction seems to do harm rather than good.)
MOVE_RATIO
The number of scalar move insns which should be generated instead of a string move insn or a library call. Increasing the value will always make code faster, but eventually incurs high cost in increased code size. If you don't define this, a reasonable default is used.
NO_FUNCTION_CSE
Define this macro if it is as good or better to call a constant function address than to call an address kept in a register.
NO_RECURSIVE_FUNCTION_CSE
Define this macro if it is as good or better for a function to call itself with an explicit address than to call an address kept in a register.
ADJUST_COST (insn, link, dep_insn, cost)
A C statement (sans semicolon) to update the integer variable cost based on the relationship between insn that is dependent on dep_insn through the dependence link. The default is to make no adjustment to cost. This can be used for example to specify to the scheduler that an output- or anti-dependence does not incur the same cost as a data-dependence.
ADJUST_PRIORITY (insn)
A C statement (sans semicolon) to update the integer scheduling priority INSN_PRIORITY(insn). Reduce the priority to execute the insn earlier, increase the priority to execute insn later. Do not define this macro if you do not need to adjust the scheduling priorities of insns.


Using and Porting GNU CC - Sections

Dividing the Output into Sections (Texts, Data, ...)

An object file is divided into sections containing different types of data. In the most common case, there are three sections: the text section, which holds instructions and read-only data; the data section, which holds initialized writable data; and the bss section, which holds uninitialized data. Some systems have other kinds of sections.

The compiler must tell the assembler when to switch sections. These macros control what commands to output to tell the assembler this. You can also define additional sections.

TEXT_SECTION_ASM_OP
A C expression whose value is a string containing the assembler operation that should precede instructions and read-only data. Normally ".text" is right.
DATA_SECTION_ASM_OP
A C expression whose value is a string containing the assembler operation to identify the following data as writable initialized data. Normally ".data" is right.
SHARED_SECTION_ASM_OP
If defined, a C expression whose value is a string containing the assembler operation to identify the following data as shared data. If not defined, DATA_SECTION_ASM_OP will be used.
BSS_SECTION_ASM_OP
If defined, a C expression whose value is a string containing the assembler operation to identify the following data as uninitialized global data. If not defined, and neither ASM_OUTPUT_BSS nor ASM_OUTPUT_ALIGNED_BSS are defined, uninitialized global data will be output in the data section if `-fno-common' is passed, otherwise ASM_OUTPUT_COMMON will be used.
SHARED_BSS_SECTION_ASM_OP
If defined, a C expression whose value is a string containing the assembler operation to identify the following data as uninitialized global shared data. If not defined, and BSS_SECTION_ASM_OP is, the latter will be used.
INIT_SECTION_ASM_OP
If defined, a C expression whose value is a string containing the assembler operation to identify the following data as initialization code. If not defined, GNU CC will assume such a section does not exist.
EXTRA_SECTIONS
A list of names for sections other than the standard two, which are in_text and in_data. You need not define this macro on a system with no other sections (that GCC needs to use).
EXTRA_SECTION_FUNCTIONS
One or more functions to be defined in `varasm.c'. These functions should do jobs analogous to those of text_section and data_section, for your additional sections. Do not define this macro if you do not define EXTRA_SECTIONS.
READONLY_DATA_SECTION
On most machines, read-only variables, constants, and jump tables are placed in the text section. If this is not the case on your machine, this macro should be defined to be the name of a function (either data_section or a function defined in EXTRA_SECTIONS) that switches to the section to be used for read-only items. If these items should be placed in the text section, this macro should not be defined.
SELECT_SECTION (exp, reloc)
A C statement or statements to switch to the appropriate section for output of exp. You can assume that exp is either a VAR_DECL node or a constant of some sort. reloc indicates whether the initial value of exp requires link-time relocations. Select the section by calling text_section or one of the alternatives for other sections. Do not define this macro if you put all read-only variables and constants in the read-only data section (usually the text section).
SELECT_RTX_SECTION (mode, rtx)
A C statement or statements to switch to the appropriate section for output of rtx in mode mode. You can assume that rtx is some kind of constant in RTL. The argument mode is redundant except in the case of a const_int rtx. Select the section by calling text_section or one of the alternatives for other sections. Do not define this macro if you put all constants in the read-only data section.
JUMP_TABLES_IN_TEXT_SECTION
Define this macro if jump tables (for tablejump insns) should be output in the text section, along with the assembler instructions. Otherwise, the readonly data section is used. This macro is irrelevant if there is no separate readonly data section.
ENCODE_SECTION_INFO (decl)
Define this macro if references to a symbol must be treated differently depending on something about the variable or function named by the symbol (such as what section it is in). The macro definition, if any, is executed immediately after the rtl for decl has been created and stored in DECL_RTL (decl). The value of the rtl will be a mem whose address is a symbol_ref. The usual thing for this macro to do is to record a flag in the symbol_ref (such as SYMBOL_REF_FLAG) or to store a modified name string in the symbol_ref (if one bit is not enough information).
STRIP_NAME_ENCODING (var, sym_name)
Decode sym_name and store the real name part in var, sans the characters that encode section info. Define this macro if ENCODE_SECTION_INFO alters the symbol's name string.
UNIQUE_SECTION_P (decl)
A C expression which evaluates to true if decl should be placed into a unique section for some target-specific reason. If you do not define this macro, the default is `0'. Note that the flag `-ffunction-sections' will also cause functions to be placed into unique sections.
UNIQUE_SECTION (decl, reloc)
A C statement to build up a unique section name, expressed as a STRING_CST node, and assign it to `DECL_SECTION_NAME (decl)'. reloc indicates whether the initial value of exp requires link-time relocations. If you do not define this macro, GNU CC will use the symbol name prefixed by `.' as the section name.


Using and Porting GNU CC - PIC

Position Independent Code

This section describes macros that help implement generation of position independent code. Simply defining these macros is not enough to generate valid PIC; you must also add support to the macros GO_IF_LEGITIMATE_ADDRESS and PRINT_OPERAND_ADDRESS, as well as LEGITIMIZE_ADDRESS. You must modify the definition of `movsi' to do something appropriate when the source operand contains a symbolic address. You may also need to alter the handling of switch statements so that they use relative addresses.

PIC_OFFSET_TABLE_REGNUM
The register number of the register used to address a table of static data addresses in memory. In some cases this register is defined by a processor's "application binary interface" (ABI). When this macro is defined, RTL is generated for this register once, as with the stack pointer and frame pointer registers. If this macro is not defined, it is up to the machine-dependent files to allocate such a register (if necessary).
PIC_OFFSET_TABLE_REG_CALL_CLOBBERED
Define this macro if the register defined by PIC_OFFSET_TABLE_REGNUM is clobbered by calls. Do not define this macro if PPIC_OFFSET_TABLE_REGNUM is not defined.
FINALIZE_PIC
By generating position-independent code, when two different programs (A and B) share a common library (libC.a), the text of the library can be shared whether or not the library is linked at the same address for both programs. In some of these environments, position-independent code requires not only the use of different addressing modes, but also special code to enable the use of these addressing modes. The FINALIZE_PIC macro serves as a hook to emit these special codes once the function is being compiled into assembly code, but not before. (It is not done before, because in the case of compiling an inline function, it would lead to multiple PIC prologues being included in functions which used inline functions and were compiled to assembly language.)
LEGITIMATE_PIC_OPERAND_P (x)
A C expression that is nonzero if x is a legitimate immediate operand on the target machine when generating position independent code. You can assume that x satisfies CONSTANT_P, so you need not check this. You can also assume flag_pic is true, so you need not check it either. You need not define this macro if all constants (including SYMBOL_REF) can be immediate operands when generating position independent code.


Using and Porting GNU CC - Assembler Format

Defining the Output Assembler Language

This section describes macros whose principal purpose is to describe how to write instructions in assembler language--rather than what the instructions do.


Using and Porting GNU CC - File Framework

The Overall Framework of an Assembler File

This describes the overall framework of an assembler file.

ASM_FILE_START (stream)
A C expression which outputs to the stdio stream stream some appropriate text to go at the start of an assembler file. Normally this macro is defined to output a line containing `#NO_APP', which is a comment that has no effect on most assemblers but tells the GNU assembler that it can save time by not checking for certain assembler constructs. On systems that use SDB, it is necessary to output certain commands; see `attasm.h'.
ASM_FILE_END (stream)
A C expression which outputs to the stdio stream stream some appropriate text to go at the end of an assembler file. If this macro is not defined, the default is to output nothing special at the end of the file. Most systems don't require any definition. On systems that use SDB, it is necessary to output certain commands; see `attasm.h'.
ASM_IDENTIFY_GCC (file)
A C statement to output assembler commands which will identify the object file as having been compiled with GNU CC (or another GNU compiler). If you don't define this macro, the string `gcc_compiled.:' is output. This string is calculated to define a symbol which, on BSD systems, will never be defined for any other reason. GDB checks for the presence of this symbol when reading the symbol table of an executable. On non-BSD systems, you must arrange communication with GDB in some other fashion. If GDB is not used on your system, you can define this macro with an empty body.
ASM_COMMENT_START
A C string constant describing how to begin a comment in the target assembler language. The compiler assumes that the comment will end at the end of the line.
ASM_APP_ON
A C string constant for text to be output before each asm statement or group of consecutive ones. Normally this is "#APP", which is a comment that has no effect on most assemblers but tells the GNU assembler that it must check the lines that follow for all valid assembler constructs.
ASM_APP_OFF
A C string constant for text to be output after each asm statement or group of consecutive ones. Normally this is "#NO_APP", which tells the GNU assembler to resume making the time-saving assumptions that are valid for ordinary compiler output.
ASM_OUTPUT_SOURCE_FILENAME (stream, name)
A C statement to output COFF information or DWARF debugging information which indicates that filename name is the current source file to the stdio stream stream. This macro need not be defined if the standard form of output for the file format in use is appropriate.
ASM_OUTPUT_SOURCE_LINE (stream, line)
A C statement to output DBX or SDB debugging information before code for line number line of the current source file to the stdio stream stream. This macro need not be defined if the standard form of debugging information for the debugger in use is appropriate.
ASM_OUTPUT_IDENT (stream, string)
A C statement to output something to the assembler file to handle a `#ident' directive containing the text string. If this macro is not defined, nothing is output for a `#ident' directive.
ASM_OUTPUT_SECTION_NAME (stream, decl, name, reloc)
A C statement to output something to the assembler file to switch to section name for object decl which is either a FUNCTION_DECL, a VAR_DECL or NULL_TREE. reloc indicates whether the initial value of exp requires link-time relocations. Some target formats do not support arbitrary sections. Do not define this macro in such cases. At present this macro is only used to support section attributes. When this macro is undefined, section attributes are disabled.
OBJC_PROLOGUE
A C statement to output any assembler statements which are required to precede any Objective C object definitions or message sending. The statement is executed only when compiling an Objective C program.


Using and Porting GNU CC - Data Output

Output of Data

This describes data output.

ASM_OUTPUT_LONG_DOUBLE (stream, value)
ASM_OUTPUT_DOUBLE (stream, value)
ASM_OUTPUT_FLOAT (stream, value)
ASM_OUTPUT_THREE_QUARTER_FLOAT (stream, value)
ASM_OUTPUT_SHORT_FLOAT (stream, value)
ASM_OUTPUT_BYTE_FLOAT (stream, value)
A C statement to output to the stdio stream stream an assembler instruction to assemble a floating-point constant of TFmode, DFmode, SFmode, TQFmode, HFmode, or QFmode, respectively, whose value is value. value will be a C expression of type REAL_VALUE_TYPE. Macros such as REAL_VALUE_TO_TARGET_DOUBLE are useful for writing these definitions.
ASM_OUTPUT_QUADRUPLE_INT (stream, exp)
ASM_OUTPUT_DOUBLE_INT (stream, exp)
ASM_OUTPUT_INT (stream, exp)
ASM_OUTPUT_SHORT (stream, exp)
ASM_OUTPUT_CHAR (stream, exp)
A C statement to output to the stdio stream stream an assembler instruction to assemble an integer of 16, 8, 4, 2 or 1 bytes, respectively, whose value is value. The argument exp will be an RTL expression which represents a constant value. Use `output_addr_const (stream, exp)' to output this value as an assembler expression. For sizes larger than UNITS_PER_WORD, if the action of a macro would be identical to repeatedly calling the macro corresponding to a size of UNITS_PER_WORD, once for each word, you need not define the macro.
ASM_OUTPUT_BYTE (stream, value)
A C statement to output to the stdio stream stream an assembler instruction to assemble a single byte containing the number value.
ASM_BYTE_OP
A C string constant giving the pseudo-op to use for a sequence of single-byte constants. If this macro is not defined, the default is "byte".
ASM_OUTPUT_ASCII (stream, ptr, len)
A C statement to output to the stdio stream stream an assembler instruction to assemble a string constant containing the len bytes at ptr. ptr will be a C expression of type char * and len a C expression of type int. If the assembler has a .ascii pseudo-op as found in the Berkeley Unix assembler, do not define the macro ASM_OUTPUT_ASCII.
CONSTANT_POOL_BEFORE_FUNCTION
You may define this macro as a C expression. You should define the expression to have a non-zero value if GNU CC should output the constant pool for a function before the code for the function, or a zero value if GNU CC should output the constant pool after the function. If you do not define this macro, the usual case, GNU CC will output the constant pool before the function.
ASM_OUTPUT_POOL_PROLOGUE (file funname fundecl size)
A C statement to output assembler commands to define the start of the constant pool for a function. funname is a string giving the name of the function. Should the return type of the function be required, it can be obtained via fundecl. size is the size, in bytes, of the constant pool that will be written immediately after this call. If no constant-pool prefix is required, the usual case, this macro need not be defined.
ASM_OUTPUT_SPECIAL_POOL_ENTRY (file, x, mode, align, labelno, jumpto)
A C statement (with or without semicolon) to output a constant in the constant pool, if it needs special treatment. (This macro need not do anything for RTL expressions that can be output normally.) The argument file is the standard I/O stream to output the assembler code on. x is the RTL expression for the constant to output, and mode is the machine mode (in case x is a `const_int'). align is the required alignment for the value x; you should output an assembler directive to force this much alignment. The argument labelno is a number to use in an internal label for the address of this pool entry. The definition of this macro is responsible for outputting the label definition at the proper place. Here is how to do this:
ASM_OUTPUT_INTERNAL_LABEL (file, "LC", labelno);
When you output a pool entry specially, you should end with a goto to the label jumpto. This will prevent the same pool entry from being output a second time in the usual manner. You need not define this macro if it would do nothing.
CONSTANT_AFTER_FUNCTION_P (exp)
Define this macro as a C expression which is nonzero if the constant exp, of type tree, should be output after the code for a function. The compiler will normally output all constants before the function; you need not define this macro if this is OK.
ASM_OUTPUT_POOL_EPILOGUE (file funname fundecl size)
A C statement to output assembler commands to at the end of the constant pool for a function. funname is a string giving the name of the function. Should the return type of the function be required, you can obtain it via fundecl. size is the size, in bytes, of the constant pool that GNU CC wrote immediately before this call. If no constant-pool epilogue is required, the usual case, you need not define this macro.
IS_ASM_LOGICAL_LINE_SEPARATOR (C)
Define this macro as a C expression which is nonzero if C is used as a logical line separator by the assembler. If you do not define this macro, the default is that only the character `;' is treated as a logical line separator.
ASM_OPEN_PAREN
ASM_CLOSE_PAREN
These macros are defined as C string constant, describing the syntax in the assembler for grouping arithmetic expressions. The following definitions are correct for most assemblers:
#define ASM_OPEN_PAREN "("
#define ASM_CLOSE_PAREN ")"

These macros are provided by `real.h' for writing the definitions of ASM_OUTPUT_DOUBLE and the like:

REAL_VALUE_TO_TARGET_SINGLE (x, l)
REAL_VALUE_TO_TARGET_DOUBLE (x, l)
REAL_VALUE_TO_TARGET_LONG_DOUBLE (x, l)
These translate x, of type REAL_VALUE_TYPE, to the target's floating point representation, and store its bit pattern in the array of long int whose address is l. The number of elements in the output array is determined by the size of the desired target floating point data type: 32 bits of it go in each long int array element. Each array element holds 32 bits of the result, even if long int is wider than 32 bits on the host machine. The array element values are designed so that you can print them out using fprintf in the order they should appear in the target machine's memory.
REAL_VALUE_TO_DECIMAL (x, format, string)
This macro converts x, of type REAL_VALUE_TYPE, to a decimal number and stores it as a string into string. You must pass, as string, the address of a long enough block of space to hold the result. The argument format is a printf-specification that serves as a suggestion for how to format the output string.


Using and Porting GNU CC - Uninitialized Data

Output of Uninitialized Variables

Each of the macros in this section is used to do the whole job of outputting a single uninitialized variable.

ASM_OUTPUT_COMMON (stream, name, size, rounded)
A C statement (sans semicolon) to output to the stdio stream stream the assembler definition of a common-label named name whose size is size bytes. The variable rounded is the size rounded up to whatever alignment the caller wants. Use the expression assemble_name (stream, name) to output the name itself; before and after that, output the additional assembler syntax for defining the name, and a newline. This macro controls how the assembler definitions of uninitialized common global variables are output.
ASM_OUTPUT_ALIGNED_COMMON (stream, name, size, alignment)
Like ASM_OUTPUT_COMMON except takes the required alignment as a separate, explicit argument. If you define this macro, it is used in place of ASM_OUTPUT_COMMON, and gives you more flexibility in handling the required alignment of the variable. The alignment is specified as the number of bits.
ASM_OUTPUT_SHARED_COMMON (stream, name, size, rounded)
If defined, it is similar to ASM_OUTPUT_COMMON, except that it is used when name is shared. If not defined, ASM_OUTPUT_COMMON will be used.
ASM_OUTPUT_BSS (stream, decl, name, size, rounded)
A C statement (sans semicolon) to output to the stdio stream stream the assembler definition of uninitialized global decl named name whose size is size bytes. The variable rounded is the size rounded up to whatever alignment the caller wants. Try to use function asm_output_bss defined in `varasm.c' when defining this macro. If unable, use the expression assemble_name (stream, name) to output the name itself; before and after that, output the additional assembler syntax for defining the name, and a newline. This macro controls how the assembler definitions of uninitialized global variables are output. This macro exists to properly support languages like c++ which do not have common data. However, this macro currently is not defined for all targets. If this macro and ASM_OUTPUT_ALIGNED_BSS are not defined then ASM_OUTPUT_COMMON or ASM_OUTPUT_ALIGNED_COMMON is used.
ASM_OUTPUT_ALIGNED_BSS (stream, decl, name, size, alignment)
Like ASM_OUTPUT_BSS except takes the required alignment as a separate, explicit argument. If you define this macro, it is used in place of ASM_OUTPUT_BSS, and gives you more flexibility in handling the required alignment of the variable. The alignment is specified as the number of bits. Try to use function asm_output_aligned_bss defined in file `varasm.c' when defining this macro.
ASM_OUTPUT_SHARED_BSS (stream, decl, name, size, rounded)
If defined, it is similar to ASM_OUTPUT_BSS, except that it is used when name is shared. If not defined, ASM_OUTPUT_BSS will be used.
ASM_OUTPUT_LOCAL (stream, name, size, rounded)
A C statement (sans semicolon) to output to the stdio stream stream the assembler definition of a local-common-label named name whose size is size bytes. The variable rounded is the size rounded up to whatever alignment the caller wants. Use the expression assemble_name (stream, name) to output the name itself; before and after that, output the additional assembler syntax for defining the name, and a newline. This macro controls how the assembler definitions of uninitialized static variables are output.
ASM_OUTPUT_ALIGNED_LOCAL (stream, name, size, alignment)
Like ASM_OUTPUT_LOCAL except takes the required alignment as a separate, explicit argument. If you define this macro, it is used in place of ASM_OUTPUT_LOCAL, and gives you more flexibility in handling the required alignment of the variable. The alignment is specified as the number of bits.
ASM_OUTPUT_SHARED_LOCAL (stream, name, size, rounded)
If defined, it is similar to ASM_OUTPUT_LOCAL, except that it is used when name is shared. If not defined, ASM_OUTPUT_LOCAL will be used.


Using and Porting GNU CC - Label Output

Output and Generation of Labels

This is about outputting labels.

ASM_OUTPUT_LABEL (stream, name)
A C statement (sans semicolon) to output to the stdio stream stream the assembler definition of a label named name. Use the expression assemble_name (stream, name) to output the name itself; before and after that, output the additional assembler syntax for defining the name, and a newline.
ASM_DECLARE_FUNCTION_NAME (stream, name, decl)
A C statement (sans semicolon) to output to the stdio stream stream any text necessary for declaring the name name of a function which is being defined. This macro is responsible for outputting the label definition (perhaps using ASM_OUTPUT_LABEL). The argument decl is the FUNCTION_DECL tree node representing the function. If this macro is not defined, then the function name is defined in the usual manner as a label (by means of ASM_OUTPUT_LABEL).
ASM_DECLARE_FUNCTION_SIZE (stream, name, decl)
A C statement (sans semicolon) to output to the stdio stream stream any text necessary for declaring the size of a function which is being defined. The argument name is the name of the function. The argument decl is the FUNCTION_DECL tree node representing the function. If this macro is not defined, then the function size is not defined.
ASM_DECLARE_OBJECT_NAME (stream, name, decl)
A C statement (sans semicolon) to output to the stdio stream stream any text necessary for declaring the name name of an initialized variable which is being defined. This macro must output the label definition (perhaps using ASM_OUTPUT_LABEL). The argument decl is the VAR_DECL tree node representing the variable. If this macro is not defined, then the variable name is defined in the usual manner as a label (by means of ASM_OUTPUT_LABEL).
ASM_FINISH_DECLARE_OBJECT (stream, decl, toplevel, atend)
A C statement (sans semicolon) to finish up declaring a variable name once the compiler has processed its initializer fully and thus has had a chance to determine the size of an array when controlled by an initializer. This is used on systems where it's necessary to declare something about the size of the object. If you don't define this macro, that is equivalent to defining it to do nothing.
ASM_GLOBALIZE_LABEL (stream, name)
A C statement (sans semicolon) to output to the stdio stream stream some commands that will make the label name global; that is, available for reference from other files. Use the expression assemble_name (stream, name) to output the name itself; before and after that, output the additional assembler syntax for making that name global, and a newline.
ASM_WEAKEN_LABEL
A C statement (sans semicolon) to output to the stdio stream stream some commands that will make the label name weak; that is, available for reference from other files but only used if no other definition is available. Use the expression assemble_name (stream, name) to output the name itself; before and after that, output the additional assembler syntax for making that name weak, and a newline. If you don't define this macro, GNU CC will not support weak symbols and you should not define the SUPPORTS_WEAK macro.
SUPPORTS_WEAK
A C expression which evaluates to true if the target supports weak symbols. If you don't define this macro, `defaults.h' provides a default definition. If ASM_WEAKEN_LABEL is defined, the default definition is `1'; otherwise, it is `0'. Define this macro if you want to control weak symbol support with a compiler flag such as `-melf'.
MAKE_DECL_ONE_ONLY
A C statement (sans semicolon) to mark decl to be emitted as a public symbol such that extra copies in multiple translation units will be discarded by the linker. Define this macro if your object file format provides support for this concept, such as the `COMDAT' section flags in the Microsoft Windows PE/COFF format, and this support requires changes to decl, such as putting it in a separate section.
SUPPORTS_WEAK
A C expression which evaluates to true if the target supports one-only semantics. If you don't define this macro, `varasm.c' provides a default definition. If MAKE_DECL_ONE_ONLY is defined, the default definition is `1'; otherwise, it is `0'. Define this macro if you want to control weak symbol support with a compiler flag, or if setting the DECL_ONE_ONLY flag is enough to mark a declaration to be emitted as one-only.
ASM_OUTPUT_EXTERNAL (stream, decl, name)
A C statement (sans semicolon) to output to the stdio stream stream any text necessary for declaring the name of an external symbol named name which is referenced in this compilation but not defined. The value of decl is the tree node for the declaration. This macro need not be defined if it does not need to output anything. The GNU assembler and most Unix assemblers don't require anything.
ASM_OUTPUT_EXTERNAL_LIBCALL (stream, symref)
A C statement (sans semicolon) to output on stream an assembler pseudo-op to declare a library function name external. The name of the library function is given by symref, which has type rtx and is a symbol_ref. This macro need not be defined if it does not need to output anything. The GNU assembler and most Unix assemblers don't require anything.
ASM_OUTPUT_LABELREF (stream, name)
A C statement (sans semicolon) to output to the stdio stream stream a reference in assembler syntax to a label named name. This should add `_' to the front of the name, if that is customary on your operating system, as it is in most Berkeley Unix systems. This macro is used in assemble_name.
ASM_OUTPUT_INTERNAL_LABEL (stream, prefix, num)
A C statement to output to the stdio stream stream a label whose name is made from the string prefix and the number num. It is absolutely essential that these labels be distinct from the labels used for user-level functions and variables. Otherwise, certain programs will have name conflicts with internal labels. It is desirable to exclude internal labels from the symbol table of the object file. Most assemblers have a naming convention for labels that should be excluded; on many systems, the letter `L' at the beginning of a label has this effect. You should find out what convention your system uses, and follow it. The usual definition of this macro is as follows:
fprintf (stream, "L%s%d:\n", prefix, num)
ASM_GENERATE_INTERNAL_LABEL (string, prefix, num)
A C statement to store into the string string a label whose name is made from the string prefix and the number num. This string, when output subsequently by assemble_name, should produce the output that ASM_OUTPUT_INTERNAL_LABEL would produce with the same prefix and num. If the string begins with `*', then assemble_name will output the rest of the string unchanged. It is often convenient for ASM_GENERATE_INTERNAL_LABEL to use `*' in this way. If the string doesn't start with `*', then ASM_OUTPUT_LABELREF gets to output the string, and may change it. (Of course, ASM_OUTPUT_LABELREF is also part of your machine description, so you should know what it does on your machine.)
ASM_FORMAT_PRIVATE_NAME (outvar, name, number)
A C expression to assign to outvar (which is a variable of type char *) a newly allocated string made from the string name and the number number, with some suitable punctuation added. Use alloca to get space for the string. The string will be used as an argument to ASM_OUTPUT_LABELREF to produce an assembler label for an internal static variable whose name is name. Therefore, the string must be such as to result in valid assembler code. The argument number is different each time this macro is executed; it prevents conflicts between similarly-named internal static variables in different scopes. Ideally this string should not be a valid C identifier, to prevent any conflict with the user's own symbols. Most assemblers allow periods or percent signs in assembler symbols; putting at least one of these between the name and the number will suffice.
ASM_OUTPUT_DEF (stream, name, value)
A C statement to output to the stdio stream stream assembler code which defines (equates) the symbol name to have the value value. If SET_ASM_OP is defined, a default definition is provided which is correct for most systems.
ASM_OUTPUT_WEAK_ALIAS (stream, name, value)
A C statement to output to the stdio stream stream assembler code which defines (equates) the weak symbol name to have the value value. Define this macro if the target only supports weak aliases; define ASM_OUTPUT_DEF instead if possible.
OBJC_GEN_METHOD_LABEL (buf, is_inst, class_name, cat_name, sel_name)
Define this macro to override the default assembler names used for Objective C methods. The default name is a unique method number followed by the name of the class (e.g. `_1_Foo'). For methods in categories, the name of the category is also included in the assembler name (e.g. `_1_Foo_Bar'). These names are safe on most systems, but make debugging difficult since the method's selector is not present in the name. Therefore, particular systems define other ways of computing names. buf is an expression of type char * which gives you a buffer in which to store the name; its length is as long as class_name, cat_name and sel_name put together, plus 50 characters extra. The argument is_inst specifies whether the method is an instance method or a class method; class_name is the name of the class; cat_name is the name of the category (or NULL if the method is not in a category); and sel_name is the name of the selector. On systems where the assembler can handle quoted names, you can use this macro to provide more human-readable names.


Using and Porting GNU CC - Initialization

How Initialization Functions Are Handled

The compiled code for certain languages includes constructors (also called initialization routines)---functions to initialize data in the program when the program is started. These functions need to be called before the program is "started"---that is to say, before main is called.

Compiling some languages generates destructors (also called termination routines) that should be called when the program terminates.

To make the initialization and termination functions work, the compiler must output something in the assembler code to cause those functions to be called at the appropriate time. When you port the compiler to a new system, you need to specify how to do this.

There are two major ways that GCC currently supports the execution of initialization and termination functions. Each way has two variants. Much of the structure is common to all four variations.

The linker must build two lists of these functions--a list of initialization functions, called __CTOR_LIST__, and a list of termination functions, called __DTOR_LIST__.

Each list always begins with an ignored function pointer (which may hold 0, -1, or a count of the function pointers after it, depending on the environment). This is followed by a series of zero or more function pointers to constructors (or destructors), followed by a function pointer containing zero.

Depending on the operating system and its executable file format, either `crtstuff.c' or `libgcc2.c' traverses these lists at startup time and exit time. Constructors are called in reverse order of the list; destructors in forward order.

The best way to handle static constructors works only for object file formats which provide arbitrarily-named sections. A section is set aside for a list of constructors, and another for a list of destructors. Traditionally these are called `.ctors' and `.dtors'. Each object file that defines an initialization function also puts a word in the constructor section to point to that function. The linker accumulates all these words into one contiguous `.ctors' section. Termination functions are handled similarly.

To use this method, you need appropriate definitions of the macros ASM_OUTPUT_CONSTRUCTOR and ASM_OUTPUT_DESTRUCTOR. Usually you can get them by including `svr4.h'.

When arbitrary sections are available, there are two variants, depending upon how the code in `crtstuff.c' is called. On systems that support an init section which is executed at program startup, parts of `crtstuff.c' are compiled into that section. The program is linked by the gcc driver like this:

ld -o output_file crtbegin.o ... crtend.o -lgcc

The head of a function (__do_global_ctors) appears in the init section of `crtbegin.o'; the remainder of the function appears in the init section of `crtend.o'. The linker will pull these two parts of the section together, making a whole function. If any of the user's object files linked into the middle of it contribute code, then that code will be executed as part of the body of __do_global_ctors.

To use this variant, you must define the INIT_SECTION_ASM_OP macro properly.

If no init section is available, do not define INIT_SECTION_ASM_OP. Then __do_global_ctors is built into the text section like all other functions, and resides in `libgcc.a'. When GCC compiles any function called main, it inserts a procedure call to __main as the first executable code after the function prologue. The __main function, also defined in `libgcc2.c', simply calls `__do_global_ctors'.

In file formats that don't support arbitrary sections, there are again two variants. In the simplest variant, the GNU linker (GNU ld) and an `a.out' format must be used. In this case, ASM_OUTPUT_CONSTRUCTOR is defined to produce a .stabs entry of type `N_SETT', referencing the name __CTOR_LIST__, and with the address of the void function containing the initialization code as its value. The GNU linker recognizes this as a request to add the value to a "set"; the values are accumulated, and are eventually placed in the executable as a vector in the format described above, with a leading (ignored) count and a trailing zero element. ASM_OUTPUT_DESTRUCTOR is handled similarly. Since no init section is available, the absence of INIT_SECTION_ASM_OP causes the compilation of main to call __main as above, starting the initialization process.

The last variant uses neither arbitrary sections nor the GNU linker. This is preferable when you want to do dynamic linking and when using file formats which the GNU linker does not support, such as `ECOFF'. In this case, ASM_OUTPUT_CONSTRUCTOR does not produce an N_SETT symbol; initialization and termination functions are recognized simply by their names. This requires an extra program in the linkage step, called collect2. This program pretends to be the linker, for use with GNU CC; it does its job by running the ordinary linker, but also arranges to include the vectors of initialization and termination functions. These functions are called via __main as described above.

Choosing among these configuration options has been simplified by a set of operating-system-dependent files in the `config' subdirectory. These files define all of the relevant parameters. Usually it is sufficient to include one into your specific machine-dependent configuration file. These files are:

`aoutos.h'
For operating systems using the `a.out' format.
`next.h'
For operating systems using the `MachO' format.
`svr3.h'
For System V Release 3 and similar systems using `COFF' format.
`svr4.h'
For System V Release 4 and similar systems using `ELF' format.
`vms.h'
For the VMS operating system.


Using and Porting GNU CC - Macros for Initialization

Macros Controlling Initialization Routines

Here are the macros that control how the compiler handles initialization and termination functions:

INIT_SECTION_ASM_OP
If defined, a C string constant for the assembler operation to identify the following data as initialization code. If not defined, GNU CC will assume such a section does not exist. When you are using special sections for initialization and termination functions, this macro also controls how `crtstuff.c' and `libgcc2.c' arrange to run the initialization functions.
HAS_INIT_SECTION
If defined, main will not call __main as described above. This macro should be defined for systems that control the contents of the init section on a symbol-by-symbol basis, such as OSF/1, and should not be defined explicitly for systems that support INIT_SECTION_ASM_OP.
LD_INIT_SWITCH
If defined, a C string constant for a switch that tells the linker that the following symbol is an initialization routine.
LD_FINI_SWITCH
If defined, a C string constant for a switch that tells the linker that the following symbol is a finalization routine.
INVOKE__main
If defined, main will call __main despite the presence of INIT_SECTION_ASM_OP. This macro should be defined for systems where the init section is not actually run automatically, but is still useful for collecting the lists of constructors and destructors.
ASM_OUTPUT_CONSTRUCTOR (stream, name)
Define this macro as a C statement to output on the stream stream the assembler code to arrange to call the function named name at initialization time. Assume that name is the name of a C function generated automatically by the compiler. This function takes no arguments. Use the function assemble_name to output the name name; this performs any system-specific syntactic transformations such as adding an underscore. If you don't define this macro, nothing special is output to arrange to call the function. This is correct when the function will be called in some other manner--for example, by means of the collect2 program, which looks through the symbol table to find these functions by their names.
ASM_OUTPUT_DESTRUCTOR (stream, name)
This is like ASM_OUTPUT_CONSTRUCTOR but used for termination functions rather than initialization functions.

If your system uses collect2 as the means of processing constructors, then that program normally uses nm to scan an object file for constructor functions to be called. On certain kinds of systems, you can define these macros to make collect2 work faster (and, in some cases, make it work at all):

OBJECT_FORMAT_COFF
Define this macro if the system uses COFF (Common Object File Format) object files, so that collect2 can assume this format and scan object files directly for dynamic constructor/destructor functions.
OBJECT_FORMAT_ROSE
Define this macro if the system uses ROSE format object files, so that collect2 can assume this format and scan object files directly for dynamic constructor/destructor functions. These macros are effective only in a native compiler; collect2 as part of a cross compiler always uses nm for the target machine.
REAL_NM_FILE_NAME
Define this macro as a C string constant containing the file name to use to execute nm. The default is to search the path normally for nm. If your system supports shared libraries and has a program to list the dynamic dependencies of a given library or executable, you can define these macros to enable support for running initialization and termination functions in shared libraries:
LDD_SUFFIX
Define this macro to a C string constant containing the name of the program which lists dynamic dependencies, like "ldd" under SunOS 4.
PARSE_LDD_OUTPUT (PTR)
Define this macro to be C code that extracts filenames from the output of the program denoted by LDD_SUFFIX. PTR is a variable of type char * that points to the beginning of a line of output from LDD_SUFFIX. If the line lists a dynamic dependency, the code must advance PTR to the beginning of the filename on that line. Otherwise, it must set PTR to NULL.


Using and Porting GNU CC - Instruction Output

Output of Assembler Instructions

This describes assembler instruction output.

REGISTER_NAMES
A C initializer containing the assembler's names for the machine registers, each one as a C string constant. This is what translates register numbers in the compiler into assembler language.
ADDITIONAL_REGISTER_NAMES
If defined, a C initializer for an array of structures containing a name and a register number. This macro defines additional names for hard registers, thus allowing the asm option in declarations to refer to registers using alternate names.
ASM_OUTPUT_OPCODE (stream, ptr)
Define this macro if you are using an unusual assembler that requires different names for the machine instructions. The definition is a C statement or statements which output an assembler instruction opcode to the stdio stream stream. The macro-operand ptr is a variable of type char * which points to the opcode name in its "internal" form--the form that is written in the machine description. The definition should output the opcode name to stream, performing any translation you desire, and increment the variable ptr to point at the end of the opcode so that it will not be output twice. In fact, your macro definition may process less than the entire opcode name, or more than the opcode name; but if you want to process text that includes `%'-sequences to substitute operands, you must take care of the substitution yourself. Just be sure to increment ptr over whatever text should not be output normally. If you need to look at the operand values, they can be found as the elements of recog_operand. If the macro definition does nothing, the instruction is output in the usual way.
FINAL_PRESCAN_INSN (insn, opvec, noperands)
If defined, a C statement to be executed just prior to the output of assembler code for insn, to modify the extracted operands so they will be output differently. Here the argument opvec is the vector containing the operands extracted from insn, and noperands is the number of elements of the vector which contain meaningful data for this insn. The contents of this vector are what will be used to convert the insn template into assembler code, so you can change the assembler output by changing the contents of the vector. This macro is useful when various assembler syntaxes share a single file of instruction patterns; by defining this macro differently, you can cause a large class of instructions to be output differently (such as with rearranged operands). Naturally, variations in assembler syntax affecting individual insn patterns ought to be handled by writing conditional output routines in those patterns. If this macro is not defined, it is equivalent to a null statement.
FINAL_PRESCAN_LABEL
If defined, FINAL_PRESCAN_INSN will be called on each CODE_LABEL. In that case, opvec will be a null pointer and noperands will be zero.
PRINT_OPERAND (stream, x, code)
A C compound statement to output to stdio stream stream the assembler syntax for an instruction operand x. x is an RTL expression. code is a value that can be used to specify one of several ways of printing the operand. It is used when identical operands must be printed differently depending on the context. code comes from the `%' specification that was used to request printing of the operand. If the specification was just `%digit' then code is 0; if the specification was `%ltr digit' then code is the ASCII code for ltr. If x is a register, this macro should print the register's name. The names can be found in an array reg_names whose type is char *[]. reg_names is initialized from REGISTER_NAMES. When the machine description has a specification `%punct' (a `%' followed by a punctuation character), this macro is called with a null pointer for x and the punctuation character for code.
PRINT_OPERAND_PUNCT_VALID_P (code)
A C expression which evaluates to true if code is a valid punctuation character for use in the PRINT_OPERAND macro. If PRINT_OPERAND_PUNCT_VALID_P is not defined, it means that no punctuation characters (except for the standard one, `%') are used in this way.
PRINT_OPERAND_ADDRESS (stream, x)
A C compound statement to output to stdio stream stream the assembler syntax for an instruction operand that is a memory reference whose address is x. x is an RTL expression. On some machines, the syntax for a symbolic address depends on the section that the address refers to. On these machines, define the macro ENCODE_SECTION_INFO to store the information into the symbol_ref, and then check for it here. See section Defining the Output Assembler Language.
DBR_OUTPUT_SEQEND(file)
A C statement, to be executed after all slot-filler instructions have been output. If necessary, call dbr_sequence_length to determine the number of slots filled in a sequence (zero if not currently outputting a sequence), to decide how many no-ops to output, or whatever. Don't define this macro if it has nothing to do, but it is helpful in reading assembly output if the extent of the delay sequence is made explicit (e.g. with white space). Note that output routines for instructions with delay slots must be prepared to deal with not being output as part of a sequence (i.e. when the scheduling pass is not run, or when no slot fillers could be found.) The variable final_sequence is null when not processing a sequence, otherwise it contains the sequence rtx being output.
REGISTER_PREFIX
LOCAL_LABEL_PREFIX
USER_LABEL_PREFIX
IMMEDIATE_PREFIX
If defined, C string expressions to be used for the `%R', `%L', `%U', and `%I' options of asm_fprintf (see `final.c'). These are useful when a single `md' file must support multiple assembler formats. In that case, the various `tm.h' files can define these macros differently.
ASSEMBLER_DIALECT
If your target supports multiple dialects of assembler language (such as different opcodes), define this macro as a C expression that gives the numeric index of the assembler language dialect to use, with zero as the first variant. If this macro is defined, you may use constructs of the form `{option0|option1|option2...}' in the output templates of patterns (see section Output Templates and Operand Substitution) or in the first argument of asm_fprintf. This construct outputs `option0', `option1' or `option2', etc., if the value of ASSEMBLER_DIALECT is zero, one or two, etc. Any special characters within these strings retain their usual meaning. If you do not define this macro, the characters `{', `|' and `}' do not have any special meaning when used in templates or operands to asm_fprintf. Define the macros REGISTER_PREFIX, LOCAL_LABEL_PREFIX, USER_LABEL_PREFIX and IMMEDIATE_PREFIX if you can express the variations in assemble language syntax with that mechanism. Define ASSEMBLER_DIALECT and use the `{option0|option1}' syntax if the syntax variant are larger and involve such things as different opcodes or operand order.
ASM_OUTPUT_REG_PUSH (stream, regno)
A C expression to output to stream some assembler code which will push hard register number regno onto the stack. The code need not be optimal, since this macro is used only when profiling.
ASM_OUTPUT_REG_POP (stream, regno)
A C expression to output to stream some assembler code which will pop hard register number regno off of the stack. The code need not be optimal, since this macro is used only when profiling.


Using and Porting GNU CC - Dispatch Tables

Output of Dispatch Tables

This concerns dispatch tables.

ASM_OUTPUT_ADDR_DIFF_ELT (stream, value, rel)
A C statement to output to the stdio stream stream an assembler pseudo-instruction to generate a difference between two labels. value and rel are the numbers of two internal labels. The definitions of these labels are output using ASM_OUTPUT_INTERNAL_LABEL, and they must be printed in the same way here. For example,
fprintf (stream, "\t.word L%d-L%d\n",
         value, rel)
You must provide this macro on machines where the addresses in a dispatch table are relative to the table's own address. If defined, GNU CC will also use this macro on all machines when producing PIC.
ASM_OUTPUT_ADDR_VEC_ELT (stream, value)
This macro should be provided on machines where the addresses in a dispatch table are absolute. The definition should be a C statement to output to the stdio stream stream an assembler pseudo-instruction to generate a reference to a label. value is the number of an internal label whose definition is output using ASM_OUTPUT_INTERNAL_LABEL. For example,
fprintf (stream, "\t.word L%d\n", value)
ASM_OUTPUT_CASE_LABEL (stream, prefix, num, table)
Define this if the label before a jump-table needs to be output specially. The first three arguments are the same as for ASM_OUTPUT_INTERNAL_LABEL; the fourth argument is the jump-table which follows (a jump_insn containing an addr_vec or addr_diff_vec). This feature is used on system V to output a swbeg statement for the table. If this macro is not defined, these labels are output with ASM_OUTPUT_INTERNAL_LABEL.
ASM_OUTPUT_CASE_END (stream, num, table)
Define this if something special must be output at the end of a jump-table. The definition should be a C statement to be executed after the assembler code for the table is written. It should write the appropriate code to stdio stream stream. The argument table is the jump-table insn, and num is the label-number of the preceding label. If this macro is not defined, nothing special is output at the end of the jump-table.


Using and Porting GNU CC - Exception Region Output

Assembler Commands for Exception Regions

This describes commands marking the start and the end of an exception region.

ASM_OUTPUT_EH_REGION_BEG ()
A C expression to output text to mark the start of an exception region. This macro need not be defined on most platforms.
ASM_OUTPUT_EH_REGION_END ()
A C expression to output text to mark the end of an exception region. This macro need not be defined on most platforms.
EXCEPTION_SECTION ()
A C expression to switch to the section in which the main exception table is to be placed (see section Dividing the Output into Sections (Texts, Data, ...)). The default is a section named .gcc_except_table on machines that support named sections via ASM_OUTPUT_SECTION_NAME, otherwise if `-fpic' or `-fPIC' is in effect, the data_section, otherwise the readonly_data_section.
EH_FRAME_SECTION_ASM_OP
If defined, a C string constant for the assembler operation to switch to the section for exception handling frame unwind information. If not defined, GNU CC will provide a default definition if the target supports named sections. `crtstuff.c' uses this macro to switch to the appropriate section. You should define this symbol if your target supports DWARF 2 frame unwind information and the default definition does not work.
OMIT_EH_TABLE ()
A C expression that is nonzero if the normal exception table output should be omitted. This macro need not be defined on most platforms.
EH_TABLE_LOOKUP ()
Alternate runtime support for looking up an exception at runtime and finding the associated handler, if the default method won't work. This macro need not be defined on most platforms.
DOESNT_NEED_UNWINDER
A C expression that decides whether or not the current function needs to have a function unwinder generated for it. See the file except.c for details on when to define this, and how.
MASK_RETURN_ADDR
An rtx used to mask the return address found via RETURN_ADDR_RTX, so that it does not contain any extraneous set bits in it.
DWARF2_UNWIND_INFO
Define this macro to 0 if your target supports DWARF 2 frame unwind information, but it does not yet work with exception handling. Otherwise, if your target supports this information (if it defines `INCOMING_RETURN_ADDR_RTX' and either `UNALIGNED_INT_ASM_OP' or `OBJECT_FORMAT_ELF'), GCC will provide a default definition of 1. If this macro is defined to 1, the DWARF 2 unwinder will be the default exception handling mechanism; otherwise, setjmp/longjmp will be used by default. If this macro is defined to anything, the DWARF 2 unwinder will be used instead of inline unwinders and __unwind_function in the non-setjmp case.


Using and Porting GNU CC - Alignment Output

Assembler Commands for Alignment

This describes commands for alignment.

ASM_OUTPUT_ALIGN_CODE (file)
A C expression to output text to align the location counter in the way that is desirable at a point in the code that is reached only by jumping. This macro need not be defined if you don't want any special alignment to be done at such a time. Most machine descriptions do not currently define the macro.
ASM_OUTPUT_LOOP_ALIGN (file)
A C expression to output text to align the location counter in the way that is desirable at the beginning of a loop. This macro need not be defined if you don't want any special alignment to be done at such a time. Most machine descriptions do not currently define the macro.
ASM_OUTPUT_SKIP (stream, nbytes)
A C statement to output to the stdio stream stream an assembler instruction to advance the location counter by nbytes bytes. Those bytes should be zero when loaded. nbytes will be a C expression of type int.
ASM_NO_SKIP_IN_TEXT
Define this macro if ASM_OUTPUT_SKIP should not be used in the text section because it fails put zeros in the bytes that are skipped. This is true on many Unix systems, where the pseudo--op to skip bytes produces no-op instructions rather than zeros when used in the text section.
ASM_OUTPUT_ALIGN (stream, power)
A C statement to output to the stdio stream stream an assembler command to advance the location counter to a multiple of 2 to the power bytes. power will be a C expression of type int.


Using and Porting GNU CC - Debugging Info

Controlling Debugging Information Format

This describes how to specify debugging information.


Using and Porting GNU CC - All Debuggers

Macros Affecting All Debugging Formats

These macros affect all debugging formats.

DBX_REGISTER_NUMBER (regno)
A C expression that returns the DBX register number for the compiler register number regno. In simple cases, the value of this expression may be regno itself. But sometimes there are some registers that the compiler knows about and DBX does not, or vice versa. In such cases, some register may need to have one number in the compiler and another for DBX. If two registers have consecutive numbers inside GNU CC, and they can be used as a pair to hold a multiword value, then they must have consecutive numbers after renumbering with DBX_REGISTER_NUMBER. Otherwise, debuggers will be unable to access such a pair, because they expect register pairs to be consecutive in their own numbering scheme. If you find yourself defining DBX_REGISTER_NUMBER in way that does not preserve register pairs, then what you must do instead is redefine the actual register numbering scheme.
DEBUGGER_AUTO_OFFSET (x)
A C expression that returns the integer offset value for an automatic variable having address x (an RTL expression). The default computation assumes that x is based on the frame-pointer and gives the offset from the frame-pointer. This is required for targets that produce debugging output for DBX or COFF-style debugging output for SDB and allow the frame-pointer to be eliminated when the `-g' options is used.
DEBUGGER_ARG_OFFSET (offset, x)
A C expression that returns the integer offset value for an argument having address x (an RTL expression). The nominal offset is offset.
PREFERRED_DEBUGGING_TYPE
A C expression that returns the type of debugging output GNU CC produces when the user specifies `-g' or `-ggdb'. Define this if you have arranged for GNU CC to support more than one format of debugging output. Currently, the allowable values are DBX_DEBUG, SDB_DEBUG, DWARF_DEBUG, DWARF2_DEBUG, and XCOFF_DEBUG. The value of this macro only affects the default debugging output; the user can always get a specific type of output by using `-gstabs', `-gcoff', `-gdwarf-1', `-gdwarf-2', or `-gxcoff'.


Using and Porting GNU CC - DBX Options

Specific Options for DBX Output

These are specific options for DBX output.

DBX_DEBUGGING_INFO
Define this macro if GNU CC should produce debugging output for DBX in response to the `-g' option.
XCOFF_DEBUGGING_INFO
Define this macro if GNU CC should produce XCOFF format debugging output in response to the `-g' option. This is a variant of DBX format.
DEFAULT_GDB_EXTENSIONS
Define this macro to control whether GNU CC should by default generate GDB's extended version of DBX debugging information (assuming DBX-format debugging information is enabled at all). If you don't define the macro, the default is 1: always generate the extended information if there is any occasion to.
DEBUG_SYMS_TEXT
Define this macro if all .stabs commands should be output while in the text section.
ASM_STABS_OP
A C string constant naming the assembler pseudo op to use instead of .stabs to define an ordinary debugging symbol. If you don't define this macro, .stabs is used. This macro applies only to DBX debugging information format.
ASM_STABD_OP
A C string constant naming the assembler pseudo op to use instead of .stabd to define a debugging symbol whose value is the current location. If you don't define this macro, .stabd is used. This macro applies only to DBX debugging information format.
ASM_STABN_OP
A C string constant naming the assembler pseudo op to use instead of .stabn to define a debugging symbol with no name. If you don't define this macro, .stabn is used. This macro applies only to DBX debugging information format.
DBX_NO_XREFS
Define this macro if DBX on your system does not support the construct `xstagname'. On some systems, this construct is used to describe a forward reference to a structure named tagname. On other systems, this construct is not supported at all.
DBX_CONTIN_LENGTH
A symbol name in DBX-format debugging information is normally continued (split into two separate .stabs directives) when it exceeds a certain length (by default, 80 characters). On some operating systems, DBX requires this splitting; on others, splitting must not be done. You can inhibit splitting by defining this macro with the value zero. You can override the default splitting-length by defining this macro as an expression for the length you desire.
DBX_CONTIN_CHAR
Normally continuation is indicated by adding a `\' character to the end of a .stabs string when a continuation follows. To use a different character instead, define this macro as a character constant for the character you want to use. Do not define this macro if backslash is correct for your system.
DBX_STATIC_STAB_DATA_SECTION
Define this macro if it is necessary to go to the data section before outputting the `.stabs' pseudo-op for a non-global static variable.
DBX_TYPE_DECL_STABS_CODE
The value to use in the "code" field of the .stabs directive for a typedef. The default is N_LSYM.
DBX_STATIC_CONST_VAR_CODE
The value to use in the "code" field of the .stabs directive for a static variable located in the text section. DBX format does not provide any "right" way to do this. The default is N_FUN.
DBX_REGPARM_STABS_CODE
The value to use in the "code" field of the .stabs directive for a parameter passed in registers. DBX format does not provide any "right" way to do this. The default is N_RSYM.
DBX_REGPARM_STABS_LETTER
The letter to use in DBX symbol data to identify a symbol as a parameter passed in registers. DBX format does not customarily provide any way to do this. The default is 'P'.
DBX_MEMPARM_STABS_LETTER
The letter to use in DBX symbol data to identify a symbol as a stack parameter. The default is 'p'.
DBX_FUNCTION_FIRST
Define this macro if the DBX information for a function and its arguments should precede the assembler code for the function. Normally, in DBX format, the debugging information entirely follows the assembler code.
DBX_LBRAC_FIRST
Define this macro if the N_LBRAC symbol for a block should precede the debugging information for variables and functions defined in that block. Normally, in DBX format, the N_LBRAC symbol comes first.
DBX_BLOCKS_FUNCTION_RELATIVE
Define this macro if the value of a symbol describing the scope of a block (N_LBRAC or N_RBRAC) should be relative to the start of the enclosing function. Normally, GNU C uses an absolute address.
DBX_USE_BINCL
Define this macro if GNU C should generate N_BINCL and N_EINCL stabs for included header files, as on Sun systems. This macro also directs GNU C to output a type number as a pair of a file number and a type number within the file. Normally, GNU C does not generate N_BINCL or N_EINCL stabs, and it outputs a single number for a type number.


Using and Porting GNU CC - DBX Hooks

Open-Ended Hooks for DBX Format

These are hooks for DBX format.

DBX_OUTPUT_LBRAC (stream, name)
Define this macro to say how to output to stream the debugging information for the start of a scope level for variable names. The argument name is the name of an assembler symbol (for use with assemble_name) whose value is the address where the scope begins.
DBX_OUTPUT_RBRAC (stream, name)
Like DBX_OUTPUT_LBRAC, but for the end of a scope level.
DBX_OUTPUT_ENUM (stream, type)
Define this macro if the target machine requires special handling to output an enumeration type. The definition should be a C statement (sans semicolon) to output the appropriate information to stream for the type type.
DBX_OUTPUT_FUNCTION_END (stream, function)
Define this macro if the target machine requires special output at the end of the debugging information for a function. The definition should be a C statement (sans semicolon) to output the appropriate information to stream. function is the FUNCTION_DECL node for the function.
DBX_OUTPUT_STANDARD_TYPES (syms)
Define this macro if you need to control the order of output of the standard data types at the beginning of compilation. The argument syms is a tree which is a chain of all the predefined global symbols, including names of data types. Normally, DBX output starts with definitions of the types for integers and characters, followed by all the other predefined types of the particular language in no particular order. On some machines, it is necessary to output different particular types first. To do this, define DBX_OUTPUT_STANDARD_TYPES to output those symbols in the necessary order. Any predefined types that you don't explicitly output will be output afterward in no particular order. Be careful not to define this macro so that it works only for C. There are no global variables to access most of the built-in types, because another language may have another set of types. The way to output a particular type is to look through syms to see if you can find it. Here is an example:
{
  tree decl;
  for (decl = syms; decl; decl = TREE_CHAIN (decl))
    if (!strcmp (IDENTIFIER_POINTER (DECL_NAME (decl)),
                 "long int"))
      dbxout_symbol (decl);
  ...
}
This does nothing if the expected type does not exist. See the function init_decl_processing in `c-decl.c' to find the names to use for all the built-in C types. Here is another way of finding a particular type:
{
  tree decl;
  for (decl = syms; decl; decl = TREE_CHAIN (decl))
    if (TREE_CODE (decl) == TYPE_DECL
        && (TREE_CODE (TREE_TYPE (decl))
            == INTEGER_CST)
        && TYPE_PRECISION (TREE_TYPE (decl)) == 16
        && TYPE_UNSIGNED (TREE_TYPE (decl)))
      /* This must be unsigned short.  */
      dbxout_symbol (decl);
  ...
}
NO_DBX_FUNCTION_END
Some stabs encapsulation formats (in particular ECOFF), cannot handle the .stabs "",N_FUN,,0,0,Lscope-function-1 gdb dbx extention construct. On those machines, define this macro to turn this feature off without disturbing the rest of the gdb extensions.


Using and Porting GNU CC - File Names and DBX

File Names in DBX Format

This describes file names in DBX format.

DBX_WORKING_DIRECTORY
Define this if DBX wants to have the current directory recorded in each object file. Note that the working directory is always recorded if GDB extensions are enabled.
DBX_OUTPUT_MAIN_SOURCE_FILENAME (stream, name)
A C statement to output DBX debugging information to the stdio stream stream which indicates that file name is the main source file--the file specified as the input file for compilation. This macro is called only once, at the beginning of compilation. This macro need not be defined if the standard form of output for DBX debugging information is appropriate.
DBX_OUTPUT_MAIN_SOURCE_DIRECTORY (stream, name)
A C statement to output DBX debugging information to the stdio stream stream which indicates that the current directory during compilation is named name. This macro need not be defined if the standard form of output for DBX debugging information is appropriate.
DBX_OUTPUT_MAIN_SOURCE_FILE_END (stream, name)
A C statement to output DBX debugging information at the end of compilation of the main source file name. If you don't define this macro, nothing special is output at the end of compilation, which is correct for most machines.
DBX_OUTPUT_SOURCE_FILENAME (stream, name)
A C statement to output DBX debugging information to the stdio stream stream which indicates that file name is the current source file. This output is generated each time input shifts to a different source file as a result of `#include', the end of an included file, or a `#line' command. This macro need not be defined if the standard form of output for DBX debugging information is appropriate.


Using and Porting GNU CC - SDB and DWARF

Macros for SDB and DWARF Output

Here are macros for SDB and DWARF output.

SDB_DEBUGGING_INFO
Define this macro if GNU CC should produce COFF-style debugging output for SDB in response to the `-g' option.
DWARF_DEBUGGING_INFO
Define this macro if GNU CC should produce dwarf format debugging output in response to the `-g' option.
DWARF2_DEBUGGING_INFO
Define this macro if GNU CC should produce dwarf version 2 format debugging output in response to the `-g' option. To support optional call frame debugging information, you must also define INCOMING_RETURN_ADDR_RTX and either set RTX_FRAME_RELATED_P on the prologue insns if you use RTL for the prologue, or call dwarf2out_def_cfa and dwarf2out_reg_save as appropriate from FUNCTION_PROLOGUE if you don't.
PUT_SDB_...
Define these macros to override the assembler syntax for the special SDB assembler directives. See `sdbout.c' for a list of these macros and their arguments. If the standard syntax is used, you need not define them yourself.
SDB_DELIM
Some assemblers do not support a semicolon as a delimiter, even between SDB assembler directives. In that case, define this macro to be the delimiter to use (usually `\n'). It is not necessary to define a new set of PUT_SDB_op macros if this is the only change required.
SDB_GENERATE_FAKE
Define this macro to override the usual method of constructing a dummy name for anonymous structure and union types. See `sdbout.c' for more information.
SDB_ALLOW_UNKNOWN_REFERENCES
Define this macro to allow references to unknown structure, union, or enumeration tags to be emitted. Standard COFF does not allow handling of unknown references, MIPS ECOFF has support for it.
SDB_ALLOW_FORWARD_REFERENCES
Define this macro to allow references to structure, union, or enumeration tags that have not yet been seen to be handled. Some assemblers choke if forward tags are used, while some require it.


Using and Porting GNU CC - Cross-compilation

Cross Compilation and Floating Point

While all modern machines use 2's complement representation for integers, there are a variety of representations for floating point numbers. This means that in a cross-compiler the representation of floating point numbers in the compiled program may be different from that used in the machine doing the compilation.

Because different representation systems may offer different amounts of range and precision, the cross compiler cannot safely use the host machine's floating point arithmetic. Therefore, floating point constants must be represented in the target machine's format. This means that the cross compiler cannot use atof to parse a floating point constant; it must have its own special routine to use instead. Also, constant folding must emulate the target machine's arithmetic (or must not be done at all).

The macros in the following table should be defined only if you are cross compiling between different floating point formats.

Otherwise, don't define them. Then default definitions will be set up which use double as the data type, == to test for equality, etc.

You don't need to worry about how many times you use an operand of any of these macros. The compiler never uses operands which have side effects.

REAL_VALUE_TYPE
A macro for the C data type to be used to hold a floating point value in the target machine's format. Typically this would be a struct containing an array of int.
REAL_VALUES_EQUAL (x, y)
A macro for a C expression which compares for equality the two values, x and y, both of type REAL_VALUE_TYPE.
REAL_VALUES_LESS (x, y)
A macro for a C expression which tests whether x is less than y, both values being of type REAL_VALUE_TYPE and interpreted as floating point numbers in the target machine's representation.
REAL_VALUE_LDEXP (x, scale)
A macro for a C expression which performs the standard library function ldexp, but using the target machine's floating point representation. Both x and the value of the expression have type REAL_VALUE_TYPE. The second argument, scale, is an integer.
REAL_VALUE_FIX (x)
A macro whose definition is a C expression to convert the target-machine floating point value x to a signed integer. x has type REAL_VALUE_TYPE.
REAL_VALUE_UNSIGNED_FIX (x)
A macro whose definition is a C expression to convert the target-machine floating point value x to an unsigned integer. x has type REAL_VALUE_TYPE.
REAL_VALUE_RNDZINT (x)
A macro whose definition is a C expression to round the target-machine floating point value x towards zero to an integer value (but still as a floating point number). x has type REAL_VALUE_TYPE, and so does the value.
REAL_VALUE_UNSIGNED_RNDZINT (x)
A macro whose definition is a C expression to round the target-machine floating point value x towards zero to an unsigned integer value (but still represented as a floating point number). x has type REAL_VALUE_TYPE, and so does the value.
REAL_VALUE_ATOF (string, mode)
A macro for a C expression which converts string, an expression of type char *, into a floating point number in the target machine's representation for mode mode. The value has type REAL_VALUE_TYPE.
REAL_INFINITY
Define this macro if infinity is a possible floating point value, and therefore division by 0 is legitimate.
REAL_VALUE_ISINF (x)
A macro for a C expression which determines whether x, a floating point value, is infinity. The value has type int. By default, this is defined to call isinf.
REAL_VALUE_ISNAN (x)
A macro for a C expression which determines whether x, a floating point value, is a "nan" (not-a-number). The value has type int. By default, this is defined to call isnan.

Define the following additional macros if you want to make floating point constant folding work while cross compiling. If you don't define them, cross compilation is still possible, but constant folding will not happen for floating point values.

REAL_ARITHMETIC (output, code, x, y)
A macro for a C statement which calculates an arithmetic operation of the two floating point values x and y, both of type REAL_VALUE_TYPE in the target machine's representation, to produce a result of the same type and representation which is stored in output (which will be a variable). The operation to be performed is specified by code, a tree code which will always be one of the following: PLUS_EXPR, MINUS_EXPR, MULT_EXPR, RDIV_EXPR, MAX_EXPR, MIN_EXPR. The expansion of this macro is responsible for checking for overflow. If overflow happens, the macro expansion should execute the statement return 0;, which indicates the inability to perform the arithmetic operation requested.
REAL_VALUE_NEGATE (x)
A macro for a C expression which returns the negative of the floating point value x. Both x and the value of the expression have type REAL_VALUE_TYPE and are in the target machine's floating point representation. There is no way for this macro to report overflow, since overflow can't happen in the negation operation.
REAL_VALUE_TRUNCATE (mode, x)
A macro for a C expression which converts the floating point value x to mode mode. Both x and the value of the expression are in the target machine's floating point representation and have type REAL_VALUE_TYPE. However, the value should have an appropriate bit pattern to be output properly as a floating constant whose precision accords with mode mode. There is no way for this macro to report overflow.
REAL_VALUE_TO_INT (low, high, x)
A macro for a C expression which converts a floating point value x into a double-precision integer which is then stored into low and high, two variables of type int.
REAL_VALUE_FROM_INT (x, low, high, mode)
A macro for a C expression which converts a double-precision integer found in low and high, two variables of type int, into a floating point value which is then stored into x. The value is in the target machine's representation for mode mode and has the type REAL_VALUE_TYPE.


Using and Porting GNU CC - Misc

Miscellaneous Parameters

Here are several miscellaneous parameters.

PREDICATE_CODES
Define this if you have defined special-purpose predicates in the file `machine.c'. This macro is called within an initializer of an array of structures. The first field in the structure is the name of a predicate and the second field is an array of rtl codes. For each predicate, list all rtl codes that can be in expressions matched by the predicate. The list should have a trailing comma. Here is an example of two entries in the list for a typical RISC machine:
#define PREDICATE_CODES \
  {"gen_reg_rtx_operand", {SUBREG, REG}},  \
  {"reg_or_short_cint_operand", {SUBREG, REG, CONST_INT}},
Defining this macro does not affect the generated code (however, incorrect definitions that omit an rtl code that may be matched by the predicate can cause the compiler to malfunction). Instead, it allows the table built by `genrecog' to be more compact and efficient, thus speeding up the compiler. The most important predicates to include in the list specified by this macro are thoses used in the most insn patterns.
CASE_VECTOR_MODE
An alias for a machine mode name. This is the machine mode that elements of a jump-table should have.
CASE_VECTOR_PC_RELATIVE
Define this macro if jump-tables should contain relative addresses.
CASE_DROPS_THROUGH
Define this if control falls through a case insn when the index value is out of range. This means the specified default-label is actually ignored by the case insn proper.
CASE_VALUES_THRESHOLD
Define this to be the smallest number of different values for which it is best to use a jump-table instead of a tree of conditional branches. The default is four for machines with a casesi instruction and five otherwise. This is best for most machines.
WORD_REGISTER_OPERATIONS
Define this macro if operations between registers with integral mode smaller than a word are always performed on the entire register. Most RISC machines have this property and most CISC machines do not.
LOAD_EXTEND_OP (mode)
Define this macro to be a C expression indicating when insns that read memory in mode, an integral mode narrower than a word, set the bits outside of mode to be either the sign-extension or the zero-extension of the data read. Return SIGN_EXTEND for values of mode for which the insn sign-extends, ZERO_EXTEND for which it zero-extends, and NIL for other modes. This macro is not called with mode non-integral or with a width greater than or equal to BITS_PER_WORD, so you may return any value in this case. Do not define this macro if it would always return NIL. On machines where this macro is defined, you will normally define it as the constant SIGN_EXTEND or ZERO_EXTEND.
SHORT_IMMEDIATES_SIGN_EXTEND
Define this macro if loading short immediate values into registers sign extends.
IMPLICIT_FIX_EXPR
An alias for a tree code that should be used by default for conversion of floating point values to fixed point. Normally, FIX_ROUND_EXPR is used.
FIXUNS_TRUNC_LIKE_FIX_TRUNC
Define this macro if the same instructions that convert a floating point number to a signed fixed point number also convert validly to an unsigned one.
EASY_DIV_EXPR
An alias for a tree code that is the easiest kind of division to compile code for in the general case. It may be TRUNC_DIV_EXPR, FLOOR_DIV_EXPR, CEIL_DIV_EXPR or ROUND_DIV_EXPR. These four division operators differ in how they round the result to an integer. EASY_DIV_EXPR is used when it is permissible to use any of those kinds of division and the choice should be made on the basis of efficiency.
MOVE_MAX
The maximum number of bytes that a single instruction can move quickly between memory and registers or between two memory locations.
MAX_MOVE_MAX
The maximum number of bytes that a single instruction can move quickly between memory and registers or between two memory locations. If this is undefined, the default is MOVE_MAX. Otherwise, it is the constant value that is the largest value that MOVE_MAX can have at run-time.
SHIFT_COUNT_TRUNCATED
A C expression that is nonzero if on this machine the number of bits actually used for the count of a shift operation is equal to the number of bits needed to represent the size of the object being shifted. When this macro is non-zero, the compiler will assume that it is safe to omit a sign-extend, zero-extend, and certain bitwise `and' instructions that truncates the count of a shift operation. On machines that have instructions that act on bitfields at variable positions, which may include `bit test' instructions, a nonzero SHIFT_COUNT_TRUNCATED also enables deletion of truncations of the values that serve as arguments to bitfield instructions. If both types of instructions truncate the count (for shifts) and position (for bitfield operations), or if no variable-position bitfield instructions exist, you should define this macro. However, on some machines, such as the 80386 and the 680x0, truncation only applies to shift operations and not the (real or pretended) bitfield operations. Define SHIFT_COUNT_TRUNCATED to be zero on such machines. Instead, add patterns to the `md' file that include the implied truncation of the shift instructions. You need not define this macro if it would always have the value of zero.
TRULY_NOOP_TRUNCATION (outprec, inprec)
A C expression which is nonzero if on this machine it is safe to "convert" an integer of inprec bits to one of outprec bits (where outprec is smaller than inprec) by merely operating on it as if it had only outprec bits. On many machines, this expression can be 1. When TRULY_NOOP_TRUNCATION returns 1 for a pair of sizes for modes for which MODES_TIEABLE_P is 0, suboptimal code can result. If this is the case, making TRULY_NOOP_TRUNCATION return 0 in such cases may improve things.
STORE_FLAG_VALUE
A C expression describing the value returned by a comparison operator with an integral mode and stored by a store-flag instruction (`scond') when the condition is true. This description must apply to all the `scond' patterns and all the comparison operators whose results have a MODE_INT mode. A value of 1 or -1 means that the instruction implementing the comparison operator returns exactly 1 or -1 when the comparison is true and 0 when the comparison is false. Otherwise, the value indicates which bits of the result are guaranteed to be 1 when the comparison is true. This value is interpreted in the mode of the comparison operation, which is given by the mode of the first operand in the `scond' pattern. Either the low bit or the sign bit of STORE_FLAG_VALUE be on. Presently, only those bits are used by the compiler. If STORE_FLAG_VALUE is neither 1 or -1, the compiler will generate code that depends only on the specified bits. It can also replace comparison operators with equivalent operations if they cause the required bits to be set, even if the remaining bits are undefined. For example, on a machine whose comparison operators return an SImode value and where STORE_FLAG_VALUE is defined as `0x80000000', saying that just the sign bit is relevant, the expression
(ne:SI (and:SI x (const_int power-of-2)) (const_int 0))
can be converted to
(ashift:SI x (const_int n))
where n is the appropriate shift count to move the bit being tested into the sign bit. There is no way to describe a machine that always sets the low-order bit for a true value, but does not guarantee the value of any other bits, but we do not know of any machine that has such an instruction. If you are trying to port GNU CC to such a machine, include an instruction to perform a logical-and of the result with 1 in the pattern for the comparison operators and let us know (see section How to Report Bugs). Often, a machine will have multiple instructions that obtain a value from a comparison (or the condition codes). Here are rules to guide the choice of value for STORE_FLAG_VALUE, and hence the instructions to be used:
  • Use the shortest sequence that yields a valid definition for STORE_FLAG_VALUE. It is more efficient for the compiler to "normalize" the value (convert it to, e.g., 1 or 0) than for the comparison operators to do so because there may be opportunities to combine the normalization with other operations.
  • For equal-length sequences, use a value of 1 or -1, with -1 being slightly preferred on machines with expensive jumps and 1 preferred on other machines.
  • As a second choice, choose a value of `0x80000001' if instructions exist that set both the sign and low-order bits but do not define the others.
  • Otherwise, use a value of `0x80000000'.
Many machines can produce both the value chosen for STORE_FLAG_VALUE and its negation in the same number of instructions. On those machines, you should also define a pattern for those cases, e.g., one matching
(set A (neg:m (ne:m B C)))
Some machines can also perform and or plus operations on condition code values with less instructions than the corresponding `scond' insn followed by and or plus. On those machines, define the appropriate patterns. Use the names incscc and decscc, respectively, for the patterns which perform plus or minus operations on condition code values. See `rs6000.md' for some examples. The GNU Superoptizer can be used to find such instruction sequences on other machines. You need not define STORE_FLAG_VALUE if the machine has no store-flag instructions.
FLOAT_STORE_FLAG_VALUE
A C expression that gives a non-zero floating point value that is returned when comparison operators with floating-point results are true. Define this macro on machine that have comparison operations that return floating-point values. If there are no such operations, do not define this macro.
Pmode
An alias for the machine mode for pointers. On most machines, define this to be the integer mode corresponding to the width of a hardware pointer; SImode on 32-bit machine or DImode on 64-bit machines. On some machines you must define this to be one of the partial integer modes, such as PSImode. The width of Pmode must be at least as large as the value of POINTER_SIZE. If it is not equal, you must define the macro POINTERS_EXTEND_UNSIGNED to specify how pointers are extended to Pmode.
FUNCTION_MODE
An alias for the machine mode used for memory references to functions being called, in call RTL expressions. On most machines this should be QImode.
INTEGRATE_THRESHOLD (decl)
A C expression for the maximum number of instructions above which the function decl should not be inlined. decl is a FUNCTION_DECL node. The default definition of this macro is 64 plus 8 times the number of arguments that the function accepts. Some people think a larger threshold should be used on RISC machines.
SCCS_DIRECTIVE
Define this if the preprocessor should ignore #sccs directives and print no error message.
NO_IMPLICIT_EXTERN_C
Define this macro if the system header files support C++ as well as C. This macro inhibits the usual method of using system header files in C++, which is to pretend that the file's contents are enclosed in `extern "C" {...}'.
HANDLE_PRAGMA (stream, node)
Define this macro if you want to implement any pragmas. If defined, it is a C expression whose value is 1 if the pragma was handled by the function. The argument stream is the stdio input stream from which the source text can be read. node is the tree node for the identifier after the #pragma. It is generally a bad idea to implement new uses of #pragma. The only reason to define this macro is for compatibility with other compilers that do support #pragma for the sake of any user programs which already use it.
VALID_MACHINE_DECL_ATTRIBUTE (decl, attributes, identifier, args)
If defined, a C expression whose value is nonzero if identifier with arguments args is a valid machine specific attribute for decl. The attributes in attributes have previously been assigned to decl.
VALID_MACHINE_TYPE_ATTRIBUTE (type, attributes, identifier, args)
If defined, a C expression whose value is nonzero if identifier with arguments args is a valid machine specific attribute for type. The attributes in attributes have previously been assigned to type.
COMP_TYPE_ATTRIBUTES (type1, type2)
If defined, a C expression whose value is zero if the attributes on type1 and type2 are incompatible, one if they are compatible, and two if they are nearly compatible (which causes a warning to be generated).
SET_DEFAULT_TYPE_ATTRIBUTES (type)
If defined, a C statement that assigns default attributes to newly defined type.
DOLLARS_IN_IDENTIFIERS
Define this macro to control use of the character `$' in identifier names. 0 means `$' is not allowed by default; 1 means it is allowed. 1 is the default; there is no need to define this macro in that case. This macro controls the compiler proper; it does not affect the preprocessor.
NO_DOLLAR_IN_LABEL
Define this macro if the assembler does not accept the character `$' in label names. By default constructors and destructors in G++ have `$' in the identifiers. If this macro is defined, `.' is used instead.
NO_DOT_IN_LABEL
Define this macro if the assembler does not accept the character `.' in label names. By default constructors and destructors in G++ have names that use `.'. If this macro is defined, these names are rewritten to avoid `.'.
DEFAULT_MAIN_RETURN
Define this macro if the target system expects every program's main function to return a standard "success" value by default (if no other value is explicitly returned). The definition should be a C statement (sans semicolon) to generate the appropriate rtl instructions. It is used only when compiling the end of main.
HAVE_ATEXIT
Define this if the target system supports the function atexit from the ANSI C standard. If this is not defined, and INIT_SECTION_ASM_OP is not defined, a default exit function will be provided to support C++.
EXIT_BODY
Define this if your exit function needs to do something besides calling an external function _cleanup before terminating with _exit. The EXIT_BODY macro is only needed if netiher HAVE_ATEXIT nor INIT_SECTION_ASM_OP are defined.
INSN_SETS_ARE_DELAYED (insn)
Define this macro as a C expression that is nonzero if it is safe for the delay slot scheduler to place instructions in the delay slot of insn, even if they appear to use a resource set or clobbered in insn. insn is always a jump_insn or an insn; GNU CC knows that every call_insn has this behavior. On machines where some insn or jump_insn is really a function call and hence has this behavior, you should define this macro. You need not define this macro if it would always return zero.
INSN_REFERENCES_ARE_DELAYED (insn)
Define this macro as a C expression that is nonzero if it is safe for the delay slot scheduler to place instructions in the delay slot of insn, even if they appear to set or clobber a resource referenced in insn. insn is always a jump_insn or an insn. On machines where some insn or jump_insn is really a function call and its operands are registers whose use is actually in the subroutine it calls, you should define this macro. Doing so allows the delay slot scheduler to move instructions which copy arguments into the argument registers into the delay slot of insn. You need not define this macro if it would always return zero.
MACHINE_DEPENDENT_REORG (insn)
In rare cases, correct code generation requires extra machine dependent processing between the second jump optimization pass and delayed branch scheduling. On those machines, define this macro as a C statement to act on the code starting at insn.
MULTIPLE_SYMBOL_SPACES
Define this macro if in some cases global symbols from one translation unit may not be bound to undefined symbols in another translation unit without user intervention. For instance, under Microsoft Windows symbols must be explicitly imported from shared libraries (DLLs).
GIV_SORT_CRITERION (giv1, giv2)
In some cases, the strength reduction optimization pass can produce better code if this is defined. This macro controls the order that induction variables are combined. This macro is particularly useful if the target has limited addressing modes. For instance, the SH target has only positive offsets in addresses. Thus sorting to put the smallest address first allows the most combinations to be found.
ISSUE_RATE
A C expression that returns how many instructions can be issued at the same time if the machine is a superscalar machine. This is only used by the `Haifa' scheduler, and not the traditional scheduler.


Using and Porting GNU CC - Config

The Configuration File

The configuration file `xm-machine.h' contains macro definitions that describe the machine and system on which the compiler is running, unlike the definitions in `machine.h', which describe the machine for which the compiler is producing output. Most of the values in `xm-machine.h' are actually the same on all machines that GNU CC runs on, so large parts of all configuration files are identical. But there are some macros that vary:

USG
Define this macro if the host system is System V.
VMS
Define this macro if the host system is VMS.
FATAL_EXIT_CODE
A C expression for the status code to be returned when the compiler exits after serious errors.
SUCCESS_EXIT_CODE
A C expression for the status code to be returned when the compiler exits without serious errors.
HOST_WORDS_BIG_ENDIAN
Defined if the host machine stores words of multi-word values in big-endian order. (GNU CC does not depend on the host byte ordering within a word.)
HOST_FLOAT_WORDS_BIG_ENDIAN
Define this macro to be 1 if the host machine stores DFmode, XFmode or TFmode floating point numbers in memory with the word containing the sign bit at the lowest address; otherwise, define it to be zero. This macro need not be defined if the ordering is the same as for multi-word integers.
HOST_FLOAT_FORMAT
A numeric code distinguishing the floating point format for the host machine. See TARGET_FLOAT_FORMAT in section Storage Layout for the alternatives and default.
HOST_BITS_PER_CHAR
A C expression for the number of bits in char on the host machine.
HOST_BITS_PER_SHORT
A C expression for the number of bits in short on the host machine.
HOST_BITS_PER_INT
A C expression for the number of bits in int on the host machine.
HOST_BITS_PER_LONG
A C expression for the number of bits in long on the host machine.
ONLY_INT_FIELDS
Define this macro to indicate that the host compiler only supports int bit fields, rather than other integral types, including enum, as do most C compilers.
OBSTACK_CHUNK_SIZE
A C expression for the size of ordinary obstack chunks. If you don't define this, a usually-reasonable default is used.
OBSTACK_CHUNK_ALLOC
The function used to allocate obstack chunks. If you don't define this, xmalloc is used.
OBSTACK_CHUNK_FREE
The function used to free obstack chunks. If you don't define this, free is used.
USE_C_ALLOCA
Define this macro to indicate that the compiler is running with the alloca implemented in C. This version of alloca can be found in the file `alloca.c'; to use it, you must also alter the `Makefile' variable ALLOCA. (This is done automatically for the systems on which we know it is needed.) If you do define this macro, you should probably do it as follows:
#ifndef __GNUC__
#define USE_C_ALLOCA
#else
#define alloca __builtin_alloca
#endif
so that when the compiler is compiled with GNU CC it uses the more efficient built-in alloca function.
FUNCTION_CONVERSION_BUG
Define this macro to indicate that the host compiler does not properly handle converting a function value to a pointer-to-function when it is used in an expression.
HAVE_VPRINTF
Define this if the library function vprintf is available on your system.
MULTIBYTE_CHARS
Define this macro to enable support for multibyte characters in the input to GNU CC. This requires that the host system support the ANSI C library functions for converting multibyte characters to wide characters.
HAVE_PUTENV
Define this if the library function putenv is available on your system.
POSIX
Define this if your system is POSIX.1 compliant.
HAVE_POPEN
Define this if the library function popen is available on your system.
NO_SYS_SIGLIST
Define this if your system does not provide the variable sys_siglist.
USE_PROTOTYPES
Define this to be 1 if you know that the host compiler supports prototypes, even if it doesn't define __STDC__, or define it to be 0 if you do not want any prototypes used in compiling GNU CC. If `USE_PROTOTYPES' is not defined, it will be determined automatically whether your compiler supports prototypes by checking if `__STDC__' is defined.
NO_MD_PROTOTYPES
Define this if you wish suppression of prototypes generated from the machine description file, but to use other prototypes within GNU CC. If `USE_PROTOTYPES' is defined to be 0, or the host compiler does not support prototypes, this macro has no effect.
MD_CALL_PROTOTYPES
Define this if you wish to generate prototypes for the gen_call or gen_call_value functions generated from the machine description file. If `USE_PROTOTYPES' is defined to be 0, or the host compiler does not support prototypes, or `NO_MD_PROTOTYPES' is defined, this macro has no effect. As soon as all of the machine descriptions are modified to have the appropriate number of arguments, this macro will be removed. Some systems do provide this variable, but with a different name such as _sys_siglist. On these systems, you can define sys_siglist as a macro which expands into the name actually provided. If you define sys_siglist, you should also define SYS_SIGLIST_DECLARED.
NO_STAB_H
Define this if your system does not have the include file `stab.h'. If `USG' is defined, `NO_STAB_H' is assumed.
PATH_SEPARATOR
Define this macro to be a C character constant representing the character used to separate components in paths. The default value is. the colon character
DIR_SEPARATOR
If your system uses some character other than slash to separate directory names within a file specification, define this macro to be a C character constant specifying that character. When GNU CC displays file names, the character you specify will be used. GNU CC will test for both slash and the character you specify when parsing filenames.
OBJECT_SUFFIX
Define this macro to be a C string representing the suffix for object files on your machine. If you do not define this macro, GNU CC will use `.o' as the suffix for object files.
EXECUTABLE_SUFFIX
Define this macro to be a C string representing the suffix for executable files on your machine. If you do not define this macro, GNU CC will use the null string as the suffix for object files.
COLLECT_EXPORT_LIST
If defined, collect2 will scan the individual object files specified on its command line and create an export list for the linker. Define this macro for systems like AIX, where the linker discards object files that are not referenced from main and uses export lists.

In addition, configuration files for system V define bcopy, bzero and bcmp as aliases. Some files define alloca as a macro when compiled with GNU CC, in order to take advantage of the benefit of GNU CC's built-in alloca.


Using and Porting GNU CC - Fragments

Makefile Fragments

When you configure GNU CC using the `configure' script (see section Installing GNU CC), it will construct the file `Makefile' from the template file `Makefile.in'. When it does this, it will incorporate makefile fragment files from the `config' directory, named `t-target' and `x-host'. If these files do not exist, it means nothing needs to be added for a given target or host.


Using and Porting GNU CC - Target Fragment

The Target Makefile Fragment

The target makefile fragment, `t-target', defines special target dependent variables and targets used in the `Makefile':

LIBGCC1
The rule to use to build `libgcc1.a'. If your target does not need to use the functions in `libgcc1.a', set this to empty. See section Interfacing to GNU CC Output.
CROSS_LIBGCC1
The rule to use to build `libgcc1.a' when building a cross compiler. If your target does not need to use the functions in `libgcc1.a', set this to empty. See section `libgcc.a' and Cross-Compilers.
LIBGCC2_CFLAGS
Compiler flags to use when compiling `libgcc2.c'.
LIB2FUNCS_EXTRA
A list of source file names to be compiled or assembled and inserted into `libgcc.a'.
CRTSTUFF_T_CFLAGS
Special flags used when compiling `crtstuff.c'. See section How Initialization Functions Are Handled.
CRTSTUFF_T_CFLAGS_S
Special flags used when compiling `crtstuff.c' for shared linking. Used if you use `crtbeginS.o' and `crtendS.o' in EXTRA-PARTS. See section How Initialization Functions Are Handled.
MULTILIB_OPTIONS
For some targets, invoking GNU CC in different ways produces objects that can not be linked together. For example, for some targets GNU CC produces both big and little endian code. For these targets, you must arrange for multiple versions of `libgcc.a' to be compiled, one for each set of incompatible options. When GNU CC invokes the linker, it arranges to link in the right version of `libgcc.a', based on the command line options used. The MULTILIB_OPTIONS macro lists the set of options for which special versions of `libgcc.a' must be built. Write options that are mutually incompatible side by side, separated by a slash. Write options that may be used together separated by a space. The build procedure will build all combinations of compatible options. For example, if you set MULTILIB_OPTIONS to `m68000/m68020 msoft-float', `Makefile' will build special versions of `libgcc.a' using the sets of options `-m68000', `-m68020', `-msoft-float', `-m68000 -msoft-float', and `-m68020 -msoft-float'.
MULTILIB_DIRNAMES
If MULTILIB_OPTIONS is used, this variable specifies the directory names that should be used to hold the various libraries. Write one element in MULTILIB_DIRNAMES for each element in MULTILIB_OPTIONS. If MULTILIB_DIRNAMES is not used, the default value will be MULTILIB_OPTIONS, with all slashes treated as spaces. For example, if MULTILIB_OPTIONS is specified as `m68000/m68020 msoft-float', then the default value of MULTILIB_DIRNAMES is `m68000 m68020 msoft-float'. You may specify a different value if you desire a different set of directory names.
MULTILIB_MATCHES
Sometimes the same option may be written in two different ways. If an option is listed in MULTILIB_OPTIONS, GNU CC needs to know about any synonyms. In that case, set MULTILIB_MATCHES to a list of items of the form `option=option' to describe all relevant synonyms. For example, `m68000=mc68000 m68020=mc68020'.
MULTILIB_EXCEPTIONS
Sometimes when there are multiple sets of MULTILIB_OPTIONS being specified, there are combinations that should not be built. In that case, set MULTILIB_EXCEPTIONS to be all of the switch exceptions in shell case syntax that should not be built. For example, in the PowerPC embedded ABI support, it was not desirable to build libraries that compiled with the `-mcall-aixdesc' option and either of the `-mcall-aixdesc' or `-mlittle' options at the same time, and therefore MULTILIB_EXCEPTIONS is set to *mrelocatable/*mcall-aixdesc* *mlittle/*mcall-aixdesc*.
MULTILIB_EXTRA_OPTS
Sometimes it is desirable that when building multiple versions of `libgcc.a' certain options should always be passed on to the compiler. In that case, set MULTILIB_EXTRA_OPTS to be the list of options to be used for all builds.


Using and Porting GNU CC - Host Fragment

The Host Makefile Fragment

The host makefile fragment, `x-host', defines special host dependent variables and targets used in the `Makefile':

CC
The compiler to use when building the first stage.
CLIB
Additional host libraries to link with.
OLDCC
The compiler to use when building `libgcc1.a' for a native compilation.
OLDAR
The version of ar to use when building `libgcc1.a' for a native compilation.
INSTALL
The install program to use.


Using and Porting GNU CC - Funding

Funding Free Software

If you want to have more free software a few years from now, it makes sense for you to help encourage people to contribute funds for its development. The most effective approach known is to encourage commercial redistributors to donate.

Users of free software systems can boost the pace of development by encouraging for-a-fee distributors to donate part of their selling price to free software developers--the Free Software Foundation, and others.

The way to convince distributors to do this is to demand it and expect it from them. So when you compare distributors, judge them partly by how much they give to free software development. Show distributors they must compete to be the one who gives the most.

To make this approach work, you must insist on numbers that you can compare, such as, "We will donate ten dollars to the Frobnitz project for each disk sold." Don't be satisfied with a vague promise, such as "A portion of the profits are donated," since it doesn't give a basis for comparison.

Even a precise fraction "of the profits from this disk" is not very meaningful, since creative accounting and unrelated business decisions can greatly alter what fraction of the sales price counts as profit. If the price you pay is $50, ten percent of the profit is probably less than a dollar; it might be a few cents, or nothing at all.

Some redistributors do development work themselves. This is useful too; but to keep everyone honest, you need to inquire how much they do, and what kind. Some kinds of development make much more long-term difference than others. For example, maintaining a separate version of a program contributes very little; maintaining the standard version of a program for the whole community contributes much. Easy new ports contribute little, since someone else would surely do them; difficult ports such as adding a new CPU to the GNU C compiler contribute more; major new features or packages contribute the most.

By establishing the idea that supporting further development is "the proper thing to do" when distributing free software for a fee, we can assure a steady flow of resources into making more free software.

Copyright (C) 1994 Free Software Foundation, Inc.
Verbatim copying and redistribution of this section is permitted
without royalty; alteration is not permitted.


Using and Porting GNU CC - Look and Feel

Protect Your Freedom--Fight "Look And Feel"

This section is a political message from the League for Programming Freedom to the users of GNU CC. We have included it here because the issue of interface copyright is important to the GNU project.

Apple, Lotus, and now CDC have tried to create a new form of legal monopoly: a copyright on a user interface.

An interface is a kind of language--a set of conventions for communication between two entities, human or machine. Until a few years ago, the law seemed clear: interfaces were outside the domain of copyright, so programmers could program freely and implement whatever interface the users demanded. Imitating de-facto standard interfaces, sometimes with improvements, was standard practice in the computer field. These improvements, if accepted by the users, caught on and became the norm; in this way, much progress took place.

Computer users, and most software developers, were happy with this state of affairs. However, large companies such as Apple and Lotus would prefer a different system--one in which they can own interfaces and thereby rid themselves of all serious competitors. They hope that interface copyright will give them, in effect, monopolies on major classes of software.

Other large companies such as IBM and Digital also favor interface monopolies, for the same reason: if languages become property, they expect to own many de-facto standard languages. But Apple and Lotus are the ones who have actually sued. Apple's lawsuit was defeated, for reasons only partly related to the general issue of interface copyright.

Lotus won lawsuits against two small companies, which were thus put out of business. Then Lotus sued Borland; Lotus won in the trial court (no surprise, since it was the same court that had ruled for Lotus twice before), but the court of appeals ruled in favor of Borland, which was assisted by a friend-of-the-court brief from the League for Programming Freedom.

Lotus appealed the case to the Supreme Court, which heard the case but was unable to reach a decision. This failure means that the appeals court decision stands, in one portion of the United States, and may influence the other appeals courts, but it does not set a nationwide precedent. The battle is not over, and it is not limited to the United States.

The battle is extending into other areas of software as well. In 1995 a company that produced a simulator for a CDC computer was shut down by a copyright lawsuit, in which CDC charged that the simulator infringed the copyright on the manuals for the computer.

If the monopolists get their way, they will hobble the software field:

  • Gratuitous incompatibilities will burden users. Imagine if each car manufacturer had to design a different way to start, stop, and steer a car.
  • Users will be "locked in" to whichever interface they learn; then they will be prisoners of one supplier, who will charge a monopolistic price.
  • Large companies have an unfair advantage wherever lawsuits become commonplace. Since they can afford to sue, they can intimidate smaller developers with threats even when they don't really have a case.
  • Interface improvements will come slower, since incremental evolution through creative partial imitation will no longer occur.

If interface monopolies are accepted, other large companies are waiting to grab theirs:

  • Adobe is expected to claim a monopoly on the interfaces of various popular application programs, if Lotus ultimately wins the case against Borland.
  • Open Computing magazine reported a Microsoft vice president as threatening to sue people who imitate the interface of Windows.

Users invest a great deal of time and money in learning to use computer interfaces. Far more, in fact, than software developers invest in developing and even implementing the interfaces. Whoever can own an interface, has made its users into captives, and misappropriated their investment.

To protect our freedom from monopolies like these, a group of programmers and users have formed a grass-roots political organization, the League for Programming Freedom.

The purpose of the League is to oppose monopolistic practices such as interface copyright and software patents. The League calls for a return to the legal policies of the recent past, in which programmers could program freely. The League is not concerned with free software as an issue, and is not affiliated with the Free Software Foundation.

The League's activities include publicizing the issues, as is being done here, and filing friend-of-the-court briefs on behalf of defendants sued by monopolists.

The League's membership rolls include Donald Knuth, the foremost authority on algorithms, John McCarthy, inventor of Lisp, Marvin Minsky, founder of the MIT Artificial Intelligence lab, Guy L. Steele, Jr., author of well-known books on Lisp and C, as well as Richard Stallman, the developer of GNU CC. Please join and add your name to the list. Membership dues in the League are $42 per year for programmers, managers and professionals; $10.50 for students; $21 for others.

Activist members are especially important, but members who have no time to give are also important. Surveys at major ACM conferences have indicated a vast majority of attendees agree with the League on both issues (interface copyrights and software patents). If just ten percent of the programmers who agree with the League join the League, we will probably triumph.

To join, or for more information, send electronic mail to the address lpf@uunet.uu.net or write to:

League for Programming Freedom
1 Kendall Square #143
P.O. Box 9171
Cambridge, MA 02139

In addition to joining the League, here are some suggestions from the League for other things you can do to protect your freedom to write programs:

  • Tell your friends and colleagues about this issue and how it threatens to ruin the computer industry.
  • Mention that you are a League member in your `.signature', and mention the League's email address for inquiries.
  • Ask the companies you consider working for or working with to make statements against software monopolies, and give preference to those that do.
  • When employers ask you to sign contracts giving them copyright on your work, insist on a clause saying they will not claim the copyright covers imitating the interface.
  • When employers ask you to sign contracts giving them patent rights, insist on clauses saying they can use these rights only defensively. Don't rely on "company policy," since that can change at any time; don't rely on an individual executive's private word, since that person may be replaced. Get a commitment just as binding as the commitment they get from you.
  • Write to Congress to explain the importance of these issues.
    House Subcommittee on Intellectual Property
2137 Rayburn Bldg
Washington, DC 20515

Senate Subcommittee on Patents, Trademarks and Copyrights
United States Senate
Washington, DC 20510
    (These committees have received lots of mail already; let's give them even more.)

Democracy means nothing if you don't use it. Stand up and be counted!


Using and Porting GNU CC - Copying

GNU GENERAL PUBLIC LICENSE

Version 2, June 1991

Copyright (C) 1989, 1991 Free Software Foundation, Inc.
59 Temple Place - Suite 330, Boston, MA 02111-1307, USA

Everyone is permitted to copy and distribute verbatim copies
of this license document, but changing it is not allowed.

Preamble

The licenses for most software are designed to take away your freedom to share and change it. By contrast, the GNU General Public License is intended to guarantee your freedom to share and change free software--to make sure the software is free for all its users. This General Public License applies to most of the Free Software Foundation's software and to any other program whose authors commit to using it. (Some other Free Software Foundation software is covered by the GNU Library General Public License instead.) You can apply it to your programs, too.

When we speak of free software, we are referring to freedom, not price. Our General Public Licenses are designed to make sure that you have the freedom to distribute copies of free software (and charge for this service if you wish), that you receive source code or can get it if you want it, that you can change the software or use pieces of it in new free programs; and that you know you can do these things.

To protect your rights, we need to make restrictions that forbid anyone to deny you these rights or to ask you to surrender the rights. These restrictions translate to certain responsibilities for you if you distribute copies of the software, or if you modify it.

For example, if you distribute copies of such a program, whether gratis or for a fee, you must give the recipients all the rights that you have. You must make sure that they, too, receive or can get the source code. And you must show them these terms so they know their rights.

We protect your rights with two steps: (1) copyright the software, and (2) offer you this license which gives you legal permission to copy, distribute and/or modify the software.

Also, for each author's protection and ours, we want to make certain that everyone understands that there is no warranty for this free software. If the software is modified by someone else and passed on, we want its recipients to know that what they have is not the original, so that any problems introduced by others will not reflect on the original authors' reputations.

Finally, any free program is threatened constantly by software patents. We wish to avoid the danger that redistributors of a free program will individually obtain patent licenses, in effect making the program proprietary. To prevent this, we have made it clear that any patent must be licensed for everyone's free use or not licensed at all.

The precise terms and conditions for copying, distribution and modification follow.

TERMS AND CONDITIONS FOR COPYING, DISTRIBUTION AND MODIFICATION

  1. This License applies to any program or other work which contains a notice placed by the copyright holder saying it may be distributed under the terms of this General Public License. The "Program", below, refers to any such program or work, and a "work based on the Program" means either the Program or any derivative work under copyright law: that is to say, a work containing the Program or a portion of it, either verbatim or with modifications and/or translated into another language. (Hereinafter, translation is included without limitation in the term "modification".) Each licensee is addressed as "you". Activities other than copying, distribution and modification are not covered by this License; they are outside its scope. The act of running the Program is not restricted, and the output from the Program is covered only if its contents constitute a work based on the Program (independent of having been made by running the Program). Whether that is true depends on what the Program does.
  2. You may copy and distribute verbatim copies of the Program's source code as you receive it, in any medium, provided that you conspicuously and appropriately publish on each copy an appropriate copyright notice and disclaimer of warranty; keep intact all the notices that refer to this License and to the absence of any warranty; and give any other recipients of the Program a copy of this License along with the Program. You may charge a fee for the physical act of transferring a copy, and you may at your option offer warranty protection in exchange for a fee.
  3. You may modify your copy or copies of the Program or any portion of it, thus forming a work based on the Program, and copy and distribute such modifications or work under the terms of Section 1 above, provided that you also meet all of these conditions:
    1. You must cause the modified files to carry prominent notices stating that you changed the files and the date of any change.
    2. You must cause any work that you distribute or publish, that in whole or in part contains or is derived from the Program or any part thereof, to be licensed as a whole at no charge to all third parties under the terms of this License.
    3. If the modified program normally reads commands interactively when run, you must cause it, when started running for such interactive use in the most ordinary way, to print or display an announcement including an appropriate copyright notice and a notice that there is no warranty (or else, saying that you provide a warranty) and that users may redistribute the program under these conditions, and telling the user how to view a copy of this License. (Exception: if the Program itself is interactive but does not normally print such an announcement, your work based on the Program is not required to print an announcement.)
    These requirements apply to the modified work as a whole. If identifiable sections of that work are not derived from the Program, and can be reasonably considered independent and separate works in themselves, then this License, and its terms, do not apply to those sections when you distribute them as separate works. But when you distribute the same sections as part of a whole which is a work based on the Program, the distribution of the whole must be on the terms of this License, whose permissions for other licensees extend to the entire whole, and thus to each and every part regardless of who wrote it. Thus, it is not the intent of this section to claim rights or contest your rights to work written entirely by you; rather, the intent is to exercise the right to control the distribution of derivative or collective works based on the Program. In addition, mere aggregation of another work not based on the Program with the Program (or with a work based on the Program) on a volume of a storage or distribution medium does not bring the other work under the scope of this License.
  4. You may copy and distribute the Program (or a work based on it, under Section 2) in object code or executable form under the terms of Sections 1 and 2 above provided that you also do one of the following:
    1. Accompany it with the complete corresponding machine-readable source code, which must be distributed under the terms of Sections 1 and 2 above on a medium customarily used for software interchange; or,
    2. Accompany it with a written offer, valid for at least three years, to give any third party, for a charge no more than your cost of physically performing source distribution, a complete machine-readable copy of the corresponding source code, to be distributed under the terms of Sections 1 and 2 above on a medium customarily used for software interchange; or,
    3. Accompany it with the information you received as to the offer to distribute corresponding source code. (This alternative is allowed only for noncommercial distribution and only if you received the program in object code or executable form with such an offer, in accord with Subsection b above.)
    The source code for a work means the preferred form of the work for making modifications to it. For an executable work, complete source code means all the source code for all modules it contains, plus any associated interface definition files, plus the scripts used to control compilation and installation of the executable. However, as a special exception, the source code distributed need not include anything that is normally distributed (in either source or binary form) with the major components (compiler, kernel, and so on) of the operating system on which the executable runs, unless that component itself accompanies the executable. If distribution of executable or object code is made by offering access to copy from a designated place, then offering equivalent access to copy the source code from the same place counts as distribution of the source code, even though third parties are not compelled to copy the source along with the object code.
  5. You may not copy, modify, sublicense, or distribute the Program except as expressly provided under this License. Any attempt otherwise to copy, modify, sublicense or distribute the Program is void, and will automatically terminate your rights under this License. However, parties who have received copies, or rights, from you under this License will not have their licenses terminated so long as such parties remain in full compliance.
  6. You are not required to accept this License, since you have not signed it. However, nothing else grants you permission to modify or distribute the Program or its derivative works. These actions are prohibited by law if you do not accept this License. Therefore, by modifying or distributing the Program (or any work based on the Program), you indicate your acceptance of this License to do so, and all its terms and conditions for copying, distributing or modifying the Program or works based on it.
  7. Each time you redistribute the Program (or any work based on the Program), the recipient automatically receives a license from the original licensor to copy, distribute or modify the Program subject to these terms and conditions. You may not impose any further restrictions on the recipients' exercise of the rights granted herein. You are not responsible for enforcing compliance by third parties to this License.
  8. If, as a consequence of a court judgment or allegation of patent infringement or for any other reason (not limited to patent issues), conditions are imposed on you (whether by court order, agreement or otherwise) that contradict the conditions of this License, they do not excuse you from the conditions of this License. If you cannot distribute so as to satisfy simultaneously your obligations under this License and any other pertinent obligations, then as a consequence you may not distribute the Program at all. For example, if a patent license would not permit royalty-free redistribution of the Program by all those who receive copies directly or indirectly through you, then the only way you could satisfy both it and this License would be to refrain entirely from distribution of the Program. If any portion of this section is held invalid or unenforceable under any particular circumstance, the balance of the section is intended to apply and the section as a whole is intended to apply in other circumstances. It is not the purpose of this section to induce you to infringe any patents or other property right claims or to contest validity of any such claims; this section has the sole purpose of protecting the integrity of the free software distribution system, which is implemented by public license practices. Many people have made generous contributions to the wide range of software distributed through that system in reliance on consistent application of that system; it is up to the author/donor to decide if he or she is willing to distribute software through any other system and a licensee cannot impose that choice. This section is intended to make thoroughly clear what is believed to be a consequence of the rest of this License.
  9. If the distribution and/or use of the Program is restricted in certain countries either by patents or by copyrighted interfaces, the original copyright holder who places the Program under this License may add an explicit geographical distribution limitation excluding those countries, so that distribution is permitted only in or among countries not thus excluded. In such case, this License incorporates the limitation as if written in the body of this License.
  10. The Free Software Foundation may publish revised and/or new versions of the General Public License from time to time. Such new versions will be similar in spirit to the present version, but may differ in detail to address new problems or concerns. Each version is given a distinguishing version number. If the Program specifies a version number of this License which applies to it and "any later version", you have the option of following the terms and conditions either of that version or of any later version published by the Free Software Foundation. If the Program does not specify a version number of this License, you may choose any version ever published by the Free Software Foundation.
  11. If you wish to incorporate parts of the Program into other free programs whose distribution conditions are different, write to the author to ask for permission. For software which is copyrighted by the Free Software Foundation, write to the Free Software Foundation; we sometimes make exceptions for this. Our decision will be guided by the two goals of preserving the free status of all derivatives of our free software and of promoting the sharing and reuse of software generally.

    NO WARRANTY

  12. BECAUSE THE PROGRAM IS LICENSED FREE OF CHARGE, THERE IS NO WARRANTY FOR THE PROGRAM, TO THE EXTENT PERMITTED BY APPLICABLE LAW. EXCEPT WHEN OTHERWISE STATED IN WRITING THE COPYRIGHT HOLDERS AND/OR OTHER PARTIES PROVIDE THE PROGRAM "AS IS" WITHOUT WARRANTY OF ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. THE ENTIRE RISK AS TO THE QUALITY AND PERFORMANCE OF THE PROGRAM IS WITH YOU. SHOULD THE PROGRAM PROVE DEFECTIVE, YOU ASSUME THE COST OF ALL NECESSARY SERVICING, REPAIR OR CORRECTION.
  13. IN NO EVENT UNLESS REQUIRED BY APPLICABLE LAW OR AGREED TO IN WRITING WILL ANY COPYRIGHT HOLDER, OR ANY OTHER PARTY WHO MAY MODIFY AND/OR REDISTRIBUTE THE PROGRAM AS PERMITTED ABOVE, BE LIABLE TO YOU FOR DAMAGES, INCLUDING ANY GENERAL, SPECIAL, INCIDENTAL OR CONSEQUENTIAL DAMAGES ARISING OUT OF THE USE OR INABILITY TO USE THE PROGRAM (INCLUDING BUT NOT LIMITED TO LOSS OF DATA OR DATA BEING RENDERED INACCURATE OR LOSSES SUSTAINED BY YOU OR THIRD PARTIES OR A FAILURE OF THE PROGRAM TO OPERATE WITH ANY OTHER PROGRAMS), EVEN IF SUCH HOLDER OR OTHER PARTY HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES.

END OF TERMS AND CONDITIONS

How to Apply These Terms to Your New Programs

If you develop a new program, and you want it to be of the greatest possible use to the public, the best way to achieve this is to make it free software which everyone can redistribute and change under these terms.

To do so, attach the following notices to the program. It is safest to attach them to the start of each source file to most effectively convey the exclusion of warranty; and each file should have at least the "copyright" line and a pointer to where the full notice is found.

one line to give the program's name and a brief idea of what it does.
Copyright (C) 19yy  name of author

This program is free software; you can redistribute it and/or modify
it under the terms of the GNU General Public License as published by
the Free Software Foundation; either version 2 of the License, or
(at your option) any later version.

This program is distributed in the hope that it will be useful,
but WITHOUT ANY WARRANTY; without even the implied warranty of
MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
GNU General Public License for more details.

You should have received a copy of the GNU General Public License
along with this program; if not, write to the Free Software
Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.

Also add information on how to contact you by electronic and paper mail.

If the program is interactive, make it output a short notice like this when it starts in an interactive mode:

Gnomovision version 69, Copyright (C) 19yy name of author
Gnomovision comes with ABSOLUTELY NO WARRANTY; for details
type `show w'.
This is free software, and you are welcome to redistribute it
under certain conditions; type `show c' for details.

The hypothetical commands `show w' and `show c' should show the appropriate parts of the General Public License. Of course, the commands you use may be called something other than `show w' and `show c'; they could even be mouse-clicks or menu items--whatever suits your program.

You should also get your employer (if you work as a programmer) or your school, if any, to sign a "copyright disclaimer" for the program, if necessary. Here is a sample; alter the names:

Yoyodyne, Inc., hereby disclaims all copyright interest in the program
`Gnomovision' (which makes passes at compilers) written by James Hacker.

signature of Ty Coon, 1 April 1989
Ty Coon, President of Vice

This General Public License does not permit incorporating your program into proprietary programs. If your program is a subroutine library, you may consider it more useful to permit linking proprietary applications with the library. If this is what you want to do, use the GNU Library General Public License instead of this License.


Using and Porting GNU CC - Contributors

Contributors to GNU CC

In addition to Richard Stallman, several people have written parts of GNU CC.

  • The idea of using RTL and some of the optimization ideas came from the program PO written at the University of Arizona by Jack Davidson and Christopher Fraser. See "Register Allocation and Exhaustive Peephole Optimization", Software Practice and Experience 14 (9), Sept. 1984, 857-866.
  • Paul Rubin wrote most of the preprocessor.
  • Leonard Tower wrote parts of the parser, RTL generator, and RTL definitions, and of the Vax machine description.
  • Ted Lemon wrote parts of the RTL reader and printer.
  • Jim Wilson implemented loop strength reduction and some other loop optimizations.
  • Nobuyuki Hikichi of Software Research Associates, Tokyo, contributed the support for the Sony NEWS machine.
  • Charles LaBrec contributed the support for the Integrated Solutions 68020 system.
  • Michael Tiemann of Cygnus Support wrote the front end for C++, as well as the support for inline functions and instruction scheduling. Also the descriptions of the National Semiconductor 32000 series cpu, the SPARC cpu and part of the Motorola 88000 cpu.
  • Gerald Baumgartner added the signature extension to the C++ front-end.
  • Jan Stein of the Chalmers Computer Society provided support for Genix, as well as part of the 32000 machine description.
  • Randy Smith finished the Sun FPA support.
  • Robert Brown implemented the support for Encore 32000 systems.
  • David Kashtan of SRI adapted GNU CC to VMS.
  • Alex Crain provided changes for the 3b1.
  • Greg Satz and Chris Hanson assisted in making GNU CC work on HP-UX for the 9000 series 300.
  • William Schelter did most of the work on the Intel 80386 support.
  • Christopher Smith did the port for Convex machines.
  • Paul Petersen wrote the machine description for the Alliant FX/8.
  • Dario Dariol contributed the four varieties of sample programs that print a copy of their source.
  • Alain Lichnewsky ported GNU CC to the Mips cpu.
  • Devon Bowen, Dale Wiles and Kevin Zachmann ported GNU CC to the Tahoe.
  • Jonathan Stone wrote the machine description for the Pyramid computer.
  • Gary Miller ported GNU CC to Charles River Data Systems machines.
  • Richard Kenner of the New York University Ultracomputer Research Laboratory wrote the machine descriptions for the AMD 29000, the DEC Alpha, the IBM RT PC, and the IBM RS/6000 as well as the support for instruction attributes. He also made changes to better support RISC processors including changes to common subexpression elimination, strength reduction, function calling sequence handling, and condition code support, in addition to generalizing the code for frame pointer elimination.
  • Richard Kenner and Michael Tiemann jointly developed reorg.c, the delay slot scheduler.
  • Mike Meissner and Tom Wood of Data General finished the port to the Motorola 88000.
  • Masanobu Yuhara of Fujitsu Laboratories implemented the machine description for the Tron architecture (specifically, the Gmicro).
  • NeXT, Inc. donated the front end that supports the Objective C language.
  • James van Artsdalen wrote the code that makes efficient use of the Intel 80387 register stack.
  • Mike Meissner at the Open Software Foundation finished the port to the MIPS cpu, including adding ECOFF debug support, and worked on the Intel port for the Intel 80386 cpu. Later at Cygnus Support, he worked on the rs6000 and PowerPC ports.
  • Ron Guilmette implemented the protoize and unprotoize tools, the support for Dwarf symbolic debugging information, and much of the support for System V Release 4. He has also worked heavily on the Intel 386 and 860 support.
  • Torbjorn Granlund implemented multiply- and divide-by-constant optimization, improved long long support, and improved leaf function register allocation.
  • Mike Stump implemented the support for Elxsi 64 bit CPU.
  • John Wehle added the machine description for the Western Electric 32000 processor used in several 3b series machines (no relation to the National Semiconductor 32000 processor).
  • Holger Teutsch provided the support for the Clipper cpu.
  • Kresten Krab Thorup wrote the run time support for the Objective C language.
  • Stephen Moshier contributed the floating point emulator that assists in cross-compilation and permits support for floating point numbers wider than 64 bits.
  • David Edelsohn contributed the changes to RS/6000 port to make it support the PowerPC and POWER2 architectures.
  • Steve Chamberlain wrote the support for the Hitachi SH processor.
  • Peter Schauer wrote the code to allow debugging to work on the Alpha.
  • Oliver M. Kellogg of Deutsche Aerospace contributed the port to the MIL-STD-1750A.
  • Michael K. Gschwind contributed the port to the PDP-11.
  • David Reese of Sun Microsystems contributed to the Solaris on PowerPC port.


Using and Porting GNU CC - Index

Index

Jump to: ! - # - $ - % - & - ' - ( - * - + - - - . - / - 0 - < - = - > - ? - \ - _ - a - b - c - d - e - f - g - h - i - j - k - l - m - n - o - p - q - r - s - t - u - v - w - x - z

!

  • `!' in constraint

    • #

  • `#' in constraint
  • # in template
  • #pragma
  • #pragma implementation, implied
  • #pragma, reason for not using

    • $

  • $

    • %

  • `%' in constraint
  • `%' in template

    • &

  • `&' in constraint

    • '

  • '

    • (

  • (nil)

    • *

  • `*' in constraint
  • * in template

    • +

  • `+' in constraint

    • -

  • -lgcc, use with -nodefaultlibs
  • -lgcc, use with -nostdlib
  • -nodefaultlibs and unresolved references
  • -nostdlib and unresolved references

    • .

  • .sdata/.sdata2 references (PowerPC)

    • /

  • //
  • `/i' in RTL dump
  • `/s' in RTL dump, `/s' in RTL dump
  • `/u' in RTL dump
  • `/v' in RTL dump

    • 0

  • `0' in constraint

    • <

  • `<' in constraint
  • <?

    • =

  • `=' in constraint

    • >

  • `>' in constraint
  • >?

    • ?

  • `?' in constraint
  • ?: extensions, ?: extensions
  • ?: side effect

    • \

  • \

    • _

  • `_' in variables in macros
  • __bb
  • __bb_init_func
  • __bb_init_trace_func, __bb_init_trace_func, __bb_init_trace_func
  • __bb_trace_func, __bb_trace_func, __bb_trace_func
  • __bb_trace_ret, __bb_trace_ret, __bb_trace_ret
  • __builtin_apply
  • __builtin_apply_args
  • __builtin_args_info
  • __builtin_classify_type
  • __builtin_next_arg
  • __builtin_return
  • __builtin_saveregs
  • __CTOR_LIST__
  • __DTOR_LIST__
  • __main

    • a

  • abort, abort
  • abs, abs
  • abs and attributes
  • absm2 instruction pattern
  • absolute value
  • access to operands
  • accessors
  • ACCUMULATE_OUTGOING_ARGS
  • ACCUMULATE_OUTGOING_ARGS and stack frames
  • ADDITIONAL_REGISTER_NAMES
  • addm3 instruction pattern
  • addr_diff_vec
  • addr_diff_vec, length of
  • addr_vec
  • addr_vec, length of
  • address
  • address constraints
  • address of a label
  • ADDRESS_COST
  • address_operand
  • addressing modes
  • ADJUST_COST
  • ADJUST_FIELD_ALIGN
  • ADJUST_INSN_LENGTH
  • ADJUST_PRIORITY
  • aggregates as return values
  • alias attribute
  • aliasing of parameters
  • aligned attribute, aligned attribute
  • alignment
  • ALL_REGS
  • Alliant
  • alloca
  • alloca and SunOS
  • alloca vs variable-length arrays
  • alloca, for SunOS
  • alloca, for Unos
  • allocate_stack instruction pattern
  • ALLOCATE_TRAMPOLINE
  • alternate keywords
  • AMD29K options
  • analysis, data flow
  • and
  • and and attributes
  • and, canonicalization of
  • andm3 instruction pattern
  • ANSI support
  • apostrophes
  • APPLY_RESULT_SIZE
  • ARG_POINTER_REGNUM
  • ARG_POINTER_REGNUM and virtual registers
  • arg_pointer_rtx
  • ARGS_GROW_DOWNWARD
  • argument passing
  • arguments in frame (88k)
  • arguments in registers
  • arguments on stack
  • arithmetic libraries
  • arithmetic shift
  • arithmetic simplifications
  • arithmetic, in RTL
  • ARM options
  • arrays of length zero
  • arrays of variable length
  • arrays, non-lvalue
  • ashift
  • ashift and attributes
  • ashiftrt
  • ashiftrt and attributes
  • ashlm3 instruction pattern
  • ashrm3 instruction pattern
  • asm expressions
  • ASM_APP_OFF
  • ASM_APP_ON
  • ASM_BYTE_OP
  • ASM_CLOSE_PAREN
  • ASM_COMMENT_START
  • ASM_DECLARE_FUNCTION_NAME
  • ASM_DECLARE_FUNCTION_SIZE
  • ASM_DECLARE_OBJECT_NAME
  • ASM_FILE_END
  • ASM_FILE_START
  • ASM_FINAL_SPEC
  • ASM_FINISH_DECLARE_OBJECT
  • ASM_FORMAT_PRIVATE_NAME
  • asm_fprintf
  • ASM_GENERATE_INTERNAL_LABEL
  • ASM_GLOBALIZE_LABEL
  • ASM_IDENTIFY_GCC
  • asm_input
  • ASM_NO_SKIP_IN_TEXT
  • asm_noperands
  • ASM_OPEN_PAREN
  • asm_operands, RTL sharing
  • asm_operands, usage
  • ASM_OUTPUT_ADDR_DIFF_ELT
  • ASM_OUTPUT_ADDR_VEC_ELT
  • ASM_OUTPUT_ALIGN
  • ASM_OUTPUT_ALIGN_CODE
  • ASM_OUTPUT_ALIGNED_BSS
  • ASM_OUTPUT_ALIGNED_COMMON
  • ASM_OUTPUT_ALIGNED_LOCAL
  • ASM_OUTPUT_ASCII
  • ASM_OUTPUT_BSS
  • ASM_OUTPUT_BYTE
  • ASM_OUTPUT_CASE_END
  • ASM_OUTPUT_CASE_LABEL
  • ASM_OUTPUT_CHAR
  • ASM_OUTPUT_COMMON
  • ASM_OUTPUT_CONSTRUCTOR
  • ASM_OUTPUT_DEF
  • ASM_OUTPUT_DESTRUCTOR
  • ASM_OUTPUT_DOUBLE
  • ASM_OUTPUT_DOUBLE_INT
  • ASM_OUTPUT_EH_REGION_BEG
  • ASM_OUTPUT_EH_REGION_END
  • ASM_OUTPUT_EXTERNAL
  • ASM_OUTPUT_EXTERNAL_LIBCALL
  • ASM_OUTPUT_FLOAT
  • ASM_OUTPUT_IDENT
  • ASM_OUTPUT_INT
  • ASM_OUTPUT_INTERNAL_LABEL
  • ASM_OUTPUT_LABEL
  • ASM_OUTPUT_LABELREF
  • ASM_OUTPUT_LOCAL
  • ASM_OUTPUT_LONG_DOUBLE
  • ASM_OUTPUT_LOOP_ALIGN
  • ASM_OUTPUT_MI_THUNK
  • ASM_OUTPUT_OPCODE
  • ASM_OUTPUT_POOL_EPILOGUE
  • ASM_OUTPUT_POOL_PROLOGUE
  • ASM_OUTPUT_QUADRUPLE_INT
  • ASM_OUTPUT_REG_POP
  • ASM_OUTPUT_REG_PUSH
  • ASM_OUTPUT_SECTION_NAME
  • ASM_OUTPUT_SHARED_BSS
  • ASM_OUTPUT_SHARED_COMMON
  • ASM_OUTPUT_SHARED_LOCAL
  • ASM_OUTPUT_SHORT
  • ASM_OUTPUT_SKIP
  • ASM_OUTPUT_SOURCE_FILENAME
  • ASM_OUTPUT_SOURCE_LINE
  • ASM_OUTPUT_SPECIAL_POOL_ENTRY
  • ASM_OUTPUT_WEAK_ALIAS
  • ASM_SPEC
  • ASM_STABD_OP
  • ASM_STABN_OP
  • ASM_STABS_OP
  • ASM_WEAKEN_LABEL
  • assemble_name
  • assembler format
  • assembler instructions
  • assembler instructions in RTL
  • assembler names for identifiers
  • assembler syntax, 88k
  • ASSEMBLER_DIALECT
  • assembly code, invalid
  • assigning attribute values to insns
  • asterisk in template
  • atof
  • attr
  • attr_flag
  • attribute expressions
  • attribute of types
  • attribute of variables
  • attribute specifications
  • attribute specifications example
  • attributes, defining
  • autoincrement addressing, availability
  • autoincrement/decrement addressing
  • autoincrement/decrement analysis
  • automatic inline for C++ member fns

    • b

  • backslash
  • backtrace for bug reports
  • barrier
  • BASE_REG_CLASS
  • basic blocks
  • bcmp
  • bcond instruction pattern
  • bcopy, implicit usage
  • BIGGEST_ALIGNMENT
  • BIGGEST_FIELD_ALIGNMENT
  • Bison parser generator
  • bit fields
  • bit shift overflow (88k)
  • BITFIELD_NBYTES_LIMITED
  • BITS_BIG_ENDIAN
  • BITS_BIG_ENDIAN, effect on sign_extract
  • BITS_PER_UNIT
  • BITS_PER_WORD
  • bitwise complement
  • bitwise exclusive-or
  • bitwise inclusive-or
  • bitwise logical-and
  • BLKmode
  • BLKmode, and function return values
  • BLOCK_PROFILER
  • BLOCK_PROFILER_CODE
  • BRANCH_COST
  • break_out_memory_refs
  • BSS_SECTION_ASM_OP
  • bug criteria
  • bug report mailing lists
  • bugs
  • bugs, known
  • builtin functions
  • byte writes (29k)
  • byte_mode
  • BYTES_BIG_ENDIAN
  • bzero
  • bzero, implicit usage

    • c

  • C compilation options
  • C intermediate output, nonexistent
  • C language extensions
  • C language, traditional
  • C statements for assembler output
  • C++
  • c++
  • C++ comments
  • C++ compilation options
  • C++ interface and implementation headers
  • C++ language extensions
  • C++ member fns, automatically inline
  • C++ misunderstandings
  • C++ named return value
  • C++ options, command line
  • C++ pragmas, effect on inlining
  • C++ signatures
  • C++ source file suffixes
  • C++ static data, declaring and defining
  • C++ subtype polymorphism
  • C++ type abstraction
  • C_INCLUDE_PATH
  • call
  • call instruction pattern
  • call usage
  • call-clobbered register
  • call-saved register
  • call-used register
  • call_insn
  • call_insn and `/u'
  • CALL_INSN_FUNCTION_USAGE
  • call_pop instruction pattern
  • CALL_USED_REGISTERS
  • call_used_regs
  • call_value instruction pattern
  • call_value_pop instruction pattern
  • CALLER_SAVE_PROFITABLE
  • calling conventions
  • calling functions in RTL
  • calling functions through the function vector on the H8/300 processors
  • CAN_DEBUG_WITHOUT_FP
  • CAN_ELIMINATE
  • canonicalization of instructions
  • CANONICALIZE_COMPARISON
  • canonicalize_funcptr_for_compare instruction pattern
  • case labels in initializers
  • case ranges
  • case sensitivity and VMS
  • CASE_DROPS_THROUGH
  • CASE_VALUES_THRESHOLD
  • CASE_VECTOR_MODE
  • CASE_VECTOR_PC_RELATIVE
  • casesi instruction pattern
  • cast to a union
  • casts as lvalues
  • CC
  • cc0
  • cc0, RTL sharing
  • cc0_rtx
  • CC1_SPEC
  • CC1PLUS_SPEC
  • cc_status
  • CC_STATUS_MDEP
  • CC_STATUS_MDEP_INIT
  • CCmode
  • CDImode
  • change_address
  • CHAR_TYPE_SIZE
  • CHECK_FLOAT_VALUE
  • check_stack instruction pattern
  • CHImode
  • class definitions, register
  • class preference constraints
  • CLASS_LIKELY_SPILLED_P
  • CLASS_MAX_NREGS
  • classes of RTX codes
  • CLEAR_INSN_CACHE
  • CLIB
  • clobber
  • clrstrm instruction pattern
  • cmpm instruction pattern
  • cmpstrm instruction pattern
  • code generation conventions
  • code generation RTL sequences
  • code motion
  • code_label
  • code_label and `/i'
  • CODE_LABEL_NUMBER
  • codes, RTL expression
  • COImode
  • COLLECT_EXPORT_LIST
  • combiner pass
  • command options
  • comments, C++ style
  • common subexpression elimination
  • COMP_TYPE_ATTRIBUTES
  • compare
  • compare, canonicalization of
  • comparison of signed and unsigned values, warning
  • compilation in a separate directory
  • compiler bugs, reporting
  • compiler compared to C++ preprocessor
  • compiler options, C++
  • compiler passes and files
  • compiler version, specifying
  • COMPILER_PATH
  • complement, bitwise
  • complex numbers
  • compound expressions as lvalues
  • computed gotos
  • computing the length of an insn
  • cond
  • cond and attributes
  • condition code register
  • condition code status
  • condition codes
  • conditional expressions as lvalues
  • conditional expressions, extensions
  • CONDITIONAL_REGISTER_USAGE
  • conditions, in patterns
  • configuration file
  • configurations supported by GNU CC
  • conflicting types
  • const applied to function
  • const function attribute
  • const0_rtx
  • CONST0_RTX
  • const1_rtx
  • CONST1_RTX
  • CONST2_RTX
  • const2_rtx
  • CONST_CALL_P
  • CONST_COSTS
  • const_double
  • const_double, RTL sharing
  • CONST_DOUBLE_CHAIN
  • CONST_DOUBLE_LOW
  • CONST_DOUBLE_MEM
  • CONST_DOUBLE_OK_FOR_LETTER_P
  • const_int
  • const_int and attribute tests
  • const_int and attributes
  • const_int, RTL sharing
  • CONST_OK_FOR_LETTER_P
  • const_string
  • const_string and attributes
  • const_true_rtx
  • constant attributes
  • constant folding
  • constant folding and floating point
  • constant propagation
  • CONSTANT_ADDRESS_P
  • CONSTANT_AFTER_FUNCTION_P
  • CONSTANT_ALIGNMENT
  • CONSTANT_P
  • CONSTANT_POOL_ADDRESS_P
  • CONSTANT_POOL_BEFORE_FUNCTION
  • constants in constraints
  • constm1_rtx
  • constraint modifier characters
  • constraint, matching
  • constraints
  • constraints, machine specific
  • constructing calls
  • constructor expressions
  • constructor function attribute
  • constructors vs goto
  • constructors, automatic calls
  • constructors, output of
  • contributors
  • controlling register usage
  • controlling the compilation driver
  • conventions, run-time
  • conversions
  • Convex options
  • copy_rtx_if_shared
  • core dump
  • cos
  • costs of instructions
  • COSTS_N_INSNS
  • CPLUS_INCLUDE_PATH
  • CPP_PREDEFINES
  • CPP_SPEC
  • CQImode
  • cross compilation and floating point
  • cross compiling
  • cross-compiler, installation
  • cross-jumping
  • CROSS_LIBGCC1
  • CRTSTUFF_T_CFLAGS
  • CRTSTUFF_T_CFLAGS_S
  • CSImode
  • CTImode
  • CUMULATIVE_ARGS
  • current_function_epilogue_delay_list
  • current_function_outgoing_args_size
  • current_function_pops_args
  • current_function_pretend_args_size

    • d

  • `d' in constraint
  • data flow analysis
  • DATA_ALIGNMENT
  • data_section
  • DATA_SECTION_ASM_OP
  • DBR_OUTPUT_SEQEND
  • dbr_sequence_length
  • DBX
  • DBX_BLOCKS_FUNCTION_RELATIVE
  • DBX_CONTIN_CHAR
  • DBX_CONTIN_LENGTH
  • DBX_DEBUGGING_INFO
  • DBX_FUNCTION_FIRST
  • DBX_LBRAC_FIRST
  • DBX_MEMPARM_STABS_LETTER
  • DBX_NO_XREFS
  • DBX_OUTPUT_ENUM
  • DBX_OUTPUT_FUNCTION_END
  • DBX_OUTPUT_LBRAC
  • DBX_OUTPUT_MAIN_SOURCE_DIRECTORY
  • DBX_OUTPUT_MAIN_SOURCE_FILE_END
  • DBX_OUTPUT_MAIN_SOURCE_FILENAME
  • DBX_OUTPUT_RBRAC
  • DBX_OUTPUT_SOURCE_FILENAME
  • DBX_OUTPUT_STANDARD_TYPES
  • DBX_REGISTER_NUMBER
  • DBX_REGPARM_STABS_CODE
  • DBX_REGPARM_STABS_LETTER
  • DBX_STATIC_CONST_VAR_CODE
  • DBX_STATIC_STAB_DATA_SECTION
  • DBX_TYPE_DECL_STABS_CODE
  • DBX_USE_BINCL
  • DBX_WORKING_DIRECTORY
  • DCmode
  • De Morgan's law
  • dead code
  • dead_or_set_p
  • deallocating variable length arrays
  • death notes
  • debug_rtx
  • DEBUG_SYMS_TEXT
  • DEBUGGER_ARG_OFFSET
  • DEBUGGER_AUTO_OFFSET
  • debugging information generation
  • debugging information options
  • debugging, 88k OCS
  • declaration scope
  • declarations inside expressions
  • declarations, RTL
  • declaring attributes of functions
  • declaring static data in C++
  • default implementation, signature member function
  • DEFAULT_CALLER_SAVES
  • DEFAULT_GDB_EXTENSIONS
  • DEFAULT_MAIN_RETURN
  • DEFAULT_PCC_STRUCT_RETURN
  • DEFAULT_SHORT_ENUMS
  • DEFAULT_SIGNED_CHAR
  • define_asm_attributes
  • define_attr
  • define_delay
  • define_expand
  • define_function_unit
  • define_insn
  • define_insn example
  • define_peephole
  • define_split
  • defining attributes and their values
  • defining jump instruction patterns
  • defining peephole optimizers
  • defining RTL sequences for code generation
  • defining static data in C++
  • delay slots, defining
  • DELAY_SLOTS_FOR_EPILOGUE
  • delayed branch scheduling
  • dependencies for make as output
  • dependencies, make
  • DEPENDENCIES_OUTPUT
  • Dependent Patterns
  • destructor function attribute
  • destructors vs goto
  • destructors, output of
  • detecting `-traditional'
  • DFmode
  • dialect options
  • digits in constraint
  • DImode
  • DIR_SEPARATOR
  • directory options
  • disabling certain registers
  • dispatch table
  • div
  • div and attributes
  • DIVDI3_LIBCALL
  • divide instruction, 88k
  • division, division, division
  • divm3 instruction pattern
  • divmodm4 instruction pattern
  • DIVSI3_LIBCALL
  • DOESNT_NEED_UNWINDER
  • dollar signs in identifier names
  • DOLLARS_IN_IDENTIFIERS
  • DONE
  • DONT_RECORD_EQUIVALENCE
  • DONT_REDUCE_ADDR
  • double-word arithmetic
  • DOUBLE_TYPE_SIZE
  • downward funargs
  • driver
  • DW bit (29k)
  • DWARF2_DEBUGGING_INFO
  • DWARF2_UNWIND_INFO
  • DWARF_DEBUGGING_INFO
  • DYNAMIC_CHAIN_ADDRESS

    • e

  • `E' in constraint
  • earlyclobber operand
  • EASY_DIV_EXPR
  • EDOM, implicit usage
  • EH_FRAME_SECTION_ASM_OP
  • EH_TABLE_LOOKUP
  • eight bit data on the H8/300 and H8/300H
  • ELIGIBLE_FOR_EPILOGUE_DELAY
  • ELIMINABLE_REGS
  • empty constraints
  • EMPTY_FIELD_BOUNDARY
  • ENCODE_SECTION_INFO
  • ENCODE_SECTION_INFO and address validation
  • ENCODE_SECTION_INFO usage
  • ENDFILE_SPEC
  • endianness
  • enum machine_mode
  • enum reg_class
  • environment variables
  • epilogue
  • EPILOGUE_USES
  • eq
  • eq and attributes
  • eq_attr
  • equal
  • errno, implicit usage
  • error messages
  • escape sequences, traditional
  • exception_receiver instruction pattern
  • EXCEPTION_SECTION
  • exclamation point
  • exclusive-or, bitwise
  • EXECUTABLE_SUFFIX
  • exit
  • exit status and VMS
  • EXIT_BODY
  • EXIT_IGNORE_STACK
  • EXPAND_BUILTIN_SAVEREGS
  • expander definitions
  • explicit register variables
  • expr_list
  • expression codes
  • expressions containing statements
  • expressions, compound, as lvalues
  • expressions, conditional, as lvalues
  • expressions, constructor
  • extended asm
  • extendmn2 instruction pattern
  • extensible constraints
  • extensions, ?:, extensions, ?:
  • extensions, C language
  • extensions, C++ language
  • extern int target_flags
  • external declaration scope
  • EXTRA_CC_MODES
  • EXTRA_CC_NAMES
  • EXTRA_CONSTRAINT
  • EXTRA_SECTION_FUNCTIONS
  • EXTRA_SECTIONS
  • EXTRA_SPECS
  • extv instruction pattern
  • extzv instruction pattern

    • f

  • `F' in constraint
  • fabs
  • FAIL
  • fatal signal
  • FATAL_EXIT_CODE
  • features, optional, in system conventions
  • ffs, ffs
  • ffsm2 instruction pattern
  • file name suffix
  • file names
  • files and passes of the compiler
  • final pass
  • FINAL_PRESCAN_INSN
  • FINAL_PRESCAN_LABEL
  • FINAL_REG_PARM_STACK_SPACE
  • final_scan_insn
  • final_sequence
  • FINALIZE_PIC
  • FIRST_INSN_ADDRESS
  • FIRST_PARM_OFFSET
  • FIRST_PARM_OFFSET and virtual registers
  • FIRST_PSEUDO_REGISTER
  • FIRST_STACK_REG
  • FIRST_VIRTUAL_REGISTER
  • fix, fix
  • fix_truncmn2 instruction pattern
  • fixed register
  • FIXED_REGISTERS
  • fixed_regs
  • fixmn2 instruction pattern
  • FIXUNS_TRUNC_LIKE_FIX_TRUNC
  • fixuns_truncmn2 instruction pattern
  • fixunsmn2 instruction pattern
  • flags in RTL expression
  • float
  • float as function value type
  • FLOAT_ARG_TYPE
  • float_extend
  • FLOAT_STORE_FLAG_VALUE
  • float_truncate
  • FLOAT_TYPE_SIZE
  • FLOAT_VALUE_TYPE
  • FLOAT_WORDS_BIG_ENDIAN
  • FLOATIFY
  • floating point and cross compilation
  • floating point precision, floating point precision
  • floatmn2 instruction pattern
  • floatunsmn2 instruction pattern
  • force_reg
  • format function attribute
  • format_arg function attribute
  • forwarding calls
  • frame layout
  • FRAME_GROWS_DOWNWARD
  • FRAME_GROWS_DOWNWARD and virtual registers
  • frame_pointer_needed
  • FRAME_POINTER_REGNUM
  • FRAME_POINTER_REGNUM and virtual registers
  • FRAME_POINTER_REQUIRED
  • frame_pointer_rtx
  • fscanf, and constant strings
  • ftruncm2 instruction pattern
  • function addressability on the M32R/D
  • function attributes
  • function call conventions
  • function entry and exit
  • function pointers, arithmetic
  • function prototype declarations
  • function units, for scheduling
  • function, size of pointer to
  • function-call insns
  • FUNCTION_ARG
  • FUNCTION_ARG_ADVANCE
  • FUNCTION_ARG_BOUNDARY
  • FUNCTION_ARG_CALLEE_COPIES
  • FUNCTION_ARG_PADDING
  • FUNCTION_ARG_PARTIAL_NREGS
  • FUNCTION_ARG_PASS_BY_REFERENCE
  • FUNCTION_ARG_REGNO_P
  • FUNCTION_BLOCK_PROFILER
  • FUNCTION_BLOCK_PROFILER_EXIT
  • FUNCTION_BOUNDARY
  • FUNCTION_CONVERSION_BUG
  • FUNCTION_EPILOGUE
  • FUNCTION_EPILOGUE and trampolines
  • FUNCTION_INCOMING_ARG
  • FUNCTION_MODE
  • FUNCTION_OUTGOING_VALUE
  • FUNCTION_PROFILER
  • FUNCTION_PROLOGUE
  • FUNCTION_PROLOGUE and trampolines
  • FUNCTION_VALUE
  • FUNCTION_VALUE_REGNO_P
  • functions called via pointer on the RS/6000 and PowerPC
  • functions in arbitrary sections
  • functions that are passed arguments in registers on the 386, functions that are passed arguments in registers on the 386
  • functions that do not pop the argument stack on the 386
  • functions that do pop the argument stack on the 386
  • functions that have no side effects
  • functions that never return
  • functions that pop the argument stack on the 386, functions that pop the argument stack on the 386
  • functions which are exported from a dll on PowerPC Windows NT
  • functions which are imported from a dll on PowerPC Windows NT
  • functions which specify exception handling on PowerPC Windows NT
  • functions with printf or scanf style arguments
  • functions, leaf

    • g

  • `G' in constraint
  • `g' in constraint
  • G++
  • g++
  • g++ 1.xx
  • g++ older version
  • g++, separate compiler
  • GCC
  • GCC_EXEC_PREFIX
  • ge
  • ge and attributes
  • GEN_ERRNO_RTX
  • gencodes
  • genconfig
  • general_operand
  • GENERAL_REGS
  • generalized lvalues
  • generating assembler output
  • generating insns
  • genflags
  • genflags, crash on Sun 4
  • get_attr
  • get_attr_length
  • GET_CLASS_NARROWEST_MODE
  • GET_CODE
  • get_frame_size
  • get_insns
  • get_last_insn
  • GET_MODE
  • GET_MODE_ALIGNMENT
  • GET_MODE_BITSIZE
  • GET_MODE_CLASS
  • GET_MODE_MASK
  • GET_MODE_NAME
  • GET_MODE_NUNITS
  • GET_MODE_SIZE
  • GET_MODE_UNIT_SIZE
  • GET_MODE_WIDER_MODE
  • GET_RTX_CLASS
  • GET_RTX_FORMAT
  • GET_RTX_LENGTH
  • geu
  • geu and attributes
  • GIV_SORT_CRITERION
  • global offset table
  • global register after longjmp
  • global register allocation
  • global register variables
  • GLOBALDEF
  • GLOBALREF
  • GLOBALVALUEDEF
  • GLOBALVALUEREF
  • GNU CC and portability
  • GNU CC command options
  • GO_IF_LEGITIMATE_ADDRESS
  • GO_IF_MODE_DEPENDENT_ADDRESS
  • goto in C++
  • goto with computed label
  • gp-relative references (MIPS)
  • gprof
  • greater than, greater than, greater than
  • grouping options
  • gt
  • gt and attributes
  • gtu
  • gtu and attributes

    • h

  • `H' in constraint
  • Haifa scheduler
  • HANDLE_PRAGMA
  • hard registers
  • HARD_FRAME_POINTER_REGNUM
  • HARD_REGNO_MODE_OK
  • HARD_REGNO_NREGS
  • hardware models and configurations, specifying
  • HAS_INIT_SECTION
  • HAVE_ATEXIT
  • HAVE_POPEN
  • HAVE_POST_DECREMENT
  • HAVE_POST_INCREMENT
  • HAVE_PRE_DECREMENT
  • HAVE_PRE_INCREMENT
  • HAVE_PUTENV
  • HAVE_VPRINTF
  • header files and VMS
  • high
  • HImode
  • HImode, in insn
  • host makefile fragment
  • HOST_BITS_PER_CHAR
  • HOST_BITS_PER_INT
  • HOST_BITS_PER_LONG
  • HOST_BITS_PER_SHORT
  • HOST_FLOAT_FORMAT
  • HOST_FLOAT_WORDS_BIG_ENDIAN
  • HOST_WORDS_BIG_ENDIAN
  • hosted environment, hosted environment
  • HPPA Options

    • i

  • `I' in constraint
  • `i' in constraint
  • i386 Options
  • IBM RS/6000 and PowerPC Options
  • IBM RT options
  • IBM RT PC
  • identifier names, dollar signs in
  • identifiers, names in assembler code
  • identifying source, compiler (88k)
  • IEEE_FLOAT_FORMAT
  • if_then_else
  • if_then_else and attributes
  • if_then_else usage
  • immediate_operand
  • IMMEDIATE_PREFIX
  • implicit argument: return value
  • IMPLICIT_FIX_EXPR
  • implied #pragma implementation
  • in_data
  • in_struct
  • in_struct, in code_label
  • in_struct, in insn, in_struct, in insn
  • in_struct, in label_ref
  • in_struct, in mem
  • in_struct, in reg
  • in_struct, in subreg
  • in_text
  • include files and VMS
  • INCLUDE_DEFAULTS
  • inclusive-or, bitwise
  • INCOMING_FRAME_SP_OFFSET
  • INCOMING_REGNO
  • INCOMING_RETURN_ADDR_RTX
  • incompatibilities of GNU CC
  • increment operators
  • INDEX_REG_CLASS
  • indirect_jump instruction pattern
  • INIT_CUMULATIVE_ARGS
  • INIT_CUMULATIVE_INCOMING_ARGS
  • INIT_ENVIRONMENT
  • INIT_SECTION_ASM_OP, INIT_SECTION_ASM_OP
  • INIT_TARGET_OPTABS
  • INITIAL_ELIMINATION_OFFSET
  • INITIAL_FRAME_POINTER_OFFSET
  • initialization routines
  • initializations in expressions
  • INITIALIZE_TRAMPOLINE
  • initializers with labeled elements
  • initializers, non-constant
  • inline automatic for C++ member fns
  • inline functions
  • inline functions, omission of
  • inline, automatic
  • inlining and C++ pragmas
  • insn
  • insn and `/i'
  • insn and `/s'
  • insn and `/u'
  • insn attributes
  • insn canonicalization
  • insn lengths, computing
  • insn splitting
  • insn-attr.h
  • INSN_ANNULLED_BRANCH_P
  • INSN_CACHE_DEPTH
  • INSN_CACHE_LINE_WIDTH
  • INSN_CACHE_SIZE
  • INSN_CLOBBERS_REGNO_P
  • INSN_CODE
  • INSN_DELETED_P
  • INSN_FROM_TARGET_P
  • insn_list
  • INSN_REFERENCES_ARE_DELAYED
  • INSN_SETS_ARE_DELAYED
  • INSN_UID
  • insns
  • insns, generating
  • insns, recognizing
  • INSTALL
  • installation trouble
  • installing GNU CC
  • installing GNU CC on the Sun
  • installing GNU CC on VMS
  • instruction attributes
  • instruction combination
  • instruction patterns
  • instruction recognizer
  • instruction scheduling, instruction scheduling
  • instruction splitting
  • insv instruction pattern
  • INT_TYPE_SIZE
  • INTEGRATE_THRESHOLD
  • integrated
  • integrated, in insn
  • integrated, in reg
  • integrating function code
  • Intel 386 Options
  • Interdependence of Patterns
  • interface and implementation headers, C++
  • interfacing to GNU CC output
  • intermediate C version, nonexistent
  • interrupt handler functions on the H8/300 processors
  • interrupt handlers on the M32R/D
  • INTIFY
  • invalid assembly code
  • invalid input
  • INVOKE__main
  • invoking g++
  • ior
  • ior and attributes
  • ior, canonicalization of
  • iorm3 instruction pattern
  • IS_ASM_LOGICAL_LINE_SEPARATOR
  • isinf
  • isnan
  • ISSUE_RATE

    • j

  • jump instruction patterns
  • jump instructions and set
  • jump optimization
  • jump threading
  • jump_insn
  • JUMP_LABEL
  • JUMP_TABLES_IN_TEXT_SECTION

    • k

  • kernel and user registers (29k)
  • keywords, alternate
  • known causes of trouble

    • l

  • LABEL_NUSES
  • LABEL_OUTSIDE_LOOP_P
  • LABEL_PRESERVE_P
  • label_ref
  • label_ref and `/s'
  • label_ref, RTL sharing
  • labeled elements in initializers
  • labels as values
  • labs
  • language dialect options
  • large bit shifts (88k)
  • large return values
  • LAST_STACK_REG
  • LAST_VIRTUAL_REGISTER
  • LD_FINI_SWITCH
  • LD_INIT_SWITCH
  • LDD_SUFFIX
  • ldexp
  • le
  • le and attributes
  • leaf functions
  • leaf_function
  • leaf_function_p
  • LEAF_REG_REMAP
  • LEAF_REGISTERS
  • left rotate
  • left shift
  • LEGITIMATE_CONSTANT_P
  • LEGITIMATE_PIC_OPERAND_P
  • LEGITIMIZE_ADDRESS
  • length-zero arrays
  • less than
  • less than or equal
  • leu
  • leu and attributes
  • LIB2FUNCS_EXTRA
  • LIB_SPEC
  • LIBCALL_VALUE
  • `libgcc.a'
  • LIBGCC1
  • LIBGCC2_CFLAGS
  • LIBGCC2_WORDS_BIG_ENDIAN
  • LIBGCC_NEEDS_DOUBLE
  • LIBGCC_SPEC
  • Libraries
  • library subroutine names
  • LIBRARY_PATH
  • LIMIT_RELOAD_CLASS
  • link options
  • LINK_LIBGCC_SPECIAL
  • LINK_LIBGCC_SPECIAL_1
  • LINK_SPEC
  • lo_sum
  • load address instruction
  • LOAD_EXTEND_OP
  • load_multiple instruction pattern
  • local labels
  • local register allocation
  • local variables in macros
  • local variables, specifying registers
  • LOCAL_INCLUDE_DIR
  • LOCAL_LABEL_PREFIX
  • LOG_LINKS
  • logical-and, bitwise
  • long long data types
  • LONG_DOUBLE_TYPE_SIZE
  • LONG_LONG_TYPE_SIZE
  • LONG_TYPE_SIZE
  • longjmp
  • longjmp and automatic variables, longjmp and automatic variables
  • longjmp incompatibilities
  • longjmp warnings
  • LONGJMP_RESTORE_FROM_STACK
  • loop optimization
  • lshiftrt
  • lshiftrt and attributes
  • lshrm3 instruction pattern
  • lt
  • lt and attributes
  • ltu
  • lvalues, generalized

    • m

  • `m' in constraint
  • M32R/D options
  • M680x0 options
  • M88k options
  • machine dependent options
  • machine description macros
  • machine descriptions
  • machine mode conversions
  • machine modes
  • machine specific constraints
  • MACHINE_DEPENDENT_REORG
  • MACHINE_STATE_RESTORE
  • MACHINE_STATE_SAVE
  • macro with variable arguments
  • macros containing asm
  • macros, inline alternative
  • macros, local labels
  • macros, local variables in
  • macros, statements in expressions
  • macros, target description
  • macros, types of arguments
  • main and the exit status
  • make
  • MAKE_DECL_ONE_ONLY (decl)
  • make_safe_from
  • makefile fragment
  • MASK_RETURN_ADDR
  • match_dup
  • match_dup and attributes
  • match_op_dup
  • match_operand
  • match_operand and attributes
  • match_operator
  • match_par_dup
  • match_parallel
  • match_scratch
  • matching constraint
  • matching operands
  • math libraries
  • math, in RTL
  • MAX_BITS_PER_WORD
  • MAX_CHAR_TYPE_SIZE
  • MAX_FIXED_MODE_SIZE
  • MAX_INT_TYPE_SIZE
  • MAX_LONG_TYPE_SIZE
  • MAX_MOVE_MAX
  • MAX_OFILE_ALIGNMENT
  • MAX_REGS_PER_ADDRESS
  • MAX_WCHAR_TYPE_SIZE
  • maximum operator
  • MAYBE_REG_PARM_STACK_SPACE
  • mcount
  • MD_CALL_PROTOTYPES
  • MD_EXEC_PREFIX
  • MD_STARTFILE_PREFIX
  • MD_STARTFILE_PREFIX_1
  • mem
  • mem and `/s'
  • mem and `/u'
  • mem and `/v'
  • mem, RTL sharing
  • MEM_IN_STRUCT_P
  • MEM_VOLATILE_P
  • member fns, automatically inline
  • memcmp
  • memcpy
  • memcpy, implicit usage
  • memory model (29k)
  • memory reference, nonoffsettable
  • memory references in constraints
  • MEMORY_MOVE_COST
  • memset, implicit usage
  • messages, warning
  • messages, warning and error
  • middle-operands, omitted
  • MIN_UNITS_PER_WORD
  • minimum operator
  • MINIMUM_ATOMIC_ALIGNMENT
  • minus
  • minus and attributes
  • minus, canonicalization of
  • MIPS options
  • misunderstandings in C++
  • mktemp, and constant strings
  • MN10300 options
  • mod
  • mod and attributes
  • MODDI3_LIBCALL
  • mode attribute
  • mode classes
  • MODE_CC
  • MODE_COMPLEX_FLOAT
  • MODE_COMPLEX_INT
  • MODE_FLOAT
  • MODE_FUNCTION
  • MODE_INT
  • MODE_PARTIAL_INT
  • MODE_RANDOM
  • MODES_TIEABLE_P
  • modifiers in constraints
  • modm3 instruction pattern
  • MODSI3_LIBCALL
  • MOVE_MAX
  • MOVE_RATIO
  • movm instruction pattern
  • movmodecc instruction pattern
  • movstrictm instruction pattern
  • movstrm instruction pattern
  • MULDI3_LIBCALL
  • mulhisi3 instruction pattern
  • mulm3 instruction pattern
  • mulqihi3 instruction pattern
  • MULSI3_LIBCALL
  • mulsidi3 instruction pattern
  • mult
  • mult and attributes
  • mult, canonicalization of
  • MULTIBYTE_CHARS
  • MULTILIB_DEFAULTS
  • MULTILIB_DIRNAMES
  • MULTILIB_EXCEPTIONS
  • MULTILIB_EXTRA_OPTS
  • MULTILIB_MATCHES
  • MULTILIB_OPTIONS
  • multiple alternative constraints
  • MULTIPLE_SYMBOL_SPACES
  • multiplication
  • multiprecision arithmetic
  • MUST_PASS_IN_STACK, and FUNCTION_ARG

    • n

  • `n' in constraint
  • N_REG_CLASSES
  • name augmentation
  • named patterns and conditions
  • named return value in C++
  • names used in assembler code
  • names, pattern
  • naming convention, implementation headers
  • naming types
  • ne
  • ne and attributes
  • neg
  • neg and attributes
  • neg, canonicalization of
  • negm2 instruction pattern
  • nested functions
  • nested functions, trampolines for
  • newline vs string constants
  • next_cc0_user
  • NEXT_INSN
  • NEXT_OBJC_RUNTIME
  • nil
  • no constraints
  • no-op move instructions
  • NO_BUILTIN_PTRDIFF_TYPE
  • NO_BUILTIN_SIZE_TYPE
  • NO_DBX_FUNCTION_END
  • NO_DOLLAR_IN_LABEL
  • NO_DOT_IN_LABEL
  • NO_FUNCTION_CSE
  • NO_IMPLICIT_EXTERN_C
  • NO_MD_PROTOTYPES
  • NO_RECURSIVE_FUNCTION_CSE
  • NO_REGS
  • NO_STAB_H
  • NO_SYS_SIGLIST
  • nocommon attribute
  • non-constant initializers
  • non-static inline function
  • NON_SAVING_SETJMP
  • nongcc_SI_type
  • nongcc_word_type
  • nonlocal_goto instruction pattern
  • nonlocal_goto_receiver instruction pattern
  • nonoffsettable memory reference
  • nop instruction pattern
  • noreturn function attribute
  • not
  • not and attributes
  • not equal
  • not using constraints
  • not, canonicalization of
  • note
  • NOTE_INSN_BLOCK_BEG
  • NOTE_INSN_BLOCK_END
  • NOTE_INSN_DELETED
  • NOTE_INSN_EH_REGION_BEG
  • NOTE_INSN_EH_REGION_END
  • NOTE_INSN_FUNCTION_END
  • NOTE_INSN_LOOP_BEG
  • NOTE_INSN_LOOP_CONT
  • NOTE_INSN_LOOP_END
  • NOTE_INSN_LOOP_VTOP
  • NOTE_INSN_SETJMP
  • NOTE_LINE_NUMBER
  • NOTE_SOURCE_FILE
  • NOTICE_UPDATE_CC
  • NUM_MACHINE_MODES

    • o

  • `o' in constraint
  • OBJC_GEN_METHOD_LABEL
  • OBJC_INCLUDE_PATH
  • OBJC_INT_SELECTORS
  • OBJC_PROLOGUE
  • OBJC_SELECTORS_WITHOUT_LABELS
  • OBJECT_FORMAT_COFF
  • OBJECT_FORMAT_ROSE
  • OBJECT_SUFFIX
  • Objective C
  • Objective C threads
  • OBSTACK_CHUNK_ALLOC
  • OBSTACK_CHUNK_FREE
  • OBSTACK_CHUNK_SIZE
  • obstack_free
  • OCS (88k)
  • offsettable address
  • old-style function definitions
  • OLDAR
  • OLDCC
  • OMIT_EH_TABLE
  • omitted middle-operands
  • one_cmplm2 instruction pattern
  • ONLY_INT_FIELDS
  • open coding
  • operand access
  • operand constraints
  • operand substitution
  • operands
  • OPTIMIZATION_OPTIONS
  • optimize options
  • optional hardware or system features
  • options to control warnings
  • options, C++
  • options, code generation
  • options, debugging
  • options, dialect
  • options, directory search
  • options, GNU CC command
  • options, grouping
  • options, linking
  • options, optimization
  • options, order
  • options, preprocessor
  • order of evaluation, side effects
  • order of options
  • order of register allocation
  • ORDER_REGS_FOR_LOCAL_ALLOC
  • Ordering of Patterns
  • other directory, compilation in
  • OUTGOING_REG_PARM_STACK_SPACE
  • OUTGOING_REGNO
  • output file option
  • output of assembler code
  • output statements
  • output templates
  • output_addr_const
  • output_asm_insn
  • overflow while constant folding
  • OVERLAPPING_REGNO_P
  • overloaded virtual fn, warning
  • OVERRIDE_OPTIONS

    • p

  • `p' in constraint
  • packed attribute
  • parallel
  • parameter forward declaration
  • parameters, aliased
  • parameters, miscellaneous
  • PARM_BOUNDARY
  • PARSE_LDD_OUTPUT
  • parser generator, Bison
  • parsing pass
  • passes and files of the compiler
  • passing arguments
  • PATH_SEPARATOR
  • PATTERN
  • pattern conditions
  • pattern names
  • Pattern Ordering
  • patterns
  • pc
  • pc and attributes
  • pc, RTL sharing
  • pc_rtx
  • PCC_BITFIELD_TYPE_MATTERS
  • PCC_STATIC_STRUCT_RETURN
  • PDImode
  • peephole optimization
  • peephole optimization, RTL representation
  • peephole optimizer definitions
  • percent sign
  • perform_...
  • PIC, PIC
  • PIC_OFFSET_TABLE_REG_CALL_CLOBBERED
  • PIC_OFFSET_TABLE_REGNUM
  • plus
  • plus and attributes
  • plus, canonicalization of
  • Pmode
  • pointer arguments
  • POINTER_SIZE
  • POINTERS_EXTEND_UNSIGNED
  • popen
  • portability
  • portions of temporary objects, pointers to
  • position independent code
  • POSIX
  • post_dec
  • post_inc
  • pragma
  • pragma, reason for not using
  • pragmas in C++, effect on inlining
  • pragmas, interface and implementation
  • pre_dec
  • pre_inc
  • predefined macros
  • PREDICATE_CODES
  • PREFERRED_DEBUGGING_TYPE
  • PREFERRED_OUTPUT_RELOAD_CLASS
  • PREFERRED_RELOAD_CLASS
  • preprocessing numbers
  • preprocessing tokens
  • preprocessor options
  • PRESERVE_DEATH_INFO_REGNO_P
  • prev_active_insn
  • prev_cc0_setter
  • PREV_INSN
  • PRINT_OPERAND
  • PRINT_OPERAND_ADDRESS
  • PRINT_OPERAND_PUNCT_VALID_P
  • probe instruction pattern
  • processor selection (29k)
  • product
  • prof
  • PROFILE_BEFORE_PROLOGUE
  • profile_block_flag, profile_block_flag, profile_block_flag
  • profiling, code generation
  • program counter
  • prologue
  • PROMOTE_FOR_CALL_ONLY
  • PROMOTE_FUNCTION_ARGS
  • PROMOTE_FUNCTION_RETURN
  • PROMOTE_MODE
  • PROMOTE_PROTOTYPES
  • promotion of formal parameters
  • pseudo registers
  • PSImode
  • PTRDIFF_TYPE
  • push address instruction
  • PUSH_ROUNDING
  • PUSH_ROUNDING, interaction with STACK_BOUNDARY
  • PUT_CODE
  • PUT_MODE
  • PUT_REG_NOTE_KIND
  • PUT_SDB_...
  • putenv

    • q

  • `Q', in constraint
  • QImode
  • QImode, in insn
  • qsort, and global register variables
  • question mark
  • quotient

    • r

  • `r' in constraint
  • r0-relative references (88k)
  • ranges in case statements
  • read-only strings
  • READONLY_DATA_SECTION
  • REAL_ARITHMETIC
  • REAL_INFINITY
  • REAL_NM_FILE_NAME
  • REAL_VALUE_ATOF
  • REAL_VALUE_FIX
  • REAL_VALUE_FROM_INT
  • REAL_VALUE_ISINF
  • REAL_VALUE_ISNAN
  • REAL_VALUE_LDEXP
  • REAL_VALUE_NEGATE
  • REAL_VALUE_RNDZINT
  • REAL_VALUE_TO_DECIMAL
  • REAL_VALUE_TO_INT
  • REAL_VALUE_TO_TARGET_DOUBLE
  • REAL_VALUE_TO_TARGET_LONG_DOUBLE
  • REAL_VALUE_TO_TARGET_SINGLE
  • REAL_VALUE_TRUNCATE
  • REAL_VALUE_TYPE
  • REAL_VALUE_UNSIGNED_FIX
  • REAL_VALUE_UNSIGNED_RNDZINT
  • REAL_VALUES_EQUAL
  • REAL_VALUES_LESS
  • recog_operand
  • recognizing insns
  • reg
  • reg and `/i'
  • reg and `/s'
  • reg and `/u'
  • reg and `/v'
  • reg, RTL sharing
  • REG_ALLOC_ORDER
  • REG_BR_PRED
  • REG_BR_PROB
  • REG_CC_SETTER
  • REG_CC_USER
  • REG_CLASS_CONTENTS
  • REG_CLASS_FROM_LETTER
  • REG_CLASS_NAMES
  • REG_DEAD
  • REG_DEP_ANTI
  • REG_DEP_OUTPUT
  • REG_EQUAL
  • REG_EQUIV
  • REG_EXEC_COUNT
  • REG_FUNCTION_VALUE_P
  • REG_INC
  • REG_LABEL
  • REG_LIBCALL
  • REG_LOOP_TEST_P
  • REG_MODE_OK_FOR_BASE_P
  • reg_names
  • REG_NO_CONFLICT
  • REG_NONNEG
  • REG_NOTE_KIND
  • REG_NOTES
  • REG_OK_FOR_BASE_P
  • REG_OK_FOR_INDEX_P
  • REG_OK_STRICT
  • REG_PARM_STACK_SPACE
  • REG_PARM_STACK_SPACE, and FUNCTION_ARG
  • REG_RETVAL
  • REG_UNUSED
  • REG_USERVAR_P
  • REG_WAS_0
  • register allocation
  • register allocation order
  • register allocation, stupid
  • register class definitions
  • register class preference constraints
  • register class preference pass
  • register pairs
  • register positions in frame (88k), register positions in frame (88k)
  • Register Transfer Language (RTL)
  • register usage
  • register use analysis
  • register variable after longjmp
  • register-to-stack conversion
  • REGISTER_MOVE_COST
  • REGISTER_NAMES
  • register_operand
  • REGISTER_PREFIX
  • registers
  • registers arguments
  • registers for local variables
  • registers in constraints
  • registers, global allocation
  • registers, global variables in
  • REGNO_MODE_OK_FOR_BASE_P
  • REGNO_OK_FOR_BASE_P
  • REGNO_OK_FOR_INDEX_P
  • REGNO_REG_CLASS
  • regs_ever_live
  • relative costs
  • RELATIVE_PREFIX_NOT_LINKDIR
  • reload pass
  • reload_completed
  • reload_in instruction pattern
  • reload_in_progress
  • reload_out instruction pattern
  • reloading
  • remainder
  • reordering, warning
  • reporting bugs
  • representation of RTL
  • rest argument (in macro)
  • rest_of_compilation
  • rest_of_decl_compilation
  • restore_stack_block instruction pattern
  • restore_stack_function instruction pattern
  • restore_stack_nonlocal instruction pattern
  • return
  • return instruction pattern
  • return value of main
  • return value, named, in C++
  • return values in registers
  • return, in C++ function header
  • RETURN_ADDR_IN_PREVIOUS_FRAME
  • RETURN_ADDR_RTX
  • RETURN_ADDRESS_POINTER_REGNUM
  • RETURN_IN_MEMORY
  • RETURN_POPS_ARGS
  • returning aggregate values
  • returning structures and unions
  • REVERSIBLE_CC_MODE
  • right rotate
  • right shift
  • rotate, rotate
  • rotatert
  • rotlm3 instruction pattern
  • rotrm3 instruction pattern
  • ROUND_TYPE_ALIGN
  • ROUND_TYPE_SIZE
  • RS/6000 and PowerPC Options
  • RT options
  • RT PC
  • RTL addition
  • RTL comparison
  • RTL comparison operations
  • RTL constant expression types
  • RTL constants
  • RTL declarations
  • RTL difference
  • RTL expression
  • RTL expressions for arithmetic
  • RTL format
  • RTL format characters
  • RTL function-call insns
  • RTL generation
  • RTL insn template
  • RTL integers
  • RTL memory expressions
  • RTL object types
  • RTL postdecrement
  • RTL postincrement
  • RTL predecrement
  • RTL preincrement
  • RTL register expressions
  • RTL representation
  • RTL side effect expressions
  • RTL strings
  • RTL structure sharing assumptions
  • RTL subtraction
  • RTL sum
  • RTL vectors
  • RTX (See RTL)
  • RTX_COSTS
  • RTX_INTEGRATED_P
  • RTX_UNCHANGING_P
  • run-time conventions
  • run-time options
  • run-time target specification

    • s

  • `s' in constraint
  • save_stack_block instruction pattern
  • save_stack_function instruction pattern
  • save_stack_nonlocal instruction pattern
  • saveable_obstack
  • scalars, returned as values
  • scanf, and constant strings
  • SCCS_DIRECTIVE
  • SCHED_GROUP_P
  • scheduler, experimental
  • scheduling, delayed branch
  • scheduling, instruction, scheduling, instruction
  • SCmode
  • scond instruction pattern
  • scope of a variable length array
  • scope of declaration
  • scope of external declarations
  • scratch
  • scratch operands
  • scratch, RTL sharing
  • SDB_ALLOW_FORWARD_REFERENCES
  • SDB_ALLOW_UNKNOWN_REFERENCES
  • SDB_DEBUGGING_INFO
  • SDB_DELIM
  • SDB_GENERATE_FAKE
  • search path
  • second include path
  • SECONDARY_INPUT_RELOAD_CLASS
  • SECONDARY_MEMORY_NEEDED
  • SECONDARY_MEMORY_NEEDED_MODE
  • SECONDARY_MEMORY_NEEDED_RTX
  • SECONDARY_OUTPUT_RELOAD_CLASS
  • SECONDARY_RELOAD_CLASS
  • section function attribute
  • section variable attribute
  • SELECT_CC_MODE
  • SELECT_RTX_SECTION
  • SELECT_SECTION
  • separate directory, compilation in
  • sequence
  • sequential consistency on 88k
  • set
  • set_attr
  • set_attr_alternative
  • SET_DEFAULT_TYPE_ATTRIBUTES
  • SET_DEST
  • SET_SRC
  • setjmp
  • setjmp incompatibilities
  • SETUP_FRAME_ADDRESSES
  • SETUP_INCOMING_VARARGS
  • SFmode
  • shared strings
  • shared VMS run time system
  • SHARED_BSS_SECTION_ASM_OP
  • SHARED_SECTION_ASM_OP
  • sharing of RTL components
  • shift
  • SHIFT_COUNT_TRUNCATED
  • SHORT_IMMEDIATES_SIGN_EXTEND
  • SHORT_TYPE_SIZE
  • side effect in ?:
  • side effects, macro argument
  • side effects, order of evaluation
  • sign_extend
  • sign_extract
  • sign_extract, canonicalization of
  • signature
  • signature in C++, advantages
  • signature member function default implementation
  • signatures, C++
  • signed and unsigned values, comparison warning
  • signed division
  • signed maximum
  • signed minimum
  • SIGNED_CHAR_SPEC
  • SImode
  • simple constraints
  • simplifications, arithmetic
  • sin
  • SIZE_TYPE
  • sizeof
  • SLOW_BYTE_ACCESS
  • SLOW_UNALIGNED_ACCESS
  • SLOW_ZERO_EXTEND
  • SMALL_REGISTER_CLASSES
  • smaller data references
  • smaller data references (88k)
  • smaller data references (MIPS)
  • smaller data references (PowerPC)
  • smax
  • smaxm3 instruction pattern
  • smin
  • sminm3 instruction pattern
  • smulm3_highpart instruction pattern
  • SPARC options
  • specified registers
  • specifying compiler version and target machine
  • specifying hardware config
  • specifying machine version
  • specifying registers for local variables
  • speed of instructions
  • splitting instructions
  • sqrt, sqrt
  • sqrtm2 instruction pattern
  • square root
  • sscanf, and constant strings
  • stack arguments
  • stack checks (29k)
  • stack frame layout
  • STACK_BOUNDARY
  • STACK_CHECK_BUILTIN
  • STACK_CHECK_FIXED_FRAME_SIZE
  • STACK_CHECK_MAX_FRAME_SIZE
  • STACK_CHECK_MAX_VAR_SIZE
  • STACK_CHECK_PROBE_INTERVAL
  • STACK_CHECK_PROBE_LOAD
  • STACK_CHECK_PROTECT
  • STACK_DYNAMIC_OFFSET
  • STACK_DYNAMIC_OFFSET and virtual registers
  • STACK_GROWS_DOWNWARD
  • STACK_PARMS_IN_REG_PARM_AREA
  • STACK_POINTER_OFFSET
  • STACK_POINTER_OFFSET and virtual registers
  • STACK_POINTER_REGNUM
  • STACK_POINTER_REGNUM and virtual registers
  • stack_pointer_rtx
  • STACK_REGS
  • stage1
  • standard pattern names
  • STANDARD_EXEC_PREFIX
  • STANDARD_INCLUDE_DIR
  • STANDARD_STARTFILE_PREFIX
  • start files
  • STARTFILE_SPEC
  • STARTING_FRAME_OFFSET
  • STARTING_FRAME_OFFSET and virtual registers
  • statements inside expressions
  • static data in C++, declaring and defining
  • STATIC_CHAIN
  • STATIC_CHAIN_INCOMING
  • STATIC_CHAIN_INCOMING_REGNUM
  • STATIC_CHAIN_REGNUM
  • `stdarg.h' and register arguments
  • `stdarg.h' and RT PC
  • storage layout
  • STORE_FLAG_VALUE
  • `store_multiple' instruction pattern
  • storem bug (29k)
  • strcmp
  • strcpy, strcpy
  • strength-reduction
  • STRICT_ALIGNMENT
  • STRICT_ARGUMENT_NAMING
  • strict_low_part
  • string constants
  • string constants vs newline
  • STRIP_NAME_ENCODING
  • strlen
  • strlenm instruction pattern
  • STRUCT_VALUE
  • STRUCT_VALUE_INCOMING
  • STRUCT_VALUE_INCOMING_REGNUM
  • STRUCT_VALUE_REGNUM
  • structure passing (88k)
  • structure value address
  • STRUCTURE_SIZE_BOUNDARY
  • structures
  • structures, constructor expression
  • structures, returning
  • stupid register allocation
  • subm3 instruction pattern
  • submodel options
  • subreg
  • subreg and `/s'
  • subreg and `/u'
  • subreg, special reload handling
  • subreg, in strict_low_part
  • SUBREG_PROMOTED_UNSIGNED_P
  • SUBREG_PROMOTED_VAR_P
  • SUBREG_REG
  • SUBREG_WORD
  • subscripting
  • subscripting and function values
  • subtype polymorphism, C++
  • SUCCESS_EXIT_CODE
  • suffixes for C++ source
  • Sun installation
  • SUPPORTS_WEAK, SUPPORTS_WEAK
  • suppressing warnings
  • surprises in C++
  • SVr4
  • SWITCH_TAKES_ARG
  • SWITCHES_NEED_SPACES
  • symbol_ref
  • symbol_ref and `/u'
  • symbol_ref and `/v'
  • symbol_ref, RTL sharing
  • SYMBOL_REF_FLAG
  • SYMBOL_REF_FLAG, in ENCODE_SECTION_INFO
  • SYMBOL_REF_USED
  • symbolic label
  • syntax checking
  • synthesized methods, warning
  • sys_siglist
  • SYSTEM_INCLUDE_DIR

    • t

  • `t-target'
  • tablejump instruction pattern
  • tagging insns
  • tail recursion optimization
  • target description macros
  • target machine, specifying
  • target makefile fragment
  • target options
  • target specifications
  • target-parameter-dependent code
  • TARGET_BELL
  • TARGET_BS
  • TARGET_CR
  • TARGET_EDOM
  • TARGET_FF
  • TARGET_FLOAT_FORMAT
  • TARGET_MEM_FUNCTIONS
  • TARGET_NEWLINE
  • TARGET_OPTIONS
  • TARGET_SWITCHES
  • TARGET_TAB
  • TARGET_VERSION
  • TARGET_VT
  • TCmode
  • tcov
  • template debugging
  • template instantiation
  • temporaries, lifetime of
  • termination routines
  • text_section
  • TEXT_SECTION_ASM_OP
  • TFmode
  • threads, Objective C
  • thunks
  • TImode
  • tiny data section on the H8/300H
  • `tm.h' macros
  • TMPDIR
  • top level of compiler
  • traditional C language
  • TRADITIONAL_RETURN_FLOAT
  • TRAMPOLINE_ALIGNMENT
  • TRAMPOLINE_SECTION
  • TRAMPOLINE_SIZE
  • TRAMPOLINE_TEMPLATE
  • trampolines for nested functions
  • TRANSFER_FROM_TRAMPOLINE
  • TRULY_NOOP_TRUNCATION
  • truncate
  • truncmn2 instruction pattern
  • tstm instruction pattern
  • type abstraction, C++
  • type alignment
  • type attributes
  • typedef names as function parameters
  • typeof

    • u

  • udiv
  • UDIVDI3_LIBCALL
  • udivm3 instruction pattern
  • udivmodm4 instruction pattern
  • UDIVSI3_LIBCALL
  • Ultrix calling convention
  • umax
  • umaxm3 instruction pattern
  • umin
  • uminm3 instruction pattern
  • umod
  • UMODDI3_LIBCALL
  • umodm3 instruction pattern
  • UMODSI3_LIBCALL
  • umulhisi3 instruction pattern
  • umulm3_highpart instruction pattern
  • umulqihi3 instruction pattern
  • umulsidi3 instruction pattern
  • unchanging
  • unchanging, in call_insn
  • unchanging, in insn
  • unchanging, in subreg
  • unchanging, in symbol_ref
  • unchanging, in reg and mem
  • undefined behavior
  • undefined function value
  • underscores in variables in macros
  • underscores, avoiding (88k)
  • union, casting to a
  • unions
  • unions, returning
  • UNIQUE_SECTION
  • UNIQUE_SECTION_P (decl)
  • UNITS_PER_WORD
  • UNKNOWN_FLOAT_FORMAT
  • unreachable code
  • unresolved references and -nodefaultlibs
  • unresolved references and -nostdlib
  • unshare_all_rtl
  • unsigned division
  • unsigned greater than, unsigned greater than
  • unsigned less than, unsigned less than
  • unsigned minimum and maximum
  • unsigned_fix
  • unsigned_float
  • unspec
  • unspec_volatile
  • untyped_call instruction pattern
  • untyped_return instruction pattern
  • use
  • USE_C_ALLOCA
  • USE_PROTOTYPES
  • used
  • used, in symbol_ref
  • USER_LABEL_PREFIX
  • USG

    • v

  • `V' in constraint
  • V850 Options
  • VALID_MACHINE_DECL_ATTRIBUTE
  • VALID_MACHINE_TYPE_ATTRIBUTE
  • value after longjmp
  • values, returned by functions
  • varargs implementation
  • `varargs.h' and RT PC
  • variable addressability on the M32R/D
  • variable alignment
  • variable attributes
  • variable number of arguments
  • variable-length array scope
  • variable-length arrays
  • variables in specified registers
  • variables, local, in macros
  • Vax calling convention
  • VAX options
  • VAX_FLOAT_FORMAT
  • `VAXCRTL'
  • VIRTUAL_INCOMING_ARGS_REGNUM
  • VIRTUAL_OUTGOING_ARGS_REGNUM
  • VIRTUAL_STACK_DYNAMIC_REGNUM
  • VIRTUAL_STACK_VARS_REGNUM
  • VMS
  • VMS and case sensitivity
  • VMS and include files
  • VMS installation
  • void pointers, arithmetic
  • void, size of pointer to
  • VOIDmode
  • volatil
  • volatil, in insn
  • volatil, in mem
  • volatil, in reg
  • volatil, in symbol_ref
  • volatile applied to function
  • volatile memory references
  • voting between constraint alternatives
  • vprintf

    • w

  • warning for comparison of signed and unsigned values
  • warning for overloaded virtual fn
  • warning for reordering of member initializers
  • warning for synthesized methods
  • warning messages
  • warnings vs errors
  • WCHAR_TYPE
  • WCHAR_TYPE_SIZE
  • weak attribute
  • which_alternative
  • whitespace
  • word_mode
  • WORD_REGISTER_OPERATIONS
  • WORD_SWITCH_TAKES_ARG
  • WORDS_BIG_ENDIAN
  • WORDS_BIG_ENDIAN, effect on subreg

    • x

  • `X' in constraint
  • `x-host'
  • XCmode
  • XCOFF_DEBUGGING_INFO
  • XEXP
  • XFmode
  • XINT
  • `xm-machine.h'
  • xor
  • xor, canonicalization of
  • xorm3 instruction pattern
  • XSTR
  • XVEC
  • XVECEXP
  • XVECLEN
  • XWINT

    • z

  • zero division on 88k
  • zero-length arrays
  • zero_extend
  • zero_extendmn2 instruction pattern
  • zero_extract
  • zero_extract, canonicalization of

    • Go to the first, previous, next, last section, table of contents.


Using and Porting GNU CC - Footnotes

Using and Porting GNU CC

(1)

Prior to release 2 of the compiler, there was a separate g++ compiler. That version was based on GNU CC, but not integrated with it. Versions of g++ with a `1.xx' version number--for example, g++ version 1.37 or 1.42--are much less reliable than the versions integrated with GCC 2. Moreover, combining G++ `1.xx' with a version 2 GCC will simply not work.

(2)

The analogous feature in Fortran is called an assigned goto, but that name seems inappropriate in C, where one can do more than simply store label addresses in label variables.

(3)

A file's basename was the name stripped of all leading path information and of trailing suffixes, such as `.h' or `.C' or `.cc'.

This document was generated on 22 March 1998 using the texi2html translator version 1.52.


Using LD, the GNU linker - Overview

Copyright (C) 1991, 92, 93, 94, 95, 96, 97, 1998 Free Software Foundation, Inc. Permission is granted to make and distribute verbatim copies of this manual provided the copyright notice and this permission notice are preserved on all copies. Permission is granted to copy and distribute modified versions of this manual under the conditions for verbatim copying, provided also that the entire resulting derived work is distributed under the terms of a permission notice identical to this one. Permission is granted to copy and distribute translations of this manual into another language, under the above conditions for modified versions.

Overview

ld combines a number of object and archive files, relocates their data and ties up symbol references. Usually the last step in compiling a program is to run ld. ld accepts Linker Command Language files written in a superset of AT&T's Link Editor Command Language syntax, to provide explicit and total control over the linking process. This version of ld uses the general purpose BFD libraries to operate on object files. This allows ld to read, combine, and write object files in many different formats--for example, COFF or a.out. Different formats may be linked together to produce any available kind of object file. See section BFD, for more information. Aside from its flexibility, the GNU linker is more helpful than other linkers in providing diagnostic information. Many linkers abandon execution immediately upon encountering an error; whenever possible, ld continues executing, allowing you to identify other errors (or, in some cases, to get an output file in spite of the error).


Using LD, the GNU linker - Invocation

Invocation

The GNU linker ld is meant to cover a broad range of situations, and to be as compatible as possible with other linkers. As a result, you have many choices to control its behavior.


Using LD, the GNU linker - Options

Command Line Options

The linker supports a plethora of command-line options, but in actual practice few of them are used in any particular context. For instance, a frequent use of ld is to link standard Unix object files on a standard, supported Unix system. On such a system, to link a file hello.o:

ld -o output /lib/crt0.o hello.o -lc

This tells ld to produce a file called output as the result of linking the file /lib/crt0.o with hello.o and the library libc.a, which will come from the standard search directories. (See the discussion of the `-l' option below.) The command-line options to ld may be specified in any order, and may be repeated at will. Repeating most options with a different argument will either have no further effect, or override prior occurrences (those further to the left on the command line) of that option. Options which may be meaningfully specified more than once are noted in the descriptions below. Non-option arguments are objects files which are to be linked together. They may follow, precede, or be mixed in with command-line options, except that an object file argument may not be placed between an option and its argument. Usually the linker is invoked with at least one object file, but you can specify other forms of binary input files using `-l', `-R', and the script command language. If no binary input files at all are specified, the linker does not produce any output, and issues the message `No input files'. If the linker can not recognize the format of an object file, it will assume that it is a linker script. A script specified in this way augments the main linker script used for the link (either the default linker script or the one specified by using `-T'). This feature permits the linker to link against a file which appears to be an object or an archive, but actually merely defines some symbol values, or uses INPUT or GROUP to load other objects. Note that specifying a script in this way should only be used to augment the main linker script; if you want to use some command that logically can only appear once, such as the SECTIONS or MEMORY command, you must replace the default linker script using the `-T' option. See section Command Language. For options whose names are a single letter, option arguments must either follow the option letter without intervening whitespace, or be given as separate arguments immediately following the option that requires them. For options whose names are multiple letters, either one dash or two can precede the option name; for example, `--oformat' and `--oformat' are equivalent. Arguments to multiple-letter options must either be separated from the option name by an equals sign, or be given as separate arguments immediately following the option that requires them. For example, `--oformat srec' and `--oformat=srec' are equivalent. Unique abbreviations of the names of multiple-letter options are accepted.

-akeyword
This option is supported for HP/UX compatibility. The keyword argument must be one of the strings `archive', `shared', or `default'. `-aarchive' is functionally equivalent to `-Bstatic', and the other two keywords are functionally equivalent to `-Bdynamic'. This option may be used any number of times.
-Aarchitecture
--architecture=architecture
In the current release of ld, this option is useful only for the Intel 960 family of architectures. In that ld configuration, the architecture argument identifies the particular architecture in the 960 family, enabling some safeguards and modifying the archive-library search path. See section ld and the Intel 960 family, for details. Future releases of ld may support similar functionality for other architecture families.
-b input-format
--format=input-format
ld may be configured to support more than one kind of object file. If your ld is configured this way, you can use the `-b' option to specify the binary format for input object files that follow this option on the command line. Even when ld is configured to support alternative object formats, you don't usually need to specify this, as ld should be configured to expect as a default input format the most usual format on each machine. input-format is a text string, the name of a particular format supported by the BFD libraries. (You can list the available binary formats with `objdump -i'.) See section BFD. You may want to use this option if you are linking files with an unusual binary format. You can also use `-b' to switch formats explicitly (when linking object files of different formats), by including `-b input-format' before each group of object files in a particular format. The default format is taken from the environment variable GNUTARGET. See section Environment Variables. You can also define the input format from a script, using the command TARGET; see section Option Commands.
-c MRI-commandfile
--mri-script=MRI-commandfile
For compatibility with linkers produced by MRI, ld accepts script files written in an alternate, restricted command language, described in section MRI Compatible Script Files. Introduce MRI script files with the option `-c'; use the `-T' option to run linker scripts written in the general-purpose ld scripting language. If MRI-cmdfile does not exist, ld looks for it in the directories specified by any `-L' options.
-d
-dc
-dp
These three options are equivalent; multiple forms are supported for compatibility with other linkers. They assign space to common symbols even if a relocatable output file is specified (with `-r'). The script command FORCE_COMMON_ALLOCATION has the same effect. See section Option Commands.
-e entry
--entry=entry
Use entry as the explicit symbol for beginning execution of your program, rather than the default entry point. See section The Entry Point, for a discussion of defaults and other ways of specifying the entry point.
-E
--export-dynamic
When creating a dynamically linked executable, add all symbols to the dynamic symbol table. The dynamic symbol table is the set of symbols which are visible from dynamic objects at run time. If you do not use this option, the dynamic symbol table will normally contain only those symbols which are referenced by some dynamic object mentioned in the link. If you use dlopen to load a dynamic object which needs to refer back to the symbols defined by the program, rather than some other dynamic object, then you will probably need to use this option when linking the program itself.
-f
--auxiliary name
When creating an ELF shared object, set the internal DT_AUXILIARY field to the specified name. This tells the dynamic linker that the symbol table of the shared object should be used as an auxiliary filter on the symbol table of the shared object name. If you later link a program against this filter object, then, when you run the program, the dynamic linker will see the DT_AUXILIARY field. If the dynamic linker resolves any symbols from the filter object, it will first check whether there is a definition in the shared object name. If there is one, it will be used instead of the definition in the filter object. The shared object name need not exist. Thus the shared object name may be used to provide an alternative implementation of certain functions, perhaps for debugging or for machine specific performance. This option may be specified more than once. The DT_AUXILIARY entries will be created in the order in which they appear on the command line.
-F name
--filter name
When creating an ELF shared object, set the internal DT_FILTER field to the specified name. This tells the dynamic linker that the symbol table of the shared object which is being created should be used as a filter on the symbol table of the shared object name. If you later link a program against this filter object, then, when you run the program, the dynamic linker will see the DT_FILTER field. The dynamic linker will resolve symbols according to the symbol table of the filter object as usual, but it will actually link to the definitions found in the shared object name. Thus the filter object can be used to select a subset of the symbols provided by the object name. Some older linkers used the -F option throughout a compilation toolchain for specifying object-file format for both input and output object files. The GNU linker uses other mechanisms for this purpose: the -b, --format, --oformat options, the TARGET command in linker scripts, and the GNUTARGET environment variable. The GNU linker will ignore the -F option when not creating an ELF shared object.
--force-exe-suffix
Make sure that an output file has a .exe suffix. If a successfully built fully linked output file does not have a .exe or .dll suffix, this option forces the linker to copy the output file to one of the same name with a .exe suffix. This option is useful when using unmodified Unix makefiles on a Microsoft Windows host, since some versions of Windows won't run an image unless it ends in a .exe suffix.
-g
Ignored. Provided for compatibility with other tools.
-Gvalue
--gpsize=value
Set the maximum size of objects to be optimized using the GP register to size. This is only meaningful for object file formats such as MIPS ECOFF which supports putting large and small objects into different sections. This is ignored for other object file formats.
-hname
-soname=name
When creating an ELF shared object, set the internal DT_SONAME field to the specified name. When an executable is linked with a shared object which has a DT_SONAME field, then when the executable is run the dynamic linker will attempt to load the shared object specified by the DT_SONAME field rather than the using the file name given to the linker.
-i
Perform an incremental link (same as option `-r').
-larchive
--library=archive
Add archive file archive to the list of files to link. This option may be used any number of times. ld will search its path-list for occurrences of libarchive.a for every archive specified. On systems which support shared libraries, ld may also search for libraries with extensions other than .a. Specifically, on ELF and SunOS systems, ld will search a directory for a library with an extension of .so before searching for one with an extension of .a. By convention, a .so extension indicates a shared library. The linker will search an archive only once, at the location where it is specified on the command line. If the archive defines a symbol which was undefined in some object which appeared before the archive on the command line, the linker will include the appropriate file(s) from the archive. However, an undefined symbol in an object appearing later on the command line will not cause the linker to search the archive again. See the -( option for a way to force the linker to search archives multiple times. You may list the same archive multiple times on the command line. This type of archive searching is standard for Unix linkers. However, if you are using ld on AIX, note that it is different from the behaviour of the AIX linker.
-Lsearchdir
--library-path=searchdir
Add path searchdir to the list of paths that ld will search for archive libraries and ld control scripts. You may use this option any number of times. The directories are searched in the order in which they are specified on the command line. Directories specified on the command line are searched before the default directories. All -L options apply to all -l options, regardless of the order in which the options appear. The default set of paths searched (without being specified with `-L') depends on which emulation mode ld is using, and in some cases also on how it was configured. See section Environment Variables. The paths can also be specified in a link script with the SEARCH_DIR command. Directories specified this way are searched at the point in which the linker script appears in the command line.
-memulation
Emulate the emulation linker. You can list the available emulations with the `--verbose' or `-V' options. If the `-m' option is not used, the emulation is taken from the LDEMULATION environment variable, if that is defined. Otherwise, the default emulation depends upon how the linker was configured.
-M
--print-map
Print a link map to the standard output. A link map provides information about the link, including the following:
  • Where object files and symbols are mapped into memory.
  • How common symbols are allocated.
  • All archive members included in the link, with a mention of the symbol which caused the archive member to be brought in.
-n
--nmagic
Set the text segment to be read only, and mark the output as NMAGIC if possible.
-N
--omagic
Set the text and data sections to be readable and writable. Also, do not page-align the data segment. If the output format supports Unix style magic numbers, mark the output as OMAGIC.
-o output
--output=output
Use output as the name for the program produced by ld; if this option is not specified, the name `a.out' is used by default. The script command OUTPUT can also specify the output file name.
-r
--relocateable
Generate relocatable output--i.e., generate an output file that can in turn serve as input to ld. This is often called partial linking. As a side effect, in environments that support standard Unix magic numbers, this option also sets the output file's magic number to OMAGIC. If this option is not specified, an absolute file is produced. When linking C++ programs, this option will not resolve references to constructors; to do that, use `-Ur'. This option does the same thing as `-i'.
-R filename
--just-symbols=filename
Read symbol names and their addresses from filename, but do not relocate it or include it in the output. This allows your output file to refer symbolically to absolute locations of memory defined in other programs. You may use this option more than once. For compatibility with other ELF linkers, if the -R option is followed by a directory name, rather than a file name, it is treated as the -rpath option.
-s
--strip-all
Omit all symbol information from the output file.
-S
--strip-debug
Omit debugger symbol information (but not all symbols) from the output file.
-t
--trace
Print the names of the input files as ld processes them.
-T commandfile
--script=commandfile
Read link commands from the file commandfile. These commands replace ld's default link script (rather than adding to it), so commandfile must specify everything necessary to describe the target format. You must use this option if you want to use a command which can only appear once in a linker script, such as the SECTIONS or MEMORY command. See section Command Language. If commandfile does not exist, ld looks for it in the directories specified by any preceding `-L' options. Multiple `-T' options accumulate.
-u symbol
--undefined=symbol
Force symbol to be entered in the output file as an undefined symbol. Doing this may, for example, trigger linking of additional modules from standard libraries. `-u' may be repeated with different option arguments to enter additional undefined symbols.
-v
--version
-V
Display the version number for ld. The -V option also lists the supported emulations.
-x
--discard-all
Delete all local symbols.
-X
--discard-locals
Delete all temporary local symbols. For most targets, this is all local symbols whose names begin with `L'.
-y symbol
--trace-symbol=symbol
Print the name of each linked file in which symbol appears. This option may be given any number of times. On many systems it is necessary to prepend an underscore. This option is useful when you have an undefined symbol in your link but don't know where the reference is coming from.
-Y path
Add path to the default library search path. This option exists for Solaris compatibility.
-z keyword
This option is ignored for Solaris compatibility.
-( archives -)
--start-group archives --end-group
The archives should be a list of archive files. They may be either explicit file names, or `-l' options. The specified archives are searched repeatedly until no new undefined references are created. Normally, an archive is searched only once in the order that it is specified on the command line. If a symbol in that archive is needed to resolve an undefined symbol referred to by an object in an archive that appears later on the command line, the linker would not be able to resolve that reference. By grouping the archives, they all be searched repeatedly until all possible references are resolved. Using this option has a significant performance cost. It is best to use it only when there are unavoidable circular references between two or more archives.
-assert keyword
This option is ignored for SunOS compatibility.
-Bdynamic
-dy
-call_shared
Link against dynamic libraries. This is only meaningful on platforms for which shared libraries are supported. This option is normally the default on such platforms. The different variants of this option are for compatibility with various systems. You may use this option multiple times on the command line: it affects library searching for -l options which follow it.
-Bstatic
-dn
-non_shared
-static
Do not link against shared libraries. This is only meaningful on platforms for which shared libraries are supported. The different variants of this option are for compatibility with various systems. You may use this option multiple times on the command line: it affects library searching for -l options which follow it.
-Bsymbolic
When creating a shared library, bind references to global symbols to the definition within the shared library, if any. Normally, it is possible for a program linked against a shared library to override the definition within the shared library. This option is only meaningful on ELF platforms which support shared libraries.
--cref
Output a cross reference table. If a linker map file is being generated, the cross reference table is printed to the map file. Otherwise, it is printed on the standard output. The format of the table is intentionally simple, so that it may be easily processed by a script if necessary. The symbols are printed out, sorted by name. For each symbol, a list of file names is given. If the symbol is defined, the first file listed is the location of the definition. The remaining files contain references to the symbol.
--defsym symbol=expression
Create a global symbol in the output file, containing the absolute address given by expression. You may use this option as many times as necessary to define multiple symbols in the command line. A limited form of arithmetic is supported for the expression in this context: you may give a hexadecimal constant or the name of an existing symbol, or use + and - to add or subtract hexadecimal constants or symbols. If you need more elaborate expressions, consider using the linker command language from a script (see section Assignment: Defining Symbols). Note: there should be no white space between symbol, the equals sign ("="), and expression.
--dynamic-linker file
Set the name of the dynamic linker. This is only meaningful when generating dynamically linked ELF executables. The default dynamic linker is normally correct; don't use this unless you know what you are doing.
-EB
Link big-endian objects. This affects the default output format.
-EL
Link little-endian objects. This affects the default output format.
--embedded-relocs
This option is only meaningful when linking MIPS embedded PIC code, generated by the -membedded-pic option to the GNU compiler and assembler. It causes the linker to create a table which may be used at runtime to relocate any data which was statically initialized to pointer values. See the code in testsuite/ld-empic for details.
--help
Print a summary of the command-line options on the standard output and exit.
-Map mapfile
Print a link map to the file mapfile. See the description of the `-M' option, above.
--no-keep-memory
ld normally optimizes for speed over memory usage by caching the symbol tables of input files in memory. This option tells ld to instead optimize for memory usage, by rereading the symbol tables as necessary. This may be required if ld runs out of memory space while linking a large executable.
--no-warn-mismatch
Normally ld will give an error if you try to link together input files that are mismatched for some reason, perhaps because they have been compiled for different processors or for different endiannesses. This option tells ld that it should silently permit such possible errors. This option should only be used with care, in cases when you have taken some special action that ensures that the linker errors are inappropriate.
--no-whole-archive
Turn off the effect of the --whole-archive option for subsequent archive files.
--noinhibit-exec
Retain the executable output file whenever it is still usable. Normally, the linker will not produce an output file if it encounters errors during the link process; it exits without writing an output file when it issues any error whatsoever.
--oformat output-format
ld may be configured to support more than one kind of object file. If your ld is configured this way, you can use the `--oformat' option to specify the binary format for the output object file. Even when ld is configured to support alternative object formats, you don't usually need to specify this, as ld should be configured to produce as a default output format the most usual format on each machine. output-format is a text string, the name of a particular format supported by the BFD libraries. (You can list the available binary formats with `objdump -i'.) The script command OUTPUT_FORMAT can also specify the output format, but this option overrides it. See section BFD.
-qmagic
This option is ignored for Linux compatibility.
-Qy
This option is ignored for SVR4 compatibility.
--relax
An option with machine dependent effects. This option is only supported on a few targets. See section ld and the H8/300. See section ld and the Intel 960 family. On some platforms, the `--relax' option performs global optimizations that become possible when the linker resolves addressing in the program, such as relaxing address modes and synthesizing new instructions in the output object file. On platforms where this is not supported, `--relax' is accepted, but ignored.
--retain-symbols-file filename
Retain only the symbols listed in the file filename, discarding all others. filename is simply a flat file, with one symbol name per line. This option is especially useful in environments (such as VxWorks) where a large global symbol table is accumulated gradually, to conserve run-time memory. `--retain-symbols-file' does not discard undefined symbols, or symbols needed for relocations. You may only specify `--retain-symbols-file' once in the command line. It overrides `-s' and `-S'.
-rpath dir
Add a directory to the runtime library search path. This is used when linking an ELF executable with shared objects. All -rpath arguments are concatenated and passed to the runtime linker, which uses them to locate shared objects at runtime. The -rpath option is also used when locating shared objects which are needed by shared objects explicitly included in the link; see the description of the -rpath-link option. If -rpath is not used when linking an ELF executable, the contents of the environment variable LD_RUN_PATH will be used if it is defined. The -rpath option may also be used on SunOS. By default, on SunOS, the linker will form a runtime search patch out of all the -L options it is given. If a -rpath option is used, the runtime search path will be formed exclusively using the -rpath options, ignoring the -L options. This can be useful when using gcc, which adds many -L options which may be on NFS mounted filesystems. For compatibility with other ELF linkers, if the -R option is followed by a directory name, rather than a file name, it is treated as the -rpath option.
-rpath-link DIR
When using ELF or SunOS, one shared library may require another. This happens when an ld -shared link includes a shared library as one of the input files. When the linker encounters such a dependency when doing a non-shared, non-relocateable link, it will automatically try to locate the required shared library and include it in the link, if it is not included explicitly. In such a case, the -rpath-link option specifies the first set of directories to search. The -rpath-link option may specify a sequence of directory names either by specifying a list of names separated by colons, or by appearing multiple times. The linker uses the following search paths to locate required shared libraries.
  1. Any directories specified by -rpath-link options.
  2. Any directories specified by -rpath options. The difference between -rpath and -rpath-link is that directories specified by -rpath options are included in the executable and used at runtime, whereas the -rpath-link option is only effective at link time.
  3. On an ELF system, if the -rpath and rpath-link options were not used, search the contents of the environment variable LD_RUN_PATH.
  4. On SunOS, if the -rpath option was not used, search any directories specified using -L options.
  5. For a native linker, the contents of the environment variable LD_LIBRARY_PATH.
  6. The default directories, normally `/lib' and `/usr/lib'.
If the required shared library is not found, the linker will issue a warning and continue with the link.
-shared
-Bshareable
Create a shared library. This is currently only supported on ELF, XCOFF and SunOS platforms. On SunOS, the linker will automatically create a shared library if the -e option is not used and there are undefined symbols in the link.
--sort-common
This option tells ld to sort the common symbols by size when it places them in the appropriate output sections. First come all the one byte symbols, then all the two bytes, then all the four bytes, and then everything else. This is to prevent gaps between symbols due to alignment constraints.
--split-by-file
Similar to --split-by-reloc but creates a new output section for each input file.
--split-by-reloc count
Trys to creates extra sections in the output file so that no single output section in the file contains more than count relocations. This is useful when generating huge relocatable for downloading into certain real time kernels with the COFF object file format; since COFF cannot represent more than 65535 relocations in a single section. Note that this will fail to work with object file formats which do not support arbitrary sections. The linker will not split up individual input sections for redistribution, so if a single input section contains more than count relocations one output section will contain that many relocations.
--stats
Compute and display statistics about the operation of the linker, such as execution time and memory usage.
--traditional-format
For some targets, the output of ld is different in some ways from the output of some existing linker. This switch requests ld to use the traditional format instead. For example, on SunOS, ld combines duplicate entries in the symbol string table. This can reduce the size of an output file with full debugging information by over 30 percent. Unfortunately, the SunOS dbx program can not read the resulting program (gdb has no trouble). The `--traditional-format' switch tells ld to not combine duplicate entries.
-Tbss org
-Tdata org
-Ttext org
Use org as the starting address for--respectively--the bss, data, or the text segment of the output file. org must be a single hexadecimal integer; for compatibility with other linkers, you may omit the leading `0x' usually associated with hexadecimal values.
-Ur
For anything other than C++ programs, this option is equivalent to `-r': it generates relocatable output--i.e., an output file that can in turn serve as input to ld. When linking C++ programs, `-Ur' does resolve references to constructors, unlike `-r'. It does not work to use `-Ur' on files that were themselves linked with `-Ur'; once the constructor table has been built, it cannot be added to. Use `-Ur' only for the last partial link, and `-r' for the others.
--verbose
Display the version number for ld and list the linker emulations supported. Display which input files can and cannot be opened. Display the linker script if using a default builtin script.
--version-script=version-scriptfile
Specify the name of a version script to the linker. This is typically used when creating shared libraries to specify additional information about the version heirarchy for the library being created. This option is only meaningful on ELF platforms which support shared libraries. See section Version Script.
--warn-common
Warn when a common symbol is combined with another common symbol or with a symbol definition. Unix linkers allow this somewhat sloppy practice, but linkers on some other operating systems do not. This option allows you to find potential problems from combining global symbols. Unfortunately, some C libraries use this practice, so you may get some warnings about symbols in the libraries as well as in your programs. There are three kinds of global symbols, illustrated here by C examples:
`int i = 1;'
A definition, which goes in the initialized data section of the output file.
`extern int i;'
An undefined reference, which does not allocate space. There must be either a definition or a common symbol for the variable somewhere.
`int i;'
A common symbol. If there are only (one or more) common symbols for a variable, it goes in the uninitialized data area of the output file. The linker merges multiple common symbols for the same variable into a single symbol. If they are of different sizes, it picks the largest size. The linker turns a common symbol into a declaration, if there is a definition of the same variable.
The `--warn-common' option can produce five kinds of warnings. Each warning consists of a pair of lines: the first describes the symbol just encountered, and the second describes the previous symbol encountered with the same name. One or both of the two symbols will be a common symbol.
  1. Turning a common symbol into a reference, because there is already a definition for the symbol.
    file(section): warning: common of `symbol'
   overridden by definition
file(section): warning: defined here
  2. Turning a common symbol into a reference, because a later definition for the symbol is encountered. This is the same as the previous case, except that the symbols are encountered in a different order.
    file(section): warning: definition of `symbol'
   overriding common
file(section): warning: common is here
  3. Merging a common symbol with a previous same-sized common symbol.
    file(section): warning: multiple common
   of `symbol'
file(section): warning: previous common is here
  4. Merging a common symbol with a previous larger common symbol.
    file(section): warning: common of `symbol'
   overridden by larger common
file(section): warning: larger common is here
  5. Merging a common symbol with a previous smaller common symbol. This is the same as the previous case, except that the symbols are encountered in a different order.
    file(section): warning: common of `symbol'
   overriding smaller common
file(section): warning: smaller common is here
--warn-constructors
Warn if any global constructors are used. This is only useful for a few object file formats. For formats like COFF or ELF, the linker can not detect the use of global constructors.
--warn-multiple-gp
Warn if multiple global pointer values are required in the output file. This is only meaningful for certain processors, such as the Alpha. Specifically, some processors put large-valued constants in a special section. A special register (the global pointer) points into the middle of this section, so that constants can be loaded efficiently via a base-register relative addressing mode. Since the offset in base-register relative mode is fixed and relatively small (e.g., 16 bits), this limits the maximum size of the constant pool. Thus, in large programs, it is often necessary to use multiple global pointer values in order to be able to address all possible constants. This option causes a warning to be issued whenever this case occurs.
--warn-once
Only warn once for each undefined symbol, rather than once per module which refers to it.
--warn-section-align
Warn if the address of an output section is changed because of alignment. Typically, the alignment will be set by an input section. The address will only be changed if it not explicitly specified; that is, if the SECTIONS command does not specify a start address for the section (see section Specifying Output Sections).
--whole-archive
For each archive mentioned on the command line after the --whole-archive option, include every object file in the archive in the link, rather than searching the archive for the required object files. This is normally used to turn an archive file into a shared library, forcing every object to be included in the resulting shared library. This option may be used more than once.
--wrap symbol
Use a wrapper function for symbol. Any undefined reference to symbol will be resolved to __wrap_symbol. Any undefined reference to __real_symbol will be resolved to symbol. This can be used to provide a wrapper for a system function. The wrapper function should be called __wrap_symbol. If it wishes to call the system function, it should call __real_symbol. Here is a trivial example:
void *
__wrap_malloc (int c)
{
  printf ("malloc called with %ld\n", c);
  return __real_malloc (c);
}
If you link other code with this file using --wrap malloc, then all calls to malloc will call the function __wrap_malloc instead. The call to __real_malloc in __wrap_malloc will call the real malloc function. You may wish to provide a __real_malloc function as well, so that links without the --wrap option will succeed. If you do this, you should not put the definition of __real_malloc in the same file as __wrap_malloc; if you do, the assembler may resolve the call before the linker has a chance to wrap it to malloc.


Using LD, the GNU linker - Environment

Environment Variables

You can change the behavior of ld with the environment variables GNUTARGET and LDEMULATION. GNUTARGET determines the input-file object format if you don't use `-b' (or its synonym `--format'). Its value should be one of the BFD names for an input format (see section BFD). If there is no GNUTARGET in the environment, ld uses the natural format of the target. If GNUTARGET is set to default then BFD attempts to discover the input format by examining binary input files; this method often succeeds, but there are potential ambiguities, since there is no method of ensuring that the magic number used to specify object-file formats is unique. However, the configuration procedure for BFD on each system places the conventional format for that system first in the search-list, so ambiguities are resolved in favor of convention. LDEMULATION determines the default emulation if you don't use the `-m' option. The emulation can affect various aspects of linker behaviour, particularly the default linker script. You can list the available emulations with the `--verbose' or `-V' options. If the `-m' option is not used, and the LDEMULATION environment variable is not defined, the default emulation depends upon how the linker was configured.


Using LD, the GNU linker - Commands

Command Language

The command language provides explicit control over the link process, allowing complete specification of the mapping between the linker's input files and its output. It controls:

  • input files
  • file formats
  • output file layout
  • addresses of sections
  • placement of common blocks

You may supply a command file (also known as a linker script) to the linker either explicitly through the `-T' option, or implicitly as an ordinary file. Normally you should use the `-T' option. An implicit linker script should only be used when you want to augment, rather than replace, the default linker script; typically an implicit linker script would consist only of INPUT or GROUP commands. If the linker opens a file which it cannot recognize as a supported object or archive format, nor as a linker script, it reports an error.


Using LD, the GNU linker - Scripts

Linker Scripts

The ld command language is a collection of statements; some are simple keywords setting a particular option, some are used to select and group input files or name output files; and two statement types have a fundamental and pervasive impact on the linking process. The most fundamental command of the ld command language is the SECTIONS command (see section Specifying Output Sections). Every meaningful command script must have a SECTIONS command: it specifies a "picture" of the output file's layout, in varying degrees of detail. No other command is required in all cases. The MEMORY command complements SECTIONS by describing the available memory in the target architecture. This command is optional; if you don't use a MEMORY command, ld assumes sufficient memory is available in a contiguous block for all output. See section Memory Layout. You may include comments in linker scripts just as in C: delimited by `/*' and `*/'. As in C, comments are syntactically equivalent to whitespace.


Using LD, the GNU linker - Expressions

Expressions

Many useful commands involve arithmetic expressions. The syntax for expressions in the command language is identical to that of C expressions, with the following features:

  • All expressions evaluated as integers and are of "long" or "unsigned long" type.
  • All constants are integers.
  • All of the C arithmetic operators are provided.
  • You may reference, define, and create global variables.
  • You may call special purpose built-in functions.


Using LD, the GNU linker - Integers

Integers

An octal integer is `0' followed by zero or more of the octal digits (`01234567').

_as_octal = 0157255;

A decimal integer starts with a non-zero digit followed by zero or more digits (`0123456789').

_as_decimal = 57005;

A hexadecimal integer is `0x' or `0X' followed by one or more hexadecimal digits chosen from `0123456789abcdefABCDEF'.

_as_hex = 0xdead;

To write a negative integer, use the prefix operator `-' (see section Operators).

_as_neg = -57005;

Additionally the suffixes K and M may be used to scale a constant by respectively. For example, the following all refer to the same quantity:

        _fourk_1 = 4K;
        _fourk_2 = 4096;
        _fourk_3 = 0x1000;


Using LD, the GNU linker - Symbols

Symbol Names

Unless quoted, symbol names start with a letter, underscore, or point and may include any letters, underscores, digits, points, and hyphens. Unquoted symbol names must not conflict with any keywords. You can specify a symbol which contains odd characters or has the same name as a keyword, by surrounding the symbol name in double quotes:

        "SECTION" = 9;
        "with a space" = "also with a space" + 10;

Since symbols can contain many non-alphabetic characters, it is safest to delimit symbols with spaces. For example, `A-B' is one symbol, whereas `A - B' is an expression involving subtraction.


Using LD, the GNU linker - Location Counter

The Location Counter

The special linker variable dot `.' always contains the current output location counter. Since the . always refers to a location in an output section, it must always appear in an expression within a SECTIONS command. The . symbol may appear anywhere that an ordinary symbol is allowed in an expression, but its assignments have a side effect. Assigning a value to the . symbol will cause the location counter to be moved. This may be used to create holes in the output section. The location counter may never be moved backwards.

SECTIONS
{
  output :
  {
  file1(.text)
  . = . + 1000;
  file2(.text)
  . += 1000;
  file3(.text)
  } = 0x1234;
}

In the previous example, file1 is located at the beginning of the output section, then there is a 1000 byte gap. Then file2 appears, also with a 1000 byte gap following before file3 is loaded. The notation `= 0x1234' specifies what data to write in the gaps (see section Optional Section Attributes). @vfill


Using LD, the GNU linker - Operators

Operators

The linker recognizes the standard C set of arithmetic operators, with the standard bindings and precedence levels: { @obeylines@parskip=0pt@parindent=0pt @dag@quad Prefix operators. @ddag@quad See section Assignment: Defining Symbols. }


Using LD, the GNU linker - Evaluation

Evaluation

The linker uses "lazy evaluation" for expressions; it only calculates an expression when absolutely necessary. The linker needs the value of the start address, and the lengths of memory regions, in order to do any linking at all; these values are computed as soon as possible when the linker reads in the command file. However, other values (such as symbol values) are not known or needed until after storage allocation. Such values are evaluated later, when other information (such as the sizes of output sections) is available for use in the symbol assignment expression.


Using LD, the GNU linker - Assignment

Assignment: Defining Symbols

You may create global symbols, and assign values (addresses) to global symbols, using any of the C assignment operators:

symbol = expression ;
symbol &= expression ;
symbol += expression ;
symbol -= expression ;
symbol *= expression ;
symbol /= expression ;

Two things distinguish assignment from other operators in ld expressions.

  • Assignment may only be used at the root of an expression; `a=b+3;' is allowed, but `a+b=3;' is an error.
  • You must place a trailing semicolon (";") at the end of an assignment statement.

Assignment statements may appear:

  • as commands in their own right in an ld script; or
  • as independent statements within a SECTIONS command; or
  • as part of the contents of a section definition in a SECTIONS command.

The first two cases are equivalent in effect--both define a symbol with an absolute address. The last case defines a symbol whose address is relative to a particular section (see section Specifying Output Sections). When a linker expression is evaluated and assigned to a variable, it is given either an absolute or a relocatable type. An absolute expression type is one in which the symbol contains the value that it will have in the output file; a relocatable expression type is one in which the value is expressed as a fixed offset from the base of a section. The type of the expression is controlled by its position in the script file. A symbol assigned within a section definition is created relative to the base of the section; a symbol assigned in any other place is created as an absolute symbol. Since a symbol created within a section definition is relative to the base of the section, it will remain relocatable if relocatable output is requested. A symbol may be created with an absolute value even when assigned to within a section definition by using the absolute assignment function ABSOLUTE. For example, to create an absolute symbol whose address is the last byte of an output section named .data:

SECTIONS{ ...
  .data :
    {
      *(.data)
      _edata = ABSOLUTE(.) ;
    }
... }

The linker tries to put off the evaluation of an assignment until all the terms in the source expression are known (see section Evaluation). For instance, the sizes of sections cannot be known until after allocation, so assignments dependent upon these are not performed until after allocation. Some expressions, such as those depending upon the location counter dot, `.' must be evaluated during allocation. If the result of an expression is required, but the value is not available, then an error results. For example, a script like the following

SECTIONS { ...
  text 9+this_isnt_constant :
    { ...
    }
... }

will cause the error message "Non constant expression for initial address". In some cases, it is desirable for a linker script to define a symbol only if it is referenced, and only if it is not defined by any object included in the link. For example, traditional linkers defined the symbol `etext'. However, ANSI C requires that the user be able to use `etext' as a function name without encountering an error. The PROVIDE keyword may be used to define a symbol, such as `etext', only if it is referenced but not defined. The syntax is PROVIDE(symbol = expression).


Using LD, the GNU linker - Arithmetic Functions

Arithmetic Functions

The command language includes a number of built-in functions for use in link script expressions.

ABSOLUTE(exp)
Return the absolute (non-relocatable, as opposed to non-negative) value of the expression exp. Primarily useful to assign an absolute value to a symbol within a section definition, where symbol values are normally section-relative.
ADDR(section)
Return the absolute address of the named section. Your script must previously have defined the location of that section. In the following example, symbol_1 and symbol_2 are assigned identical values:
SECTIONS{ ...
  .output1 :
    {
    start_of_output_1 = ABSOLUTE(.);
    ...
    }
  .output :
    {
    symbol_1 = ADDR(.output1);
    symbol_2 = start_of_output_1;
    }
... }
LOADADDR(section)
Return the absolute load address of the named section. This is normally the same as ADDR, but it may be different if the AT keyword is used in the section definition (see section Optional Section Attributes).
ALIGN(exp)
Return the result of the current location counter (.) aligned to the next exp boundary. exp must be an expression whose value is a power of two. This is equivalent to
(. + exp - 1) & ~(exp - 1)
ALIGN doesn't change the value of the location counter--it just does arithmetic on it. As an example, to align the output .data section to the next 0x2000 byte boundary after the preceding section and to set a variable within the section to the next 0x8000 boundary after the input sections:
SECTIONS{ ...
  .data ALIGN(0x2000): {
    *(.data)
    variable = ALIGN(0x8000);
  }
... }
The first use of ALIGN in this example specifies the location of a section because it is used as the optional start attribute of a section definition (see section Optional Section Attributes). The second use simply defines the value of a variable. The built-in NEXT is closely related to ALIGN.
DEFINED(symbol)
Return 1 if symbol is in the linker global symbol table and is defined, otherwise return 0. You can use this function to provide default values for symbols. For example, the following command-file fragment shows how to set a global symbol begin to the first location in the .text section--but if a symbol called begin already existed, its value is preserved:
SECTIONS{ ...
  .text : {
    begin = DEFINED(begin) ? begin : . ;
    ...
  }
... }
NEXT(exp)
Return the next unallocated address that is a multiple of exp. This function is closely related to ALIGN(exp); unless you use the MEMORY command to define discontinuous memory for the output file, the two functions are equivalent.
SIZEOF(section)
Return the size in bytes of the named section, if that section has been allocated. In the following example, symbol_1 and symbol_2 are assigned identical values:
SECTIONS{ ...
  .output {
    .start = . ;
    ...
    .end = . ;
    }
  symbol_1 = .end - .start ;
  symbol_2 = SIZEOF(.output);
... }
SIZEOF_HEADERS
sizeof_headers
Return the size in bytes of the output file's headers. You can use this number as the start address of the first section, if you choose, to facilitate paging.
MAX(exp1, exp2)
Returns the maximum of exp1 and exp2.
MIN(exp1, exp2)
Returns the minimum of exp1 and exp2.


Using LD, the GNU linker - Semicolons

Semicolons

Semicolons (";") are required in the following places. In all other places they can appear for aesthetic reasons but are otherwise ignored.

Assignment
Semicolons must appear at the end of assignment expressions. See section Assignment: Defining Symbols
PHDRS
Semicolons must appear at the end of a PHDRS statement. See section ELF Program Headers


Using LD, the GNU linker - MEMORY

Memory Layout

The linker's default configuration permits allocation of all available memory. You can override this configuration by using the MEMORY command. The MEMORY command describes the location and size of blocks of memory in the target. By using it carefully, you can describe which memory regions may be used by the linker, and which memory regions it must avoid. The linker does not shuffle sections to fit into the available regions, but does move the requested sections into the correct regions and issue errors when the regions become too full. A command file may contain at most one use of the MEMORY command; however, you can define as many blocks of memory within it as you wish. The syntax is:

MEMORY
  {
    name (attr) : ORIGIN = origin, LENGTH = len
    ...
  }
name
is a name used internally by the linker to refer to the region. Any symbol name may be used. The region names are stored in a separate name space, and will not conflict with symbols, file names or section names. Use distinct names to specify multiple regions.
(attr)
is an optional list of attributes that specify whether to use a particular memory to place sections that are not listed in the linker script. Valid attribute lists must be made up of the characters "ALIRWX" that match section attributes. If you omit the attribute list, you may omit the parentheses around it as well. The attributes currently supported are:
`Letter'
Section Attribute
`R'
Read-only sections.
`W'
Read/write sections.
`X'
Sections containing executable code.
`A'
Allocated sections.
`I'
Initialized sections.
`L'
Same as I.
`!'
Invert the sense of any of the following attributes.
origin
is the start address of the region in physical memory. It is an expression that must evaluate to a constant before memory allocation is performed. The keyword ORIGIN may be abbreviated to org or o (but not, for example, `ORG').
len
is the size in bytes of the region (an expression). The keyword LENGTH may be abbreviated to len or l.

For example, to specify that memory has two regions available for allocation--one starting at 0 for 256 kilobytes, and the other starting at 0x40000000 for four megabytes. The rom memory region will get all sections without an explicit memory register that are either read-only or contain code, while the ram memory region will get the sections.

MEMORY
  {
  rom (rx)  : ORIGIN = 0, LENGTH = 256K
  ram (!rx) : org = 0x40000000, l = 4M
  }

Once you have defined a region of memory named mem, you can direct specific output sections there by using a command ending in `>mem' within the SECTIONS command (see section Optional Section Attributes). If the combined output sections directed to a region are too big for the region, the linker will issue an error message.


Using LD, the GNU linker - SECTIONS

Specifying Output Sections

The SECTIONS command controls exactly where input sections are placed into output sections, their order in the output file, and to which output sections they are allocated. You may use at most one SECTIONS command in a script file, but you can have as many statements within it as you wish. Statements within the SECTIONS command can do one of three things:

  • define the entry point;
  • assign a value to a symbol;
  • describe the placement of a named output section, and which input sections go into it.

You can also use the first two operations--defining the entry point and defining symbols--outside the SECTIONS command: see section The Entry Point, and section Assignment: Defining Symbols. They are permitted here as well for your convenience in reading the script, so that symbols and the entry point can be defined at meaningful points in your output-file layout. If you do not use a SECTIONS command, the linker places each input section into an identically named output section in the order that the sections are first encountered in the input files. If all input sections are present in the first file, for example, the order of sections in the output file will match the order in the first input file.


Using LD, the GNU linker - Section Definition

Section Definitions

The most frequently used statement in the SECTIONS command is the section definition, which specifies the properties of an output section: its location, alignment, contents, fill pattern, and target memory region. Most of these specifications are optional; the simplest form of a section definition is

SECTIONS { ...
  secname : {
    contents
  }
... }

secname is the name of the output section, and contents a specification of what goes there--for example, a list of input files or sections of input files (see section Section Placement). The whitespace around secname is required, so that the section name is unambiguous. The other whitespace shown is optional. You do need the colon `:' and the braces `{}', however. secname must meet the constraints of your output format. In formats which only support a limited number of sections, such as a.out, the name must be one of the names supported by the format (a.out, for example, allows only .text, .data or .bss). If the output format supports any number of sections, but with numbers and not names (as is the case for Oasys), the name should be supplied as a quoted numeric string. A section name may consist of any sequence of characters, but any name which does not conform to the standard ld symbol name syntax must be quoted. See section Symbol Names. The special secname `/DISCARD/' may be used to discard input sections. Any sections which are assigned to an output section named `/DISCARD/' are not included in the final link output. The linker will not create output sections which do not have any contents. This is for convenience when referring to input sections that may or may not exist. For example,

.foo { *(.foo) }

will only create a `.foo' section in the output file if there is a `.foo' section in at least one input file.


Using LD, the GNU linker - Section Placement

Section Placement

In a section definition, you can specify the contents of an output section by listing particular input files, by listing particular input-file sections, or by a combination of the two. You can also place arbitrary data in the section, and define symbols relative to the beginning of the section. The contents of a section definition may include any of the following kinds of statement. You can include as many of these as you like in a single section definition, separated from one another by whitespace.

filename
You may simply name a particular input file to be placed in the current output section; all sections from that file are placed in the current section definition. If the file name has already been mentioned in another section definition, with an explicit section name list, then only those sections which have not yet been allocated are used. To specify a list of particular files by name:
.data : { afile.o bfile.o cfile.o }
The example also illustrates that multiple statements can be included in the contents of a section definition, since each file name is a separate statement.
filename( section )
filename( section , section, ... )
filename( section section ... )
You can name one or more sections from your input files, for insertion in the current output section. If you wish to specify a list of input-file sections inside the parentheses, separate the section names with whitespace.
* (section)
* (section, section, ...)
* (section section ...)
Instead of explicitly naming particular input files in a link control script, you can refer to all files from the ld command line: use `*' instead of a particular file name before the parenthesized input-file section list. If you have already explicitly included some files by name, `*' refers to all remaining files--those whose places in the output file have not yet been defined. For example, to copy sections 1 through 4 from an Oasys file into the .text section of an a.out file, and sections 13 and 14 into the .data section:
SECTIONS {
  .text :{
    *("1" "2" "3" "4")
  }

  .data :{
    *("13" "14")
  }
}
`[ section ... ]' used to be accepted as an alternate way to specify named sections from all unallocated input files. Because some operating systems (VMS) allow brackets in file names, that notation is no longer supported.
filename( COMMON )
*( COMMON )
Specify where in your output file to place uninitialized data with this notation. *(COMMON) by itself refers to all uninitialized data from all input files (so far as it is not yet allocated); filename(COMMON) refers to uninitialized data from a particular file. Both are special cases of the general mechanisms for specifying where to place input-file sections: ld permits you to refer to uninitialized data as if it were in an input-file section named COMMON, regardless of the input file's format.

In any place where you may use a specific file or section name, you may also use a wildcard pattern. The linker handles wildcards much as the Unix shell does. A `*' character matches any number of characters. A `?' character matches any single character. The sequence `[chars]' will match a single instance of any of the chars; the `-' character may be used to specify a range of characters, as in `[a-z]' to match any lower case letter. A `\' character may be used to quote the following character. When a file name is matched with a wildcard, the wildcard characters will not match a `/' character (used to separate directory names on Unix). A pattern consisting of a single `*' character is an exception; it will always match any file name. In a section name, the wildcard characters will match a `/' character. Wildcards only match files which are explicitly specified on the command line. The linker does not search directories to expand wildcards. However, if you specify a simple file name--a name with no wildcard characters--in a linker script, and the file name is not also specified on the command line, the linker will attempt to open the file as though it appeared on the command line. In the following example, the command script arranges the output file into three consecutive sections, named .text, .data, and .bss, taking the input for each from the correspondingly named sections of all the input files:

SECTIONS {
  .text : { *(.text) }
  .data : { *(.data) }
  .bss :  { *(.bss)  *(COMMON) }
}

The following example reads all of the sections from file all.o and places them at the start of output section outputa which starts at location 0x10000. All of section .input1 from file foo.o follows immediately, in the same output section. All of section .input2 from foo.o goes into output section outputb, followed by section .input1 from foo1.o. All of the remaining .input1 and .input2 sections from any files are written to output section outputc.

SECTIONS {
  outputa 0x10000 :
    {
    all.o
    foo.o (.input1)
    }
  outputb :
    {
    foo.o (.input2)
    foo1.o (.input1)
    }
  outputc :
    {
    *(.input1)
    *(.input2)
    }
}

This example shows how wildcard patterns might be used to partition files. All .text sections are placed in .text, and all .bss sections are placed in .bss. For all files beginning with an upper case character, the .data section is placed into .DATA; for all other files, the .data section is placed into .data.

SECTIONS {
  .text : { *(.text) }
  .DATA : { [A-Z]*(.data) }
  .data : { *(.data) }
  .bss : { *(.bss) }
}


Using LD, the GNU linker - Section Data Expressions

Section Data Expressions

The foregoing statements arrange, in your output file, data originating from your input files. You can also place data directly in an output section from the link command script. Most of these additional statements involve expressions (see section Expressions). Although these statements are shown separately here for ease of presentation, no such segregation is needed within a section definition in the SECTIONS command; you can intermix them freely with any of the statements we've just described.

CREATE_OBJECT_SYMBOLS
Create a symbol for each input file in the current section, set to the address of the first byte of data written from that input file. For instance, with a.out files it is conventional to have a symbol for each input file. You can accomplish this by defining the output .text section as follows:
SECTIONS {
  .text 0x2020 :
     {
    CREATE_OBJECT_SYMBOLS
    *(.text)
    _etext = ALIGN(0x2000);
    }
  ...
}
If sample.ld is a file containing this script, and a.o, b.o, c.o, and d.o are four input files with contents like the following---
/* a.c */

afunction() { }
int adata=1;
int abss;
`ld -M -T sample.ld a.o b.o c.o d.o' would create a map like this, containing symbols matching the object file names:
00000000 A __DYNAMIC
00004020 B _abss
00004000 D _adata
00002020 T _afunction
00004024 B _bbss
00004008 D _bdata
00002038 T _bfunction
00004028 B _cbss
00004010 D _cdata
00002050 T _cfunction
0000402c B _dbss
00004018 D _ddata
00002068 T _dfunction
00004020 D _edata
00004030 B _end
00004000 T _etext
00002020 t a.o
00002038 t b.o
00002050 t c.o
00002068 t d.o
symbol = expression ;
symbol f= expression ;
symbol is any symbol name (see section Symbol Names). "f=" refers to any of the operators &= += -= *= /= which combine arithmetic and assignment. When you assign a value to a symbol within a particular section definition, the value is relative to the beginning of the section (see section Assignment: Defining Symbols). If you write
SECTIONS {
  abs = 14 ;
  ...
  .data : { ... rel = 14 ; ... }
  abs2 = 14 + ADDR(.data);
  ...
}
abs and rel do not have the same value; rel has the same value as abs2.
BYTE(expression)
SHORT(expression)
LONG(expression)
QUAD(expression)
SQUAD(expression)
By including one of these four statements in a section definition, you can explicitly place one, two, four, eight unsigned, or eight signed bytes (respectively) at the current address of that section. When using a 64 bit host or target, QUAD and SQUAD are the same. When both host and target are 32 bits, QUAD uses an unsigned 32 bit value, and SQUAD sign extends the value. Both will use the correct endianness when writing out the value. Multiple-byte quantities are represented in whatever byte order is appropriate for the output file format (see section BFD).
FILL(expression)
Specify the "fill pattern" for the current section. Any otherwise unspecified regions of memory within the section (for example, regions you skip over by assigning a new value to the location counter `.') are filled with the two least significant bytes from the expression argument. A FILL statement covers memory locations after the point it occurs in the section definition; by including more than one FILL statement, you can have different fill patterns in different parts of an output section.


Using LD, the GNU linker - Section Options

Optional Section Attributes

Here is the full syntax of a section definition, including all the optional portions:

SECTIONS {
...
secname start BLOCK(align) (NOLOAD) : AT ( ldadr )
  { contents } >region :phdr =fill
...
}

secname and contents are required. See section Section Definitions, and section Section Placement, for details on contents. The remaining elements---start, BLOCK(align), (NOLOAD), AT ( ldadr ), >region, :phdr, and =fill---are all optional.

start
You can force the output section to be loaded at a specified address by specifying start immediately following the section name. start can be represented as any expression. The following example generates section output at location 0x40000000:
SECTIONS {
  ...
  output 0x40000000: {
    ...
    }
  ...
}
BLOCK(align)
You can include BLOCK() specification to advance the location counter . prior to the beginning of the section, so that the section will begin at the specified alignment. align is an expression.
(NOLOAD)
The `(NOLOAD)' directive will mark a section to not be loaded at run time. The linker will process the section normally, but will mark it so that a program loader will not load it into memory. For example, in the script sample below, the ROM section is addressed at memory location `0' and does not need to be loaded when the program is run. The contents of the ROM section will appear in the linker output file as usual.
SECTIONS {
  ROM  0  (NOLOAD)  : { ... }
  ...
}
AT ( ldadr )
The expression ldadr that follows the AT keyword specifies the load address of the section. The default (if you do not use the AT keyword) is to make the load address the same as the relocation address. This feature is designed to make it easy to build a ROM image. For example, this SECTIONS definition creates two output sections: one called `.text', which starts at 0x1000, and one called `.mdata', which is loaded at the end of the `.text' section even though its relocation address is 0x2000. The symbol _data is defined with the value 0x2000:
SECTIONS
  {
  .text 0x1000 : { *(.text) _etext = . ; }
  .mdata 0x2000 :
    AT ( ADDR(.text) + SIZEOF ( .text ) )
    { _data = . ; *(.data); _edata = . ;  }
  .bss 0x3000 :
    { _bstart = . ;  *(.bss) *(COMMON) ; _bend = . ;}
}
The run-time initialization code (for C programs, usually crt0) for use with a ROM generated this way has to include something like the following, to copy the initialized data from the ROM image to its runtime address:
char *src = _etext;
char *dst = _data;

/* ROM has data at end of text; copy it. */
while (dst < _edata) {
  *dst++ = *src++;
}

/* Zero bss */
for (dst = _bstart; dst< _bend; dst++)
  *dst = 0;
>region
Assign this section to a previously defined region of memory. See section Memory Layout.
:phdr
Assign this section to a segment described by a program header. See section ELF Program Headers. If a section is assigned to one or more segments, then all subsequent allocated sections will be assigned to those segments as well, unless they use an explicitly :phdr modifier. To prevent a section from being assigned to a segment when it would normally default to one, use :NONE.
=fill
Including =fill in a section definition specifies the initial fill value for that section. You may use any expression to specify fill. Any unallocated holes in the current output section when written to the output file will be filled with the two least significant bytes of the value, repeated as necessary. You can also change the fill value with a FILL statement in the contents of a section definition.


Using LD, the GNU linker - Overlays

Overlays

The OVERLAY command provides an easy way to describe sections which are to be loaded as part of a single memory image but are to be run at the same memory address. At run time, some sort of overlay manager will copy the overlaid sections in and out of the runtime memory address as required, perhaps by simply manipulating addressing bits. This approach can be useful, for example, when a certain region of memory is faster than another. The OVERLAY command is used within a SECTIONS command. It appears as follows:

  OVERLAY start : [ NOCROSSREFS ] AT ( ldaddr )
   {
     secname1 { contents } :phdr =fill
     secname2 { contents } :phdr =fill
     ...
   } >region :phdr =fill

Everything is optional except OVERLAY (a keyword), and each section must have a name (secname1 and secname2 above). The section definitions within the OVERLAY construct are identical to those within the general SECTIONS contruct (see section Specifying Output Sections), except that no addresses and no memory regions may be defined for sections within an OVERLAY. The sections are all defined with the same starting address. The load addresses of the sections are arranged such that they are consecutive in memory starting at the load address used for the OVERLAY as a whole (as with normal section definitions, the load address is optional, and defaults to the start address; the start address is also optional, and defaults to .). If the NOCROSSREFS keyword is used, and there any references among the sections, the linker will report an error. Since the sections all run at the same address, it normally does not make sense for one section to refer directly to another. See section Option Commands. For each section within the OVERLAY, the linker automatically defines two symbols. The symbol __load_start_secname is defined as the starting load address of the section. The symbol __load_stop_secname is defined as the final load address of the section. Any characters within secname which are not legal within C identifiers are removed. C (or assembler) code may use these symbols to move the overlaid sections around as necessary. At the end of the overlay, the value of . is set to the start address of the overlay plus the size of the largest section. Here is an example. Remember that this would appear inside a SECTIONS construct.

  OVERLAY 0x1000 : AT (0x4000)
   {
     .text0 { o1/*.o(.text) }
     .text1 { o2/*.o(.text) }
   }

This will define both .text0 and .text1 to start at address 0x1000. .text0 will be loaded at address 0x4000, and .text1 will be loaded immediately after .text0. The following symbols will be defined: __load_start_text0, __load_stop_text0, __load_start_text1, __load_stop_text1. C code to copy overlay .text1 into the overlay area might look like the following.

  extern char __load_start_text1, __load_stop_text1;
  memcpy ((char *) 0x1000, &__load_start_text1,
          &__load_stop_text1 - &__load_start_text1);

Note that the OVERLAY command is just syntactic sugar, since everything it does can be done using the more basic commands. The above example could have been written identically as follows.

  .text0 0x1000 : AT (0x4000) { o1/*.o(.text) }
  __load_start_text0 = LOADADDR (.text0);
  __load_stop_text0 = LOADADDR (.text0) + SIZEOF (.text0);
  .text1 0x1000 : AT (0x4000 + SIZEOF (.text0)) { o2/*.o(.text) }
  __load_start_text1 = LOADADDR (.text1);
  __load_stop_text1 = LOADADDR (.text1) + SIZEOF (.text1);
  . = 0x1000 + MAX (SIZEOF (.text0), SIZEOF (.text1));


Using LD, the GNU linker - PHDRS

ELF Program Headers

The ELF object file format uses program headers, which are read by the system loader and describe how the program should be loaded into memory. These program headers must be set correctly in order to run the program on a native ELF system. The linker will create reasonable program headers by default. However, in some cases, it is desirable to specify the program headers more precisely; the PHDRS command may be used for this purpose. When the PHDRS command is used, the linker will not generate any program headers itself. The PHDRS command is only meaningful when generating an ELF output file. It is ignored in other cases. This manual does not describe the details of how the system loader interprets program headers; for more information, see the ELF ABI. The program headers of an ELF file may be displayed using the `-p' option of the objdump command. This is the syntax of the PHDRS command. The words PHDRS, FILEHDR, AT, and FLAGS are keywords.

PHDRS
{
  name type [ FILEHDR ] [ PHDRS ] [ AT ( address ) ]
        [ FLAGS ( flags ) ] ;
}

The name is used only for reference in the SECTIONS command of the linker script. It does not get put into the output file. Certain program header types describe segments of memory which are loaded from the file by the system loader. In the linker script, the contents of these segments are specified by directing allocated output sections to be placed in the segment. To do this, the command describing the output section in the SECTIONS command should use `:name', where name is the name of the program header as it appears in the PHDRS command. See section Optional Section Attributes. It is normal for certain sections to appear in more than one segment. This merely implies that one segment of memory contains another. This is specified by repeating `:name', using it once for each program header in which the section is to appear. If a section is placed in one or more segments using `:name', then all subsequent allocated sections which do not specify `:name' are placed in the same segments. This is for convenience, since generally a whole set of contiguous sections will be placed in a single segment. To prevent a section from being assigned to a segment when it would normally default to one, use :NONE. The FILEHDR and PHDRS keywords which may appear after the program header type also indicate contents of the segment of memory. The FILEHDR keyword means that the segment should include the ELF file header. The PHDRS keyword means that the segment should include the ELF program headers themselves. The type may be one of the following. The numbers indicate the value of the keyword.

PT_NULL (0)
Indicates an unused program header.
PT_LOAD (1)
Indicates that this program header describes a segment to be loaded from the file.
PT_DYNAMIC (2)
Indicates a segment where dynamic linking information can be found.
PT_INTERP (3)
Indicates a segment where the name of the program interpreter may be found.
PT_NOTE (4)
Indicates a segment holding note information.
PT_SHLIB (5)
A reserved program header type, defined but not specified by the ELF ABI.
PT_PHDR (6)
Indicates a segment where the program headers may be found.
expression
An expression giving the numeric type of the program header. This may be used for types not defined above.

It is possible to specify that a segment should be loaded at a particular address in memory. This is done using an AT expression. This is identical to the AT command used in the SECTIONS command (see section Optional Section Attributes). Using the AT command for a program header overrides any information in the SECTIONS command. Normally the segment flags are set based on the sections. The FLAGS keyword may be used to explicitly specify the segment flags. The value of flags must be an integer. It is used to set the p_flags field of the program header. Here is an example of the use of PHDRS. This shows a typical set of program headers used on a native ELF system.

PHDRS
{
  headers PT_PHDR PHDRS ;
  interp PT_INTERP ;
  text PT_LOAD FILEHDR PHDRS ;
  data PT_LOAD ;
  dynamic PT_DYNAMIC ;
}

SECTIONS
{
  . = SIZEOF_HEADERS;
  .interp : { *(.interp) } :text :interp
  .text : { *(.text) } :text
  .rodata : { *(.rodata) } /* defaults to :text */
  ...
  . = . + 0x1000; /* move to a new page in memory */
  .data : { *(.data) } :data
  .dynamic : { *(.dynamic) } :data :dynamic
  ...
}


Using LD, the GNU linker - Entry Point

The Entry Point

The linker command language includes a command specifically for defining the first executable instruction in an output file (its entry point). Its argument is a symbol name:

ENTRY(symbol)

Like symbol assignments, the ENTRY command may be placed either as an independent command in the command file, or among the section definitions within the SECTIONS command--whatever makes the most sense for your layout. ENTRY is only one of several ways of choosing the entry point. You may indicate it in any of the following ways (shown in descending order of priority: methods higher in the list override methods lower down).

  • the `-e' entry command-line option;
  • the ENTRY(symbol) command in a linker control script;
  • the value of the symbol start, if present;
  • the address of the first byte of the .text section, if present;
  • The address 0.

For example, you can use these rules to generate an entry point with an assignment statement: if no symbol start is defined within your input files, you can simply define it, assigning it an appropriate value---

start = 0x2020;

The example shows an absolute address, but you can use any expression. For example, if your input object files use some other symbol-name convention for the entry point, you can just assign the value of whatever symbol contains the start address to start:

start = other_symbol ;


Using LD, the GNU linker - Version Script

Version Script

The linker command script includes a command specifically for specifying a version script, and is only meaningful for ELF platforms that support shared libraries. A version script can be build directly into the linker script that you are using, or you can supply the version script as just another input file to the linker at the time that you link. The command script syntax is:

VERSION { version script contents }

The version script can also be specified to the linker by means of the `--version-script' linker command line option. Version scripts are only meaningful when creating shared libraries. The format of the version script itself is identical to that used by Sun's linker in Solaris 2.5. Versioning is done by defining a tree of version nodes with the names and interdependencies specified in the version script. The version script can specify which symbols are bound to which version nodes, and it can reduce a specified set of symbols to local scope so that they are not globally visible outside of the shared library. The easiest way to demonstrate the version script language is with a few examples.

VERS_1.1 {
     global:
         foo1;
     local:
         old*;
         original*;
         new*;
};

VERS_1.2 {
         foo2;
} VERS_1.1;

VERS_2.0 {
         bar1; bar2;
} VERS_1.2;

In this example, three version nodes are defined. `VERS_1.1' is the first version node defined, and has no other dependencies. The symbol `foo1' is bound to this version node, and a number of symbols that have appeared within various object files are reduced in scope to local so that they are not visible outside of the shared library. Next, the node `VERS_1.2' is defined. It depends upon `VERS_1.1'. The symbol `foo2' is bound to this version node. Finally, the node `VERS_2.0' is defined. It depends upon `VERS_1.2'. The symbols `bar1' and `bar2' are bound to this version node. Symbols defined in the library which aren't specifically bound to a version node are effectively bound to an unspecified base version of the library. It is possible to bind all otherwise unspecified symbols to a given version node using `global: *' somewhere in the version script. Lexically the names of the version nodes have no specific meaning other than what they might suggest to the person reading them. The `2.0' version could just as well have appeared in between `1.1' and `1.2'. However, this would be a confusing way to write a version script. When you link an application against a shared library that has versioned symbols, the application itself knows which version of each symbol it requires, and it also knows which version nodes it needs from each shared library it is linked against. Thus at runtime, the dynamic loader can make a quick check to make sure that the libraries you have linked against do in fact supply all of the version nodes that the application will need to resolve all of the dynamic symbols. In this way it is possible for the dynamic linker to know with certainty that all external symbols that it needs will be resolvable without having to search for each symbol reference. The symbol versioning is in effect a much more sophisticated way of doing minor version checking that SunOS does. The fundamental problem that is being addressed here is that typically references to external functions are bound on an as-needed basis, and are not all bound when the application starts up. If a shared library is out of date, a required interface may be missing; when the application tries to use that interface, it may suddenly and unexpectedly fail. With symbol versioning, the user will get a warning when they start their program if the libraries being used with the application are too old. There are several GNU extensions to Sun's versioning approach. The first of these is the ability to bind a symbol to a version node in the source file where the symbol is defined instead of in the versioning script. This was done mainly to reduce the burden on the library maintainer. This can be done by putting something like:

__asm__(".symver original_foo,foo@VERS_1.1");

in the C source file. This renamed the function `original_foo' to be an alias for `foo' bound to the version node `VERS_1.1'. The `local:' directive can be used to prevent the symbol `original_foo' from being exported. The second GNU extension is to allow multiple versions of the same function to appear in a given shared library. In this way an incompatible change to an interface can take place without increasing the major version number of the shared library, while still allowing applications linked against the old interface to continue to function. This can only be accomplished by using multiple `.symver' directives in the assembler. An example of this would be:

__asm__(".symver original_foo,foo@");
__asm__(".symver old_foo,foo@VERS_1.1");
__asm__(".symver old_foo1,foo@VERS_1.2");
__asm__(".symver new_foo,foo@@VERS_2.0");

In this example, `foo@' represents the symbol `foo' bound to the unspecified base version of the symbol. The source file that contains this example would define 4 C functions: `original_foo', `old_foo', `old_foo1', and `new_foo'. When you have multiple definitions of a given symbol, there needs to be some way to specify a default version to which external references to this symbol will be bound. This can be accomplished with the `foo@@VERS_2.0' type of `.symver' directive. Only one version of a symbol can be declared 'default' in this manner - otherwise you would effectively have multiple definitions of the same symbol. If you wish to bind a reference to a specific version of the symbol within the shared library, you can use the aliases of convenience (i.e. `old_foo'), or you can use the `.symver' directive to specifically bind to an external version of the function in question.


Using LD, the GNU linker - Option Commands

Option Commands

The command language includes a number of other commands that you can use for specialized purposes. They are similar in purpose to command-line options.

CONSTRUCTORS
When linking using the a.out object file format, the linker uses an unusual set construct to support C++ global constructors and destructors. When linking object file formats which do not support arbitrary sections, such as ECOFF and XCOFF, the linker will automatically recognize C++ global constructors and destructors by name. For these object file formats, the CONSTRUCTORS command tells the linker where this information should be placed. The CONSTRUCTORS command is ignored for other object file formats. The symbol __CTOR_LIST__ marks the start of the global constructors, and the symbol __DTOR_LIST marks the end. The first word in the list is the number of entries, followed by the address of each constructor or destructor, followed by a zero word. The compiler must arrange to actually run the code. For these object file formats GNU C++ calls constructors from a subroutine __main; a call to __main is automatically inserted into the startup code for main. GNU C++ runs destructors either by using atexit, or directly from the function exit. For object file formats such as COFF or ELF which support multiple sections, GNU C++ will normally arrange to put the addresses of global constructors and destructors into the .ctors and .dtors sections. Placing the following sequence into your linker script will build the sort of table which the GNU C++ runtime code expects to see.
      __CTOR_LIST__ = .;
      LONG((__CTOR_END__ - __CTOR_LIST__) / 4 - 2)
      *(.ctors)
      LONG(0)
      __CTOR_END__ = .;
      __DTOR_LIST__ = .;
      LONG((__DTOR_END__ - __DTOR_LIST__) / 4 - 2)
      *(.dtors)
      LONG(0)
      __DTOR_END__ = .;
Normally the compiler and linker will handle these issues automatically, and you will not need to concern yourself with them. However, you may need to consider this if you are using C++ and writing your own linker scripts.
FLOAT
NOFLOAT
These keywords were used in some older linkers to request a particular math subroutine library. ld doesn't use the keywords, assuming instead that any necessary subroutines are in libraries specified using the general mechanisms for linking to archives; but to permit the use of scripts that were written for the older linkers, the keywords FLOAT and NOFLOAT are accepted and ignored.
FORCE_COMMON_ALLOCATION
This command has the same effect as the `-d' command-line option: to make ld assign space to common symbols even if a relocatable output file is specified (`-r').
INCLUDE filename
Include the linker script filename at this point. The file will be searched for in the current directory, and in any directory specified with the -L option. You can nest calls to INCLUDE up to 10 levels deep.
INPUT ( file, file, ... )
INPUT ( file file ... )
Use this command to include binary input files in the link, without including them in a particular section definition. Specify the full name for each file, including `.a' if required. ld searches for each file through the archive-library search path, just as for files you specify on the command line. See the description of `-L' in section Command Line Options. If you use `-lfile', ld will transform the name to libfile.a as with the command line argument `-l'.
GROUP ( file, file, ... )
GROUP ( file file ... )
This command is like INPUT, except that the named files should all be archives, and they are searched repeatedly until no new undefined references are created. See the description of `-(' in section Command Line Options.
OUTPUT ( filename )
Use this command to name the link output file filename. The effect of OUTPUT(filename) is identical to the effect of `-o filename', which overrides it. You can use this command to supply a default output-file name other than a.out.
OUTPUT_ARCH ( bfdname )
Specify a particular output machine architecture, with one of the names used by the BFD back-end routines (see section BFD). This command is often unnecessary; the architecture is most often set implicitly by either the system BFD configuration or as a side effect of the OUTPUT_FORMAT command.
OUTPUT_FORMAT ( bfdname )
When ld is configured to support multiple object code formats, you can use this command to specify a particular output format. bfdname is one of the names used by the BFD back-end routines (see section BFD). The effect is identical to the effect of the `--oformat' command-line option. This selection affects only the output file; the related command TARGET affects primarily input files.
SEARCH_DIR ( path )
Add path to the list of paths where ld looks for archive libraries. SEARCH_DIR(path) has the same effect as `-Lpath' on the command line.
STARTUP ( filename )
Ensure that filename is the first input file used in the link process.
TARGET ( format )
When ld is configured to support multiple object code formats, you can use this command to change the input-file object code format (like the command-line option `-b' or its synonym `--format'). The argument format is one of the strings used by BFD to name binary formats. If TARGET is specified but OUTPUT_FORMAT is not, the last TARGET argument is also used as the default format for the ld output file. See section BFD. If you don't use the TARGET command, ld uses the value of the environment variable GNUTARGET, if available, to select the output file format. If that variable is also absent, ld uses the default format configured for your machine in the BFD libraries.
NOCROSSREFS ( section section ... )
This command may be used to tell ld to issue an error about any references among certain sections. In certain types of programs, particularly on embedded systems, when one section is loaded into memory, another section will not be. Any direct references between the two sections would be errors. For example, it would be an error if code in one section called a function defined in the other section. The NOCROSSREFS command takes a list of section names. If ld detects any cross references between the sections, it reports an error and returns a non-zero exit status. The NOCROSSREFS command uses output section names, defined in the SECTIONS command. It does not use the names of input sections.


Using LD, the GNU linker - Machine Dependent

Machine Dependent Features

ld has additional features on some platforms; the following sections describe them. Machines where ld has no additional functionality are not listed.


Using LD, the GNU linker - H8/300

ld and the H8/300

For the H8/300, ld can perform these global optimizations when you specify the `--relax' command-line option.

relaxing address modes
ld finds all jsr and jmp instructions whose targets are within eight bits, and turns them into eight-bit program-counter relative bsr and bra instructions, respectively.
synthesizing instructions
ld finds all mov.b instructions which use the sixteen-bit absolute address form, but refer to the top page of memory, and changes them to use the eight-bit address form. (That is: the linker turns `mov.b @aa:16' into `mov.b @aa:8' whenever the address aa is in the top page of memory).


Using LD, the GNU linker - i960

ld and the Intel 960 family

You can use the `-Aarchitecture' command line option to specify one of the two-letter names identifying members of the 960 family; the option specifies the desired output target, and warns of any incompatible instructions in the input files. It also modifies the linker's search strategy for archive libraries, to support the use of libraries specific to each particular architecture, by including in the search loop names suffixed with the string identifying the architecture. For example, if your ld command line included `-ACA' as well as `-ltry', the linker would look (in its built-in search paths, and in any paths you specify with `-L') for a library with the names

try
libtry.a
tryca
libtryca.a

The first two possibilities would be considered in any event; the last two are due to the use of `-ACA'. You can meaningfully use `-A' more than once on a command line, since the 960 architecture family allows combination of target architectures; each use will add another pair of name variants to search for when `-l' specifies a library. ld supports the `--relax' option for the i960 family. If you specify `--relax', ld finds all balx and calx instructions whose targets are within 24 bits, and turns them into 24-bit program-counter relative bal and cal instructions, respectively. ld also turns cal instructions into bal instructions when it determines that the target subroutine is a leaf routine (that is, the target subroutine does not itself call any subroutines).


Using LD, the GNU linker - BFD

BFD

The linker accesses object and archive files using the BFD libraries. These libraries allow the linker to use the same routines to operate on object files whatever the object file format. A different object file format can be supported simply by creating a new BFD back end and adding it to the library. To conserve runtime memory, however, the linker and associated tools are usually configured to support only a subset of the object file formats available. You can use objdump -i (see section `objdump' in The GNU Binary Utilities) to list all the formats available for your configuration. As with most implementations, BFD is a compromise between several conflicting requirements. The major factor influencing BFD design was efficiency: any time used converting between formats is time which would not have been spent had BFD not been involved. This is partly offset by abstraction payback; since BFD simplifies applications and back ends, more time and care may be spent optimizing algorithms for a greater speed. One minor artifact of the BFD solution which you should bear in mind is the potential for information loss. There are two places where useful information can be lost using the BFD mechanism: during conversion and during output. See section Information Loss.


Using LD, the GNU linker - BFD outline

How it works: an outline of BFD

When an object file is opened, BFD subroutines automatically determine the format of the input object file. They then build a descriptor in memory with pointers to routines that will be used to access elements of the object file's data structures.

As different information from the the object files is required, BFD reads from different sections of the file and processes them. For example, a very common operation for the linker is processing symbol tables. Each BFD back end provides a routine for converting between the object file's representation of symbols and an internal canonical format. When the linker asks for the symbol table of an object file, it calls through a memory pointer to the routine from the relevant BFD back end which reads and converts the table into a canonical form. The linker then operates upon the canonical form. When the link is finished and the linker writes the output file's symbol table, another BFD back end routine is called to take the newly created symbol table and convert it into the chosen output format.


Using LD, the GNU linker - BFD information loss

Information Loss

Information can be lost during output. The output formats supported by BFD do not provide identical facilities, and information which can be described in one form has nowhere to go in another format. One example of this is alignment information in b.out. There is nowhere in an a.out format file to store alignment information on the contained data, so when a file is linked from b.out and an a.out image is produced, alignment information will not propagate to the output file. (The linker will still use the alignment information internally, so the link is performed correctly).

Another example is COFF section names. COFF files may contain an unlimited number of sections, each one with a textual section name. If the target of the link is a format which does not have many sections (e.g., a.out) or has sections without names (e.g., the Oasys format), the link cannot be done simply. You can circumvent this problem by describing the desired input-to-output section mapping with the linker command language.

Information can be lost during canonicalization. The BFD internal canonical form of the external formats is not exhaustive; there are structures in input formats for which there is no direct representation internally. This means that the BFD back ends cannot maintain all possible data richness through the transformation between external to internal and back to external formats.

This limitation is only a problem when an application reads one format and writes another. Each BFD back end is responsible for maintaining as much data as possible, and the internal BFD canonical form has structures which are opaque to the BFD core, and exported only to the back ends. When a file is read in one format, the canonical form is generated for BFD and the application. At the same time, the back end saves away any information which may otherwise be lost. If the data is then written back in the same format, the back end routine will be able to use the canonical form provided by the BFD core as well as the information it prepared earlier. Since there is a great deal of commonality between back ends, there is no information lost when linking or copying big endian COFF to little endian COFF, or a.out to b.out. When a mixture of formats is linked, the information is only lost from the files whose format differs from the destination.


Using LD, the GNU linker - Canonical format

The BFD canonical object-file format

The greatest potential for loss of information occurs when there is the least overlap between the information provided by the source format, that stored by the canonical format, and that needed by the destination format. A brief description of the canonical form may help you understand which kinds of data you can count on preserving across conversions.

files
Information stored on a per-file basis includes target machine architecture, particular implementation format type, a demand pageable bit, and a write protected bit. Information like Unix magic numbers is not stored here--only the magic numbers' meaning, so a ZMAGIC file would have both the demand pageable bit and the write protected text bit set. The byte order of the target is stored on a per-file basis, so that big- and little-endian object files may be used with one another.
sections
Each section in the input file contains the name of the section, the section's original address in the object file, size and alignment information, various flags, and pointers into other BFD data structures.
symbols
Each symbol contains a pointer to the information for the object file which originally defined it, its name, its value, and various flag bits. When a BFD back end reads in a symbol table, it relocates all symbols to make them relative to the base of the section where they were defined. Doing this ensures that each symbol points to its containing section. Each symbol also has a varying amount of hidden private data for the BFD back end. Since the symbol points to the original file, the private data format for that symbol is accessible. ld can operate on a collection of symbols of wildly different formats without problems. Normal global and simple local symbols are maintained on output, so an output file (no matter its format) will retain symbols pointing to functions and to global, static, and common variables. Some symbol information is not worth retaining; in a.out, type information is stored in the symbol table as long symbol names. This information would be useless to most COFF debuggers; the linker has command line switches to allow users to throw it away. There is one word of type information within the symbol, so if the format supports symbol type information within symbols (for example, COFF, IEEE, Oasys) and the type is simple enough to fit within one word (nearly everything but aggregates), the information will be preserved.
relocation level
Each canonical BFD relocation record contains a pointer to the symbol to relocate to, the offset of the data to relocate, the section the data is in, and a pointer to a relocation type descriptor. Relocation is performed by passing messages through the relocation type descriptor and the symbol pointer. Therefore, relocations can be performed on output data using a relocation method that is only available in one of the input formats. For instance, Oasys provides a byte relocation format. A relocation record requesting this relocation type would point indirectly to a routine to perform this, so the relocation may be performed on a byte being written to a 68k COFF file, even though 68k COFF has no such relocation type.
line numbers
Object formats can contain, for debugging purposes, some form of mapping between symbols, source line numbers, and addresses in the output file. These addresses have to be relocated along with the symbol information. Each symbol with an associated list of line number records points to the first record of the list. The head of a line number list consists of a pointer to the symbol, which allows finding out the address of the function whose line number is being described. The rest of the list is made up of pairs: offsets into the section and line numbers. Any format which can simply derive this information can pass it successfully between formats (COFF, IEEE and Oasys).


Using LD, the GNU linker - Reporting Bugs

Reporting Bugs

Your bug reports play an essential role in making ld reliable. Reporting a bug may help you by bringing a solution to your problem, or it may not. But in any case the principal function of a bug report is to help the entire community by making the next version of ld work better. Bug reports are your contribution to the maintenance of ld. In order for a bug report to serve its purpose, you must include the information that enables us to fix the bug.


Using LD, the GNU linker - Bug Criteria

Have you found a bug?

If you are not sure whether you have found a bug, here are some guidelines:

  • If the linker gets a fatal signal, for any input whatever, that is a ld bug. Reliable linkers never crash.
  • If ld produces an error message for valid input, that is a bug.
  • If ld does not produce an error message for invalid input, that may be a bug. In the general case, the linker can not verify that object files are correct.
  • If you are an experienced user of linkers, your suggestions for improvement of ld are welcome in any case.


Using LD, the GNU linker - Bug Reporting

How to report bugs

A number of companies and individuals offer support for GNU products. If you obtained ld from a support organization, we recommend you contact that organization first. You can find contact information for many support companies and individuals in the file `etc/SERVICE' in the GNU Emacs distribution. In any event, we also recommend that you send bug reports for ld to `bug-gnu-utils@gnu.org'. The fundamental principle of reporting bugs usefully is this: report all the facts. If you are not sure whether to state a fact or leave it out, state it! Often people omit facts because they think they know what causes the problem and assume that some details do not matter. Thus, you might assume that the name of a symbol you use in an example does not matter. Well, probably it does not, but one cannot be sure. Perhaps the bug is a stray memory reference which happens to fetch from the location where that name is stored in memory; perhaps, if the name were different, the contents of that location would fool the linker into doing the right thing despite the bug. Play it safe and give a specific, complete example. That is the easiest thing for you to do, and the most helpful. Keep in mind that the purpose of a bug report is to enable us to fix the bug if it is new to us. Therefore, always write your bug reports on the assumption that the bug has not been reported previously. Sometimes people give a few sketchy facts and ask, "Does this ring a bell?" Those bug reports are useless, and we urge everyone to refuse to respond to them except to chide the sender to report bugs properly. To enable us to fix the bug, you should include all these things:

  • The version of ld. ld announces it if you start it with the `--version' argument. Without this, we will not know whether there is any point in looking for the bug in the current version of ld.
  • Any patches you may have applied to the ld source, including any patches made to the BFD library.
  • The type of machine you are using, and the operating system name and version number.
  • What compiler (and its version) was used to compile ld---e.g. "gcc-2.7".
  • The command arguments you gave the linker to link your example and observe the bug. To guarantee you will not omit something important, list them all. A copy of the Makefile (or the output from make) is sufficient. If we were to try to guess the arguments, we would probably guess wrong and then we might not encounter the bug.
  • A complete input file, or set of input files, that will reproduce the bug. It is generally most helpful to send the actual object files, uuencoded if necessary to get them through the mail system. Making them available for anonymous FTP is not as good, but may be the only reasonable choice for large object files. If the source files were assembled using gas or compiled using gcc, then it may be OK to send the source files rather than the object files. In this case, be sure to say exactly what version of gas or gcc was used to produce the object files. Also say how gas or gcc were configured.
  • A description of what behavior you observe that you believe is incorrect. For example, "It gets a fatal signal." Of course, if the bug is that ld gets a fatal signal, then we will certainly notice it. But if the bug is incorrect output, we might not notice unless it is glaringly wrong. You might as well not give us a chance to make a mistake. Even if the problem you experience is a fatal signal, you should still say so explicitly. Suppose something strange is going on, such as, your copy of ld is out of synch, or you have encountered a bug in the C library on your system. (This has happened!) Your copy might crash and ours would not. If you told us to expect a crash, then when ours fails to crash, we would know that the bug was not happening for us. If you had not told us to expect a crash, then we would not be able to draw any conclusion from our observations.
  • If you wish to suggest changes to the ld source, send us context diffs, as generated by diff with the `-u', `-c', or `-p' option. Always send diffs from the old file to the new file. If you even discuss something in the ld source, refer to it by context, not by line number. The line numbers in our development sources will not match those in your sources. Your line numbers would convey no useful information to us.

Here are some things that are not necessary:

  • A description of the envelope of the bug. Often people who encounter a bug spend a lot of time investigating which changes to the input file will make the bug go away and which changes will not affect it. This is often time consuming and not very useful, because the way we will find the bug is by running a single example under the debugger with breakpoints, not by pure deduction from a series of examples. We recommend that you save your time for something else. Of course, if you can find a simpler example to report instead of the original one, that is a convenience for us. Errors in the output will be easier to spot, running under the debugger will take less time, and so on. However, simplification is not vital; if you do not want to do this, report the bug anyway and send us the entire test case you used.
  • A patch for the bug. A patch for the bug does help us if it is a good one. But do not omit the necessary information, such as the test case, on the assumption that a patch is all we need. We might see problems with your patch and decide to fix the problem another way, or we might not understand it at all. Sometimes with a program as complicated as ld it is very hard to construct an example that will make the program follow a certain path through the code. If you do not send us the example, we will not be able to construct one, so we will not be able to verify that the bug is fixed. And if we cannot understand what bug you are trying to fix, or why your patch should be an improvement, we will not install it. A test case will help us to understand.
  • A guess about what the bug is or what it depends on. Such guesses are usually wrong. Even we cannot guess right about such things without first using the debugger to find the facts.


Using LD, the GNU linker - MRI

MRI Compatible Script Files

To aid users making the transition to GNU ld from the MRI linker, ld can use MRI compatible linker scripts as an alternative to the more general-purpose linker scripting language described in section Command Language. MRI compatible linker scripts have a much simpler command set than the scripting language otherwise used with ld. GNU ld supports the most commonly used MRI linker commands; these commands are described here. In general, MRI scripts aren't of much use with the a.out object file format, since it only has three sections and MRI scripts lack some features to make use of them. You can specify a file containing an MRI-compatible script using the `-c' command-line option. Each command in an MRI-compatible script occupies its own line; each command line starts with the keyword that identifies the command (though blank lines are also allowed for punctuation). If a line of an MRI-compatible script begins with an unrecognized keyword, ld issues a warning message, but continues processing the script. Lines beginning with `*' are comments. You can write these commands using all upper-case letters, or all lower case; for example, `chip' is the same as `CHIP'. The following list shows only the upper-case form of each command.

ABSOLUTE secname
ABSOLUTE secname, secname, ... secname
Normally, ld includes in the output file all sections from all the input files. However, in an MRI-compatible script, you can use the ABSOLUTE command to restrict the sections that will be present in your output program. If the ABSOLUTE command is used at all in a script, then only the sections named explicitly in ABSOLUTE commands will appear in the linker output. You can still use other input sections (whatever you select on the command line, or using LOAD) to resolve addresses in the output file.
ALIAS out-secname, in-secname
Use this command to place the data from input section in-secname in a section called out-secname in the linker output file. in-secname may be an integer.
ALIGN secname = expression
Align the section called secname to expression. The expression should be a power of two.
BASE expression
Use the value of expression as the lowest address (other than absolute addresses) in the output file.
CHIP expression
CHIP expression, expression
This command does nothing; it is accepted only for compatibility.
END
This command does nothing whatever; it's only accepted for compatibility.
FORMAT output-format
Similar to the OUTPUT_FORMAT command in the more general linker language, but restricted to one of these output formats:
  1. S-records, if output-format is `S'
  2. IEEE, if output-format is `IEEE'
  3. COFF (the `coff-m68k' variant in BFD), if output-format is `COFF'
LIST anything...
Print (to the standard output file) a link map, as produced by the ld command-line option `-M'. The keyword LIST may be followed by anything on the same line, with no change in its effect.
LOAD filename
LOAD filename, filename, ... filename
Include one or more object file filename in the link; this has the same effect as specifying filename directly on the ld command line.
NAME output-name
output-name is the name for the program produced by ld; the MRI-compatible command NAME is equivalent to the command-line option `-o' or the general script language command OUTPUT.
ORDER secname, secname, ... secname
ORDER secname secname secname
Normally, ld orders the sections in its output file in the order in which they first appear in the input files. In an MRI-compatible script, you can override this ordering with the ORDER command. The sections you list with ORDER will appear first in your output file, in the order specified.
PUBLIC name=expression
PUBLIC name,expression
PUBLIC name expression
Supply a value (expression) for external symbol name used in the linker input files.
SECT secname, expression
SECT secname=expression
SECT secname expression
You can use any of these three forms of the SECT command to specify the start address (expression) for section secname. If you have more than one SECT statement for the same secname, only the first sets the start address.


Using LD, the GNU linker - Index

Index

"

  • "

    • *

  • *( COMMON )
  • *(section)

    • -

  • -(
  • --architecture=arch
  • --auxiliary
  • --cref
  • --defsym symbol=exp
  • --discard-all
  • --discard-locals
  • --dynamic-linker file
  • --embedded-relocs
  • --entry=entry
  • --export-dynamic
  • --filter
  • --force-exe-suffix
  • --format=format
  • --gpsize
  • --help
  • --just-symbols=file
  • --library-path=dir
  • --library=archive
  • --mri-script=MRI-cmdfile
  • --nmagic
  • --no-keep-memory
  • --no-warn-mismatch
  • --no-whole-archive
  • --noinhibit-exec
  • --oformat
  • --omagic
  • --output=output
  • --print-map
  • --relax
  • --relax on i960
  • --relocateable
  • --script=script
  • --sort-common
  • --split-by-file
  • --split-by-reloc
  • --stats
  • --strip-all
  • --strip-debug
  • --trace
  • --trace-symbol=symbol
  • --traditional-format
  • --undefined=symbol
  • --verbose
  • --version
  • --version-script=version-scriptfile
  • --warn-comon
  • --warn-constructors
  • --warn-multiple-gp
  • --warn-once
  • --warn-section-align
  • --whole-archive
  • --wrap
  • -Aarch
  • -akeyword
  • -assert keyword
  • -b format
  • -Bdynamic
  • -Bshareable
  • -Bstatic
  • -Bsymbolic
  • -c MRI-cmdfile
  • -call_shared
  • -d
  • -dc
  • -dn
  • -dp
  • -dy
  • -E
  • -e entry
  • -EB
  • -EL
  • -f
  • -F
  • -G
  • -g
  • -hname
  • -i
  • -larchive
  • -Ldir
  • -M
  • -m emulation
  • -Map
  • -N
  • -n
  • -non_shared
  • -o output
  • -qmagic
  • -Qy
  • -r
  • -R file
  • -rpath
  • -rpath-link
  • -s
  • -S
  • -shared
  • -soname=name
  • -static
  • -t
  • -T script
  • -Tbss org
  • -Tdata org
  • -Ttext org
  • -u symbol
  • -Ur
  • -v
  • -V
  • -x
  • -X
  • -Y path
  • -y symbol
  • -z keyword

    • .

  • .

    • 0

  • 0x

    • :

  • :phdr

    • ;

  • ;

    • =

  • =fill

    • >

  • >region

    • [

  • [section...], not supported

    • a

  • ABSOLUTE (MRI)
  • absolute and relocatable symbols
  • ABSOLUTE(exp)
  • ADDR(section)
  • ALIAS (MRI)
  • ALIGN (MRI)
  • ALIGN(exp)
  • aligning sections
  • allocating memory
  • architectures
  • archive files, from cmd line
  • arithmetic
  • arithmetic operators
  • assignment in scripts
  • assignment, in section defn
  • AT ( ldadr )

    • b

  • back end
  • BASE (MRI)
  • BFD canonical format
  • BFD requirements
  • big-endian objects
  • binary input files
  • binary input format
  • BLOCK(align)
  • bug criteria
  • bug reports
  • bugs in ld
  • BYTE(expression)

    • c

  • C++ constructors, arranging in link
  • CHIP (MRI)
  • combining symbols, warnings on
  • command files
  • command line
  • commands, fundamental
  • comments
  • common allocation, common allocation
  • commons in output
  • compatibility, MRI
  • CONSTRUCTORS
  • constructors
  • constructors, arranging in link
  • contents of a section
  • crash of linker
  • CREATE_OBJECT_SYMBOLS
  • cross reference table
  • cross references
  • current output location

    • d

  • dbx
  • decimal integers
  • default emulation
  • default input format
  • DEFINED(symbol)
  • deleting local symbols
  • direct output
  • discontinuous memory
  • dot
  • dynamic linker, from command line
  • dynamic symbol table

    • e

  • ELF program headers
  • emulation
  • emulation, default
  • END (MRI)
  • endianness
  • entry point, defaults
  • entry point, from command line
  • ENTRY(symbol)
  • error on valid input
  • expression evaluation order
  • expression syntax
  • expression, absolute
  • expressions in a section

    • f

  • fatal signal
  • filename
  • filename symbols
  • filename(section)
  • files and sections, section defn
  • files, including in output sections
  • fill pattern, entire section
  • FILL(expression)
  • first input file
  • first instruction
  • FLOAT
  • FORCE_COMMON_ALLOCATION
  • FORMAT (MRI)
  • format, output file
  • functions in expression language
  • fundamental script commands

    • g

  • GNU linker
  • GNUTARGET, GNUTARGET
  • GROUP ( files )
  • grouping input files
  • groups of archives

    • h

  • H8/300 support
  • header size
  • help
  • hexadecimal integers
  • holes
  • holes, filling

    • i

  • i960 support
  • INCLUDE filename
  • including a linker script
  • including an entire archive
  • incremental link
  • INPUT ( files )
  • input file format
  • input filename symbols
  • input files, displaying
  • input files, section defn
  • input format, input format
  • input sections to output section
  • integer notation
  • integer suffixes
  • internal object-file format
  • invalid input

    • k

  • K and M integer suffixes

    • l

  • l =
  • L, deleting symbols beginning
  • layout of output file
  • lazy evaluation
  • ld bugs, reporting
  • LDEMULATION
  • len =
  • LENGTH =
  • link map
  • link-time runtime library search path
  • linker crash
  • LIST (MRI)
  • little-endian objects
  • LOAD (MRI)
  • load address, specifying
  • LOADADDR(section)
  • loading, preventing
  • local symbols, deleting
  • location counter
  • LONG(expression)

    • m

  • M and K integer suffixes
  • machine architecture, output
  • machine dependencies
  • MAX
  • MEMORY
  • memory region attributes
  • memory regions and sections
  • memory usage
  • MIN
  • MIPS embedded PIC code
  • MRI compatibility

    • n

  • NAME (MRI)
  • names
  • naming memory regions
  • naming output sections
  • naming the output file, naming the output file
  • negative integers
  • NEXT(exp)
  • NMAGIC
  • NOCROSSREFS ( sections )
  • NOFLOAT
  • NOLOAD
  • Non constant expression

    • o

  • o =
  • objdump -i
  • object file management
  • object files
  • object formats available
  • object size
  • octal integers
  • OMAGIC
  • opening object files
  • Operators for arithmetic
  • options
  • ORDER (MRI)
  • org =
  • ORIGIN =
  • OUTPUT ( filename )
  • output file after errors
  • output file layout
  • OUTPUT_ARCH ( bfdname )
  • OUTPUT_FORMAT ( bfdname )
  • OVERLAY
  • overlays

    • p

  • partial link
  • path for libraries
  • PHDRS
  • precedence in expressions
  • prevent unnecessary loading
  • program headers
  • program headers and sections
  • provide
  • PUBLIC (MRI)

    • q

  • QUAD(expression)
  • quoted symbol names

    • r

  • read-only text
  • read/write from cmd line
  • regions of memory
  • relaxing addressing modes
  • relaxing on H8/300
  • relaxing on i960
  • relocatable and absolute symbols
  • relocatable output
  • reporting bugs in ld
  • requirements for BFD
  • retaining specified symbols
  • rounding up location counter
  • runtime library name
  • runtime library search path

    • s

  • scaled integers
  • script files
  • search directory, from cmd line
  • search path, libraries
  • SEARCH_DIR ( path )
  • SECT (MRI)
  • section address, section address
  • section alignment
  • section alignment, warnings on
  • section definition
  • section defn, full syntax
  • section fill pattern
  • section load address
  • section size
  • section start
  • section, assigning to memory region
  • section, assigning to program header
  • SECTIONS
  • segment origins, cmd line
  • semicolon
  • shared libraries
  • SHORT(expression)
  • SIZEOF(section)
  • SIZEOF_HEADERS
  • sizeof_headers
  • specify load address
  • SQUAD(expression)
  • standard Unix system
  • start address, section
  • start of execution
  • STARTUP ( filename )
  • strip all symbols
  • strip debugger symbols
  • stripping all but some symbols
  • suffixes for integers
  • symbol defaults
  • symbol definition, scripts
  • symbol names
  • symbol tracing
  • symbol versions
  • symbol-only input
  • symbol = expression ;
  • symbol f= expression ;
  • symbols, from command line
  • symbols, relocatable and absolute
  • symbols, retaining selectively
  • synthesizing linker
  • synthesizing on H8/300

    • t

  • TARGET ( format )
  • traditional format

    • u

  • unallocated address, next
  • undefined symbol
  • undefined symbols, warnings on
  • uninitialized data
  • unspecified memory
  • usage

    • v

  • variables, defining
  • verbose
  • version
  • version script
  • version script, symbol versions
  • VERSION {script text}
  • versions of symbols

    • w

  • warnings, on combining symbols
  • warnings, on section alignment
  • warnings, on undefined symbols
  • what is this?

    • Go to the first, previous, next, last section, table of contents.


Cygnus C Support Library, Full - Stdlib

`libc' includes software developed by the University of California, Berkeley and its contributors.

`libc' includes software developed by Martin Jackson, Graham Haley and Steve Chamberlain of Tadpole Technology and released to Cygnus.

`libc' uses floating point converstion software developed at AT&T, which includes this copyright information:

The author of this software is David M. Gay.

Copyright (c) 1991 by AT&T.

Permission to use, copy, modify, and distribute this software for any purpose without fee is hereby granted, provided that this entire notice is included in all copies of any software which is or includes a copy or modification of this software and in all copies of the supporting documentation for such software.

THIS SOFTWARE IS BEING PROVIDED "AS IS", WITHOUT ANY EXPRESS OR IMPLIED WARRANTY. IN PARTICULAR, NEITHER THE AUTHOR NOR AT&T MAKES ANY REPRESENTATION OR WARRANTY OF ANY KIND CONCERNING THE MERCHANTABILITY OF THIS SOFTWARE OR ITS FITNESS FOR ANY PARTICULAR PURPOSE.

Permission is granted to make and distribute verbatim copies of this manual provided the copyright notice and this permission notice are preserved on all copies.

Permission is granted to copy and distribute modified versions of this manual under the conditions for verbatim copying, subject to the terms of the GNU General Public License, which includes the provision that the entire resulting derived work is distributed under the terms of a permission notice identical to this one.

Permission is granted to copy and distribute translations of this manual into another language, under the above conditions for modified versions.

Standard Utility Functions (`stdlib.h')

This chapter groups utility functions useful in a variety of programs. The corresponding declarations are in the header file `stdlib.h'.


Cygnus C Support Library, Full - abort

abort---abnormal termination of a program

Synopsis

#include <stdlib.h>
void abort(void);

Description
Use abort to signal that your program has detected a condition it cannot deal with. Normally, abort ends your program's execution.

Before terminating your program, abort raises the exception SIGABRT (using `raise(SIGABRT)'). If you have used signal to register an exception handler for this condition, that handler has the opportunity to retain control, thereby avoiding program termination.

In this implementation, abort does not perform any stream- or file-related cleanup (the host environment may do so; if not, you can arrange for your program to do its own cleanup with a SIGABRT exception handler).

Returns
abort does not return to its caller.

Portability
ANSI C requires abort.

Supporting OS subroutines required: getpid, kill.


Cygnus C Support Library, Full - abs

abs---integer absolute value (magnitude)

Synopsis

#include <stdlib.h>
int abs(int i);

Description
abs returns the absolute value of i (also called the magnitude of i). That is, if i is negative, the result is the opposite of i, but if i is nonnegative the result is i.

The similar function labs uses and returns long rather than int values.

Returns
The result is a nonnegative integer.

Portability
abs is ANSI.

No supporting OS subroutines are required.


Cygnus C Support Library, Full - assert

assert---Macro for Debugging Diagnostics

Synopsis

#include <assert.h>
void assert(int expression);

Description
Use this macro to embed debuggging diagnostic statements in your programs. The argument expression should be an expression which evaluates to true (nonzero) when your program is working as you intended.

When expression evaluates to false (zero), assert calls abort, after first printing a message showing what failed and where:

 Assertion failed: expression, file filename, line lineno

The macro is defined to permit you to turn off all uses of assert at compile time by defining NDEBUG as a preprocessor variable. If you do this, the assert macro expands to

 (void(0))

Returns
assert does not return a value.

Portability
The assert macro is required by ANSI, as is the behavior when NDEBUG is defined.

Supporting OS subroutines required (only if enabled): close, fstat, getpid, isatty, kill, lseek, read, sbrk, write.


Cygnus C Support Library, Full - atexit

atexit---request execution of functions at program exit

Synopsis

#include <stdlib.h>
int atexit(void (*function)(void);

    @end example
Description

You can use atexit to enroll functions in a list of functions that
will be called when your program terminates normally.  The argument is
a pointer to a user-defined function (which must not require arguments and
must not return a result).

The functions are kept in a LIFO stack; that is, the last function
enrolled by atexit will be the first to execute when your program
exits.

There is no built-in limit to the number of functions you can enroll
in this list; however, after every group of 32 functions is enrolled,
atexit will call malloc to get space for the next part of the
list.   The initial list of 32 functions is statically allocated, so
you can always count on at least that many slots available.

Returns

atexit returns 0 if it succeeds in enrolling your function,
-1 if it fails (possible only if no space was available for
malloc to extend the list of functions).

Portability

atexit is required by the ANSI standard, which also specifies that
implementations must support enrolling at least 32 functions.

Supporting OS subroutines required: close, fstat, isatty,
lseek, read, sbrk, write.


Cygnus C Support Library, Full - atof

atof, atoff---string to double or float

Synopsis

#include <stdlib.h>
double atof(const char *s);
float atoff(const char *s);

Description
atof converts the initial portion of a string to a double. atoff converts the initial portion of a string to a float.

The functions parse the character string s, locating a substring which can be converted to a floating point value. The substring must match the format:

 [+|-]digits[.][digits][(e|E)[+|-]digits]

The substring converted is the longest initial fragment of s that has the expected format, beginning with the first non-whitespace character. The substring is empty if str is empty, consists entirely of whitespace, or if the first non-whitespace character is something other than +, -, ., or a digit.

atof(s) is implemented as strtod(s, NULL). atoff(s) is implemented as strtodf(s, NULL).

Returns
atof returns the converted substring value, if any, as a double; or 0.0, if no conversion could be performed. If the correct value is out of the range of representable values, plus or minus HUGE_VAL is returned, and ERANGE is stored in errno. If the correct value would cause underflow, 0.0 is returned and ERANGE is stored in errno.

atoff obeys the same rules as atof, except that it returns a float.

Portability
atof is ANSI C. atof, atoi, and atol are subsumed by strod and strol, but are used extensively in existing code. These functions are less reliable, but may be faster if the argument is verified to be in a valid range.

Supporting OS subroutines required: close, fstat, isatty, lseek, read, sbrk, write.


Cygnus C Support Library, Full - atoi

atoi, atol---string to integer

Synopsis

#include <stdlib.h>
int atoi(const char *s);
long atol(const char *s);

Description
atoi converts the initial portion of a string to an int. atol converts the initial portion of a string to a long.

atoi(s) is implemented as (int)strtol(s, NULL, 10). atol(s) is implemented as strtol(s, NULL, 10).

Returns
The functions return the converted value, if any. If no conversion was made, 0 is returned.

Portability
atoi is ANSI.

No supporting OS subroutines are required.


Cygnus C Support Library, Full - bsearch

bsearch---binary search

Synopsis

#include <stdlib.h>
void *bsearch(const void *key, const void *base,
    size_t nmemb, size_t size,
    int (*compar)(const void *, const void *));

Description
bsearch searches an array beginning at base for any element that matches key, using binary search. nmemb is the element count of the array; size is the size of each element.

The array must be sorted in ascending order with respect to the comparison function compar (which you supply as the last argument of bsearch).

You must define the comparison function (*compar) to have two arguments; its result must be negative if the first argument is less than the second, zero if the two arguments match, and positive if the first argument is greater than the second (where "less than" and "greater than" refer to whatever arbitrary ordering is appropriate).

Returns
Returns a pointer to an element of array that matches key. If more than one matching element is available, the result may point to any of them.

Portability
bsearch is ANSI.

No supporting OS subroutines are required.


Cygnus C Support Library, Full - calloc

calloc---allocate space for arrays

Synopsis

#include <stdlib.h>
void *calloc(size_t n, size_t s);
void *calloc_r(void *reent, size_t <n>, <size_t> s);

Description
Use calloc to request a block of memory sufficient to hold an array of n elements, each of which has size s.

The memory allocated by calloc comes out of the same memory pool used by malloc, but the memory block is initialized to all zero bytes. (To avoid the overhead of initializing the space, use malloc instead.)

The alternate functios _calloc_r is reentrant. The extra argument reent is a pointer to a reentrancy structure.

Returns
If successful, a pointer to the newly allocated space.

If unsuccessful, NULL.

Portability
calloc is ANSI.

Supporting OS subroutines required: close, fstat, isatty, lseek, read, sbrk, write.


Cygnus C Support Library, Full - div

div---divide two integers

Synopsis

#include <stdlib.h>
div_t div(int n, int d);

Description
Divide returning quotient and remainder as two integers in a structure div_t.

Returns
The result is represented with the structure

 typedef struct
 {
  int quot;
  int rem;
 } div_t;

where the quot field represents the quotient, and rem the remainder. For nonzero d, if `r = div(n,d);' then n equals `r.rem + d*r.quot'.

To divide long rather than int values, use the similar function ldiv.

Portability
div is ANSI.

No supporting OS subroutines are required.


Cygnus C Support Library, Full - ecvt

ecvt,ecvtf,fcvt,fcvtf---double or float to string

Synopsis

#include <stdlib.h>

char *ecvt(double val, int chars, int *decpt, int *sgn);
char *ecvtf(float val, int chars, int *decpt, int *sgn);

char *fcvt(double val, int decimals,
    int *decpt, int *sgn);
char *fcvtf(float val, int decimals,
    int *decpt, int *sgn);

Description
ecvt and fcvt produce (null-terminated) strings of digits representating the double number val. ecvtf and fcvtf produce the corresponding character representations of float numbers.

(The stdlib functions ecvtbuf and fcvtbuf are reentrant versions of ecvt and fcvt.)

The only difference between ecvt and fcvt is the interpretation of the second argument (chars or decimals). For ecvt, the second argument chars specifies the total number of characters to write (which is also the number of significant digits in the formatted string, since these two functions write only digits). For fcvt, the second argument decimals specifies the number of characters to write after the decimal point; all digits for the integer part of val are always included.

Since ecvt and fcvt write only digits in the output string, they record the location of the decimal point in *decpt, and the sign of the number in *sgn. After formatting a number, *decpt contains the number of digits to the left of the decimal point. *sgn contains 0 if the number is positive, and 1 if it is negative.

Returns
All four functions return a pointer to the new string containing a character representation of val.

Portability
None of these functions are ANSI C.

Supporting OS subroutines required: close, fstat, isatty, lseek, read, sbrk, write.


Cygnus C Support Library, Full - gvcvt

gvcvt, gcvtf---format double or float as string

Synopsis

#include <stdlib.h>

char *gcvt(double val, int precision, char *buf);
char *gcvtf(float val, int precision, char *buf);

Description
gcvt writes a fully formatted number as a null-terminated string in the buffer *buf. gdvtf produces corresponding character representations of float numbers.

gcvt uses the same rules as the printf format `%.precisiong'---only negative values are signed (with `-'), and either exponential or ordinary decimal-fraction format is chosen depending on the number of significant digits (specified by precision).

Returns
The result is a pointer to the formatted representation of val (the same as the argument buf).

Portability
Neither function is ANSI C.

Supporting OS subroutines required: close, fstat, isatty, lseek, read, sbrk, write.


Cygnus C Support Library, Full - ecvtbuf

ecvtbuf, fcvtbuf---double or float to string

Synopsis

#include <stdio.h>

char *ecvtbuf(double val, int chars, int *decpt,
    int *sgn, char *buf);

char *fcvtbuf(double val, int decimals, int *decpt,
    int *sgn, char *buf);

Description
ecvtbuf and fcvtbuf produce (null-terminated) strings of digits representating the double number val.

The only difference between ecvtbuf and fcvtbuf is the interpretation of the second argument (chars or decimals). For ecvtbuf, the second argument chars specifies the total number of characters to write (which is also the number of significant digits in the formatted string, since these two functions write only digits). For fcvtbuf, the second argument decimals specifies the number of characters to write after the decimal point; all digits for the integer part of val are always included.

Since ecvtbuf and fcvtbuf write only digits in the output string, they record the location of the decimal point in *decpt, and the sign of the number in *sgn. After formatting a number, *decpt contains the number of digits to the left of the decimal point. *sgn contains 0 if the number is positive, and 1 if it is negative. For both functions, you supply a pointer buf to an area of memory to hold the converted string.

Returns
Both functions return a pointer to buf, the string containing a character representation of val.

Portability
Neither function is ANSI C.

Supporting OS subroutines required: close, fstat, isatty, lseek, read, sbrk, write.


Cygnus C Support Library, Full - exit

exit---end program execution

Synopsis

#include <stdlib.h>
void exit(int code);

Description
Use exit to return control from a program to the host operating environment. Use the argument code to pass an exit status to the operating environment: two particular values, EXIT_SUCCESS and EXIT_FAILURE, are defined in `stdlib.h' to indicate success or failure in a portable fashion.

exit does two kinds of cleanup before ending execution of your program. First, it calls all application-defined cleanup functions you have enrolled with atexit. Second, files and streams are cleaned up: any pending output is delivered to the host system, each open file or stream is closed, and files created by tmpfile are deleted.

Returns
exit does not return to its caller.

Portability
ANSI C requires exit, and specifies that EXIT_SUCCESS and EXIT_FAILURE must be defined.

Supporting OS subroutines required: _exit.


Cygnus C Support Library, Full - getenv

getenv---look up environment variable

Synopsis

#include <stdlib.h>
char *getenv(const char *name);

Description
getenv searches the list of environment variable names and values (using the global pointer `char **environ') for a variable whose name matches the string at name. If a variable name matches, getenv returns a pointer to the associated value.

Returns
A pointer to the (string) value of the environment variable, or NULL if there is no such environment variable.

Portability
getenv is ANSI, but the rules for properly forming names of environment variables vary from one system to another.

getenv requires a global pointer environ.


Cygnus C Support Library, Full - labs

labs---long integer absolute value

Synopsis

#include <stdlib.h>
long labs(long i);

Description
labs returns the absolute value of i (also called the magnitude of i). That is, if i is negative, the result is the opposite of i, but if i is nonnegative the result is i.

The similar function abs uses and returns int rather than long values.

Returns
The result is a nonnegative long integer.

Portability
labs is ANSI.

No supporting OS subroutine calls are required.


Cygnus C Support Library, Full - ldiv

ldiv---divide two long integers

Synopsis

#include <stdlib.h>
ldiv_t ldiv(long n, long d);

Description
Divide returning quotient and remainder as two long integers in a structure ldiv_t.

Returns
The result is represented with the structure

 typedef struct
 {
  long quot;
  long rem;
 } ldiv_t;

where the quot field represents the quotient, and rem the remainder. For nonzero d, if `r = ldiv(n,d);' then n equals `r.rem + d*r.quot'.

To divide int rather than long values, use the similar function div.

Portability
ldiv is ANSI.

No supporting OS subroutines are required.


Cygnus C Support Library, Full - malloc

malloc, realloc, free---manage memory

Synopsis

#include <stdlib.h>
void *malloc(size_t nbytes);
void *realloc(void *aptr, size_t nbytes);
void free(void *aptr);

void *_malloc_r(void *reent, size_t nbytes);
void *_realloc_r(void *reent,
    void *aptr, size_t nbytes);
void _free_r(void *reent, void *aptr);

Description
These functions manage a pool of system memory.

Use malloc to request allocation of an object with at least nbytes bytes of storage available. If the space is available, malloc returns a pointer to a newly allocated block as its result.

If you already have a block of storage allocated by malloc, but you no longer need all the space allocated to it, you can make it smaller by calling realloc with both the object pointer and the new desired size as arguments. realloc guarantees that the contents of the smaller object match the beginning of the original object.

Similarly, if you need more space for an object, use realloc to request the larger size; again, realloc guarantees that the beginning of the new, larger object matches the contents of the original object.

When you no longer need an object originally allocated by malloc or realloc (or the related function calloc), return it to the memory storage pool by calling free with the address of the object as the argument. You can also use realloc for this purpose by calling it with 0 as the nbytes argument.

The alternate functions _malloc_r, _realloc_r, and _free_r are reentrant versions. The extra argument reent is a pointer to a reentrancy structure.

Returns
malloc returns a pointer to the newly allocated space, if successful; otherwise it returns NULL. If your application needs to generate empty objects, you may use malloc(0) for this purpose.

realloc returns a pointer to the new block of memory, or NULL if a new block could not be allocated. NULL is also the result when you use `realloc(aptr,0)' (which has the same effect as `free(aptr)'). You should always check the result of realloc; successful reallocation is not guaranteed even when you request a smaller object.

free does not return a result.

Portability
malloc, realloc, and free are specified by the ANSI C standard, but other conforming implementations of malloc may behave differently when nbytes is zero.

Supporting OS subroutines required: sbrk, write (if WARN_VLIMIT).


Cygnus C Support Library, Full - mbtowc

mbtowc---minimal multibyte to wide char converter

Synopsis

#include <stdlib.h>
int mbtowc(wchar_t *pwc, const char *s, size_t n);

Description
This is a minimal ANSI-conforming implementation of mbtowc. The only "multi-byte character sequences" recognized are single bytes, and they are "converted" to themselves.

Each call to mbtowc copies one character from *s to *pwc, unless s is a null pointer.

In this implementation, the argument n is ignored.

Returns
This implementation of mbtowc returns 0 if s is NULL; it returns 1 otherwise (reporting the length of the character "sequence" used).

Portability
mbtowc is required in the ANSI C standard. However, the precise effects vary with the locale.

mbtowc requires no supporting OS subroutines.


Cygnus C Support Library, Full - qsort

qsort---sort an array

Synopsis

#include <stdlib.h>
void qsort(void *base, size_t nmemb, size_t size,
    int (*compar)(const void *, const void *) );

Description
qsort sorts an array (beginning at base) of nmemb objects. size describes the size of each element of the array.

You must supply a pointer to a comparison function, using the argument shown as compar. (This permits sorting objects of unknown properties.) Define the comparison function to accept two arguments, each a pointer to an element of the array starting at base. The result of (*compar) must be negative if the first argument is less than the second, zero if the two arguments match, and positive if the first argument is greater than the second (where "less than" and "greater than" refer to whatever arbitrary ordering is appropriate).

The array is sorted in place; that is, when qsort returns, the array elements beginning at base have been reordered.

Returns
qsort does not return a result.

Portability
qsort is required by ANSI (without specifying the sorting algorithm).


Cygnus C Support Library, Full - rand

rand, srand---pseudo-random numbers

Synopsis

#include <stdlib.h>
int rand(void);
void srand(unsigned int seed);
int rand_r(unsigned int *seed);

Description
rand returns a different integer each time it is called; each integer is chosen by an algorithm designed to be unpredictable, so that you can use rand when you require a random number. The algorithm depends on a static variable called the "random seed"; starting with a given value of the random seed always produces the same sequence of numbers in successive calls to rand.

You can set the random seed using srand; it does nothing beyond storing its argument in the static variable used by rand. You can exploit this to make the pseudo-random sequence less predictable, if you wish, by using some other unpredictable value (often the least significant parts of a time-varying value) as the random seed before beginning a sequence of calls to rand; or, if you wish to ensure (for example, while debugging) that successive runs of your program use the same "random" numbers, you can use srand to set the same random seed at the outset.

Returns
rand returns the next pseudo-random integer in sequence; it is a number between 0 and RAND_MAX (inclusive).

srand does not return a result.

Portability
rand is required by ANSI, but the algorithm for pseudo-random number generation is not specified; therefore, even if you use the same random seed, you cannot expect the same sequence of results on two different systems.

rand requires no supporting OS subroutines.


Cygnus C Support Library, Full - strtod

strtod, strtodf---string to double or float

Synopsis

#include <stdlib.h>
double strtod(const char *str, char **tail);
float strtodf(const char *str, char **tail);

double _strtod_r(void *reent,
    const char *str, char **tail);

Description
The function strtod parses the character string str, producing a substring which can be converted to a double value. The substring converted is the longest initial subsequence of str, beginning with the first non-whitespace character, that has the format:

[+|-]digits[.][digits][(e|E)[+|-]digits]

The substring contains no characters if str is empty, consists entirely of whitespace, or if the first non-whitespace character is something other than +, -, ., or a digit. If the substring is empty, no conversion is done, and the value of str is stored in *tail. Otherwise, the substring is converted, and a pointer to the final string (which will contain at least the terminating null character of str) is stored in *tail. If you want no assignment to *tail, pass a null pointer as tail. strtodf is identical to strtod except for its return type.

This implementation returns the nearest machine number to the input decimal string. Ties are broken by using the IEEE round-even rule.

The alternate function _strtod_r is a reentrant version. The extra argument reent is a pointer to a reentrancy structure.

Returns
strtod returns the converted substring value, if any. If no conversion could be performed, 0 is returned. If the correct value is out of the range of representable values, plus or minus HUGE_VAL is returned, and ERANGE is stored in errno. If the correct value would cause underflow, 0 is returned and ERANGE is stored in errno.

Supporting OS subroutines required: close, fstat, isatty, lseek, read, sbrk, write.


Cygnus C Support Library, Full - strtol

strtol---string to long

Synopsis

#include <stdlib.h>
long strtol(const char *s, char **ptr,int base);

long _strtol_r(void *reent,
    const char *s, char **ptr,int base);

Description
The function strtol converts the string *s to a long. First, it breaks down the string into three parts: leading whitespace, which is ignored; a subject string consisting of characters resembling an integer in the radix specified by base; and a trailing portion consisting of zero or more unparseable characters, and always including the terminating null character. Then, it attempts to convert the subject string into a long and returns the result.

If the value of base is 0, the subject string is expected to look like a normal C integer constant: an optional sign, a possible `0x' indicating a hexadecimal base, and a number. If base is between 2 and 36, the expected form of the subject is a sequence of letters and digits representing an integer in the radix specified by base, with an optional plus or minus sign. The letters a--z (or, equivalently, A--Z) are used to signify values from 10 to 35; only letters whose ascribed values are less than base are permitted. If base is 16, a leading 0x is permitted.

The subject sequence is the longest initial sequence of the input string that has the expected form, starting with the first non-whitespace character. If the string is empty or consists entirely of whitespace, or if the first non-whitespace character is not a permissible letter or digit, the subject string is empty.

If the subject string is acceptable, and the value of base is zero, strtol attempts to determine the radix from the input string. A string with a leading 0x is treated as a hexadecimal value; a string with a leading 0 and no x is treated as octal; all other strings are treated as decimal. If base is between 2 and 36, it is used as the conversion radix, as described above. If the subject string begins with a minus sign, the value is negated. Finally, a pointer to the first character past the converted subject string is stored in ptr, if ptr is not NULL.

If the subject string is empty (or not in acceptable form), no conversion is performed and the value of s is stored in ptr (if ptr is not NULL).

The alternate function _strtol_r is a reentrant version. The extra argument reent is a pointer to a reentrancy structure.

Returns
strtol returns the converted value, if any. If no conversion was made, 0 is returned.

strtol returns LONG_MAX or LONG_MIN if the magnitude of the converted value is too large, and sets errno to ERANGE.

Portability
strtol is ANSI.

No supporting OS subroutines are required.


Cygnus C Support Library, Full - strtoul

strtoul---string to unsigned long

Synopsis

#include <stdlib.h>
unsigned long strtoul(const char *s, char **ptr,
    int base);

unsigned long _strtoul_r(void *reent, const char *s,
    char **ptr, int base);

Description
The function strtoul converts the string *s to an unsigned long. First, it breaks down the string into three parts: leading whitespace, which is ignored; a subject string consisting of the digits meaningful in the radix specified by base (for example, 0 through 7 if the value of base is 8); and a trailing portion consisting of one or more unparseable characters, which always includes the terminating null character. Then, it attempts to convert the subject string into an unsigned long integer, and returns the result.

If the value of base is zero, the subject string is expected to look like a normal C integer constant (save that no optional sign is permitted): a possible 0x indicating hexadecimal radix, and a number. If base is between 2 and 36, the expected form of the subject is a sequence of digits (which may include letters, depending on the base) representing an integer in the radix specified by base. The letters a--z (or A--Z) are used as digits valued from 10 to 35. If base is 16, a leading 0x is permitted.

The subject sequence is the longest initial sequence of the input string that has the expected form, starting with the first non-whitespace character. If the string is empty or consists entirely of whitespace, or if the first non-whitespace character is not a permissible digit, the subject string is empty.

If the subject string is acceptable, and the value of base is zero, strtoul attempts to determine the radix from the input string. A string with a leading 0x is treated as a hexadecimal value; a string with a leading 0 and no x is treated as octal; all other strings are treated as decimal. If base is between 2 and 36, it is used as the conversion radix, as described above. Finally, a pointer to the first character past the converted subject string is stored in ptr, if ptr is not NULL.

If the subject string is empty (that is, if *s does not start with a substring in acceptable form), no conversion is performed and the value of s is stored in ptr (if ptr is not NULL).

The alternate function _strtoul_r is a reentrant version. The extra argument reent is a pointer to a reentrancy structure.

Returns
strtoul returns the converted value, if any. If no conversion was made, 0 is returned.

strtoul returns ULONG_MAX if the magnitude of the converted value is too large, and sets errno to ERANGE.

Portability
strtoul is ANSI.

strtoul requires no supporting OS subroutines.


Cygnus C Support Library, Full - system

system---execute command string

Synopsis

#include <stdlib.h>
int system(char *s);

int _system_r(void *reent, char *s);

Description

Use system to pass a command string *s to /bin/sh on your system, and wait for it to finish executing.

Use `system(NULL)' to test whether your system has /bin/sh available.

The alternate function _system_r is a reentrant version. The extra argument reent is a pointer to a reentrancy structure.

Returns
system(NULL) returns a non-zero value if /bin/sh is available, and 0 if it is not.

With a command argument, the result of system is the exit status returned by /bin/sh.

Portability
ANSI C requires system, but leaves the nature and effects of a command processor undefined. ANSI C does, however, specify that system(NULL) return zero or nonzero to report on the existence of a command processor.

POSIX.2 requires system, and requires that it invoke a sh. Where sh is found is left unspecified.

Supporting OS subroutines required: _exit, _execve, _fork_r, _wait_r.


Cygnus C Support Library, Full - wctomb

wctomb---minimal wide char to multibyte converter

Synopsis

#include <stdlib.h>
int wctomb(char *s, wchar_t wchar);

Description
This is a minimal ANSI-conforming implementation of wctomb. The only "wide characters" recognized are single bytes, and they are "converted" to themselves.

Each call to wctomb copies the character wchar to *s, unless s is a null pointer.

Returns
This implementation of wctomb returns 0 if s is NULL; it returns 1 otherwise (reporting the length of the character "sequence" generated).

Portability
wctomb is required in the ANSI C standard. However, the precise effects vary with the locale.

wctomb requires no supporting OS subroutines.


Cygnus C Support Library, Full - Ctype

Character Type Macros and Functions (`ctype.h')

This chapter groups macros (which are also available as subroutines) to classify characters into several categories (alphabetic, numeric, control characters, whitespace, and so on), or to perform simple character mappings.

The header file `ctype.h' defines the macros.


Cygnus C Support Library, Full - isalnum

isalnum---alphanumeric character predicate

Synopsis

#include <ctype.h>
int isalnum(int c);

Description
isalnum is a macro which classifies ASCII integer values by table lookup. It is a predicate returning non-zero for alphabetic or numeric ASCII characters, and 0 for other arguments. It is defined for all integer values.

You can use a compiled subroutine instead of the macro definition by undefining the macro using `#undef isalnum'.

Returns
isalnum returns non-zero if c is a letter (a--z or A--Z) or a digit (0--9).

Portability
isalnum is ANSI C.

No OS subroutines are required.


Cygnus C Support Library, Full - isalpha

isalpha---alphabetic character predicate

Synopsis

#include <ctype.h>
int isalpha(int c);

Description
isalpha is a macro which classifies ASCII integer values by table lookup. It is a predicate returning non-zero when c represents an alphabetic ASCII character, and 0 otherwise. It is defined only when isascii(c) is true or c is EOF.

You can use a compiled subroutine instead of the macro definition by undefining the macro using `#undef isalpha'.

Returns
isalpha returns non-zero if c is a letter (A--Z or a--z).

Portability
isalpha is ANSI C.

No supporting OS subroutines are required.


Cygnus C Support Library, Full - isascii

isascii---ASCII character predicate

Synopsis

#include <ctype.h>
int isascii(int c);

Description
isascii is a macro which returns non-zero when c is an ASCII character, and 0 otherwise. It is defined for all integer values.

You can use a compiled subroutine instead of the macro definition by undefining the macro using `#undef isascii'.

Returns
isascii returns non-zero if the low order byte of c is in the range 0 to 127 (0x00--0x7F).

Portability
isascii is ANSI C.

No supporting OS subroutines are required.


Cygnus C Support Library, Full - iscntrl

iscntrl---control character predicate

Synopsis

#include <ctype.h>
int iscntrl(int c);

Description
iscntrl is a macro which classifies ASCII integer values by table lookup. It is a predicate returning non-zero for control characters, and 0 for other characters. It is defined only when isascii(c) is true or c is EOF.

You can use a compiled subroutine instead of the macro definition by undefining the macro using `#undef iscntrl'.

Returns
iscntrl returns non-zero if c is a delete character or ordinary control character (0x7F or 0x00--0x1F).

Portability
iscntrl is ANSI C.

No supporting OS subroutines are required.


Cygnus C Support Library, Full - isdigit

isdigit---decimal digit predicate

Synopsis

#include <ctype.h>
int isdigit(int c);

Description
isdigit is a macro which classifies ASCII integer values by table lookup. It is a predicate returning non-zero for decimal digits, and 0 for other characters. It is defined only when isascii(c) is true or c is EOF.

You can use a compiled subroutine instead of the macro definition by undefining the macro using `#undef isdigit'.

Returns
isdigit returns non-zero if c is a decimal digit (0--9).

Portability
isdigit is ANSI C.

No supporting OS subroutines are required.


Cygnus C Support Library, Full - islower

islower---lower-case character predicate

Synopsis

#include <ctype.h>
int islower(int c);

Description
islower is a macro which classifies ASCII integer values by table lookup. It is a predicate returning non-zero for minuscules (lower-case alphabetic characters), and 0 for other characters. It is defined only when isascii(c) is true or c is EOF.

You can use a compiled subroutine instead of the macro definition by undefining the macro using `#undef islower'.

Returns
islower returns non-zero if c is a lower case letter (a--z).

Portability
islower is ANSI C.

No supporting OS subroutines are required.


Cygnus C Support Library, Full - isprint

isprint, isgraph---printable character predicates

Synopsis

#include <ctype.h>
int isprint(int c);
int isgraph(int c);

Description
isprint is a macro which classifies ASCII integer values by table lookup. It is a predicate returning non-zero for printable characters, and 0 for other character arguments. It is defined only when isascii(c) is true or c is EOF.

You can use a compiled subroutine instead of the macro definition by undefining either macro using `#undef isprint' or `#undef isgraph'.

Returns
isprint returns non-zero if c is a printing character, (0x20--0x7E). isgraph behaves identically to isprint, except that the space character (0x20) is excluded.

Portability
isprint and isgraph are ANSI C.

No supporting OS subroutines are required.


Cygnus C Support Library, Full - ispunct

ispunct---punctuation character predicate

Synopsis

#include <ctype.h>
int ispunct(int c);

Description
ispunct is a macro which classifies ASCII integer values by table lookup. It is a predicate returning non-zero for printable punctuation characters, and 0 for other characters. It is defined only when isascii(c) is true or c is EOF.

You can use a compiled subroutine instead of the macro definition by undefining the macro using `#undef ispunct'.

Returns
ispunct returns non-zero if c is a printable punctuation character (isgraph(c) && !isalnum(c)).

Portability
ispunct is ANSI C.

No supporting OS subroutines are required.


Cygnus C Support Library, Full - isspace

isspace---whitespace character predicate

Synopsis

#include <ctype.h>
int isspace(int c);

Description
isspace is a macro which classifies ASCII integer values by table lookup. It is a predicate returning non-zero for whitespace characters, and 0 for other characters. It is defined only when isascii(c) is true or c is EOF.

You can use a compiled subroutine instead of the macro definition by undefining the macro using `#undef isspace'.

Returns
isspace returns non-zero if c is a space, tab, carriage return, new line, vertical tab, or formfeed (0x09--0x0D, 0x20).

Portability
isspace is ANSI C.

No supporting OS subroutines are required.


Cygnus C Support Library, Full - isupper

isupper---uppercase character predicate

Synopsis

#include <ctype.h>
int isupper(int c);

Description
isupper is a macro which classifies ASCII integer values by table lookup. It is a predicate returning non-zero for upper-case letters (A--Z), and 0 for other characters. It is defined only when isascii(c) is true or c is EOF.

You can use a compiled subroutine instead of the macro definition by undefining the macro using `#undef isupper'.

Returns
isupper returns non-zero if c is a upper case letter (A-Z).

Portability
isupper is ANSI C.

No supporting OS subroutines are required.


Cygnus C Support Library, Full - isxdigit

isxdigit---hexadecimal digit predicate

Synopsis

#include <ctype.h>
int isxdigit(int c);

Description
isxdigit is a macro which classifies ASCII integer values by table lookup. It is a predicate returning non-zero for hexadecimal digits, and 0 for other characters. It is defined only when isascii(c) is true or c is EOF.

You can use a compiled subroutine instead of the macro definition by undefining the macro using `#undef isxdigit'.

Returns
isxdigit returns non-zero if c is a hexadecimal digit (0--9, a--f, or A--F).

Portability
isxdigit is ANSI C.

No supporting OS subroutines are required.


Cygnus C Support Library, Full - toascii

toascii---force integers to ASCII range

Synopsis

#include <ctype.h>
int toascii(int c);

Description
toascii is a macro which coerces integers to the ASCII range (0--127) by zeroing any higher-order bits.

You can use a compiled subroutine instead of the macro definition by undefining this macro using `#undef toascii'.

Returns
toascii returns integers between 0 and 127.

Portability
toascii is not ANSI C.

No supporting OS subroutines are required.


Cygnus C Support Library, Full - tolower

tolower---translate characters to lower case

Synopsis

#include <ctype.h>
int tolower(int c);
int _tolower(int c);

Description
tolower is a macro which converts upper-case characters to lower case, leaving all other characters unchanged. It is only defined when c is an integer in the range EOF to 255.

You can use a compiled subroutine instead of the macro definition by undefining this macro using `#undef tolower'.

_tolower performs the same conversion as tolower, but should only be used when c is known to be an uppercase character (A--Z).

Returns
tolower returns the lower-case equivalent of c when it is a character between A and Z, and c otherwise.

_tolower returns the lower-case equivalent of c when it is a character between A and Z. If c is not one of these characters, the behaviour of _tolower is undefined.

Portability
tolower is ANSI C. _tolower is not recommended for portable programs.

No supporting OS subroutines are required.


Cygnus C Support Library, Full - toupper

toupper---translate characters to upper case

Synopsis

#include <ctype.h>
int toupper(int c);
int _toupper(int c);

Description
toupper is a macro which converts lower-case characters to upper case, leaving all other characters unchanged. It is only defined when c is an integer in the range EOF to 255.

You can use a compiled subroutine instead of the macro definition by undefining this macro using `#undef toupper'.

_toupper performs the same conversion as toupper, but should only be used when c is known to be a lowercase character (a--z).

Returns
toupper returns the upper-case equivalent of c when it is a character between a and z, and c otherwise.

_toupper returns the upper-case equivalent of c when it is a character between a and z. If c is not one of these characters, the behaviour of _toupper is undefined.

Portability
toupper is ANSI C. _toupper is not recommended for portable programs.

No supporting OS subroutines are required.


Cygnus C Support Library, Full - Stdio

Input and Output (`stdio.h')

This chapter comprises functions to manage files or other input/output streams. Among these functions are subroutines to generate or scan strings according to specifications from a format string.

The underlying facilities for input and output depend on the host system, but these functions provide a uniform interface.

The corresponding declarations are in `stdio.h'.

The reentrant versions of these functions use macros

_stdin_r(reent)
_stdout_r(reent)
_stderr_r(reent)

instead of the globals stdin, stdout, and stderr. The argument <[reent]> is a pointer to a reentrancy structure.


Cygnus C Support Library, Full - clearerr

clearerr---clear file or stream error indicator

Synopsis

#include <stdio.h>
void clearerr(FILE *fp);

Description
The stdio functions maintain an error indicator with each file pointer fp, to record whether any read or write errors have occurred on the associated file or stream. Similarly, it maintains an end-of-file indicator to record whether there is no more data in the file.

Use clearerr to reset both of these indicators.

See ferror and feof to query the two indicators.

Returns
clearerr does not return a result.

Portability
ANSI C requires clearerr.

No supporting OS subroutines are required.


Cygnus C Support Library, Full - fclose

fclose---close a file

Synopsis

#include <stdio.h>
int fclose(FILE *fp);

Description
If the file or stream identified by fp is open, fclose closes it, after first ensuring that any pending data is written (by calling fflush(fp)).

Returns
fclose returns 0 if successful (including when fp is NULL or not an open file); otherwise, it returns EOF.

Portability
fclose is required by ANSI C.

Required OS subroutines: close, fstat, isatty, lseek, read, sbrk, write.


Cygnus C Support Library, Full - feof

feof---test for end of file

Synopsis

#include <stdio.h>
int feof(FILE *fp);

Description
feof tests whether or not the end of the file identified by fp has been reached.

Returns
feof returns 0 if the end of file has not yet been reached; if at end of file, the result is nonzero.

Portability
feof is required by ANSI C.

No supporting OS subroutines are required.


Cygnus C Support Library, Full - ferror

ferror---test whether read/write error has occurred

Synopsis

#include <stdio.h>
int ferror(FILE *fp);

Description
The stdio functions maintain an error indicator with each file pointer fp, to record whether any read or write errors have occurred on the associated file or stream. Use ferror to query this indicator.

See clearerr to reset the error indicator.

Returns
ferror returns 0 if no errors have occurred; it returns a nonzero value otherwise.

Portability
ANSI C requires ferror.

No supporting OS subroutines are required.


Cygnus C Support Library, Full - fflush

fflush---flush buffered file output

Synopsis

#include <stdio.h>
int fflush(FILE *fp);

Description
The stdio output functions can buffer output before delivering it to the host system, in order to minimize the overhead of system calls.

Use fflush to deliver any such pending output (for the file or stream identified by fp) to the host system.

If fp is NULL, fflush delivers pending output from all open files.

Returns
fflush returns 0 unless it encounters a write error; in that situation, it returns EOF.

Portability
ANSI C requires fflush.

No supporting OS subroutines are required.


Cygnus C Support Library, Full - fgetc

fgetc---get a character from a file or stream

Synopsis

#include <stdio.h>
int fgetc(FILE *fp);

Description
Use fgetc to get the next single character from the file or stream identified by fp. As a side effect, fgetc advances the file's current position indicator.

For a macro version of this function, see getc.

Returns
The next character (read as an unsigned char, and cast to int), unless there is no more data, or the host system reports a read error; in either of these situations, fgetc returns EOF.

You can distinguish the two situations that cause an EOF result by using the ferror and feof functions.

Portability
ANSI C requires fgetc.

Supporting OS subroutines required: close, fstat, isatty, lseek, read, sbrk, write.


Cygnus C Support Library, Full - fgetpos

fgetpos---record position in a stream or file

Synopsis

#include <stdio.h>
int fgetpos(FILE *fp, fpos_t *pos);

Description
Objects of type FILE can have a "position" that records how much of the file your program has already read. Many of the stdio functions depend on this position, and many change it as a side effect.

You can use fgetpos to report on the current position for a file identified by fp; fgetpos will write a value representing that position at *pos. Later, you can use this value with fsetpos to return the file to this position.

In the current implementation, fgetpos simply uses a character count to represent the file position; this is the same number that would be returned by ftell.

Returns
fgetpos returns 0 when successful. If fgetpos fails, the result is 1. Failure occurs on streams that do not support positioning; the global errno indicates this condition with the value ESPIPE.

Portability
fgetpos is required by the ANSI C standard, but the meaning of the value it records is not specified beyond requiring that it be acceptable as an argument to fsetpos. In particular, other conforming C implementations may return a different result from ftell than what fgetpos writes at *pos.

No supporting OS subroutines are required.


Cygnus C Support Library, Full - fgets

fgets---get character string from a file or stream

Synopsis

#include <stdio.h>
char *fgets(char *buf, int n, FILE *fp);

Description
Reads at most n-1 characters from fp until a newline is found. The characters including to the newline are stored in buf. The buffer is terminated with a 0.

Returns
fgets returns the buffer passed to it, with the data filled in. If end of file occurs with some data already accumulated, the data is returned with no other indication. If no data are read, NULL is returned instead.

Portability
fgets should replace all uses of gets. Note however that fgets returns all of the data, while gets removes the trailing newline (with no indication that it has done so.)

Supporting OS subroutines required: close, fstat, isatty, lseek, read, sbrk, write.


Cygnus C Support Library, Full - fiprintf

fiprintf---format output to file (integer only)

Synopsis

#include <stdio.h>

int fiprintf(FILE *fd, const char *format, ...);

Description
fiprintf is a restricted version of fprintf: it has the same arguments and behavior, save that it cannot perform any floating-point formatting--the f, g, G, e, and F type specifiers are not recognized.

Returns
fiprintf returns the number of bytes in the output string, save that the concluding NULL is not counted. fiprintf returns when the end of the format string is encountered. If an error occurs, fiprintf returns EOF.

Portability
fiprintf is not required by ANSI C.

Supporting OS subroutines required: close, fstat, isatty, lseek, read, sbrk, write.


Cygnus C Support Library, Full - fopen

fopen---open a file

Synopsis

#include <stdio.h>
FILE *fopen(const char *file, const char *mode);

FILE *_fopen_r(void *reent,
    const char *file, const char *mode);

Description
fopen initializes the data structures needed to read or write a file. Specify the file's name as the string at file, and the kind of access you need to the file with the string at mode.

The alternate function _fopen_r is a reentrant version. The extra argument reent is a pointer to a reentrancy structure.

Three fundamental kinds of access are available: read, write, and append. *mode must begin with one of the three characters `r', `w', or `a', to select one of these:

r
Open the file for reading; the operation will fail if the file does not exist, or if the host system does not permit you to read it.
w
Open the file for writing from the beginning of the file: effectively, this always creates a new file. If the file whose name you specified already existed, its old contents are discarded.
a
Open the file for appending data, that is writing from the end of file. When you open a file this way, all data always goes to the current end of file; you cannot change this using fseek.

Some host systems distinguish between "binary" and "text" files. Such systems may perform data transformations on data written to, or read from, files opened as "text". If your system is one of these, then you can append a `b' to any of the three modes above, to specify that you are opening the file as a binary file (the default is to open the file as a text file).

`rb', then, means "read binary"; `wb', "write binary"; and `ab', "append binary".

To make C programs more portable, the `b' is accepted on all systems, whether or not it makes a difference.

Finally, you might need to both read and write from the same file. You can also append a `+' to any of the three modes, to permit this. (If you want to append both `b' and `+', you can do it in either order: for example, "rb+" means the same thing as "r+b" when used as a mode string.)

Use "r+" (or "rb+") to permit reading and writing anywhere in an existing file, without discarding any data; "w+" (or "wb+") to create a new file (or begin by discarding all data from an old one) that permits reading and writing anywhere in it; and "a+" (or "ab+") to permit reading anywhere in an existing file, but writing only at the end.

Returns
fopen returns a file pointer which you can use for other file operations, unless the file you requested could not be opened; in that situation, the result is NULL. If the reason for failure was an invalid string at mode, errno is set to EINVAL.

Portability
fopen is required by ANSI C.

Supporting OS subroutines required: close, fstat, isatty, lseek, open, read, sbrk, write.


Cygnus C Support Library, Full - fdopen

fdopen---turn open file into a stream

Synopsis

#include <stdio.h>
FILE *fdopen(int fd, const char *mode);
FILE *_fdopen_r(void *reent,
    int fd, const char *mode);

Description
fdopen produces a file descriptor of type FILE *, from a descriptor for an already-open file (returned, for example, by the system subroutine open rather than by fopen). The mode argument has the same meanings as in fopen.

Returns
File pointer or NULL, as for fopen.

Portability
fdopen is ANSI.


Cygnus C Support Library, Full - fputc

fputc---write a character on a stream or file

Synopsis

#include <stdio.h>
int fputc(int ch, FILE *fp);

Description
fputc converts the argument ch from an int to an unsigned char, then writes it to the file or stream identified by fp.

If the file was opened with append mode (or if the stream cannot support positioning), then the new character goes at the end of the file or stream. Otherwise, the new character is written at the current value of the position indicator, and the position indicator oadvances by one.

For a macro version of this function, see putc.

Returns
If successful, fputc returns its argument ch. If an error intervenes, the result is EOF. You can use `ferror(fp)' to query for errors.

Portability
fputc is required by ANSI C.

Supporting OS subroutines required: close, fstat, isatty, lseek, read, sbrk, write.


Cygnus C Support Library, Full - fputs

fputs---write a character string in a file or stream

Synopsis

#include <stdio.h>
int fputs(const char *s, FILE *fp);

Description
fputs writes the string at s (but without the trailing null) to the file or stream identified by fp.

Returns
If successful, the result is 0; otherwise, the result is EOF.

Portability
ANSI C requires fputs, but does not specify that the result on success must be 0; any non-negative value is permitted.

Supporting OS subroutines required: close, fstat, isatty, lseek, read, sbrk, write.


Cygnus C Support Library, Full - fread

fread---read array elements from a file

Synopsis

#include <stdio.h>
size_t fread(void *buf, size_t size, size_t count,
    FILE *fp);

Description
fread attempts to copy, from the file or stream identified by fp, count elements (each of size size) into memory, starting at buf. fread may copy fewer elements than count if an error, or end of file, intervenes.

fread also advances the file position indicator (if any) for fp by the number of characters actually read.

Returns
The result of fread is the number of elements it succeeded in reading.

Portability
ANSI C requires fread.

Supporting OS subroutines required: close, fstat, isatty, lseek, read, sbrk, write.


Cygnus C Support Library, Full - freopen

freopen---open a file using an existing file descriptor

Synopsis

#include <stdio.h>
FILE *freopen(const char *file, const char *mode,
    FILE *fp);

Description
Use this variant of fopen if you wish to specify a particular file descriptor fp (notably stdin, stdout, or stderr) for the file.

If fp was associated with another file or stream, freopen closes that other file or stream (but ignores any errors while closing it).

file and mode are used just as in fopen.

Returns
If successful, the result is the same as the argument fp. If the file cannot be opened as specified, the result is NULL.

Portability
ANSI C requires freopen.

Supporting OS subroutines required: close, fstat, isatty, lseek, open, read, sbrk, write.


Cygnus C Support Library, Full - fseek

fseek---set file position

Synopsis

#include <stdio.h>
int fseek(FILE *fp, long offset, int whence)

Description
Objects of type FILE can have a "position" that records how much of the file your program has already read. Many of the stdio functions depend on this position, and many change it as a side effect.

You can use fseek to set the position for the file identified by fp. The value of offset determines the new position, in one of three ways selected by the value of whence (defined as macros in `stdio.h'):

SEEK_SET---offset is the absolute file position (an offset from the beginning of the file) desired. offset must be positive.

SEEK_CUR---offset is relative to the current file position. offset can meaningfully be either positive or negative.

SEEK_END---offset is relative to the current end of file. offset can meaningfully be either positive (to increase the size of the file) or negative.

See ftell to determine the current file position.

Returns
fseek returns 0 when successful. If fseek fails, the result is EOF. The reason for failure is indicated in errno: either ESPIPE (the stream identified by fp doesn't support repositioning) or EINVAL (invalid file position).

Portability
ANSI C requires fseek.

Supporting OS subroutines required: close, fstat, isatty, lseek, read, sbrk, write.


Cygnus C Support Library, Full - fsetpos

fsetpos---restore position of a stream or file

Synopsis

#include <stdio.h>
int fsetpos(FILE *fp, const fpos_t *pos);

Description
Objects of type FILE can have a "position" that records how much of the file your program has already read. Many of the stdio functions depend on this position, and many change it as a side effect.

You can use fsetpos to return the file identified by fp to a previous position *pos (after first recording it with fgetpos).

See fseek for a similar facility.

Returns
fgetpos returns 0 when successful. If fgetpos fails, the result is 1. The reason for failure is indicated in errno: either ESPIPE (the stream identified by fp doesn't support repositioning) or EINVAL (invalid file position).

Portability
ANSI C requires fsetpos, but does not specify the nature of *pos beyond identifying it as written by fgetpos.

Supporting OS subroutines required: close, fstat, isatty, lseek, read, sbrk, write.


Cygnus C Support Library, Full - ftell

ftell---return position in a stream or file

Synopsis

#include <stdio.h>
long ftell(FILE *fp);

Description
Objects of type FILE can have a "position" that records how much of the file your program has already read. Many of the stdio functions depend on this position, and many change it as a side effect.

The result of ftell is the current position for a file identified by fp. If you record this result, you can later use it with fseek to return the file to this position.

In the current implementation, ftell simply uses a character count to represent the file position; this is the same number that would be recorded by fgetpos.

Returns
ftell returns the file position, if possible. If it cannot do this, it returns -1L. Failure occurs on streams that do not support positioning; the global errno indicates this condition with the value ESPIPE.

Portability
ftell is required by the ANSI C standard, but the meaning of its result (when successful) is not specified beyond requiring that it be acceptable as an argument to fseek. In particular, other conforming C implementations may return a different result from ftell than what fgetpos records.

No supporting OS subroutines are required.


Cygnus C Support Library, Full - fwrite

fwrite---write array elements

Synopsis

#include <stdio.h>
size_t fwrite(const void *buf, size_t size,
    size_t count, FILE *fp);

Description
fwrite attempts to copy, starting from the memory location buf, count elements (each of size size) into the file or stream identified by fp. fwrite may copy fewer elements than count if an error intervenes.

fwrite also advances the file position indicator (if any) for fp by the number of characters actually written.

Returns
If fwrite succeeds in writing all the elements you specify, the result is the same as the argument count. In any event, the result is the number of complete elements that fwrite copied to the file.

Portability
ANSI C requires fwrite.

Supporting OS subroutines required: close, fstat, isatty, lseek, read, sbrk, write.


Cygnus C Support Library, Full - getc

getc---read a character (macro)

Synopsis

#include <stdio.h>
int getc(FILE *fp);

Description
getc is a macro, defined in stdio.h. You can use getc to get the next single character from the file or stream identified by fp. As a side effect, getc advances the file's current position indicator.

For a subroutine version of this macro, see fgetc.

Returns
The next character (read as an unsigned char, and cast to int), unless there is no more data, or the host system reports a read error; in either of these situations, getc returns EOF.

You can distinguish the two situations that cause an EOF result by using the ferror and feof functions.

Portability
ANSI C requires getc; it suggests, but does not require, that getc be implemented as a macro. The standard explicitly permits macro implementations of getc to use the argument more than once; therefore, in a portable program, you should not use an expression with side effects as the getc argument.

Supporting OS subroutines required: close, fstat, isatty, lseek, read, sbrk, write.


Cygnus C Support Library, Full - getchar

getchar---read a character (macro)

Synopsis

#include <stdio.h>
int getchar(void);

int _getchar_r(void *reent);

Description
getchar is a macro, defined in stdio.h. You can use getchar to get the next single character from the standard input stream. As a side effect, getchar advances the standard input's current position indicator.

The alternate function _getchar_r is a reentrant version. The extra argument reent is a pointer to a reentrancy structure.

Returns
The next character (read as an unsigned char, and cast to int), unless there is no more data, or the host system reports a read error; in either of these situations, getchar returns EOF.

You can distinguish the two situations that cause an EOF result by using `ferror(stdin)' and `feof(stdin)'.

Portability
ANSI C requires getchar; it suggests, but does not require, that getchar be implemented as a macro.

Supporting OS subroutines required: close, fstat, isatty, lseek, read, sbrk, write.


Cygnus C Support Library, Full - gets

gets---get character string (obsolete, use fgets instead)

Synopsis

#include <stdio.h>

char *gets(char *buf);

char *_gets_r(void *reent, char *buf);

Description
Reads characters from standard input until a newline is found. The characters up to the newline are stored in buf. The newline is discarded, and the buffer is terminated with a 0.

This is a dangerous function, as it has no way of checking the amount of space available in buf. One of the attacks used by the Internet Worm of 1988 used this to overrun a buffer allocated on the stack of the finger daemon and overwrite the return address, causing the daemon to execute code downloaded into it over the connection.

The alternate function _gets_r is a reentrant version. The extra argument reent is a pointer to a reentrancy structure.

Returns
gets returns the buffer passed to it, with the data filled in. If end of file occurs with some data already accumulated, the data is returned with no other indication. If end of file occurs with no data in the buffer, NULL is returned.

Supporting OS subroutines required: close, fstat, isatty, lseek, read, sbrk, write.


Cygnus C Support Library, Full - iprintf

iprintf---write formatted output (integer only)

Synopsis

#include <stdio.h>

int iprintf(const char *format, ...);

Description
iprintf is a restricted version of printf: it has the same arguments and behavior, save that it cannot perform any floating-point formatting: the f, g, G, e, and F type specifiers are not recognized.

Returns
iprintf returns the number of bytes in the output string, save that the concluding NULL is not counted. iprintf returns when the end of the format string is encountered. If an error occurs, iprintf returns EOF.

Portability
iprintf is not required by ANSI C.

Supporting OS subroutines required: close, fstat, isatty, lseek, read, sbrk, write.


Cygnus C Support Library, Full - mktemp

mktemp, mkstemp---generate unused file name

Synopsis

#include <stdio.h>
char *mktemp(char *path);
int mkstemp(char *path);

char *_mktemp_r(void *reent, char *path);
int *_mkstemp_r(void *reent, char *path);

Description
mktemp and mkstemp attempt to generate a file name that is not yet in use for any existing file. mkstemp creates the file and opens it for reading and writing; mktemp simply generates the file name.

You supply a simple pattern for the generated file name, as the string at path. The pattern should be a valid filename (including path information if you wish) ending with some number of `X' characters. The generated filename will match the leading part of the name you supply, with the trailing `X' characters replaced by some combination of digits and letters.

The alternate functions _mktemp_r and _mkstemp_r are reentrant versions. The extra argument reent is a pointer to a reentrancy structure.

Returns
mktemp returns the pointer path to the modified string representing an unused filename, unless it could not generate one, or the pattern you provided is not suitable for a filename; in that case, it returns NULL.

mkstemp returns a file descriptor to the newly created file, unless it could not generate an unused filename, or the pattern you provided is not suitable for a filename; in that case, it returns -1.

Portability
ANSI C does not require either mktemp or mkstemp; the System V Interface Definition requires mktemp as of Issue 2.

Supporting OS subroutines required: getpid, open, stat.


Cygnus C Support Library, Full - perror

perror---print an error message on standard error

Synopsis

#include <stdio.h>
void perror(char *prefix);

void _perror_r(void *reent, char *prefix);

Description
Use perror to print (on standard error) an error message corresponding to the current value of the global variable errno. Unless you use NULL as the value of the argument prefix, the error message will begin with the string at prefix, followed by a colon and a space (: ). The remainder of the error message is one of the strings described for strerror.

The alternate function _perror_r is a reentrant version. The extra argument reent is a pointer to a reentrancy structure.

Returns
perror returns no result.

Portability
ANSI C requires perror, but the strings issued vary from one implementation to another.

Supporting OS subroutines required: close, fstat, isatty, lseek, read, sbrk, write.


Cygnus C Support Library, Full - putc

putc---write a character (macro)

Synopsis

#include <stdio.h>
int putc(int ch, FILE *fp);

Description
putc is a macro, defined in stdio.h. putc writes the argument ch to the file or stream identified by fp, after converting it from an int to an unsigned char.

If the file was opened with append mode (or if the stream cannot support positioning), then the new character goes at the end of the file or stream. Otherwise, the new character is written at the current value of the position indicator, and the position indicator advances by one.

For a subroutine version of this macro, see fputc.

Returns
If successful, putc returns its argument ch. If an error intervenes, the result is EOF. You can use `ferror(fp)' to query for errors.

Portability
ANSI C requires putc; it suggests, but does not require, that putc be implemented as a macro. The standard explicitly permits macro implementations of putc to use the fp argument more than once; therefore, in a portable program, you should not use an expression with side effects as this argument.

Supporting OS subroutines required: close, fstat, isatty, lseek, read, sbrk, write.


Cygnus C Support Library, Full - putchar

putchar---write a character (macro)

Synopsis

#include <stdio.h>
int putchar(int ch);

int _putchar_r(void *reent, int ch);

Description
putchar is a macro, defined in stdio.h. putchar writes its argument to the standard output stream, after converting it from an int to an unsigned char.

The alternate function _putchar_r is a reentrant version. The extra argument reent is a pointer to a reentrancy structure.

Returns
If successful, putchar returns its argument ch. If an error intervenes, the result is EOF. You can use `ferror(stdin)' to query for errors.

Portability
ANSI C requires putchar; it suggests, but does not require, that putchar be implemented as a macro.

Supporting OS subroutines required: close, fstat, isatty, lseek, read, sbrk, write.


Cygnus C Support Library, Full - puts

puts---write a character string

Synopsis

#include <stdio.h>
int puts(const char *s);

int _puts_r(void *reent, const char *s);

Description
puts writes the string at s (followed by a newline, instead of the trailing null) to the standard output stream.

The alternate function _puts_r is a reentrant version. The extra argument reent is a pointer to a reentrancy structure.

Returns
If successful, the result is a nonnegative integer; otherwise, the result is EOF.

Portability
ANSI C requires puts, but does not specify that the result on success must be 0; any non-negative value is permitted.

Supporting OS subroutines required: close, fstat, isatty, lseek, read, sbrk, write.


Cygnus C Support Library, Full - remove

remove---delete a file's name

Synopsis

#include <stdio.h>
int remove(char *filename);

int _remove_r(void *reent, char *filename);

Description
Use remove to dissolve the association between a particular filename (the string at filename) and the file it represents. After calling remove with a particular filename, you will no longer be able to open the file by that name.

In this implementation, you may use remove on an open file without error; existing file descriptors for the file will continue to access the file's data until the program using them closes the file.

The alternate function _remove_r is a reentrant version. The extra argument reent is a pointer to a reentrancy structure.

Returns
remove returns 0 if it succeeds, -1 if it fails.

Portability
ANSI C requires remove, but only specifies that the result on failure be nonzero. The behavior of remove when you call it on an open file may vary among implementations.

Supporting OS subroutine required: unlink.


Cygnus C Support Library, Full - rename

rename---rename a file

Synopsis

#include <stdio.h>
int rename(const char *old, const char *new);

int _rename_r(void *reent,
    const char *old, const char *new);

Description
Use rename to establish a new name (the string at new) for a file now known by the string at old. After a successful rename, the file is no longer accessible by the string at old.

If rename fails, the file named *old is unaffected. The conditions for failure depend on the host operating system.

The alternate function _rename_r is a reentrant version. The extra argument reent is a pointer to a reentrancy structure.

Returns
The result is either 0 (when successful) or -1 (when the file could not be renamed).

Portability
ANSI C requires rename, but only specifies that the result on failure be nonzero. The effects of using the name of an existing file as *new may vary from one implementation to another.

Supporting OS subroutines required: link, unlink, or rename.


Cygnus C Support Library, Full - rewind

rewind---reinitialize a file or stream

Synopsis

#include <stdio.h>
void rewind(FILE *fp);

Description
rewind returns the file position indicator (if any) for the file or stream identified by fp to the beginning of the file. It also clears any error indicator and flushes any pending output.

Returns
rewind does not return a result.

Portability
ANSI C requires rewind.

No supporting OS subroutines are required.


Cygnus C Support Library, Full - setbuf

setbuf---specify full buffering for a file or stream

Synopsis

#include <stdio.h>
void setbuf(FILE *fp, char *buf);

Description
setbuf specifies that output to the file or stream identified by fp should be fully buffered. All output for this file will go to a buffer (of size BUFSIZ, specified in `stdio.h'). Output will be passed on to the host system only when the buffer is full, or when an input operation intervenes.

You may, if you wish, supply your own buffer by passing a pointer to it as the argument buf. It must have size BUFSIZ. You can also use NULL as the value of buf, to signal that the setbuf function is to allocate the buffer.

Warnings
You may only use setbuf before performing any file operation other than opening the file.

If you supply a non-null buf, you must ensure that the associated storage continues to be available until you close the stream identified by fp.

Returns
setbuf does not return a result.

Portability
Both ANSI C and the System V Interface Definition (Issue 2) require setbuf. However, they differ on the meaning of a NULL buffer pointer: the SVID issue 2 specification says that a NULL buffer pointer requests unbuffered output. For maximum portability, avoid NULL buffer pointers.

Supporting OS subroutines required: close, fstat, isatty, lseek, read, sbrk, write.


Cygnus C Support Library, Full - setvbuf

setvbuf---specify file or stream buffering

Synopsis

#include <stdio.h>
int setvbuf(FILE *fp, char *buf,
    int mode, size_t size);

Description
Use setvbuf to specify what kind of buffering you want for the file or stream identified by fp, by using one of the following values (from stdio.h) as the mode argument:

_IONBF
Do not use a buffer: send output directly to the host system for the file or stream identified by fp.
_IOFBF
Use full output buffering: output will be passed on to the host system only when the buffer is full, or when an input operation intervenes.
_IOLBF
Use line buffering: pass on output to the host system at every newline, as well as when the buffer is full, or when an input operation intervenes.

Use the size argument to specify how large a buffer you wish. You can supply the buffer itself, if you wish, by passing a pointer to a suitable area of memory as buf. Otherwise, you may pass NULL as the buf argument, and setvbuf will allocate the buffer.

Warnings
You may only use setvbuf before performing any file operation other than opening the file.

If you supply a non-null buf, you must ensure that the associated storage continues to be available until you close the stream identified by fp.

Returns
A 0 result indicates success, EOF failure (invalid mode or size can cause failure).

Portability
Both ANSI C and the System V Interface Definition (Issue 2) require setvbuf. However, they differ on the meaning of a NULL buffer pointer: the SVID issue 2 specification says that a NULL buffer pointer requests unbuffered output. For maximum portability, avoid NULL buffer pointers.

Both specifications describe the result on failure only as a nonzero value.

Supporting OS subroutines required: close, fstat, isatty, lseek, read, sbrk, write.


Cygnus C Support Library, Full - siprintf

siprintf---write formatted output (integer only)

Synopsis

#include <stdio.h>

int siprintf(char *str, const char *format [, arg, ...]);

Description
siprintf is a restricted version of sprintf: it has the same arguments and behavior, save that it cannot perform any floating-point formatting: the f, g, G, e, and F type specifiers are not recognized.

Returns
siprintf returns the number of bytes in the output string, save that the concluding NULL is not counted. siprintf returns when the end of the format string is encountered.

Portability
siprintf is not required by ANSI C.

Supporting OS subroutines required: close, fstat, isatty, lseek, read, sbrk, write.


Cygnus C Support Library, Full - printf

printf, fprintf, sprintf---format output

Synopsis

#include <stdio.h>

int printf(const char *format [, arg, ...]);
int fprintf(FILE *fd, const char *format [, arg, ...]);
int sprintf(char *str, const char *format [, arg, ...]);

Description
printf accepts a series of arguments, applies to each a format specifier from *format, and writes the formatted data to stdout, terminated with a null character. The behavior of printf is undefined if there are not enough arguments for the format. printf returns when it reaches the end of the format string. If there are more arguments than the format requires, excess arguments are ignored.

fprintf and sprintf are identical to printf, other than the destination of the formatted output: fprintf sends the output to a specified file fd, while sprintf stores the output in the specified char array str. For sprintf, the behavior is also undefined if the output *str overlaps with one of the arguments. format is a pointer to a charater string containing two types of objects: ordinary characters (other than %), which are copied unchanged to the output, and conversion specifications, each of which is introduced by %. (To include % in the output, use %% in the format string.) A conversion specification has the following form:

       %[flags][width][.prec][size][type]

The fields of the conversion specification have the following meanings:

  • flags an optional sequence of characters which control output justification, numeric signs, decimal points, trailing zeroes, and octal and hex prefixes. The flag characters are minus (-), plus (+), space ( ), zero (0), and sharp (#). They can appear in any combination.
    -
    The result of the conversion is left justified, and the right is padded with blanks. If you do not use this flag, the result is right justified, and padded on the left.
    +
    The result of a signed conversion (as determined by type) will always begin with a plus or minus sign. (If you do not use this flag, positive values do not begin with a plus sign.)
    " " (space)
    If the first character of a signed conversion specification is not a sign, or if a signed conversion results in no characters, the result will begin with a space. If the space ( ) flag and the plus (+) flag both appear, the space flag is ignored.
    0
    If the type character is d, i, o, u, x, X, e, E, f, g, or G: leading zeroes, are used to pad the field width (following any indication of sign or base); no spaces are used for padding. If the zero (0) and minus (-) flags both appear, the zero (0) flag will be ignored. For d, i, o, u, x, and X conversions, if a precision prec is specified, the zero (0) flag is ignored. Note that 0 is interpreted as a flag, not as the beginning of a field width.
    #
    The result is to be converted to an alternative form, according to the next character:
    0
    increases precision to force the first digit of the result to be a zero.
    x
    a non-zero result will have a 0x prefix.
    X
    a non-zero result will have a 0X prefix.
    e, E or f
    The result will always contain a decimal point even if no digits follow the point. (Normally, a decimal point appears only if a digit follows it.) Trailing zeroes are removed.
    g or G
    same as e or E, but trailing zeroes are not removed.
    all others
    undefined.
  • width width is an optional minimum field width. You can either specify it directly as a decimal integer, or indirectly by using instead an asterisk (*), in which case an int argument is used as the field width. Negative field widths are not supported; if you attempt to specify a negative field width, it is interpreted as a minus (-) flag followed by a positive field width.
  • prec an optional field; if present, it is introduced with `.' (a period). This field gives the maximum number of characters to print in a conversion; the minimum number of digits of an integer to print, for conversions with type d, i, o, u, x, and X; the maximum number of significant digits, for the g and G conversions; or the number of digits to print after the decimal point, for e, E, and f conversions. You can specify the precision either directly as a decimal integer or indirectly by using an asterisk (*), in which case an int argument is used as the precision. Supplying a negative precision is equivalent to omitting the precision. If only a period is specified the precision is zero. If a precision appears with any other conversion type than those listed here, the behavior is undefined.
  • size h, l, and L are optional size characters which override the default way that printf interprets the data type of the corresponding argument. h forces the following d, i, o, u, x or X conversion type to apply to a short or unsigned short. h also forces a following n type to apply to a pointer to a short. Similarily, an l forces the following d, i, o, u, x or X conversion type to apply to a long or unsigned long. l also forces a following n type to apply to a pointer to a long. If an h or an l appears with another conversion specifier, the behavior is undefined. L forces a following e, E, f, g or G conversion type to apply to a long double argument. If L appears with any other conversion type, the behavior is undefined.
  • type type specifies what kind of conversion printf performs. Here is a table of these:
    %
    prints the percent character (%)
    c
    prints arg as single character
    s
    prints characters until precision is reached or a null terminator is encountered; takes a string pointer
    d
    prints a signed decimal integer; takes an int (same as i)
    i
    prints a signed decimal integer; takes an int (same as d)
    o
    prints a signed octal integer; takes an int
    u
    prints an unsigned decimal integer; takes an int
    x
    prints an unsigned hexadecimal integer (using abcdef as digits beyond 9); takes an int
    X
    prints an unsigned hexadecimal integer (using ABCDEF as digits beyond 9); takes an int
    f
    prints a signed value of the form [-]9999.9999; takes a floating point number
    e
    prints a signed value of the form [-]9.9999e[+|-]999; takes a floating point number
    E
    prints the same way as e, but using E to introduce the exponent; takes a floating point number
    g
    prints a signed value in either f or e form, based on given value and precision--trailing zeros and the decimal point are printed only if necessary; takes a floating point number
    G
    prints the same way as g, but using E for the exponent if an exponent is needed; takes a floating point number
    n
    stores (in the same object) a count of the characters written; takes a pointer to int
    p
    prints a pointer in an implementation-defined format. This implementation treats the pointer as an unsigned long (same as Lu).

Returns
sprintf returns the number of bytes in the output string, save that the concluding NULL is not counted. printf and fprintf return the number of characters transmitted. If an error occurs, printf and fprintf return EOF. No error returns occur for sprintf.

Portability
The ANSI C standard specifies that implementations must support at least formatted output of up to 509 characters.

Supporting OS subroutines required: close, fstat, isatty, lseek, read, sbrk, write.


Cygnus C Support Library, Full - scanf

scanf, fscanf, sscanf---scan and format input

Synopsis

#include <stdio.h>

int scanf(const char *format [, arg, ...]);
int fscanf(FILE *fd, const char *format [, arg, ...]);
int sscanf(const char *str, const char *format
    [, arg, ...]);

Description
scanf scans a series of input fields from standard input, one character at a time. Each field is interpreted according to a format specifier passed to scanf in the format string at *format. scanf stores the interpreted input from each field at the address passed to it as the corresponding argument following format. You must supply the same number of format specifiers and address arguments as there are input fields.

There must be sufficient address arguments for the given format specifiers; if not the results are unpredictable and likely disasterous. Excess address arguments are merely ignored.

scanf often produces unexpected results if the input diverges from an expected pattern. Since the combination of gets or fgets followed by sscanf is safe and easy, that is the preferred way to be certain that a program is synchronized with input at the end of a line.

fscanf and sscanf are identical to scanf, other than the source of input: fscanf reads from a file, and sscanf from a string.

The string at *format is a character sequence composed of zero or more directives. Directives are composed of one or more whitespace characters, non-whitespace characters, and format specifications.

Whitespace characters are blank ( ), tab (\t), or newline (\n). When scanf encounters a whitespace character in the format string it will read (but not store) all consecutive whitespace characters up to the next non-whitespace character in the input.

Non-whitespace characters are all other ASCII characters except the percent sign (%). When scanf encounters a non-whitespace character in the format string it will read, but not store a matching non-whitespace character.

Format specifications tell scanf to read and convert characters from the input field into specific types of values, and store then in the locations specified by the address arguments.

Trailing whitespace is left unread unless explicitly matched in the format string.

The format specifiers must begin with a percent sign (%) and have the following form:

       %[*][width][size]type

Each format specification begins with the percent character (%). The other fields are:

*
an optional marker; if present, it suppresses interpretation and assignment of this input field.
width
an optional maximum field width: a decimal integer, which controls the maximum number of characters that will be read before converting the current input field. If the input field has fewer than width characters, scanf reads all the characters in the field, and then proceeds with the next field and its format specification. If a whitespace or a non-convertable character occurs before width character are read, the characters up to that character are read, converted, and stored. Then scanf proceeds to the next format specification.
size
h, l, and L are optional size characters which override the default way that scanf interprets the data type of the corresponding argument.
Modifier   Type(s)
   h       d, i, o, u, x     convert input to short,
                             store in short object

   h       D, I, O, U, X     no effect
           e, f, c, s, n, p

   l       d, i, o, u, x     convert input to long,
                             store in long object

   l       e, f, g           convert input to double
                             store in a double object

   l       D, I, O, U, X     no effect
           c, s, n, p

   L       d, i, o, u, x     convert to long double,
                             store in long double

   L      all others         no effect
type
A character to specify what kind of conversion scanf performs. Here is a table of the conversion characters:
%
No conversion is done; the percent character (%) is stored.
c
Scans one character. Corresponding arg: (char *arg).
s
Reads a character string into the array supplied. Corresponding arg: (char arg[]).
[pattern]
Reads a non-empty character string into memory starting at arg. This area must be large enough to accept the sequence and a terminating null character which will be added automatically. (pattern is discussed in the paragraph following this table). Corresponding arg: (char *arg).
d
Reads a decimal integer into the corresponding arg: (int *arg).
D
Reads a decimal integer into the corresponding arg: (long *arg).
o
Reads an octal integer into the corresponding arg: (int *arg).
O
Reads an octal integer into the corresponding arg: (long *arg).
u
Reads an unsigned decimal integer into the corresponding arg: (unsigned int *arg).
U
Reads an unsigned decimal integer into the corresponding arg: (unsigned long *arg).
x,X
Read a hexadecimal integer into the corresponding arg: (int *arg).
e, f, g
Read a floating point number into the corresponding arg: (float *arg).
E, F, G
Read a floating point number into the corresponding arg: (double *arg).
i
Reads a decimal, octal or hexadecimal integer into the corresponding arg: (int *arg).
I
Reads a decimal, octal or hexadecimal integer into the corresponding arg: (long *arg).
n
Stores the number of characters read in the corresponding arg: (int *arg).
p
Stores a scanned pointer. ANSI C leaves the details to each implementation; this implementation treats %p exactly the same as %U. Corresponding arg: (void **arg).
A pattern of characters surrounded by square brackets can be used instead of the s type character. pattern is a set of characters which define a search set of possible characters making up the scanf input field. If the first character in the brackets is a caret (^), the search set is inverted to include all ASCII characters except those between the brackets. There is also a range facility which you can use as a shortcut. %[0-9] matches all decimal digits. The hyphen must not be the first or last character in the set. The character prior to the hyphen must be lexically less than the character after it. Here are some pattern examples:
%[abcd]
matches strings containing only a, b, c, and d.
%[^abcd]
matches strings containing any characters except a, b, c, or d
%[A-DW-Z]
matches strings containing A, B, C, D, W, X, Y, Z
%[z-a]
matches the characters z, -, and a
Floating point numbers (for field types e, f, g, E, F, G) must correspond to the following general form:
        [+/-] ddddd[.]ddd [E|e[+|-]ddd]
where objects inclosed in square brackets are optional, and ddd represents decimal, octal, or hexadecimal digits.

Returns
scanf returns the number of input fields successfully scanned, converted and stored; the return value does not include scanned fields which were not stored.

If scanf attempts to read at end-of-file, the return value is EOF.

If no fields were stored, the return value is 0.

scanf might stop scanning a particular field before reaching the normal field end character, or may terminate entirely.

scanf stops scanning and storing the current field and moves to the next input field (if any) in any of the following situations:

  • The assignment suppressing character (*) appears after the % in the format specification; the current input field is scanned but not stored.
  • width characters have been read (width is a width specification, a positive decimal integer).
  • The next character read cannot be converted under the the current format (for example, if a Z is read when the format is decimal).
  • The next character in the input field does not appear in the search set (or does appear in the inverted search set).

When scanf stops scanning the current input field for one of these reasons, the next character is considered unread and used as the first character of the following input field, or the first character in a subsequent read operation on the input.

scanf will terminate under the following circumstances:

  • The next character in the input field conflicts with a corresponding non-whitespace character in the format string.
  • The next character in the input field is EOF.
  • The format string has been exhausted.

When the format string contains a character sequence that is not part of a format specification, the same character sequence must appear in the input; scanf will scan but not store the matched characters. If a conflict occurs, the first conflicting character remains in the input as if it had never been read.

Portability
scanf is ANSI C.

Supporting OS subroutines required: close, fstat, isatty, lseek, read, sbrk, write.


Cygnus C Support Library, Full - tmpfile

tmpfile---create a temporary file

Synopsis

#include <stdio.h>
FILE *tmpfile(void);

FILE *_tmpfile_r(void *reent);

Description
Create a temporary file (a file which will be deleted automatically), using a name generated by tmpnam. The temporary file is opened with the mode "wb+", permitting you to read and write anywhere in it as a binary file (without any data transformations the host system may perform for text files).

The alternate function _tmpfile_r is a reentrant version. The argument reent is a pointer to a reentrancy structure.

Returns
tmpfile normally returns a pointer to the temporary file. If no temporary file could be created, the result is NULL, and errno records the reason for failure.

Portability
Both ANSI C and the System V Interface Definition (Issue 2) require tmpfile.

Supporting OS subroutines required: close, fstat, getpid, isatty, lseek, open, read, sbrk, write.

tmpfile also requires the global pointer environ.


Cygnus C Support Library, Full - tmpnam

tmpnam, tempnam---name for a temporary file

Synopsis

#include <stdio.h>
char *tmpnam(char *s);
char *tempnam(char *dir, char *pfx);
char *_tmpnam_r(void *reent, char *s);
char *_tempnam_r(void *reent, char *dir, char *pfx);

Description
Use either of these functions to generate a name for a temporary file. The generated name is guaranteed to avoid collision with other files (for up to TMP_MAX calls of either function).

tmpnam generates file names with the value of P_tmpdir (defined in `stdio.h') as the leading directory component of the path.

You can use the tmpnam argument s to specify a suitable area of memory for the generated filename; otherwise, you can call tmpnam(NULL) to use an internal static buffer.

tempnam allows you more control over the generated filename: you can use the argument dir to specify the path to a directory for temporary files, and you can use the argument pfx to specify a prefix for the base filename.

If dir is NULL, tempnam will attempt to use the value of environment variable TMPDIR instead; if there is no such value, tempnam uses the value of P_tmpdir (defined in `stdio.h').

If you don't need any particular prefix to the basename of temporary files, you can pass NULL as the pfx argument to tempnam.

_tmpnam_r and _tempnam_r are reentrant versions of tmpnam and tempnam respectively. The extra argument reent is a pointer to a reentrancy structure.

Warnings
The generated filenames are suitable for temporary files, but do not in themselves make files temporary. Files with these names must still be explicitly removed when you no longer want them.

If you supply your own data area s for tmpnam, you must ensure that it has room for at least L_tmpnam elements of type char.

Returns
Both tmpnam and tempnam return a pointer to the newly generated filename.

Portability
ANSI C requires tmpnam, but does not specify the use of P_tmpdir. The System V Interface Definition (Issue 2) requires both tmpnam and tempnam.

Supporting OS subroutines required: close, fstat, getpid, isatty, lseek, open, read, sbrk, write.

The global pointer environ is also required.


Cygnus C Support Library, Full - vprintf

vprintf, vfprintf, vsprintf---format argument list

Synopsis

#include <stdio.h>
#include <stdarg.h>
int vprintf(const char *fmt, va_list list);
int vfprintf(FILE *fp, const char *fmt, va_list list);
int vsprintf(char *str, const char *fmt, va_list list);

int _vprintf_r(void *reent, const char *fmt,
    va_list list);
int _vfprintf_r(void *reent, FILE *fp, const char *fmt,
    va_list list);
int _vsprintf_r(void *reent, char *str, const char *fmt,
    va_list list);

Description
vprintf, vfprintf, and vsprintf are (respectively) variants of printf, fprintf, and sprintf. They differ only in allowing their caller to pass the variable argument list as a va_list object (initialized by va_start) rather than directly accepting a variable number of arguments.

Returns
The return values are consistent with the corresponding functions: vsprintf returns the number of bytes in the output string, save that the concluding NULL is not counted. vprintf and vfprintf return the number of characters transmitted. If an error occurs, vprintf and vfprintf return EOF. No error returns occur for vsprintf.

Portability
ANSI C requires all three functions.

Supporting OS subroutines required: close, fstat, isatty, lseek, read, sbrk, write.


Cygnus C Support Library, Full - Strings

Strings and Memory (`string.h')

This chapter describes string-handling functions and functions for managing areas of memory. The corresponding declarations are in `string.h'.


Cygnus C Support Library, Full - bcmp

bcmp---compare two memory areas

Synopsis

#include <string.h>
int bcmp(const char *s1, const char *s2, size_t n);

Description
This function compares not more than n characters of the object pointed to by s1 with the object pointed to by s2.

This function is identical to memcmp.
Returns
The function returns an integer greater than, equal to or less than zero according to whether the object pointed to by s1 is greater than, equal to or less than the object pointed to by s2.

Portability
bcmp requires no supporting OS subroutines.


Cygnus C Support Library, Full - bcopy

bcopy---copy memory regions

Synopsis

#include <string.h>
void bcopy(const char *in, char  *out, size_t n);

Description
This function copies n bytes from the memory region pointed to by in to the memory region pointed to by out.

This function is implemented in term of memmove.

Portability
bcopy requires no supporting OS subroutines.


Cygnus C Support Library, Full - bzero

bzero---initialize memory to zero

Synopsis

#include <string.h>
void bzero(char *b, size_t length);

Description
bzero initializes length bytes of memory, starting at address b, to zero.

Returns
bzero does not return a result.

Portability
bzero is in the Berkeley Software Distribution. Neither ANSI C nor the System V Interface Definition (Issue 2) require bzero.

bzero requires no supporting OS subroutines.


Cygnus C Support Library, Full - index

index---search for character in string

Synopsis

#include <string.h>
char * index(const char *string, int c);

Description
This function finds the first occurence of c (converted to a char) in the string pointed to by string (including the terminating null character).

This function is identical to strchr.

Returns
Returns a pointer to the located character, or a null pointer if c does not occur in string.

Portability
index requires no supporting OS subroutines.


Cygnus C Support Library, Full - memchr

memchr---find character in memory

Synopsis

#include <string.h>
void *memchr(const void *src, int c, size_t length);

Description
This function searches memory starting at *src for the character c. The search only ends with the first occurrence of c, or after length characters; in particular, NULL does not terminate the search.

Returns
If the character c is found within length characters of *src, a pointer to the character is returned. If c is not found, then NULL is returned.

Portability
memchr> is ANSI C.

memchr requires no supporting OS subroutines.


Cygnus C Support Library, Full - memcmp

memcmp---compare two memory areas

Synopsis

#include <string.h>
int memcmp(const void *s1, const void *s2, size_t n);

Description
This function compares not more than n characters of the object pointed to by s1 with the object pointed to by s2.

Returns
The function returns an integer greater than, equal to or less than zero according to whether the object pointed to by s1 is greater than, equal to or less than the object pointed to by s2.

Portability
memcmp is ANSI C.

memcmp requires no supporting OS subroutines.


Cygnus C Support Library, Full - memcpy

memcpy---copy memory regions

Synopsis

#include <string.h>
void* memcpy(void *out, const void *in, size_t n);

Description
This function copies n bytes from the memory region pointed to by in to the memory region pointed to by out.

If the regions overlap, the behavior is undefined.

Returns
memcpy returns a pointer to the first byte of the out region.

Portability
memcpy is ANSI C.

memcpy requires no supporting OS subroutines.


Cygnus C Support Library, Full - memmove

memmove---move possibly overlapping memory

Synopsis

#include <string.h>
void *memmove(void *dst, const void *src, size_t length);

Description
This function moves length characters from the block of memory starting at *src to the memory starting at *dst. memmove reproduces the characters correctly at *dst even if the two areas overlap.

Returns
The function returns dst as passed.

Portability
memmove is ANSI C.

memmove requires no supporting OS subroutines.


Cygnus C Support Library, Full - memset

memset---set an area of memory

Synopsis

#include <string.h>
void *memset(const void *dst, int c, size_t length);

Description
This function converts the argument c into an unsigned char and fills the first length characters of the array pointed to by dst to the value.

Returns
memset returns the value of m.

Portability
memset is ANSI C.

memset requires no supporting OS subroutines.


Cygnus C Support Library, Full - rindex

rindex---reverse search for character in string

Synopsis

#include <string.h>
char * rindex(const char *string, int c);

Description
This function finds the last occurence of c (converted to a char) in the string pointed to by string (including the terminating null character).

This function is identical to strrchr.

Returns
Returns a pointer to the located character, or a null pointer if c does not occur in string.

Portability
rindex requires no supporting OS subroutines.


Cygnus C Support Library, Full - strcat

strcat---concatenate strings

Synopsis

#include <string.h>
char *strcat(char *dst, const char *src);

Description
strcat appends a copy of the string pointed to by src (including the terminating null character) to the end of the string pointed to by dst. The initial character of src overwrites the null character at the end of dst.

Returns
This function returns the initial value of dst

Portability
strcat is ANSI C.

strcat requires no supporting OS subroutines.


Cygnus C Support Library, Full - strchr

strchr---search for character in string

Synopsis

#include <string.h>
char * strchr(const char *string, int c);

Description
This function finds the first occurence of c (converted to a char) in the string pointed to by string (including the terminating null character).

Returns
Returns a pointer to the located character, or a null pointer if c does not occur in string.

Portability
strchr is ANSI C.

strchr requires no supporting OS subroutines.


Cygnus C Support Library, Full - strcmp

strcmp---character string compare

Synopsis

#include <string.h>
int strcmp(const char *a, const char *b);

Description
strcmp compares the string at a to the string at b.

Returns
If *a sorts lexicographically after *b, strcmp returns a number greater than zero. If the two strings match, strcmp returns zero. If *a sorts lexicographically before *b, strcmp returns a number less than zero.

Portability
strcmp is ANSI C.

strcmp requires no supporting OS subroutines.


Cygnus C Support Library, Full - strcoll

strcoll---locale specific character string compare

Synopsis

#include <string.h>
int strcoll(const char *stra, const char * strb);

Description
strcoll compares the string pointed to by stra to the string pointed to by strb, using an interpretation appropriate to the current LC_COLLATE state.

Returns
If the first string is greater than the second string, strcoll returns a number greater than zero. If the two strings are equivalent, strcoll returns zero. If the first string is less than the second string, strcoll returns a number less than zero.

Portability
strcoll is ANSI C.

strcoll requires no supporting OS subroutines.


Cygnus C Support Library, Full - strcpy

strcpy---copy string

Synopsis

#include <string.h>
char *strcpy(char *dst, const char *src);

Description
strcpy copies the string pointed to by src (including the terminating null character) to the array pointed to by dst.

Returns
This function returns the initial value of dst.

Portability
strcpy is ANSI C.

strcpy requires no supporting OS subroutines.


Cygnus C Support Library, Full - strcspn

strcspn---count chars not in string

Synopsis

size_t strcspn(const char *s1, const char *s2);

Description
This function computes the length of the initial part of the string pointed to by s1 which consists entirely of characters NOT from the string pointed to by s2 (excluding the terminating null character).

Returns
strcspn returns the length of the substring found.

Portability
strcspn is ANSI C.

strcspn requires no supporting OS subroutines.


Cygnus C Support Library, Full - strerror

strerror---convert error number to string

Synopsis

#include <string.h>
char *strerror(int errnum);

Description
strerror converts the error number errnum into a string. The value of errnum is usually a copy of errno. If errnum is not a known error number, the result points to an empty string.

This implementation of strerror prints out the following strings for each of the values defined in `errno.h':

E2BIG
Arg list too long
EACCES
Permission denied
EADV
Advertise error
EAGAIN
No more processes
EBADF
Bad file number
EBADMSG
Bad message
EBUSY
Device or resource busy
ECHILD
No children
ECOMM
Communication error
EDEADLK
Deadlock
EEXIST
File exists
EDOM
Math argument
EFAULT
Bad address
EFBIG
File too large
EIDRM
Identifier removed
EINTR
Interrupted system call
EINVAL
Invalid argument
EIO
I/O error
EISDIR
Is a directory
ELIBACC
Cannot access a needed shared library
ELIBBAD
Accessing a corrupted shared library
ELIBEXEC
Cannot exec a shared library directly
ELIBMAX
Attempting to link in more shared libraries than system limit
ELIBSCN
.lib section in a.out corrupted
EMFILE
Too many open files
EMLINK
Too many links
EMULTIHOP
Multihop attempted
ENAMETOOLONG
File or path name too long
ENFILE
Too many open files in system
ENODEV
No such device
ENOENT
No such file or directory
ENOEXEC
Exec format error
ENOLCK
No lock
ENOLINK
Virtual circuit is gone
ENOMEM
Not enough space
ENOMSG
No message of desired type
ENONET
Machine is not on the network
ENOPKG
No package
ENOSPC
No space left on device
ENOSR
No stream resources
ENOSTR
Not a stream
ENOSYS
Function not implemented
ENOTBLK
Block device required
ENOTDIR
Not a directory
ENOTEMPTY
Directory not empty
ENOTTY
Not a character device
ENXIO
No such device or address
EPERM
Not owner
EPIPE
Broken pipe
EPROTO
Protocol error
ERANGE
Result too large
EREMOTE
Resource is remote
EROFS
Read-only file system
ESPIPE
Illegal seek
ESRCH
No such process
ESRMNT
Srmount error
ETIME
Stream ioctl timeout
ETXTBSY
Text file busy
EXDEV
Cross-device link

Returns
This function returns a pointer to a string. Your application must not modify that string.

Portability
ANSI C requires strerror, but does not specify the strings used for each error number.

Although this implementation of strerror is reentrant, ANSI C declares that subsequent calls to strerror may overwrite the result string; therefore portable code cannot depend on the reentrancy of this subroutine.

This implementation of strerror provides for user-defined extensibility. errno.h defines __ELASTERROR, which can be used as a base for user-defined error values. If the user supplies a routine named _user_strerror, and errnum passed to strerror does not match any of the supported values, _user_strerror is called with errnum as its argument.

_user_strerror takes one argument of type int, and returns a character pointer. If errnum is unknown to _user_strerror, _user_strerror returns NULL. The default _user_strerror returns NULL for all input values.

strerror requires no supporting OS subroutines.


Cygnus C Support Library, Full - strlen

strlen---character string length

Synopsis

#include <string.h>
size_t strlen(const char *str);

Description
The strlen function works out the length of the string starting at *str by counting chararacters until it reaches a NULL character.

Returns
strlen returns the character count.

Portability
strlen is ANSI C.

strlen requires no supporting OS subroutines.


Cygnus C Support Library, Full - strlwr

strlwr---force string to lower case

Synopsis

#include <string.h>
char *strlwr(char *a);

Description
strlwr converts each characters in the string at a to lower case.

Returns
strlwr returns its argument, a.

Portability
strlwr is not widely portable.

strlwr requires no supporting OS subroutines.


Cygnus C Support Library, Full - strncat

strncat---concatenate strings

Synopsis

#include <string.h>
char *strncat(char *dst, const char *src, size_t length);

Description
strncat appends not more than length characters from the string pointed to by src (including the terminating null character) to the end of the string pointed to by dst. The initial character of src overwrites the null character at the end of dst. A terminating null character is always appended to the result

Warnings
Note that a null is always appended, so that if the copy is limited by the length argument, the number of characters appended to dst is n + 1.
Returns
This function returns the initial value of dst

Portability
strncat is ANSI C.

strncat requires no supporting OS subroutines.


Cygnus C Support Library, Full - strncmp

strncmp---character string compare

Synopsis

#include <string.h>
int strncmp(const char *a, const char * b, size_t length);

Description
strncmp compares up to length characters from the string at a to the string at b.

Returns
If *a sorts lexicographically after *b, strncmp returns a number greater than zero. If the two strings are equivalent, strncmp returns zero. If *a sorts lexicographically before *b, strncmp returns a number less than zero.

Portability
strncmp is ANSI C.

strncmp requires no supporting OS subroutines.


Cygnus C Support Library, Full - strncpy

strncpy---counted copy string

Synopsis

#include <string.h>
char *strncpy(char *dst, const char *src, size_t length);

Description
strncpy copies not more than length characters from the the string pointed to by src (including the terminating null character) to the array pointed to by dst. If the string pointed to by src is shorter than length characters, null characters are appended to the destination array until a total of length characters have been written.

Returns
This function returns the initial value of dst.

Portability
strncpy is ANSI C.

strncpy requires no supporting OS subroutines.


Cygnus C Support Library, Full - strpbrk

strpbrk---find chars in string

Synopsis

#include <string.h>
char *strpbrk(const char *s1, const char *s2);

Description
This function locates the first occurence in the string pointed to by s1 of any character in string pointed to by s2 (excluding the terminating null character).

Returns
strpbrk returns a pointer to the character found in s1, or a null pointer if no character from s2 occurs in s1.

Portability
strpbrk requires no supporting OS subroutines.


Cygnus C Support Library, Full - strrchr

strrchr---reverse search for character in string

Synopsis

#include <string.h>
char * strrchr(const char *string, int c);

Description
This function finds the last occurence of c (converted to a char) in the string pointed to by string (including the terminating null character).

Returns
Returns a pointer to the located character, or a null pointer if c does not occur in string.

Portability
strrchr is ANSI C.

strrchr requires no supporting OS subroutines.


Cygnus C Support Library, Full - strspn

strspn---find initial match

Synopsis

#include <string.h>
size_t strspn(const char *s1, const char *s2);

Description
This function computes the length of the initial segment of the string pointed to by s1 which consists entirely of characters from the string pointed to by s2 (excluding the terminating null character).

Returns
strspn returns the length of the segment found.

Portability
strspn is ANSI C.

strspn requires no supporting OS subroutines.


Cygnus C Support Library, Full - strstr

strstr---find string segment

Synopsis

#include <string.h>
char *strstr(const char *s1, const char *s2);

Description
Locates the first occurence in the string pointed to by s1 of the sequence of characters in the string pointed to by s2 (excluding the terminating null character).

Returns
Returns a pointer to the located string segment, or a null pointer if the string s2 is not found. If s2 points to a string with zero length, the s1 is returned.

Portability
strstr is ANSI C.

strstr requires no supporting OS subroutines.


Cygnus C Support Library, Full - strtok

strtok---get next token from a string

Synopsis

#include <string.h>
char *strtok(char *source, const char *delimiters)
char *strtok_r(char *source, const char *delimiters,
    char **lasts)

Description
The strtok function is used to isolate sequential tokens in a null-terminated string, *source. These tokens are delimited in the string by at least one of the characters in *delimiters. The first time that strtok is called, *source should be specified; subsequent calls, wishing to obtain further tokens from the same string, should pass a null pointer instead. The separator string, *delimiters, must be supplied each time, and may change between calls.

The strtok function returns a pointer to the beginning of each subsequent token in the string, after replacing the separator character itself with a NUL character. When no more tokens remain, a null pointer is returned.

The strtok_r function has the same behavior as strtok, except a pointer to placeholder *[lasts> must be supplied by the caller.

Returns
strtok returns a pointer to the next token, or NULL if no more tokens can be found.

Portability
strtok is ANSI C.

strtok requires no supporting OS subroutines.


Cygnus C Support Library, Full - strupr

strupr---force string to uppercase

Synopsis

#include <string.h>
char *strupr(char *a);

Description
strupr converts each characters in the string at a to upper case.

Returns
strupr returns its argument, a.

Portability
strupr is not widely portable.

strupr requires no supporting OS subroutines.


Cygnus C Support Library, Full - strxfrm

strxfrm---transform string

Synopsis

#include <string.h>
size_t strxfrm(char *s1, const char *s2, size_t n);

Description
This function transforms the string pointed to by s2 and places the resulting string into the array pointed to by s1. The transformation is such that if the strcmp function is applied to the two transformed strings, it returns a value greater than, equal to, or less than zero, correspoinding to the result of a strcoll function applied to the same two original strings.

No more than n characters are placed into the resulting array pointed to by s1, including the terminating null character. If n is zero, s1 may be a null pointer. If copying takes place between objects that overlap, the behavior is undefined.

With a C locale, this function just copies.

Returns
The strxfrm function returns the length of the transformed string (not including the terminating null character). If the value returned is n or more, the contents of the array pointed to by s1 are indeterminate.

Portability
strxfrm is ANSI C.

strxfrm requires no supporting OS subroutines.


Cygnus C Support Library, Full - Signals

Signal Handling (`signal.h')

A signal is an event that interrupts the normal flow of control in your program. Your operating environment normally defines the full set of signals available (see `sys/signal.h'), as well as the default means of dealing with them--typically, either printing an error message and aborting your program, or ignoring the signal.

All systems support at least the following signals:

SIGABRT
Abnormal termination of a program; raised by the <<abort>> function.
SIGFPE
A domain error in arithmetic, such as overflow, or division by zero.
SIGILL
Attempt to execute as a function data that is not executable.
SIGINT
Interrupt; an interactive attention signal.
SIGSEGV
An attempt to access a memory location that is not available.
SIGTERM
A request that your program end execution.

Two functions are available for dealing with asynchronous signals--one to allow your program to send signals to itself (this is called raising a signal), and one to specify subroutines (called handlers to handle particular signals that you anticipate may occur--whether raised by your own program or the operating environment.

To support these functions, `signal.h' defines three macros:

SIG_DFL
Used with the signal function in place of a pointer to a handler subroutine, to select the operating environment's default handling of a signal.
SIG_IGN
Used with the signal function in place of a pointer to a handler, to ignore a particular signal.
SIG_ERR
Returned by the signal function in place of a pointer to a handler, to indicate that your request to set up a handler could not be honored for some reason.

`signal.h' also defines an integral type, sig_atomic_t. This type is not used in any function declarations; it exists only to allow your signal handlers to declare a static storage location where they may store a signal value. (Static storage is not otherwise reliable from signal handlers.)


Cygnus C Support Library, Full - raise

raise---send a signal

Synopsis

#include <signal.h>
int raise(int sig);

int _raise_r(void *reent, int sig);

Description
Send the signal sig (one of the macros from `sys/signal.h'). This interrupts your program's normal flow of execution, and allows a signal handler (if you've defined one, using signal) to take control.

The alternate function _raise_r is a reentrant version. The extra argument reent is a pointer to a reentrancy structure.

Returns
The result is 0 if sig was successfully raised, 1 otherwise. However, the return value (since it depends on the normal flow of execution) may not be visible, unless the signal handler for sig terminates with a return or unless SIG_IGN is in effect for this signal.

Portability
ANSI C requires raise, but allows the full set of signal numbers to vary from one implementation to another.

Required OS subroutines: getpid, kill.


Cygnus C Support Library, Full - signal

signal---specify handler subroutine for a signal

Synopsis

#include <signal.h>
void ( * signal(int sig, void(*func)(int)) )(int);

void ( * _signal_r(void *reent,
    int sig, void(*func)(int)) )(int);

int raise (int sig);

int _raise_r (void *reent, int sig);

Description
signal, raise provide a simple signal/raise implementation for embedded targets.

signal allows you to request changed treatment for a particular signal sig. You can use one of the predefined macros SIG_DFL (select system default handling) or SIG_IGN (ignore this signal) as the value of func; otherwise, func is a function pointer that identifies a subroutine in your program as the handler for this signal.

Some of the execution environment for signal handlers is unpredictable; notably, the only library function required to work correctly from within a signal handler is signal itself, and only when used to redefine the handler for the current signal value.

Static storage is likewise unreliable for signal handlers, with one exception: if you declare a static storage location as `volatile sig_atomic_t', then you may use that location in a signal handler to store signal values.

If your signal handler terminates using return (or implicit return), your program's execution continues at the point where it was when the signal was raised (whether by your program itself, or by an external event). Signal handlers can also use functions such as exit and abort to avoid returning.

raise sends the signal sig to the executing program. It returns zero if successful, non-zero if unsuccessful.

The alternate functions _signal_r, _raise_r are the reentrant versions. The extra argument reent is a pointer to a reentrancy structure.

Returns
If your request for a signal handler cannot be honored, the result is SIG_ERR; a specific error number is also recorded in errno.

Otherwise, the result is the previous handler (a function pointer or one of the predefined macros).

Portability
ANSI C requires raise, signal.

No supporting OS subroutines are required to link with signal, but it will not have any useful effects, except for software generated signals, without an operating system that can actually raise exceptions.


Cygnus C Support Library, Full - Timefns

Time Functions (`time.h')

This chapter groups functions used either for reporting on time (elapsed, current, or compute time) or to perform calculations based on time.

The header file `time.h' defines three types. clock_t and time_t are both used for representations of time particularly suitable for arithmetic. (In this implementation, quantities of type clock_t have the highest resolution possible on your machine, and quantities of type time_t resolve to seconds.) size_t is also defined if necessary for quantities representing sizes.

`time.h' also defines the structure tm for the traditional representation of Gregorian calendar time as a series of numbers, with the following fields:

tm_sec
Seconds.
tm_min
Minutes.
tm_hour
Hours.
tm_mday
Day.
tm_mon
Month.
tm_year
Year (since 1900).
tm_wday
Day of week: the number of days since Sunday.
tm_yday
Number of days elapsed since last January 1.
tm_isdst
Daylight Savings Time flag: positive means DST in effect, zero means DST not in effect, negative means no information about DST is available.


Cygnus C Support Library, Full - asctime

asctime---format time as string

Synopsis

#include <time.h>
char *asctime(const struct tm *clock);
char *asctime_r(const struct tm *clock, char *buf);

Description
Format the time value at clock into a string of the form

 Wed Jun 15 11:38:07 1988\n\0

The string is generated in a static buffer; each call to asctime overwrites the string generated by previous calls.

Returns
A pointer to the string containing a formatted timestamp.

Portability
ANSI C requires asctime.

asctime requires no supporting OS subroutines.


Cygnus C Support Library, Full - clock

clock---cumulative processor time

Synopsis

#include <time.h>
clock_t clock(void);

Description
Calculates the best available approximation of the cumulative amount of time used by your program since it started. To convert the result into seconds, divide by the macro CLOCKS_PER_SEC.

Returns
The amount of processor time used so far by your program, in units defined by the machine-dependent macro CLOCKS_PER_SEC. If no measurement is available, the result is -1.

Portability
ANSI C requires clock and CLOCKS_PER_SEC.

Supporting OS subroutine required: times.


Cygnus C Support Library, Full - ctime

ctime---convert time to local and format as string

Synopsis

#include <time.h>
char *ctime(time_t clock);
char *ctime_r(time_t clock, char *buf);

Description
Convert the time value at clock to local time (like localtime) and format it into a string of the form

 Wed Jun 15 11:38:07 1988\n\0

(like asctime).

Returns
A pointer to the string containing a formatted timestamp.

Portability
ANSI C requires ctime.

ctime requires no supporting OS subroutines.


Cygnus C Support Library, Full - difftime

difftime---subtract two times

Synopsis

#include <time.h>
double difftime(time_t tim1, time_t tim2);

Description
Subtracts the two times in the arguments: `tim1 - tim2'.

Returns
The difference (in seconds) between tim2 and tim1, as a double.

Portability
ANSI C requires difftime, and defines its result to be in seconds in all implementations.

difftime requires no supporting OS subroutines.


Cygnus C Support Library, Full - gmtime

gmtime---convert time to UTC traditional form

Synopsis

#include <time.h>
struct tm *gmtime(const time_t *clock);
struct tm *gmtime_r(const time_t *clock, struct tm *res);

Description
gmtime assumes the time at clock represents a local time. gmtime converts it to UTC (Universal Coordinated Time, also known in some countries as GMT, Greenwich Mean time), then converts the representation from the arithmetic representation to the traditional representation defined by struct tm.

gmtime constructs the traditional time representation in static storage; each call to gmtime or localtime will overwrite the information generated by previous calls to either function.

Returns
A pointer to the traditional time representation (struct tm).

Portability
ANSI C requires gmtime.

gmtime requires no supporting OS subroutines.


Cygnus C Support Library, Full - localtime

localtime---convert time to local representation

Synopsis

#include <time.h>
struct tm *localtime(time_t *clock);
struct tm *localtime_r(time_t *clock, struct tm *res);

Description
localtime converts the time at clock into local time, then converts its representation from the arithmetic representation to the traditional representation defined by struct tm.

localtime constructs the traditional time representation in static storage; each call to gmtime or localtime will overwrite the information generated by previous calls to either function.

mktime is the inverse of localtime.

Returns
A pointer to the traditional time representation (struct tm).

Portability
ANSI C requires localtime.

localtime requires no supporting OS subroutines.


Cygnus C Support Library, Full - mktime

mktime---convert time to arithmetic representation

Synopsis

#include <time.h>
time_t mktime(struct tm *timp);

Description
mktime assumes the time at timp is a local time, and converts its representation from the traditional representation defined by struct tm into a representation suitable for arithmetic.

localtime is the inverse of mktime.

Returns
If the contents of the structure at timp do not form a valid calendar time representation, the result is -1. Otherwise, the result is the time, converted to a time_t value.

Portability
ANSI C requires mktime.

mktime requires no supporting OS subroutines.


Cygnus C Support Library, Full - strftime

strftime---flexible calendar time formatter

Synopsis

#include <time.h>
size_t strftime(char *s, size_t maxsize,
    const char *format, const struct tm *timp);

Description
strftime converts a struct tm representation of the time (at timp) into a string, starting at s and occupying no more than maxsize characters.

You control the format of the output using the string at format. *format can contain two kinds of specifications: text to be copied literally into the formatted string, and time conversion specifications. Time conversion specifications are two-character sequences beginning with `%' (use `%%' to include a percent sign in the output). Each defined conversion specification selects a field of calendar time data from *timp, and converts it to a string in one of the following ways:

%a
An abbreviation for the day of the week.
%A
The full name for the day of the week.
%b
An abbreviation for the month name.
%B
The full name of the month.
%c
A string representing the complete date and time, in the form
 Mon Apr 01 13:13:13 1992
%d
The day of the month, formatted with two digits.
%H
The hour (on a 24-hour clock), formatted with two digits.
%I
The hour (on a 12-hour clock), formatted with two digits.
%j
The count of days in the year, formatted with three digits (from `001' to `366').
%m
The month number, formatted with two digits.
%M
The minute, formatted with two digits.
%p
Either `AM' or `PM' as appropriate.
%S
The second, formatted with two digits.
%U
The week number, formatted with two digits (from `00' to `53'; week number 1 is taken as beginning with the first Sunday in a year). See also %W.
%w
A single digit representing the day of the week: Sunday is day 0.
%W
Another version of the week number: like `%U', but counting week 1 as beginning with the first Monday in a year.
o %x
A string representing the complete date, in a format like
 Mon Apr 01 1992
%X
A string representing the full time of day (hours, minutes, and seconds), in a format like
 13:13:13
%y
The last two digits of the year.
%Y
The full year, formatted with four digits to include the century.
%Z
Defined by ANSI C as eliciting the time zone if available; it is not available in this implementation (which accepts `%Z' but generates no output for it).
%%
A single character, `%'.

Returns
When the formatted time takes up no more than maxsize characters, the result is the length of the formatted string. Otherwise, if the formatting operation was abandoned due to lack of room, the result is 0, and the string starting at s corresponds to just those parts of *format that could be completely filled in within the maxsize limit.

Portability
ANSI C requires strftime, but does not specify the contents of *s when the formatted string would require more than maxsize characters.

strftime requires no supporting OS subroutines.


Cygnus C Support Library, Full - time

time---get current calendar time (as single number)

Synopsis

#include <time.h>
time_t time(time_t *t);

Description
time looks up the best available representation of the current time and returns it, encoded as a time_t. It stores the same value at t unless the argument is NULL.

Returns
A -1 result means the current time is not available; otherwise the result represents the current time.

Portability
ANSI C requires time.

Supporting OS subroutine required: Some implementations require gettimeofday.


Cygnus C Support Library, Full - Locale

Locale (`locale.h')

A locale is the name for a collection of parameters (affecting collating sequences and formatting conventions) that may be different depending on location or culture. The "C" locale is the only one defined in the ANSI C standard.

This is a minimal implementation, supporting only the required "C" value for locale; strings representing other locales are not honored. ("" is also accepted; it represents the default locale for an implementation, here equivalent to "C".

`locale.h' defines the structure lconv to collect the information on a locale, with the following fields:

char *decimal_point
The decimal point character used to format "ordinary" numbers (all numbers except those referring to amounts of money). "." in the C locale.
char *thousands_sep
The character (if any) used to separate groups of digits, when formatting ordinary numbers. "" in the C locale.
char *grouping
Specifications for how many digits to group (if any grouping is done at all) when formatting ordinary numbers. The numeric value of each character in the string represents the number of digits for the next group, and a value of 0 (that is, the string's trailing NULL) means to continue grouping digits using the last value specified. Use CHAR_MAX to indicate that no further grouping is desired. "" in the C locale.
char *int_curr_symbol
The international currency symbol (first three characters), if any, and the character used to separate it from numbers. "" in the C locale.
char *currency_symbol
The local currency symbol, if any. "" in the C locale.
char *mon_decimal_point
The symbol used to delimit fractions in amounts of money. "" in the C locale.
char *mon_thousands_sep
Similar to thousands_sep, but used for amounts of money. "" in the C locale.
char *mon_grouping
Similar to grouping, but used for amounts of money. "" in the C locale.
char *positive_sign
A string to flag positive amounts of money when formatting. "" in the C locale.
char *negative_sign
A string to flag negative amounts of money when formatting. "" in the C locale.
char int_frac_digits
The number of digits to display when formatting amounts of money to international conventions. CHAR_MAX (the largest number representable as a char) in the C locale.
char frac_digits
The number of digits to display when formatting amounts of money to local conventions. CHAR_MAX in the C locale.
char p_cs_precedes
1 indicates the local currency symbol is used before a positive or zero formatted amount of money; 0 indicates the currency symbol is placed after the formatted number. CHAR_MAX in the C locale.
char p_sep_by_space
1 indicates the local currency symbol must be separated from positive or zero numbers by a space; 0 indicates that it is immediately adjacent to numbers. CHAR_MAX in the C locale.
char n_cs_precedes
1 indicates the local currency symbol is used before a negative formatted amount of money; 0 indicates the currency symbol is placed after the formatted number. CHAR_MAX in the C locale.
char n_sep_by_space
1 indicates the local currency symbol must be separated from negative numbers by a space; 0 indicates that it is immediately adjacent to numbers. CHAR_MAX in the C locale.
char p_sign_posn
Controls the position of the positive sign for numbers representing money. 0 means parentheses surround the number; 1 means the sign is placed before both the number and the currency symbol; 2 means the sign is placed after both the number and the currency symbol; 3 means the sign is placed just before the currency symbol; and 4 means the sign is placed just after the currency symbol. CHAR_MAX in the C locale.
char n_sign_posn
Controls the position of the negative sign for numbers representing money, using the same rules as p_sign_posn. CHAR_MAX in the C locale.


Cygnus C Support Library, Full - setlocale

setlocale, localeconv---select or query locale

Synopsis

#include <locale.h>
char *setlocale(int category, const char *locale);
lconv *localeconv(void);

char *_setlocale_r(void *reent,
    int category, const char *locale);
lconv *_localeconv_r(void *reent);

Description
setlocale is the facility defined by ANSI C to condition the execution environment for international collating and formatting information; localeconv reports on the settings of the current locale.

This is a minimal implementation, supporting only the required "C" value for locale; strings representing other locales are not honored. ("" is also accepted; it represents the default locale for an implementation, here equivalent to "C".)

If you use NULL as the locale argument, setlocale returns a pointer to the string representing the current locale (always "C" in this implementation). The acceptable values for category are defined in `locale.h' as macros beginning with "LC_", but this implementation does not check the values you pass in the category argument.

localeconv returns a pointer to a structure (also defined in `locale.h') describing the locale-specific conventions currently in effect.

_localeconv_r and _setlocale_r are reentrant versions of localeconv and setlocale respectively. The extra argument reent is a pointer to a reentrancy structure.

Returns
setlocale returns either a pointer to a string naming the locale currently in effect (always "C" for this implementation), or, if the locale request cannot be honored, NULL.

localeconv returns a pointer to a structure of type lconv, which describes the formatting and collating conventions in effect (in this implementation, always those of the C locale).

Portability
ANSI C requires setlocale, but the only locale required across all implementations is the C locale.

No supporting OS subroutines are required.


Cygnus C Support Library, Full - Reentrancy

Reentrancy

Reentrancy is a characteristic of library functions which allows multiple processes to use the same address space with assurance that the values stored in those spaces will remain constant between calls. Cygnus's implementation of the library functions ensures that whenever possible, these library functions are reentrant. However, there are some functions that can not be trivially made reentrant. Hooks have been provided to allow you to use these functions in a fully reentrant fashion.

These hooks use the structure _reent defined in `reent.h'. A variable defined as `struct _reent' is called a reentrancy structure. All functions which must manipulate global information are available in two versions. The first version has the usual name, and uses a single global instance of the reentrancy structure. The second has a different name, normally formed by prepending `_' and appending `_r', and takes a pointer to the particular reentrancy structure to use.

For example, the function fopen takes two arguments, file and mode, and uses the global reentrancy structure. The function _fopen_r takes the arguments, struct_reent, which is a pointer to an instance of the reentrancy structure, file and mode.

Each function which uses the global reentrancy structure uses the global variable _impure_ptr, which points to a reentrancy structure.

This means that you have two ways to achieve reentrancy. Both require that each thread of execution control initialize a unique global variable of type `struct _reent':

  1. Use the reentrant versions of the library functions, after initializing a global reentrancy structure for each process. Use the pointer to this structure as the extra argument for all library functions.
  2. Ensure that each thread of execution control has a pointer to its own unique reentrancy structure in the global variable _impure_ptr, and call the standard library subroutines.

The following functions are provided in both reentrant and non-reentrant versions.

Equivalent for errno variable:
_errno_r

Locale functions:
_localeconv_r  _setlocale_r

Equivalents for stdio variables:
_stdin_r        _stdout_r       _stderr_r

Stdio functions:
_fdopen_r       _mkstemp_r       _remove_r
_fopen_r        _mktemp_r        _rename_r
_getchar_r      _perror_r        _tempnam_r
_gets_r         _putchar_r       _tmpnam_r
_iprintf_r 	_puts_r		 _tmpfile_r

Signal functions:
_raise_r        _signal_r

Stdlib functions:
_dtoa_r         _realloc_r      _strtoul_r
_free_r         _srand_r        _system_r
_malloc_r       _strtod_r
_rand_r         _strtol_r

String functions:
_strtok_r

System functions:
_close_r        _lseek_r        _stat_r
_fork_r         _open_r         _unlink_r
_fstat_r        _read_r         _wait_r
_link_r         _sbrk_r         _write_r

Time function:
_asctime_r


Cygnus C Support Library, Full - Misc

Miscellaneous Macros and Functions

This chapter describes miscellaneous routines not covered elsewhere.


Cygnus C Support Library, Full - unctrl

unctrl---translate characters to upper case

Synopsis

#include <unctrl.h>
char *unctrl(int c);
int unctrllen(int c);

Description
unctrl is a macro which returns the printable representation of c as a string. unctrllen is a macro which returns the length of the printable representation of c.

Returns
unctrl returns a string of the printable representation of c.

unctrllen returns the length of the string which is the printable representation of c.

Portability
unctrl and unctrllen are not ANSI C.

No supporting OS subroutines are required.


Cygnus C Support Library, Full - Syscalls

System Calls

The C subroutine library depends on a handful of subroutine calls for operating system services. If you use the C library on a system that complies with the POSIX.1 standard (also known as IEEE 1003.1), most of these subroutines are supplied with your operating system.

If some of these subroutines are not provided with your system--in the extreme case, if you are developing software for a "bare board" system, without an OS--you will at least need to provide do-nothing stubs (or subroutines with minimal functionality) to allow your programs to link with the subroutines in libc.a.


Cygnus C Support Library, Full - Stubs

Definitions for OS interface

This is the complete set of system definitions (primarily subroutines) required; the examples shown implement the minimal functionality required to allow libc to link, and fail gracefully where OS services are not available.

Graceful failure is permitted by returning an error code. A minor complication arises here: the C library must be compatible with development environments that supply fully functional versions of these subroutines. Such environments usually return error codes in a global errno. However, the Cygnus C library provides a macro definition for errno in the header file `errno.h', as part of its support for reentrant routines (see section Reentrancy).

The bridge between these two interpretations of errno is straightforward: the C library routines with OS interface calls capture the errno values returned globally, and record them in the appropriate field of the reentrancy structure (so that you can query them using the errno macro from `errno.h').

This mechanism becomes visible when you write stub routines for OS interfaces. You must include `errno.h', then disable the macro, like this:

#include <errno.h>
#undef errno
extern int errno;

The examples in this chapter include this treatment of errno.

_exit
Exit a program without cleaning up files. If your system doesn't provide this, it is best to avoid linking with subroutines that require it (exit, system).
close
Close a file. Minimal implementation:
int close(int file){
    return -1;
}
environ
A pointer to a list of environment variables and their values. For a minimal environment, this empty list is adequate:
char *__env[1] = { 0 };
char **environ = __env;
execve
Transfer control to a new process. Minimal implementation (for a system without processes):
#include <errno.h>
#undef errno
extern int errno;
int execve(char *name, char **argv, char **env){
  errno=ENOMEM;
  return -1;
}
fork
Create a new process. Minimal implementation (for a system without processes):
#include <errno.h>
#undef errno
extern int errno;
int fork() {
  errno=EAGAIN;
  return -1;
}
fstat
Status of an open file. For consistency with other minimal implementations in these examples, all files are regarded as character special devices. The `sys/stat.h' header file required is distributed in the `include' subdirectory for this C library.
#include <sys/stat.h>
int fstat(int file, struct stat *st) {
  st->st_mode = S_IFCHR;
  return 0;
}
getpid
Process-ID; this is sometimes used to generate strings unlikely to conflict with other processes. Minimal implementation, for a system without processes:
int getpid() {
  return 1;
}
isatty
Query whether output stream is a terminal. For consistency with the other minimal implementations, which only support output to stdout, this minimal implementation is suggested:
int isatty(int file){
   return 1;
}
kill
Send a signal. Minimal implementation:
#include <errno.h>
#undef errno
extern int errno;
int kill(int pid, int sig){
  errno=EINVAL;
  return(-1);
}
link
Establish a new name for an existing file. Minimal implementation:
#include <errno.h>
#undef errno
extern int errno;
int link(char *old, char *new){
  errno=EMLINK;
  return -1;
}
lseek
Set position in a file. Minimal implementation:
int lseek(int file, int ptr, int dir){
    return 0;
}
read
Read from a file. Minimal implementation:
int read(int file, char *ptr, int len){
    return 0;
}
sbrk
Increase program data space. As malloc and related functions depend on this, it is useful to have a working implementation. The following suffices for a standalone system; it exploits the symbol end automatically defined by the GNU linker.
caddr_t sbrk(int incr){
  extern char end;		/* Defined by the linker */
  static char *heap_end;
  char *prev_heap_end;

  if (heap_end == 0) {
    heap_end = &end;
  }
  prev_heap_end = heap_end;
  if (heap_end + incr > stack_ptr)
    {
      _write (1, "Heap and stack collision\n", 25);
      abort ();
    }

  heap_end += incr;
  return (caddr_t) prev_heap_end;
}
stat
Status of a file (by name). Minimal implementation:
int stat(char *file, struct stat *st) {
  st->st_mode = S_IFCHR;
  return 0;
}
times
Timing information for current process. Minimal implementation:
int times(struct tms *buf){
  return -1;
}
unlink
Remove a file's directory entry. Minimal implementation:
#include <errno.h>
#undef errno
extern int errno;
int unlink(char *name){
  errno=ENOENT;
  return -1;
}
wait
Wait for a child process. Minimal implementation:
#include <errno.h>
#undef errno
extern int errno;
int wait(int *status) {
  errno=ECHILD;
  return -1;
}
write
Write a character to a file. `libc' subroutines will use this system routine for output to all files, including stdout---so if you need to generate any output, for example to a serial port for debugging, you should make your minimal write capable of doing this. The following minimal implementation is an incomplete example; it relies on a writechar subroutine (not shown; typically, you must write this in assembler from examples provided by your hardware manufacturer) to actually perform the output.
int write(int file, char *ptr, int len){
    int todo;

    for (todo = 0; todo < len; todo++) {
        writechar(*ptr++);
    }
    return len;
}


Cygnus C Support Library, Full - Reentrant Syscalls

Reentrant covers for OS subroutines

Since the system subroutines are used by other library routines that require reentrancy, `libc.a' provides cover routines (for example, the reentrant version of fork is _fork_r). These cover routines are consistent with the other reentrant subroutines in this library, and achieve reentrancy by using a reserved global data block (see section Reentrancy).

_open_r
A reentrant version of open. It takes a pointer to the global data block, which holds errno.
int _open_r(void *reent,
    const char *file, int flags, int mode);
_close_r
A reentrant version of close. It takes a pointer to the global data block, which holds errno.
int _close_r(void *reent, int fd);
_lseek_r
A reentrant version of lseek. It takes a pointer to the global data block, which holds errno.
off_t _lseek_r(void *reent,
    int fd, off_t pos, int whence);
_read_r
A reentrant version of read. It takes a pointer to the global data block, which holds errno.
long _read_r(void *reent,
    int fd, void *buf, size_t cnt);
_write_r
A reentrant version of write. It takes a pointer to the global data block, which holds errno.
long _write_r(void *reent,
    int fd, const void *buf, size_t cnt);
_fork_r
A reentrant version of fork. It takes a pointer to the global data block, which holds errno.
int _fork_r(void *reent);
_wait_r
A reentrant version of wait. It takes a pointer to the global data block, which holds errno.
int _wait_r(void *reent, int *status);
_stat_r
A reentrant version of stat. It takes a pointer to the global data block, which holds errno.
int _stat_r(void *reent,
    const char *file, struct stat *pstat);
_fstat_r
A reentrant version of fstat. It takes a pointer to the global data block, which holds errno.
int _fstat_r(void *reent,
    int fd, struct stat *pstat);
_link_r
A reentrant version of link. It takes a pointer to the global data block, which holds errno.
int _link_r(void *reent,
    const char *old, const char *new);
_unlink_r
A reentrant version of unlink. It takes a pointer to the global data block, which holds errno.
int _unlink_r(void *reent, const char *file);
_sbrk_r
A reentrant version of sbrk. It takes a pointer to the global data block, which holds errno.
char *_sbrk_r(void *reent, size_t incr);


Cygnus C Support Library, Full - Arglists

Variable Argument Lists

The printf family of functions is defined to accept a variable number of arguments, rather than a fixed argument list. You can define your own functions with a variable argument list, by using macro definitions from either `stdarg.h' (for compatibility with ANSI C) or from `varargs.h' (for compatibility with a popular convention prior to ANSI C).


Cygnus C Support Library, Full - Stdarg

ANSI-standard macros, `stdarg.h'

In ANSI C, a function has a variable number of arguments when its parameter list ends in an ellipsis (...). The parameter list must also include at least one explicitly named argument; that argument is used to initialize the variable list data structure.

ANSI C defines three macros (va_start, va_arg, and va_end) to operate on variable argument lists. `stdarg.h' also defines a special type to represent variable argument lists: this type is called va_list.


Cygnus C Support Library, Full - va_start

Initialize variable argument list

Synopsis

#include <stdarg.h>
void va_start(va_list ap, rightmost);

Description
Use va_start to initialize the variable argument list ap, so that va_arg can extract values from it. rightmost is the name of the last explicit argument in the parameter list (the argument immediately preceding the ellipsis `...' that flags variable arguments in an ANSI C function header). You can only use va_start in a function declared using this ellipsis notation (not, for example, in one of its subfunctions).

Returns
va_start does not return a result.

Portability
ANSI C requires va_start.


Cygnus C Support Library, Full - va_arg

Extract a value from argument list

Synopsis

#include <stdarg.h>
type va_arg(va_list ap, type);

Description
va_arg returns the next unprocessed value from a variable argument list ap (which you must previously create with va_start). Specify the type for the value as the second parameter to the macro, type.

You may pass a va_list object ap to a subfunction, and use va_arg from the subfunction rather than from the function actually declared with an ellipsis in the header; however, in that case you may only use va_arg from the subfunction. ANSI C does not permit extracting successive values from a single variable-argument list from different levels of the calling stack.

There is no mechanism for testing whether there is actually a next argument available; you might instead pass an argument count (or some other data that implies an argument count) as one of the fixed arguments in your function call.

Returns
va_arg returns the next argument, an object of type type.

Portability
ANSI C requires va_arg.


Cygnus C Support Library, Full - va_end

Abandon a variable argument list

Synopsis

#include <stdarg.h>
void va_end(va_list ap);

Description
Use va_end to declare that your program will not use the variable argument list ap any further.

Returns
va_end does not return a result.

Portability
ANSI C requires va_end.


Cygnus C Support Library, Full - Varargs

Traditional macros, `varargs.h'

If your C compiler predates ANSI C, you may still be able to use variable argument lists using the macros from the `varargs.h' header file. These macros resemble their ANSI counterparts, but have important differences in usage. In particular, since traditional C has no declaration mechanism for variable argument lists, two additional macros are provided simply for the purpose of defining functions with variable argument lists.

As with `stdarg.h', the type va_list is used to hold a data structure representing a variable argument list.


Cygnus C Support Library, Full - va_alist

Declare variable arguments

Synopsis

#include <varargs.h>
function(va_alist)
va_dcl

Description
To use the `varargs.h' version of variable argument lists, you must declare your function with a call to the macro va_alist as its argument list, and use va_dcl as the declaration. Do not use a semicolon after va_dcl.

Returns
These macros cannot be used in a context where a return is syntactically possible.

Portability
va_alist and va_dcl were the most widespread method of declaring variable argument lists prior to ANSI C.


Cygnus C Support Library, Full - va_start-trad

Initialize variable argument list

Synopsis

#include <varargs.h>
va_list ap;
va_start(ap);

Description
With the `varargs.h' macros, use va_start to initialize a data structure ap to permit manipulating a variable argument list. ap must have the type va_alist.

Returns
va_start does not return a result.

Portability
va_start is also defined as a macro in ANSI C, but the definitions are incompatible; the ANSI version has another parameter besides ap.


Cygnus C Support Library, Full - va_arg-trad

Extract a value from argument list

Synopsis

#include <varargs.h>
type va_arg(va_list ap, type);

Description
va_arg returns the next unprocessed value from a variable argument list ap (which you must previously create with va_start). Specify the type for the value as the second parameter to the macro, type.

Returns
va_arg returns the next argument, an object of type type.

Portability
The va_arg defined in `varargs.h' has the same syntax and usage as the ANSI C version from `stdarg.h'.


Cygnus C Support Library, Full - va_end-trad

Abandon a variable argument list

Synopsis

#include <varargs.h>
va_end(va_list ap);

Description
Use va_end to declare that your program will not use the variable argument list ap any further.

Returns
va_end does not return a result.

Portability
The va_end defined in `varargs.h' has the same syntax and usage as the ANSI C version from `stdarg.h'.


Cygnus C Support Library, Full - Library Index

Index

Jump to: _ - a - b - c - d - e - f - g - i - k - l - m - o - p - q - r - s - t - u - v - w

_

  • _asctime_r
  • _calloc_r
  • _close_r
  • _exit
  • _fdopen_r
  • _fopen_r
  • _fork_r
  • _free_r
  • _fstat_r
  • _getchar_r
  • _gets_r
  • _impure_ptr
  • _link_r
  • _localeconv_r
  • _lseek_r
  • _malloc_r
  • _mkstemp_r
  • _mktemp_r
  • _open_r
  • _perror_r
  • _putchar_r
  • _puts_r
  • _raise_r, _raise_r
  • _read_r
  • _realloc_r
  • _reent
  • _rename_r
  • _sbrk_r
  • _setlocale_r
  • _signal_r
  • _stat_r
  • _strtod_r
  • _strtol_r
  • _strtoul_r
  • _system_r
  • _tempnam_r
  • _tmpfile_r
  • _tmpnam_r
  • _tolower
  • _toupper
  • _unlink_r
  • _wait_r
  • _write_r

    • a

  • abort
  • abs
  • asctime
  • assert
  • atexit
  • atof
  • atoff
  • atoi
  • atol

    • b

  • bcmp
  • bsearch
  • bzero

    • c

  • calloc
  • clearerr
  • clock
  • close
  • ctime

    • d

  • difftime
  • div

    • e

  • ecvt
  • ecvtbuf
  • environ, environ
  • errno global vs macro
  • execve
  • exit
  • extra argument, reentrant fns

    • f

  • fclose
  • fcvt
  • fcvtbuf
  • fdopen
  • feof
  • ferror
  • fflush
  • fgetc
  • fgetpos
  • fgets
  • fiprintf
  • fopen
  • fork
  • fprintf
  • fputc
  • fputs
  • fread
  • free
  • freopen
  • fscanf
  • fseek
  • fsetpos
  • fstat
  • ftell
  • fwrite

    • g

  • gcvt
  • gcvtf
  • getc
  • getchar
  • getenv
  • getpid
  • gets
  • global reentrancy structure
  • gmtime

    • i

  • index
  • iprintf
  • isalnum
  • isalpha
  • isascii
  • isatty
  • iscntrl
  • isdigit
  • isgraph
  • islower
  • isprint
  • ispunct
  • isspace
  • isupper
  • isxdigit

    • k

  • kill

    • l

  • labs
  • ldiv
  • link
  • linking the C library
  • list of reentrant functions
  • localeconv
  • localtime
  • lseek

    • m

  • malloc
  • mbtowc
  • memchr
  • memcmp
  • memmove
  • memset
  • mkstemp
  • mktemp
  • mktime

    • o

  • OS interface subroutines

    • p

  • perror
  • printf
  • putc
  • putchar
  • puts

    • q

  • qsort

    • r

  • raise, raise
  • rand
  • rand_r
  • read
  • realloc
  • reent.h
  • reentrancy
  • reentrancy structure
  • reentrant function list
  • remove
  • rename
  • rewind
  • rindex

    • s

  • sbrk
  • scanf
  • setbuf
  • setlocale
  • setvbuf
  • signal
  • siprintf
  • sprintf
  • srand
  • sscanf
  • stat
  • strcat
  • strchr
  • strcmp
  • strcoll
  • strcpy
  • strcspn
  • strerror
  • strftime
  • strlen
  • strlwr
  • strncat
  • strncmp
  • strncpy
  • strpbrk
  • strrchr
  • strspn
  • strstr
  • strtod
  • strtodf
  • strtok
  • strtok_r
  • strtol
  • strtoul
  • strupr
  • strxfrm
  • stubs
  • subroutines for OS interface
  • system

    • t

  • tempnam
  • time
  • times
  • tmpfile
  • tmpnam
  • toascii
  • tolower
  • toupper

    • u

  • unctrl
  • unctrllen
  • unlink

    • v

  • va_alist
  • va_arg, va_arg
  • va_dcl
  • va_end, va_end
  • va_start, va_start
  • vfprintf
  • vprintf
  • vsprintf

    • w

  • wait
  • wctomb
  • write

    • Go to the first, previous, next, last section, table of contents.


Cygnus C Math Library - Math

Copyright (C) 1992, 1993 Cygnus Support

`libm' includes software developed at SunPro, a Sun Microsystems, Inc. business. Permission to use, copy, modify, and distribute this software is freely granted, provided that this notice is preserved.

Permission is granted to make and distribute verbatim copies of this manual provided the copyright notice and this permission notice are preserved on all copies.

Permission is granted to copy and distribute modified versions of this manual under the conditions for verbatim copying, subject to the terms of the GNU General Public License, which includes the provision that the entire resulting derived work is distributed under the terms of a permission notice identical to this one.

Permission is granted to copy and distribute translations of this manual into another language, under the above conditions for modified versions.

Mathematical Functions (`math.h')

This chapter groups a wide variety of mathematical functions. The corresponding definitions and declarations are in `math.h'. Two definitions from `math.h' are of particular interest.

  1. The representation of infinity as a double is defined as HUGE_VAL; this number is returned on overflow by many functions.
  2. The structure exception is used when you write customized error handlers for the mathematical functions. You can customize error handling for most of these functions by defining your own version of matherr; see the section on matherr for details.

Since the error handling code calls fputs, the mathematical subroutines require stubs or minimal implementations for the same list of OS subroutines as fputs: close, fstat, isatty, lseek, read, sbrk, write. See section `System Calls' in The Cygnus C Support Library, for a discussion and for sample minimal implementations of these support subroutines.

Alternative declarations of the mathematical functions, which exploit specific machine capabilities to operate faster--but generally have less error checking and may reflect additional limitations on some machines--are available when you include `fastmath.h' instead of `math.h'.


Cygnus C Math Library - version

Version of library

There are four different versions of the math library routines: IEEE, POSIX, X/Open, or SVID. The version may be selected at runtime by setting the global variable _LIB_VERSION, defined in `math.h'. It may be set to one of the following constants defined in `math.h': _IEEE_, _POSIX_, _XOPEN_, or _SVID_. The _LIB_VERSION variable is not specific to any thread, and changing it will affect all threads.

The versions of the library differ only in how errors are handled.

In IEEE mode, the matherr function is never called, no warning messages are printed, and errno is never set.

In POSIX mode, errno is set correctly, but the matherr function is never called and no warning messages are printed.

In X/Open mode, errno is set correctly, and matherr is called, but warning message are not printed.

In SVID mode, functions which overflow return 3.40282346638528860e+38, the maximum single precision floating point value, rather than infinity. Also, errno is set correctly, matherr is called, and, if matherr returns 0, warning messages are printed for some errors. For example, by default `log(-1.0)' writes this message on standard error output:

log: DOMAIN error

The library is set to X/Open mode by default.


Cygnus C Math Library - acos

acos, acosf---arc cosine

Synopsis

#include <math.h>
double acos(double x);
float acosf(float x);

Description

acos computes the inverse cosine (arc cosine) of the input value. Arguments to acos must be in the range -1 to 1.

acosf is identical to acos, except that it performs its calculations on floats.

Returns

If x is not between -1 and 1, the returned value is NaN (not a number) the global variable errno is set to EDOM, and a DOMAIN error message is sent as standard error output.

You can modify error handling for these functions using matherr.


Cygnus C Math Library - acosh

acosh, acoshf---inverse hyperbolic cosine

Synopsis

#include <math.h>
double acosh(double x);
float acoshf(float x);

Description
acosh calculates the inverse hyperbolic cosine of x. acosh is defined as

x must be a number greater than or equal to 1.

acoshf is identical, other than taking and returning floats.

Returns
acosh and acoshf return the calculated value. If x less than 1, the return value is NaN and errno is set to EDOM.

You can change the error-handling behavior with the non-ANSI matherr function.

Portability
Neither acosh nor acoshf are ANSI C. They are not recommended for portable programs.


Cygnus C Math Library - asin

asin, asinf---arc sine

Synopsis

#include <math.h>
double asin(double x);
float asinf(float x);

Description

asin computes the inverse sine (arc sine) of the argument x. Arguments to asin must be in the range -1 to 1.

asinf is identical to asin, other than taking and returning floats.

You can modify error handling for these routines using matherr.

Returns

If x is not in the range -1 to 1, asin and asinf return NaN (not a number), set the global variable errno to EDOM, and issue a DOMAIN error message.

You can change this error treatment using matherr.


Cygnus C Math Library - asinh

asinh, asinhf---inverse hyperbolic sine

Synopsis

#include <math.h>
double asinh(double x);
float asinhf(float x);

Description
asinh calculates the inverse hyperbolic sine of x. asinh is defined as

asinhf is identical, other than taking and returning floats.

Returns
asinh and asinhf return the calculated value.

Portability
Neither asinh nor asinhf are ANSI C.


Cygnus C Math Library - atan

atan, atanf---arc tangent

Synopsis

#include <math.h>
double atan(double x);
float atanf(float x);

Description

atan computes the inverse tangent (arc tangent) of the input value.

atanf is identical to atan, save that it operates on floats.

Returns

Portability
atan is ANSI C. atanf is an extension.


Cygnus C Math Library - atan2

atan2, atan2f---arc tangent of y/x

Synopsis

#include <math.h>
double atan2(double y,double x);
float atan2f(float y,float x);

Description

atan2 computes the inverse tangent (arc tangent) of y/x. atan2 produces the correct result even for angles near (that is, when x is near 0).

atan2f is identical to atan2, save that it takes and returns float.

Returns
atan2 and atan2f return a value in radians, in the range of

If both x and y are 0.0, atan2 causes a DOMAIN error.

You can modify error handling for these functions using matherr.

Portability
atan2 is ANSI C. atan2f is an extension.


Cygnus C Math Library - atanh

atanh, atanhf---inverse hyperbolic tangent

Synopsis

#include <math.h>
double atanh(double x);
float atanhf(float x);

Description
atanh calculates the inverse hyperbolic tangent of x.

atanhf is identical, other than taking and returning float values.

Returns
atanh and atanhf return the calculated value.

If is greater than 1, the global errno is set to EDOM and the result is a NaN. A DOMAIN error is reported.

If is 1, the global errno is set to EDOM; and the result is infinity with the same sign as x. A SING error is reported.

You can modify the error handling for these routines using matherr.

Portability
Neither atanh nor atanhf are ANSI C.


Cygnus C Math Library - jN

jN,jNf,yN,yNf---Bessel functions

Synopsis

#include <math.h>
double j0(double x);
float j0f(float x);
double j1(double x);
float j1f(float x);
double jn(int n, double x);
float jnf(int n, float x);
double y0(double x);
float y0f(float x);
double y1(double x);
float y1f(float x);
double yn(int n, double x);
float ynf(int n, float x);

Description
The Bessel functions are a family of functions that solve the differential equation These functions have many applications in engineering and physics.

jn calculates the Bessel function of the first kind of order n. j0 and j1 are special cases for order 0 and order 1 respectively.

Similarly, yn calculates the Bessel function of the second kind of order n, and y0 and y1 are special cases for order 0 and 1.

jnf, j0f, j1f, ynf, y0f, and y1f perform the same calculations, but on float rather than double values.

Returns
The value of each Bessel function at x is returned.

Portability
None of the Bessel functions are in ANSI C.


Cygnus C Math Library - cbrt

cbrt, cbrtf---cube root

Synopsis

#include <math.h>
double cbrt(double x);
float  cbrtf(float x);

Description
cbrt computes the cube root of the argument.

Returns
The cube root is returned.

Portability
cbrt is in System V release 4. cbrtf is an extension.


Cygnus C Math Library - copysign

copysign, copysignf---sign of y, magnitude of x

Synopsis

#include <math.h>
double copysign (double x, double y);
float copysignf (float x, float y);

Description
copysign constructs a number with the magnitude (absolute value) of its first argument, x, and the sign of its second argument, y.

copysignf does the same thing; the two functions differ only in the type of their arguments and result.

Returns
copysign returns a double with the magnitude of x and the sign of y. copysignf returns a float with the magnitude of x and the sign of y.

Portability
copysign is not required by either ANSI C or the System V Interface Definition (Issue 2).


Cygnus C Math Library - cosh

cosh, coshf---hyperbolic cosine

Synopsis

#include <math.h>
double cosh(double x);
float coshf(float x)

Description

cosh computes the hyperbolic cosine of the argument x. cosh(x) is defined as

Angles are specified in radians. coshf is identical, save that it takes and returns float.

Returns
The computed value is returned. When the correct value would create an overflow, cosh returns the value HUGE_VAL with the appropriate sign, and the global value errno is set to ERANGE.

You can modify error handling for these functions using the function matherr.

Portability
cosh is ANSI. coshf is an extension.


Cygnus C Math Library - erf

erf, erff, erfc, erfcf---error function

Synopsis

#include <math.h>
double erf(double x);
float erff(float x);
double erfc(double x);
float erfcf(float x);

Description
erf calculates an approximation to the "error function", which estimates the probability that an observation will fall within x standard deviations of the mean (assuming a normal distribution).

erfc calculates the complementary probability; that is, erfc(x) is 1 - erf(x). erfc is computed directly, so that you can use it to avoid the loss of precision that would result from subtracting large probabilities (on large x) from 1.

erff and erfcf differ from erf and erfc only in the argument and result types.

Returns
For positive arguments, erf and all its variants return a probability--a number between 0 and 1.

Portability
None of the variants of erf are ANSI C.


Cygnus C Math Library - exp

exp, expf---exponential

Synopsis

#include <math.h>
double exp(double x);
float expf(float x);

Description
exp and expf calculate the exponential of x, that is, is the base of the natural system of logarithms, approximately 2.71828).

You can use the (non-ANSI) function matherr to specify error handling for these functions.

Returns
On success, exp and expf return the calculated value. If the result underflows, the returned value is 0. If the result overflows, the returned value is HUGE_VAL. In either case, errno is set to ERANGE.

Portability
exp is ANSI C. expf is an extension.


Cygnus C Math Library - expm1

expm1, expm1f---exponential minus 1

Synopsis

#include <math.h>
double expm1(double x);
float expm1f(float x);

Description
expm1 and expm1f calculate the exponential of x and subtract 1, that is, is the base of the natural system of logarithms, approximately 2.71828). The result is accurate even for small values of x, where using exp(x)-1 would lose many significant digits.

Returns
e raised to the power x, minus 1.

Portability
Neither expm1 nor expm1f is required by ANSI C or by the System V Interface Definition (Issue 2).


Cygnus C Math Library - fabs

fabs, fabsf---absolute value (magnitude)

Synopsis

#include <math.h>
double fabs(double x);
float fabsf(float x);

Description
fabs and fabsf calculate the absolute value (magnitude) of the argument x, by direct manipulation of the bit representation of x.

Returns
The calculated value is returned. No errors are detected.

Portability
fabs is ANSI. fabsf is an extension.


Cygnus C Math Library - floor

floor, floorf, ceil, ceilf---floor and ceiling

Synopsis

#include <math.h>
double floor(double x);
float floorf(float x);
double ceil(double x);
float ceilf(float x);

Description
floor and floorf find the nearest integer less than or equal to x. ceil and ceilf find the nearest integer greater than or equal to x.

Returns
floor and ceil return the integer result as a double. floorf and ceilf return the integer result as a float.

Portability
floor and ceil are ANSI. floorf and ceilf are extensions.


Cygnus C Math Library - fmod

fmod, fmodf---floating-point remainder (modulo)

Synopsis

#include <math.h>
double fmod(double x, double y)
float fmodf(float x, float y)

Description
The fmod and fmodf functions compute the floating-point remainder of x/y (x modulo y).

Returns
The fmod function returns the value for the largest integer i such that, if y is nonzero, the result has the same sign as x and magnitude less than the magnitude of y.

fmod(x,0) returns NaN, and sets errno to EDOM.

You can modify error treatment for these functions using matherr.

Portability
fmod is ANSI C. fmodf is an extension.


Cygnus C Math Library - frexp

frexp, frexpf---split floating-point number

Synopsis

#include <math.h>
double frexp(double val, int *exp);
float frexpf(float val, int *exp);

Description
All non zero, normal numbers can be described as m * 2**p. frexp represents the double val as a mantissa m and a power of two p. The resulting mantissa will always be greater than or equal to 0.5, and less than 1.0 (as long as val is nonzero). The power of two will be stored in *exp.

frexpf is identical, other than taking and returning floats rather than doubles.

Returns
frexp returns the mantissa m. If val is 0, infinity, or Nan, frexp will set *exp to 0 and return val.

Portability
frexp is ANSI. frexpf is an extension.


Cygnus C Math Library - gamma

gamma, gammaf, lgamma, lgammaf, gamma_r,

Synopsis

#include <math.h>
double gamma(double x);
float gammaf(float x);
double lgamma(double x);
float lgammaf(float x);
double gamma_r(double x, int *signgamp);
float gammaf_r(float x, int *signgamp);
double lgamma_r(double x, int *signgamp);
float lgammaf_r(float x, int *signgamp);

Description
gamma calculates the natural logarithm of the gamma function of x. The gamma function (exp(gamma(x))) is a generalization of factorial, and retains the property that Accordingly, the results of the gamma function itself grow very quickly. gamma is defined as to extend the useful range of results representable.

The sign of the result is returned in the global variable signgam, which is declared in math.h.

gammaf performs the same calculation as gamma, but uses and returns float values.

lgamma and lgammaf are alternate names for gamma and gammaf. The use of lgamma instead of gamma is a reminder that these functions compute the log of the gamma function, rather than the gamma function itself.

The functions gamma_r, gammaf_r, lgamma_r, and lgammaf_r are just like gamma, gammaf, lgamma, and lgammaf, respectively, but take an additional argument. This additional argument is a pointer to an integer. This additional argument is used to return the sign of the result, and the global variable signgam is not used. These functions may be used for reentrant calls (but they will still set the global variable errno if an error occurs).

Returns
Normally, the computed result is returned.

When x is a nonpositive integer, gamma returns HUGE_VAL and errno is set to EDOM. If the result overflows, gamma returns HUGE_VAL and errno is set to ERANGE.

You can modify this error treatment using matherr.

Portability
Neither gamma nor gammaf is ANSI C.


Cygnus C Math Library - hypot

hypot, hypotf---distance from origin

Synopsis

#include <math.h>
double hypot(double x, double y);
float hypotf(float x, float y);

Description
hypot calculates the Euclidean distance between the origin (0,0) and a point represented by the Cartesian coordinates (x,y). hypotf differs only in the type of its arguments and result.

Returns
Normally, the distance value is returned. On overflow, hypot returns HUGE_VAL and sets errno to ERANGE.

You can change the error treatment with matherr.

Portability
hypot and hypotf are not ANSI C.


Cygnus C Math Library - ilogb

ilogb, ilogbf---get exponent of floating point number

Synopsis

#include <math.h>
int ilogb(double val);
int ilogbf(float val);

Description

All non zero, normal numbers can be described as m * 2**p. ilogb and ilogbf examine the argument val, and return p. The functions frexp and frexpf are similar to ilogb and ilogbf, but also return m.

Returns

ilogb and ilogbf return the power of two used to form the floating point argument. If val is 0, they return - INT_MAX (INT_MAX is defined in limits.h). If val is infinite, or NaN, they return INT_MAX.

Portability
Neither ilogb nor ilogbf is required by ANSI C or by the System V Interface Definition (Issue 2).


Cygnus C Math Library - infinity

infinity, infinityf---representation of infinity

Synopsis

#include <math.h>
double infinity(void);
float infinityf(void);

Description
infinity and infinityf return the special number IEEE infinity in double and single precision arithmetic respectivly.


Cygnus C Math Library - isnan

isnan,isnanf,isinf,isinff,finite,finitef---test for exceptional numbers

Synopsis

#include <ieeefp.h>
int isnan(double arg);
int isinf(double arg);
int finite(double arg);
int isnanf(float arg);
int isinff(float arg);
int finitef(float arg);

Description
These functions provide information on the floating point argument supplied.

There are five major number formats -

zero
a number which contains all zero bits.
subnormal
Is used to represent number with a zero exponent, but a non zero fraction.
normal
A number with an exponent, and a fraction
infinity
A number with an all 1's exponent and a zero fraction.
NAN
A number with an all 1's exponent and a non zero fraction.

isnan returns 1 if the argument is a nan. isinf returns 1 if the argument is infinity. finite returns 1 if the argument is zero, subnormal or normal. The isnanf, isinff and finitef perform the same operations as their isnan, isinf and finite counterparts, but on single precision floating point numbers.


Cygnus C Math Library - ldexp

ldexp, ldexpf---load exponent

Synopsis

#include <math.h>
double ldexp(double val, int exp);
float ldexpf(float val, int exp);

Description
ldexp calculates the value ldexpf is identical, save that it takes and returns float rather than double values.

Returns
ldexp returns the calculated value.

Underflow and overflow both set errno to ERANGE. On underflow, ldexp and ldexpf return 0.0. On overflow, ldexp returns plus or minus HUGE_VAL.

Portability
ldexp is ANSI, ldexpf is an extension.


Cygnus C Math Library - log

log, logf---natural logarithms

Synopsis

#include <math.h>
double log(double x);
float logf(float x);

Description
Return the natural logarithm of x, that is, its logarithm base e (where e is the base of the natural system of logarithms, 2.71828...). log and logf are identical save for the return and argument types.

You can use the (non-ANSI) function matherr to specify error handling for these functions.

Returns
Normally, returns the calculated value. When x is zero, the returned value is -HUGE_VAL and errno is set to ERANGE. When x is negative, the returned value is -HUGE_VAL and errno is set to EDOM. You can control the error behavior via matherr.

Portability
log is ANSI, logf is an extension.


Cygnus C Math Library - log10

log10, log10f---base 10 logarithms

Synopsis

#include <math.h>
double log10(double x);
float log10f(float x);

Description
log10 returns the base 10 logarithm of x. It is implemented as log(x) / log(10).

log10f is identical, save that it takes and returns float values.

Returns
log10 and log10f return the calculated value.

See the description of log for information on errors.

Portability
log10 is ANSI C. log10f is an extension.


Cygnus C Math Library - log1p

log1p, log1pf---log of 1 + x

Synopsis

#include <math.h>
double log1p(double x);
float log1pf(float x);

Description
log1p calculates the natural logarithm of 1+x. You can use log1p rather than `log(1+x)' for greater precision when x is very small.

log1pf calculates the same thing, but accepts and returns float values rather than double.

Returns
log1p returns a double, the natural log of 1+x. log1pf returns a float, the natural log of 1+x.

Portability
Neither log1p nor log1pf is required by ANSI C or by the System V Interface Definition (Issue 2).


Cygnus C Math Library - matherr

matherr---modifiable math error handler

Synopsis

#include <math.h>
int matherr(struct exception *e);

Description
matherr is called whenever a math library function generates an error. You can replace matherr by your own subroutine to customize error treatment. The customized matherr must return 0 if it fails to resolve the error, and non-zero if the error is resolved.

When matherr returns a nonzero value, no error message is printed and the value of errno is not modified. You can accomplish either or both of these things in your own matherr using the information passed in the structure *e.

This is the exception structure (defined in `math.h'):

    struct exception {
            int type;
            char *name;
            double arg1, arg2, retval;
        int err;
    };

The members of the exception structure have the following meanings:

type
The type of mathematical error that occured; macros encoding error types are also defined in `math.h'.
name
a pointer to a null-terminated string holding the name of the math library function where the error occurred.
arg1, arg2
The arguments which caused the error.
retval
The error return value (what the calling function will return).
err
If set to be non-zero, this is the new value assigned to errno.

The error types defined in `math.h' represent possible mathematical errors as follows:

DOMAIN
An argument was not in the domain of the function; e.g. log(-1.0).
SING
The requested calculation would result in a singularity; e.g. pow(0.0,-2.0)
OVERFLOW
A calculation would produce a result too large to represent; e.g. exp(1000.0).
UNDERFLOW
A calculation would produce a result too small to represent; e.g. exp(-1000.0).
TLOSS
Total loss of precision. The result would have no significant digits; e.g. sin(10e70).
PLOSS
Partial loss of precision.

Returns
The library definition for matherr returns 0 in all cases.

You can change the calling function's result from a customized matherr by modifying e->retval, which propagates backs to the caller.

If matherr returns 0 (indicating that it was not able to resolve the error) the caller sets errno to an appropriate value, and prints an error message.

Portability
matherr is not ANSI C.


Cygnus C Math Library - modf

modf, modff---split fractional and integer parts

Synopsis

#include <math.h>
double modf(double val, double *ipart);
float modff(float val, float *ipart);

Description
modf splits the double val apart into an integer part and a fractional part, returning the fractional part and storing the integer part in *ipart. No rounding whatsoever is done; the sum of the integer and fractional parts is guaranteed to be exactly equal to val. That is, if . realpart = modf(val, &intpart); then `realpart+intpart' is the same as val. modff is identical, save that it takes and returns float rather than double values.

Returns
The fractional part is returned. Each result has the same sign as the supplied argument val.

Portability
modf is ANSI C. modff is an extension.


Cygnus C Math Library - nan

nan, nanf---representation of infinity

Synopsis

#include <math.h>
double nan(void);
float nanf(void);

Description
nan and nanf return an IEEE NaN (Not a Number) in double and single precision arithmetic respectivly.


Cygnus C Math Library - nextafter

nextafter, nextafterf---get next number

Synopsis

#include <math.h>
double nextafter(double val, double dir);
float nextafterf(float val, float dir);

Description
nextafter returns the double) precision floating point number closest to val in the direction toward dir. nextafterf performs the same operation in single precision. For example, nextafter(0.0,1.0) returns the smallest positive number which is representable in double precision.

Returns
Returns the next closest number to val in the direction toward dir.

Portability
Neither nextafter nor nextafterf is required by ANSI C or by the System V Interface Definition (Issue 2).


Cygnus C Math Library - pow

pow, powf---x to the power y

Synopsis

#include <math.h>
double pow(double x, double y);
float pow(float x, float y);

Description
pow and powf calculate x raised to the exp1.0nt y.

Returns
On success, pow and powf return the value calculated.

When the argument values would produce overflow, pow returns HUGE_VAL and set errno to ERANGE. If the argument x passed to pow or powf is a negative noninteger, and y is also not an integer, then errno is set to EDOM. If x and y are both 0, then pow and powf return 1.

You can modify error handling for these functions using matherr.

Portability
pow is ANSI C. powf is an extension.


Cygnus C Math Library - rint

rint, rintf, remainder, remainderf---round and remainder

Synopsis

#include <math.h>
double rint(double x);
float rintf(float x);
double remainder(double x, double y);
float remainderf(float x, float y);

Description
rint and rintf returns their argument rounded to the nearest integer. remainder and remainderf find the remainder of x/y; this value is in the range -y/2 .. +y/2.

Returns
rint and remainder return the integer result as a double.

Portability
rint and remainder are System V release 4. rintf and remainderf are extensions.


Cygnus C Math Library - scalbn

scalbn, scalbnf---scale by integer

Synopsis

#include <math.h>
double scalbn(double x, int y);
float scalbnf(float x, int y);

Description
scalbn and scalbnf scale x by n, returning x times 2 to the power n. The result is computed by manipulating the exponent, rather than by actually performing an exponentiation or multiplication.

Returns
x times 2 to the power n.

Portability
Neither scalbn nor scalbnf is required by ANSI C or by the System V Interface Definition (Issue 2).


Cygnus C Math Library - sqrt

sqrt, sqrtf---positive square root

Synopsis

#include <math.h>
double sqrt(double x);
float  sqrtf(float x);

Description
sqrt computes the positive square root of the argument. You can modify error handling for this function with matherr.

Returns
On success, the square root is returned. If x is real and positive, then the result is positive. If x is real and negative, the global value errno is set to EDOM (domain error).

Portability
sqrt is ANSI C. sqrtf is an extension.


Cygnus C Math Library - sin

sin, sinf, cos, cosf---sine or cosine

Synopsis

#include <math.h>
double sin(double x);
float  sinf(float x);
double cos(double x);
float cosf(float x);

Description
sin and cos compute (respectively) the sine and cosine of the argument x. Angles are specified in radians.

sinf and cosf are identical, save that they take and return float values.

Returns
The sine or cosine of x is returned.

Portability
sin and cos are ANSI C. sinf and cosf are extensions.


Cygnus C Math Library - sinh

sinh, sinhf---hyperbolic sine

Synopsis

#include <math.h>
double sinh(double x);
float  sinhf(float x);

Description
sinh computes the hyperbolic sine of the argument x. Angles are specified in radians. sinh(x) is defined as

sinhf is identical, save that it takes and returns float values.

Returns
The hyperbolic sine of x is returned.

When the correct result is too large to be representable (an overflow), sinh returns HUGE_VAL with the appropriate sign, and sets the global value errno to ERANGE.

You can modify error handling for these functions with matherr.

Portability
sinh is ANSI C. sinhf is an extension.


Cygnus C Math Library - tan

tan, tanf---tangent

Synopsis

#include <math.h>
double tan(double x);
float tanf(float x);

Description
tan computes the tangent of the argument x. Angles are specified in radians.

tanf is identical, save that it takes and returns float values.

Returns
The tangent of x is returned.

Portability
tan is ANSI. tanf is an extension.


Cygnus C Math Library - tanh

tanh, tanhf---hyperbolic tangent

Synopsis

#include <math.h>
double tanh(double x);
float tanhf(float x);

Description

tanh computes the hyperbolic tangent of the argument x. Angles are specified in radians.

tanh(x) is defined as

 sinh(x)/cosh(x)

tanhf is identical, save that it takes and returns float values.

Returns
The hyperbolic tangent of x is returned.

Portability
tanh is ANSI C. tanhf is an extension.


Cygnus C Math Library - Reentrancy

Reentrancy Properties of libm

When a libm function detects an exceptional case, errno may be set, the matherr function may be called, and a error message may be written to the standard error stream. This behavior may not be reentrant.

With reentrant C libraries like the Cygnus C library, errno is a macro which expands to the per-thread error value. This makes it thread safe.

When the user provides his own matherr function it must be reentrant for the math library as a whole to be reentrant.

In normal debugged programs, there are usually no math subroutine errors--and therefore no assignments to errno and no matherr calls; in that situation, the math functions behave reentrantly.


Cygnus C Math Library - Index

Index

Jump to: a - c - e - f - g - h - i - j - l - m - n - o - p - r - s - t - y

a

  • acos
  • acosf
  • acosh
  • acoshf
  • asin
  • asinf
  • asinh
  • asinhf
  • atan
  • atan2
  • atan2f
  • atanf
  • atanh
  • atanhf

    • c

  • cbrt
  • cbrtf
  • ceil
  • ceilf
  • copysign
  • copysignf
  • cos
  • cosf

    • e

  • erf
  • erfc
  • erfcf
  • erff
  • exp
  • expf
  • expm1
  • expm1f

    • f

  • fabs
  • fabsf
  • finite
  • finitef
  • floor
  • floorf
  • fmod
  • fmodf
  • frexp
  • frexpf

    • g

  • gamma
  • gamma_r
  • gammaf
  • gammaf_r

    • h

  • hypot
  • hypotf

    • i

  • ilogb
  • ilogbf
  • infinity
  • infinityf
  • isinf
  • isinff
  • isnan
  • isnanf

    • j

  • j0
  • j0f
  • j1
  • j1f
  • jn
  • jnf

    • l

  • ldexp
  • ldexpf
  • lgamma
  • lgamma_r
  • lgammaf
  • lgammaf_r
  • log
  • log10
  • log10f
  • log1p
  • log1pf
  • logf

    • m

  • matherr
  • matherr and reentrancy
  • modf
  • modff

    • n

  • nan
  • nanf
  • nextafter
  • nextafterf

    • o

  • OS stubs

    • p

  • pow
  • powf

    • r

  • reentrancy
  • remainder
  • remainderf
  • rint
  • rintf

    • s

  • scalbn
  • scalbnf
  • sin
  • sinf
  • sinh
  • sinhf
  • sqrt
  • sqrtf
  • stubs
  • support subroutines
  • system calls

    • t

  • tan
  • tanf
  • tanh
  • tanhf

    • y

  • y0
  • y0f
  • y1
  • y1f
  • yn
  • ynf

    • Go to the first, previous, next, last section, table of contents.


Embed with GNU - Libgloss

@raggedbottom @global@parindent=0pt

Copyright (C) 1993, 1994, 1995 Cygnus Support

Permission is granted to make and distribute verbatim copies of this manual provided the copyright notice and this permission notice are preserved on all copies.

Permission is granted to copy and distribute modified versions of this manual under the conditions for verbatim copying, provided also that the entire resulting derived work is distributed under the terms of a permission notice identical to this one.

Permission is granted to copy and distribute translations of this manual into another language, under the above conditions for modified versions.

Rough Draft

The goal of this document is to gather all the information needed to port the GNU tools to a new embedded target in one place. This will duplicate some info found in the other manual for the GNU tools, but this should be all you'll need.

Libgloss

Libgloss is a library for all the details that usually get glossed over. This library refers to things like startup code, and usually I/O support for gcc and C library. The C library used through out this manual is newlib. Newlib is a ANSI conforming C library developed by Cygnus Support. Libgloss could easily be made to support other C libraries, and it can be used standalone as well. The standalone configuration is typically used when bringing up new hardware, or on small systems.

For a long time, these details were part of newlib. This approach worked well when a complete tool chain only had to support one system. A tool chain refers to the series of compiler passes required to produce a binary file that will run on an embedded system. For C, the passes are cpp, gcc, gas, ld. Cpp is the preprocessor, which process all the header files and macros. Gcc is the compiler, which produces assembler from the processed C files. Gas assembles the code into object files, and then ld combines the object files and binds the code to addresses and produces the final executable image.

Most of the time a tool chain does only have to support one target execution environment. An example of this would be a tool chain for the AMD 29k processor family. All of the execution environments for this processor are have the same interface, the same memory map, and the same I/O code. In this case all of the support code is in newlib/sys/FIXME. Libgloss's creation was forced initially be the cpu32 processor family. There are many different execution environments for this line, and they vary wildly. newlib itself has only has a few dependencies that it needs for each target. These are explained later in this doc. The hardware dependent part of newlib was reorganized into a separate directory structure within newlib called the stub dirs. It was initially called this because most of the routines newlib needs for a target were simple stubs that do nothing, but return a value to the application. They only exist so the linker can produce a final executable image. This work was done during the early part of 1993.

After a while it became apparent that this approach of isolating the hardware and systems files together made sense. Around this same time the stub dirs were made to run standalone, mostly so it could also be used to support GDB's remote debugging needs. At this time it was decided to move the stub dirs out of newlib and into it's own separate library so it could be used standalone, and be included in various other GNU tools without having to bring in all of newlib, which is large. The new library is called Libgloss, for Gnu Low-level OS support.

Supported Targets

Currently libgloss is being used for the following targets:

Sparclite Targets Supported

This is for the Fujitsu Sparclite family of processors. Currently this covers the ex930, ex931, ex932, ex933, and the ex934. In addition to the I/O code a startup file, this has a GDB debug-stub that gets linked into your application. This is an exception handler style debug stub. For more info, see the section on Porting GDB. section Writing a new GDB backend.

The Fujitsu eval boards use a host based terminal program to load and execute programs on the target. This program, pciuh is relatively new (in 1994) and it replaced the previous ROM monitor which had the shell in the ROM. GDB uses the the GDB remote protocol, the relevant source files from the gdb sources are remote-sparcl.c. The debug stub is part of libgloss and is called sparcl-stub.c.

Motorola CPU32 Targets supported

This refers to Motorola's m68k based CPU32 processor family. The crt0.S startup file should be usable with any target environment, and it's mostly just the I/O code and linker scripts that vary. Currently there is support for the Motorola MVME line of 6U VME boards and IDP line of eval boards. All of the Motorola VME boards run Bug, a ROM based debug monitor. This monitor has the feature of using user level traps to do I/O, so this code should be portable to other MVME boards with little if any change. The startup file also can remain unchanged. About the only thing that varies is the address for where the text section begins. This can be accomplished either in the linker script, or on the command line using the `-Ttext [address]'.

There is also support for the rom68k monitor as shipped on Motorola's IDP eval board line. This code should be portable across the range of CPU's the board supports. There is also GDB support for this target environment in the GDB source tree. The relevant files are gdb/monitor.c, monitor.h, and rom58k-rom.c. The usage of these files is discussed in the GDB section.

Mips core Targets Supported

The Crt0 startup file should run on any mips target that doesn't require additional hardware initialization. The I/O code so far only supports a custom LSI33k based RAID disk controller board. It should easy to change to support the IDT line of eval boards. Currently the two debugging protocols supported by GDB for mips targets is IDT's mips debug protocol, and a customized hybrid of the standard GDB remote protocol and GDB's standard ROM monitor support. Included here is the debug stub for the hybrid monitor. This supports the LSI33k processor, and only has support for the GDB protocol commands g, G, m, M, which basically only supports the register and memory reading and writing commands. This is part of libgloss and is called lsi33k-stub.c.

The crt0.S should also work on the IDT line of eval boards, but has only been run on the LSI33k for now. There is no I/O support for the IDT eval board at this time. The current I/O code is for a customized version of LSI's pmon ROM monitor. This uses entry points into the monitor, and should easily port to other versions of the pmon monitor. Pmon is distributed in source by LSI.

PA-RISC Targets Supported

This supports the various boards manufactured by the HP-PRO consortium. This is a group of companies all making variations on the PA-RISC processor. Currently supported are ports to the WinBond `Cougar' board based around their w89k version of the PA. Also supported is the Oki op50n processor.

There is also included, but never built an unfinished port to the HP 743 board. This board is the main CPU board for the HP700 line of industrial computers. This target isn't exactly an embedded system, in fact it's really only designed to load and run HP-UX. Still, the crt0.S and I/O code are fully working. It is included mostly because their is a barely functioning exception handler GDB debug stub, and I hope somebody could use it. The other PRO targets all use GDB's ability to talk to ROM monitors directly, so it doesn't need a debug stub. There is also a utility that will produce a bootable file by HP's ROM monitor. This is all included in the hopes somebody else will finish it. :-)

Both the WinBond board and the Oki board download srecords. The WinBond board also has support for loading the SOM files as produced by the native compiler on HP-UX. WinBond supplies a set of DOS programs that will allow the loading of files via a bidirectional parallel port. This has never been tested with the output of GNU SOM, as this manual is mostly for Unix based systems.

Configuring and building libgloss.

Libgloss uses an autoconf based script to configure. Autoconf scripts are portable shell scripts that are generated from a configure.in file. Configure input scripts are based themselves on m4. Most configure scripts run a series of tests to determine features the various supported features of the target. For features that can't be determined by a feature test, a makefile fragment is merged in. The configure process leaves creates a Makefile in the build directory. For libgloss, there are only a few configure options of importance. These are --target and --srcdir.

Typically libgloss is built in a separate tree just for objects. In this manner, it's possible to have a single source tree, and multiple object trees. If you only need to configure for a single target environment, then you can configure in the source tree. The argument for --target is a config string. It's usually safest to use the full canonical opposed to the target alias. So, to configure for a CPU32 (m68k) with a separate source tree, use:

../src/libgloss/configure --verbose --target m68k-coff

The configure script is in the source tree. When configure is invoked it will determine it's own source tree, so the --srcdir is would be redundant here.

Once libgloss is configured, make is sufficient to build it. The default values for Makefiles are typically correct for all supported systems. The test cases in the testsuite will also built automatically as opposed to a make check, where test binaries aren't built till test time. This is mostly cause the libgloss testsuites are the last thing built when building the entire GNU source tree, so it's a good test of all the other compilation passes.

The default values for the Makefiles are set in the Makefile fragment merged in during configuration. This fragment typically has rules like

CC_FOR_TARGET = `if [ -f $${OBJROOT}/gcc/xgcc ] ; \
    then echo ${OBJROOT}/gcc/xgcc -B${OBJROOT}/gcc/ ; \
    else t='${program_transform_name}'; echo gcc | sed -e " $$t ; fi`

Basically this is a runtime test to determine whether there are freshly built executables for the other main passes of the GNU tools. If there isn't an executable built in the same object tree, then transformedthe generic tool name (like gcc) is transformed to the name typically used in GNU cross compilers. The names are typically based on the target's canonical name, so if you've configured for m68k-coff the transformed name is m68k-coff-gcc in this case. If you install with aliases or rename the tools, this won't work, and it will always look for tools in the path. You can force the a different name to work by reconfiguring with the --program-transform-name option to configure. This option takes a sed script like this -e s,^,m68k-coff-, which produces tools using the standard names (at least here at Cygnus).

The search for the other GNU development tools is exactly the same idea. This technique gets messier when build options like -msoft-float support are used. The Makefile fragments set the MUTILIB variable, and if it is set, the search path is modified. If the linking is done with an installed cross compiler, then none of this needs to be used. This is done so libgloss will build automatically with a fresh, and uninstalled object tree. It also makes it easier to debug the other tools using libgloss's test suites.


Embed with GNU - Porting GCC

Porting GCC

Porting GCC requires two things, neither of which has anything to do with GCC. If GCC already supports a processor type, then all the work in porting GCC is really a linker issue. All GCC has to do is produce assembler output in the proper syntax. Most of the work is done by the linker, which is described elsewhere.

Mostly all GCC does is format the command line for the linker pass. The command line for GCC is set in the various config subdirectories of gcc. The options of interest to us are CPP_SPEC and STARTFILE_SPEC. CPP_SPEC sets the builtin defines for your environment. If you support multiple environments with the same processor, then OS specific defines will need to be elsewhere.

STARTFILE_SPEC

Once you have linker support, GCC will be able to produce a fully linked executable image. The only part of GCC that the linker wants is a crt0.o, and a memory map. If you plan on running any programs that do I/O of any kind, you'll need to write support for the C library, which is described elsewhere.

Compilation passes

GCC by itself only compiles the C or C++ code into assembler. Typically GCC invokes all the passes required for you. These passes are cpp, cc1, gas, ld. cpp is the C preprocessor. This will merge in the include files, expand all macros definitions, and process all the #ifdef sections. To see the output of ccp, invoke gcc with the -E option, and the preprocessed file will be printed on the stdout. cc1 is the actual compiler pass that produces the assembler for the processed file. GCC is actually only a driver program for all the compiler passes. It will format command line options for the other passes. The usual command line GCC uses for the final link phase will have LD link in the startup code and additional libraries by default.

GNU AS started it's life to only function as a compiler pass, but these days it can also be used as a source level assembler. When used as a source level assembler, it has a companion assembler preprocessor called gasp. This has a syntax similar to most other assembler macros packages. GAS emits a relocatable object file from the assembler source. The object file contains the executable part of the application, and debug symbols.

LD is responsible for resolving the addresses and symbols to something that will be fully self-contained. Some RTOS's use relocatable object file formats like a.out, but more commonly the final image will only use absolute addresses for symbols. This enables code to be burned into PROMS as well. Although LD can produce an executable image, there is usually a hidden object file called crt0.o that is required as startup code. With this startup code and a memory map, the executable image will actually run on the target environment. section Crt0, the main startup file.

The startup code usually defines a special symbol like _start that is the default base address for the application, and the first symbol in the executable image. If you plan to use any routines from the standard C library, you'll also need to implement the functions that this library is dependent on. section Porting newlib.

Options for the various development tools are covered in more detail elsewhere. Still, the amount of options can be an overwhelming amount of stuff, so the options most suited to embedded systems are summarized here. If you use GCC as the main driver for all the passes, most of the linker options can be passed directly to the compiler. There are also GCC options that control how the GCC driver formats the command line arguments for the linker.

Most of the GCC options that we're interested control how the GCC driver formats the options for the linker pass.

-nostartfiles
-nostdlib
-Xlinker
Pass the next option directly to the linker.
-v
-fpic


Embed with GNU - Porting newlib

Porting newlib

Crt0, the main startup file

To make a program that has been compiled with GCC to run, you need to write some startup code. The initial piece of startup code is called a crt0. (C RunTime 0) This is usually written in assembler, and it's object gets linked in first, and bootstraps the rest of the application when executed. This file needs to do the following things.

  1. Initialize anything that needs it. This init section varies. If you are developing an application that gets download to a ROM monitor, then there is usually no need for any special initialization. The ROM monitor handles it for you. If you plan to burn your code in a ROM, then the crt0 typically has to do all the hardware initialization that is required to run an application. This can include things like initializing serial ports or run a memory check. It all depends on the hardware.
  2. Zero the BSS section. This is for uninitialized data. All the addresses in this section need to be initialized to zero so that programs that forget to check new variables default value will get unpredictable results.
  3. Call main() This is what basically starts things running. If your ROM monitor supports it, then first setup argc and argv for command line arguments and an environment pointer. Then branch to main(). For G++ the the main routine gets a branch to __main inserted by the code generator at the very top. __main() is used by G++ to initialize it's internal tables. __main() then returns back to your original main() and your code gets executed.
  4. Call exit() After main() has returned, you need to cleanup things and return control of the hardware from the application. On some hardware, there is nothing to return to, especially if your program is in ROM. Sometimes the best thing to do in this case is do a hardware reset, or branch back to the start address all over again. When there is a ROM monitor present, usually a user trap can be called and then the ROM takes over. Pick a safe vector with no side effects. Some ROMs have a builtin trap handler just for this case.

portable between all the m68k based boards we have here. section crt0.S - The startup file.

/* ANSI concatenation macros.  */

#define CONCAT1(a, b) CONCAT2(a, b)
#define CONCAT2(a, b) a ## b

These we'll use later.

/* These are predefined by new versions of GNU cpp.  */

#ifndef __USER_LABEL_PREFIX__
#define __USER_LABEL_PREFIX__ _
#endif

/* Use the right prefix for global labels.  */
#define SYM(x) CONCAT1 (__USER_LABEL_PREFIX__, x)

These macros are to make this code portable between both COFF and a.out. COFF always has an _ (underline) prepended on the front of all global symbol names. a.out has none.

#ifndef __REGISTER_PREFIX__
#define __REGISTER_PREFIX__
#endif

/* Use the right prefix for registers.  */
#define REG(x) CONCAT1 (__REGISTER_PREFIX__, x)

#define d0 REG (d0)
#define d1 REG (d1)
#define d2 REG (d2)
#define d3 REG (d3)
#define d4 REG (d4)
#define d5 REG (d5)
#define d6 REG (d6)
#define d7 REG (d7)
#define a0 REG (a0)
#define a1 REG (a1)
#define a2 REG (a2)
#define a3 REG (a3)
#define a4 REG (a4)
#define a5 REG (a5)
#define a6 REG (a6)
#define fp REG (fp)
#define sp REG (sp)

This is for portability between assemblers. Some register names have a % or $ prepended to the register name.

/*
 * Set up some room for a stack. We just grab a chunk of memory.
 */
    .set	stack_size, 0x2000
    .comm	SYM (stack), stack_size

Set up space for the stack. This can also be done in the linker script, but it typically gets done here.

/*
 * Define an empty environment.
 */
        .data
        .align 2
SYM (environ):
        .long 0

Set up an empty space for the environment. This is bogus on any most ROM monitor, but we setup a valid address for it, and pass it to main. At least that way if an application checks for it, it won't crash.

     .align	2
    .text
    .global SYM (stack)

    .global SYM (main)
    .global SYM (exit)
/*
 * This really should be __bss_start, not SYM (__bss_start).
 */
    .global __bss_start

Setup a few global symbols that get used elsewhere. __bss_start needs to be unchanged, as it's setup by the linker script.

/*
 * start -- set things up so the application will run.
 */
SYM (start):
    link	a6, #-8
    moveal	#SYM (stack) + stack_size, sp

/*
 * zerobss -- zero out the bss section
 */
    moveal	#__bss_start, a0
    moveal	#SYM (end), a1
1:
    movel	#0, (a0)
    leal	4(a0), a0
    cmpal	a0, a1
    bne	1b

The global symbol start is used by the linker as the default address to use for the .text section. then it zeros the .bss section so the uninitialized data will all be cleared. Some programs have wild side effects from having the .bss section let uncleared. Particularly it causes problems with some implementations of malloc.

/*
 * Call the main routine from the application to get it going.
 * main (argc, argv, environ)
 * We pass argv as a pointer to NULL.
 */
        pea     0
        pea     SYM (environ)
        pea     sp@(4)
        pea     0
    jsr	SYM (main)
    movel	d0, sp@-

Setup the environment pointer and jump to main(). When main() returns, it drops down to the exit routine below.

/*
 * _exit -- Exit from the application. Normally we cause a user trap
 *          to return to the ROM monitor for another run.
 */
SYM (exit):
    trap	#0

Implementing exit here is easy. Both the rom68k and bug can handle a user caused exception of zero with no side effects. Although the bug monitor has a user caused trap that will return control to the ROM monitor, this solution has been more portable.

Linker scripts for memory management

The linker script sets up the memory map of an application. It also sets up default values for variables used elsewhere by sbrk() and the crt0. These default variables are typically called _bss_start and _end.

For G++, the constructor and destructor tables must also be setup here. The actual section names vary depending on the object file format. For a.out and coff, the three main sections are .text, .data, and .bss.

Now that you have an image, you can test to make sure it got the memory map right. You can do this by having the linker create a memory map (by using the -Map option), or afterwards by using nm to check a few critical addresses like start, bss_end, and _etext.

Here's a breakdown of a linker script for a m68k based target board. See the file libgloss/m68k/idp.ld, or go to the appendixes in the end of the manual. section Linker script for the IDP board.

STARTUP(crt0.o)
OUTPUT_ARCH(m68k)
INPUT(idp.o)
SEARCH_DIR(.)
__DYNAMIC  =  0;

The STARTUP command loads the file specified so that it's first. In this case it also doubles to load the file as well, because the m68k-coff configuration defaults to not linking in the crt0.o by default. It assumes that the developer probably has their own crt0.o. This behavior is controlled in the config file for each architecture. It's a macro called STARTFILE_SPEC, and if it's set to null, then when gcc formats it's command line, it doesn't add crto.o. Any file name can be specified here, but the default is always crt0.o.

Course if you only use ld to link, then the control of whether or not to link in crt0.o is done on the command line. If you have multiple crto files, then you can leave this out all together, and link in the crt0.o in the makefile, or by having different linker scripts. Sometimes this is done for initializing floating point optionally, or to add device support.

The OUTPUT_ARCH sets architecture the output file is for.

INPUT loads in the file specified. In this case, it's a relocated library that contains the definitions for the low-level functions need by libc.a. This could have also been specified on the command line, but as it's always needed, it might as well be here as a default. SEARCH_DIR specifies the path to look for files, and _DYNAMIC means in this case there are no shared libraries.

/*
 * Setup the memory map of the MC68ec0x0 Board (IDP)
 * stack grows up towards high memory. This works for
 * both the rom68k and the mon68k monitors.
 */
MEMORY
{
  ram     : ORIGIN = 0x10000, LENGTH = 2M
}

This specifies a name for a section that can be referred to later in the script. In this case, it's only a pointer to the beginning of free RAM space, with an upper limit at 2M. If the output file exceeds the upper limit, it will produce an error message.

/*
 * stick everything in ram (of course)
 */
SECTIONS
{
  .text :
  {
    CREATE_OBJECT_SYMBOLS
    *(.text)
     etext  =  .;
     __CTOR_LIST__ = .;
     LONG((__CTOR_END__ - __CTOR_LIST__) / 4 - 2)
    *(.ctors)
     LONG(0)
     __CTOR_END__ = .;
     __DTOR_LIST__ = .;
     LONG((__DTOR_END__ - __DTOR_LIST__) / 4 - 2)
    *(.dtors)
     LONG(0)
     __DTOR_END__ = .;
    *(.lit)
    *(.shdata)
  }  > ram
  .shbss SIZEOF(.text) + ADDR(.text) :	{
    *(.shbss)
  }

Set up the .text section. In a COFF file, .text is where all the actual instructions are. This also sets up the CONTRUCTOR and the DESTRUCTOR tables for G++. Notice that the section description redirects itself to the ram variable setup earlier.

  .talias :	 { }  > ram
  .data  : {
    *(.data)
    CONSTRUCTORS
    _edata  =  .;
  } > ram

Setup the .data section. In a coff file, this is where all he initialized data goes. CONSTRUCTORS is a special command used by ld.

  .bss SIZEOF(.data) + ADDR(.data) :
  {
   __bss_start = ALIGN(0x8);
   *(.bss)
   *(COMMON)
      end = ALIGN(0x8);
      _end = ALIGN(0x8);
      __end = ALIGN(0x8);
  }
  .mstack  : { }  > ram
  .rstack  : { }  > ram
  .stab  . (NOLOAD) :
  {
    [ .stab ]
  }
  .stabstr  . (NOLOAD) :
  {
    [ .stabstr ]
  }
}

Setup the .bss section. In a COFF file, this is where unitialized data goes. The symbols _bss_start and _end are setup here for use by the crt0.o when it zero's the .bss section.

What to do when you have a binary image

A few ROM monitors load binary images, typically a.out, but most all will load an srecord. An srecord is an ASCII representation of a binary image. At it's simplest, an srecord is an address, followed by a byte count, followed by the bytes, and a 2's compliment checksum. A whole srecord file has an optional start record, and a required end record. To make an srecord from a binary image, the GNU objcopy program is used. This will read the image and make an srecord from it. To do this, invoke objcopy like this: objcopy -O srec infile outfile. Most PROM burners also read srecords or a similar format. Use objdump -i to get a list of support object files types for your architecture.

Libraries

This describes newlib, a freely available libc replacement. Most applications use calls in the standard C library. When initially linking in libc.a, several I/O functions are undefined. If you don't plan on doing any I/O, then you're OK, otherwise they need to be created. These routines are read, write, open, close. sbrk, and kill. Open & close don't need to be fully supported unless you have a filesystems, so typically they are stubbed out. Kill is also a stub, since you can't do process control on an embedded system.

Sbrk() is only needed by applications that do dynamic memory allocation. It's uses the symbol _end that is setup in the linker script. It also requires a compile time option to set the upper size limit on the heap space. This leaves us with read and write, which are required for serial I/O. Usually these two routines are written in C, and call a lower level function for the actual I/O operation. These two lowest level I/O primitives are inbyte() and outbyte(), and are also used by GDB back ends if you've written an exception handler. Some systems also implement a havebyte() for input as well.

Other commonly included functions are routines for manipulating LED's on the target (if they exist) or low level debug help. Typically a putnum() for printing words and bytes as a hex number is helpful, as well as a low-level print() to output simple strings.

As libg++ uses the I/O routines in libc.a, if read and write work, then libg++ will also work with no additional changes.

Making I/O work

Routines for dynamic memory allocation

To support using any of the memory functions, you need to implement sbrk(). malloc(), calloc(), and realloc() all call sbrk() at there lowest level. caddr_t is defined elsewhere as char *. RAMSIZE is presently a compile time option. All this does is move a pointer to heap memory and check for the upper limit. section C based "glue" code.. sbrk() returns a pointer to the previous value before more memory was allocated.

/* _end is set in the linker command file *
extern caddr_t _end;/

/* just in case, most boards have at least some memory */
#ifndef RAMSIZE
#  define RAMSIZE             (caddr_t)0x100000
#endif

/*
 * sbrk -- changes heap size size. Get nbytes more
 *         RAM. We just increment a pointer in what's
 *         left of memory on the board.
 */
caddr_t
sbrk(nbytes)
     int nbytes;
{
  static caddr_t heap_ptr = NULL;
  caddr_t        base;

  if (heap_ptr == NULL) {
    heap_ptr = (caddr_t)&_end;
  }

  if ((RAMSIZE - heap_ptr) >= 0) {
    base = heap_ptr;
    heap_ptr += nbytes;
    return (base);
  } else {
    errno = ENOMEM;
    return ((caddr_t)-1);
  }
}

Misc support routines

These are called by newlib but don't apply to the embedded environment. isatty() is self explanatory. kill() doesn't apply either in an environment withno process control, so it justs exits, which is a similar enough behavior. getpid() can safely return any value greater than 1. The value doesn't effect anything in newlib because once again there is no process control.

/*
 * isatty -- returns 1 if connected to a terminal device,
 *           returns 0 if not. Since we're hooked up to a
 *           serial port, we'll say yes and return a 1.
 */
int
isatty(fd)
     int fd;
{
  return (1);
}

/*
 * getpid -- only one process, so just return 1.
 */
#define __MYPID 1
int
getpid()
{
  return __MYPID;
}

/*
 * kill -- go out via exit...
 */
int
kill(pid, sig)
     int pid;
     int sig;
{
  if(pid == __MYPID)
    _exit(sig);
  return 0;
}

Useful debugging functions

There are always a few useful functions for debugging your project in progress. I typically implement a simple print() routine that runs standalone in liblgoss, with no newlib support. The I/O function outbyte() can also be used for low level debugging. Many times print will work when there are problems that cause printf() to cause an exception. putnum() is just to print out values in hex so they are easier to read.

/*
 * print -- do a raw print of a string
 */
int
print(ptr)
char *ptr;
{
  while (*ptr) {
    outbyte (*ptr++);
  }
}

/*
 * putnum -- print a 32 bit number in hex
 */
int
putnum (num)
unsigned int num;
{
  char  buffer[9];
  int   count;
  char  *bufptr = buffer;
  int   digit;

  for (count = 7 ; count >= 0 ; count--) {
    digit = (num >> (count * 4)) & 0xf;

    if (digit <= 9)
      *bufptr++ = (char) ('0' + digit);
    else
      *bufptr++ = (char) ('a' - 10 + digit);
  }

  *bufptr = (char) 0;
  print (buffer);
  return;
}

If there are LEDs on the board, they can also be put to use for debugging when the serial I/O code is being written. I usually implement a zylons() function, which strobes the LEDS (if there is more than one) in sequence, creating a rotating effect. This is convenient between I/O to see if the target is still alive. Another useful LED function is led_putnum(), which takes a digit and displays it as a bit pattern or number. These usually have to be written in assembler for each target board. Here are a number of C based routines that may be useful.

led_putnum() puts a number on a single digit segmented LED display. This LED is set by setting a bit mask to an address, where 1 turns the segment off, and 0 turns it on. There is also a little decimal point on the LED display, so it gets the leftmost bit. The other bits specify the segment location. The bits look like:

        [d.p | g | f | e | d | c | b | a ] is the byte.

The locations are set up as:

             a
           -----
        f |     | b
          |  g  |
           -----
          |     |
        e |     | c
           -----
             d

This takes a number that's already been converted to a string, and prints it.

#define LED_ADDR	0xd00003

void
led_putnum ( num )
char num;
{
    static unsigned char *leds = (unsigned char *)LED_ADDR;
    static unsigned char num_bits [18] = {
      0xff,						/* clear all */
      0xc0, 0xf9, 0xa4, 0xb0, 0x99, 0x92, 0x82, 0xf8, 0x80, 0x98, /* numbers 0-9 */
      0x98, 0x20, 0x3, 0x27, 0x21, 0x4, 0xe 		/* letters a-f */
    };

    if (num >= '0' && num <= '9')
      num = (num - '0') + 1;

    if (num >= 'a' && num <= 'f')
      num = (num - 'a') + 12;

    if (num == ' ')
      num = 0;

    *leds = num_bits[num];
}

/*
 * zylons -- draw a rotating pattern. NOTE: this function never returns.
 */
void
zylons()
{
  unsigned char *leds 	= (unsigned char *)LED_ADDR;
  unsigned char curled = 0xfe;

  while (1)
    {
      *leds = curled;
      curled = (curled >> 1) | (curled << 7);
      delay ( 200 );
    }
}


Embed with GNU - Writing a new GDB backend

Writing a new GDB backend

Typically, either the low-level I/O routines are used for debugging, or LEDs, if present. It is much easier to use GDb for debugging an application. There are several different techniques used to have GDB work remotely. Commonly more than one kind of GDB interface is used to cober a wide variety of development needs.

The most common style of GDB backend is an exception handler for breakpoints. This is also called a gdb stub, and is requires the two additional lines of init code in your main() routine. The GDB stubs all use the GDB remote protocol. When the application gets a breakpoint exception, it communicates to GDB on the host.

Another common style of interfacing GDB to a target is by using an existing ROM monitor. These break down into two main kinds, a similar protocol to the GDB remote protocol, and an interface that uses the ROM monitor directly. This kind has GDB simulating a human operator, and all GDB does is work as a command formatter and parser.

The standard remote protocol

The standard remote protocol is a simple, packet based scheme. A debug packet whose contents are <data> is encapsulated for transmission in the form:

    $ <data> # CSUM1 CSUM2

<data> must be ASCII alphanumeric and cannot include characters $ or #. If <data> starts with two characters followed by :, then the existing stubs interpret this as a sequence number. For example, the command g is used to read the values of the registers. So, a packet to do this would look like

        $g#67

CSUM1 and CSUM2 are an ascii representation in hex of an 8-bit checksum of <data>, the most significant nibble is sent first. the hex digits 0-9,a-f are used.

A simple protocol is used when communicating with the target. This is mainly to give a degree of error handling over the serial cable. For each packet transmitted successfully, the target responds with a + (ACK). If there was a transmission error, then the target responds with a - (NAK). An error is determined when the checksum doesn't match the calculated checksum for that data record. Upon reciept of the ACK, GDB can then transmit the next packet.

Here is a list of the main functions that need to be supported. Each data packet is a command with a set number of bytes in the command packet. Most commands either return data, or respond with a NAK. Commands that don't return data respond with an ACK. All data values are ascii hex digits. Every byte needs two hex digits to represent t. This means that a byte with the value `7' becomes `07'. On a 32 bit machine this works out to 8 characters per word. All of the bytes in a word are stored in the target byte order. When writing the host side of the GDB protocol, be careful of byte order, and make sure that the code will run on both big and little endian hosts and produce the same answers.

These functions are the minimum required to make a GDB backend work. All other commands are optional, and not supported by all GDB backends.

`read registers g'
returns XXXXXXXX... Registers are in the internal order for GDB, and the bytes in a register are in the same order the machine uses. All values are in sequence starting with register 0. All registers are listed in the same packet. A sample packet would look like $g#.
`write registers GXXXXXXXX...'
XXXXXXXX is the value to set the register to. Registers are in the internal order for GDB, and the bytes in a register are in the same order the machine uses. All values are in sequence starting with register 0. All registers values are listed in the same packet. A sample packet would look like $G000000001111111122222222...# returns ACK or NAK
`read memory mAAAAAAAA,LLLL'
AAAAAAAA is address, LLLL is length. A sample packet would look like $m00005556,0024#. This would request 24 bytes starting at address 00005556 returns XXXXXXXX... XXXXXXXX is the memory contents. Fewer bytes than requested will be returned if only part of the data can be read. This can be determined by counting the values till the end of packet # is seen and comparing that with the total count of bytes that was requested.
`write memory MAAAAAAAA,LLLL:XXXXXXXX'
AAAAAAAA is the starting address, LLLL is the number of bytes to be written, and XXXXXXXX is value to be written. A sample packet would look like $M00005556,0024:101010101111111100000000...# returns ACK or NAK for an error. NAK is also returned when only part of the data is written.
`continue cAAAAAAAAA'
AAAAAAAA is address to resume execution at. If AAAAAAAA is omitted, resume at the curent address of the pc register. returns the same replay as last signal. There is no immediate replay to cont until the next breakpoint is reached, and the program stops executing.
`step sAA..AA'
AA..AA is address to resume If AA..AA is omitted, resume at same address. returns the same replay as last signal. There is no immediate replay to step until the next breakpoint is reached, and the program stops executing.
`last signal ?'
This returns one of the following:
  • SAA Where AA is the number of the last signal. Exceptions on the target are converted to the most similar Unix style signal number, like SIGSEGV. A sample response of this type would look like $S05#.
  • TAAnn:XXXXXXXX;nn:XXXXXXXX;nn:XXXXXXXX; AA is the signal number. nn is the register number. XXXXXXXX is the register value.
  • WAA The process exited, and AA is the exit status. This is only applicable for certains sorts of targets.
These are used in some GDB backends, but not all.
`write reg Pnn=XXXXXXXX'
Write register nn with value XXXXXXXX. returns ACK or NAK
`kill request k'
`toggle debug d'
toggle debug flag (see 386 & 68k stubs)
`reset r'
reset -- see sparc stub.
`reserved other'
On other requests, the stub should ignore the request and send an empty response $#<checksum>. This way we can extend the protocol and GDB can tell whether the stub it is talking to uses the old or the new.
`search tAA:PP,MM'
Search backwards starting at address AA for a match with pattern PP and mask MM. PP and MM are 4 bytes.
`general query qXXXX'
Request info about XXXX.
`general set QXXXX=yyyy'
Set value of XXXX to yyyy.
`query sect offs qOffsets'
Get section offsets. Reply is Text=xxx;Data=yyy;Bss=zzz
`console output Otext'
Send text to stdout. The text gets display from the target side of the serial connection.

Responses can be run-length encoded to save space. A *means that the next character is an ASCII encoding giving a repeat count which stands for that many repetitions of the character preceding the *. The encoding is n+29, yielding a printable character where n >=3 (which is where run length encoding starts to win). You can't use a value of where n >126 because it's only a two byte value. An example would be a 0*03 means the same thing as 0000.

A linked in exception handler

A GDB stub consists of two parts, support for the exception handler, and the exception handler itself. The exception handler needs to communicate to GDB on the host whenever there is a breakpoint exception. When GDB starts a program running on the target, it's polling the serial port during execution looking for any debug packets. So when a breakpoint occurs, the exception handler needs to save state, and send a GDB remote protocol packet to GDB on the host. GDB takes any output that isn't a debug command packet and displays it in the command window.

Support for the exception handler varies between processors, but the minimum supported functions are those needed by GDB. These are functions to support the reading and writing of registers, the reading and writing of memory, start execution at an address, single step, and last signal. Sometimes other functions for adjusting the baud rate, or resetting the hardware are implemented.

Once GDB gets the command packet from the breakpoint, it will read a few registers and memory locations an then wait for the user. When the user types run or continue a continue command is issued to the backend, and control returns from the breakpoint routine to the application.

Using a ROM monitor as a backend

GDB also can mimic a human user and use a ROM monitors normal debug commands as a backend. This consists mostly of sending and parsing ASCII strings. All the ROM monitor interfaces share a common set of routines in gdb/monitor.c. This supports adding new ROM monitor interfaces by filling in a structure with the common commands GDB needs. GDb already supports several command ROM monitors, including Motorola's Bug monitor for their VME boards, and the Rom68k monitor by Integrated Systems, Inc. for various m68k based boards. GDB also supports the custom ROM monitors on the WinBond and Oki PA based targets. There is builtin support for loading files to ROM monitors specifically. GDB can convert a binary into an srecord and then load it as an ascii file, or using xmodem.

Adding support for new protocols

Go to the first, previous, next, last section, table of contents.


Embed with GNU - Code Listings

Code Listings

Linker script for the IDP board

This is the linker script script that is used on the Motorola IDP board.

STARTUP(crt0.o)
OUTPUT_ARCH(m68k)
INPUT(idp.o)
SEARCH_DIR(.)
__DYNAMIC  =  0;
/*
 * Setup the memory map of the MC68ec0x0 Board (IDP)
 * stack grows up towards high memory. This works for
 * both the rom68k and the mon68k monitors.
 */
MEMORY
{
  ram     : ORIGIN = 0x10000, LENGTH = 2M
}
/*
 * stick everything in ram (of course)
 */
SECTIONS
{
  .text :
  {
    CREATE_OBJECT_SYMBOLS
    *(.text)
     etext  =  .;
     __CTOR_LIST__ = .;
     LONG((__CTOR_END__ - __CTOR_LIST__) / 4 - 2)
    *(.ctors)
     LONG(0)
     __CTOR_END__ = .;
     __DTOR_LIST__ = .;
     LONG((__DTOR_END__ - __DTOR_LIST__) / 4 - 2)
    *(.dtors)
     LONG(0)
     __DTOR_END__ = .;
    *(.lit)
    *(.shdata)
  }  > ram
  .shbss SIZEOF(.text) + ADDR(.text) :	{
    *(.shbss)
  }
  .talias :	 { }  > ram
  .data  : {
    *(.data)
    CONSTRUCTORS
    _edata  =  .;
  } > ram

  .bss SIZEOF(.data) + ADDR(.data) :
  {
   __bss_start = ALIGN(0x8);
   *(.bss)
   *(COMMON)
      end = ALIGN(0x8);
      _end = ALIGN(0x8);
      __end = ALIGN(0x8);
  }
  .mstack  : { }  > ram
  .rstack  : { }  > ram
  .stab  . (NOLOAD) :
  {
    [ .stab ]
  }
  .stabstr  . (NOLOAD) :
  {
    [ .stabstr ]
  }
}

crt0.S - The startup file

/*
 * crt0.S -- startup file for m68k-coff
 *
 */

    .title "crt0.S for m68k-coff"

/* These are predefined by new versions of GNU cpp.  */

#ifndef __USER_LABEL_PREFIX__
#define __USER_LABEL_PREFIX__ _
#endif

#ifndef __REGISTER_PREFIX__
#define __REGISTER_PREFIX__
#endif

/* ANSI concatenation macros.  */

#define CONCAT1(a, b) CONCAT2(a, b)
#define CONCAT2(a, b) a ## b

/* Use the right prefix for global labels.  */

#define SYM(x) CONCAT1 (__USER_LABEL_PREFIX__, x)

/* Use the right prefix for registers.  */

#define REG(x) CONCAT1 (__REGISTER_PREFIX__, x)

#define d0 REG (d0)
#define d1 REG (d1)
#define d2 REG (d2)
#define d3 REG (d3)
#define d4 REG (d4)
#define d5 REG (d5)
#define d6 REG (d6)
#define d7 REG (d7)
#define a0 REG (a0)
#define a1 REG (a1)
#define a2 REG (a2)
#define a3 REG (a3)
#define a4 REG (a4)
#define a5 REG (a5)
#define a6 REG (a6)
#define fp REG (fp)
#define sp REG (sp)

/*
 * Set up some room for a stack. We just grab a chunk of memory.
 */
    .set	stack_size, 0x2000
    .comm	SYM (stack), stack_size

/*
 * Define an empty environment.
 */
        .data
        .align 2
SYM (environ):
        .long 0

     .align	2
    .text
    .global SYM (stack)

    .global SYM (main)
    .global SYM (exit)
/*
 * This really should be __bss_start, not SYM (__bss_start).
 */
    .global __bss_start

/*
 * start -- set things up so the application will run.
 */
SYM (start):
    link	a6, #-8
    moveal	#SYM (stack) + stack_size, sp

/*
 * zerobss -- zero out the bss section
 */
    moveal	#__bss_start, a0
    moveal	#SYM (end), a1
1:
    movel	#0, (a0)
    leal	4(a0), a0
    cmpal	a0, a1
    bne	1b

/*
 * Call the main routine from the application to get it going.
 * main (argc, argv, environ)
 * We pass argv as a pointer to NULL.
 */
        pea     0
        pea     SYM (environ)
        pea     sp@(4)
        pea     0
    jsr	SYM (main)
    movel	d0, sp@-

/*
 * _exit -- Exit from the application. Normally we cause a user trap
 *          to return to the ROM monitor for another run.
 */
SYM (exit):
    trap	#0

C based "glue" code.

/*
 * glue.c -- all the code to make GCC and the libraries run on
 *           a bare target board. These should work with any
 *           target if inbyte() and outbyte() exist.
 */

#include <sys/types.h>
#include <sys/stat.h>
#include <errno.h>
#ifndef NULL
#define NULL 0
#endif

/* FIXME: this is a hack till libc builds */
__main()
{
  return;
}

#undef errno
int errno;

extern caddr_t _end;                /* _end is set in the linker command file */
extern int outbyte();
extern unsigned char inbyte();
extern int havebyte();

/* just in case, most boards have at least some memory */
#ifndef RAMSIZE
#  define RAMSIZE             (caddr_t)0x100000
#endif

/*
 * read  -- read bytes from the serial port. Ignore fd, since
 *          we only have stdin.
 */
int
read(fd, buf, nbytes)
     int fd;
     char *buf;
     int nbytes;
{
  int i = 0;

  for (i = 0; i < nbytes; i++) {
    *(buf + i) = inbyte();
    if ((*(buf + i) == '\n') || (*(buf + i) == '\r')) {
      (*(buf + i)) = 0;
      break;
    }
  }
  return (i);
}

/*
 * write -- write bytes to the serial port. Ignore fd, since
 *          stdout and stderr are the same. Since we have no filesystem,
 *          open will only return an error.
 */
int
write(fd, buf, nbytes)
     int fd;
     char *buf;
     int nbytes;
{
  int i;

  for (i = 0; i < nbytes; i++) {
    if (*(buf + i) == '\n') {
      outbyte ('\r');
    }
    outbyte (*(buf + i));
  }
  return (nbytes);
}

/*
 * open -- open a file descriptor. We don't have a filesystem, so
 *         we return an error.
 */
int
open(buf, flags, mode)
     char *buf;
     int flags;
     int mode;
{
  errno = EIO;
  return (-1);
}

/*
 * close -- close a file descriptor. We don't need
 *          to do anything, but pretend we did.
 */
int
close(fd)
     int fd;
{
  return (0);
}

/*
 * sbrk -- changes heap size size. Get nbytes more
 *         RAM. We just increment a pointer in what's
 *         left of memory on the board.
 */
caddr_t
sbrk(nbytes)
     int nbytes;
{
  static caddr_t heap_ptr = NULL;
  caddr_t        base;

  if (heap_ptr == NULL) {
    heap_ptr = (caddr_t)&_end;
  }

  if ((RAMSIZE - heap_ptr) >= 0) {
    base = heap_ptr;
    heap_ptr += nbytes;
    return (base);
  } else {
    errno = ENOMEM;
    return ((caddr_t)-1);
  }
}

/*
 * isatty -- returns 1 if connected to a terminal device,
 *           returns 0 if not. Since we're hooked up to a
 *           serial port, we'll say yes and return a 1.
 */
int
isatty(fd)
     int fd;
{
  return (1);
}

/*
 * lseek -- move read/write pointer. Since a serial port
 *          is non-seekable, we return an error.
 */
off_t
lseek(fd,  offset, whence)
     int fd;
     off_t offset;
     int whence;
{
  errno = ESPIPE;
  return ((off_t)-1);
}

/*
 * fstat -- get status of a file. Since we have no file
 *          system, we just return an error.
 */
int
fstat(fd, buf)
     int fd;
     struct stat *buf;
{
  errno = EIO;
  return (-1);
}

/*
 * getpid -- only one process, so just return 1.
 */
#define __MYPID 1
int
getpid()
{
  return __MYPID;
}

/*
 * kill -- go out via exit...
 */
int
kill(pid, sig)
     int pid;
     int sig;
{
  if(pid == __MYPID)
    _exit(sig);
  return 0;
}

/*
 * print -- do a raw print of a string
 */
int
print(ptr)
char *ptr;
{
  while (*ptr) {
    outbyte (*ptr++);
  }
}

/*
 * putnum -- print a 32 bit number in hex
 */
int
putnum (num)
unsigned int num;
{
  char  buffer[9];
  int   count;
  char  *bufptr = buffer;
  int   digit;

  for (count = 7 ; count >= 0 ; count--) {
    digit = (num >> (count * 4)) & 0xf;

    if (digit <= 9)
      *bufptr++ = (char) ('0' + digit);
    else
      *bufptr++ = (char) ('a' - 10 + digit);
  }

  *bufptr = (char) 0;
  print (buffer);
  return;
}

I/O assembler code sample

/*
 * mvme.S -- board support for m68k
 */

    .title "mvme.S for m68k-coff"

/* These are predefined by new versions of GNU cpp.  */

#ifndef __USER_LABEL_PREFIX__
#define __USER_LABEL_PREFIX__ _
#endif

#ifndef __REGISTER_PREFIX__
#define __REGISTER_PREFIX__
#endif

/* ANSI concatenation macros.  */

#define CONCAT1(a, b) CONCAT2(a, b)
#define CONCAT2(a, b) a ## b

/* Use the right prefix for global labels.  */

#define SYM(x) CONCAT1 (__USER_LABEL_PREFIX__, x)

/* Use the right prefix for registers.  */

#define REG(x) CONCAT1 (__REGISTER_PREFIX__, x)

#define d0 REG (d0)
#define d1 REG (d1)
#define d2 REG (d2)
#define d3 REG (d3)
#define d4 REG (d4)
#define d5 REG (d5)
#define d6 REG (d6)
#define d7 REG (d7)
#define a0 REG (a0)
#define a1 REG (a1)
#define a2 REG (a2)
#define a3 REG (a3)
#define a4 REG (a4)
#define a5 REG (a5)
#define a6 REG (a6)
#define fp REG (fp)
#define sp REG (sp)
#define vbr REG (vbr)

    .align	2
    .text
    .global SYM (_exit)
    .global SYM (outln)
    .global SYM (outbyte)
    .global SYM (putDebugChar)
    .global SYM (inbyte)
    .global SYM (getDebugChar)
    .global SYM (havebyte)
    .global SYM (exceptionHandler)

    .set	vbr_size, 0x400
    .comm	SYM (vbr_table), vbr_size

/*
 * inbyte -- get a byte from the serial port
 *	d0 - contains the byte read in
 */
    .align	2
SYM (getDebugChar):		/* symbol name used by m68k-stub */
SYM (inbyte):
    link	a6, #-8
    trap 	#15
    .word	inchr
    moveb 	sp@, d0
    extbl	d0
    unlk	a6
    rts

/*
 * outbyte -- sends a byte out the serial port
 *	d0 - contains the byte to be sent
 */
    .align	2
SYM (putDebugChar):		/* symbol name used by m68k-stub */
SYM (outbyte):
    link	fp, #-4
     moveb	fp@(11), sp@
    trap 	#15
    .word	outchr
    unlk	fp
    rts

/*
 * outln -- sends a string of bytes out the serial port with a CR/LF
 *	a0 - contains the address of the string's first byte
 *	a1 - contains the address of the string's last byte
 */
    .align	2
SYM (outln):
    link	a6, #-8
    moveml	a0/a1, sp@
    trap 	#15
    .word 	outln
    unlk	a6
    rts

/*
 * outstr -- sends a string of bytes out the serial port without a CR/LF
 *	a0 - contains the address of the string's first byte
 *	a1 - contains the address of the string's last byte
 */
    .align	2
SYM (outstr):
    link	a6, #-8
    moveml	a0/a1, sp@
    trap 	#15
    .word 	outstr
    unlk	a6
    rts

/*
 * havebyte -- checks to see if there is a byte in the serial port,
 *	     returns 1 if there is a byte, 0 otherwise.
 */
SYM (havebyte):
    trap 	#15
    .word	instat
    beqs	empty
    movel 	#1, d0
    rts
empty:
    movel	#0, d0
    rts

/*
 * These constants are for the MVME-135 board's boot monitor. They
 * are used with a TRAP #15 call to access the monitor's I/O routines.
 * they must be in the word following the trap call.
 */
    .set inchr, 0x0
    .set instat, 0x1
    .set inln, 0x2
    .set readstr, 0x3
    .set readln, 0x4
    .set chkbrk, 0x5

    .set outchr, 0x20
    .set outstr, 0x21
    .set outln, 0x22
    .set write, 0x23
    .set writeln, 0x24
    .set writdln, 0x25
    .set pcrlf, 0x26
    .set eraseln, 0x27
    .set writd, 0x28
    .set sndbrk, 0x29

    .set tm_ini, 0x40
    .set dt_ini, 0x42
    .set tm_disp, 0x43
    .set tm_rd, 0x44

    .set redir, 0x60
    .set redir_i, 0x61
    .set redir_o, 0x62
    .set return, 0x63
    .set bindec, 0x64

    .set changev, 0x67
    .set strcmp, 0x68
    .set mulu32, 0x69
    .set divu32, 0x6A
    .set chk_sum, 0x6B

I/O code sample

#include "w89k.h"

/*
 * outbyte -- shove a byte out the serial port. We wait till the byte
 */
int
outbyte(byte)
     unsigned char byte;
{
  while ((inp(RS232REG) & TRANSMIT) == 0x0) {  } ;
  return (outp(RS232PORT, byte));
}

/*
 * inbyte -- get a byte from the serial port
 */
unsigned char
inbyte()
{
  while ((inp(RS232REG) & RECEIVE) == 0x0) { };
  return (inp(RS232PORT));
}

Led control sample

/*
 * leds.h -- control the led's on a Motorola mc68ec0x0 board.
 */

#ifndef __LEDS_H__
#define __LEDS_H__

#define LED_ADDR	0xd00003
#define LED_0           ~0x1
#define LED_1           ~0x2
#define LED_2           ~0x4
#define LED_3           ~0x8
#define LED_4           ~0x10
#define LED_5           ~0x20
#define LED_6           ~0x40
#define LED_7           ~0x80
#define LEDS_OFF	0xff
#define LEDS_ON		0x0

#define FUDGE(x) ((x >= 0xa && x <= 0xf) ? (x + 'a') & 0x7f : (x + '0') & 0x7f)

extern void led_putnum( char );

#endif		/* __LEDS_H__ */

/*
 * leds.c -- control the led's on a Motorola mc68ec0x0 (IDP)board.
 */
#include "leds.h"

void zylons();
void led_putnum();

/*
 * led_putnum -- print a hex number on the LED. the value of num must be a char with
 *              the ascii value. ie... number 0 is '0', a is 'a', ' ' (null) clears
 *		the led display.
 *		Setting the bit to 0 turns it on, 1 turns it off.
 * 		the LED's are controlled by setting the right bit mask in the base
 * 		address.
 *		The bits are:
 *			[d.p | g | f | e | d | c | b | a ] is the byte.
 *
 *		The locations are:
 *
 *			 a
 *		       -----
 *		    f |     | b
 *		      |  g  |
 *		       -----
 *                    |     |
 *                  e |     | c
 *                     -----
 *                       d                . d.p (decimal point)
 */
void
led_putnum ( num )
char num;
{
    static unsigned char *leds = (unsigned char *)LED_ADDR;
    static unsigned char num_bits [18] = {
      0xff,						/* clear all */
      0xc0, 0xf9, 0xa4, 0xb0, 0x99, 0x92, 0x82, 0xf8, 0x80, 0x98, /* numbers 0-9 */
      0x98, 0x20, 0x3, 0x27, 0x21, 0x4, 0xe 		/* letters a-f */
    };

    if (num >= '0' && num <= '9')
      num = (num - '0') + 1;

    if (num >= 'a' && num <= 'f')
      num = (num - 'a') + 12;

    if (num == ' ')
      num = 0;

    *leds = num_bits[num];
}

/*
 * zylons -- draw a rotating pattern. NOTE: this function never returns.
 */
void
zylons()
{
  unsigned char *leds 	= (unsigned char *)LED_ADDR;
  unsigned char curled = 0xfe;

  while (1)
    {
      *leds = curled;
      curled = (curled >> 1) | (curled << 7);
      delay ( 200 );
    }
}